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The KVM and Serial Access Clients User Guide was formerly called the 
MPC and RRC User Guide. The previous version of the guide contained 
only information about MPC and RRC. This new iteration of the guide 
contains MPC and RRC information, but now also contains Raritan Serial 
Client information and Virtual KVM Client information. 

In addition to the overall guide contents, the following sections have 
changed or information has been added to the user guide based on 
enhancements and changes to the application and/or user 
documentation.  

MPC and RRC 

• Keyboard Limitations (on page 101) - information on known 
keyboard limitations for Hungarian and Japanese keyboards has 
been added to the guide. 

MPC 

• Connected Server Toolbar (see "Connected Server(s) Toolbar" on 
page 80) - MPC now allows users to view the Connected Sever 
Toolbar in full screen mode, as well as return to the standard view 
using a Close button (see MPC Target Screen Resolution Mode (on 
page 84)). 

• Installing MPC for Linux (on page 37) - information on creating a 
desktop shortcut when installing MPC on a Linux machine is noted 
in this section. 

Please see the Release Notes for a more detailed explanation of the 
changes applied to this version of the application. 
 

What's New in the User Guide 
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Raritan Multi-Platform Client (MPC), Raritan Remote Client (RRC), and 
the Virtual KVM Client (VKC) are graphical user interfaces for the 
Raritan Dominion and IP-Reach product lines, providing remote access 
to target servers connected to Raritan KVM over IP devices.  

By default, generation 2 Raritan devices use VKC. However, generation 2 
devices will not work using RRC. Non-Windows users must use Raritan 
Multi-Platform Client and Windows® users connecting to a generation 1 
Raritan device must use RRC. 

The standalone Raritan Serial Client (RSC) is used to make direct 
connections to a serial target without going through the  application. The 
user specifies the  address and the port number (target), and is then 
connected. 

In This Chapter 
Use with Raritan Products ........................................................................... 1 
 
 

Use with Raritan Products 

The following table lists Raritan products and the applications with 
which they work: 

Works with... Product 

 
MPC RRC VKC RSC 

KX 1 G1     

KX II G2     

KX II 101     

KX 101 G1     

KSX G1     

KSX II G2     

SX     

IP Reach G1     

UST-IP G1     

Chapter 1 Introduction
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Legend: 

G1 Generation 1 

G2 Generation 2 

Note: There are some differences in MPC when used with the Dominion 
KX I, Dominion KX II, and Dominion KSX II devices; these differences 
are noted in the user guide. 
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Overview 

Whenever you access a target server using the  Remote Console, a 
Virtual KVM Client window is opened. There is one Virtual KVM Client 
for each target server connected to; these windows can be accessed via 
the Windows task bar. See Connecting to a KVM Target Server in your 
device user guide for information accessing Virtual KVM Client 
windows. 

Virtual KVM Client windows can be minimized, maximized, and moved 
around your computer desktop. 

Note: Refreshing your HTML browser will close the Virtual KVM Client 
connection, so please exercise caution. 

 

The features available in the Virtual KVM Client are accessible through 
the menu and toolbar. 

Feature Description 

Menu Bar Drop-down menus of commands and 
settings. 

Toolbar Shortcut buttons to frequently used 
features and commands. 
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Feature Description 

Target Server Video 
Window 

Target device display. 

Status Bar Real-time information on connection 
parameters, target server window size, 
concurrent connections, Caps Lock 
indicator, and Num Lock indicator. 

 
 

Options 

Menu Tree 

The following list contains all of the menus and menu items available in 
the Virtual KVM Client. 

• Connection 

 Properties 

 Connection Info 

 Exit 

• Keyboard 

 Send Ctrl + Alt + Delete 

 Keyboard Macros 

 User-Created Macros (Optional) 

• Video 

 Refresh Screen 

 Auto-Sense Video Settings 

 Calibrate Color 

 Video Settings 

• Mouse 

 Synchronize Mouse 

 Single Mouse Cursor 

 Absolute 

 Intelligent 

 Standard 
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• Virtual Media 

 Connect Drive 

 Connect CD-ROM/ISO Image 

• Tools 

 Options 

• View 

 View Toolbar 

 Scaling 

 Target Screen Resolution 

• Help 

 About Raritan Virtual KVM Client 
 

Toolbar 

Button Description 

 Properties 

 Video settings 

 Calibrate color 

 Synchronize client and target server mouse cursors 

 Refresh screen 

 Auto-sense video 

 Send Ctrl+Alt+Delete 

 Toggles single/double mouse modes 

 Full screen 

 Resize video to fit screen 
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Mouse Pointer Synchronization 

When remotely viewing a target server that uses a mouse, you will see 
two mouse pointers: one belonging to your remote client workstation 
and the other belonging to the target server. When the mouse pointer lies 
within the Virtual KVM Client target server window, mouse movements 
and clicks are directly transmitted to the connected target server. While 
in motion, the client mouse pointer slightly leads the target mouse 
pointer due to mouse acceleration settings. 

 

On fast LAN connections, you may want to disable the Virtual KVM 
Client mouse pointer and view only the target server's pointer. You can 
toggle between these two modes (single mouse and dual mouse). Refer 
to Mouse Menu (on page 20) for additional information about the 
available mouse modes. 
 

Mouse Synchronization Tips 

Be sure to follow these steps when obtaining mouse synchronization: 

1. Verify that the selected video resolution and refresh rate is among 
those supported by the  device. The Virtual KVM Client Connection 
Info dialog displays the actual values that the  device is seeing. 
Please refer to Supported Video Resolutions in the device user guide 
for more information about the video resolutions that are supported. 

2. Verify that the cable length is within the specified limits for the 
selected video resolution. Please refer to Target Server Connection 
Distance and Video Resolution in the device user guide for more 
information. 
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3. Verify that the mouse and video have been properly configured 
during the installation process. Please refer to Installation and 
Configuration in the device user guide for complete instructions. 

4. Force an auto-sense by clicking the Virtual KVM Client auto-sense  
button. 

5. If that does not improve the mouse synchronization (for Linux, 
UNIX, and Solaris KVM target servers): 

a. Open a terminal window. 

b. Enter the xset mouse 1 1 command. 

c. Close the terminal window. 

6. Click the Virtual KVM Client mouse synchronization  button. 

Additional Notes for Intelligent Mouse Mode 

• Be sure that there are no icons or applications in the upper left 
section of the screen since that is where the synchronization routine 
takes place. 

• Do not use an animated mouse. 

• Disable active desktop on KVM target servers. 
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Connection Menu 

Properties Dialog 

The  dynamic video compression algorithms maintain KVM console 
usability under varying bandwidth constraints.  units optimize KVM 
output not only for LAN use, but also for WAN use. These units can also 
control color depth and limit video output, offering an optimal balance 
between video quality and system responsiveness for any bandwidth. 

 
Connection 
Properties 

Manually adjust bandwidth-related options 
(connection speed, color depth, etc.). 

The parameters in the Properties dialog can be optimized to suit your 
needs for different operating environments. 

 To set the connection properties: 

1. Choose Connection > Properties. The Properties dialog opens. 

 

2. Choose the Connection Speed from the drop-down list.  can 
automatically detect available bandwidth and not limit bandwidth 
use; but you can also adjust this usage according to bandwidth 
limitations. 

Auto 

1G Ethernet 

100 Mb Ethernet 

10 Mb Ethernet 

1.5 Mb (MAX DSL/T1) 

1 Mb (Fast DSL/T1) 

512 Kb (Medium DSL/T1) 

384 Kb (Slow DSL/T1) 
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256 Kb (Cable) 

128 Kb (Dual ISDN) 

Please note that these settings are an optimization for specific 
conditions rather than an exact speed. The client and server always 
attempt to deliver video as quickly as possible on the network 
regardless of the current network speed and encoding setting. But 
the system will be most responsive when the settings match the real 
world environment. 

3. Choose the Color Depth from the drop-down list.  can dynamically 
adapt the color depth transmitted to remote users in order to 
maximize usability in all bandwidths. 

15-bit RGB Color 

8-bit RGB Color 

4-bit Color 

4-bit Gray 

3-bit Gray 

2-bit Gray 

Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, etc.), the full 24-bit or 32-bit color spectrum made 
available by most modern video graphics cards is not necessary. 
Attempting to transmit such high color depths, wastes network 
bandwidth. 

4. Use the slider to select the desired level of Smoothing (15-bit color 
mode only). The level of smoothing determines how aggressively to 
blend screen regions with small color variation into a single smooth 
color. Smoothing improves the appearance of target video by 
reducing displayed video noise. 

5. Click OK to set these properties. 

 To cancel without saving changes: 

• Click Cancel. 
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Connection Info 

 To obtain information about your Virtual KVM Client 
connection: 

• Choose Connection > Connection Info. The Connection Info window 
opens. 

The following information is displayed about the current connection: 

• Device Name. The name of the  device. 

• IP Address. The IP Address of the  device. 

• Port. The KVM Communication TCP/IP Port used to access the 
target device. 

• Data In/Second. Data rate in. 

• Data Out/Second. Data rate out. 

• Connect Time. The duration of the connect time. 

• FPS. The frames per second transmitted for video. 

• Horizontal Resolution. The screen resolution horizontally. 

• Vertical Resolution. The screen resolution vertically. 

• Refresh Rate. How often the screen is refreshed. 

• Protocol Version. RFB Protocol version. 

 To copy this information: 

• Click Copy to Clipboard. The information is available to be pasted 
into the program of your choice. 

 

Exit 

 To close the Virtual KVM Client (the target you are 
currently accessing): 

• Choose Connection > Exit. 
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Keyboard Menu 

Send Ctrl+Alt+Delete 

Due to its frequent use, a Ctrl+Alt+Delete macro has been pre-
programmed into the Virtual KVM Client. 

This key sequence is sent to the target server to which you are currently 
connected. In contrast, if you were to physically press the 
Ctrl+Alt+Delete keys while using the Virtual KVM Client, the command 
would first be intercepted by your own PC due to the structure of the 
operating system, instead of sending the key sequence to the target 
server as intended. 

 Send Ctrl+Alt+Delete Sends a Ctrl+Alt+Delete key 
sequence to the target server 

 To send a Ctrl+Alt+Delete key sequence to the target 
server: 

• Choose Keyboard > Send Ctrl+Alt+Delete, or 

• Click the Send Ctrl+Alt+Delete button from toolbar 
 

Keyboard Macros 

Keyboard macros ensure that keystroke combinations intended for the 
target server, are sent to and interpreted only by the target server. 
Otherwise, they might be interpreted by the computer on which the 
Virtual KVM Client is running (your client PC). 

Macros are stored on the client PC and are PC-specific; therefore, if you 
use another PC you will not see your macros. In addition, if another 
person uses your PC and logs in under a different name, that user will 
see your macros since they are computer-wide. Keyboard macros created 
in the Virtual KVM Client are available in MPC and vice versa. 
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Creating a Keyboard Macro 

 To create a keyboard macro (add a macro): 

1. Choose Keyboard > Keyboard Macros. The Keyboard Macros 
window opens: 

 

2. Click Add. The Add Keyboard Macro window opens: 

 

3. Type a name in the Keyboard Macro Name field. This is the name 
that will display on the Virtual KVM Client menu bar after the 
macro is created. In this example, type Minimize All Windows. 

4. In the Keys to Press drop-down list: 

a. Scroll through and select each key for which you would like to 
emulate a key press (in the order in which they are to be 
pressed). 

b. Click the Press Key button after each selection. As each key is 
selected, it displays in the Keys to Release field. 
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In this example, select two keys: the Windows key and the letter D 
key. 

5. In the Keys to Release field: 

a. Choose each key for which you would like to emulate a key 
release (in the order in which they are to be released). 

b. Click Release Key after each selection. 

In this example, both keys pressed must also be released. 

6. Review the Macro Sequence - which has been automatically 
generated using the Keys to Press and Keys to Release selections. 
Verify that the Macro Sequence is the exact key sequence you want. 
(To remove a step in the sequence, select it and click Remove.) 

 

Tip: Use the ^ and v keys to reorder the key sequence. 

7. Click OK in the Add Keyboard Macro window to save the macro. 

8. Click Close from the Keyboard Macros window. The keyboard 
macro created is now listed as an option from Keyboard menu: 
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 To cancel without saving changes: 

• Click Cancel. 

 To clear all fields and start over: 

• Click the Clear button. 
 

Running a Keyboard Macro 

Once you have created a keyboard macro, execute it by clicking on its 
name in the Keyboard menu. 

 To execute a macro (using this example): 

• Choose Keyboard > Minimize All Windows. 

An alternative method is to select the macro from the Keyboard 
Macros window. 

 To execute a macro: 

1. Choose Keyboard > Keyboard Macros. The Keyboard Macros 
window opens. 

2. Select the macro from among those listed. 

3. Click Run Macro. 
 

Modifying a Keyboard Macro 

 To modify a macro: 

1. Choose Keyboard > Keyboard Macros. The Keyboard Macros 
window opens. 

2. Choose the macro from among those listed. 

3. Click Modify. The Add/Edit Macro window opens. 

4. Make your changes. 

5. Click OK. 
 

Removing a Keyboard Macro 

Please exercise caution in the removal of macros; you are not prompted 
to confirm their deletion. 
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 To remove a macro: 

1. Choose Keyboard > Keyboard Macros. The Keyboard Macros 
window opens. 

2. Choose the macro from among those listed. 

3. Click Remove. The macro is deleted. 
 

Video Menu 

Video settings can be refreshed automatically in several ways: 

• The Refresh Screen option forces a refresh of the video screen 

• The Auto-sense Video Settings option automatically detects the 
target server's video settings 

• The Calibrate Color option calibrates the video to enhance the colors 
being displayed 

In addition, you can manually adjust the settings using the Video 
Settings option. 
 

Refresh Screen 

The Refresh Screen option forces a refresh of the video screen. The entire 
video screen is redrawn. 

 Refresh Screen button 

 To refresh the video settings: 

• Choose Video > Refresh Screen, or 

• Click the Refresh Screen button from toolbar 
 

Auto-Sense Video Settings 

The Auto-sense Video Settings option forces a re-sensing of the video 
settings (resolution, refresh rate) and redraws the video screen. 

 Auto-Sense Video Settings button 

 To automatically detect the video settings: 

• Choose Video > Auto-sense Video Settings, or 

• Click the Auto-Sense Video Settings button from toolbar 

A message is displayed that auto adjustment is in progress. 
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Calibrate Color 

Use the Calibrate Color command to optimize the color levels (hue, 
brightness, saturation) of the transmitted video images. The  color 
settings are on a target server-basis. 

 
Calibrate Color Adjusts color settings to optimize the 

video display. 

Note: The Calibrate Color option applies to the current connection only. 

 To calibrate the color: 

1. Open a remote KVM connection to any target server running a 
graphical user interface. 

2. Choose Video > Calibrate Color (or click the Calibrate Color button). 
The target device screen updates its color calibration. 

 

Video Settings 

Use the Video Settings option to manually adjust the video settings. 

 Video Settings Opens Video Settings for manual 
adjustment of video parameters. 
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 To change the video settings: 

1. Choose Video > Video Settings. The Video Settings window opens 
displaying the current settings: 

 

2. Use the sliders to adjust the settings to achieve the desired results (as 
you adjust the settings the effects are immediately visible): 

 Noise Filter.  can filter out the electrical interference of video 
output from graphics cards. This feature optimizes picture 
quality and reduces bandwidth. Higher settings transmit variant 
pixels only if a large color variation exists in comparison to the 
neighboring pixels. However, setting the threshold too high can 
result in the unintentional filtering of desired screen changes. 
Lower settings transmit most pixel changes. Setting this 
threshold too low can result in higher bandwidth use. 

 Brightness: Use this setting to adjust the brightness of the target 
server display. 

 Red. Controls the brightness of the red signal. 

 Green. Controls the brightness of the green signal. 

 Blue. Controls the brightness of the blue signal. 

 Color Contrast Settings: Controls the contrast adjustment. 
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 Contrast Red. Controls the red signal. 

 Contrast Green. Controls the green signal. 

 Contrast Blue. Controls the blue signal. 

 If the video image looks extremely blurry or unfocused, the 
settings for clock and phase can be adjusted until a better image 
appears on the active target server. 

Warning: Please exercise caution when changing the Clock and 
Phase settings; doing so may result in lost or distorted video and you 
may not be able to return to the previous state. Contact Raritan 
Technical Support before making any changes. 

 Clock. Controls how quickly video pixels are displayed 
across the video screen. Changes made to clock settings 
cause the video image to stretch or shrink horizontally; odd 
number settings are recommended. Under most 
circumstances this setting should not be changed because 
the auto-detect is usually quite accurate. 

 Phase. Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image 
for the active target server. 

 Offset: Controls the on-screen positioning: 

 Horizontal Offset. Controls the horizontal positioning of the 
target server display on your monitor. 

 Vertical Offset. Controls the vertical positioning of the target 
server display on your monitor. 

 Auto Color Calibration. Check this option if you would like 
automatic color calibration. 

 Video Sensing: Select the video sensing mode: 

 Best possible video mode:  will perform the full Auto Sense 
process when switching targets or target resolutions. 
Selecting this option calibrates the video for the best image 
quality. 

 Quick sense video mode: With this option, the  device will 
use a quick video Auto Sense in order to show the target's 
video sooner. This option is especially useful for entering a 
target server's BIOS configuration right after a reboot. 

3. Click Apply. The Video Settings are changed. 
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Note: Some Sun background screens, such as screens with very dark 
borders, may not center precisely on certain Sun servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
screen. 

 To cancel with saving your changes: 

• Click Cancel. 
 

Mouse Menu 

When controlling a target server, the  Remote Console displays two 
mouse cursors: one belonging to your client workstation and the other 
belonging to the target server. You can operate in either single mouse 
mode or dual mouse mode. When in dual mouse mode and properly 
configured, these two mouse cursors will align. If you experience 
difficulty with mouse synchronization, refer to Configure Target Servers. 

When there are two mouse cursors, the  device offers several mouse 
modes: 

• Absolute (Mouse Synchronization) 

• Intelligent (Mouse Mode) 

• Standard (Mouse Mode) 
 

Synchronize Mouse 

In dual mouse mode, the Synchronize Mouse option forces realignment 
of the target server mouse pointer with Virtual KVM Client mouse 
pointer. 

 Synchronize Mouse 

 To synchronize the mouse: 

• Choose Mouse > Synchronize Mouse, or 

• Click the Synchronize Mouse button from the toolbar 
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Single Mouse Cursor 

Single Mouse Cursor enters single mouse mode, in which only the target 
server mouse cursor is shown; the local PC mouse pointer no longer 
appears on-screen. While in single mouse mode, the Synchronize Mouse 
option is not available (there is no need to synchronize a single mouse 
cursor). 

 Single Mouse Cursor

 To enter single mouse mode: 

• Choose Mouse > Single Mouse Cursor, or 

• Click the Single/Double Mouse Cursor button from the toolbar 

 To exit single mouse mode: 

1. When entering single mouse mode, the following message is 
displayed. Click OK. 

 

2. Press Ctrl+Alt+O on your keyboard to exit single mouse mode. 
 

Standard 

This is the standard mouse synchronization algorithm using relative 
mouse positions. Standard mouse mode requires that acceleration is 
disabled and other mouse parameters are set correctly in order for the 
client and server mouse to stay synchronized. Standard mouse mode is 
the default. 

 To enter standard mouse mode: 

• Choose Mouse > Standard. 
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Intelligent 

In Intelligent mouse mode, the  device can detect the target mouse 
settings and synchronize the mouse pointers accordingly, allowing 
mouse acceleration on the target. In this mode, the mouse cursor does a 
“dance” in the top left corner of the screen and calculates the 
acceleration. For this mode to work properly, certain conditions must be 
met. 

For additional information on Intelligent Mouse mode, refer to the 
Raritan Multi-Platform Client User Guide (Appendix B: Conditions for 
Intelligent Mouse Synchronization) available on Raritan's Website 
http://www.raritan.com/support/productdocumentation, or on the 
Raritan User Manuals & Quick Setup Guides CD ROM included with 
your  shipment. 

 To enter intelligent mouse mode: 

• Choose Mouse > Intelligent. 
 

Absolute 

Note: Absolute Mouse Synchronization is available for use with the 
Virtual Media-enabled USB CIM (D2CIM-VUSB) only. 

In this mode, absolute coordinates are used to keep the client and target 
pointers in sync, even when the target mouse is set to a different 
acceleration or speed. This mode is supported on servers with USB ports; 
the mouse moves to the exact location on the target server. 

 To enter absolute mouse mode: 

• Choose Mouse > Absolute. 
 

Virtual Media 

Refer to the chapter on Virtual Media (on page 150) for complete 
information about setting up and using virtual media. 
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Tools Menu 

Options 

From the Tools menu, you can specify certain options for use with the 
Virtual KVM Client: synchronize mouse when in dual mouse mode, 
enable logging, keyboard type, and the exit target screen resolution 
mode hotkey. 

 To set the tools options: 

1. Choose Tools > Options. The Options window opens: 

 

2. Select the Enable Logging checkbox only if directed to by Technical 
Support. This option creates a log file in your home directory. 

3. Choose the Keyboard Type from the drop-down list (if necessary). 
The options include: 

 US/International 

 French (France) 

 German (Germany) 

 Japanese 

 United Kingdom 

 Korean (Korea) 

 Traditional and Simplified Chinese 

 German 

 Belgian 

 Norwegian 

 Danish 

 Swedish 
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4. Exit Target Screen Resolution Mode - Hotkey. When you enter target 
screen resolution mode, the display of the target server becomes full 
screen and acquires the same resolution as the target server. This is 
the hotkey used for exiting this mode; select from the drop-down 
list. 

5. Exit Single Cursor Mode - Hotkey. When you enter single cursor 
mode, only the target server mouse cursor is visible. This is the 
hotkey used to exit single cursor mode and bring back the client 
mouse cursor; select from the drop-down list. 

6. Click OK. 
 

View Menu 

View Toolbar 

You can use the Virtual KVM client with or without the toolbar display. 

 To toggle the display of the toolbar (on and off): 

• Choose View > View Toolbar. 
 

Scaling 

Scaling your target window allows you to view the entire contents of the 
target server window. This feature increases or reduces the size of the 
target video to fit the Virtual KVM Client window size, and maintains 
the aspect ratio so that you see the entire target server desktop without 
using the scroll bar. 

 To toggle scaling (on and off): 

• Choose View > Scaling. 
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Target Screen Resolution 

When you enter target screen resolution mode, the display of the target 
server becomes full screen and acquires the same resolution as the target 
server. The hotkey used for exiting this mode is specified in the Options 
dialog (default is Ctrl+Alt+M). 

 To enter target screen resolution: 

• Choose View > Target Screen Resolution. 

 To exit target screen resolution mode: 

• Press the hotkey configured in the Tools Options dialog. The default 
is Ctrl+Alt+M. 

Note to CC-SG Users: Target Screen Resolution is disabled; full screen 
mode is available only when the  device is not under CC-SG 
management. 
 

Help Menu 

About Raritan Virtual KVM Client 

This menu option provides version information about the Virtual KVM 
Client should you require assistance from Raritan technical support. 

 To obtain version information: 

• Choose Help > About Raritan Virtual KVM Client. 
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Requirements and Installation 

MPC Requirements and Installation Instructions 

Note to CC-SG Users 

If you are using Dominion KX II in a CC-SG configuration, do not use 
the CC-SG proxy mode if you are also planning to use the Multi-
Platform Client (MPC).  
 

MPC Minimum System Requirements 

The minimum system requirements for the Multi-Platform Client are: 

• CPU Speed: 1.0 GHz 

• RAM: 512 Mbytes 

Note: Running the client software on system configurations below either 
of these specifications may impact performance and result in errors. 
 

MPC Supported Browsers 

MPC supports the following browsers: 

• Internet Explorer 6 and 7 

• Firefox® 1.5 and 2.0 

• Mozilla® 1.7 

• Safari 2.0 
 

Chapter 3 Multi-Platform Client and 
Raritan Remote Client 
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Raritan Multi-Platform Client (MPC) Supported Operating Systems 

When launched as a web applet or as a standalone application, MPC 
allows you to reach target servers via different Raritan Dominion devices 
and IP Reach models. 

Raritan MPC is compatible with the following platforms: 

• Windows XP 

• Windows 2000 SP4 

• Windows Vista 

• Red Hat Linux® 9.0 

• Red Hat Enterprise Workstation 3.0 and 4.0 

• SUSE Linux Professional 9.2 and 10 

• Fedora Core 5 and above 

• Mac® 

• Solaris™ 
 

Launching MPC from a Web Browser 

Important: Regardless of the browser you use, you must allow pop-ups 
from the Dominion device's IP address in order to open MPC. 

1. To open MPC from a client running any supported browser (see 
"MPC Supported Browsers" on page 26), type http://IP-
ADDRESS/mpc into the address line, where IP-ADDRESS is the IP 
address of your Raritan device. MPC will open in a new window. 
This window will not contain a menu bar, toolbar, scroll bar, or 
address bar. Work in this window and toggle to other open windows 
using the Alt+Tab command. 

Note: The Alt+Tab command will toggle between windows only on 
the local system. 

When MPC opens, the Raritan devices that were automatically 
detected and which are found on your subnet are displayed in the 
Navigator in tree format.  

2. If your device is not listed by name in the navigator, add it manually:  

a. Select Connection > New Profile. The Add Connection window 
opens. 

b. In the Add Connection window, type a device Description, 
specify a Connection Type, add the device IP Address, and click 
OK. These specifications can be edited later. 
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3. In the Navigator panel on the left of the page, double-click on the 
icon that corresponds to your Raritan device to connect to it. 

Note: Depending on your browser and browser security settings, you 
may see various security and certificate check and warning dialog boxes. 
It is necessary to accept the options in order to open MPC. 

 
 

Installing and Opening Standalone MPC 

Raritan recommends that you open only one standalone MPC session at 
a time. Opening more than one standalone MPC session on the same 
client at the same time may cause performance problems and system 
errors. 

Note: Please note that the installer file names and the install 
directories/folder paths that are documented in the device user guides 
may differ slightly from what is outlined in this guide. 

 

Important: MPC modem connectivity is supported on Windows, 
Linux, and Sun Solaris but not Macintosh. When working in 
Windows, use Standalone MPC. 
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You must have the MPC JAR file to install MPC for any of these 
operating systems. 

1. Download the installation file, MPC-installer.jar from the Raritan 
website on the Support - Firmware Upgrades page 
(http://www.raritan.com/support/firmwareupgrades). Click on 
Dominion Family and scroll to the Standalone Multi-Platform Client 
link. 

2. If copying MPC-installer.jar from a known location, double-click on 
the file to start installation. 

 

Windows 

Checking JRE Version in Windows 
1. Do one of the following to check the JRE version in Windows: 

a. Determine your version of the JRE from the Java website: 
http://www.java.com/en/download/help/testvm.xml. 

b. Or, click on the Windows Start button at the bottom left of your 
page and click Control Panel.  

Tip: In the upper left corner of the page, you may see a panel named 
Control Panel with the option Switch to Classic View or Switch to 
Category View.  For easier viewing, opt for Classic View. 

c. Search the Control Panel files for a Java icon. When you locate 
the Java icon, double-click on it to open the Java Control panel. 
Click on the General tab and then click on the About button to 
check the current Java Runtime Environment (JRE). 

d. If the JRE is version 1.4.2_05 or later, proceed with the MPC 
Installation. If the Java icon does not exist in the Control Panel or 
if the JRE version is prior to 1.4.2_05, go to the Sun Microsystems 
website at http://java.sun.com/products/ to download the latest 
version of JRE. 

2. For future Java access and to automatically open it, set your path to 
the Java executable.  

a. Right-click on the My Computer icon on your desktop and click 
Properties. 

b. Click on the Advanced tab and then click "Environment 
variables". 
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c. Edit the Path address so that it contains the path to the Java 
executable.   
For example, if Java is installed on C:\j2re1.4.2_05 and your path 
is currently set to C:\WINDOWS\SYSTEM32, then change the 
path to read C:\WINDOWS\SYSTEM32;C:\j2re1.4.2_05 

 
 

Installing MPC for Windows 
1. Download the MPC-installer.jar installation file or copy the file from 

a known location. See Installing and Launching Standalone MPC 
(see "Installing and Opening Standalone MPC" on page 28) for 
information on locating the MPC-installer.jar file. 

2. Double-click on the jar file icon to open the installation dialog. 

3. After the initial dialog appears, click Next. 

 

4. Select the directory where you want to install MPC and click Next. 
Click Browse to locate a non-default directory. 
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5. Click Next. 

 

6. In the Shortcut dialog, choose a shortcut location, determine who 
should have the shortcut, and determine whether you want the 
shortcut on the desktop. When finished, click Next. 
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Once the installation is complete, the final dialog indicates where 
you will find an uninstaller program and provides an option for 
generating an automatic installation script. Click Done to close the 
Installation dialog. 

 
 

Opening MPC in Windows 
1. Click on the Windows Start menu and then click All Programs > 

Raritan Multi-Platform Client. Alternatively, double-click the MPC 
desktop shortcut icon if you created one. 

2. Double-click on the desired device in the Navigator to establish a 
connection. 

3. Type your Username and Password in the device dialog and then 
click OK to log on.  
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Linux 

Java Runtime Environment (JRE) Requirements for MPC 

Raritan recommends using Java® Runtime Environment (JRE) version 
1.5 for optimum performance but MPC will function with JRE version 
1.4.2_05 or greater (with the exception of JRE 1.5.0_02). JRE 1.6 is also 
supported but has not been fully tested. 

Determine your version of the JRE from the Java website: 
http://www.java.com/en/download/help/testvm.xml. 

You may need some configuration depending on your OS and browser. 
Configuration instructions are provided with the JRE download.  

Note: Modem use is not supported with Raritan's Dominion KX101. 

 

Important: When launching MPC from a browser, it is highly 
recommended that you disable the Java Applet caching. 

Although no actual problems have occurred when Java caching is turned 
on, some non-impacting Java exceptions have occurred. Generation of 
these Java-exceptions can appear in the Java Applet Console window 
and may degrade performance. 

For Linux/UNIX environments, the Java Control Panel is located in the 
JRE's bin directory; the location varies based on where JRE was installed 
by your Linux/UNIX administrator. 

Tip: It is also recommended that you clear the Java cache. 

 To disable Java caching and clear the cache (use these 
steps with Microsoft Windows XP and JRE 1.5.0): 

1. From the Start menu, click Control Panel. 
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2. Double-click on the Java icon to launch it. The Java Control Panel 
dialog appears. 

 

3. To disable Java caching: 
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a. From the General tab, click the Settings button. The Temporary 
Files Settings dialog appears. 

 

b. Click the View Applets button. The Java Applet Cache Viewer 
opens. 

 

c. Deselect the Enable Caching checkbox if it is already checked. 

d. Click OK. 

4. To clear the Java cache: 

a. From the Temporary Files Settings dialog, click the Delete Files 
button. The Delete Temporary Files dialog appears. 
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b. Select the temporary files that you want to delete. 

 

c. Click OK. 
 

Checking JRE Version in Linux 
1. In a graphical environment, open a terminal window. 

2. Type java version in the command line and press Enter on your 
keyboard. The currently-installed version of Java Runtime 
Environment (JRE) is displayed. 

If your path variable is not set to where the java binaries have been 
installed, you may not be able to see the JRE version. 

3. Set your path:  

a. To set your path and assuming JRE 1.4.2_05 is installed in 
/usr/local/java: you must set your PATH variable. 

b. To set the path for bash shell, export 
PATH=$PATH:/usr/local/java/j2re1.4.2_05/bin. 

c. To set the path for tcsh or csh, set PATH = ($PATH 
/usr/local/java/j2re1.4.2_05/bin). 

These commands can be typed at the terminal each time you login. 
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for 
csh, or tcsh so that each time you login the PATH is already set.  
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Please refer to your shell documentation if you encounter problems.  

 

4. If the JRE is version 1.4.2_05 or higher, proceed with the MPC 
installation. If the version is prior to 1.4.2_05, please go to the Java 
website at http://java.sun.com/products/ to download the latest 
Runtime Environment. 

 

Installing MPC for Linux 

You must have Administrative privileges to install MPC. 

1. Download the MPC-installer.jar file or copy it from a known 
location. 

2. Open a terminal window and open the directory where the installer 
is saved. 

3. Type java -jar MPC-installer.jar and press Enter to run the installer. 
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4. After the initial page loads, click Next. 

 

5. Use the Browse function to select a directory to install MPC if the 
directory is different from the default path displayed in the "Select 
the installation path" field.  

6. Click Next to open the Shortcut dialog. 

7. On the Shortcut dialog: 

 Choose a shortcut location from the "Select a Program Group for 
the Shortcuts:" field. 

 Select either "current user" or "all users" to define who should 
have access to the shortcut. 

 Check the "Create shortcut on the desktop" checkbox if you want 
the shortcut to appear on the desktop.  
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8. When finished, click Next. 

 

Note: Once MPC is installed successfully, a shortcut will be available 
on the desktop. However, for Linux users, you will need to log out of 
and then back into your session before the shortcut will be visible on 
the desktop.  

Once the installation is complete, the final page indicates where you 
will find an uninstaller program and provides you with the option to 
generate an automatic installation script.  
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9. Click Done to close the Installation dialog. 

 
 

Opening MPC in Linux 
1. Open a terminal window and change directories to the directory 

where you installed MPC (default location: /usr/local/Raritan/Raritan 
MPC/4.40.1.7/). 

2. Type ./start.sh and press Enter to open MPC. 

3. Double-click on the desired device to establish a connection, type 
your Username and Password, and click OK to log on.  

 

Solaris 

Checking JRE Version on Sun Solaris 
1. Launch a terminal window on the Sun Solaris desktop. 

2. Type java version in the command line and press Enter. The 
currently-installed version of Java Runtime Environment (JRE) 
appears. 

If your path variable is not set to where the java binaries have been 
installed, you may not be able to see the JRE version. 

a. To set your path and assuming JRE 1.4.2_05 is installed in 
/usr/local/java, you must set your PATH variable. 

b. To set path for bash shell, export 
PATH=$PATH:/usr/local/java/j2re1.4.2_05/bin. 

c. To set path for tcsh or csh, set PATH = ($PATH 
/usr/local/java/j2re1.4.2_05/bin). 
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3. These commands can be typed at the terminal each time you login. 
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for 
csh, or tcsh so that each time you login the PATH is already set. 
Please refer to your shell documentation if you encounter problems. 

 

4. If the JRE is version 1.4.2_05 or higher, proceed with the MPC 
installation. If the version is prior to 1.4.2_05, please go to the Sun 
website at http://java.sun.com/products/ to download the latest 
Runtime Environment. 

 

Installing MPC for Sun Solaris 

You must have administrative privileges to install MPC. 

1. Download the MPC-installer.jar file or copy it from a known 
location. 

2. Open a terminal window and navigate to the directory where the 
installer is saved. 

3. Type java -jar MPC-installer.jar and press Enter to run the installer. 
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4. After the initial page loads, click Next. 

 

5. Use the Browse function to navigate to the directory you want to 
install MPC or select the default directory displayed in the "Select the 
installation path" field. 

6. Click Next.  

7. When installation is complete, click Next. 

8. Click Next again. 

Once the installation is complete, the final dialog will indicate where 
you will find an uninstaller program and provides the option to 
generate an automatic installation script.  
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9. Click Done to close the Installation window. 

 
 

Opening MPC on Sun Solaris 
1. Open a terminal window and navigate to the directory where you 

installed MPC (the default location is /usr/local/Raritan/Raritan 
MPC/4.40.1.7). 

2. Type ./start.sh and press Enter to open MPC. 

3. Double-click on the desired device to establish a connection, type 
your Username and Password, and click OK to log on.  

 

Macintosh 

Checking JRE Version in Mac OSX 
1. Launch a terminal window on the Macintosh desktop. 
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2. Type the java version in the command line and press Enter. The 
currently-installed version of the Java Runtime Environment (JRE) is 
displayed. 

 

3. If the JRE is version 1.4.2_05 or higher, proceed with the MPC 
installation. If the version is prior to 1.4.2_05, please go to the Apple 
website to download the latest Runtime Environment. 

 

Installing MPC for Mac OSX 

You must have administrative privileges to install MPC. 

1. Download the MPC-installer.jar file or copy it from a known 
location. 

2. Open a Finder window and locate the installer. 

3. Double click on the MPC-installer.jar file to run the installer. 
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4. After the initial page opens, click Next. 

 

5. Use the Browse function to select a directory to install MPC if the 
directory is different from the default path displayed in the "Select 
the installation path" field. 

6. When installation is complete, click Next. 

Once the installation is complete, the final dialog indicates where 
you will find an uninstaller program and provides you with the 
option to generate an automatic installation script.  
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7. Click Done to close the Installation window. 

 
 

Opening MPC in Mac OSX 
1. Open a Finder window and navigate to the directory where you 

installed MPC (the default location is /Applications/Raritan/Raritan 
MPC/4.40.1.7). 

 

2. Double-click on the desired device to establish a connection, type 
your Username and Password, and click OK to log on.  
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RRC Requirements and Installation Instructions 

Important: RRC works only with Microsoft Internet Explorer. If you 
are using a different web browser, MPC will load automatically. 

Most users access RRC via Internet Explorer, while other users, 
particularly those operating over a modem connection, access RRC 
standalone. Both options are detailed in this guide.  

Note: Modem use is not supported with Raritan's Dominion KX101. 
 

RRC Minimum System Requirements 

The minimum system requirements for the Raritan Remote Client are: 

• CPU Speed: 1.0 GHz 

• RAM: 512 Mbytes 

Note: Running the client software on system configurations below either 
of these specifications may impact performance and result in errors. 
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Opening RRC from a Web Browser 

Your IP-Reach and Dominion units feature web browser-access 
capabilities and can provide a connection from any Windows-based, 
remote PC running Microsoft Internet Explorer 6.0/7.0. 

Security Settings 

To access IP-Reach or a Dominion device via the web, your web browser 
must be configured appropriately on the Internet Explorer security 
settings tab. Specifically: 

• "Download Signed ActiveX controls" should be set to either Enable 
or Prompt. 

• "Run ActiveX controls and plug-ins" should be set to either Enable or 
Prompt. 

Please consult your Microsoft Internet Explorer documentation for 
additional information. 

Note: Microsoft Windows 2000, Microsoft Windows XP, and Microsoft 
Windows 2003 restrict certain types of users from downloading and 
running ActiveX controls and plug-ins regardless of the above settings in 
Internet Explorer. Please consult your Microsoft Windows 
documentation for more information. 

Opening RRC 

1. Ensure that your browser security settings are configured 
appropriately and type the IP address assigned to your IP-Reach or 
Dominion unit in the URL field of your web browser. See the Initial 
Configuration section in the device user guide for additional 
information on configuring IP addresses. 

 

Note: IP-Reach and Dominion units ship with the default IP address 
of 192.168.0.192. Please note that an IP address must be used. Host 
names are not currently supported. 
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You will be redirected to an HTTPS (128-bit) secure webpage so you 
can open RRC. 

 

2. Depending on your browser and its security configuration, you may 
see any or all of the following dialogs asking you to confirm you 
want to access and open an externally-provided application. Click 
Yes to accept these prompts. 
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Removing RRC from the Browser Cache 

• To remove RRC from your browser cache for any reason, follow the 
standard procedure for your web browser software. 

 To remove cached files in Internet Explorer v6.0: 

1. If you have used RRC recently, exit all instances of Internet Explorer 
and restart Internet Explorer. 

2. On the Internet Explorer Tools menu, click Internet Options. 

3. When the Internet Options dialog appears, click on the General 
Settings tab and then click Delete Files. 

4. Click on the Settings tab and then click View Objects. 

5. Internet Explorer will display a list of cached objects. Select any 
entries named “TeleControl Class,” “Raritan Console,” or “Power 
Board” and delete them. 
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Installing and Opening Standalone RRC 

Note: This step is optional. IP-Reach or Dominion can be accessed from a 
remote PC either by installing RRC software or by opening RRC via a 
web browser. Accessing IP-Reach or Dominion via a web browser does 
not require any software installation on a remote PC.  

This section lists the steps required to invoke RRC using standalone 
software, which may be useful for accessing IP-Reach or Dominion via 
modem or if you wish to close firewall access to ports 80 and/or 443. 

1. Launch your web browser and go to Raritan's website 
(http://www.raritan.com/).  

2. Click Support in the top navigation bar and then click Firmware 
Upgrades in the left navigation panel (or type the URL 
http://www.raritan.com/support/firmwareupgrades). 

3. Scroll down the page until you see the appropriate product name 
and click on it. 

4. Locate the version of the standalone RRC client you are using. The 
entry for the standalone RRC client is a .zip file which contains the 
release notes and the installer for standalone RRC.  Check the release 
notes for the latest information. 

5. Download the .zip file or simply click on the .zip file entry. 

6. Double-click on the installer executable in the .zip file and follow the 
instructions in the InstallShield Wizard to complete the RRC 
installation.  Be sure to check the release notes for the latest 
information and any release specific instructions. 

Depending upon the configuration of your PC, the RRC installation 
program may also automatically install DirectX and Microsoft 
Foundation Class libraries (if they are required).  If they are installed, 
you will be asked to restart your PC after the installation. 

7. A Raritan Remote Client icon will appear on your desktop after the 
installation is complete. Click on this icon to open the standalone 
RRC application. 

The standalone application can be uninstalled using the Add or 
Remove Programs function in the Windows Control Panel.   

Note: You must uninstall the application before installing a new version 
of standalone RRC. 
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Modem Connectivity  in MPC 

 To make modem connectivity available on Unix, Linux, 
and Mac OS for non-root users: 

1. As the root, change the group for /etc/ppp directory and required 
files: 

a. chgrp uucp /etc/ppp 

b. chgrp uucp /etc/ppp/pap-secrets 

c. chgrp uucp /etc/ppp/peers 

2. Change the permissions for /etc/ppp chmod g+rwx /etc/ppp 

3. Change the permissions for /etc/ppp/pap-secrets chmod g+rwx 
/etc/ppp/pap-secrets 

4. Change the permissions for /etc/ppp/peers chmod g+rwx 
/etc/ppp/peers 

5. Set the suid bit to pppd chmod u+s /usr/sbin/pppd (/usr/bin/pppd 
depending on the location of pppd) 

6. Assign users to the uucp group: 

a. /usr/sbin/usermod -G {existing groups for user1},uucp user1 

b. /usr/sbin/usermod -G {existing groups for user2},uucp user2, etc. 

7. When logged in as the normal user, update the path for access to 
pppd and the chat export PATH=$PATH:/usr/sbin (/usr/bin 
depending on the location of pppd). 

Note: For both root and non-root users, ensure that the options file exists 
under /etc/ppp 

 
 

Operation 

Note: Unless otherwise indicated, the contents of this section are the 
same in MPC and RRC. 
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Connection Profiles 

Connection profiles store important information about your Raritan 
device such as the IP address, custom TCP ports, preferred compression 
settings, and custom security keys. A profile is required to access devices 
outside your subnet and to access devices using a dial-up connection. 

Through profiles, you can set up personalized connections. These 
profiles are not shared among other users. 

Tip: If your Raritan device is configured to use a custom TCP port or a 
group security key, first create a connection profile so that you can access 
the device. 

Connection profiles are created, modified, deleted, established, and 
closed in the same way for both MPC and RRC. 
 

Creating Profiles 

 To create a profile: 

1. There are two ways to create a profile: 

 For automatically discovered devices, right-click on the device 
name in the Navigator and select Add Profile from the shortcut 
menu. 

 For other devices, select Connection > New Profile. 

The Add Connection dialog appears. Options are organized into 
three tabs. 

2. On the Connect tab, type a meaningful description of the device in 
the Description field (up to 32 alphanumeric, special characters (see 
"Special Characters in MPC" on page 148) characters are allowed). 
This description identifies the Raritan device in the Navigator. 

3. From the Product drop-down, select the Raritan product you are 
using. 

4. Select the Connection Type from the drop-down to specify the type 
of connection.  

Note: Only TCP/IP is available for Generation 2 (G2) Raritan devices. 

a. If TCP/IP Connection is selected for a LAN/WAN connection, 
complete the information in the Find Raritan device By section: 

 Type the IP Address assigned to your Raritan device. 



Operation 
 

54
 

 Type the name assigned to your Raritan device during initial 
setup. 

 Type the Domain Name Server (DNS) name. Use this option if 
you use a DNS server to resolve a DNS name to the IP Address 
assigned to your Raritan device. 

Note: You cannot use this option for Raritan Generation 2 (G2) 
devices. 

 

a. Select Dial Up Connection from the Connection Type drop-down 
for a direct analog modem connection to the Raritan device. 
Type the parameters that MPC or RRC should use to establish a 
connection. Dial up connection does not apply to Generation 2 
(G2) or KX101. 

 Enter the phone number for the dial-up connection. Remember to 
include any additional codes that should be dialed to establish a 
connection, such as country codes, area codes, or outside line 
access codes. 

 Select the modem (as configured in Windows) from the drop-
down list that will be used to dial and connect to your Raritan 
device. 
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Note: For security reasons, you must use the MPC standalone client 
if you require modem access. Further, one modem on a client PC can 
be used for only one device connection. 

    
• Check Use Default Port Number to use the default port number 

(5000). For TCP Ports, Dominion KX and IP-Reach are automatically 
configured to use TCP Port 5000 when communicating with 
MPC/RRC.  If you do not want to use the default port number, 
uncheck the checkbox and type the port number in the Port Number 
field. 

1. Update the Compression tab (not available for Generation 2 (G2) 
Raritan devices): 

a. Select the Connection Speed from the drop-down. IP Reach and 
Dominion can automatically detect available bandwidth and not 
limit bandwidth use, but you can also adjust this usage 
according to bandwidth limitations. Depending on the Raritan 
device in use, different options may be available. 
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• Auto Detect 

• 100mb Ethernet 

• 10mb Ethernet 

• 1.5mb (Max DSL/T1) 

• 1mb (Fast DSL/T1) 

• 512 kb (Medium DSL/T1) 

• 384 kb (Slow DSL/T1) 

• 256 kb (Cable) 

• 128 kb (Dual ISDN) 

• 56 kb (ISP Modem) 

• 33 kb (Fast Modem) 

• 24 kb (Slow Modem) 

a. Select the Color Depth from the drop-down. IP-Reach and 
Dominion can dynamically adapt the color depth transmitted to 
remote users in order to maximize usability in all bandwidth 
constraints. Depending on the Raritan device in use, different 
options may be available. 

• Auto Select Color 

• 15-bit RGB Color 

• 12-bit RGB Color 

• 8-bit RGB Color 

• 5-bit Color 

• 4-bit Color 

• 4-bit Gray 

• 3-bit Gray 

• 2-bit Gray
• Black and White 

Important: For most administrative tasks (server monitoring, 
reconfiguring, etc.), administrators do not require the full 24-bit or 
32-bit color spectrum made available by most video graphics cards. 
Attempting to transmit such high color depths wastes network 
bandwidth. 

a. Select Progressive Update to increase the usability in constrained 
bandwidth environments. When Progressive Update is enabled, 
IP-Reach or Dominion initially sends an image of the remote 
desktop at lower color depths, and then provides higher color 
depth images as bandwidth allows. 
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Note: When Color Depth is set to Auto Select Color (default), 
Progressive Update is automatic. IP-Reach or Dominion will 
enable/disable Progressive Update as required, disabling it for fast 
connections and enabling it for slow connections. 

b. When using IP-Reach or Dominion over an unpredictable public 
WAN (particularly in international scenarios), checking the 
Internet Flow Control check box ensures that packets 
transmitted by IP-Reach or Dominion are received and 
reconstructed by MPC/RRC in the correct order. 

c. Use the slider to select the desired level of video Smoothing (15-
bit mode only). The level determines how aggressively to blend 
page regions with small color variation into a single smooth 
color. Smoothing improves the appearance of the target video by 
reducing the video noise that is displayed. 

d. Select the "Frames per second". This setting instructs MPC on 
how often to redraw the video display of the target. This only 
affects the client display behavior and has no bearing on the data 
rate of the video being sent to the client. Setting this option 
higher makes the video appear smoother but also requires more 
processing power. 

Note: "Frames per second" option is only available in MPC. 
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1. Update the Security tab. 

Please note that the Security tab is disabled for Generation 2 Raritan 
devices. If your Dominion or IP-Reach unit is configured to use a 
private security key, input that key to gain the authorization 
required to initiate a connection to that IP-Reach or Dominion unit. 

a. Type the private security key in the Private Key field. 

b. Retype the private security key in the Confirm Private Key field 
to ensure no typographical errors were made. 
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2. Click OK to create the connection profile. 

 
 

Modifying Profiles 

 To modify a profile in MPC or RRC: 

1. Select the device in the Navigator panel and right-click on it. 
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2. Select Modify Profile. The Modify Connection dialog appears. 

 

3. Update the fields as appropriate. 

4. Click OK. 
 

Deleting Profiles 

 To delete a profile in MPC or RRC: 

1. Select the device with a profile in the Navigator and right-click on it. 

2. Select Delete Profile. 

3. When prompted to confirm the deletion, click Yes to delete the 
profile for this device or click No to return to the application without 
deleting. 
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Establishing a New Connection 

Note: Depending on your version of the JRE, you might receive a 
certificate message when using the standalone application to access a 
Dominion device. You have to accept the certificate in order to establish 
the connection. 

To connect to a device, double-click the device's icon in the Navigator, 
then type your user name and password to connect. You can also right-
click on the device name in the Navigator and select New Connection. 

Note: The default IP-Reach or Dominion login user name is admin and 
the default password is raritan. You have administrative privileges using 
these login credentials.  

Passwords are case sensitive and must be entered in the exact case 
combination in which they were created. To ensure security, change the 
default username password as soon as possible. 

If you do not see an icon for your IP-Reach or Dominion device in the 
Navigator, please follow the instructions in the Creating Profiles section 
(see "Creating Profiles" on page 53) to create a new connection profile. 

If you are having problems connecting to a device, be sure to check the 
following: 

• Username: Raritan usernames are not case-sensitive. 

• Password: Raritan passwords are case-sensitive. 

• TCP Port: If you have configured your device to use a non-default 
TCP Port, this information must be entered into its connection 
profile. 

• Firewall Settings: If you are accessing a device through a firewall, 
that firewall must be configured to allow two-way communication 
on TCP Port 5000 (or the custom TCP Port to which your device has 
been configured). 

• Security Key: If you have configured your device to require a group 
security key, that key must be entered into the device's connection 
profile. 

Note: If you are running MPC on Internet Explorer with both a Microsoft 
firewall and a non-Microsoft firewall utility installed, IE will display a 
message telling you that MPC is already running (even if it is not in fact 
running). To avoid this, deactivate one of your firewalls, or use a 
browser such as Mozilla or Firefox. 
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Closing a Remote Connection 

To close the IP-Reach or Dominion connection, select the device in the 
Navigator and right-click on it. Select Disconnect from the shortcut 
menu. 

To exit MPC or RRC completely, click Exit on the Connection menu. 
 

MPC Connection Information 

Note: RRC can support only one modem connection at one time. 

 To obtain information about your MPC connection: 

• Select Connection > Connection Info. The Connection Info dialog 
appears. 

 

The following information is displayed about the current connection: 

Connection 
information 

Description 

Device Name The name of your Dominion or IP-Reach 
device. 

IP Address The IP Address of your Dominion or IP-Reach 
device. 

Port The KVM Communication TCP/IP Port used to 
access the target device. 

Data In/Second Data rate in. 
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Connection 
information 

Description 

Data Out/Second Data rate out. 

FPS The frames per second transmitted for video. 

Connect Time The duration of the connect time. 

Horizontal 
Resolution 

The page resolution horizontally. 

Vertical Resolution The page resolution vertically. 

Refresh Rate How often the page is refreshed. 

Protocol Version The RFB Protocol version. 

 To copy this information: 

• Click Copy to Clipboard in the Connection Info dialog. The 
information is now available to be pasted into the program of your 
choice. 

 

Connect to a Remote KVM Console 

Once you establish a connection with a Raritan IP-Reach or Dominion 
device, that unit's icon in the navigator expands to display all ports 
enabled for remote access. 
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Choose one of the following options to establish a remote KVM console 
connection: 

• Double-click on the KVM port you want to control. This method 
closes any previous connection before connecting to the new port. 

• Right-click on the port and select Switch from the shortcut menu. 
This method closes any previous connection before connecting to the 
new port. 

• Right-click on the port and select New Connection from the shortcut 
menu. This method allows you to connect to the selected port 
without closing any previous connections and create a new 
connection if the device supports multiple concurrent connections. 

Once connected, Raritan KVM over IP devices display real-time video 
output of the target server (this video is compressed and encrypted 
according to the configuration settings specified by the Administrator). 
You now have complete, low-level control of the KVM console as if you 
were physically located next to the server. 

• To close a connection, right-click on the connected device and click 
Disconnect. 

• To exit completely, on Connection > Exit. 
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Window Layout 

MPC Interface 

MPC functions are grouped into six general sections on the page. As a 
standalone product or using a web browser, the MPC window contains 
these main sections. 

 
 



Operation 
 

66
 

RRC Interface 

The RRC window is almost identical to the MPC window. 
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Navigator 

The navigator provides a tree view of every known Raritan device. From 
this panel, you can access all Raritan networked devices for which a 
connection profile exists and/or all Raritan devices automatically 
identified on the network. 

Note: Automatic Raritan device identification uses the UDP protocol and 
will typically identify all Raritan devices on your subnet. Network 
administrators rarely allow UDP broadcasts to function outside of a 
subnet. Automatic Raritan device identification will find only those 
Raritan devices that are configured to use the default TCP Port (5000) or 
another broadcast port, which is defined on the Advanced tab of the 
Options dialog (select Tools > Options to access the Options dialog in 
MPC and RRC). 
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Devices 

In MPC, devices are named according to the Manager Name field on the 
Manager's Network Configuration page. Dominion devices are named 
according to the Device Name field on the Dominion Console Network 
Settings page. 

In RRC, profiled devices are listed in the Navigator according to the data 
in the Description field of the device's profile. Automatically-identified 
devices will be identified according to the name assigned to them in that 
device's network configuration setting. 

Device Ports 

For each device to which you are connected, you are able to expand the 
tree associated with it to see each device port to which you have access. 
Ports with a green icon indicate that you are connected to that port. The 
port that is bolded in the Navigator indicates that it is the port currently 
displayed (active) in the remote desktop area of the application. 

If no name is assigned to a port, by default it is listed as 'Unnamed' in the 
Navigator. So, if you create a port and do not provide a name for it or if 
you delete an existing port's name, it will be use 'Unnamed' when you 
reconnect to the device. 

If all device ports to which you are connecting are already occupied, an 
alert message appears and you must wait until one of the ports is 
available in order to connect. 
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Navigator Icons 

Each device in the Navigator is assigned two icons. One icon represents 
the device's connection profile and the other icon represents its network 
status. A connection profile is generally created by a user in order to 
store personalized information about specific devices (see Creating 
Profiles (on page 53) for additional information). The connection status 
indicates the current status of the device. 

Device Connection Profile Icons (Left Icon) 

Icon Description 

 
Profiled - A network connection profile exists for this 
device. 

 
Modem Profile - A modem connection profile exists for 
this device. 

 
Not Profiled - The device was found on the network 
but a connection profile does not exist for it. 

Device Network Status Icons (Right Icon) 

Icon Description 

 
Connected (green) - You are currently authenticated 
and connected to this device. 

 
Available (black) - This device is currently available on 
the network but you are not currently connected to it. 

 

Unavailable - A profile exists for this device but it is 
not currently available on the network. (Note that all 
devices to which you are not currently connected and 
that have modem profiles will use this icon.) 

Port Connection Status Icons 

For each server port listed in the Navigator, the following icons can be 
associated with it depending on its status: 

Icon Description 

  Connected 

 Available for connection. 

 
Unavailable (either no device is connected or access is 
blocked). 
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Icon Description 

 
In use by another user (may be unavailable depending 
on permissions). 

 
 

Customizing the Navigator 

Navigator Customization 

Use specific tools in the Toolbar to customize some Navigator attributes: 

Icon Description 

 
Display/Hide Navigator. You can also select Navigator 
in the View menu to toggle between displaying and 
hiding the Navigator. 

 
Refresh Navigator. Updates the device status 
information displayed in the Navigator. 

 

Browse Discovered Devices. When enabled, Show 
Discovered Devices will display devices that are “not 
profiled” but have been found on the network. This 
option can also be enabled by selecting View > Show > 
Discovered Devices. 

Note: The Browse Discovered Devices option is the 
only method of connecting to a Raritan device 
configured to use a DHCP IP address. 

 
 

MPC Navigator Tabs 

MPC tabs at the base of its Navigator pane. These tabs allow you to 
change how you display devices. 

Click the View By Name tab to sort the list alphabetically by name or 
click the View By IP tab to sort the list numerically by IP address. 

 

Please note that these tabs are available only in the MPC interface. 
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Display and Sorting Options 

To better organize your view of all ports, use the Show and Sort options 
in the View menu. Note that you do not need an open connection to a 
target to show and sort targets in the Navigation panel. 

Showing Ports 

• Discovered Devices: Shows or hides discovered devices from the 
Navigator view. You will not see broadcast messages when this 
option is disabled (not selected). 

• Unassigned Channels: Shows or hides channels with no assigned 
targets. Note that the default for Generation 1 (G1) devices is to 
show unassigned channels (option is enabled), whereas the default is 
to hide unassigned channels (option is disabled) for Generation 2 
(G2) devices. 

• Tools: Shows or hides the Admin and Diagnostic ports. 
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Note: These settings are saved from session to session. 

Sorting Ports 

Use the Sort options on the View menu to organize port information. 
You are able to sort ports by channel number, channel name, or channel 
status. 

  

Channel Number: When sorted by channel (View > Sort > Channel), 
ports are listed numerically. 
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Name: When sorted by name (View > Sort > Name), port names are 
sorted alphanumerically within each group. 
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Status: When sorted by status (View > Sort > Status), ports are sorted in 
the following order: 

• Active Channels 

• Busy Channels 

• Available Devices 

• Unavailable Devices 
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Toolbars 

Standard Toolbar 

The Standard toolbar provides one-click access to the most frequently-
used commands.  

 To display the Standard toolbar: 

• Select View > Standard Toolbar. 

Following is a list of the buttons in the standard toolbar as well as a 
description of the action performed once the buttons are selected. 
Additionally, if there are menu options or shortcut menu options that 
will perform the same task, they are listed, too. 

Button Button 
Name 

Description 

 New Profile 

Creates a new Navigator entry for a 
Raritan device.  

Same result as selecting Connection > New 
Profile in the menu. 

 
Connection 
Properties 

Opens the Modify Connection Properties 
dialog from which you can manually 
adjust bandwidth options (such as 
connection speed, color depth, and so 
forth).  

Same as selecting Connection > Properties 
or selecting Connection Properties on the 
shortcut menu, which is opened by 
pressing Ctrl+Left Alt+M. 

 Video Settings

Opens the Video Settings dialog, allowing 
you to manually adjust video conversion 
parameters.  

Same as selecting Video > Video Settings 
or selecting Video Settings on the shortcut 
menu, which is opened by pressing 
Ctrl+Left Alt+M. 

 
Color 
Calibration 

Adjusts color settings to reduce excess 
color noise.  

Same as selecting Video > Color Calibrate. 
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Button Button 
Name 

Description 

 
Synchronize 
Mouse 

In dual-mouse mode, forces realignment of 
the target server mouse pointer with the 
mouse pointer.  

Same as selecting Mouse > Synchronize 
Mouse or selecting Synchronize Mouse on 
the shortcut menu, which is opened by 
pressing Ctrl+Left Alt+M. 

 
Refresh 
Screen 

Forces a refresh of the video screen.  

Same as selecting Video > Refresh Screen 
or selecting Refresh Screen on the shortcut 
menu, which is opened by pressing 
Ctrl+Left Alt+M. 

 
Auto-sense 
Video Settings

Forces a refresh of the video settings 
(resolution, refresh rate).  

Same as selecting Video > Auto-sense 
Video Settings. 

 
Enter On-
Screen Menu 

Not applicable for IP-Reach or Dominion. 
Used by the application with other Raritan 
products.  

Same as selecting Keyboard > Enter On-
Screen Menu. 

 
Exit On-
Screen Menu 

Not applicable for IP-Reach or Dominion. 
Used by the application with other Raritan 
products.  

Alternatively, select Esc on the keyboard. 
Same as selecting Keyboard > Exit On-
Screen Menu. 

 
Send 
Ctrl+Alt+Del 

Sends a Ctrl+Alt+Del hot key combination 
to the target server.  

Same as selecting Keyboard > Send 
Ctrl+Alt+Del. 
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Button Button 
Name 

Description 

 
Single Cursor 
Mode 

Starts Single Cursor mode in which the 
local mouse pointer no longer appears on-
screen.  

Same as selecting Mouse > Single Cursor 
Mode. Press Ctrl+Alt+X to exit this mode. 
Alternatively, select Single/Double Cursor 
from the shortcut menu, which is opened 
by pressing Ctrl+Left Alt+M. 

 
Full Screen 
Mode 

Maximizes the screen real estate to view 
the target server desktop. 

Same as selecting View > Target Screen 
Resolution (in MPC) or Full Screen (in 
RRC). Alternatively, press Ctrl+Left Alt+M 
to open the shortcut menu and then select 
Full/Normal Screen or press the F key on 
your keyboard. 

 Scaling 

Increases or reduces the target video size 
so you can view the entire contents of the 
target server window without using the 
scroll bar. 

 
Show/Hide 
Navigator 

Toggles the Navigator panel between 
visible and hidden.  

Same as selecting View > Navigator. 

 
Refresh 
Navigator 

Forces a refresh of the data displayed in 
the Navigator.  

 

Show/Hide 
Browse All 
Devices 

Toggles between displaying and not 
displaying Raritan devices in the 
Navigator that are automatically identified 
on the network and that do not have 
preconfigured profiles associated with 
them.  

 About 
Displays the application version 
information.  

Same as selecting Help in the menu bar. 
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Connected Server(s) Toolbar 

The Connected Server(s) toolbar is comprised of a button for each 
connected target server port, thus enabling quick access to connected 
targets. When you connect to a port, a button corresponding to that port 
is added to the toolbar and labeled with the name of the port. 
Conversely, when you disconnect from a port, the corresponding button 
is removed from the toolbar. When a Raritan device is disconnected, all 
of the buttons corresponding to the ports of that device are removed 
from the toolbar. 

Note: The Connected Server(s) Toolbar does not appear in Single Mouse 
mode. 

By default, the Connected Server(s) toolbar is enabled (visible). To 
disable it, deselect Connected Server(s) Toolbar in the View menu.  
Buttons corresponding to windows that do not support full screen mode 
are not shown in the toolbar. For example, serial ports, generation one 
(G1) admin ports, and G1 diagnostic ports will not be displayed in the 
toolbar in full screen mode. 

While in full screen mode, you are able to view the Connected Server(s) 
toolbar by hovering your mouse over the top of the screen. To use this 
feature, the Connected Servers Toolbar option must be selected in the 
View menu.  

 

 To display the Connected Server(s) toolbar (when not 
already visible): 

• Select View > Connected Server(s) Toolbar. 

 To view the window for a target server: 

• Click the button that corresponds to the appropriate connected 
target server you want to view. The window for the corresponding 
target server is displayed and the button for the selected port is 
highlighted. In full screen mode, note that this action is window 
swapping, not video switching. 

Note: When you click a button that is already highlighted, the 
corresponding window is minimized. If you click that button again, the 
window is brought forward and maximized. 
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Status Bar 

The status bar displays session information about your connection to a 
Raritan IP-Reach or Dominion device. This information includes: 

 

Diagra
m key 

Session 
information 

Description 

 
Video sensing 
status/path 
indicator 

Indicates when video sensing occurs 
during connections to target KVM server 
ports. 

 
Bandwidth 
usage indicator 

Indicates how much of your total 
available bandwidth is currently being 
used. The connection speed setting 
determines total available bandwidth.  

This setting is defined on the 
Compression tab of the Connection 
Properties dialog, which is accessed by 
selecting Connection > Properties, or 
pressing Ctrl+Left Alt+ M and then 
selecting Connection Properties. 

 
Security 
indicator 

Indicates whether the current remote 
connection is protected by encryption. 
Encryption requirements are set during 
IP-Reach or Dominion configuration of 
your Raritan KVM over IP device.  

When a Raritan IP-Reach or Dominion 
device is configured for no encryption or 
SSL authentication, the Security Indicator 
is represented on the status bar by an 
open lock icon.  

When SSL authentication, data 
encryption, or SSL encryption is applied, 
the security indicator is represented on 
the status bar by a closed lock. 
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Diagra
m key 

Session 
information 

Description 

 
Concurrent 
connections 
indicator 

Indicates that multiple remote users are 
currently connected to the same IP-Reach 
or Dominion target server on the device. 

One icon indicates a single user is 
connected and two icons indicates two or 
more users are connected.  

Concurrent connection ability can be set 
globally under PC share mode on the 
Manager Security Settings page or set per 
individual user in the Concurrent Access 
Mode setting on the KX Manager User 
Account Settings page. For Dominion KX 
II, concurrent connection ability can be set 
using the PC Share Mode option in the 
Dominion KX II Security Settings page: 
PC-Share permits concurrent access and 
Private limits server access to one user at 
a time. 

 
Lock key 
indicators 

Indicates the status of the current target 
KVM Server, in respect to the activation 
of the Caps-Lock, Num-Lock, and Scroll-
Lock keys. If these keys are enabled on 
the target server being viewed, this 
affirmative status will be reflected on the 
status bar. 

Note: If a light is used on your keyboard to indicate the Scroll Lock, Num 
Lock, and Caps Lock key is active, it may or may not be in sync with the 
lock key indicator status displayed on the RRC status bar. Refer to the 
status bar as your guide if this occurs. 
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Screen Modes 

Besides a standard view, MPC and RRC provide a full screen view and a 
scaling option. These options increase the remote desktop area and make 
viewing the target video easier.  

This option it is called Full Screen mode in RRC and Target Screen 
Resolution mode in RRC. In both applications, you can click the Full 

Screen button  on the toolbar to activate Full Screen mode or use the 
Ctrl+Left Alt+M+F hot key combination to enable it. 
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MPC Target Screen Resolution Mode 

Target Screen Resolution mode provides you with the ability to view the 
target server desktop in full screen mode, which removes all toolbars 
from view.  

Activate Target Screen Resolution mode once you are connected to a 
target by doing one of the following: 

• Click the Full Screen icon  in the toolbar and then click OK in the 
confirmation message that appears. 

• Click View > Target Screen Resolution and then click OK in the 
confirmation message that appears. 

• Press Ctrl+Left Alt+M to open the shortcut menu. Next, press the F 
key on your keyboard or use your mouse to select Full/Normal 
Screen. Click OK in the confirmation message that appears. 
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To exit full screen mode, use the shortcut menu or click the Close icon 

 that appears at the top right of the page when you hover your mouse 
along the top of the screen. 

While in Target Screen Resolution mode, you are able to view the 
Connect Server toolbar by hovering your mouse over the top of the 
screen. To use this feature, the Connected Servers Toolbar option must 
be selected in the View menu.  

Additionally, while in Target Screen mode, your monitor's resolution 
may be adjusted to match the resolution of the target server (provided 
your graphics system supports it). If your graphics system does not 
support the resolution of the target system, you will be unable to activate 
full screen mode and a message will appear requesting that you change 
your video resolutions first. 

Tip: To view the video resolutions your system supports in a Windows 
environment, access your computer's Control Panel from the Windows 
Start menu, double-click on Display, and click on the Settings tab. 

 

Note: The Ctrl+Left Alt+M key combination does not work for certain 
target servers if you are running JRE 1.5.0_01. To return from full page 
mode, use Alt+Tab and select MPC. 
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RRC Full Screen Mode 

Full screen mode removes the surrounding RRC graphical interface and 
your local desktop area, filling your screen with the video from the 
target server. Your screen's resolution will be adjusted to match the 
resolution of the target server (provided your graphics system supports 
it). If your graphics system does not support the resolution of the target 
system, you will be unable to activate full screen mode and a message 
will appear requesting that you change your video resolutions first. 

Note: To view the video resolutions your system supports in a Windows 
environment, access your computer's Control Panel from the Windows 
Start menu, double-click on Display, and click on the Settings tab. 

Activate full screen mode in one of the following ways once you are 
connected to a target: 

• Click the Full Screen icon  in the toolbar and then click OK in the 
confirmation message that appears. 

• Click View > Full Screen and then click OK in the confirmation 
message that appears. 

• Press Ctrl+Left Alt+M to open the shortcut menu. Next, press the F 
key on your keyboard or use your mouse to select Full/Normal 
Screen. Click OK in the confirmation message that appears.  
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Scaling 

Scaling your target window size allows you to view the entire contents 
of the target server window. This feature increases or reduces the size of 
the target video to fit the window size and maintains the aspect ratio. 
This allows you to see the entire target server desktop while in standard 
view. 

To activate Scale Video mode, do one of the following: 

• Click View > Scale Video. 
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• Click the Scaling button  on the toolbar. 

To exit this mode and return the target window to its previous size, 
deselect Scale Video on the View menu or click the Scaling button once 
again. 

 

Note: Enabling Scale Video will scale the complete target video image to 
fit the remote desktop area as it grows or shrinks. You can combine this 
setting with target screen resolution for a full page affect on targets with 
a higher resolution than your desktop. 
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RRC Scaling (Shared) 

Scaling your target window size allows you to view the entire contents 
of the target server window. This feature increases or reduces the size of 
the target video to fit the window size and maintains the aspect ratio. 
This allows you to see the entire target server desktop while in standard 
view. 

To activate Scale Video mode, do one of the following: 

• Click View > Scale. 

 

 

• Click the Scaling button  on the toolbar.  

To exit this mode and return the target window to its previous size, click 
Scale on the View menu or click the Scaling button once again. 

Note: Enabling Scale Video will scale the complete target video image to 
fit the remote desktop area as it grows or shrinks. You can combine this 
setting with target screen resolution for a full page affect on targets with 
a higher resolution than your desktop. 
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Auto-Scroll 

The auto-scroll feature automatically scrolls the video display in the 
direction of the cursor as the cursor approaches the edge of the display. 
A thin border appears around the perimeter of the remote desktop area 
to indicate the function is on. When enabled, if you see scroll bars and 
then move the cursor onto the border, the page will automatically scroll 
in the appropriate direction. 

The scroll border is activated by selecting Show Scroll Borders in the 
Options dialog, which is accessed by selecting Tools > Options.  
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Shortcut Menu 

To access the shortcut menu, use either the default keyboard 
combination of Ctrl+Left Alt+M or the keyboard combination you assign. 
See Changing the Shortcut Menu Keyboard Combination (on page 92) for 
more information.  

Execute any of the commands on the shortcut menu by either clicking 
the command in the menu or using a key combination. If you are using a 
key combination to execute a command, you will press Ctrl+Left Alt+M 
and then press the key on your keyboard that corresponds to the 
underlined letter in the shortcut menu. For example, press Ctrl+Left 
Alt+M+F to enter full screen mode.  See the table below for information 
on invoking commands from the shortcut menu using keyboard 
combinations. 

Note: You must use the Left Alt key on your keyboard when using the 
Ctrl+Left+Alt combination. 

To Press Ctrl+Left 
Alt+M+_ 

Toggle between Full/Normal screen mode* F 

Perform video autosensing** A 

Display connection information* I 

Display or set connection properties* P 

Display or set video settings* V 

Refresh the page R 

Color calibrate** C 

Synchronize mouse Y 

Change to/from single/double cursor mode S 

Send Ctrl+Alt+Del to the target system D 

Send Ctrl+Alt+M to the target system N 

Exit a dialog or menu without altering the 
keyboard state 

Esc 
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* If Full Screen mode is active, executing this command will 
automatically end Full Screen mode. 

** If Full Screen mode is active, executing this command will 
automatically end Full Screen mode only in RRC. 

TIP: If at some point you forget the keyboard combination used to open 
the shortcut menu, press Ctrl+Left Alt at the same time. The keyboard 
combination will be displayed across the bottom of the page for five 
seconds.  

 
 

Changing the Shortcut Menu Keyboard Combination 

 To change the keyboard combination that opens the 
shortcut menu used in MPC, do the following: 

1. Select Tools > Options to open the Options dialog. 

2. From the Keyboard Shortcut Menu HotKey drop-down, select the 
keyboard combination you want to use to open the shortcut menu. 

3. Click OK or Apply. 
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Once a new keyboard combination is assigned, the new combination will 
be displayed in the shortcut menu and the onscreen message that 
displays when the combination is used.  
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Keyboard Macros 

A hot key combination is a set of keystrokes that performs an action 
when pressed. For example, the hot key combination Ctrl+Alt+0 might be 
created to minimize all windows.  

A keyboard macro is a shortcut that sends a hot key combination to a 
target server. Using keyboard macros ensures that hot key combinations 
intended to be used on the target server are sent to and interpreted only 
by the target server, and not by the computer on which MPC or RRC is 
running. 

Raritan strongly suggests the use of keyboard macros instead of hot key 
combinations since certain hot key combinations have been found not to 
work properly, depending on the platform and behavioral difference 
between the application and web browser version. Specifically, using hot 
keys can result in your own client PC intercepting the command and 
performing the action instead of sending the command to the target 
server as intended. 

 
 

Building a Keyboard Macro 

 To build a macro: 

1. On the Keyboard menu, click Keyboard Macros. 

2. When the Keyboard Macros dialog appears, click Add. The Add 
Keyboard Macro dialog then appears. 

3. Build the keyboard macro by editing the fields in the dialog. 

a. Type a name in the Keyboard Macro Name field. This name will 
appear in the Keyboard menu after it is created.  

b. From the Hot-Key Combination field, select a keyboard 
combination from the drop-down list. This allows you to execute 
the macro with a predefined keystroke. Optional 

c. In the Keys to Press drop-down list, select each key you would 
like to use to emulate keystrokes. Select the keys in the order by 
which they are to be pressed. After each selection, select Press 
Key.  

As each key is selected, it will appear in the Keys to Release field. 
For example, select the Windows key and the letter D key. When 
these keys are selected, the macro will be executed. Add a key 
release attribute to the macro if needed (see next step). 
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d. In the Keys to Release field, you can define the keys you want 
released in order to run the macro.  For example, specify that the 
keys to be pressed must also be released in order for the macro 
to be executed. Select the keys in the order by which they are to 
be released. Click Release Key after each selection. 

e. Review the Macro Sequence field to be sure the macro sequence 
is defined correctly. The contents of this field are automatically 
generated and are based on the selections made in the Keys to 
Press and Keys to Release fields. To remove a step in the 
sequence, select it and click Remove. To change the order of 
steps in the sequence, click on the step and then click the up or 
down arrow buttons to reorder them as needed. 
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4. Click OK to save the macro. Click Clear to clear all field and start 
over. When you click OK, the Keyboard Macros dialog appears and 
lists the new keyboard macro. 

 

5. Click Close to close the window. The macro will now appear on the 
Keyboard menu in the application. Select the new macro on the 
menu to run it or use the keystrokes you assigned to the macro. 

Note: Foreign keyboard layouts are not supported when using keyboard 
macros, except for those keys listed in the “Add Keyboard Macro” dialog 
for Japanese and Korean. 
 

Running a Keyboard Macro 

Once you have created a keyboard macro, execute it using the keyboard 
macro you assigned to it or by selecting it from the Keyboard menu. 

Run a Macro from the Menu Bar 

When you create a macro, it appears under the Keyboard menu. Execute 
the keyboard macro by clicking on its name on the Keyboard menu. 
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Run a Macro Using a Keyboard Combination 

If you assigned a keyboard combination to a macro when building it, 
you can execute the macro by pressing its assigned keystrokes. For 
example, press the keys Ctrl+Alt+0 simultaneously to minimize all 
windows on a Windows target server. 
 

Ctrl+Alt+Del Macro 

Due to its frequent use, a Ctrl+Alt+Delete macro, used to reboot the 
target computer, has been preprogrammed into MPC and RRC. Clicking 

on the Ctrl+Alt+Delete button  in the toolbar sends this key sequence 
to the server or to the KVM switch to which you are currently connected.  

In contrast, if you were to physically press the Ctrl+Alt+Del keys while 
using MPC or RRC, the command would first be intercepted by your 
own PC due to the structure of the Windows operating system, instead 
of sending the key sequence to the target server as intended. 
 

Common Hot Key Exceptions for MPC 

The following common hot key combinations are not sent to the target 
system: 

Hot Key 
Combination 

Description  

Ctrl+Alt+Delete  Reboots the computer. The sequence is sent to the 
local system and the Windows Security (Task 
Manager, Shutdown, and so on) dialog is displayed. 

Ctrl+Left Alt+M Brings up the shortcut menu (on page 91).  

Print Scrn Treated locally and copies the page to the clipboard. 
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Following are limitations to specific keyboards and hot key 
combinations: 

Hot Key 
Combination 

Description 

Alt Gr Because of a limitation in the Java Runtime 
Environment (JRE), Fedora, Linux, and Solaris 
clients receive an invalid response from Alt Gr 
on United Kingdom and US International 
language keyboards.  

Fedora, Linux, and Solaris do not pick up events 
for the Alt Gr key combination for Java 1.4.2 or 
1.5. Java 1.6 appears to improve on this, although 
the keyPressed and keyReleased events for Alt 
Gr still identify it as an “unknown key code”.  

Further, a key pressed in combination with Alt 
Gr (such as on the UK keyboard Alt Gr-4, which 
is the Euro symbol), will only generate a 
keyTyped followed by a keyReleased event for 
that value without a keyPressed event. Java 1.6 
improves upon this by filling in the keyPressed 
event as well.  

Alt+SysRq+[key] Since the SysRq keyboard stroke is used by some 
operating systems as a print shortcut, the Alt + 
SysRq + [key] combination is supported only as a 
macro when using DKX with RRC and MPC to a 
Linux target.   

 
 

Common Hot Key Combinations for RRC 

The following common hot key combinations are not sent to the target 
system: 

Hot Key 
Combination 

Description  

Ctrl+Alt+Delete  Reboots the computer. The sequence is sent to the 
local system and the Windows Security (Task 
Manager, Shutdown, and so on) dialog is displayed. 
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Hot Key 
Combination 

Description  

Ctrl+Num Lock This toggles the state of the Num Lock light if the 
Num Lock state on the local system is not the same 
as the target system.  

Ctrl+Caps Lock This toggles the state of the Caps Lock light if the 
Caps Lock state of the local system is not the same 
as the target system.  

Ctrl+Scroll Lock This toggles the state of the Scroll Lock light if the 
Scroll Lock state of the local system is not the same 
as the target system.  

Ctrl+Left Alt+M Brings up the shortcut menu (on page 91).  

Print Scrn Treated locally and copies the page to the clipboard. 

Following are limitations to specific keyboards and hot key 
combinations: 

Hot Key 
Combination 

Description 

Alt+SysRq+[key] Since the SysRq keyboard stroke is used by some 
operating systems as a print shortcut, the Alt + 
SysRq + [key] combination is supported only as a 
macro when using DKX with RRC and MPC to a 
Linux target.   

 

 
 

Keyboard Type 

Specifying a Keyboard Type in MPC 

MPC will not autodetect the type of keyboard you use, so you must 
specify your keyboard type to ensure accurate keyboard mapping. 
Options include US/International, French, German, Japanese, UK 
English, Korean, Belgian, and Norwegian.  

 To specify a keyboard type: 

1. On the Tools menu, click Options. The Options dialog will appear. 
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2. Click on the Keyboard Type drop-down and select your keyboard 
type from the list. 

3. Click OK. 

 
 



 Chapter 3: Multi-Platform Client and Raritan Remote Client 
 

 
101

Windows Key in MPC 

When running MPC on a Windows JRE 1.4.2_x platform, if you press the 
Windows key   to display the Start menu, the Start menu will only 
appear on the client machine; the key is not sent to the target device. 

When running MPC on a Windows JRE 1.5.0_x platform, if you press the 
Windows key, the Start menu appears on both the client and the target 
devices. Use your mouse to manually close the Start menu if you do not 
want to use. 

Please note that if you do not close the target device's Start menu 
properly, any key that you touch on your keyboard (that has a Windows 
key combination function) will send that command to the target device. 
For example, if you press E, the target device will open a new Explorer 
window; if you press D, all target windows will be minimized so you 
can view the desktop. To close the Start menu on the target device, click 
on the Start button or click off of the Start menu. 
 

Keyboard Limitations 

Japanese Kanji Keyboards 

For Kanji keyboards, when using DCIM-USBs and MPC, the remote 
client cannot enter EISU mode by pressing the Caps Lock key (key#30). 
Local port access is not affected. You can access the DCIM-USBs using 
RRC or using the keyboard macro Shift + Caps Lock in MPC.   

Language Configuration on Linux 

Because the Sun JRE on Linux has problems generating the correct 
KeyEvents for foreign-language keyboards configured using System 
Preferences, Raritan recommends that you configure foreign keyboards 
using the methods described in the following table. 

Language Configuration method 

US Intl Default 

UK System Settings (Control Center) 

French Keyboard Indicator 

German System Settings (Control Center) 

Norwegian Keyboard Indicator 

Swedish Keyboard Indicator 

Danish Keyboard Indicator 
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Language Configuration method 

Japanese System Settings (Control Center) 

Korean System Settings (Control Center) 

Hungarian System Settings (Control Center)  

Note: The Keyboard Indicator should be used on Linux systems using 
Gnome as a desktop environment. 

 
 

Single Mouse Mode/Dual Mouse Mode 

When remotely viewing a target server that uses a mouse, you will see 
two mouse pointers on the remote desktop. When your mouse pointer 
lies within the remote desktop area, mouse movements and clicks are 
directly transmitted to the connected target server. The pointer, 
generated by the operating system on which MPC or RRC is running, 
slightly leads the target server's mouse pointer during movement. This is 
a result of digital delay. 

On fast LAN connections, you may want to disable the mouse pointer 
and view only the target server's pointer. To toggle between these two 
modes, select Single/Double Cursor on the shortcut menu to enable 
single/double cursor mode. Alternatively, click the Single Mouse Pointer 

icon  in the toolbar or click Mouse > Single Cursor Mode. 
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When in Dual Cursor mode, press Ctrl+Left Alt+M and execute the 
Synchronize Mouse shortcut to force realignment of the mouse pointers. 
If the mouse pointers still remain out of sync, click on the Auto-Sense 

Video Settings button  on the toolbar. 

Note: When in Dual Cursor mode, if the dual mouse pointers are 
synchronized but left idle for five minutes or longer, the target mouse 
pointer will automatically align itself with the upper left corner of the 
target window. Execute the Synchronize Mouse command to ensure 
local and target mouse pointer alignment. 

Single Mouse Cursor mode for Apple Mac target servers is supported for 
MPC. Select Single Mouse Cursor on the Mouse menu in MPC to enter 
this mode.  While in this mode, the cursor will remain in the video 
window for the Mac Server.  To exit, open the shortcut menu and press S 
on the keyboard. 
 

Automatic Mouse Synchronization 

When in Dual Cursor mode, the system will automatically align the 
mouse pointers when the cursor is inactive for 15 seconds. Enable this 
feature by selecting Options from the Tools menu and clicking on the 
checkbox before Auto-Sync mouse in two-cursor mode. 
 

Mouse Synchronization Options 

In addition to synchronizing mouse pointers or toggling between single 
and double cursor mode, the Mouse menu provides three options for 
synching pointers when in Dual Cursor mode: 

Menu 
Option 

Description 

Absolute When connected to selected Dominion devices and 
targets with USB ports, the application will use 
absolute coordinates to keep the pointers in sync. 

Note: The absolute mouse setting requires a USB 
target system and is the recommended mouse setting 
for KX101. 
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Menu 
Option 

Description 

Intelligent Under certain conditions, the application can detect 
the target mouse settings and synchronize the mouse 
pointers accordingly, accelerating the mouse on the 
target device. See Intelligent Mouse Synchronization 
Conditions (see "Intelligent Mouse Synchronization" 
on page 105) for more details. 

Standard This is the standard mouse synchronization 
algorithm. For the proper target mouse settings, see 
the user guide of your Raritan device. 

Please note that the intelligent and standard mouse are only available to 
users working on Dominion devices. 
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Intelligent Mouse Synchronization 

The Intelligent Mouse Synchronization command, available on the 
Mouse menu, automatically synchronizes mouse cursors during 
moments of inactivity. For this to work properly, however, the following 
conditions must be met: 

• The active desktop should be disabled on the target. 

• No windows should appear in the top left corner of the target page. 

• There should not be an animated background in the top left corner of 
the target page. 

• The target mouse cursor shape should be normal and not animated. 

• The target mouse speeds should not be set to very slow or very high 
values. 

• Advanced mouse properties such as “Enhanced pointer precision" or 
“Snap mouse to default button in dialogs”  should be disabled. 

• Choose “Best Possible Video Mode” in the Video Settings window. 

• The edges of the target video should be clearly visible (that is, a 
black border should be visible between the target desktop and the 
remote KVM console window when you scroll to an edge of the 
target video image). 

After autosensing the target video, manually initiate mouse 
synchronization by clicking the Synchronize Mouse button on the 
toolbar. This also applies when the resolution of the target changes if the 
mouse cursors start to desync from each other. 

If intelligent mouse synchronization fails, this mode will revert to 
standard mouse synchronization behavior. 

Please note that mouse configurations will vary on different target 
operating systems. Consult your OS guidelines for further details. Also 
note that intelligent mouse synchronization does not work with UNIX 
targets. 
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Connection and Video Properties 

The IP-Reach and Dominion dynamic video compression algorithms 
maintain KVM console usability under varying bandwidth constraints. 
The IP-Reach and Dominion devices optimize KVM output not only for 
LAN use, but also for WAN and dial-up use. These units can also control 
color depth and limit video output, offering an optimal balance between 
video quality and system responsiveness for any bandwidth constraint. 

The parameters discussed in this section can be optimized in the 
Connection Properties dialog and Video Settings dialog to suit your 
requirements for different operating environments. 
 

MPC Connection and Video Properties 

MPC Connections 

 To set connection properties in MPC: 

1. Select Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 
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2. Connection Speed: Use this setting to manually adjust the connection 
speed to accommodate bandwidth constraints. IP-Reach and 
Dominion can automatically detect available bandwidth and not 
limit bandwidth use, but you can also adjust this usage according to 
your needs. Depending on the Raritan device in use, different 
options may be available. 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 

 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

3. Color Depth: IP-Reach and Dominion can dynamically adapt the 
color depth transmitted to remote users in order to maximize 
usability in all bandwidths. Select from among the options in the 
drop-down list (depending on the Raritan device in use, different 
options may be available): 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 

 For information on Progressive Update, Internet Flow Control, 
Smoothing (15-bit mode only), and Frames per second (MPC 
only), please refer to Connection Profiles (on page 53). 
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Important: For most administrative tasks (server monitoring, 
reconfiguring, etc.), administrators do not require the full 24-bit or 
32-bit color spectrum made available by most video graphics cards. 
Attempting to transmit such high color depths wastes network 
bandwidth. 

4. Click OK to change the Connection Properties. 
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MPC Video Properties 

Refreshing Video Settings 

Video settings can be refreshed in several ways: 

• Using Video > Refresh Screen. 

• Directing IP-Reach or Dominion to automatically detect the video 
settings (Video > Auto-sense Video Settings). 

• Using the Color Calibration (on page 124) command to calibrate the 
video, thereby enhancing the colors that are displayed. 

• Changing the settings from the Video Settings dialog. 

Change RRC Video Settings 

 To change the video settings: 

1. Select Video > Video Settings or click the Video Settings button  
in the toolbar. The Settings dialog appears and you can update the 
desired settings. 
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2. Noise Filter: IP Reach and Dominion can filter out the electrical 
interference of video output from graphics cards. This feature 
optimizes picture quality and reduces bandwidth. Higher settings 
transmit variant pixels only if a large color variation exists in 
comparison to the neighboring pixels. However, setting the 
threshold too high can result in the unintentional filtering of desired 
page changes. Lower settings transmit most pixel changes. Setting 
this threshold too low can result in higher bandwidth use. 

Note: Lower Noise Filter settings (approximately 1 to 4) are 
recommended. Although higher settings will stop the needless 
transmission of false color variations, true and intentional small 
changes to a video image may not be transmitted. 

3. PLL Settings: If the video image looks extremely blurry or 
unfocused, the PLL settings for clock and phase can be adjusted until 
a better image appears on the active target server. 

Warning: Please exercise caution when changing the clock and phase 
settings since doing so may result in lost or distorted video and you 
may not be able to return to the previous state. Contact Raritan 
Technical Support before making any changes. 

 Clock: Controls how quickly video pixels are displayed across 
the video page. Changes made to clock settings cause the video 
image to stretch or shrink horizontally. Odd number settings are 
recommended. Under most circumstances this setting should not 
be changed because the autodetect is usually quite accurate. 

 Phase: Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

4. Color Settings: These settings control the brightness, contrast, and 
positioning of the target server display. 

 Brightness Red: Controls the brightness of the red signal; range is 
0 - 127. 

 Brightness Green: Controls the brightness of the green signal; 
range is 0 - 127. 

 Brightness Blue: Controls the brightness of the blue signal; range 
is 0 - 127. 

 Contrast Red: Controls the red signal contrast; range is 0 - 255. 

 Contrast Green: Controls the green signal contrast; range is 0 - 
255. 

 Contrast Blue: Controls the blue signal contrast; range is 0 - 255. 
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 Horizontal Offset: Controls the horizontal positioning of the 
target server display on your monitor; range is 0 - 512. 

 Vertical Offset: Controls the vertical positioning of the target 
server display on your monitor; range is 0 - 128. 

5. To preview the change prior to making the selection, check the 
Preview checkbox. 

6. Check the Automatic Color Calibration checkbox to enable this 
feature. 

7. Select the video sensing mode: 

 Best possible video mode: IP-Reach or Dominion will perform 
the full Auto Sense process when switching targets or target 
resolutions. Selecting this option calibrates the video for the best 
image quality. 

 Quick sense video mode: Selecting this option will cause IP-
Reach or Dominion to use a quick video Auto Sense in order to 
show the target's video sooner. This option is especially useful 
for entering a target server's BIOS configuration right after a 
reboot. 

8. Click OK to change the Video Settings. 

Note: Some Sun background screens, such as screens with very dark 
borders, may not center precisely on certain Sun servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
page. 

Video Settings (Generation 1 Equipment Only) 

1. Select Video > Video Settings or click the Video Settings button  
in the toolbar. The Settings dialog appears. 
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These settings can be refreshed using the Color Calibration 
command, described in the next section, by manually forcing IP-
Reach or Dominion to auto-detect the video settings (on the Video 
menu, click Auto-sense Video Settings), or by changing the settings 
in this page. After you change a value, click Apply to test the setting. 

2. Noise Filter: IP-Reach or Dominion can filter out electrical 
interference of video output from graphics cards. This feature 
optimizes picture quality and reduced used bandwidth. 

Note: The default Noise Filter is 4; Raritan recommends that you 
lower this value to 0 (zero). 
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 Higher: Noise Filter settings instruct IP-Reach or Dominion to 
transmit a variant pixel of video only if a large color variation 
exists in comparison to its neighbors. However, setting the 
threshold too high can result in the unintentional filtering of 
desired page changes. 

 Lower: Noise Filter settings instruct IP-Reach or Dominion to 
transmit most pixel changes. Setting this threshold too low can 
result in higher bandwidth use. 

Note: Lower Noise Filter settings (approximately 1 to 4) are 
recommended. Although higher settings will stop the needless 
transmission of false color variations, true and intentional small 
changes to a video image may not be transmitted. 

3. Analog-to-Digital Settings: The following parameters are best left to 
IP-Reach or Dominion to automatically detect (on the RRC Menu 
Bar, select Video > Auto-sense Video Settings), but a brief description 
of each is included here.  

4. PLL Settings: If the video image looks extremely blurry or 
unfocused, the PLL Settings for clock and phase can be adjusted 
until a better image appears on the active target server. 

 Clock: Horizontal sync divider to produce pixel clock. Controls 
how quickly video pixels are displayed across the video page. 
Changes made to clock settings cause the video image to stretch 
or shrink horizontally. Odd number settings are recommended. 

 Phase: Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that results in the best video image for 
the active target server. 

5. Color Settings: Gain control can be thought of as contrast 
adjustment. Offset control can be thought of as brightness 
adjustment. 

 Red Gain: Controls the amplification of the red signal. 

 Red Offset: Controls the bias of the red signal. 

 Green Gain: Controls the amplification of the green signal. 

 Green Offset: Controls the bias of the green signal. 

 Blue Gain: Controls the amplification of the blue signal. 

 Blue Offset: Controls the bias of the blue signal. 
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 Link Color Controls: Makes all gain slide adjusters move in 
unison when any one color's gain slide is moved and all the 
offset slide adjusters move in unison when any one color's offset 
slide is moved. 

6. Select the video sensing option you would like to apply. 

 Best possible video mode: IP-Reach or Dominion will perform 
the full Auto Sense process when switching targets or target 
resolutions. Selecting this radio button will cause IP-Reach or 
Dominion to calibrate the video for the best image quality.  

 Quick sense video mode: Selecting this radio button will cause 
IP-Reach or Dominion to use a quick video Auto Sense in order 
to show the target's video sooner. This option is especially useful 
for entering a target server's BIOS configuration right after a 
reboot. 

7. Click OK to set Video Settings. 

Note: Some SUN background screens, such as screens with very dark 
borders, may not center precisely on certain SUN servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
page. 

Video Settings (KX101 Only) 
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Raritan's Dominion KX101 Color Settings window varies from those of 
other Dominion units. 

1. In the Color Settings panel, adjust the following options: 

 Brightness: Controls the backlight on your page. 

 Red Contrast: Controls the level of red tone on your page. 

 Green Contrast: Controls the level green tone on your page. 

 Blue Contrast: Controls the level of blue tone on your page. 

 Click on the Link Color Controls check box to make all above 
slide adjusters move in unison when any one option is moved. 

2. Click OK when finished. 
 

RRC Connection and Video Properties 

RRC Connections 

 To set connection properties in RRC: 

1. Select Connection > Properties or click the Connection Properties 

button  in the toolbar. Update the settings in the Compression 
tab. 
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2. Connection Speed: Use this setting to manually adjust the connection 
speed to accommodate bandwidth constraints. IP-Reach and 
Dominion can automatically detect available bandwidth and not 
limit bandwidth use, but you can also adjust this usage according to 
your needs. Depending on the Raritan device in use, different 
options may be available. 

 Auto Detect 

 1G Ethernet 

 100mb Ethernet 

 10mb Ethernet 

 1.5mb (Max DSL/T1) 

 1mb (Fast DSL/T1) 

 512 kb (Medium DSL/T1) 

 384 kb (Slow DSL/T1) 

 256 kb (Cable) 

 128 kb (Dual ISDN) 

 56 kb (ISP Modem) 

 33 kb (Fast Modem) 

 24 kb (Slow Modem) 

3. Color Depth: IP-Reach and Dominion can dynamically adapt the 
color depth transmitted to remote users in order to maximize 
usability in all bandwidths. Select from among the options in the 
drop-down list (depending on the Raritan device in use, different 
options may be available): 

 15-bit RGB Color 

 8-bit RGB Color 

 4-bit Color 

 4-bit Gray 

 3-bit Gray 

 2-bit Gray 

 Black and White 

 For information about the Progressive Update, Internet Flow 
Control, and Smoothing (15-bit mode only), please refer to 
Connection Profiles (on page 53). 
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Important: For most administrative tasks (server monitoring, 
reconfiguring, etc.), administrators do not require the full 24-bit or 
32-bit color spectrum made available by most video graphics cards. 
Attempting to transmit such high color depths wastes network 
bandwidth. 

4. Click OK to change the Connection Properties or Cancel to close the 
window without saving changes. 
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RRC Video Properties 

Refresh Video Settings 

Video settings can be refreshed in several ways: 

• Using Video > Refresh Screen. 

• Directing IP-Reach or Dominion to automatically detect the video 
settings (Video > Auto-sense Video Settings). 

• Using the Color Calibration (on page 124) command to calibrate the 
video, thereby enhancing the colors that are displayed. 

• Changing the settings from the Video Settings page. 

Change RRC Video Settings 

 To change the video settings: 

1. Select Video > Video Settings or click the Video Settings button  
in the toolbar. The Settings dialog appears. Update the desired 
settings. 
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2. Noise Filter: IP Reach and Dominion can filter out the electrical 
interference of video output from graphics cards. This feature 
optimizes picture quality and reduces bandwidth. Higher settings 
transmit variant pixels only if a large color variation exists in 
comparison to the neighboring pixels. However, setting the 
threshold too high can result in the unintentional filtering of desired 
page changes. Lower settings transmit most pixel changes. Setting 
this threshold too low can result in higher bandwidth use. 

Note: Lower Noise Filter settings (approximately 1 to 4) are 
recommended. Although higher settings will stop the needless 
transmission of false color variations, true and intentional small 
changes to a video image may not be transmitted. 

3. PLL Settings: If the video image looks extremely blurry or 
unfocused, the PLL settings for clock and phase can be adjusted until 
a better image appears on the active target server. 

Warning: Please exercise caution when changing the clock and phase 
settings since doing so may result in lost or distorted video and you 
may not be able to return to the previous state. Contact Raritan 
Technical Support before making any changes. 

 Clock: Controls how quickly video pixels are displayed across 
the video page. Changes made to clock settings cause the video 
image to stretch or shrink horizontally. Odd number settings are 
recommended. Under most circumstances this setting should not 
be changed because the autodetect is usually quite accurate. 

 Phase: Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image for 
the active target server. 

4. Color Settings: These settings control the brightness, contrast, and 
positioning of the target server display. 

 Brightness Red: Controls the brightness of the red signal; range is 
0 - 127. 

 Brightness Green: Controls the brightness of the green signal; 
range is 0 - 127. 

 Brightness Blue: Controls the brightness of the blue signal; range 
is 0 - 127. 

 Contrast Red: Controls the red signal contrast; range is 0 - 255. 

 Contrast Green: Controls the green signal contrast; range is 0 - 
255. 

 Contrast Blue: Controls the blue signal contrast; range is 0 - 255. 
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 Horizontal Offset: Controls the horizontal positioning of the 
target server display on your monitor; range is 0 - 512. 

 Vertical Offset: Controls the vertical positioning of the target 
server display on your monitor; range is 0 - 128. 

5. To preview the change prior to making the selection, check the 
Preview checkbox. 

6. Check the Automatic Color Calibration checkbox to enable this 
feature. 

7. Video Sensing: Select the video sensing mode: 

 Best possible video mode: IP-Reach or Dominion will perform 
the full Auto Sense process when switching targets or target 
resolutions. Selecting this option calibrates the video for the best 
image quality. 

 Quick sense video mode: Selecting this option will cause IP-
Reach or Dominion to use a quick video Auto Sense in order to 
show the target's video sooner. This option is especially useful 
for entering a target server's BIOS configuration right after a 
reboot. 

8. Click OK to change the Video Settings. 

Note: Some Sun background screens, such as screens with very dark 
borders, may not center precisely on certain Sun servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
page. 

Video Settings (Generation 1 Equipment Only) 

1. Select Video > Video Settings or click the Video Settings button  
in the toolbar. The Settings dialog appears. 
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These settings can be refreshed using the Color Calibration 
command, described in the next section, by manually forcing IP-
Reach or Dominion to auto-detect the video settings (on the Video 
menu, click Auto-sense Video Settings), or by changing the settings 
in this page. After you change a value, click Apply to test the setting. 

2. Noise Filter: IP-Reach or Dominion can filter out electrical 
interference of video output from graphics cards. This feature 
optimizes picture quality and reduced used bandwidth. 

Note: The default Noise Filter is 4; Raritan recommends that you 
lower this value to 0 (zero). 
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 Higher: Noise Filter settings instruct IP-Reach or Dominion to 
transmit a variant pixel of video only if a large color variation 
exists in comparison to its neighbors. However, setting the 
threshold too high can result in the unintentional filtering of 
desired page changes. 

 Lower: Noise Filter settings instruct IP-Reach or Dominion to 
transmit most pixel changes. Setting this threshold too low can 
result in higher bandwidth use. 

Note: Lower Noise Filter settings (approximately 1 to 4) are 
recommended. Although higher settings will stop the needless 
transmission of false color variations, true and intentional small 
changes to a video image may not be transmitted. 

3. Analog-to-Digital Settings: The following parameters are best left to 
IP-Reach or Dominion to automatically detect (on the RRC Menu 
Bar, select Video > Auto-sense Video Settings), but a brief description 
of each is included here.  

4. PLL Settings: If the video image looks extremely blurry or 
unfocused, the PLL Settings for clock and phase can be adjusted 
until a better image appears on the active target server. 

 Clock: Horizontal sync divider to produce pixel clock. Controls 
how quickly video pixels are displayed across the video page. 
Changes made to clock settings cause the video image to stretch 
or shrink horizontally. Odd number settings are recommended. 

 Phase: Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that results in the best video image for 
the active target server. 

5. Color Settings: Gain control can be thought of as contrast 
adjustment. Offset control can be thought of as brightness 
adjustment. 

 Red Gain: Controls the amplification of the red signal. 

 Red Offset: Controls the bias of the red signal. 

 Green Gain: Controls the amplification of the green signal. 

 Green Offset: Controls the bias of the green signal. 

 Blue Gain: Controls the amplification of the blue signal. 

 Blue Offset: Controls the bias of the blue signal. 
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 Link Color Controls: Makes all gain slide adjusters move in 
unison when any one color's gain slide is moved and all the 
offset slide adjusters move in unison when any one color's offset 
slide is moved. 

6. Video Sensing 

 Best possible video mode: IP-Reach or Dominion will perform 
the full Auto Sense process when switching targets or target 
resolutions. Selecting this radio button will cause IP-Reach or 
Dominion to calibrate the video for the best image quality.  

 Quick sense video mode: Selecting this radio button will cause 
IP-Reach or Dominion to use a quick video Auto Sense in order 
to show the target's video sooner. This option is especially useful 
for entering a target server's BIOS configuration right after a 
reboot. 

7. Click OK to set Video Settings or Cancel to close the window 
without saving changes. 

Note: Some SUN background screens, such as screens with very dark 
borders, may not center precisely on certain SUN servers. Use a different 
background or place a lighter colored icon in the upper left corner of the 
page. 

Video Settings in Window (KX101) 
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Raritan's Dominion KX101 Color Settings window varies from those of 
other Dominion units. 

1. In the Color Settings panel, adjust the following options: 

 Brightness: Controls the backlight on your page. 

 Red Contrast: Controls the level of red tone on your page. 

 Green Contrast: Controls the level green tone on your page. 

 Blue Contrast: Controls the level of blue tone on your page. 

 Click on the Link Color Controls check box to make all above 
slide adjusters move in unison when any one option is moved. 

2. Click OK when finished. 
 

Color Calibration 

Use the Color Calibration command if the color levels (hue, brightness, 
and saturation) of the transmitted video images do not seem accurate. IP-
Reach or Dominion color settings remain the same when switching from 
one target KVM server to another, so you can perform color calibration 
once to affect all connected target servers. 

1. Open a remote KVM connection to any server running a graphical 
user interface. 

2. Ensure that a solid white color covers approximately 15% or more of 
the target server's desktop. 
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TIP: Open Microsoft Notepad and maximize the window. 

 

3. On the Video menu, click Calibrate Color or click the Color 
Calibration button  on the toolbar. The target device page will 
update its calibration. 

Tip: You can also specify automatic color calibration using Tools > 
Options. Refer to General Options (see "General Options in MPC" on 
page 126) for more information. 

 

Administrative Functions 

Overview 

Although your IP-Reach or Dominion device provides a remote interface 
to administrative functions through IP-Reach or Dominion Manager, 
MPC and RRC provide an interface to frequently-used administrative 
functions directly from its own interface. When logged into an IP-Reach 
or Dominion unit as an administrator, you can perform the 
administrative tasks discussed here. 

Note: Most of the commands discussed here are available in both the 
Tools menu and in the shortcut menu that appears when you right-click 
on the device in the Navigator panel. 
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Note to MPC Users 

MPC users must belong to the administrator group in order to receive 
administrative permissions. MPC uses one permission: either 
administrator or normal user. It is only when the user belongs to the 
administrator group that they have access to backup, restore, and restart 
functions. This is true regardless of any device user group settings that 
may be applied to the user. 
 

General Options 

General Options in MPC 

The Options available in the Tools menu provide options that allow you 
to customize scroll borders, mouse mode settings, single cursor mode, 
auto color calibration, hot key configuration, keyboard type, broadcast 
port, and logging. 

 To configure the general options in MPC: 

1. In MPC, select Tools > Options. The Options dialog appears and 
displays the General tab by default. 

 

2. Select the "Show scroll borders" checkbox to view the thin scroll 
borders designating the autoscroll area. 

3. Select the "Auto-Sync mouse in two-cursor mode" checkbox to 
enable automatic mouse synchronization. 
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4. If you select the "Display single cursor" mode instructions checkbox, 
the Single Cursor Mode dialog will open each time Single Cursor is 
enabled in the application (see Single Mouse Mode/Dual Mouse 
Mode (on page 102) for more information). 

 

5. Select the Automatic Color Calibration checkbox to enable automatic 
color calibration. This option is available for KX generation 1 (G1) 
only. 

6. Select the Keyboard Type from the drop-down list (depending on 
the Raritan device in use, different options may be available): 

 US/International 

 French (France) 

 German (Germany) 

 Japanese 

 United Kingdom 

 Korean (Korea) 

 Belgian 

 Norwegian 

7. From the Keyboard Shortcut Menu HotKey drop-down, select the 
key combination you would like to use to invoke the Keyboard 
Shortcut Menu (see "Shortcut Menu" on page 91).  
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8. For advanced options, open the Advanced tab. 

 

9. From the KVM Switch OSUI Hot Key section, select the hot key to 
use when switching between target server displays. 

10. For the Broadcast Port, type the broadcast port number in the Port 
field if you want to use a port other then 5000. 

11. Select the Enable Logging checkbox only if directed to by Technical 
Support. This option creates a log file in your home directory. 

12. Click OK when finished. Click Apply any time while making 
selections to apply it. 
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General Options in RRC 

The Options available in the Tools menu provide options that allow you 
to customize scroll borders, mouse mode settings, single cursor mode, 
auto color calibration, hot key configuration, keyboard type, broadcast 
port, and logging. 

 To configure the general options in RRC: 

1. In RRC, select Tools > Options to open the Options dialog.  

 

2. Select the "Show scroll borders" checkbox to view the thin scroll 
borders that show the Auto-Scroll area. 

3. Select the "Auto-Sync mouse in two cursor mode" checkbox to enable 
Automatic Mouse Synchronization. 
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4. If you select the "Display single cursor mode instructions" checkbox 
the Single Cursor Mode dialog will open each time Single Cursor is 
enabled in the application (see Single Mouse Mode/Dual Mouse 
Mode (on page 102) for more information).  

 

5. Select Auto-Color Calibration to enable it. 

6. In the KVM Switch OSUI Hot Key panel, select the radio button next 
to the hot key combination you would like to use. 

7. In the Keyboard Type panel, click on the drop-down arrow and click 
on your keyboard choice. 

8. In the Broadcast Port panel, type the broadcast port number in the 
Port field. 

9. Click OK when finished. Click Apply any time during your selection 
to apply an option you have chosen. 

 
 

Upgrading Device Firmware 

 To update a device's firmware: 

1. Connect to the device by highlighting the device's icon in the 
Navigator. 

2. Click Tools > Update > Update Device to perform firmware 
upgrades. 

3. You will be prompted to locate a Raritan firmware distribution file 
(*.RFP format), which can be found on the Raritan Website Firmware 
Upgrades page: http://www.raritan.com/support/firmwareupgrades.  
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Please ensure that you read all instructions included in firmware ZIP 
files carefully before upgrading a device. 

Note: Copy the firmware update file on the Raritan website to a local 
machine before uploading. Do not load the file from a network drive. 
 

Changing a Password 

 To update your password 

1. Connect to an IP-Reach or Dominion target by selecting it in the 
Navigator.  

2. Highlight the target's icon in the Navigator and then click Tools > 
Update > User Password. The Change Password dialog appears. 

 

3. Type your current password in the Old Password field. 

4. Type the new password in the New Password field.  

5. Retype the password in the Confirm New Password field. 

6. When finished, click OK. 
 

Restarting a Device 

 To restart a device: 

1. Select the device in the Navigator.  

2. On the Tools menu, click Restart Device. 
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Backing Up a Device Configuration 

 To back up a device: 

1. Download the IP-Reach or Dominion device configuration to your 
local computer by selecting the device in the Navigator.  

2. On the Tools menu, click Save Device Configuration. 
 

Restoring a Device Configuration 

 To restore a device configuration: 

1. Upload the archived IP-Reach or Dominion device configuration by 
selecting the device in the Navigator.  

2. On the Tools menu, click Restore Device Configuration. 

Please note that device configuration is specific to a particular device 
and should not be restored to another device. 

 

Backing Up a User Configuration 

 To back up a unit's user configuration: 

1. Select the device in the Navigator.  

2. On the Tools menu, click Save User Configuration. 
 

Restoring a User Configuration 

 To restore a user configuration: 

1. Upload a device's archived user configuration by selecting the device 
in the Navigator.  

2. On the Tools menu, click Restore User Configuration 

Note: Use these commands to easily transfer user and group information 
from one IP-Reach or Dominion unit to another. 
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Backup and Restore (Dominion KX II only) 

In addition to using backup and restore for business continuity 
purposes, you can use this feature as a time-saving mechanism. For 
instance, you can quickly provide access from another Dominion device 
to your team by backing up the user configuration settings from the 
device in use and restoring those configurations to the new Dominion 
device. 

Note: Backups are always complete system backups. Restores can be 
complete or partial depending on your selection. 
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 To backup the entire system (both user and device 
configuration): 

1. Select Tools > Backup All. The Backup All dialog appears. 

 

2. Navigate to the desired directory and give the backup file a name. 
(Backup files have an extension of .rfp). 

3. Click Save. A message is displayed confirming the successful 
backup. 

4. Click OK. 
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 To restore: 

1. Select Tools > Restore Configuration. The Restore Device 
Configuration dialog appears. 

 

2. Navigate to the appropriate directory and select the backup file. 

3. Click Open. The Restore Packages dialog appears. 

 

4. Select the type of restore you want to run: 
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• Full Restore: A complete restore of the entire system; generally used 
for traditional backup and restore purposes. 

• Protected Restore: Everything is restored except device-specific 
information such as serial number, MAC Address, IP Address, 
name, port names, etc. With this option, you can setup one 
Dominion device and copy the configuration to multiple Dominion 
devices. 

• Custom Restore: With this option, the following options are 
available. Check the appropriate checkboxes: 

 User and Group Restore: This option includes only user and 
group information. Use this option to quickly setup users on a 
different Dominion device. 

 Device Settings Restore: This option includes only device 
settings. Use this option to quickly copy the device information. 

1. Click OK. 
 

Log Files 

Activity Log 

 To download a detailed activity log for review or 
troubleshooting: 

1. Select the device in the Navigator.  

2. On the Tools menu, click Save Activity Log. 
 

Diagnostic Log (excluding Dominion KX II) 

To download a detailed diagnostic log for reporting or analysis: 

1. Select the device in the Navigator.  

2. On the Tools menu, click Save Diagnostic Log. 
 

Broadcast Port 

By default, all Raritan devices send data through Port 5000. This network 
traffic includes the auto-discovery broadcast. In the case of conflicts or to 
deal with firewall issues, you may want to use a different broadcast port. 

 To change the autodiscovery port from the default 
broadcast port of 5000:  

1. Select the device in the Navigator.  
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2. On the Tools menu, click Options. The Options dialog appears. 

3. In the Broadcast Port field, type the new port number in the Port 
field and then click OK. 

Note: If you want the application to autodiscover Raritan devices on the 
new broadcast port you entered in the Options window, you must 
configure all Raritan devices to use the new port number. 
 

MPC Broadcast Port 

By default, all Raritan devices send data through Port 5000. This network 
traffic includes the auto-discovery broadcast. In the case of conflicts or to 
deal with firewall issues, you may want to use a different broadcast port. 

 To change the autodiscovery port from the default 
broadcast port of 5000:  

1. Select the device in the Navigator.  

2. On the Tools menu, click Options. The Options dialog appears. 

3. On the Advanced tab, type the new port number in the Port field 
and then click OK. 

Note: If you want the application to autodiscover Raritan devices on the 
new broadcast port you entered in the Options window, you must 
configure all Raritan devices to use the new port number. 
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RRC Broadcast Port 

By default, all Raritan devices send data through Port 5000. This network 
traffic includes the auto-discovery broadcast. In the case of conflicts or to 
deal with firewall issues, you may want to use a different broadcast port. 

 To change the autodiscovery port from the default 
broadcast port of 5000:  

1. Select the device in the Navigator.  

2. On the Tools menu, click Options. The Options dialog appears. 

3. In the Broadcast Port field, type the new port number in the Port 
field and then click OK. 
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Note: If you want the application to autodiscover Raritan devices on the 
new broadcast port you entered in the Options window, you must 
configure all Raritan devices to use the new port number. 
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Remote Power Management 

AC power to associated targets can be managed when used with a 
properly configured Raritan Remote Power Control Strip (RPC strip). 
Three options are available when performing remote target power 
management:  

• Power On 

• Power Off 

• Cycle Power 

 To change the power status of a target: 

1. Select the device in the Navigator.  

2. On the Tools menu, click Power On, Power Off, or Cycle Power. 
 

Import/Export Keyboard Macro Definitions 

Import/Export MPC Keyboard Macros 

The functions contained in this section describe how to exchange 
keyboard macro definitions between users using import and export 
functions. The primary purpose of this function is to exchange data 
between copies of MPC.  

 To export MPC macros: 

1. Click Tools > Export Macros to open the Select Keyboard Macros to 
Export dialog. 
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2. Select the macros to be exported by checking their corresponding 
checkbox or using the Select All or Deselect All options.  

3. Click OK. The selected macro file(s) will be moved to your desktop 
(by default). 

A dialog from which you can locate and select the macro file will 
then appear. By default, the macro will exist on your desktop.  

4. Locate the macro file, click on it to select it and then click Save. If the 
macro already exists, you will receive an alert message. Select Yes to 
overwrite the existing macro or No to close the alert without 
overwriting the macro. 

 

 To import MPC macros: 

1. Click Tools > Import Macros to open the Import Macros dialog. By 
default, the macro will exist on the desktop. 

2. Click on the macro file and click Open to import the macro.  

a. If too many macros are found in the file, an error message will be 
displayed and the import will terminate once OK is selected. 

b. If the import fails, an error dialog will open and will display a 
message regarding why the import failed. Select OK to continue 
the import without importing the macros that cannot be 
imported. 

3. Select the macros to be imported by checking their corresponding 
checkbox or using the Select All or Deselect All options. 

4. Click OK and the import will begin. 

a. If a duplicate macro is found, the Import Macros dialog will 
appear. Do one of the following: 
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 Click Yes to replace the existing macro with the imported 
version. 

 Click Yes to All to replace the currently selected and any 
other duplicate macros that are found. 

 Click No to keep the original macro and proceed to the next 
macro 

 Click No to All keep the original macro and proceed to the 
next macro. Any other duplicates that are found will be 
skipped as well. 

 Click Cancel to stop the import.  

 Alternatively, click Rename to rename the macro and import 
it. If Rename is selected, the Rename Macro dialog will open. 
Enter a new name for the macro in the field and click OK. 
The dialog will close and the process will proceed. If the 
name that is entered is a duplicate of a macro, an alert will 
appear and you will be required to enter another name for 
the macro. 

b. If during the import process the number of allowed, imported 
macros is exceeded, a dialog will open.  Click OK to attempt to 
continue importing macros or click Cancel to stop the import 
process. 

The macros will then be imported. 

If a macro is imported that contains a hot key that already exists, the 
hot key for the imported macro will be discarded.  

 
 



 Chapter 3: Multi-Platform Client and Raritan Remote Client 
 

 
143

Import/Export RRC Keyboard Macros 

The functions contained in this section describe how to exchange 
keyboard macro definitions between users using import and export 
functions. The primary purpose of this function is to exchange data 
between copies of RRC.  

 To export RRC macros: 

1. Click Tools > Export Macros to open the Export Macros dialog. 

 

2. Select the macros to be exported by checking their corresponding 
checkbox or using the Select All or Unselect All options.  

3. Click OK. The selected macro file(s) will be moved to your desktop 
(by default). 

A select dialog from which you can locate and select the macro file 
will then appear. By default, the macro will exist on your desktop.  
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4. Locate the macro file, click on it to select it and then click Save. If the 
macro already exists, you will receive an alert message. Select Yes to 
overwrite the existing macro or No to close the alert without 
overwriting the macro. 

 

 To import RRC macros: 

1. Click Tools > Import Macros to open the Import Macros dialog. By 
default, the macro will exist on the desktop. 

 

2. Click on the macro file and click Open to import the macro.  
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a. If too many macros are found in the file, an error message will be 
displayed and the import will terminate once OK is selected. 

 

b. If the import fails, an error dialog will open and will display a 
message regarding why the import failed. Select OK to continue 
the import without importing the macros that cannot be 
imported. 

 

3. Select the macros to be imported by checking their corresponding 
checkbox or using the Select All or Unselect All options. 

4. Click OK and the import will begin. 

 

a. If a duplicate macro is found, a dialog will appear. Do one of the 
following: 
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 Click Yes to replace the existing macro with the imported 
version. 

 Click Yes to All to replace the currently selected and any 
other duplicate macros that are found. 

 Click No to keep the original macro and proceed to the next 
macro 

 Click No to All keep the original macro and proceed to the 
next macro. Any other duplicates that are found will be 
skipped as well. 

 Click Cancel to stop the import.  

 

 Alternatively, click Rename to rename the macro and import 
it. If Rename is selected, Raritan Remote Client Rename 
Macro dialog will open. Enter a new name for the macro in 
the field and click OK. The dialog will close and the process 
will proceed. If the name that is entered is a duplicate of a 
macro, an alert will appear and you will be required to enter 
another name for the macro. 
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b. If during the import process the number of allowed, imported 
macros is exceeded, a message will appear.  Click OK to attempt 
to continue importing macros or click Cancel to stop the import 
process. 

 

The macros will then be imported. 

If a macro is imported that contains a hot key that already exists, the 
hot key for the imported macro will be discarded.  

 
 

Opening Administrator and Diagnostic Interfaces 

Administrator Interface 

For further control of a selected device, in the Navigator, scroll down the 
list of all the targets associated with the specific device (you may have to 
expand your view of the device by clicking on the + sign before its 
name). Next, double-click on the Admin icon at the bottom of the target 
list. The Administrator login page for the selected device appears.  
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Please refer to the specific Raritan device user guide for additional 
information and managing the device. The user guide is contained on the 
CD included with the device shipment or you can download it from the 
Product Documentation page on Raritan's website: 
http://www.raritan.com/support/productdocumentation. 
 

Diagnostic Interface (excluding Dominion KX II) 

Access the device's diagnostic console by double clicking on the 
Diagnostic icon at the bottom of the target list in the Navigator. Scroll 
down the list of all the targets associated with the device (you may have 
to expand your view of the device) and double-click on the Diagnostic 
icon at the bottom of the target list. 

 
 

Special Characters in MPC 

The following table identifies the special characters that can be used in 
MPC: 

Character Description Character Description 
! Exclamation point : Colon 

" Double quote ; Semi-colon 

# Pound sign = Equal sign 

$ Dollar sign > Greater than sign 
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Character Description Character Description 
% Percent sign ? Question mark 

& Ampersand @ At sign 

' Single quote [ Left bracket 

( Left parenthesis \ Backward slash 

) Right parenthesis ] Right bracket 

* Asterisk ^ Caret 

+ Plus sign _ Underscore 

, Comma ` Grave accent 

- Dash { Left brace 

. Period | Pipe sign 

/ Forward slash } Right brace 

< Less than sign ~ Tilde 
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Overview 

Virtual media extends KVM capabilities by enabling KVM target servers 
to remotely access media from the client PC and network file servers. 
With this feature, media mounted on the client PC and network file 
servers is essentially mounted virtually by the target server. The target 
server can then read from and write to that media as if it were physically 
connected to the target server itself. Virtual media can include internal 
and USB-mounted CD and DVD drives, USB mass storage devices, PC 
hard drives, and ISO images (disk images). 

Note: ISO9660 is the standard supported by Raritan. However, other ISO 
standards can be used. 

Virtual media provides the ability to perform additional tasks remotely, 
such as: 

• transferring files 

• running diagnostics 

• installing or patching applications 

• complete installation of the operating system 

This expanded KVM control eliminates most trips to the data center, 
saving time and money, thereby making virtual media very powerful. 
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Item Description 

 
Desktop PC 

 
 

 
CIM 

 
Target Server 

 
CD/DVD Drive 

 
USB 

 
Hard Drive Image Files 

 
Remote File Server (ISO Images) 
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Prerequisites for Using Virtual Media 

The following conditions must be met in order to use virtual media: 

 
• For users requiring access to virtual media,  permissions must be set 

to allow access to the relevant ports, as well as virtual media access 
(VM Access port permission) for those ports. Port permissions are set 
at the group-level; please refer to Setting Port Permissions in the 
device user guide for more information. 

• A USB connection must exist between the  device and the target 
server. 

• If you want to use PC-Share, VM Share Mode must also be enabled 
in the Security Settings page. Optional  

• You must choose the correct USB profile for the KVM target server 
you are connecting to. For information about choosing a USB profile, 
see Setting Up USB Profiles in the device user guide. 

Client PC 
• Certain virtual media options require administrative privileges on 

the client PC (for example, drive redirection of complete drives). 

Note: If you are using Microsoft Vista, turn User Account Control 
off: Control Panel > User Accounts > User Account Control > turn off. 

If you would prefer not to change Vista account permissions, run 
Internet Explorer as an administrator. To do this, click on the Start 
Menu, locate IE, right click it and select Run as Administrator. 

• USB 2.0 ports are both faster and preferred. 

Target Server 
• KVM target servers must support USB connected drives. 

• KVM target servers running Windows 2000 must have all of the 
recent patches installed. 
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Using Virtual Media 

With the  virtual media feature, you can mount up to two drives (of 
different types). These drives are accessible for the duration of the KVM 
session. 

For example, you can mount a specific CD-ROM, use it, and then 
disconnect it when you are done. The CD-ROM virtual media “channel” 
will remain open, however, so that you can virtually mount another CD-
ROM. These virtual media “channels” remain open until the KVM 
session is closed. 

 To use virtual media: 

1. Connect/attach the media to the client or network file server that you 
want to access from the target server. This need not be the first step, 
but it must be done prior to attempting to access this media. 

2. Verify that the appropriate prerequisites  (see "Prerequisites for 
Using Virtual Media" on page 154)are met. 

3. (File server ISO images only) If you plan to access file server ISO 
images, identify those file servers and images through the  Remote 
Console File Server Setup page (see "File Server Setup (File Server 
ISO Images Only)" on page 160). 

Note: ISO9660 format is the standard supported by Raritan. 
However, other CD-ROM extensions may also work. 

4. Open a KVM session with the appropriate target server. 

5. Connect to the virtual media. 

For: Select this VM option: 
Local drives Connect Drive (see "Local Drives" on 

page 156) 

Local CD/DVD drives Connect CD-ROM/ISO Image (see 
"CD-ROM/DVD-ROM/ISO Images" 
on page 158) 

ISO Images Connect CD-ROM/ISO Image 

File Server ISO Images Connect CD-ROM/ISO Image 

6. Upon completion of your tasks, disconnect the virtual media (see 
"Disconnecting Virtual Media" on page 159). 
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Connecting to Virtual Media 

Local Drives 

This option mounts an entire drive; the entire disk drive is mounted 
virtually onto the target server. Use this option for hard drives and 
external drives only; it does not include network drives, CD-ROM, or 
DVD-ROM drives. This is the only option for which read/write is 
available. 

Note: KVM target servers running certain version of the Windows 
operating system may not accept new mass storage connections after an 
NTFS-formatted partition (for example, the local C drive) has been 
redirected to them. If this occurs, close the  Remote Console and 
reconnect before redirecting another virtual media device. If other users 
are connected to the same target server, they must also close their 
connections to the target server. 

 To access a drive on the client computer: 

1. From the Virtual KVM Client, select Virtual Media > Connect Drive. 
The Map Virtual Media Drive dialog opens: 

 

2. Choose the drive from the Local Drive drop-down list. 

3. If you want read and write capabilities, select the Read-Write option 
checkbox. This option is disabled for non-removable drives. Please 
refer to the conditions when read-write is not available (on page 
157) for more information. When checked, you will be able to read or 
write the connected USB disk. 

WARNING: Enabling Read-Write access can be dangerous! 
Simultaneous access to the same drive from more than one entity can 
result in data corruption. If you do not require write access, leave 
this option unselected. 
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4. Click Connect. The media will be mounted on the target server 
virtually. You can access the media just like any other drive. 

Note: If there is no USB connection to the target server, you will see a 
warning message that says, "The virtual media capability is set up 
but will not be available until the USB cable is connected or the 
target is powered on. Please check your USB connectivity or see if 
the target is powered on." Resolve this issue, then connect to the 
drive again. 

 

Conditions when Read-Write is not Available 

Virtual media read/write is not available in the following situations: 

• For all hard drives. 

• When the drive is write-protected. 

• When the user does not have read/write permission: 

 Port Permission Access is set to None or View 

 Port Permission VM Access is set to Read-Only or Deny 
 



Connecting to Virtual Media 
 

158
 

CD-ROM/DVD-ROM/ISO Images 

This option mounts CD-ROM, DVD-ROM, and ISO images. 

Note: ISO9660 format is the standard supported by Raritan. However, 
other CD-ROM extensions may also work. 

 To access a CD-ROM, DVD-ROM, or ISO image: 

1. From the Virtual KVM Client, choose Virtual Media > Connect CD-
ROM/ISO Image. The Map Virtual Media CD/ISO Image dialog 
opens: 

 

2. For internal and external CD-ROM or DVD-ROM drives: 

a. Choose the Local CD/DVD Drive option. 

b. Choose the drive from the Local CD/DVD Drive drop-down list. 
All available internal and external CD and DVD drive names 
will be populated in the drop-down list. 

c. Click Connect. 

3. For ISO images: 

a. Choose the ISO Image option. Use this option when you want to 
access a disk image of a CD, DVD, or hard drive. ISO format is 
the only format supported. 

b. Click the Browse button. 

c. Navigate to the path containing the disk image you want to use 
and click Open. The path is populated in the Image Path field. 
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d. Click Connect. 

4. For remote ISO images on a file server: 

a. Choose the Remote Server ISO Image option. 

b. Choose Hostname and Image from the drop-down lists. The file 
servers and image paths available are those that you configured 
using the File Server Setup page. Only items you configured 
using the  File Server Setup page will be in the drop-down list. 

c. File Server Username. Username required for access to the file 
server. 

d. File Server Password. Password required for access to the file 
server (field is masked as you type). 

e. Click Connect. 

The media will be mounted on the target server virtually. You can 
access the media just like any other drive. 

 

Disconnecting Virtual Media 

 To disconnect the Virtual Media drives: 

• For local drives, choose Virtual Media > Disconnect Drive. 

• For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media > 
Disconnect CD-ROM/ISO Image. 

Note: In addition to disconnecting the virtual media using the 
Disconnect option, simply closing the KVM connection closes the virtual 
media as well. 
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File Server Setup (File Server ISO Images Only) 

Note: This feature is only required when using virtual media to access 
file server ISO images. 

Note: ISO9660 format is the standard supported by Raritan. However, 
other CD-ROM extensions may also work. 

Use the  Remote Console File Server Setup page to designate the files 
server(s) and image paths that you want to access using  Virtual Media. 
File server ISO image(s) specified here will become available for selection 
in the Remote Server ISO Image Hostname and Image drop-down lists 
(in the Map Virtual Media CD/ISO Image dialog (see "CD-ROM/DVD-
ROM/ISO Images" on page 158)). 

 To designate file server ISO images for virtual media 
access: 

1. Choose Virtual Media from the  Remote Console. The File Server 
Setup page opens: 

 

2. Enter information about the file server ISO images that you want to 
access: 
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 Host Name/IP Address. Host name or IP Address of the file 
server. 

 Image Path. Full path name of the location of the ISO image. 

3. Select the Selected checkbox for all media that you want accessible as 
virtual media. 

4. Click Save. All media specified here will now be available for 
selection in the Map Virtual Media CD/ISO Image dialog. 

 To cancel without saving: 

• Click Cancel. 
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The standalone Raritan Serial Client (RSC) is used to make direct 
connections to a serial target without going through the  application. The 
user specifies the  address and the port number (target), and is then 
connected. 

In This Chapter 
System Requirements (Shared KSX II) .................................................... 162 
Installing RSC on Windows ..................................................................... 167 
Installing RSC for Sun Solaris and Linux ................................................ 169 
Opening RSC from a  Remote Console.................................................... 170 
Raritan Serial Client Interface .................................................................. 171 
 
 

System Requirements (Shared KSX II) 

The following requirements must be met to support the Raritan Serial 
Console: 

• The RSC will function with JRE version 1.4.2_05 or later (except for 
JRE version  1.5.0_02). However, for optimum performance, Raritan 
recommends using JRE 1.5.0 (except, of course for  1.5.0_02). 

• Your system may require configuration adjustments depending on 
the operating system and browser. The JRE provides configuration 
instructions with the JRE download. Browse to the page at 
http://www.java.com/en/download/help/testvm.xml 
(http://www.java.com/en/download/help/testvm.xml \o 
http://www.java.com/en/download/help/testvm.xml) to determine 
the JRE version currently installed on your system. If you do not 
have a compatible version of the JRE, go to http://www.java.com 
(http://www.java.com)  and click the Download Now button. 

Note: Raritan does not support JRE version 1.5.0_02 for use with the 
RSC. 

• Minimum 1 GHz PC with 512 MB RAM. 

Ensure that Java can be started from the command line. To do this, 
environment variables must be configured. Make a note of the exact path 
where Java was installed. (The path information will be used later.) 
 

Setting Windows OS Variables 

1. Open the Start menu, and then open the Control Panel and choose 
System. 

Chapter 5 Raritan Serial Console
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2. Go to Advanced and open Environment Variables. 

 

3. In the System variables section, click New. 

4. In the New System Variable dialog, add JAVA_HOME to the 
Variable name block and the path you wrote down earlier in the 
Variable value block. 
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5. Click OK. 

 

6. Select the PATH variable and click Edit. 

7. Add %JAVA_HOME%\bin to the end of the current Variable value. 
Ensure a  
semicolon (;) separates the new value from the last value in the 
string. 
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8. Click OK. 

 

9. Select the CLASSPATH variable and click Edit. 

10. Ensure the CLASSPATH Variable value is configured properly; that 
is, its value must have a period (.) in it. If, for any reason, there is no 
CLASSPATH variable defined, create one. 
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Setting Linux OS Variables 

If you want to set Java for this user only, open and edit .profile file 
located in the /home/Username folder. 

If you want to set Java for all users, open .profile file in your /etc folder: 

1. Find the line where you set your PATH 

Example: export PATH=$PATH:/home/username/somefolder 

2. Before that line you must set your JAVA_HOME and then modify 
your PATH to include it. 
To achieve this, add the following lines: 

export  
JAVA_HOME=/home/username/j2sdk1.4.2/ 
export PATH=$PATH:$JAVA_HOME/bin 

3. Save the file and you are finished. 
 

Setting UNIX OS Variables 

Perform the following steps to check the latest JRE Version on Sun 
Solaris. 

1. Launch a terminal window on the Sun Solaris desktop. 

2. Type java -version in the command line and press ENTER. The 
currently-installed version of Java Runtime Environment (JRE) 
appears. 

 If your path variable is not set to where the java binaries have 
been installed, you may not be able to see the JRE version. 

 To set your path: Assuming JRE 1.4.2_05 is installed in 
/usr/local/java: you must set your PATH variable. 

 To set path for bash shell: 
export 
PATH=$PATH:/usr/local/java/j2re1.4.2_05/bin 

 To set path for tcsh or csh: 
set PATH = ($PATH 
/usr/local/java/j2re1.4.2_05/bin) 
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 These commands can either be typed at the terminal each time 
you log in, or you can add them to your .bashrc for bash shell or 
.cshrc for csh or tcsh so that each time you log in, the PATH is 
already set. See your shell documentation if you encounter 
problems. 

 

3. If the JRE is version 1.4.2_05 or later, but not version 1.5.0_02 , 
proceed with the RSC installation. If the version is older, go to the 
Sun website at: http://java.sun.com/products/ 
(http://java.sun.com/products/) to download the latest Runtime 
Environment. 

 

Installing RSC on Windows 

You must have administrative privileges to install RSC. 

 To install RSC on Windows: 

1. Log on to a Windows machine. 

2. Download, or copy from a known location, the RSC-installer.jar 
installation file. 

3. Double-click on the executable file to start the installer program. The 
splash page appears. 

4. Click Next. The installation path page appears. 

5. Change the path, if desired. 

6. Click Next. The installation progress page appears. 
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Note: The standalone version of Raritan Serial Console (RSC) is 
available from the Raritan Support website: 
http://www.raritan.com/support/sup_upgrades.aspx 
(http://www.raritan.com/support/sup_upgrades.aspx) 
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7. Click Next. The Windows shortcut page appears. 

 

8. Specify the desired Program Group for the Shortcut. 

9. Click Next. The installation finished page appears. 

10. Click Done. 
 

Installing RSC for Sun Solaris and Linux 

You must have administrative privileges to install RSC. 

1. Log on to your Sun Solaris machine. 

2. Download, or copy from a known location, the RSC-installer.jar 
installation file. 

3. Open a terminal window and change to the directory where the 
installer is saved. 

4. Type java -jar RSC-installer.jar and press ENTER to run the installer. 

5. Click Next after the initial page loads. 

6. The Set Installation Path page appears. 

a. Select the directory where you want to install RSC and click 
Next. 
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b. Click Browse to navigate to a non-default directory. 

c. Click Next when the installation is complete. 

d. Click Next again. The installation is complete. The final page 
indicates where you will find an uninstaller program, and allows 
the option of generating an automatic installation script. 

e. Click Done to close the Installation window. 
 

Opening RSC from a  Remote Console 

 To open the Raritan Serial Console (RSC) from the 
Remote Console: 

1. Select the Port Access tab. 

 

2. Click on the name of the serial port you want to access for the RSC. 

Note: A security pop-up screen appears only if you used https to 
connect to the RSC. 

3. Click Yes. A Warning - Security pop-up screen appears. 

4. Click Yes to access the Raritan Serial Console from the Port page. 

Note: If you click Always, you will not receive the security page for 
future access. 
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The Raritan Serial Console window appears. For information, see to 
Raritan Serial Console Interface (see "Raritan Serial Client Interface" 
on page 171) section in this chapter. 

Note: You can download the standalone Raritan Serial Client from 
the Raritan support website: http://www.raritan.com/support 
(http://www.raritan.com/support). 

 To open RSC from the Windows desktop: 

1. Double-click on the shortcut or use Start Programs to open the 
standalone RSC. The Raritan Serial Console Login connection 
properties window appears. 

2. Enter the Dominion  IP address, account information, and the 
desired target (port). 

3. Click Start. The RSC opens with a connection to the port. 

Note: In case of unrecognized characters or blurry pages that might 
appear in RSC window due to localization support, please try 
changing the font to Courier New.  Go to: Emulator > Settings > 
Display, and select Courier New for Terminal Font Properties or GUI 
Font Properties. 

Note: When RSC connects a serial target, hitting Ctrl + _ or Ctrl + ^ + _ 
does not cause information to be sent. However, hitting the Ctrl + Shift + 
_ or the Ctrl + Shift + ^ will cause information to be sent.  

 To open RSC on Sun Solaris: 

1. Open a terminal window and change to the directory where you 
installed the RSC. 

2. Type ./start.sh and press ENTER to open RSC. 

3. Double-click on the desired device to establish a connection. 

4. Type your Username and Password. 

5. Click OK to log in. 

 
 

Raritan Serial Client Interface 

Important: The Raritan Serial Console page usually opens in a separate 
window in back of the Port page. With some versions of Java on 
Windows, the page opens in front of the Port page. 
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Minimize the Port Access page to access the Raritan Serial Console page. 
The RSC contains drop-down menus that provide the user with the 
ability to: 

• Modify emulation settings such as fonts and window size. 

• Manage the history of the session. 

• Request Write Access to the port. 

• Get a Write Lock on the port. 

• Send a Break signal (used for Solaris servers). 

• Get a list of users connected to this port. 

• Edit text in the window. 

• Manage client workstation-based logging of data from the target 
device. 

• Send Keystroke (combinations). 

• Send Text files. 

• Send power commands to a Power Distribution Unit (PDU). 

• Chat among other users on the same port. 

• Get help. 
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Default RSC Option Values 

The following default values apply to the GUI font properties, colors and 
fonts defined in RSC: 

Item Value 

Font Properties Monospaced 

GUI Font Properties Monospaced 

Colors Black Foreground and White 
Background 
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Emulator 

1. Change the default user Idle Timeout setting before launching the 
RSC for the first time or it will timeout in 10 minutes and display a 
host termination message. See the Security section of the  User Guide 
for changing the Idle Timeout setting.. 

2. Click the Emulator drop-down menu to display a list of topics. 
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Settings 

Note: Terminal emulation settings are set with the port by an 
Administrator using the Setup->Port Configuration menu. 

1. Choose Emulator > Settings. The Settings page displays the General 
tab with the default settings. 

 

2. Accept the Main Menu Shortcut: default of None or choose one of 
the following from the Main Menu Shortcut: drop-down menu. 

 F10 

 Alt 

3. Accept the Show Confirmation Dialog on Exit default or uncheck it. 

4. Accept the Terminal Size: default or choose a size from the Terminal 
Size: drop-down menu. 
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5. Accept the Backspace Sends: default of ASCII DEL or choose 
Control-H from the Backspace Sends: drop-down menu. 

6. Accept the History Buffer Size: default of 200 or use the arrows to 
change the buffer size. 

7. Accept the Cursor type: default of Block Cursor: or select Line 
Cursor. 

8. Click OK. 
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Display Settings 

1. Return to the Emulator menu, choose Settings and then click the 
Display tab. 

 

2. Click Default to accept the Default settings. Then click Ok to close 
the Display Settings dialog; however, if you want to change the 
settings, perform the following steps: 

3. Accept the Terminal Font Properties default of Arial or choose a font 
from the Terminal Font Properties scrolling list. 

4. Accept the Antialiase Font default or uncheck it. 
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5. If you want to change the size of the font, check the Lock Font Size 
box and choose a font size from the Font size: drop-down menu. 

6. Click the GUI Font Properties tab and accept the default of 
Monospaced or choose a font from the GUI Font Properties scrolling 
list. 

 

Note: For Simplified Chinese characters, Raritan Serial Console 
supports EUC-CN encoding system.  

7. Choose the following from their drop-down menus: 

 Foreground Color 
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 Background Color 

8. Choose one of the following from the Encoding drop-down menu: 

 US-ASCII 

 ISO-8859-1 

 ISO-8859-15 

9. Choose one of the following from the Language drop-down menu: 

 English 

 Japanese 

 Korean 

 Chinese 

10. Click Ok to close the Display Settings dialog. If you changed the 
Language setting, the RSC changes to that language when the 
Display Settings dialog is closed. 

Note: In case of unrecognized characters or blurry pages that might 
appear when RSC is launched due to localization support, please try 
changing the font to Courier New.  

Get History 

History information can be useful when debugging, troubleshooting, or 
administering a target device. The Get History feature: 

• Allows you to view the recent history of console sessions by 
displaying the console messages to and from the target device. 

When the size limit is reached, the text will wrap, overwriting the oldest 
data with the newest. 

Notes: Verify the memory on your unit from the Maintenance-
>Configuration menu. History data is displayed only to the user who 
requested the history. 

To view the Session History, click Get History on the Emulator menu. 

Clear History 

 To clear the history, click Clear History on the Emulator menu. 
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Get Write Access 

Only Administrators and Operators can get write access. The user with 
Write Access can send commands to the target device. Write Access can 
be transferred among users working in the Raritan Serial Console via the 
Get Write Access command. 

To enable Write Access, click Get Write Access on the Emulator menu. 

• You now have Write Access to the target device. 

• When another user assumes Write Access from you, 

 The RSC displays a red block before Write Access in the status 
bar. 

 A message alerting the user who currently has Write Access 
appears to tell that user that another user has taken over access 
to the console. 

Get Write Lock 

1. To get write lock, click Get Write Lock on the Emulator menu. 

2. If the Get Write Lock is not available, a request rejected message 
appears. 

Write Unlock 

To get Write Unlock, click Write Unlock on the Emulator menu. 

Send Break 

Some target systems such as Sun Solaris servers require the transmission 
of a null character (Break) to generate the OK prompt. This is equivalent 
to issuing a STOP-A from the Sun keyboard. 

• Only users with Administrator privileges can send a break. 

• Users who are Operator or Observers cannot send a break. 

To send an intentional “break” to a Sun Solaris server: 

1. Verify that you have Write Access. If not, follow the instructions in 
the previous section to obtain write access. 

2. Click Send Break on the Emulator menu. 
A Send Break Ack (Acknowledgement) pop-up appears. 

3. Click OK. 
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Connected Users 

The Connected Users command allows you to view a list of other users 
who are currently connected on the same port. 

1. Click Connected Users to view the connected users on the Emulator 
menu. 

 

2. A check mark appears in the Write Access column after the name of 
the User who has Write Access to the console. 

3. Click Close to close the Connected Users dialog. 

Exit 

1. Click Exit on the Emulator menu to close the Raritan Serial Console. 

The Exit Confirmation page appears. 

2. Click Yes. 
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Edit 

Use the Copy, Paste, and Select All text commands to relocate and/or re-
use important text. 

 

 Copy and Paste All Text: 

1. Click Select All on the Edit menu. 

2. Click Copy on the Edit menu. 

3. Position the cursor at the location where you want to paste the text. 

4. Click once to make that location active. 

5. Click Paste on the Edit menu. 
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Note: Here are keyboard shortcuts that you can use to highlight, copy, 
and paste all or partial lines of text: 
- Click and drag your mouse over the text you wish to copy. 
- Press Ctrl and tap the C key to copy. 
- Position the cursor where you want to paste the text and click in that 
location to make it 
  active. 
- Press Ctrl and tap the V key to paste. 

The text copy limit in Raritan Serial Console is 9999 lines. 
 

Tools 

Click on the Tools drop-down menu to display a list of topics. 
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Start Logging 

The Start Logging function allows you to collect raw console data from 
the target device and save it to a file in your computer. When you start 
the RSC, the Logging indicator on the status bar indicates whether 
logging is on or off. 

1. On the Tools menu, click Start Logging. 

2. Choose an existing file or provide a new file name in the Save RSC 
Log dialog. 

 When an existing file is selected for logging, data gets appended 
to the contents. 

 Providing a new file name results in new file being created. 

 

3. Click Save after selecting or creating a file. 
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Stop Logging 

On the Tools menu, click Stop Logging. The logging stops. 

 

Send Keystroke 

1. On the Tools menu, click Send Keystroke.  
A Send Keystroke screen appears: 

 

2. Enter the keystroke combinations that you want and select a Key 
Code name from the drop-down menu. 

3. Send the keystroke combinations. 

 

Send Text File 

1. On the Tools menu, click Send Text File.  
A Send Text File screen appears: 

2. Open the directory of the Text file. 

3. Click on or enter the File Name of the Text file. 

4. Click Open. 

 As soon as you click the Open dialog, it sends whatever file you 
selected directly to the port. 

 If there is a loopback plug inserted, you see the file displayed. 

If there is currently no target connected, then nothing will be visible on 
the screen. 
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Chat 

When using browser access over SSL, an interactive chat feature called 
Chat provides you and other users on the same port to communicate. 
You can conduct an online dialog for training or collaborative diagnostic 
activities. The maximum length of a chat message is 300 characters. 

Note: When a chat is initiated, a chat window appears on the monitors of 
all SSL users logged on to the port. If a user is logged into a port multiple 
times, chat messages will not be shown to the same user. 

To use Chat: 

1. Click Chat on the Chat menu. 

 

2. Type a message in the Message text field. 

3. Click Send or press ENTER to send the message. 

4. Click Clear to delete the typed text, or click Close to exit and close 
the Message window. 

 

Help 

Help Topics include on-line assistance for operating the Raritan Serial 
Console, and release information about Raritan Serial Console. 

Help Topics 

To Access Help Topics: 

1. Click Help Topics on the Help menu. 
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2. Use the navigation bar on the right side of Table of Contents window 
to scroll to the topic you need or click on the links. 

3. Close this window when you are finished. 

About Raritan Serial Console 

The About Raritan Serial Console window displays the copyright and 
version information (name and revision number) of the console terminal 
emulation software. When contacting Raritan for technical support or 
when performing a software upgrade, you may be asked for this 
information. 

 To Access 'About' Information: 

1. Click About Raritan Serial Console on the Help menu. 

An About Raritan Serial Console message appears on top of the 
Raritan Serial Console drop-down menu: 

 

2. Click OK to close the About Raritan Serial Console dialog. 
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 U.S./Canada/Latin America  
Monday - Friday  
8 a.m. - 8 p.m. ET  
Phone: 800-724-8090 or 732-764-8886 
For CommandCenter NOC: Press 6, then Press 1 
For CommandCenter Secure Gateway: Press 6, then Press 2 
Fax: 732-764-8887 
Email for CommandCenter NOC: tech-ccnoc@raritan.com 
Email for all other products: tech@raritan.com 

 China 

Beijing  
Monday - Friday  
9 a.m. - 6 p.m. local time  
Phone: +86-10-88091890 

Shanghai 
Monday - Friday  
9 a.m. - 6 p.m. local time  
Phone: +86-21-5425-2499  

GuangZhou 
Monday - Friday  
9 a.m. - 6 p.m. local time  
Phone: +86-20-8755-5561  

 India  
Monday - Friday  
9 a.m. - 6 p.m. local time 
Phone: +91-124-410-7881  

 Japan  
Monday - Friday  
9:30 a.m. - 5:30 p.m. local time  
Phone: +81-3-3523-5994 
Email: support.japan@raritan.com 

 Europe  

Europe 
Monday - Friday 
8:30 a.m. - 5 p.m. GMT+1 CET  
Phone: +31-10-2844040  
Email: tech.europe@raritan.com 

United Kingdom  
Monday - Friday  
8:30 a.m. to 5 p.m. GMT+1 CET  
Phone +44-20-7614-77-00  
France  
Monday - Friday  
8:30 a.m. - 5 p.m. GMT+1 CET  
Phone: +33-1-47-56-20-39 

Germany  
Monday - Friday  
8:30 a.m. - 5 p.m. GMT+1 CET  
Phone:  +49-20-17-47-98-0  

 Korea  
Monday - Friday  
9 a.m. - 6 p.m. local time 
Phone: +82-2-5578730  

 Melbourne, Australia 
Monday - Friday 
9:00 a.m. - 6 p.m. local time 
Phone: +61-3-9866-6887  

 Taiwan  
Monday - Friday  
9 a.m. - 6 p.m. GMT -5 Standard -4 Daylight  
Phone: +886-2-8919-1333  
Email:  tech.rap@raritan.com  
 

 

 


