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Overview
The Dominion KX III is an enterprise-class, secure, KVM-over-IP switch
that provides 1, 2, 4 or 8 users with remote BIOS-level control of 8 to 64
servers.
KX III comes with standard features such as DVI/HDMI/DisplayPort
digital and analog video, audio, virtual media, smart card/CAC, blade
server support, and mobile access.
Deploy KX III individually, or with Raritan’s CommandCenter Secure
Gateway (CC-SG).

What's New in Help


KX III supports DVI video monitors



Also added for this release:


Ability to extend the KX III's reach by connecting to Raritan's
Cat5 Reach DVI - see Connecting a KX III and Cat5 Reach
DVI - Provide Extended Local Port Functionality (on page
100)



Changes to Virtual KVM Client (VKC) and Active KVM Client
(AKC) connection properties - see Configuring Connection
Properties (on page 27)



Enable and disable Favorites in the KX III Remote Client - see
Managing Favorites (on page 83)



Support for all external virtual media drive types
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Package Contents
Each KX III ships as a fully-configured stand-alone product in a standard
1U (2U for KX3-864) 19" rackmount chassis. Each KX III device ships
with the following contents:


1 - KX III device



1 - KX III Quick Setup Guide



1 - Rackmount kit



2 - AC power cords



1 - Set of 4 rubber feet (for desktop use)



1 - Application note



1 - Warranty card

KX III Device Photos and Features
Hardware


Integrated KVM-over-IP remote access



1U or 2U rack-mountable (brackets included)



Dual power supplies with failover; autoswitching power supply with
power failure warning



Support for the following CIMs:




For virtual media and Absolute Mouse Synchronization, use one
of the following CIMs:


D2CIM-VUSB



D2CIM-DVUSB



D2CIM-DVUSB-DVI



D2CIM-DVUSB-HDMI



D2CIM-DVUSB-DP

Required for PS2 connection:




2

DCIM-PS2

DVI monitor support from the DVI local port


VGA support via a DVI to VGA converter



DVI support via a standard DVI cable
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Support for tiering in which a base KX III device is used to access
multiple other tiered devices



Multiple user capacity (1/2/4/8 remote users; 1 local user)



UTP (Cat5/5e/6) server cabling



Dual Ethernet ports (10/100/1000 LAN) with failover



Field upgradable



Local USB User port for in-rack access


USB Keyboard/mouse ports



One front and three back panel USB ports for supported USB
devices



Fully concurrent local and remote user access



Local graphical user interface (GUI) for administration



Centralized access security



Integrated power control



LED indicators for dual power status, network activity, and remote
user status



Hardware Reset button

Note: Release KX III 3.0.0 does not provide modem support, but will in a
future release.
Software


Virtual media support in Windows®, Mac® and Linux® environments*



Absolute Mouse Synchronization*
*Note: Virtual media and Absolute Mouse Synchronization require
use of a D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI or D2CIM-DVUSB-DP CIM.
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Support for digital audio over USB



Port scanning and thumbnail view of up to 32 targets within a
configurable scan set



Web-based access and management



Intuitive graphical user interface (GUI)



Support for dual port video output



256-bit encryption of complete KVM signal, including video and
virtual media



LDAP, Active Directory®, RADIUS, or internal authentication and
authorization



DHCP or fixed IP addressing



Smart card/CAC authentication



SNMP, SNMP3 and Syslog management



IPv4 and IPv6 support



Power control associated directly with servers to prevent mistakes



Integration with Raritan's CommandCenter Secure Gateway (CC-SG)
management unit



CC Unmanage feature to remove device from CC-SG control



Support of Raritan PX1 and PX2 appliances

Dominion KX3-832
KX3-832 Photos

KX3-832 Features
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Diagram key
Dual Power AC 100V/240V
Local USB Ports
DVI-D Port
32 KVM Ports UTP Cabling
(Cat5/5e/6)
Dual 10/100/1000 Ethernet Access
Tier Port
Note: Release KX III 3.0.0 does not provide
modem support, but will in a future release.
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Dominion KX3-864
KX3-864 Photos

KX3-864 Features

Diagram key
Dual Power AC 100V/240V
Local USB Ports
DVI-D Port
64 KVM Ports UTP Cabling
(Cat5/5e/6)
Dual 10/100/1000 Ethernet Access
Tier Port
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Diagram key
Note: Release KX III 3.0.0 does not provide
modem support, but will in a future release.

Supported Users and Ports per Model
Model

Ports

Remote users

KX3-864

64

8

KX3-832

32

8

KX3-808

8

8

KX3-464

64

4

KX3-432

32

4

KX3-416

16

4

KX3-232

32

2

KX3-216

16

2

KX3-132

32

1

KX3-116

16

1

KX3-108

8

1

KX III Remote and Local Console Interfaces
Use the Remote Console interface to configure and manage the KX III
over a network connection.
The Local Console interface provides access to the KX III while at the
rack.
See KX III Remote Console Interface (on page 16), KX III Local
Console - KX III Administration Functions and KX III Local Console
Interface (on page 24), respectively.
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KX III KVM Client Applications
KX III works with the Virtual KVM Client (VKC) and the Active KVM Client
(AKC).
Java™ 1.7 is required to use the Java-based Virtual KVM Client.
Microsoft .NET® 3.5 (or later) is required to use KX III with the Microsoft
Windows®-based Active KVM Client (AKC).
For help on using the clients, see Virtual KVM Client (VKC) Help (on
page 25) and Active KVM Client (AKC) Help (on page 72).

KX III Online Help
KX III online help is considered your primary help resource. PDF
versions of help are a secondary resource.
See the KX III Release Notes for important information on the current
release before you begin using the KX III.
KVM Client help is provided as part of KX III online help.
Online help is accompanied by the KX III Quick Setup Guide, which can
be found on the Raritan Firmware, Upgrades and Documentation page of
Raritan's website
(http://www.raritan.com/support/firmware-and-documentation).
The Firmware, Upgrades and Documentation page also contains a PDF
version of the administrator help.
Note: To use online help, Active Content must be enabled in your
browser.
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Install and Configure KX III
If you have not already done so, install and configure KX III.
See the KX III Quick Setup Guide that came with the KX III device or
download it from the Raritan Support website
http://www.raritan.com/support, or see KX III Installation and
Configuration.

Allow Pop-Ups
Regardless of the browser used, you must allow pop-ups from the
device's IP address to launch the KX III Remote Console.

Security Warnings and Validation Messages
When logging in to KX III, security warnings and application validation
message may appear.
These include:


Java™ security warnings and requests to validate KX III. See Java
Validation and Access Warning (on page 9), and Installing a
Certificate (on page 10)



Additional security warnings based on your browser and security
settings. See Additional Security Warnings (on page 10)

Java Validation and Access Warning
When logging in to KX III, Java™ 1.7 prompts you to validate KX III, and
to allow access to the application.
Raritan recommends installing an SSL certificate in each KX III device in
order to reduce Java warnings, and enhance security. See SSL
Certificates
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Additional Security Warnings
Even after an SSL certificate is installed in the KX III, depending on your
browser and security settings, additional security warnings may be
displayed when you log in to KX III.
It is necessary to accept these warnings to launch the KX III Remote
Console.
Reduce the number of warning messages during subsequent log ins by
checking the following options on the security and certificate warning
messages:


In the future, do not show this warning



Always trust content from this publisher

Installing a Certificate
You may be prompted by the browser to accept and validate the KX III's
SSL certificate.
Depending on your browser and security settings, additional security
warnings may be displayed when you log in to KX III.
It is necessary to accept these warnings to launch the KX III Remote
Console. For more information, see Security Warnings and Validation
Messages (on page 9).
Two sample methods on how to install an SSL Certificate in the browser
are provided here, both using Microsoft Internet Explorer 8® and
Windows 7®.
Specific methods and steps depend on your browser and operating
system. See your browser and operating system help for details.
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Example 1: Import the Certificate into the Browser
In this example, you import the Certificate into the browser.

Steps
Open an IE browser, then log in to KX III.
Click More Information on the first Java™ security warning.
Click View Certificate Details on the More Information dialog. You are prompted to
install the certificate. Follow the wizard steps.
Note: If you are not prompted by the browser, manually select Tools > Internet
Options to open the Internet Options dialog.

11
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Steps
Click the Content tab.
Click Certificates.
The Certificate Import Wizard opens and walks you through each step.
 File to Import - Browse to locate the Certificate
 Certificate Store - Select the location to store the Certificate
Click Finish on the last step of the Wizard.
The Certificate is imported. Close the success message.
Click OK on the Internet Options dialog to apply the changes, then close and reopen
the browser.

12
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Example 2: Add the KX III to Trusted Sites and Import the Certificate
In this example, the KX III's URL is added as a Trusted Site, and the Self
Signed Certificate is added as part of the process.

Steps
Open an IE browser, then select Tools > Internet Options to open the Internet Options
dialog
Click the Security tab.
Click on Trusted Sites.
Disable Protected Mode, and accept any warnings.
Click Sites to open the Trusted Sites dialog.
Enter the KX III URL, then click Add.
Deselect server verification for the zone (if applicable).
Click Close.
Click OK on the Internet Options dialog to apply the changes, then close and reopen
the browser.
Next, import the Certificate.
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Steps
Open an IE browser, then log in to KX III.
Click More Information on the first Java™ security warning.
Click View Certificate Details on the More Information dialog. You are prompted to
install the certificate. Follow the wizard steps.
For details see, Example 1: Import the Certificate into the Browser (on page 11)

Logging In to the KX III
Log in to your KX III Remote Console from any workstation with network
connectivity. Java™ 1.7 is required to use the Java-based Virtual KVM
Client. Alternatively, Microsoft .NET ® 3.5 (or later) is required to use KX
III with the Microsoft Windows®-based Active KVM Client (AKC).
Logging in and using KX III requires you to allow pop-ups.
For information on security warnings and validation messages, and steps
to reduce or eliminate them, see Security Warnings and Validation
Messages (on page 9).
To log in to the KX III:
1. Launch a supported web browser.
2. Enter either:

14
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The URL - http://IP-ADDRESS to use the Java-based Virtual
KVM Client
Or



http://IP-ADDRESS/akc for the Microsoft .NET-based Active KVM
Client

IP-ADDRESS is the IP address assigned to your KX III
You can also use HTTPS, or the DNS name of the KX III assigned by
your administrator (if applicable).
You are always redirected to the IP address from HTTP to HTTPS.
3. Enter your username and password, then click Login.
4. Accept the user agreement (if applicable).
5. If security warnings appear, accept and/or allow access.

15

Chapter 3

KX III Interface and Navigation

In This Chapter
Overview ..................................................................................................16
KX III Remote Console Interface .............................................................16
KX III Local Console Interface .................................................................24

Overview
The KX III Remote Console and the KX III Local Console interfaces
provide a web-based interface for device configuration and
administration, as well as target server list and selection.

KX III Remote Console Interface
The KX III Remote Console is a browser-based graphical user interface
that allows you to log in to KVM target servers and serial targets
connected to the KX III and to remotely administer the KX III.
The KX III Remote Console provides a digital connection to your
connected KVM target servers. When you log into a KVM target server
using the KX III Remote Console, a Virtual KVM Client window opens.
There are many similarities among the KX III Local Console and the KX
III Remote Console graphical user interfaces, and where there are
differences, they are noted in the user manual. The following options are
available in the KX III Remote Console but not the KX III Local Console:


Virtual Media



Favorites



Backup/Restore



Firmware Upgrade



SSL Certificates



Audio
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Port Access Page (Remote Console Display)
After a successful login, the Port Access page opens listing all ports
along with their status and availability.
Ports connected to KVM target servers (blades and standard servers)
are displayed in blue. Right-click on any of these ports to open the Port
Action menu. For more information, see Port Action Menu (on page 20).
Ports with no CIM connected or with a blank CIM name, a default port
name of Dominion-KX3_Port#is assigned, where Port# is the number of
the KX III physical port.

Four tabs are provided on the page allowing you to view by port, view by
group, view by search and scan ports.
You can sort by Port Number, Port Name, Status (Up and Down), and
Availability (Idle, Connected, Busy, Unavailable, and Connecting) by
clicking on the column heading.
Use the Set Scan tab to scan for up to 32 targets that are connected to
the KX III. See Scanning Ports - Remote Console (on page 77)
Tiered Devices - Port Access Page

If you are using a tiered configuration in which a base KX III device is
used to access multiple other tiered devices, the tiered devices are
viewed on the Port Access page by clicking on the Expand Arrow icon
to the left of the tier device name.
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Blade Chassis - Port Access Page

The blade chassis is displayed in an expandable, hierarchical list on the
Port Access page, with the blade chassis at the root of the hierarchy and
the individual blades labeled and displayed below the root. Use the
Expand Arrow icon
next to the root chassis to display the individual
blades.
Note: To view the blade chassis in a hierarchal order, blade-chassis
subtypes must be configured for the blade server chassis.
Dual Port Video Groups - Port Access Page

Dual video port groups appear on the Port Access page as Dual Port
types.
The primary and secondary ports that are a part of the port group appear
on the Port Access page as Dual Port(P) and Dual Port(S), respectively.
For example, if the CIM type is DCIM, "DCIM Dual Port (P)" is displayed.
When you access a dual port video group from the remote client, you
connect to the primary port, which opens a KVM connection window to
both the primary and secondary ports of the dual port group.
Note: The dual video primary port is defined when the port group is
created.
Note: Two KVM channels are required to remotely connect to the dual
video port group by clicking primary port. If two channels are not
available, the Connect link is not displayed.
Note: The Action menu is not displayed when you click on a secondary
port in a dual video port group.
Note: You cannot connect to the primary port and secondary port at the
same time from the Local Port.
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View by Group Tab

The View by Group tab displays blade chassis, 'standard' port groups,
and dual video port groups. Click the Expand Arrow icon
next to a
group to view the ports assigned to the port group.

View by Search Tab

The View by Search tab allows you to search by port name. The search
feature supports the use of an asterisk (*) as a wildcard, and full and
partial names.
Set Scan Tab

The port scanning feature is accessed from the Set Scan tab on the Port
Access page. The feature allows you to define a set of targets to be
scanned. Thumbnail views of the scanned targets are also available.
Select a thumbnail to open that target in its Virtual KVM Client window.
See See Scanning Ports - Remote Console (on page 77) for more
information.
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Port Action Menu
When you click a Port Name in the Port Access list, the Port Action menu
appears.
Choose the desired menu option for that port to execute it. Note that only
currently available options, depending on the port's status and availability,
are listed in the Port Action menu.

Connect



Connect - Creates a new connection to the target server.
For the KX III Remote Console, a new Virtual KVM Client page
appears.
For the KX III Local Console, the display switches to the target server,
and switches away from the local user interface.
On the local port, the KX III Local Console interface must be visible in
order to perform the switch.
Hot key switching is also available from the local port.
Note: This option is not available from the KX III Remote Console for
an available port if all connections are busy.
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Switch From



Switch From - Switches from an existing connection to the selected
port (KVM target server).
This menu item is available only for KVM targets, and only when a
Virtual KVM Client is opened.
Note: This menu item is not available on the KX III Local Console.

Disconnect



Disconnect - Disconnects this port and closes the Virtual KVM Client
page for this target server.
This menu item is available only when the port status is up and
connected, or up and busy.
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Note: This menu item is not available on the KX III Local Console.
The only way to disconnect from the switched target in the Local
Console is to use the hot key.

Power On



Power On - Powers on the target server through the associated
outlet.
This option is visible only when there are one or more power
associations to the target, and when the user has permission to
operate this service.

Power Off



Power Off - Powers off the target server through the associated
outlets.
This option is visible only when there are one or more power
associations to the target, when the target power is on (port status is
up), and when user has permission to operate this service.

Power Cycle



Power Cycle - Power cycles the target server through the associated
outlets.
This option is visible only when there are one or more power
associations to the target, and when the user has permission to
operate this service.
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Left Panel
The left panel of the KX III interface contains the following information.
Note that some information is conditional - meaning it is displayed based
on your role, features being used and so on. Conditional information is
noted here.
Information

Description

When displayed?

Time & Session

The date and time the
current session started

Always

User

Username

Always

State

The current state of the
application, either idle or
active. If idle, the
application tracks and
displays the time the
session has been idle.

Always

Your IP

The IP address used to
access the KX III

Always

Last Login

The last login date and
time

Always

Under CC-SG
Management

The IP address of the
CC-SG device managing
the KX III

When the KX III is
being managed by
CC-SG

Device Information

Information specific to the Always
KX III you are using

Device Name

Name assigned to the
device

IP Address

The IP address of the KX Always
III

Firmware

Current version of
firmware

Always

Device Model

Model of the KX III

Always

Serial number

Serial number of the KX
III

Always

Network

The name assigned to
the current network

Always

Always
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Information

Description

When displayed?

PowerIn1

Status of the power 1
outlet connection. Either
on or off, or Auto-detect
off

Always

PowerIn2

Status of the power 2
outlet connection. Either
on or off, or Auto-detect
off

Always

Configured As
If you are using a tiering When the KX III is
Base or Configured configuration, this
part of a tiered
indicates if the KX III you configuration
As Tiered
are accessing is the base
device or a tiered device.
Port States

The statuses of the ports
being used by the KX III

Always

Connect Users

The users, identified by
Always
their username and IP
address, who are
currently connected to the
KX III

Online Help

Links to online help

Favorite Devices

See Managing Favorites When enabled
(on page 83)

FIPS Mode

FIPS Mode: EnabledSSL
Certificate: FIPS Mode
Compliant

Always

When FIPS is
enabled

KX III Local Console Interface
There are many similarities among the KX III Local Console and the KX
III Remote Console graphical user interfaces. Where there are
differences, they are noted in the help.
For details on using the Local Console see KX III Local Console - KX III
End User Help (on page 87).
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Overview
Whenever you access a target server from the Port Access page of KX
III the Remote Console, a Virtual KVM Client (VKC) window opens.

25

Chapter 4: Virtual KVM Client (VKC) Help

There is one Virtual KVM Client for each target server connected.
Virtual KVM Client windows can be minimized, maximized, and moved
around your computer desktop.
IMPORTANT: Refreshing your browser closes the Virtual KVM
Client connection, so exercise caution.

Virtual KVM Client Java Requirements
Java™ 1.7 is required to use the Java-based Virtual VKM Client (VKC).

Virtual KVM Client and Active KVM Client (AKC) Shared Features
The Virtual KVM Client (VKC) and Active KVM Client (AKC) are
interfaces used to access remote targets.
VKC and AKC share similar features with the exception of the following:


Minimum system requirements



Supported operating systems and browsers



Keyboard macros created in AKC cannot be used in VKC



Direct port access configuration (see Enabling Direct Port Access
via URL)



AKC server certification validation configuration (see Prerequisites
for Using AKC (on page 74))

Connect to a Target Server
Once you have logged on to the KX III Remote Console, access target
servers via the Virtual KVM Client (VKC) or Active KVM Client (AKC).
To connect to an available server:
1. On the Port Access page, click on the port name of the target server
you want to connect to. The Port Action menu opens.
2. Click Connect.
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See Port Action Menu (on page 20) for details on additional available
menu options.

Configuring Connection Properties
Access Connection Properties
To access connection properties:
Click Connection > Properties, or click the Connection... icon to open the
Connection Properties dialog.

About Connection Properties
The Virtual KVM Client (VKC) and Active KVM Client (AKC) support
connection property management.
Connection properties manage streaming video performance over
remote connections to target servers.
The properties are applied only to your connection - they do not impact
the connection of other users accessing the same target servers via VKC
or AKC.
If you make changes to connection properties, they are retained by VKC
and AKC.
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Default Connection Property Settings - Optimized for Best
Performance
KX III comes configured to provide optimal performance for the majority
of video streaming conditions.
Default connection settings are:


Optimized for: Text Readability - video modes are designed to
maximize text readability.
This setting is ideal for general IT and computer applications, such as
performing server administration.



Video Mode - defaults to Full Color 2.
Video frames transmit in high-quality, 24-bit color. This setting is
suitable where a high-speed LAN is used.



Noise Filter - defaults to 2.
The noise filter setting does not often need to be changed.

Click Reset on the Connection Properties dialog at any time to return to
the default settings.
Tip: Use the Connection Information dialog to monitor the connection in
real-time. See Access and Copy Connection Information (on page 31)
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Optimize for: Selections
Text Readability

When Text Readability is selected, all video modes are designed to
provide high-quality, readable text.
This setting is ideal when working with computer GUIs, such as when
performing server administration and so on.
When working in full color video modes, a slight contrast boost is
provided, and text is sharper.
In lower quality video modes, bandwidth is decreased at the expense of
accuracy.
Color Accuracy

When Color Accuracy is selected, all video modes are rendered in full
color with flat color response.
This setting applies to viewing video streams such as movies or other
broadcast streams.
In lower quality video modes, sharpness of fine detail, such as text, is
sacrificed.
Video Mode
The Video Mode slider controls each video frame's encoding, affecting
video quality, frame rate and bandwidth.
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In general, moving the slider to the left results in higher quality at the cost
of higher bandwidth and, in some cases, lower frame rate.
Moving the slider to the right enables stronger compression, reducing the
bandwidth per frame, but video quality is reduced.
In situations where system bandwidth is a limiting factor, moving the
video mode slider to the right can result in higher frame rates.
When Text Readability is selected as the Optimized setting, the four
rightmost modes provide reduced color resolution or no color at all.
These modes are appropriate for administration work where text and GUI
elements take priority, and bandwidth is at a premium.
Click Reset on the Connection Properties dialog at any time to return to
the default settings.
Noise Filter
Unless there is a specific need to do so, do not change the noise filter
setting. The default setting is designed to work well in most situations.
The Noise Filter controls how much interframe noise is absorbed by the
KX III.

Moving the Noise Filter slider to the left lowers the filter threshold,
resulting in higher dynamic video quality. However, more noise is likely to
come through, resulting in higher bandwidth and lower frame rates.
Moving the slider to the right raises the threshold, allows less noise and
less bandwidth is used. Video artifacts may be increased.
Moving the noise filter to the right may be useful when accessing a
computer GUI over severely bandwidth-limited connections.
Click Reset on the Connection Properties dialog at any time to return to
the default settings.
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Connection Information
Open the Connection Information dialog for real-time connection
information, and copy the information from the dialog as needed.
This is useful if, for example, you want to gather real-time information on
your current connection. See Configuring Connection Properties (on
page 27)
The following information is displayed about the current connection:


KX III Name - The name of the KX III.



IP Address - The IP address of the KX III.



Port - The KVM communication TCP/IP port used to access the KX
III.



Data In/Second - Data rate received from the KX III.



Data Out/Second - Data rate sent to the KX III.



Connect Time - The duration of the current connection.



FPS - Video frames per second transmitted received from the KX III.



Horizontal Resolution - The target server horizontal resolution.



Vertical Resolution - The target server vertical resolution.



Refresh Rate - Refresh rate of the target server.



Protocol Version - Raritan communications protocol version.

Access and Copy Connection Information
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Steps
Click Connection > Info... to open the Connection Info dialog.
Click Copy to Clipboard. Paste the information in a file of your choosing.

USB Profiles
Set a USB profile for a target server from the Virtual KVM Client (VKC)
by clicking USB Profile in the menu, then selecting from the menu
choices.

Select a USB profile that best applies to the KVM target server.
For example, if the server is running Windows® operating system, it
would be best to use the Generic profile.
Or, to change settings in the BIOS menu or boot from a virtual media
drive, depending on the target server model, a BIOS profile may be more
appropriate.
For details on USB profiles, see USB Profiles - Overview.
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Keyboard
Send Ctrl+Alt+Del Macro
Due to its frequent use, a Ctrl+Alt+Delete macro is preprogrammed.
Selecting Keyboard > Send Ctrl+Alt+Del, or clicking on the
Ctrl+Alt+Delete button
in the toolbar sends this key sequence to
the server or to the KVM switch to which you are currently connected.
In contrast, if you were to physically press the Ctrl+Alt+Del keys, the
command would first be intercepted by your own PC due to the structure
of the Windows operating system, instead of sending the key sequence
to the target server as intended.
Send LeftAlt+Tab (Switch Between Open Windows on a Target
Server)
Select Keyboard > Send LeftAlt + Tab to switch between open windows
on the target server or KVM switch you are connected to.
Setting CIM Keyboard/Mouse Options
To access the DCIM-USBG2 setup menu:
1. Put the mouse focus on a window such as Note Pad (Windows ®
operating system) or an equivalent.
2. Select Set CIM Keyboard/Mouse options. This is the equivalent of
sending the Left-Control and Num Lock to the target. The CIM setup
menu options are then displayed.
3. Set the language and mouse settings.
4. Exit the menu to return to normal CIM functionality.
Send Text to Target
To use the Send Text to Target function for the macro:
1. Click the Keyboard > Send Text to Target. The Send Text to Target
dialog appears.
2. Enter the text you want sent to the target.
Note: Non-English characters are not supported by the Send Text to
Target function.
3. If the target uses a US/International keyboard layout, select the
"Target system is set to the US/International keyboard layout"
checkbox.
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4. Click OK.
Keyboard Macros
Keyboard macros ensure that keystroke combinations intended for the
target server are sent to and interpreted only by the target server.
Otherwise, they might be interpreted by the computer on which the
Virtual KVM Client (VKC) is running (your client PC).
Macros are stored on the client PC and are PC-specific. Therefore, if you
use another PC, you cannot see your macros.
In addition, if another person uses your PC and logs in under a different
name, that user will see your macros since they are computer-wide.
Keyboard macros created in Virtual KVM Client (VKC) cannot be used in
Active KVM Client (AKC) or vice versa.
Build a New Macro
To build a macro:
1. Click Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.
2. Click Add. The Add Keyboard Macro dialog appears.
3. Type a name for the macro in the Keyboard Macro Name field. This
name appears in the Keyboard menu after it is created.
4. From the Hot-Key Combination field, select a keyboard combination
from the drop-down list. This allows you to execute the macro with a
predefined keystroke. Optional
5. In the Keys to Press drop-down list, select each key you would like to
use to emulate the keystrokes that is used to perform the command.
Select the keys in the order by which they are to be pressed. After
each selection, select Add Key. As each key is selected, it appears
in the Macro Sequence field and a Release Key command is
automatically added after each selection.
For example, create a macro to close a window by selecting Left Ctrl
+ Esc. This appears in the Macro Sequence box as follows:
Press Left Alt
Press F4
Esc
Release F4
Esc
Release Left Alt
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6. Review the Macro Sequence field to be sure the macro sequence is
defined correctly.
a. To remove a step in the sequence, select it and click Remove.
b. To change the order of steps in the sequence, click the step and
then click the up or down arrow buttons to reorder them as
needed.
7. Click OK to save the macro. Click Clear to clear all field and start
over. When you click OK, the Keyboard Macros dialog appears and
lists the new keyboard macro.
8. Click Close to close the Keyboard Macros dialog. The macro now
appears on the Keyboard menu in the application.
9. Select the new macro on the menu to run it or use the keystrokes
you assigned to the macro.
Import Macros
To import macros:
1. Choose Keyboard > Import Keyboard Macros to open the Import
Macros dialog. Browse to the folder location of the macro file.
2. Click on the macro file and click Open to import the macro.
a. If too many macros are found in the file, an error message is
displayed and the import terminates once OK is selected.
b. If the import fails, an error dialog appears and a message
regarding why the import failed is displayed. Select OK to
continue the import without importing the macros that cannot be
imported.
3. Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Deselect All options.
4. Click OK to begin the import.
a. If a duplicate macro is found, the Import Macros dialog appears.
Do one of the following:
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Click Yes to replace the existing macro with the imported
version.



Click Yes to All to replace the currently selected and any
other duplicate macros that are found.



Click No to keep the original macro and proceed to the next
macro



Click No to All keep the original macro and proceed to the
next macro. Any other duplicates that are found are skipped
as well.



Click Cancel to stop the import.



Alternatively, click Rename to rename the macro and import
it. If Rename is selected, the Rename Macro dialog appears.
Enter a new name for the macro in the field and click OK.
The dialog closes and the process proceeds. If the name
that is entered is a duplicate of a macro, an alert appears
and you are required to enter another name for the macro.

b. If during the import process the number of allowed, imported
macros is exceeded, a dialog appears. Click OK to attempt to
continue importing macros or click Cancel to stop the import
process.
The macros are then imported. If a macro is imported that contains a hot
key that already exists, the hot key for the imported macro is discarded.
Export Macros
1. Choose Tools > Export Macros to open the Select Keyboard Macros
to Export dialog.

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Deselect All options.
3. Click Ok. An "Export Keyboard Macros to" dialog is displayed.
Locate and select the macro file. By default, the macro exists on your
desktop.
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4. Select the folder to save the macro file to, enter a name for the file
and click Save. If the macro already exists, you receive an alert
message.
5. Select Yes to overwrite the existing macro or No to close the alert
without overwriting the macro.

Video Properties
Refreshing the Screen
The Refresh Screen command forces a refresh of the video screen.
Video settings can be refreshed automatically in several ways:


The Refresh Screen command forces a refresh of the video screen.



The Auto-sense Video Settings command automatically detects the
target server's video settings.



The Calibrate Color command calibrates the video to enhance the
colors being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.
To refresh the video settings, do one of the following:


Choose Video > Refresh Screen, or click the Refresh Screen button
in the toolbar.

Auto-Sense Video Settings
The Auto-sense Video Settings command forces a re-sensing of the
video settings (resolution, refresh rate) and redraws the video screen.
To automatically detect the video settings, do the following:


Choose Video > Auto-sense Video Settings, or click the Auto-Sense
Video Settings button

in the toolbar.

A message stating that the auto adjustment is in progress appears.
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Calibrating Color
Use the Calibrate Color command to optimize the color levels (hue,
brightness, saturation) of the transmitted video images. The color
settings are on a target server-basis.
Note: The Calibrate Color command applies to the current connection
only.
To calibrate the color, do the following:


Choose Video > Calibrate Color, or click the Calibrate Color button
in the toolbar.
The target device screen updates its color calibration.

Adjusting Video Settings
Use the Video Settings command to manually adjust the video settings.
To change the video settings:
1. Choose Video > Video Settings to open the Video Settings dialog.
2. Adjust the following settings as required. As you adjust the settings
the effects are immediately visible:
a. PLL Settings
Clock - Controls how quickly video pixels are displayed across
the video screen. Changes made to clock settings cause the
video image to stretch or shrink horizontally. Odd number
settings are recommended. Under most circumstances this
setting should not be changed because the autodetect is usually
quite accurate.
Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.
b. Brightness: Use this setting to adjust the brightness of the target
server display.
c.

Brightness Red - Controls the brightness of the target server
display for the red signal.

d. Brightness Green - Controls the brightness of the green signal.
e. Brightness Blue - Controls the brightness of the blue signal.
f.

Contrast Red - Controls the red signal contrast.

g. Contrast Green - Controls the green signal.
h. Contrast Blue - Controls the blue signal.
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If the video image looks extremely blurry or unfocused, the
settings for clock and phase can be adjusted until a better image
appears on the active target server.
Warning: Exercise caution when changing the Clock and Phase
settings. Doing so may result in lost or distorted video and you may
not be able to return to the previous state. Contact Raritan Technical
Support before making any changes.
i.

Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor.

j.

Vertical Offset - Controls the vertical positioning of the target
server display on your monitor.

3. Select Automatic Color Calibration to enable this feature.
4. Select the video sensing mode:


Best possible video mode

The device will perform the full Auto Sense process when
switching targets or target resolutions. Selecting this option
calibrates the video for the best image quality.


Quick sense video mode

With this option, the device will use a quick video Auto Sense in
order to show the target's video sooner. This option is especially
useful for entering a target server's BIOS configuration right after
a reboot.
5. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.
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Note: Some Sun background screens, such as screens with very dark
borders, may not center precisely on certain Sun servers. Use a different
background or place a lighter colored icon in the upper left corner of the
screen.

Screenshot from Target Command (Target Screenshot)
You are able to take a screenshot of a target server using the
Screenshot from Target server command. If needed, save this
screenshot to a file location of your choosing as a bitmap, JPEG or PNG
file.
To take a screenshot of the target server:
1. Select Video > Screenshot from Target, or click the Target
Screenshot button

on the toolbar.

2. In the Save dialog, choose the location to save the file, name the file,
and select a file format from the 'Files of type' drop-down.
3. Click Save to save the screenshot.
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Mouse Options
When in dual mouse mode, and provided the option is properly
configured, the mouse cursors align.
In dual mouse mode, when controlling a target server, the Remote
Console displays two mouse cursors: one belonging to your KX III client
workstation, and the other belonging to the target server.
You can operate in either single mouse mode or dual mouse mode.
When there are two mouse cursors, the device offers several mouse
modes:


Absolute (Mouse Synchronization)



Intelligent (Mouse Mode)



Standard (Mouse Mode)

When the mouse pointer lies within the KVM Client target server window,
mouse movements and clicks are directly transmitted to the connected
target server.
While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.
On fast LAN connections, you can use single mouse mode, and view
only the target server's pointer.
You can toggle between these two modes (single mouse and dual
mouse).

41

Chapter 4: Virtual KVM Client (VKC) Help

Dual Mouse Modes
Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different
acceleration or speed.
This mode is supported on servers with USB ports and is the default
mode for Virtual Media CIMs.
Absolute Mouse Synchronization requires the use of a virtual media CIM:


D2CIM-VUSB



D2CIM-DVUSB



D2CIM-DVUSB-DVI



D2CIM-DVUSB-HDMI



D2CIM-DVUSB-DP
To enter Absolute Mouse Synchronization:



Choose Mouse > Absolute.

Note that the black connector on the DVUSB CIMs are used for the
keyboard and mouse. The gray connector is used for virtual media.
Keep both plugs of the CIM connected to the device. The device may not
operate properly if both plugs are not connected to the target server.
Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing mouse
acceleration on the target. Intelligent mouse mode is the default for
non-VM targets.

Enter Intelligent Mouse Mode

To enter intelligent mouse mode:
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Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the
Mouse menu, automatically synchronizes mouse cursors during
moments of inactivity. For this to work properly, however, the following
conditions must be met:


The active desktop should be disabled on the target.



No windows should appear in the top left corner of the target page.



There should not be an animated background in the top left corner of
the target page.



The target mouse cursor shape should be normal and not animated.



The target mouse speeds should not be set to very slow or very high
values.



Advanced mouse properties such as “Enhanced pointer precision" or
“Snap mouse to default button in dialogs” should be disabled.



Choose “Best Possible Video Mode” in the Video Settings window.



The edges of the target video should be clearly visible (that is, a
black border should be visible between the target desktop and the
remote KVM console window when you scroll to an edge of the
target video image).



When using the intelligent mouse synchronization function, having a
file icon or folder icon located in the upper left corner of your desktop
may cause the function not to work properly. To be sure to avoid any
problems with this function, Raritan recommends you do not have file
icons or folder icons in the upper left corner of your desktop.

After autosensing the target video, manually initiate mouse
synchronization by clicking the Synchronize Mouse button on the toolbar.
This also applies when the resolution of the target changes if the mouse
cursors start to desync from each other.
If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.
Please note that mouse configurations will vary on different target
operating systems. Consult your OS guidelines for further details. Also
note that intelligent mouse synchronization does not work with UNIX
targets.
Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization
algorithm using relative mouse positions. Standard Mouse mode requires
that mouse acceleration is disabled and other mouse parameters are set
correctly in order for the client and server mouse to stay synchronized.
To enter Standard Mouse mode:


Choose Mouse > Standard.
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Mouse Synchronization Tips

If you have an issue with mouse synchronization:
1. Verify that the selected video resolution and refresh rate are among
those supported by the device. The KVM Client Connection Info
dialog displays the actual values that the device is seeing.
2. Force an auto-sense by clicking the KVM Client auto-sense button.
3. If that does not improve the mouse synchronization (for Linux, UNIX,
and Solaris KVM target servers):
a. Open a terminal window.
b. Enter the following command: xset mouse 1 1
c.

Close the terminal window.

4. Click the "KVM Client mouse synchronization" button

.

Synchronize Your Mouse

In dual mouse mode, the Synchronize Mouse command forces
realignment of the target server mouse pointer with KVM Client mouse
pointer.
To synchronize the mouse, do one of the following:


Choose Mouse > Synchronize Mouse or click the Synchronize
Mouse button

in the toolbar.

Note: This option is available only in Standard and Intelligent mouse
modes.
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Single Mouse Mode
Single Mouse mode uses only the target server mouse cursor and the
local mouse pointer no longer appears onscreen.
Note: Single mouse mode does not work on Windows or Linux targets
when client is running on a Virtual Machine.
To enter single mouse mode, do one the following:


Choose Mouse > Single Mouse Cursor.



Click the Single/Double Mouse Cursor button

in the toolbar.

To exit single mouse mode:
1. Press Ctrl+Alt+O on your keyboard to exit single mouse mode.

Tool Options
General Settings
To set the tools options:
1. Click Tools > Options. The Options dialog appears.
2. Select the Enable Logging checkbox only if directed to by Technical
Support.
This option creates a log file in your home directory.
3. Choose the Keyboard Type from the drop-down list (if necessary).
The options include:


US/International



French (France)



German (Germany)



Japanese
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United Kingdom



Korean (Korea)



French (Belgium)



Norwegian (Norway)



Portuguese (Portugal)



Danish (Denmark)



Swedish (Sweden)



German (Switzerland)



Hungarian (Hungary)



Spanish (Spain)



Italian (Italy)



Slovenian



Translation: French - US



Translation: French - US International

In AKC, the keyboard type defaults to the local client, so this option
does not apply.
4. Configure hotkeys:


Exit Full Screen Mode - Hotkey.
When you enter Full Screen mode, the display of the target
server becomes full screen and acquires the same resolution as
the target server.
This is the hot key used for exiting this mode.



Exit Single Cursor Mode - Hotkey.
When you enter single cursor mode, only the target server
mouse cursor is visible.
This is the hot key used to exit single cursor mode and bring
back the client mouse cursor.



Disconnect from Target - Hotkey.
Enable this hotkey to allow users to quickly disconnect from the
target.

For hotkey combinations, the application does not allow you to
assign the same hotkey combination to more than one function.
For example, if Q is already applied to the Disconnect from Target
function, it won't be available for the Exit Full Screen Mode function.
Further, if a hotkey is added to the application due to an upgrade and
the default value for the key is already in use, the next available
value is applied to the function instead.
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5. Click OK.

Keyboard Limitations

Turkish Keyboards
If using a Turkish keyboard, you must connect to a target server through
the Active KVM Client (AKC). It is not supported by other Raritan clients.
Slovenian Keyboards
The < key does not work on Slovenian keyboards due to a JRE
limitation.
Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key
Events for foreign-language keyboards configured using System
Preferences, Raritan recommends that you configure foreign keyboards
using the methods described in the following table.
Language

Configuration method

US Intl

Default

French

Keyboard Indicator

German

System Settings (Control Center)

Japanese

System Settings (Control Center)

UK

System Settings (Control Center)

Korean

System Settings (Control Center)
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Language

Configuration method

Belgian

Keyboard Indicator

Norwegian

Keyboard Indicator

Danish

Keyboard Indicator

Swedish

Keyboard Indicator

Hungarian

System Settings (Control Center)

Spanish

System Settings (Control Center)

Italian

System Settings (Control Center)

Slovenian

System Settings (Control Center)

Portuguese

System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using
Gnome as a desktop environment.
Client Launch Settings
Configuring client launch settings allows you to define the screen
settings for a KVM session.
To configure client launch settings:
1. Click Tools > Options. The Options dialog appears.
2. Click on the Client Launch Settings tab.


To configure the target window settings:

a. Select 'Standard - sized to target Resolution' to open the window
using the target's current resolution. If the target resolution is
greater than the client resolution, the target window covers as
much screen area as possible and scroll bars are added (if
needed).
b. Select 'Full Screen' to open the target window in full screen
mode.


To configure the monitor on which the target viewer is launched:

a. Select 'Monitor Client Was Launched From' if you want the target
viewer to be launched using the same display as the application
that is being used on the client (for example, a web browser or
applet).
b. Use 'Select From Detected Monitors' to select from a list of
monitors that are currently detected by the application. If a
previously selected monitor is no longer detected, 'Currently
Selected Monitor Not Detected' is displayed.
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a. Select 'Enable Single Cursor Mode' to enable single mouse
mode as the default mouse mode when the server is accessed.
b. Select 'Enable Scale Video' to automatically scale the display on
the target server when it is accessed.
c.

Select 'Pin Menu Toolbar' if you want the toolbar to remain
visible on the target when it is in Full Screen mode. By default,
while the target is in Full Screen mode, the menu is only visible
when you hover your mouse along the top of the screen.

3. Click OK.
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Configuring Port Scan Settings in VKC and AKC
Configuring port scan options in VKC and AKC applies to scanning from
the KX III Remote Console.
To configure port scan options for the Local Console, see Configure
Local Console Scan Settings (on page 94)
Use the port scanning feature to search for selected targets, and display
them in a slide show view, allowing you to monitor up to 32 targets at
one time.
You can connect to targets or focus on a specific target as needed.
Scans can include standard targets, blade servers, tiered Dominion
devices, and KVM switch ports.
Configure scan settings from either the Virtual KVM Client (VKC) or
Active KVM Client (AKC).
See Scanning Ports - Remote Console (on page 77)
Use the Scan Settings tab to customize the scan interval and default
display options.
Configure Port Scan

To set scan settings:
1. Click Tools > Options. The Options dialog appears.
2. Select the Scan Settings tab.
3. In the "Display Interval (10-255 sec):" field, specify the number of
seconds you want the target that is in focus to display in the center of
the Port Scan window.
4. In the "Interval Between Ports (10 - 255 sec):" field, specify the
interval at which the device should pause between ports.
5. In the Display section, change the default display options for the
thumbnail size and split orientation of the Port Scan window.
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6. Click OK.

View Options
View Toolbar
You can use the Virtual KVM client with or without the toolbar display.
To toggle the display of the toolbar (on and off):


Choose View > View Toolbar.

View Status Bar
By default, the status bar is displayed at the bottom of the target window.
To hide the status bar:


Click View > Status Bar to deselect it.
To restore the status bar:



Click View > Status Bar to select it.
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Scaling
Scaling your target window allows you to view the entire contents of the
target server window.
This feature increases or reduces the size of the target video to fit the
Virtual KVM Client window size, and maintains the aspect ratio so that
you see the entire target server desktop without using the scroll bar.
To toggle scaling (on and off):


Choose View > Scaling.

Full Screen Mode
When you enter Full Screen mode, the target's full screen is displayed
and acquires the same resolution as the target server.
The hot key used for exiting this mode is specified in the Options dialog,
see Tool Options (on page 45).
While in Full Screen mode, moving your mouse to the top of the screen
displays the Full Screen mode menu bar.
If you want the menu bar to remain visible while in Full Screen mode,
enable the Pin Menu Toolbar option from the Tool Options dialog. See
Tool Options (on page 45).
To enter full screen mode:


Choose View > Full Screen, or click the Full Screen button

.

To exit full screen mode:


Press the hot key configured in the Tool's Options dialog. The default
is Ctrl+Alt+M.

If you want to access the target in full screen mode at all times, you can
make Full Screen mode the default.
To set Full Screen mode as the default mode:
1. Click Tools > Options to open the Options dialog.
2. Select Enable Launch in Full Screen Mode and click OK.
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Virtual Media
All KX III models support virtual media. Virtual media extends KVM
capabilities by enabling target servers to remotely access media from a
client PC and network file servers.
With this feature, media mounted on client PCs and network file servers
are essentially "mounted virtually" by the target server. The target server
can then read from and write to that media as if it were physically
connected to the target server itself.
Each KX III comes equipped with virtual media to enable remote
management tasks using the widest variety of CD, DVD, USB, audio
playback and record devices, internal and remote drives, and images.
Virtual media sessions are secured using 128 or 256 bit AES, or RC4
encryption.
Prerequisites for Using Virtual Media
KX III Virtual Media Prerequisites



For users requiring access to virtual media, the KX III permissions
must be set to allow access to the relevant ports, as well as virtual
media access (VM Access port permission) for those ports. Port
permissions are set at the group-level.



A USB connection must exist between the device and the target
server.



If you want to use PC-Share, Security Settings must also be enabled
in the Security Settings page. Optional



You must choose the correct USB profile for the KVM target server
you are connecting to.

Remote PC VM Prerequisites



Certain virtual media options require administrative privileges on the
remote PC (for example, drive redirection of complete drives).
Note: If you are using Microsoft Vista or Windows 7, disable User
Account Control or select Run as Administrator when starting
Internet Explorer. To do this, click the Start Menu, locate IE,
right-click and select Run as Administrator.

Target Server VM Prerequisites



KVM target servers must support USB connected drives.



USB 2.0 ports are faster and preferred.
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CIMs Required for Virtual Media

You must use one of the following CIMs is to use virtual media:


D2CIM-VUSB



D2CIM-DVUSB



D2CIM-DVUSB-DVI



D2CIM-DVUSB-HDMI



D2CIM-DVUSB-DP

Note that the black connector on the DVUSB CIMs are used for the
keyboard and mouse. The gray connector is used for virtual media.
Keep both plugs of the CIM connected to the device. The device may not
operate properly if both plugs are not connected to the target server.
Mounting Local Drives
This option mounts an entire drive, which means the entire disk drive is
mounted virtually onto the target server.
Use this option for hard drives and external drives only. It does not
include network drives, CD-ROM, or DVD-ROM drives.
Notes on Mounting Local Drives

KVM target servers running the Windows XP® operating system may not
accept new mass storage connections after an NTFS-formatted partition
(for example, the local C drive) has been redirected to them.
If this occurs, close the Remote Console and reconnect before
redirecting another virtual media device. If other users are connected to
the same target server, they must also close their connections to the
target server.
Supported Tasks Via Virtual Media
Virtual media provides the ability to perform tasks remotely, such as:
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Transferring files



Running diagnostics



Installing or patching applications



Complete installation of the operating system



Record and playback of digital audio
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Supported Virtual Media Types
The following virtual media types are supported for Windows ®, Mac® and
Linux™ clients:


Internal and external hard drives



Internal and USB-mounted CD and DVD drives



USB mass storage devices



PC hard drives



ISO images (disk images)



Digital audio devices*

Note: ISO9660 is the standard supported by Raritan. However, other ISO
standards can be used.
Conditions when Read/Write is Not Available

Virtual media Read/Write is not available in the following situations:


For Linux® and Mac® clients



When the drive is write-protected



When the user does not have Read/Write permission:


Port Permission Access is set to None or View



Port Permission VM Access is set to Read-Only or Deny

Supported Virtual Media Operating Systems
The following client operating systems are supported:


Windows® 7 operating system



Windows 8 operating system



Windows XP® operating system



openSUSE® 11.4 Celadon (x86_64)



Fedora® 18



RHEL® 6.4



OSX Mountain Lion® 10.7 (and later)



Solaris® 10

The Active KVM Client (AKC) can be used to mount virtual media types
but only for Windows operating systems.
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Number of Supported Virtual Media Drives
With the virtual media feature, you can mount up to two drives (of
different types) that are supported by the USB profile currently applied to
the target. These drives are accessible for the duration of the KVM
session.
For example, you can mount a specific CD-ROM, use it, and then
disconnect it when you are done. The CD-ROM virtual media “channel”
will remain open, however, so that you can virtually mount another
CD-ROM. These virtual media “channels” remain open until the KVM
session is closed as long as the USB profile supports it.
To use virtual media, connect/attach the media to the client or network
file server that you want to access from the target server.
This need not be the first step, but it must be done prior to attempting to
access this media.
Connecting and Disconnecting from Virtual Media
Access a Virtual Media Drive on a Client Computer

To access a virtual media drive on the client computer:
1. From the Virtual KVM Client, choose Virtual Media > Connect Drive,
or click the Connect Drive... button
Drive dialog appears.

. The Map Virtual Media

2. Choose the drive from the Local Drive drop-down list.
If you want Read and Write capabilities, select the Read-Write
checkbox.
This option is disabled for nonremovable drives. See the Conditions
when Read/Write is Not Available (on page 55) for more
information.
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When checked, you will be able to read or write to the connected
USB disk.
WARNING: Enabling Read/Write access can be dangerous!
Simultaneous access to the same drive from more than one entity
can result in data corruption. If you do not require Write access,
leave this option unselected.
3. Click OK. The media will be mounted on the target server virtually.
You can access the media just like any other drive.
Mounting CD-ROM/DVD-ROM/ISO Images

This option mounts CD-ROM, DVD-ROM, and ISO images.
Note: ISO9660 format is the standard supported by Raritan. However,
other CD-ROM extensions may also work.
To access a CD-ROM, DVD-ROM, or ISO image:
1. From the Virtual KVM Client, choose Virtual Media > Connect
CD-ROM/ISO Image, or click the Connect CD ROM/ISO button
. The Map Virtual Media CD/ISO Image dialog appears.
2. For internal and external CD-ROM or DVD-ROM drives:
a. Choose the Local CD/DVD Drive option.
b. Choose the drive from the Local CD/DVD Drive drop-down list.
All available internal and external CD and DVD drive names will
be populated in the drop-down list.
c.

Click Connect.

3. For ISO images:
a. Choose the ISO Image option. Use this option when you want to
access a disk image of a CD, DVD, or hard drive. ISO format is
the only format supported.
b. Click Browse.
c.

Navigate to the path containing the disk image you want to use
and click Open. The path is populated in the Image Path field.

d. Click Connect.
4. For remote ISO images on a file server:
a. Choose the Remote Server ISO Image option.
b. Choose Hostname and Image from the drop-down list. The file
servers and image paths available are those that you configured
using the File Server Setup page. Only items you configured
using the File Server Setup page will be in the drop-down list.
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c.

File Server Username - User name required for access to the file
server. The name can include the domain name such as
mydomain/username.

d. File Server Password - Password required for access to the file
server (field is masked as you type).
e. Click Connect.
The media will be mounted on the target server virtually. You can
access the media just like any other drive.
Note: If you are working with files on a Linux® target, use the Linux Sync
command after the files are copied using virtual media in order to view
the copied files. Files may not appear until a sync is performed.
Note: If you are using the Windows 7® operating system®, Removable
Disk is not displayed by default in the Window's My Computer folder
when you mount a Local CD/DVD Drive or Local or Remote ISO Image.
To view the Local CD/DVD Drive or Local or Remote ISO Image in this
folder, select Tools > Folder Options > View and deselect "Hide empty
drives in the Computer folder".
Note: You cannot access a remote ISO image via virtual media using an
IPv6 address due to third-party software technical limitations.
Disconnect from Virtual Media Drives

To disconnect the virtual media drives:


For local drives, choose Virtual Media > Disconnect Drive.



For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media >
Disconnect CD-ROM/ISO Image.

Note: In addition to disconnecting the virtual media using the Disconnect
command, simply closing the KVM connection closes the virtual media
as well.
Virtual Media in a Windows XP Environment
If you are running the Virtual KVM Client or Active KVM Client in a
Windows® XP environment, users must have Administrator privileges to
access any virtual media type other than CD-ROM connections, ISOs
and ISO images.
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Virtual Media in a Linux Environment
Active System Partitions

You cannot mount active system partitions from a Linux client.
Linux Ext3/4 drive partitions need to be unmounted via umount
/dev/<device label> prior to a making a virtual media connection.
Drive Partitions

The following drive partition limitations exist across operating systems:


Windows® and Mac targets are not able to read Linux formatted
partitions



Windows and Linux cannot read Mac formatted partitions



Only Windows Fat partitions are supported by Linux

Root User Permission Requirement

Your virtual media connection can be closed if you mount a CD ROM
from a Linux client to a target and then unmount the CD ROM.
To avoid these issues, you must be a root user.
Virtual Media in a Mac Environment
Active System Partition

You cannot use virtual media to mount active system partitions for a Mac
client.
Drive Partitions

The following drive partition limitations exist across operating systems:


Windows® and Mac targets are not able to read Linux formatted
partitions



Windows cannot read Mac formatted partitions



Windows FAT and NTFS are supported by Mac



Mac users must unmount any devices that are already mounted in
order to connect to a target server. Use >diskutil umount
/dev/disk1s1 to unmount the device and diskutil mount /dev/disk1s1
to remount it.
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Virtual Media File Server Setup (File Server ISO Images Only)
This feature is only required when using virtual media to access file
server ISO images. ISO9660 format is the standard supported by Raritan.
However, other CD-ROM extensions may also work.
Note: SMB/CIFS support is required on the file server.
Use the Remote Console File Server Setup page to designate the files
server(s) and image paths that you want to access using virtual media.
File server ISO images specified here are available for selection in the
Remote Server ISO Image Hostname and Image drop-down lists in the
Map Virtual Media CD/ISO Image dialog. See Mounting
CD-ROM/DVD-ROM/ISO Images (on page 57).
To designate file server ISO images for virtual media access:
1. Choose Virtual Media from the Remote Console. The File Server
Setup page opens.
2. Check the Selected checkbox for all media that you want accessible
as virtual media.
3. Enter information about the file server ISO images that you want to
access:


IP Address/Host Name - Host name or IP address of the file
server.



Image Path - Full path name of the location of the ISO image. For
example, /sharename0/path0/image0.iso,
\sharename1\path1\image1.iso, and so on.

Note: The host name cannot exceed 232 characters in length.
4. Click Save. All media specified here are now available for selection
in the Map Virtual Media CD/ISO Image dialog.
Note: If you are connecting to a Windows 2003® server and attempt to
load an ISO image from the server, you may receive an error stating
"Virtual Media mounting on port failed. Unable to connect to the file
server or incorrect File Server username and password". If this occurs,
disable "Microsoft Network Server: Digitally Sign Communications"
option on the server under the Domain Controllers policies.
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Smart Cards
Using the KX III, you are able to mount a smart card reader onto a target
server to support smart card authentication and related applications.
For a list of supported smart cards, smart card readers, and additional
system requirements, see Smart Card Minimum System
Requirements, CIMs and Supported/Unsupported Smart Card
Readers (on page 61).
Note: The USB Smart Card token (eToken NG-OTP) is only supported
from the remote client.
Smart card reader mounting is also supported from the Local Console.
See Local Console Smart Card Access (on page 95) in your Dominion
device help.
Smart Card Minimum System Requirements, CIMs and
Supported/Unsupported Smart Card Readers
Before you begin using a smart card reader, review the following:


Smart Card Minimum System Requirements (on page 122)



Supported Computer Interface Module (CIMs) Specifications (on
page 116)



Supported and Unsupported Smart Card Readers

Authentication When Accessing a Smart Card Reader
When accessing a server remotely, you can select an attached smart
card reader and mount it onto the server.
Smart card authentication is used with the target server, it is not used to
log into the device. Therefore, changes to smart card PIN and
credentials do not require updates to device accounts.
PC Share Mode and Privacy Settings when Using Smart Cards
When PC-Share mode is enabled on the device, multiple users can
share access to a target server.
However, when a smart card reader is connected to a target, the device
will enforce privacy regardless of the PC-Share mode setting.
In addition, if you join a shared session on a target server, the smart card
reader mounting will be disabled until exclusive access to the target
server becomes available.
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Smart Card Reader Detected
After a KVM session is established with a target server, a Smart Card
menu and button are available in VKC and AKC.
Once the Smart Card button is selected or Smart Card is selected from
the menu, the smart card readers that are detected as attached to the
remote client are displayed in a dialog.
From this dialog you can attach additional smart card readers, refresh
the list of smart card readers attached to the target, and detach smart
card readers.
You are also able to remove or reinsert a smart card. This function can
be used to provide notification to a target server OS that requires a
removal/reinsertion in order to display the appropriate login dialog. Using
this function allows the notification to be sent to a single target without
affecting other active KVM sessions.
Mount a Smart Card Reader
When mounted onto the target server, the card reader and smart card
will cause the server to behave as if they had been directly attached.
Removal of the smart card or smart card reader will cause the user
session to be locked or you will be logged out depending on how the
card removal policy has been setup on the target server OS.
When the KVM session is terminated, either because it has been closed
or because you switch to a new target, the smart card reader will be
automatically unmounted from the target server.
To mount a smart card reader from VKC or AKC:
1. Click the Smart Card menu and then select Smart Card Reader.
Alternatively, click the Smart Card button

in the toolbar.

2. Select the smart card reader from the Select Smart Card Reader
dialog.
3. Click Mount.
4. A progress dialog will open. Check the 'Mount selected card reader
automatically on connection to targets' checkbox to mount the smart
card reader automatically the next time you connect to a target. Click
OK to begin the mounting process.
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Update a Smart Card Reader
To update the smart card in the Select Smart Card Reader
dialog:


Click Refresh List if a new smart card reader has been attached to
the client PC.

Send Smart Card Remove and Reinsert Notifications
To send smart card remove and reinsert notifications to the
target:


Select the smart card reader that is currently mounted and click the
Remove/Reinsert button.

Unmount (Remove) a Smart Card Reader
To unmount a smart card reader:


Select the smart card reader to be unmounted and click the Unmount
button.
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Digital Audio
The KX III supports end-to-end, bidirectional, digital audio connections
for digital audio playback and capture devices from a remote client to a
target server.
The audio devices are accessed over a USB connection.
Current device firmware is required.
One of the following CIMs must be used:


D2CIM-DVUSB



D2CIM-DVUSB-DVI



D2CIM-DVUSB-HDMI



D2CIM-DVUSB-DP

Windows®, Linux® and Mac® operating systems are supported. The
Virtual KVM Client (VKC) and Active KVM Client (AKC) support
connections to audio devices.
Note: Audio CDs are not supported by virtual media so they do not work
with the audio feature.
Before you begin using the audio feature, Raritan recommends you
review the audio related information documented in the following
sections of Help:


Supported Audio Device Formats (on page 64)



Recommendations for Dual Port Video



Supported Mouse Modes



CIMs Required for Dual Video Support



Informational Notes, Audio (on page 146)

Supported Audio Device Formats
The KX III supports one playback and capture device and one record
device on a target at a time. The following audio device formats are
supported:
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Stereo, 16 bit, 44.1K



Mono, 16 bit, 44.1K



Stereo, 16 bit, 22.05K



Mono, 16 bit, 22.05K



Stereo, 16 bit, 11.025K



Mono, 16 bit, 11.025K
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Audio Playback and Capture Recommendations and Requirements
Audio Level


Set the target audio level to a mid-range setting.
For example, on a Windows® client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio
device, not from the client audio device control.
Recommendations for Audio Connections when PC Share Mode is
Enabled
If you are using the audio feature while running PC Share mode, audio
playback and capture are interrupted if an additional audio device is
connected to the target.
For example, User A connects a playback device to Target1 and runs an
audio playback application then User B connects a capture device to the
same target. User A's playback session is interrupted and the audio
application may need to be restarted.
The interruption occurs because the USB device needs to be
re-enumerated with the new device configuration.
It may take some time for the target to install a driver for the new device.
Audio applications may stop playback completely, go to the next track, or
just continue playing.
The exact behavior is dependent on how the audio application is
designed to handle a disconnect/reconnect event.
Bandwidth Requirements
The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.
Audio format

Network bandwidth requirement

44.1 KHz, 16bit stereo

176 KB/s

44.1 KHz, 16bit mono

88.2 KB/s

2.05 KHz, 16bit stereo

88.2 KB/s

22.05 KHz, 16bit mono

44.1 KB/s

11.025 KHz, 16bit stereo

44.1 KB/s

11.025 KHz, 16bit mono

Audio 22.05 KB/s
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In practice, the bandwidth used when an audio device connects to a
target is higher due to the keyboard and video data consumed when
opening and using an audio application on the target.
A general recommendation is to have at least a 1.5MB connection before
running playback and capture.
However, high video-content, full-color connections using high-target
screen resolutions consume much more bandwidth and impact the
quality of the audio considerably.
To help mitigate quality degeneration, there are a number of
recommended client settings that reduce the impact of video on audio
quality at lower bandwidths:
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Connect audio playback at the lower quality formats. The impact of
video consuming bandwidth is much less notable at 11k connections
than at 44k



Set the connection speed under Connection Properties to a value
that best matches the client to server connection



Under Connection Properties, set the color depth to as lowt value as
possible. Reducing the color depth to 8 bit color considerably
reduces the bandwidth consumed



Set Smoothing, to High. This will improve the appearance of the
target video by reducing displayed video noise



Under Video settings, set the Noise Filter to its highest setting of 7
(highest value) so less bandwidth is used for target screen changes
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Saving Audio Settings
Audio device settings are applied on a per KX III device basis.
Once the audio devices settings are configured and saved on the KX III,
the same settings are applied to it.
For example, you can configure a Windows® audio device to us a stereo,
16 bit, 44.1K format.
When you connect to different targets and use that Windows audio
device, the stereo, 16 bit, 44.1K format is applied to each target server.
For both playback and recording devices, the device type, device format,
and the buffer settings applied to the device are saved.
See Connecting and Disconnecting from a Digital Audio Device (on
page 68) for information on connecting to and configuring an audio
device, and Adjusting Capture and Playback Buffer Size (Audio Settings)
for information on audio device buffer settings.
If you are using the audio feature while running PC Share mode and VM
Share mode so multiple users can access the same audio device on a
target at once, the audio device settings of the user who initiates the
session are applied to all users who join the session.
So, when a user joins an audio session, the target machine settings are
used. See Connecting to Multiple Targets from a Single Remote
Client (on page 67).
Connecting to Multiple Targets from a Single Remote Client
Connect to audio on up to four (4) target servers at the same time from a
single, remote client.
See Connecting and Disconnecting from a Digital Audio Device (on
page 68) for information on connecting to audio devices.
A Speaker icon
is displayed in the status bar at the bottom of the
client window. It is grayed out when no audio is being used. When the
Speaker icon and Microphone icon
are displayed in the status bar,
the session is being captured as it is streamed.
Note: When an audio session is underway, be sure to keep the session
active or change the KX III's idle timeout time so the audio session does
not time out.
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Operating System Audio Playback Support

Review the table shown here to see which Raritan client works with
audio playback/capture for each operating system:
Operating system

Audio playback and capture supported
by:

Windows®



Active KVM Client (AKC)



Virtual KVM Client (VKC)



Virtual KVM Client (VKC)



Virtual KVM Client (VKC)

Linux®
Mac

®

Connecting and Disconnecting from a Digital Audio Device
Audio device settings are applied on a per KX III device basis.
Once the audio devices settings are configured and saved on the KX III,
the same settings are applied to it.
See Saving Audio Settings (on page 67) for more information.
Note: If you are using the audio feature while running PC Share mode
and VM Share mode, see Audio Playback and Capture
Recommendations and Requirements (on page 65) for important
information. See also Connecting to Multiple Targets from a Single
Remote Client (on page 67).
Connect to a Digital Audio Device

To connect to an audio device:
1. Connect the audio device to the remote client PC prior to launching
the browser connection to the KX III.
2. Connect to the target from the Port Access page.
3. Once connected, click the Audio button

in the toolbar.

The Connect Audio Device dialog appears. A list of available audio
device connected to the remote client PC is displayed.
Note: If there are no available audio devices connected to the remote
client PC, the Audio icon is grayed out. .
4. Check Connect Playback Device if you are connecting to a playback
device.
5. Select the device that you wish to connect from the drop-down list.
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6. Select the audio format for the playback device from the Format:
drop-down.
Note: Select the format that you wish to use based on the available
network bandwidth. Formats with lower sampling rates consume less
bandwidth and may tolerate more network congestion.
7. Check Connect Recording Device if you are connecting a recording
device.
Note: The device names listed in the Connect Recording Device
drop-down are truncated to a maximum of 30 characters for Java
clients.
8. Select the device that you wish to connect from the drop-down list.
9. Select the audio format for the recording device from the Format:
drop-down.
10. Click OK. If the audio connection is established, a confirmation
message appears. Click OK.
If the connection was not established, an error message appears.
Once an audio connection is established, the Audio menu is changed
to Disconnect Audio. Additionally, the settings for the audio device
are saved and applied to the audio device.
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A Speaker icon
is displayed in the status bar at the bottom of
the client window. It is grayed out when no audio is being used.
When the Speaker icon and Microphone icon
are displayed in
the status bar, the session is being captured as it is streamed.

Disconnect from an Audio Device

To disconnect from the audio device:
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Click the Audio icon
in the toolbar and select OK when you are
prompted to confirm the disconnect. A confirmation message
appears. Click OK.
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Adjusting Capture and Playback Buffer Size (Audio Settings)
Once an audio device is connected, the capture and playback buffer size
can be adjusted as needed.
This feature is useful for controlling the quality of the audio, which may
be impacted by bandwidth limitations or network spikes.
Increasing the buffer size improves the audio quality but may impact the
delivery speed.
The maximum available buffer size is 400 milliseconds since anything
higher than that greatly impacts audio quality.
The buffer size can be adjusted whenever needed, including during an
audio session.
Audio settings are configured in VKC or AKC.
Adjust Audio Settings

To adjust audio settings:
1. Select Audio Settings from the Audio menu. The Audio Settings
dialog opens.
2. Adjust the capture and/or playback buffer size as needed. Click OK.

Version Information - Virtual KVM Client
This menu command provides version information about the Virtual KVM
Client, in case you require assistance from Raritan Technical Support.
To obtain version information:
1. Choose Help > About Raritan Virtual KVM Client.
2. Use the Copy to Clipboard button to copy the information contained
in the dialog to a clipboard file so it can be accessed later when
dealing with support (if needed).
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Overview
The Active KVM Client (AKC) is based on Microsoft Windows .NET ®
technology.
This allows you to run the client in a Windows environments without
using the Java® Runtime Environment (JRE), which is required to run
Raritan's Virtual KVM Client (VKC).
AKC also works with CC-SG.
AKC provides the same features as VKC with the exception of the
following:


Keyboard macros created in AKC cannot be used in VKC



Direct port access configuration (see Enabling Direct Port Access via
URL)



AKC server certification validation configuration (see Prerequisites
for Using AKC (on page 74))



AKC automatically loads favorites, VKC does not. See Managing
Favorites (on page 83)

For details on using the features, see Virtual KVM Client (VKC) Help
(on page 25).

Connect to a Target Server
Once you have logged on to the KX III Remote Console, access target
servers via the Virtual KVM Client (VKC) or Active KVM Client (AKC).
To connect to an available server:
1. On the Port Access page, click on the port name of the target server
you want to connect to. The Port Action menu opens.
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2. Click Connect.

See Port Action Menu (on page 20) for details on additional available
menu options.

AKC Supported Microsoft .NET Framework
The Active KVM Client (AKC) requires Windows .NET ® version 3.5, 4.0
or 4.5. AKC works with both 3.5 and 4.0 installed.

AKC Supported Operating Systems
When launched from Internet Explorer®, the Active KVM Client (AKC)
allows you to reach target servers via the KX III.
AKC is compatible with the following platforms:


Windows XP® operating system



Windows Vista® operating system (up to 64 bit)



Windows 7® operating system (up to 64 bit)



Windows 8® operating system (up to 64 bit)

Note: You must be using Windows 7 if WINDOWS PC FIPs is turned on
and you are accessing a target using AKC and a smartcard.
Since .NET is required to run AKC, if you do not have .NET installed or
you have an unsupported version of .NET installed, you will receive a
message instructing you to check the .NET version.
Note: Raritan recommends Windows XP® operating system users verify
you have a working version of .NET 3.5 or 4.0 already installed before
you launch AKC. If you do not verify your .NET version is working, you
may be prompted to download a file versus receiving the default
message to check your .NET version.
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AKC Supported Browsers


Internet Explorer® 8 (and later)
If you attempt to open AKC from a browser other than Internet
Explorer 8 (and later), you will receive an error message instructing
you to check your browser and to switch to Internet Explorer.

Prerequisites for Using AKC
Allow Cookies
Ensure the cookies from the IP address of the device that is being
accessed are not currently being blocked.
Include KX III IP Address in 'Trusted Sites Zone'
Windows Vista®, Windows® 7 and Windows 2008 server users should
ensure that the IP address of the device being accessed is included in
their browser's Trusted Sites Zone.
Disable 'Protected Mode'
Windows Vista®, Windows® 7 and Windows 2008 server users should
ensure that Protected Mode is not on when accessing the Raritan
device.
Enable AKC Download Server Certificate Validation
If the Raritan device (or CC-SG) administrator has enabled the Enable
AKC Download Server Certificate Validation option:
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Administrators must upload a valid certificate to the device or
generate a self-signed certificate on the device. The certificate must
have a valid host designation.



Each user must add the CA certificate (or a copy of self-signed
certificate) to the Trusted Root CA store in their browser.
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Overview
When you log in to the KX III via a network connection, you access the
Remote Console. The first page accessed is the Port Access page.
See Logging In to the KX III (on page 14) and Port Access Page
(Remote Console Display) (on page 17)

Use the Remote Console to access and scan target servers, manage
favorites, and change your password.
For more in the Remote Console interface elements, see KX III Remote
Console Interface (on page 16).
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Logging In to the KX III
Log in to your KX III Remote Console from any workstation with network
connectivity. Java™ 1.7 is required to use the Java-based Virtual KVM
Client. Alternatively, Microsoft .NET ® 3.5 (or later) is required to use KX
III with the Microsoft Windows®-based Active KVM Client (AKC).
Logging in and using KX III requires you to allow pop-ups.
For information on security warnings and validation messages, and steps
to reduce or eliminate them, see Security Warnings and Validation
Messages (on page 9).
To log in to the KX III:
1. Launch a supported web browser.
2. Enter either:


The URL - http://IP-ADDRESS to use the Java-based Virtual
KVM Client
Or



http://IP-ADDRESS/akc for the Microsoft .NET-based Active KVM
Client

IP-ADDRESS is the IP address assigned to your KX III
You can also use HTTPS, or the DNS name of the KX III assigned by
your administrator (if applicable).
You are always redirected to the IP address from HTTP to HTTPS.
3. Enter your username and password, then click Login.
4. Accept the user agreement (if applicable).
5. If security warnings appear, accept and/or allow access.
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Scanning Ports - Remote Console
Use the port scanning feature to search for selected targets and display
them in individual thumbnails as part of a slide show.
This feature allows you to monitor up to 32 targets at one time since you
can view each target server individually as it is displayed during the slide
show.
Connect to targets or focus on a specific target as needed.
Scans can include standard targets, blade servers, tiered Dominion
devices, and KVM switch ports.
For dual video port groups, the primary port is included in a port scan,
but the secondary port is not included when connecting from a remote
client. Both ports can be included in the scan from the Local Port.
Note: The scan port feature is available from the Remote Console and
Local Console, but the feature varies slightly.
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Scanning Ports Slide Show - Remote Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.
The slide show scrolls through the target thumbnails based on the
default interval of 10 seconds or according to the interval you specify.
As the scan scrolls through the targets, the target that is the focus of the
slide show displays in the center of the page.
The name of the target is displayed below its thumbnail and in the task
bar at the bottom of the window.
If a target is busy, a blank screen is displayed instead of the target server
access page.

Configure scan settings for the Remote Console from either the Virtual
KVM Client (VKC) or Active KVM Client (AKC).
See Configuring Port Scan Settings in VKC and AKC (on page 50)
Note: Scan port settings for the Local Console are configured on the
Local Port Settings page. See Scanning Ports - Local Console (on
page 91)
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Target Status Indicators During Port Scanning - Remote Console
The status of each target is indicated by green, yellow and red lights that
are displayed below the target thumbnail.
As the target is the focus of the rotation, the indicator is in the task bar
also shows the status.
Lights for each target are gray until they are the focus of the slide show.
The status lights indicate the following:


Green - the target is up/idle or up/connected



Yellow - the target is down but connected



Red - the target is down/idle, busy, or otherwise not accessible
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Using Scan Port Options
Following are options available to you while scanning targets.
With the exception of the Expand/Collapse icon, all of these options are
selected from the Options menu in the upper left of the Port Scan viewer.
The options will return to their defaults when you close the window.
Note: Configure scan settings such as the display interval from either the
Virtual KVM Client (VKC) or Active KVM Client (AKC). See Configuring
Port Scan Settings in VKC and AKC (on page 50)
Hide or View Thumbnails


Use the Expand/Collapse icon
at the upper left of the window to
hide or view thumbnails. Expanded is the default view.
Pause the Thumbnail Slide Show



Pause thumbnails from rotating between one target and the next by
selecting Options > Pause. Rotating thumbnails is the default setting.
Resume the Thumbnail Slide Show



Resume the thumbnail rotation by selecting Options > Resume.
Size the Thumbnails in the Port Scan Viewer



Enlarge the size of the thumbnails by selecting Options > Size >
360x240.



Minimize the size of the thumbnails by selection Options > Size >
160x120. This is the default thumbnail size.
Change the Orientation of the Port Scan Viewer
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View thumbnails along the bottom of the Port Scan viewer by
selecting Options > Split Orientation > Horizontal.



View thumbnails along the right of the Port Scan viewer by selecting
Options > Split Orientation > Vertical. This is the default view.
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Scan for Targets
To scan for targets:
1. Click the Set Scan tab on the Port Access page.
2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top
of the target column to select all targets.
3. Leave the Up Only checkbox selected if you only want targets that
are up to be included in the scan. Deselect this checkbox if you want
to include all targets, whether up or down.
4. Click Scan to begin the scan.
As each target is scanned, it is displayed in slide show view on the
page.

5. Click Options > Pause to pause the slide show and stop it from
moving between targets, click Options > Resume to resume the slide
show.
6. Click on a target thumbnail to scan it next.
7. Connect to a target by double clicking on its thumbnail.
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Changing a Password
To change your KX III password:
1. Choose User Management > Change Password. The Change
Password page opens.
2. Type your current password in the Old Password field.
3. Type a new password in the New Password field. Retype the new
password in the Confirm New Password field. Passwords can be up
to 64 characters in length and can consist of English alphanumeric
characters and special characters.
4. Click OK.
5. You will receive confirmation that the password was successfully
changed. Click OK.
Note: If strong passwords are in use, this page displays information
about the format required for the passwords. For more information about
passwords and strong passwords, see Strong Passwords in online help.
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Managing Favorites
A Favorites feature is provided so you can organize and quickly access
the devices you use frequently.
The Favorite Devices section is located in the lower left side (sidebar) of
the Port Access page and provides the ability to:


Create and manage a list of favorite devices



Quickly access frequently-used devices



List your favorites either by Device Name, IP Address, or DNS
hostname



Discover KX III devices on its subnet (before and after login)



Retrieve discovered KX III devices from the connected Dominion
device (after login)
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Enable Favorites


Click Enable in the Favorite Devices section of the left panel of the
KX III interface.
Once enabled, the Enable button becomes a Disable button.
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Access and Display Favorites
To access a favorite KX III device:


Click the device name (listed beneath Favorite Devices). A new
browser opens to that device.
To display favorites by name:



Click Display by Name.
To display favorites by IP Address:



Click Display by IP.
To display favorites by the host name:



Click Display by Host Name.

Discovering Devices on the Local Subnet
This option discovers the devices on your local subnet, which is the
subnet where the KX III Remote Console is running. These devices can
be accessed directly from this page or you can add them to your list of
favorites. See Favorites List Page.
To discover devices on the local subnet:
1. Choose Manage > Discover Devices - Local Subnet. The Discover
Devices - Local Subnet page appears.
2. Choose the appropriate discovery port:
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To use the default discovery port, select the Use Default Port
5000 checkbox.



To use a different discovery port:

a. Deselect the Use Default Port 5000 checkbox.
b. Type the port number in the Discover on Port field.
c.

Click Save.

3. Click Refresh. The list of devices on the local subnet is refreshed.
To add devices to your Favorites List:
1. Select the checkbox next to the device name/IP address.
2. Click Add.
To access a discovered device:


Click the device name or IP address for that device. A new browser
opens to that device.

Discovering Devices on the KX III Subnet
This option discovers devices on the device subnet, which is the subnet
of the KX III device IP address itself. You can access these devices
directly from this the Subnet page or add them to your list of favorites.
See Favorites List Page.
This feature allows multiple KX III devices to interoperate and scale
automatically. The KX III Remote Console automatically discovers the
KX III devices, and any other Raritan device, in the subnet of the KX III.
To discover devices on the device subnet:
1. Choose Manage > Discover Devices - KX III Subnet. The Discover
Devices - KX III Subnet page appears.
2. Click Refresh. The list of devices on the local subnet is refreshed.
To add devices to your Favorites List:
1. Select the checkbox next to the device name/IP address.
2. Click Add.
To access a discovered device:
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Click the device name or IP address for that device. A new browser
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Overview
The Local Console interface provides access to the KX III while at the
rack.
This section contains help on tasks performed by end users at the Local
Console.

Accessing a Target Server
To access a target server:
1. Click the Port Name of the target you want to access. The Port
Action Menu is displayed.
2. Choose Connect from the Port Action menu. The video display
switches to the target server interface.
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Local Console Video Resolutions
Once a monitor is connected to the KX III Local Console, KX III detects
the native resolution of the monitor. This is typically the highest
resolution supported by the monitor.
As long as the monitor's native resolution is supported by the Local
Console, KX III uses that resolution.
If the native resolution is not supported by the Local Console, and no
other resolution is supported by the monitor and Local Console, KX III
uses the resolution of the last monitor that was connected to the Local
Console.
For example, you connect a monitor set to a resolution of
1600x1200@60Hz to the KX III Local Console. KX III uses that resolution
since it is supported by the Local Console.
If the next monitor you connect to the Local Console is not set to a
supported resolution, KX III uses the resolution of 1024x768@60.
For a list of supported Local Console video resolutions, see Supported
KX III Local Port DVI Resolutions (on page 116).
Considering also reviewing Video Mode and Resolution Notes (on
page 141) for additional information.

Simultaneous Users
The KX III Local Console provides an independent access path to the
connected KVM target servers.
Using the Local Console does not prevent other users from
simultaneously connecting over the network. And even when remote
users are connected to the KX III, you can still simultaneously access
your servers from the rack via the Local Console.

Hot Keys and Connect Keys
Because the KX III Local Console interface is completely replaced by the
interface for the target server you are accessing, a hot key is used to
disconnect from a target and return to the local port GUI.
A connect key is used to connect to a target or switch between targets.
The Local Port hot key allows you to rapidly access the KX III Local
Console user interface when a target server is currently being viewed.
See Configuring KX III Local Console Local Port Settings
information.
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Return to the KX III Local Console Interface - Default Hot Key
To return to the KX III Local Console from the target server:


Press the Scroll Lock key twice rapidly.
The video display switches from the target server interface to the KX
III Local Console interface.

This key combination can be changed in the Local Port Settings page.
See Configuring KX III Local Port Settings from the Local Console in
online help.
Connect Key Examples
Standard servers
Connect key action Key sequence example
Access a port from
the local port GUI

Access port 5 from the local port GUI:

Switch between
ports

Switch from target port 5 to port 11:

Disconnect from a
target and return to
the local port GUI

Disconnect from target port 11 and return to the
local port GUI (the page from which you
connected to target):







Press Left ALT > Press and Release 5 >
Release Left ALT

Press Left ALT > Press and Release 1 >
Press and Release 1 > Release Left ALT

Double Click Scroll Lock

Blade chassis
Connect key action Key sequence example
Access a port from
the local port GUI

Access port 5, slot 2:

Switch between
ports

Switch from target port 5, slot 2 to port 5, slot
11:





Disconnect from a
target and return to

Press Left ALT > Press and Release 5 >
Press and Release - > Press and Release
2 > Release Left ALT

Press Left ALT > Press and Release 5 >
Press and Release - > Press and Release
1 > Press and Release 1 > Release Left
ALT

Disconnect from target port 5, slot 11 and return
to the local port GUI (the page from which you
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Standard servers
Connect key action Key sequence example
the local port GUI
connected to target):


Double Click Scroll Lock

Special Sun Key Combinations
The following key combinations for Sun™ Microsystems server’s special
keys operate on the local port. These special are available from the
Keyboard menu when you connect to a Sun target server:
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Sun key

Local port key combination

Again

Ctrl+ Alt +F2

Props

Ctrl + Alt +F3

Undo

Ctrl + Alt +F4

Stop A

Break a

Front

Ctrl + Alt + F5

Copy

Ctrl + Alt + F6

Open

Ctrl + Alt + F7

Find

Ctrl + Alt + F9

Cut

Ctrl + Alt + F10

Paste

Ctrl + Alt + F8

Mute

Ctrl + Alt + F12

Compose

Ctrl+ Alt + KPAD *

Vol +

Ctrl + Alt + KPAD +

Vol -

Ctrl + Alt + KPAD -

Stop

No key combination

Power

No key combination
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Scanning Ports - Local Console
Use the port scanning feature to search for selected targets and display
them in individual thumbnails as part of a slide show.
This feature allows you to monitor up to 32 targets at one time since you
can view each target server individually as it is displayed during the slide
show.
Connect to targets or focus on a specific target as needed.
Scans can include standard targets, blade servers, tiered Dominion
devices, and KVM switch ports.
For dual video port groups, the primary port is included in a port scan,
but the secondary port is not included when connecting from a remote
client. Both ports can be included in the scan from the Local Port.
Click on the thumbnail of any target server to exit scan mode and
connect to the target, or use the Local Port ConnectKey sequence.
To exit scan mode, click the Stop Scan button in the thumbnail view, or
use the DisconnectKey sequence hot key.
Note: The scan port feature is available from the Remote Console and
Local Console, but the feature varies slightly. See Scanning Ports Remote Console (on page 77)
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Scanning Port Slide Show - Local Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.
The slide show scrolls through the target thumbnails based on the
default interval of 10 seconds or according to the interval you specify.
As the scan scrolls through the targets, the target that is the focus of the
slide show displays in the center of the page.
The name of the target is displayed below its thumbnail and in the task
bar at the bottom of the window.
If a target is busy, a blank screen is displayed instead of the target server
access page.
Configure the time between the slide show thumbnail rotation and the
thumbnail focus interval on the Local Port Settings page.
See Configure Local Console Scan Settings (on page 94)
Note: Configure scan settings for the Remote Console from either the
Virtual KVM Client (VKC) or Active KVM Client (AKC). See Configuring
Port Scan Settings in VKC and AKC (on page 50)
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Target Status Indicators During Port Scanning - Local Console
In thumbnail view on the Local Console, the status of each target is
indicated below the thumbnail on the page until it is the focus of the slide
show view.
The scanning status of each target is displayed as:


not scanned



connecting



scanned



skipped

Configure Local Console Scan Settings
Do the following to configure Local Console scan port options.
Note: Configure scan settings for the Remote Console from either the
Virtual KVM Client (VKC) or Active KVM Client (AKC). See Configuring
Port Scan Settings in VKC and AKC (on page 50)
To configure the Local Console scan port settings:
1. On the Local Console, select Device Settings.
2. In the Local Port Settings section, select Local Port Scan Mode.
3. Change the display interval as needed:
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Display Interval - changes the scan display interval.



Interval Between Ports - change interval between switching
different port during scan.

Scan for Targets - Local Console
To scan for targets:
1. Click the Set Scan tab on the Port Access page.
2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top
of the target column to select all targets.
3. Leave the Up Only checkbox selected if you only want targets that
are up to be included in the scan. Deselect this checkbox if you want
to include all targets, whether up or down.
4. Click Scan to begin the scan.
As each target is scanned, it is displayed in slide show view on the
page.

Local Console Smart Card Access
To use a smart card to access a server at the Local Console, plug a USB
smart card reader into the KX III using one of the USB ports located on
the KX III.
Once a smart card reader is plugged in or unplugged from the KX III, the
KX III autodetects it.
For a list of supported smart cards and additional system requirements,
see Supported and Unsupported Smart Card Readers and Smart Card
Minimum System Requirements (on page 122).
When mounted onto the target server, the card reader and smart card
will cause the server to behave as if they had been directly attached.
Removal of the smart card or smart card reader will cause the user
session to be locked or you will be logged out depending on how the
card removal policy has been setup on the target server OS.
When the KVM session is terminated, either because it has been closed
or because you switch to a new target, the smart card reader will be
automatically unmounted from the target server.
To mount a smart card reader onto a target via the KX III Local
console:
1. Plug a USB smart card reader into the KX III using one of the USB
ports located on the device. Once attached, the smart card reader
will be detected by the KX III.
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2. From the Local Console, click Tools.
3. Select the smart card reader from the Card Readers Detected list.
Select None from the list if you do not want a smart card reader
mounted.
4. Click OK. Once the smart card reader is added, a message will
appear on the page indicating you have completed the operation
successfully. A status of either Selected or Not Selected will appear
in the left panel of the page under Card Reader.
To update the Card Readers Detected list:
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Click Refresh if a new smart card has been mounted. The Card
Readers Detected list will be refreshed to reflect the newly added
smart card reader.
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Local Console USB Profile Options
From the USB Profile Options section of the Tools page, you can choose
from the available USB profiles.
The ports that can be assigned profiles are displayed in the Port Name
field and the profiles that are available for a port appear in the Select
Profile To Use field after the port is selected. The profiles selected for
use with a port appear in the Profile In Use field.
To apply a USB profile to a local console port:
1. In the Port Name field, select the port you want to apply the USB
profile to.
2. In the Select Profile To Use field, select the profile to use from
among those available for the port.
3. Click OK. The USB profile will be applied to the local port and will
appear in the Profile In Use field.

97

Chapter 7: KX III Local Console - KX III End User Help

KX III Local Console Factory Reset
Note: It is recommended that you save the audit log prior to performing a
factory reset.
The audit log is deleted when a factory reset is performed and the reset
event is not logged in the audit log. For more information about saving
the audit log, see Audit Log.
To perform a factory reset:
1. Choose Maintenance > Factory Reset. The Factory Reset page
opens.
2. Choose the appropriate reset option from the following options:


Full Factory Reset - Removes the entire configuration and resets
the device completely to the factory defaults. Note that any
management associations with CommandCenter will be broken.
Because of the complete nature of this reset, you will be
prompted to confirm the factory reset.



Network Parameter Reset - Resets the network parameters of
the device back to the default values (click Device Settings >
Network Settings to access this information).

3. Click Reset to continue. You will be prompted to confirm the factory
reset because all network settings will be permanently lost.
4. Click OK proceed. Upon completion, the KX III device is
automatically restarted.

Resetting the KX III Using the Reset Button on the Device
On the back panel of the device, there is a Reset button. It is recessed to
prevent accidental resets (you need a pointed object to press this
button).
The actions that are performed when the Reset button is pressed are
defined on the Encryption & Share page. See Encryption & Share in
online help.
Note: It is recommended that you save the audit log prior to performing a
factory reset.
The audit log is deleted when a factory reset is performed and the reset
event is not logged in the audit log. For more information about saving
the audit log, see Audit Log.
To reset the device:
1. Power off the KX III.
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2. Use a pointed object to press and hold the Reset button.
3. While continuing to hold the Reset button, power the KX III device
back on.
4. Continue holding the Reset button for 10 seconds.
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Appendix A Connecting a KX III and Cat5 Reach
DVI - Provide Extended Local Port
Functionality

In This Chapter
Overview ................................................................................................100
About the Cat5 Reach DVI ....................................................................100
Connect a KX III and Cat5 Reach DVI ..................................................101

Overview
An extended local port extends the reach of the local port beyond the
rack the KX II is located, for example to another KVM switch.
This can be achieved by configuring a KX III to work with a Raritan Cat5
Reach DVI transmitter and receiver, which are then connected to a
remote console or other device.
Once connected to the Cat5 Reach DVI, the KX III can be accessed up
500 feet (152 m) away.
Connecting the KX III to the Cat5 Reach DVI by daisy chaining Ethernet
switches extends can extend the KX III's reach up to 3000 feet (914 m).

About the Cat5 Reach DVI
For details on the Cat5 Reach DVI, see the Cat5 Reach DVI online help
available on the Raritan Support page
http://www.raritan.com/support.
Contact Raritan (http://www.raritan.com/contact-us/) for additional
information on the Cat5 Reach DVI, or for information on purchasing.
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Connect a KX III and Cat5 Reach DVI
Note: The images used in the diagrams are not specific to KX III but the
connections are accurate.
This section introduces three scenarios involving KVM switches.


Connect the Cat5 Reach DVI between any KVM switch and its local
console.



Connect the Cat5 Reach DVI between two KVM switches.



Connect the Cat5 Reach DVI between a computer/server and a KVM
switch.

Turn off all devices before making the connections.
For detailed information on setting up the local and remote consoles, see
Connecting a Keyboard/Mouse/Video Source in Cat5 Reach DVI
Help for more information.
To connect a KX III and Cat5 Reach DVI:
1. If you have not already done so, set up the local and remote
consoles with the Cat5 Reach DVI transmitter and receiver,
respectively.
See Basic Installation in Cat5 Reach DVI Help for more
information.
2. Use a Cat5e/6 cable to connect the transmitter and receiver.
3. Connect the transmitter and receiver to an appropriate power source
respectively.
4. Connect the local console ports of the KVM switch to the transmitter.
a. Plug one end of the Raritan-provided DVI cable into the DVI-I IN
port on the transmitter, and the other end into the KVM switch's
video port.
b. Plug the USB-B connector of the Raritan-provided USB cable
into the USB-B port on the transmitter, and the other end into the
KVM switch's local USB-A port.
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5. Turn on the KVM switch.

Tip: The local or remote console can be equipped with a KVM drawer
instead of a set of keyboard, mouse and monitor. See the illustration
below.

To increase the distance between two tiered KVM switches:
1. Set up a remote console by connecting the receiver to a KVM switch.
a. Connect a USB CIM to the receiver.
b. Connect this USB CIM to any channel port on the KVM switch
via a Cat5 cable.
2. Use a Cat5e/6 cable to connect the transmitter and receiver.
3. Connect the transmitter and receiver to an appropriate power source
respectively.
4. Connect the KVM switch to the transmitter.
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5. Turn on both KVM switches.

To increase the distance between any computer and a KVM
switch:
1. Set up an optional local console with the transmitter.
2. Set up a remote console by connecting the receiver to a KVM switch.
3. Use a Cat5e/6 cable to connect the transmitter and receiver.
4. Connect the transmitter and receiver to an appropriate power source
respectively.
5. Connect the computer to the transmitter.
6. Turn on the computer.
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Appendix B Accessing a Paragon II from the KX
III

In This Chapter
Overview ................................................................................................104
Supported Paragon II CIMS and Configurations ...................................105
Connecting the Paragon II to the KX III .................................................110

Overview
Connect the Paragon II system to a KX III device that is managed by
CC-SG so that Paragon II is accessible from CC-SG.
This diagram indicates the configuration integrating KX III.
Note: The images are for example purposes only, and may not look
exactly like your device.

The Paragon II system involving Paragon II switches,
servers and user stations
The user station with a DCIM-USB G2 attached
KX III
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When you access the Paragon II system from KX III or CC-SG (if the KX
III is managed by CC-SG), the Paragon II OSUI login screen appears for
you to log in.
In this integration, you can perform any OSUI functions implemented with
current Paragon II firmware or any KX III function implemented with
current KX III firmware except for the virtual media feature.
When accessing the Paragon II OSUI through KX III, DO NOT attempt to
synchronize the mouse manually. A mouse is not necessary on the OSUI
screen and mouse synchronization will delay the keyboard response for
seconds.
See Supported Paragon II CIMS and Configurations (on page 105) for
additional information.

Supported Paragon II CIMS and Configurations
The KX III supports the P2CIM-APS2DUAL and P2CIM-AUSBDUAL
CIMs, which provide two RJ45 connections to different KVM switches.
Support of these CIMs provides a second path to access the target in the
event that one of the KVM switches is blocked or fails.
Paragon CIM

Supports

P2CIM-APS2DUAL





Does not support
®

Servers with IBM
PS/2-type keyboard
and mouse ports



Virtual media



Smart cards


Automatic skew
compensation (when

the CIMs are
connected to
Paragon II, not from a 
KX III)



Intelligent Mouse
mode



Standard Mouse
mode

Absolute Mouse
mode
Use with blade
chassis
Cascaded KVM
configurations
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Paragon CIM

Supports

Does not support

P2CIM-AUSBDUAL





Virtual media



Smart cards



Absolute Mouse
mode
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Servers with USB- or
Sun™ USB-type
keyboard and mouse
ports

Automatic skew
compensation (when 
the CIMs are
connected to

Paragon II, not from a
KX III)



Intelligent Mouse
mode



Standard Mouse
mode

Use with blade
chassis
Cascaded KVM
configurations
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KX III-to-KX III Paragon CIM Guidelines
The following system configuration guidelines should be followed when
you are using Paragon CIMs in a KX III-to-KX III configuration:
Concurrent Access
Both KX III KVM switches should be configured with the same policy for
concurrent access to targets - both PC-Share or both Private.
If Private access to targets is required, both KVM switches must be
configured accordingly:


From Security > Security Settings > Encryption & Share, set PC
Share Mode to ‘Private’

This guarantees that concurrent access to targets is prohibited, for all
targets by all user groups.
The KX III allows for more granular control of concurrent access to
targets on a per user group basis. This is done by setting the user
group’s PC Share permissions. However, this is only enforced within
the boundary of a KX III. User Group PC Share permissions must not
be relied on if Privacy must be guaranteed when using the
P2CIM-APS2DUAL or P2CIM-AUSBDUAL with the KX III.
CIM Name Updates
The P2CIM-APS2 and P2CIM-AUSB names are stored within the CIM’s
memory. There are two memory locations provided to accommodate
the Paragon naming convention (12 characters) and the KX III naming
convention (32 characters).
When first connected to a KX III, the Paragon name will be retrieved from
memory and written into the CIM memory location used by KX III.
Subsequent queries for the CIM name or updates to the CIM name from
the KX III will be made to the memory location used by the KX III.
Updates will not be made by the KX III to the memory location used by
Paragon II.
When the CIM name is updated by one KX III, the other KX III will detect
and retrieve the updated name on the next attempt to connect to that
target. Until that time, the name will not be updated on the other KX III.
Port Status and Availability
The port status, displayed on the KX III Port Access page as either Up or
Down, is updated to show whether the CIM is powered up and
connected to the KX III port.
The port availability, as displayed on the KX III Port Access page as Idle,
Busy or Connected, is only updated to reflect activity on a target that has
been initiated from that same KX III.
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If a connection to the target is in place from the other KX III, the
availability is checked when a connection is attempted. Access is denied
or allowed consistent with the PC-Share policy in place for the KX III.
Until that time, the availability is not be updated on the other KX III.
If access is denied because the target is busy, a notification is displayed.
Working from CC-SG
Operations initiated from CC-SG are based on the Status, Availability
and CIM name reported by the managed KX III. When the target is
connected to two managed KX IIIs and the devices are added to CC-SG,
two nodes will be created. Each node will have its own oob-kvm interface
associated with it. Alternatively, a single node can be configured with an
oob-kvm interface from each KX III.
If the KX IIIs are configured for ‘Private’ mode, when a second
connection is attempted the user is notified that they cannot connect and
access is denied.
When a port name change is initiated via the CC-SG Port Profile pane,
the changed name is pushed to the managed KX III. The corresponding
port name of the other KX III will not be updated in CC-SG until a
connection is attempted to the target port via the other KX III’s oob-kvm
interface.
KX III-to-Paragon II Guidelines
The P2CIM-APS2DUAL or P2CIM-AUSBDUAL can be connected to a
KX III and Paragon II.
Concurrent Access
The KX III and Paragon II must be configured with the same policy for
concurrent access to targets.
Paragon II
operation
mode

Mode description

Supported?

Private

A server or other device
on a specific channel
port can be accessed
exclusively by only one
user at a time.

Supported.
Paragon II and the KX III
must be set to Private. The
Private setting is applied on
to KX III device, not per user
group.
The Paragon II uses Red to
indicate ‘busy’ or Green to
indicate ‘available’.

PC Share
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A server or other device
on a specific channel

Supported.
However, PC Share Idle
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Paragon II
operation
mode

Public View

Mode description

Supported?

port can be selected and
controlled by more than
one user, but only one
user has keyboard and
mouse control at any
one time.

Timeout, which is configured
on the Paragon II, is not
supported. Both users will
have concurrent keyboard
and mouse control.

While one user is
accessing a server or
other device on a
specific channel port,
other users can select
that channel port and
view the video output
from that device.
However, only the first
user will have keyboard
and mouse control until
they disconnect or
switch away.

Not supported.

The Paragon II uses Green
to indicate ‘available’. This
will also be true if another
user is already accessing
the target.

This mode cannot be used
when connecting the CIM to
a Paragon II and the KX III.
The Paragon II uses Yellow
to indicate it is in P-View
mode.

CIM Name Updates


CIM names updated from Paragon II are stored and retrieved from
the CIM memory location corresponding to the Paragon naming
convention.



CIM names updated from the KX III are stored and retrieved from the
CIM memory location corresponding to the KX III naming convention.



CIM name updates do not propagate between the Paragon II and the
KX III.

Supported Connection Distances Between Paragon II and KX III
When using KX III as the front end of a Paragon II system, you should
restrict the cable length (distance) for good video quality.
Supported distance from the Paragon II user station to the target server
is 500 cable feet (152 m). Greater distances may result in video
performance that may or may not be acceptable to you.
Supported distance from KX III to the Paragon II user station is up to 150
cable feet (45 m).
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Connecting the Paragon II to the KX III
To connect the Paragon II system to a KX III:
1. Check whether the Paragon II user station that you want to connect
to the KX III is implemented with version 4.6 firmware (or later). If not,
upgrade it.
The Paragon II user station can be one of these:


P2-UST



P2-EUST



P2-EUST/C

See Paragon II Help for information on upgrading.
2. Plug a compatible DCIM-USB into the USB and video ports on the
Paragon II user station.
If the system is a two- or three-tier system, ensure the Paragon II
user station is connected to the base KX III device (first tier).
3. Connect the Paragon II user station to a KX III device via a Cat5
UTP cable up to 150 feet (45 m).


Plug one end of the cable to the DCIM's RJ-45 port and the other
end to one of the channel ports on the KX III device.

4. If you want to have more paths to access the same Paragon II
system in KX III or CC-SG, repeat Steps 1 to 3 to connect additional
user stations to the KX III.
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In This Chapter
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Software.................................................................................................132

Hardware
KX III Dimensions and Physical Specifications
Dominion KX Description Power &
III model
heat
dissipation

8
server
DKX3-108
Dual Power
ports
110V/240V,
 1 remote 50-60Hz
user
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack
DKX3-116

DKX3-132

DKX3-216

Dimensions Weight
(WxDxH)

Operating
temp

Humidity

17.3" x
13.15'' x
1.73''

0º - 45º C

0-85 %
RH

8.60lbs

439x334x44 3.9kg
mm

32º - 113º
F

 16 server Dual Power
ports
110V/240V,
 1 remote 50-60Hz
user
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.15'' x
1.73''

0º - 45º C

439x334x44 3.9kg
mm

32º - 113º
F

 32 server Dual Power
ports
110V/240V,
 1 remote 50-60Hz
user
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.15'' x
1.73''

0º - 45º C

439x334x44 3.9kg
mm

32º - 113º
F

 16 server Dual Power
ports
110V/240V,
 2 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local

17.3" x
13.15'' x
1.73''

9.08lbs

0º - 45º C

439x334x44 4.12kg
mm

32º - 113º
F

8.60lbs

8.60lbs

0-85 %
RH

0-85 %
RH

0-85 %
RH
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Dominion KX Description Power &
III model
heat
dissipation
port for
use at
the rack
DKX3-232

DKX3-416

DKX3-432

DKX3-464

DKX3-808
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Dimensions Weight
(WxDxH)

Operating
temp

Humidity

 32 server Dual Power
ports
110V/240V,
 2 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.15'' x
1.73''

9.08lbs

0º - 45º C

0-85 %
RH

439x334x44 4.12kg
mm

32º - 113º
F

 16 server Dual Power
ports
110V/240V,
 4 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.15'' x
1.73''

9.08lbs

0º - 45º C

439x334x44 4.12kg
mm

32º - 113º
F

 32 server Dual Power
ports
110V/240V,
 4 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.15'' x
1.73''

9.08lbs

0º - 45º C

439x334x44 4.12kg
mm

32º - 113º
F

 64 server Dual Power
ports
110V/240V,
 4 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.3" x 3.5"

0º - 45º C

439x338x89 5.62kg
mm

32º - 113º
F

 8 server
ports

17.3" x
13.15'' x
1.73''

9.96lbs

0º - 45º C

439x334x44 4.52kg
mm

32º - 113º
F

Dual Power
110V/240V,
 8 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local
port for

12.39lbs

0-85 %
RH

0-85 %
RH

0-85 %
RH

0-85 %
RH
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Dominion KX Description Power &
III model
heat
dissipation
use at
the rack
DKX3-832

DKX3-864

Dimensions Weight
(WxDxH)

Operating
temp

Humidity

 32 server Dual Power
ports
110V/240V,
 8 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.15'' x
1.73''

9.96lbs

0º - 45º C

0-85 %
RH

439x334x44 4.52kg
mm

32º - 113º
F

 64 server Dual Power
ports
110V/240V,
 8 remote 50-60Hz
users
1.8A 60W
52 KCAL
 1 local
port for
use at
the rack

17.3" x
13.3" x 3.5"

0º - 45º C

12.39lbs

439x338x89 5.62kg
mm

0-85 %
RH

32º - 113º
F
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KX III Supported Target Server Video Resolutions
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640x350@70Hz



640x350@85Hz



640x400@56Hz



640x400@84Hz



640x400@85Hz



640x480@60Hz



640x480@66.6Hz



640x480@72Hz



640x480@75Hz



640x480@85Hz



720x400@70Hz



720x400@84Hz



720x400@85Hz



800x600@56Hz



800x600@60Hz



800x600@70Hz



800x600@72Hz



800x600@75Hz



800x600@85Hz



800x600@90Hz



800x600@100Hz



832x624@75.1Hz



1024x768@60Hz



1024x768@70Hz



1024x768@72Hz



1024x768@85Hz



1024x768@75Hz



1024x768@90Hz



1024x768@100Hz



1152x864@60Hz



1152x864@70Hz



1152x864@75Hz



1152x864@85Hz



1152x870@75.1Hz



1280x720@60Hz
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1280x960@60Hz



1280x960@85Hz



1280x1024@60Hz



1280x1024@75Hz



1280x1024@85Hz



1360x768@60Hz



1366x768@60Hz



1368x768@60Hz



1400x1050@60Hz



1440x900@60Hz



1600x1200@60Hz



1680x1050@60Hz



1920x1080@60Hz



1920x1200@60Hz (Requires Reduced Blanking Time)

For 1920x1200@60Hz, you must use a digital CIM and set the CIM’s
preferred resolution to 1920x1200@60Hz.
Target Server Video Resolution Supported Connection Distances
and Refresh Rates
The maximum supported distance is a function of many factors including
the type/quality of the Cat5 cable, server type and manufacturer, video
driver and monitor, environmental conditions, and user expectations.
The following table summarizes the maximum target server distance for
various video resolutions and refresh rates:
Target server video resolution

Maximum distance

1024x768@60Hz (and below)

150' (45 m)

1280x1024@60Hz

100' (30 m)

1280×720@60Hz

75' (22 m)

1600x1200@60Hz

50' (15 m)

1920x1080@60Hz

50' (15 m)

See KX III Supported Target Server Video Resolutions (on page 114)
for the video resolutions supported by the KX III.
Note: Due to the multiplicity of server manufacturers and types, OS
versions, video drivers, and so on, as well as the subjective nature of
video quality, Raritan cannot guarantee performance across all distances
in all environments.
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Supported KX III Local Port DVI Resolutions


1920x1080@60



1280x720@60



1024x768@60 (default)



1024x768@75



1280x1024@60



1280x1024@75



1600x1200@60



800x480@60



1280x768@60



1366x768@60



1360x768@60



1680x1050@60



1440x900@60

Supported Computer Interface Module (CIMs) Specifications
Digital CIMs support Display Data Channels (DDC) and Enhanced Extended Display
Identification Data (E-EDID).
CIM model

Dimensions (WxDxH)

Weight

D2CIM-DVUS Dual USB CIM for BIOS virtual media,
B
smartcard/CAC, audio and Absolute
Mouse Synchronization

1.7" x 3.5" x 0.8"; 43 x
90 x 19mm

0.25lb;
0.11kg

D2CIM-VUSB

1.3" x 3.0" x 0.6"; 33 x
76 x 15mm

0.20lb;
0.09kg
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CIM model

Dimensions (WxDxH)

Weight

D2CIM-DVUS Digital CIM that provides digital-to-analog
B-DVI
conversion and support for virtual media,
smartcard/CAC, audio, Absolute and
Relative Mouse Synchronization

Description

1.7" x 3.5" x 0.8"; 43 x
90 x 19mm

0.25lb;
0.11kg

D2CIM-DVUS Digital CIM that provides digital-to-analog
B-DP
conversion and support for virtual media,
smartcard/CAC, audio, Absolute and
Relative Mouse Synchronization

1.7" x 3.5" x 0.8"; 43 x
90 x 19mm

0.25lb;
0.11kg

D2CIM-DVUS Digital CIM that provides digital-to-analog
B-HDMI
conversion and support for virtual media,
smartcard/CAC, audio, Absolute and
Relative Mouse Synchronization

1.7" x 3.5" x 0.8"; 43 x
90 x 19mm

0.25lb;
0.11kg

DCIM-PS2

1.3" x 3.0" x 0.6"; 33 x
76 x 15mm

0.20lb;
0.09kg

1.3" x 3.0" x 0.6"; 33 x
76 x 15mm

0.20lb;
0.09kg

CIM for PS2

DCIM-USBG2 CIM for USB and Sun USB
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CIM model

Description

Dimensions (WxDxH)

Weight

Note that the black connector on the DVUSB CIMs are used for the
keyboard and mouse. The gray connector is used for virtual media.
Keep both plugs of the CIM connected to the device. The device may not
operate properly if both plugs are not connected to the target server.
Supported Digital Video CIMs for Mac
Use a digital video CIM to connect to the following Mac ® ports:
Mac port

CIM

DVI

D2CIM-DVUSB-DVI

HDMI

D2CIM-DVUSB-HDMI

DisplayPort or Thunderbolt

D2CIM-DVUSB-DP

If the Mac’s HDMI or DisplayPort video has a mini connector, a passive
adapter cable may be required to connect to the full sized HDMI and
DisplayPort plugs on the digital CIMs.
Alternatively, use the Mac VGA adapter with the D2CIM-VUSB or
D2CIM-DVUSB. Note that this may be less reliable and the video quality
may suffer.
For information on established modes supported by the KX III 2.5.0 (and
later) for Mac, see Digital CIM Established and Standard Modes (on
page 119).
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Digital CIM Timing Modes
Following are the default timing modes that are used when the KX III
communicates with a video source via a digital CIM.
The timing mode that is used is dependent on the native resolution of the
video source.


1024x768@60Hz



1152x864@60Hz



1280x720@60Hz



1280x960@60Hz



1280x1024@60Hz (default resolution applied to digital CIMs)



1360x768@60Hz



1400x1050@60Hz



1440x900@60Hz



1600x1200@60Hz



1680x1050@60Hz



1920x1080@60Hz



1920x1200@60Hz

See Configuring CIM Ports

in online help for more information.

Digital CIM Established and Standard Modes
The following additional established and standard resolutions and timing
modes are supported by the KX III 3.0.0 (and later).
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Digital CIM Established Modes



720x400@70Hz IBM, VGA



640x480@60Hz IBM, VGA



640x480@67Hz Apple Mac® II



640x480@72Hz VESA



640x480@75Hz VESA



800x600@56Hz VESA



800x600@60Hz VESA



800x600@72Hz VESA



800x600@75Hz VESA



832x624@75Hz Apple Mac II



1024x768@60Hz VESA



1024x768@70Hz VESA



1024x768@75Hz VESA



1280x1024@75Hz VESA



1152x870@75Hz Apple Mac II

Digital CIM Standard Modes



1152x864@75Hz VESA



1280x960@60Hz VESA



1280x1024@60Hz VESA



1360x768@60Hz VESA



1400x1050@60Hz VESA



1440x900@60Hz VESA



1600x1200 @60Hz VESA



1680x1050@60Hz VESA



1920x1080@60Hz VESA

DVI Compatibility Mode
DVI Compatibility Mode may be required if you are using an HDMI CIM
to connect to a Dell Optiplex target with an Intel video card, or a Mac ®
Mini with an HDMI video port.
Selecting this mode ensures a good video quality from the targets.
See Configuring CIM Ports
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Supported Remote Connections
Remote
connection

Details

Network

10BASE-T, 100BASE-T, and 1000BASE-T (Gigabit)
Ethernet

Protocols

TCP/IP, UDP, SNTP, HTTP, HTTPS, RADIUS,
LDAP/LDAPS

Network Speed Settings
KX III network speed setting
Network
switch port
setting
Auto

1000/Full

100/Full

100/Half

Auto

1000/Full

100/Full

100/Half

10/Full

10/Half

Highest
Available
Speed

1000/Full

KX III:
100/Full

100/Half

KX III:
10/Full

10/Half

1000/Full

1000/Full

No
No
No
No
Communica Communicat Communica Communicat
tion
ion
tion
ion

KX III:
100/Half

KX III:
100/Half

100/Full

Switch:
100/Full

Switch:
100/Full

100/Half

100/Half

Switch:
100/Half

KX III:
10/Half
Switch:
10/Full

10/Half

10/Half

KX III:
100/Half
Switch:
100/Full

KX III:
100/Full
Switch:
100/Half

10/Full

Switch:
10/Half

100/Half

No
No
Communica Communicat
tion
ion

No
No
Communica Communicat
tion
ion

No
No
No
10/Full
Communica Communica Communicat
tion
tion
ion

KX III:
10/Half

No
No
No
KX III:
Communica Communica Communicat 10/Full
tion
tion
ion
Switch:
10/Half

10/Half

Switch:
10/Full
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Legend:
Does not function as expected

Supported

Functions; not recommended

NOT supported by Ethernet specification; product will
communicate, but collisions will occur

Per Ethernet specification, these should be “no
communication,” however, note that the KX III behavior
deviates from expected behavior
Note: For reliable network communication, configure the KX III and the
LAN switch to the same LAN Interface Speed and Duplex. For example,
configure the KX III and LAN Switch to Autodetect (recommended), or
set both to a fixed speed/duplex such as 100MB/s/Full.
Dell Chassis Cable Lengths and Video Resolutions
In order to maintain video quality, Raritan recommends using the
following cable lengths and video resolutions when you are connecting to
Dell® blade chassis from the KX III:
Video resolution

Cable length

1024x768@60Hz

50' (15.24 m)

1280x1024@60Hz

50' (15.24 m)

1600x1200@60Hz

30' (9.14 m)

Smart Card Minimum System Requirements
Local Port Requirements

The basic interoperability requirement for local port attachment to the KX
III is:
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All devices (smart card reader or token) that are locally attached
must be USB CCID-compliant.
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Target Server Requirements

When using smart card readers, the basic requirements for
interoperability at the target server are:


The IFD (smart card reader) Handler must be a standard USB CCID
device driver (comparable to the generic Microsoft® USB CCID
driver).



A digital CIM or D2CIM-DVUSB (Dual-VM CIM) is required and must
be using firmware version 3A6E or later.



Blade chassis server connections, where a CIM per blade is used,
are supported.



Blade chassis server connections, where a CIM per chassis is used,
is only supported for IBM® BladeCenter® models H and E with
auto-discovery enabled.

Windows XP Targets
Windows XP® operating system targets must be running Windows XP
SP3 in order to use smart cards with the KX III. If you are working
with .NET 3.5 in a Windows XP environment on the target server, you
must be using SP1.
Linux Targets
If you are using a Linux® target, the following requirements must be met
to use smart card readers with the Raritan device.


CCID Requirements
If the Raritan D2CIM-DVUSB VM/CCID is not recognized as a smart
card reader by your Linux target, you may need to update the CCID
driver version to 1.3.8 or above and update the driver configuration
file (Info.plist).
Operating system

CCID requirements

RHEL 5

ccid-1.3.8-1.el5

SuSE 11

pcsc-ccid-1.3.8-3.12

Fedora® Core 10

ccid-1.3.8-1.fc10.i386
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Remote Client Requirements

The basic requirements for interoperability at the remote client are:


The IFD (smart card reader) Handler must be a PC/SC compliant
device driver.



The ICC (smart card) Resource Manager must be available and be
PC/SC compliant.



The JRE® Java™ 1.7 with smart card API must be available for use by
the Raritan client application.

Remote Linux Client Requirements

If you are using a Linux® client, the following requirements must be met
to use smart card readers with the Raritan device.
Note: User login to client, on smart card insertion, may take longer when
1 or more KVM sessions are actively in place to targets. As the login
process to these targets is also under way.


PC/SC Requirements
Operating system

Required PC/SC

RHEL 5

pcsc-lite-1.4.4-0.1.el5

SuSE 11

pcsc-lite-1.4.102-1.24

®

Fedora Core 10


pcsc-lite-1.4.102.3.fc10.i386

Create a Java® Library Link
A soft link must be created to the libpcsclite.so after upgrading RHEL
4, RHEL 5 and FC 10. For example, ln –s /usr/lib/libpcsclite.so.1
/usr/lib/libpcsclite.so, assuming installing the package places the
libraries in /usr/lib or /user/local/lib



PC/SC Daemon
When the pcsc daemon (resource manager in framework) is
restarted, restart the browser

Supported Smart Card Readers
Type

Vendor

Model

Verified

USB

SCM Microsystems

SCR331

Verified on local and
remote

USB

ActivIdentity®

ActivIdentity USB Reader v2.0

Verified on local and
remote
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Type

Vendor

Model

Verified

USB

SCM Microsystems

SCR331

Verified on local and
remote

USB

ActivIdentity

ActivIdentity USB Reader v3.0

Verified on local and
remote

USB

Gemalto®

GemPC USB-SW

Verified on local and
remote

USB Keyboard/Card Dell®
reader combo

USB Smart Card Reader
Keyboard

Verified on local and
remote

USB Keyboard/Card Cherry GmbH
reader combo

G83-6744 SmartBoard

Verified on local and
remote

USB reader for
SIM-sized cards

Omnikey

6121

Verified on local and
remote

Integrated (Dell
Latitude D620)

O2Micro

OZ776

Remote only

PCMCIA

ActivIdentity

ActivIdentity PCMCIA Reader

Remote only

PCMCIA

SCM Microsystems

SCR243

Remote only

Note: SCM Microsystems SCR331 smart card readers must be using
SCM Microsystems firmware v5.25.
Unsupported Smart Card Readers
This table contains a list of readers that Raritan has tested and found not
to work with the Raritan device, therefore they are unsupported.
If a smart card reader does not appear in the supported smart card
readers table or in the unsupported smart card readers table, Raritan
cannot guarantee it will function with the device.
Type

Vendor

Model

Notes

USB Keyboard/Card
reader Combo

HP®

ED707A

No interrupt endpoint
=> not compatible with
Microsoft® driver

USB Keyboard/Card
reader Combo

SCM
Microsystems

SCR338

Proprietary card
reader implementation
(not CCID-compliant)

USB Token

Aladdin®

eToken
PRO™

Proprietary
implementation
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Audio Playback and Capture Recommendations and Requirements
Audio Level



Set the target audio level to a mid-range setting.
For example, on a Windows® client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio
device, not from the client audio device control.
Recommendations for Audio Connections when PC Share Mode is Enabled

If you are using the audio feature while running PC Share mode, audio
playback and capture are interrupted if an additional audio device is
connected to the target.
For example, User A connects a playback device to Target1 and runs an
audio playback application then User B connects a capture device to the
same target. User A's playback session is interrupted and the audio
application may need to be restarted.
The interruption occurs because the USB device needs to be
re-enumerated with the new device configuration.
It may take some time for the target to install a driver for the new device.
Audio applications may stop playback completely, go to the next track, or
just continue playing.
The exact behavior is dependent on how the audio application is
designed to handle a disconnect/reconnect event.
Bandwidth Requirements

The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.
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Audio format

Network bandwidth requirement

44.1 KHz, 16bit stereo

176 KB/s

44.1 KHz, 16bit mono

88.2 KB/s

2.05 KHz, 16bit stereo

88.2 KB/s

22.05 KHz, 16bit mono

44.1 KB/s

11.025 KHz, 16bit stereo

44.1 KB/s

11.025 KHz, 16bit mono

Audio 22.05 KB/s
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In practice, the bandwidth used when an audio device connects to a
target is higher due to the keyboard and video data consumed when
opening and using an audio application on the target.
A general recommendation is to have at least a 1.5MB connection before
running playback and capture.
However, high video-content, full-color connections using high-target
screen resolutions consume much more bandwidth and impact the
quality of the audio considerably.
To help mitigate quality degeneration, there are a number of
recommended client settings that reduce the impact of video on audio
quality at lower bandwidths:


Connect audio playback at the lower quality formats. The impact of
video consuming bandwidth is much less notable at 11k connections
than at 44k



Set the connection speed under Connection Properties to a value
that best matches the client to server connection



Under Connection Properties, set the color depth to as lowt value as
possible. Reducing the color depth to 8 bit color considerably
reduces the bandwidth consumed



Set Smoothing, to High. This will improve the appearance of the
target video by reducing displayed video noise



Under Video settings, set the Noise Filter to its highest setting of 7
(highest value) so less bandwidth is used for target screen changes

Audio in a Mac Environment

Following are known issues in a Mac® environment.


On Mac clients, only one playback device is listed on the Connect
Audio panel when accessing the device through the Virtual KVM
Client (VKC). The device listed is the default and is displayed on the
Connect Audio panel as Java Sound Audio Engine.



Using audio on a Mac target through Skype® may cause the audio to
be corrupted.

Number of Supported Audio/Virtual Media and Smartcard
Connections
Following are the number of simultaneous Audio/Virtual Media and
Smartcard connections that can be made from a client to a target:


1 smartcard



1 virtual media



1 Smartcard and 1 virtual media



2 virtual media
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KX III Supported Keyboard Languages
The KX III provides keyboard support for the languages listed in the
following table.
Note: You can use the keyboard for Chinese, Japanese, and Korean for
display only; local language input is not supported at this time for the KX
III Local Console functions. For more information about non-US
keyboards, see Informational Notes (on page 135).
Note: Raritan strongly recommends that you use system-config-keyboard
to change languages if you are working in a Linux environment.
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Language

Regions

Keyboard layout

US English

United States of America and
most of English-speaking
countries: for example, Canada,
Australia, and New Zealand.

US Keyboard layout

US English
International

United States of America and
most of English-speaking
countries: for example,
Netherlands

US Keyboard layout

UK English

United Kingdom

UK layout keyboard

Chinese
Traditional

Hong Kong S. A. R., Republic of
China (Taiwan)

Chinese Traditional

Chinese
Simplified

Mainland of the People’s
Republic of China

Chinese Simplified

Korean

South Korea

Dubeolsik Hangul

Japanese

Japan

JIS Keyboard

French

France

French (AZERTY)
layout keyboard.

German

Germany and Austria

German keyboard
(QWERTZ layout)

French

Belgium

Belgian

Norwegian

Norway

Norwegian

Danish

Denmark

Danish

Swedish

Sweden

Swedish

Hungarian

Hungary

Hungarian

Slovenian

Slovenia

Slovenian

Italian

Italy

Italian
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Language

Regions

Keyboard layout

Spanish

Spain and most Spanish
speaking countries

Spanish

Portuguese

Portugal

Portuguese

Mac Mini BIOS Keystroke Commands
The following BIOS commands have been tested on Intel-based Mac®
Mini target servers and Mac Lion® servers running Mac Snow Leopard®.
The servers were attached to a KX III with D2CIM-DVUSB and
D2CIM-VUSB CIMs. See below for the supported keys and any notes.
Keystroke

Description

Virtual Media CIM Dual Virtual
Media CIM

Mac Lion Server
HDMI CIM

Press C during
startup

Start up from a
bootable CD or DVD,
such as the Mac OS X
Install disc

Press D during
startup

Start up in Apple
Hardware Test (AHT)
May need BIOS
Mac profile for the
mouse to work

May need BIOS
Mac profile for
mouse to work

May need BIOS
Mac profile for
the mouse to
work

Press OptionReset NVRAM
Command-P-R until
you hear startup
sound a second
time.
Press Option
during startup

Start up in Startup
Manager, where you
can select a Mac OS X
volume to start from

Press Eject, F12, or Ejects any removable
hold the mouse
media, such as an
button
optical disc
Press N during
startup

Start up from a
compatible network
server (NetBoot)

Press T during
startup

Start up in Target Disk
mode

Press Shift during

Start up in Safe Boot

Known issue with
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Keystroke

Description

startup

mode and temporarily
disable login items

Press Command-V
during startup

Start up in Verbose
mode.admin

Press Command-S
during startup

Start up in Single-User
mode

Press Option-N
during startup

Start from a NetBoot
server using the default
boot image

Press Command-R Start from Lion
during startup
Recovery1

Virtual Media CIM Dual Virtual
Media CIM

Mac Lion Server
HDMI CIM
LION to boot to
safe mode. "Safe
Mode" in red
does not appear
for Lion

N/A

N/A

Using a Windows Keyboard to Access Mac Targets
A Windows® keyboard can be used to access a Mac® connected to a KX
III. Windows keys are then used to emulate the special Mac keys. This is
the same as connecting a Windows keyboard directly to the Mac.
TCP and UDP Ports Used
Port

Description

HTTP, Port 80

This port can be configured as needed. See HTTP and HTTPS Port
Settings (on page 131).
By default, all requests received by the KX III via HTTP (port 80) are
automatically forwarded to HTTPS for complete security.
The KX III responds to Port 80 for user convenience, relieving users
from having to explicitly type in the URL field to access the KX III, while
still preserving complete security.

HTTPS, Port 443

This port can be configured as needed. See HTTP and HTTPS Port
Settings (on page 131).
By default, this port is used for multiple purposes, including the web
server for the HTML client, the download of client software (Virtual KVM
Client (VKC)) onto the client's host, and the transfer of KVM and virtual
media data streams to the client.

KX III (Raritan
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Port
KVM-over-IP)
Protocol,
Configurable Port
5000

Description
communication between Raritan devices and systems, including
CC-SG for devices that CC-SG management is available.
By default, this is set to Port 5000, but you may configure it to use any
TCP port not currently in use. For details on how to configure this
setting, see Network Settings.

SNTP (Time Server) The KX III offers the optional capability to synchronize its internal clock
on Configurable
to a central time server.
UDP Port 123
This function requires the use of UDP Port 123 (the standard for
SNTP), but can also be configured to use any port of your designation.
Optional
LDAP/LDAPS on
Configurable Ports
389 or 636

If the KX III is configured to remotely authenticate user logins via the
LDAP/LDAPS protocol, ports 389 or 636 will be used, but the system
can also be configured to use any port of your designation. Optional

RADIUS on
Configurable Port
1812

If the KX III is configured to remotely authenticate user logins via the
RADIUS protocol, either port 1812 will be used, but the system can also
be configured to use any port of your designation. Optional

RADIUS Accounting If the KX III is configured to remotely authenticate user logins via the
on Configurable Port RADIUS protocol, and also employs RADIUS accounting for event
1813
logging, port 1813 or an additional port of your designation will be used
to transfer log notifications.
SYSLOG on
Configurable UDP
Port 514

If the KX III is configured to send messages to a Syslog server, then the
indicated port(s) will be used for communication - uses UDP Port 514.

SNMP Default UDP
Ports

Port 161 is used for inbound/outbound read/write SNMP access and
port 162 is used for outbound traffic for SNMP traps. Optional

TCP Port 22

Port 22 is used for the KX III command line interface (when you are
working with Raritan Technical Support).

SSH

(Secure Shell) SSH port can be configured. The default is port 22.

HTTP and HTTPS Port Settings
You are able to configure HTTP and/or HTTPS ports used by the KX III.
For example, if you are using the default HTTP port 80 for another
purpose, changing the port will ensure the device does not attempt to
use it.
To change the HTTP and/or HTTPS port settings:
1. Choose Device Settings > Device Services. The Device Service
Settings page opens.
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2. Enter the new ports in the HTTP Port and/or HTTPS Port fields.
3. Click OK.

Software
Supported Operating Systems and Browsers
Operating Systems

Browsers

Windows 7® Home Premium SP1 64-bit

 Internet Explorer® 10 and 11
 Firefox® 25
 Chrome® 31
 Safari® 5.1.7

Windows 7 Ultimate SP1 64-bit

 Internet Explorer 8, 9, 11
 Firefox 25
 Chrome 31

Windows 7 Ultimate 32-bit

 Internet Explorer 8
 Firefox 25
 Chrome 31
 Internet Explorer 11

®

Windows 8 64-bit

 Firefox 25
 Chrome 31
®

Windows Server 2012 Standard 64-bit

 Internet Explorer 11
 Firefox 25
 Chrome 31

Windows XP® Home Edition with SP 3

 Internet Explorer 11
 Firefox 25
 Chrome 31

openSUSE® 11.4 Celadon (x86_64)

 Firefox 16.0.2

Fedora® 18 (Speherical Cow)

 Firefox 24

RHEL 6.4

 Firefox 21

Mac® OS X Mountain Lion® 10.7.5

 Firefox 25
 Safari 6.0.5 running JRE™ 1.7.0_51

Mac OS X Mountain Lion 10.8.5 *

 Firefox 25
 Safari 6.1.1 running JRE 1.7.0_51

®

Solaris 10 64-bit
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*Note: Upon upgrading from OS X 10.8.2 to OS X 10.8.3, Safari® may
block Java™.
JRE Requirements and Browser Considerations for Mac

Java Runtime Environment Requirements for Mac
Install Java Runtime Environment 7 (JRE)® on PCs and Macs® when
using the Virtual KVM Client (VKC) to access target servers via KX III.
This ensures in order to provide high performance, KVM-over-IP video
processing when remotely accessing target servers/PCs/Macs.
The latest version of JRE for Mac can be downloaded from the Apple
Support website.
Browser Considerations for Mac
Java may be disabled by default in certain browsers. Enable Java and
accept all security warnings in order to use KX III.
Certain versions of Safari® block Java for security reasons. Since Java is
required to use KX III, Raritan recommends you use Firefox ® instead.
Additionally, you may be required to navigate through a number of
messages. Select 'Do Not Block' if these messages are displayed.
Java and Microsoft .NET Requirements
Java™ 1.7 is required to use the Java-based KX III Virtual KVM Client..
Microsoft .NET® 3.5 (or later) is required to use KX III with the Microsoft
Windows®-based Active KVM Client (AKC).
KX III checks your current Java version and prompts you to update it if it
is not compatible.
See Java Runtime Environment (JRE) Notes (on page 135) for
additional information.
Multi-Language Keyboard JRE Requirement
In order for multi-language keyboards to work in the KX III and Virtual
KVM Client (VKC), install the multi-language version of JRE™.
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Events Captured in the Audit Log and Syslog
Following is a list and description of the events that are captured by the
KX III audit log and syslog:
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Access Login - A user has logged in to the KX III



Access Logout - A user has logged out of the KX III



Active USB Profile - The USB profile is active



CIM Connected - A CIM was connected



CIM Disconnected - A CIM was disconnected



Connection Lost - The connection to the target was lost



Disconnected User - A user was disconnected from a port



End CC Control - CC-SG management ended



Login Failed - User login failed



Password Changed - Password change occurred



Port Connect - Port was connected



Port Disconnect - Port was disconnected



Port Status Change - Change in the port status



Scan Started - A target scan was started



Scan Stopped - A target scan was stopped



Session Timeout - A session timeout occurred



VM Image Connected - A VM image was connected



VM Image Disconnected - A VM image was disconnected
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Overview
This section includes important notes on KX III usage. Future updates
will be documented and available online through the Help link in the KX
III Remote Console interface.
Note: Some topics in this section reference other multiple Raritan
devices because various devices are impacted by the information.

Java Runtime Environment (JRE) Notes
Disable Java Caching and Clear the Java Cache
It is highly recommended that you disable Java caching in Microsoft
Windows®, and clear the Java™ cache.
To disable Java caching and clear the cache:
1. From the Windows Start menu, click Control Panel.
2. Double-click on the Java icon to launch it. The Java Control Panel
dialog appears.
3. To disable Java caching:
a. From the General tab, click the Settings button. The Temporary
Files Settings dialog appears.
b. Click the View Applets button. The Java Applet Cache Viewer
opens.
c.

Deselect the Enable Caching checkbox if it is already checked.

d. Click OK.
4. To clear the Java cache:
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a. From the Temporary Files Settings dialog, click the Delete Files
button. The Delete Temporary Files dialog appears.
b. Select the temporary files that you want to delete.
c.

Click OK.

Java Not Loading Properly on Mac
If you are using a Mac® and see the following message when connecting
to a device from the KX III Port Access Table, Java™ is not loaded
properly:
"Error while getting the list of open targets, please try again in a few
seconds".
If this occurs, check your Java installation from this website:
http://www.java.com/en/download/testjava.jsp
http://www.java.com/en/download/testjava.jsp
If your Java applet is inactive, it can be enabled from this page. If it is not
installed correctly, a message lets you know and you can then reinstall
Java.

CIM Notes
Windows 3-Button Mouse on Linux Targets
When using a 3-button mouse on a Windows® client connecting to a
Linux® target, the left mouse button may get mapped to the center button
of the Windows client 3-button mouse.
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Windows 2000 Composite USB Device Behavior for Virtual Media
The Windows 2000® operating system does not support USB composite
devices, like Raritan’s D2CIM-VUSB, in the same manner as
non-composite USB devices.
As a result, the “Safely Remove Hardware” system tray icon does not
appear for drives mapped by the D2CIM-VUSB and a warning message
may appear when disconnecting the device. Raritan has not observed
any problems or issues from this message, however.
Raritan’s US engineering department has developed a configuration
which supports the “Safely Remove Hardware” icon and avoids this
Windows message. This configuration requires the use of the
D2CIM-DVUSB virtual media adapter and the Troubleshooting 3 USB
Profile that configures the D2CIM-DVUSB as a non-composite USB
device supporting a single virtual media connection. Raritan has
successfully tested this configuration in the US and Japan.

Virtual Media Notes
Cannot Connect to Drives from Linux Clients
If you cannot connect to a virtual media drive on a target server when
you connect from a client running Linux® Fedora™ 18 with Java™ 1.7
(update 45 and later), disable SELinux in Fedora 18 on the client to
resolve the problem.
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Cannot Write To/From a File from a Mac Client
If you are connecting to the KX III from a Mac® 10.8.5 client running
Safari® 6.1 with Java™ 1.7 and cannot write to/from a file on a target
server or access virtual media, do the following to correct this:
1. In Safari, select Preferences.
2. Under the Security tab, select Manage Website Settings.
3. Click on "Website for KX3".
4. Select "Run in safe mode" from the drop-down.
5. Restart Safari.
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Virtual Media via VKC and AKC in a Windows Environment
Windows XP® operating system administrator and standard user
privileges vary from those of the Windows Vista® operating system and
the Windows 7® operating system.
When enabled in Vista or Windows 7, User Access Control (UAC)
provides the lowest level of rights and privileges a user needs for an
application. For example, a Run as Administrator option is provided for
Internet Explorer® for Administrator level tasks; otherwise these are not
accessible even though the user has an Administrator login.
Both features affect the types of virtual media that can be accessed by
users via Virtual KVM Client (VKC) and Active KVM Client (AKC). See
your Microsoft® help for additional information on these features and how
to use them.
Following is a list virtual media types users can access via VKC and AKC
when running in a Windows environment. The features are broken down
by client and the virtual media features that are accessible to each
Windows user role.
Windows XP
If you are running VKC and AKC in a Windows XP environment, users
must have Administrator privileges to access any virtual media type other
than CD-ROM connections, ISOs and ISO images.
Windows Vista and Windows 7
If you are running VKC and AKC in a Windows Vista or Windows 7
environment and UAC is enabled, the following virtual media types can
be accessed depending on the user's Windows role:
Client

Administrator

AKC and Access to:
VKC
 Fixed drives and fixed
drive partitions

Standard User
Access to:


Removable drives





CD/DVD drives

Removable drives





ISO images

CD/DVD drives





Remote ISO images

ISO images



Remote ISO images

Virtual Media Not Refreshed After Files Added
After a virtual media drive has been mounted, if you add a file(s) to that
drive, those files may not be immediately visible on the target server.
Disconnect and then reconnect the virtual media connection.
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Virtual Media Linux Drive Listed Twice
For KX III, users who are logged in to Linux™ clients as root users, the
drives are listed twice in the Local Drive drop-down.
For example, you will see eg /dev/sdc and eg /dev/sdc1 where the first
drive is the boot sector and the second drive is the first partition on the
disk.
Accessing Virtual Media on a Windows 2000
A virtual media local drive cannot be accessed on a Windows 2000®
server using a D2CIM-VUSB.
Disconnecting Mac and Linux Virtual Media USB Drives
In a Linux® or Mac® environment:


For Linux users, if there is /dev/sdb and /dev/sdb1, the client only
uses /dev/sdb1 and advertise it as removable disk



/dev/sdb is not available for the user.



For Linux users, if there is /dev/sdb but no /dev/sdb1, /dev/sdb is
used as a removable device



For Mac users, /dev/disk1 and /dev/disk1s1 is used

Target BIOS Boot Time with Virtual Media
The BIOS for certain targets may take longer to boot if media is mounted
virtually at the target.
To shorten the boot time:
1. Close the Virtual KVM Client to completely release the virtual media
drives.
2. Restart the target.
Virtual Media Connection Failures Using High Speed for Virtual
Media Connections
Under certain circumstances it may be necessary to select the "Use Full
Speed for Virtual Media CIM" when a target has problems with "High
Speed USB" connections or when the target is experiencing USB
protocol errors caused by signal degradation due to additional
connectors and cables (for example, a connection to a blade server via a
dongle).
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Video Mode and Resolution Notes
Video Image Appears Dark when Using a Mac
If you are using a Mac® with an HDMI video port and the video seems too
dark, enable DVI Compatibility Mode on the CIM to help resolve the
issue.
See Configuring CIM Ports

Black Stripe/Bar(s) Displayed on the Local Port
Certain servers and video resolutions may display on the local port with
small black bars at the edge of the screen.
If this occurs:
1. Try a different resolution, or
2. If using a digital CIM, then change the Display Native Resolution on
the Port Configuration page to another resolution, or
3. If using the HDMI CIM, use the DVI Compatibility Mode.
Contact Raritan Technical Support for additional assistance.
Sun Composite Synch Video
Sun™ composite synch video is not supported.
SUSE/VESA Video Modes
The SuSE X.org configuration tool SaX2 generates video modes using
modeline entries in the X.org configuration file. These video modes do
not correspond exactly with VESA video mode timing (even when a
VESA monitor is selected). The KX III, on the other hand, relies on exact
VESA mode timing for proper synchronization. This disparity can result in
black borders, missing sections of the picture, and noise.
To configure the SUSE video display:
1. The generated configuration file /etc/X11/xorg.conf includes a
Monitor section with an option named UseModes. For example,
UseModes "Modes[0]"
2. Either comment out this line (using #) or delete it completely.
3. Restart the X server.
With this change, the internal video mode timing from the X server is
used and corresponds exactly with the VESA video mode timing,
resulting in the proper video display on the KX III.

141

Appendix D: Informational Notes

Keyboard Notes
French Keyboard
Caret Symbol (Linux Clients Only)

The Virtual KVM Client (VKC) do not process the key combination of Alt
Gr + 9 as the caret symbol (^) when using French keyboards with Linux ®
clients.
To obtain the caret symbol:
From a French keyboard, press the ^ key (to the right of the P key), then
immediately press the space bar.
Alternatively, create a macro consisting of the following commands:
1. Press Right Alt
2. Press 9.
3. Release 9.
4. Release Right Alt.
Note: These procedures do not apply to the circumflex accent (above
vowels). In all cases, the ^ key (to the right of the P key) works on French
keyboards to create the circumflex accent when used in combination with
another character.
Accent Symbol (Windows XP Operating System Clients Only)

From the Virtual KVM Client (VKC), the key combination of Alt Gr + 7
results in the accented character displaying twice when using French
keyboards with Windows XP® clients.
Note: This does not occur with Linux® clients.
Numeric Keypad

From the Virtual KVM Client (VKC), the numeric keypad symbols display
as follows when using a French keyboard:
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Tilde Symbol

From the Virtual KVM Client (VKC), the key combination of Alt Gr + 2
does not produce the tilde (~) symbol when using a French keyboard.
To obtain the tilde symbol:
Create a macro consisting of the following commands:


Press right Alt



Press 2



Release 2



Release right Alt

Keyboard Language Preference (Fedora Linux Clients)
Because the Sun™ JRE™ on Linux® has problems generating the correct
KeyEvents for foreign-language keyboards configured using System
Preferences, Raritan recommends that you configure foreign keyboards
using the methods described in the following table.
Language

Configuration method

US Intl

Default

UK

System Settings (Control Center)

French

Keyboard Indicator

German

Keyboard Indicator

Hungarian

System Settings (Control Center)

Spanish

System Settings (Control Center)

Swiss-German

System Settings (Control Center)

Norwegian

Keyboard Indicator

Swedish

Keyboard Indicator

Danish

Keyboard Indicator

Japanese

System Settings (Control Center)

Korean

System Settings (Control Center)

Slovenian

System Settings (Control Center)

Italian

System Settings (Control Center)

Portuguese

System Settings (Control Center)
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Note: The Keyboard Indicator should be used on Linux systems using
Gnome as a desktop environment.
When using a Hungarian keyboard from a Linux client, the Latin letter U
with Double Acute and the Latin letter O with Double Acute work only
with JRE 1.6 (and later).
There are several methods that can be used to set the keyboard
language preference on Fedora® Linux clients. The following method
must be used in order for the keys to be mapped correctly from the
Virtual KVM Client (VKC).
To set the keyboard language using System Settings:
1. From the toolbar, choose System > Preferences > Keyboard.
2. Open the Layouts tab.
3. Add or select the appropriate language.
4. Click Close.
To set the keyboard language using the Keyboard Indicator:
1. Right-click the Task Bar and choose Add to Panel.
2. In the Add to Panel dialog, right-click the Keyboard Indicator and
from the menu choose Open Keyboard Preferences.
3. In the Keyboard Preferences dialog, click the Layouts tab.
4. Add and remove languages as necessary.
Macros Not Saving on Linux Target Servers
If you receive the following error message when you create and then
save a macro on a target server running Linux® Fedora™ 18 with Java™
1.7.0 (update 45 and later), disable SELinux in Fedora 18 on the target
server to resolve the problem.
"An error occurred attempting to write the new keyboard
macros. Macro was not added"
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Mac Keyboard Keys Not Supported for Remote Access
When a Mac® is used as the client, the following keys on the Mac ®
keyboard are not captured by the Java™ Runtime Environment (JRE™):


F9



F10



F11



F14



F15



Volume Up



Volume Down



Mute



Eject

As a result, the Virtual KVM Client (VKC) are unable to process these
keys from a Mac client's keyboard.

Mouse Notes
Mouse Pointer Synchronization (Fedora)
When connected in dual mouse mode to a target server running Fedora®
7, if the target and local mouse pointers lose synchronization, changing
the mouse mode from or to Intelligent or Standard may improve
synchronization.
Single mouse mode may also provide for better control.
To resynchronize the mouse cursors:


Use the Synchronize Mouse option from the Virtual KVM Client
(VKC).

Single Mouse Mode when Connecting to a Target Under CC-SG
Control
When using Firefox® to connect to a KX III target under CC-SG control
using DCIM-PS2 or DCIM-USBG2, if you change to Single Mouse Mode
in the Virtual KVM Client (VKC), the VKC window will no longer be the
focus window and the mouse will not respond.
If this occurs, left click on the mouse or press Alt+Tab to return the focus
to the VKC window.
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Audio
Audio Playback and Capture Issues
Features that May Interrupt an Audio Connection
If you use any of the following features while connected to an audio
device, your audio connection may be interrupted. Raritan recommends
you do not use these features if you are connected to an audio device:


Video Auto-Sense



Extensive use of the local port



Adding users

Issues when Using a Capture Device and Playback Device
Simultaneously on a Target
On some targets, the simultaneous connection of capture devices and
playback devices may not work due to the USB hub controller and how it
manages the USB ports. Consider selecting an audio format that
requires less bandwidth.
If this does not resolve the issue, connect the D2CIM-DVUSB CIM's
keyboard and mouse connector to a different port on the target. If this
does not solve the problem, connect the device to a USB hub and
connect the hub to the target.
Audio in a Linux Environment
The following are known issues when using the audio feature in a Linux ®
environment.


Linux® users, use the default audio device for playback. Sound may
not come through if a non-default sound card is selected.



SuSE 11 clients require Javas_1_6_0-sun-alsa (ALSA support for
java-1_6_0-sun) to be installed via YAST.



For Logitech® headsets with a built in a mic, only the Mono Capture
option is available.



In order to display the device, if you are running SUSE 11 and an
ALSA driver, log out of KX III, then log back in.
Additionally, if you connect and disconnect the audio device a
number of times, the device may be listed several times vs. just once
as it should.
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Using the audio feature with a Fedora Core® 13 target set to mono
16 bit, 44k may cause considerable interference during playback.
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Audio in a Windows Environment
On Windows® 64-bit clients, only one playback device is listed on the
Connect Audio panel when accessing the device through the Virtual
KVM Client (VKC).
The audio device is the default device, and is listed on the Connect
Audio panel as Java Sound Audio Engine.

Smart Card Notes
Virtual KVM Client (VKC) Smart Card Connections to Fedora
Servers
If you are using a smart card to connect to a Linux® Fedora® server via
Virtual KVM Client (VKC) upgrade the pcsc-lite library to 1.4.102-3 or
above.

Browser Notes
Resolving Issues with Firefox Freezing when Using Fedora
If you are accessing Firefox® and are using a Fedora® server, Firefox
may freeze when it is opening.
To resolve this issue, install the libnpjp2.so Java™ plug-in on the server.
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Question

Answer

What is Dominion KX III?

Dominion KX III is a third-generation digital
KVM (keyboard, video, mouse) switch that
enables one, two, four or eight IT
administrators to access and control 8, 16, 32
or 64 servers over the network with BIOS-level
functionality. Dominion KX III is completely
hardware- and OS-independent; users can
troubleshoot and reconfigure servers even
when servers are down.
At the rack, Dominion KX III provides the same
functionality, convenience, and space and cost
savings as traditional analog KVM switches.
However, Dominion KX III also integrates the
industry’s highest performing KVM-over-IP
technology, allowing multiple administrators to
access server KVM consoles from any
networked workstation as well as from the
iPhone® and iPad®.

How is KX III
II ?

different from KX

The KX III is the next generation version of the
KX II. Featuring a modern hardware design
with increased computing power and storage,
the KX III provides KVM-over-IP access for IT
administration, as well as high performance IP
access for broadcast applications. KX III
includes virtually all KX II features with the
following advancements:
The KX III's new video processing engine
supports a broad range of applications from
traditional computer applications to the most
dynamic broadcast applications requiring 30
frames-per-second 1920x1080 video, 24 bit
color, digital audio, dual monitors and DVI,
HDMI, DisplayPort and VGA video.
With the industry’s first DVI-based local port,
the KX III's common user interface provides
new levels of productivity and performance for
at-the-rack administration and server access.
All KX III models feature a tiering port to
connect multiple Dominion KX III switches
together and access the attached servers. Up
to 1024 servers can be accessed via a
consolidated port list.
KX III supports all Dominion and Paragon II
CIMs supported by KX II.
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Question

Answer

How does Dominion KX III differ
from remote control software?

When using Dominion KX III remotely, the
interface, at first glance, may seem similar to
remote control software such as pcAnywhereTM,
Windows® Terminal Services/Remote Desktop,
VNC, etc. However, because Dominion KX III
is not a software but a hardware solution, it’s
much more powerful:
Hardware- and OS-independent – Dominion
KX III can be used to manage servers running
many popular OSs, including Intel®, Sun®,
PowerPC running Windows, Linux®, SolarisTM,
etc.
State-independent/Agentless – Dominion KX
IIKX IIII does not require the managed server
OS to be up and running, nor does it require
any special software to be installed on the
managed server.
Out-of-band – Even if the managed server’s
own network connection is unavailable, it can
still be managed through Dominion KX III.
BIOS-level access – Even if the server is hung
at boot up, requires booting to safe mode, or
requires system BIOS parameters to be
altered, Dominion KX III still works flawlessly to
enable these configurations to be made.

Can the Dominion KX III be rack
mounted?

Yes. The Dominion KX III ships standard with
19" rack mount brackets. It can also be reverse
rack mounted so the server ports face forward.

How large is the Dominion KX III?

Dominion KX III is only 1U high (except the
KX3-864 and KX3-464, which are 2U), fits in a
standard 19" rack mount and is only 11.4" (29
cm) deep. The Dominion KX3-832 and
KX3-864 are 13.8" (36 cm) deep.

Remote Access
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Question

Answer

How many users can remotely
access servers on each Dominion
KX III?

Dominion KX III models offer remote
connections for up to eight users per user
channel to simultaneously access and control a
unique target server. For one-channel devices
like the DKX3-116, up to eight remote users
can access and control a single target server.
For two-channel devices, like the DKX3-216,
up to eight users can access and control the
server on channel one and up to another eight
users on channel two. For four-channel
devices, up to eight users per channel, for a
total of 32 (8 x 4) users, can access and
control four servers. Likewise, for the
eight-channel devices, up to eight users can
access a single server, up to an overall
maximum of 32 users across the eight
channels.

Can I remotely access servers
from my iPhone or iPad?

Yes. Users can access servers connected to
the KX III using their iPhone or iPad.

Can two people look at the same
server at the same time?

Yes. Actually, up to eight people can access
and control any single server at the same time.

Can two people access the same Yes. The local port is completely independent
server, one remotely and one from of the remote "ports." The local port can
the local port?
access the same server using the PC-Share
feature.
In order to access Dominion KX III
from a client, what hardware,
software or network configuration
is required?

Because Dominion KX III is completely
Web-accessible, it doesn’t require customers
to install proprietary software on clients used
for access.
Note: Release KX III 3.0.0 does not provide
modem support, but will in a future release.
Dominion KX III can be accessed through
major Web browsers, including: Internet
Explorer® and Firefox®. Dominion KX III can be
accessed on Windows®, Linux® and Mac®
desktops, via Raritan’s Windows Client, and
the Java™-based Virtual KVM Client™.
Dominion KX III administrators can also
perform remote management (set passwords
and security, rename servers, change IP
address, etc.) using a convenient
browser-based interface.
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Question

Answer

What is the file size of the applet
that’s used to access Dominion KX
III? How long does it take to
retrieve?

The Virtual KVM Client (VKC) applet used to
access Dominion KX III is approximately 500KB
in size. The following chart describes the time
required to retrieve Dominion KX III’s applet at
different network speeds:

Do you have a Windows KVM
Client?

100Mbps

Theoretical
100Mbit network
speed

.05 seconds

60Mbps

Likely practical
100Mbit network
speed

.08 seconds

10Mbps

Theoretical 10Mbit
network speed

.4 seconds

6Mbps

Likely practical
10Mbit network
speed

.8 seconds

512Kbps

Cable modem
download speed
(typical)

8 seconds

Yes. We have a native .NET Windows Client
called the Raritan Active KVM Client (AKC).
See Active KVM Client (AKC) Help (on page
72)

Do you have a non-Windows KVM Yes. The Virtual KVM Client (VKC) allows
Client?
non-Windows users to connect to target
servers in the data center. See Virtual KVM
Client (VKC) Help (on page 25)
Do your KVM Clients have
multi-language support?

Yes. The Dominion KX III’s remote HTML User
Interface and the KVM Clients support the
Japanese, Simplified Chinese and Traditional
Chinese languages. This is available
stand-alone as well as through CC-SG.

Do your KVM Clients support dual
LCD monitors?

Yes. For customers wishing to enhance their
productivity by using multiple LCD monitors on
their desktops, the Dominion KX III can launch
KVM sessions to multiple monitors, either in full
screen or standard modes.
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Question

Answer

Do you support servers with dual
video cards?

Yes, dual video cards are supported with an
extended desktop configuration available to the
remote user.

Universal Virtual Media
Question

Answer

Which Dominion KX III models
support virtual media?

All Dominion KX III models support virtual
media. It is available stand-alone and through
CommandCenter® Secure Gateway, Raritan’s
centralized management appliance.

Which types of virtual media does
the Dominion KX III support?

Dominion KX III supports the following types of
media: internal and USB-connected CD/DVD
drives, USB mass storage devices, PC hard
drives and ISO images.

What is required for virtual media? A Dominion KX III virtual media CIM is required.
There are two VGA-based CIMs: a
D2CIM-VUSB or D2CIM-DVUSB.
The D2CIM-VUSB has a single USB connector
and is for customers who will use virtual media
at the OS level.
The D2CIM-DVUSB has dual USB connectors
and should be purchased by customers who
wish to utilize virtual media at the BIOS level.
The D2CIM-DVUSB is also required for smart
card authentication, tiering/cascading and digital
audio.
Both support virtual media sessions to target
servers supporting the USB 2.0 interface.
Available in economical 32 and 64 quantity CIM
packages, these CIMs support Absolute Mouse
Synchronization™ as well as remote firmware
updates.
Our CIMs have traditionally supported analog
VGA video. Three new dual virtual media CIMs
support digital video formats, including DVI,
HDMI and DisplayPort. These are the
D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI and
D2CIM-DVUSB-DP.
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Question

Answer

Is virtual media secure?

Yes. Virtual media sessions are secured using
256-bit AES, 128-bit AES or 128-bit RC4
encryption.

Does virtual media really support
audio?

Yes. Audio playback and recording to a server
connected to the Dominion KX III is supported.
You can listen to sounds and audio playing on a
remote server in the data center using the
speakers connected to your desktop PC or
laptop. You can also record on the remote
server using a microphone connected to your
PC or laptop. A digital CIM or D2CIM-DVUSB
dual virtual media CIM is required.

What is a USB profile?

Certain servers require a specifically configured
USB interface for USB-based services such as
virtual media. The USB profile tailors the KX III’s
USB interface to the server to accommodate
these server-specific characteristics.

Why would I use a USB profile?

USB profiles are most often required at the
BIOS level where there may not be full support
for the USB specification when accessing virtual
media drives. However, profiles are sometimes
used at the OS level, for example, for mouse
synchronization for Mac and Linux servers.

How is a USB profile used?

Individual ports or groups of ports can be
configured by the administrator to use a specific
USB profile in the KX III’s port configuration
page. A USB profile can also be selected in the
KX III Client when required. See the user guide
for more information.

Do I always need to set a USB
profile when I use virtual media?

No. In many cases, the default USB profile is
sufficient when using virtual media at the OS
level or operating at the BIOS level without
accessing virtual media.

What profiles are available? Where Consult the user guide for the available profiles
can I find more information?
and for more information.

Bandwidth and KVM-over-IP Performance
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Question

Answer

How is bandwidth used in
KVM-over-IP systems?

Dominion KX III offers totally new video
processing that provides flexible, high
performance video, efficient use of bandwidth
and anytime/anywhere access via LAN, WAN
or Internet.
The Dominion KX III digitizes compresses and
encrypts the keyboard, video and mouse
signals from the target server and transmits IP
packets over the IP network to the remote
client to create the remote session to the user.
The KX III provides an at-the-rack experience
based on its industry-leading video processing
algorithms.
Screen changes, i.e., video accounts for the
majority of the bandwidth used – and keyboard
and mouse activity are significantly less.
It is important to note that bandwidth is only
used when the user is active. The amount of
bandwidth used is based on the amount of
change to the server’s video display screen.
If there are no changes to the video – the user
is not interacting with the server – there is
generally little to no bandwidth used. If the user
moves the mouse or types a character, then
there is a small amount of bandwidth used. If
the display is running a complex screen saver
or playing a video, then there can be a larger
amount of bandwidth used.

How does bandwidth affect
KVM-over-IP performance?

In general, there is a trade-off between
bandwidth and performance. The more
bandwidth available, the better performance
can be. In limited bandwidth environments,
performance can degrade. The Dominion KX III
has been optimized to provide strong
performance in a wide variety of environments.
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Question

Answer

What factors affect bandwidth?

There are many factors that determine how
much bandwidth will be used. The primary
factor, noted above, is the amount of change in
the target server’s video display. This is
dependent on the user’s task and actions.
Other factors include the server’s video
resolution, networking speed and
characteristics, the KVM Client Connection
Properties, client PC resources and video card
noise.

How much bandwidth does KX III
use for common tasks?
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Bandwidth primarily depends on the user’s task
and actions. The more the server’s video
screen changes, the more bandwidth is
utilized.
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Question

Answer

How do I optimize performance
and bandwidth?

KX III provides a variety of settings in our
remote clients for the user to optimize
bandwidth and performance. The default
settings will provide an at-the-rack level of
performance in standard LAN/WAN
environments with economical use of
bandwidth.
Optimize For. Use this setting to configure
the video engine for standard IT/computer
applications or for video/broadcast
applications.
Compression. Move the slider to the left for
the highest possible video quality and to the
right for the least amount of bandwidth.
Noise Filter. In most cases, the default
setting will work best, however you can move
to the left for more responsive video and to the
right for lower bandwidth.
Other tips to decrease bandwidth include:
 Use a solid desktop background instead of
a complex image
 Disable screensavers
 Use a lower video resolution on the target
server
 Uncheck the "Show window contents while
dragging" option in Windows
 Use simple images, themes and desktops
(e.g., Windows Classic)

I want to connect over the Internet. It depends on the bandwidth and latency of the
What type of performance should I Internet connection between your remote client
expect?
and the KX III. With a cable modem or high
speed DSL connection, your performance can
be very similar to a LAN/WAN connection. For
lower speed links, use the suggestions above
to improve performance.
I have a high bandwidth
environment. How can I optimize
performance?

The default settings will work well. You can
move the Connection Properties settings to the
left for increased video performance.
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Question

Answer

What is the maximum remote (over The Dominion KX III is the first and only
IP) video resolution supported?
KVM-over-IP switch to support full high
definition (HD) remote video resolution –
1920x1080 at frame rates up to 30 frames per
second with digital audio.
In addition, popular widescreen formats are
supported, including 1600x1200, 1680x1050
and 1440x900, so remote users can work with
today’s higher resolution monitors.
How much bandwidth is used for
audio?

It depends on the type of audio format used,
but to listen to CD quality audio, approximately
1.5 Mbps is used.

What about servers with DVI
ports?

Servers with DVI ports that support DVI-A
(analog) and DVI-I (integrated analog and
digital) can use Raritan’s ADVI-VGA
inexpensive, passive adapter to convert the
server’s DVI port to a VGA plug that can be
connected to a KX III CIM’s VGA plug.
Servers with DVI ports that support DVI-I or
DVI-D (digital) can use the new
D2CIM-DVUSB-DVI CIM.

IPv6 Networking
Question

Answer

What is IPv6?

IPv6 is the acronym for Internet Protocol Version 6.
IPv6 is the "next generation" IP protocol which will
replace the current IP Version 4 (IPv4) protocol.
IPv6 addresses a number of problems in IPv4, such
as the limited number of IPv4 addresses. It also
improves IPv4 in areas such as routing and network
auto-configuration. IPv6 is expected to gradually
replace IPv4, with the two coexisting for a number of
years.
IPv6 treats one of the largest headaches of an IP
network from the administrator’s point of view –
configuring and maintaining an IP network.
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Question

Answer

Why does KX III support IPv6 U.S. government agencies and the Department of
networking?
Defense are now mandated to purchase
IPv6-compatible products. In addition, many
enterprises and foreign countries, such as China, will
be transitioning to IPv6 over the next several years.
What is "dual stack" and why Dual stack is the ability to simultaneously support
is it required?
IPv4 and IPv6 protocols. Given the gradual transition
from IPv4 to IPv6, dual stack is a fundamental
requirement for IPv6 support.
How do I enable IPv6 on the
KX III?

Use the "Network Settings" page, available from the
"Device Settings" tab. Enable IPv6 addressing and
choose manual or auto-configuration. Consult the
user guide for more information.

What if I have an external
The KX III can access external servers via their IPv6
server with an IPv6 address addresses, for example, an SNMP manager, syslog
that I want to use with my KX server or LDAP server.
III?
Using the KX III’s dual-stack architecture, these
external servers can be accessed via: (1) an IPv4
address, (2) IPv6 address or (3) hostname. So, the
KX III supports the mixed IPv4/IPv6 environment
many customers will have.
What if my network doesn’t
support IPv6?

The KX III’s default networking is set at the factory for
IPv4 only. When you are ready to use IPv6, then
follow the above instructions to enable IPv4/IPv6
dual-stack operation.

Where can I get more
information on IPv6?

See www.ipv6.org for general information on IPv6.
The KX III user guide describes the KX III’s support
for IPv6.

Servers
Question

Answer

Does Dominion KX III depend on a Absolutely not. Because users depend on the
Windows server to operate?
KVM infrastructure to always be available in
any scenario whatsoever (as they will likely
need to use the KVM infrastructure to fix
problems), Dominion KX III is designed to be
completely independent from any external
server.
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Question

Answer

What should I do to prepare a
server for connection to Dominion
KX III?

Set the mouse parameter options to provide
users with the best mouse synchronization and
turn off screensavers and any power
management features that affect screen
display.

What about mouse
synchronization?

In the past, KVM-over-IP mouse
synchronization was a frustrating experience.
The Dominion KX III’s Absolute Mouse
Synchronization provides for a tightly
synchronized mouse without requiring server
mouse setting changes on Windows and
Apple® Mac servers. For other servers, the
Intelligent Mouse mode or the speedy, single
mouse mode can be used to avoid changing
the server mouse settings.

What comes in the Dominion KX III The following is included: (1) Dominion KX III
box?
unit, (2) Quick Setup Guide, (3) standard 19"
rack mount brackets, (4) user manual
CD-ROM, (6) localized AC line cord and (7)
warranty certificate and other documentation.

Blade Servers
Question

Answer

Can I connect blade servers to the
Dominion KX III?

Yes. Dominion KX III supports popular blade
server models from the leading blade server
manufacturers: HP®, IBM®, Dell® and Cisco®.

Which blade servers are
supported?

The following models are supported: Dell
PowerEdge® 1855, 1955 and M1000e; HP
BladeSystem c3000 and c7000; IBM
BladeCenter® H, E and S; and Cisco UCS
B-Series.

Which CIM should I use?

It depends on the type of KVM ports on the
specific make and model of the blade server
you are using. The following CIMs are
supported: DCIM-PS2, DCIM-USBG2,
D2CIM-VUSB and D2CIM-DVUSB.

Which types of access and control
are available?

The Dominion KX III provides automated and
secure KVM access: (1) at the rack, (2)
remotely over IP, (3) via CommandCenter and
(4) by modem.
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Question

Answer

Do I have to use hotkeys to switch
between blades?

Some blade servers require you to use hotkeys
to switch between blades. With the Dominion
KX III, you don’t have to use these hotkeys.
Just click on the name of the blade server, and
the Dominion KX III will automatically switch to
that blade without the explicit use of the
hotkey.

Can I access the blade server’s
management module?

Yes. You can define the URL of the
management module and access it from the
Dominion KX III or from our CommandCenter
Secure Gateway. If configured, one-click
access is available.

How many blade servers can I
connect to a Dominion KX III?

For performance and reliability reasons, you
can connect up to eight blade chassis to a
Dominion KX III, regardless of model. Raritan
recommends connecting up to two times the
number of remote connections supported by
the device. For example, with a KX3-216 with
two remote channels, we recommend
connecting up to four blade server chassis.
You can, of course, connect individual servers
to the remaining server ports.

I’m an enterprise customer using
CommandCenter Secure Gateway.
Can I access blade servers via
CommandCenter Secure
Gateway?

Yes. Once blade servers are configured on the
Dominion KX III, the CommandCenter Secure
Gateway user can access them via KVM
connections. In addition, the blade servers are
organized by chassis as well as
CommandCenter Secure Gateway custom
views.

What if I also want in-band or
embedded KVM access?

In-band and embedded access to blade
servers can be configured within
CommandCenter Secure Gateway.

I’m running VMware® on some of
my blade servers. Is this
supported?

Yes. With CommandCenter Secure Gateway,
you can display and access virtual machines
running on blade servers.

Is virtual media supported?

This depends on the blade server. HP blades
can support virtual media. The IBM
BladeCenter (except for BladeCenter T)
supports virtual media if configured
appropriately. A virtual media CIM –
D2CIM-VUSB or D2CIM-DVUSB – must be
used.
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Question

Answer

Is Absolute Mouse
Synchronization supported?

Servers with internal KVM switches inside the
blade chassis typically do not support absolute
mouse technology. For HP blade and some
Dell blade servers, a CIM can be connected to
each blade, so Absolute Mouse
Synchronization is supported.

Is blade access secure?

Yes. Blade access uses all of the standard
Dominion KX III security features such as
128-bit or 256-bit encryption. In addition, there
are blade-specific security features such as per
blade access permissions and hotkey-blocking
that eliminates unauthorized access.

Does the Dominion KSX II or the
KX III-101 support blade servers?

At this time, these products do not support
blade servers.

Installation
Question

Answer

Besides the unit itself, what do I
need to order from Raritan to
install Dominion KX III?

Each server that connects to Dominion KX III
requires a Dominion or Paragon computer
interface module (CIM), an adapter that
connects directly to the keyboard, video and
mouse ports of the server.

Which kind of Cat5 cabling should
be used in my installation?

Dominion KX III can use any standard UTP
(unshielded twisted pair) cabling, whether
Cat5, Cat5e or Cat6. Often in our manuals and
marketing literature, Raritan will simply say
"Cat5" cabling for short. In actuality, any brand
UTP cable will suffice for Dominion KX III.

Which types of servers and PCs
can be connected to Dominion KX
III?

Dominion KX III is completely vendor
independent. Any server with
standards-compliant keyboard, video and
mouse ports can be connected. In addition,
servers with serial ports can be controlled
using the P2CIM-SER CIM.

How do I connect servers to
Dominion KX III?

Servers that connect to the Dominion KX III
require a Dominion or Paragon CIM, which
connects directly to the keyboard, video and
mouse ports of the server. Then, connect each
CIM to Dominion KX III using standard UTP
(unshielded twisted pair) cable such as Cat5,
Cat5e or Cat6.
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Question

Answer

How far can my servers be from
Dominion KX III?

In general, servers can be up to 150 feet (45
m) away from Dominion KX III, depending on
the type of server. (See Target Server Video
Resolution Supported Connection
Distances and Refresh Rates (on page 115))
For the D2CIM-VUSB CIMs that supports
virtual media and Absolute Mouse
Synchronization, a 100-foot (30 m) range is
recommended.

Some operating systems lock up
when I disconnect a keyboard or
mouse during operation. What
prevents servers connected to
Dominion KX III from locking up
when I switch away from them?

Each Dominion computer interface module
(DCIM) dongle acts as a virtual keyboard and
mouse to the server to which it is connected.
This technology is called KME
(keyboard/mouse emulation). Raritan’s KME
technology is data center grade, battle-tested
and far more reliable than that found in
lower-end KVM switches: it incorporates more
than 15 years of experience and has been
deployed to millions of servers worldwide.

Are there any agents
that must be installed on servers
connected to Dominion KX III?

Servers connected to Dominion KX III do not
require any software agents to be installed
because Dominion KX III connects directly via
hardware to the servers’ keyboard, video and
mouse ports.

How many servers can be
Dominion KX III models range from 8, 16 or 32
connected to each Dominion KX III server ports in a 1U chassis, to 64 server ports
unit?
in a 2U chassis. This is the industry’s highest
digital KVM switch port density.
What happens if I disconnect a
server from Dominion KX III and
reconnect it to another Dominion
KX III unit, or connect it to a
different port on the same
Dominion KX III unit?

Dominion KX III will automatically update the
server port names when servers are moved
from port to port. Furthermore, this automatic
update does not just affect the local access
port, but propagates to all remote clients and
the optional CommandCenter Secure Gateway
management appliance.
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Question

Answer

How do I connect a serially
controlled (RS-232) device, such
as a Cisco router/switch or a
headless Sun server, to Dominion
KX III?

If there are only a few serially controlled
devices, they may be connected to a Dominion
KX III using Raritan’s P2CIM-SER serial
converter.
Customers can also consider deploying the
Dominion KSX II, an integrated KVM and serial
switch. The DKSX-144 features four
KVM-over-IP ports and four serial ports.
The DKSX-188 features eight KVM-over-IP
ports and eight serial ports.
However, if there are many serially controlled
devices, we recommend the use of Raritan’s
Dominion SX line of secure console servers.
Dominion SX offers more serial functionality at
a better price point than Dominion KX III. This
SX is easy to use, configure and manage, and
can be completely integrated with a Dominion
series deployment.

Local Port - KX IIII
Question

Answer

Can I access my servers directly
from the rack?

Yes. At the rack, Dominion KX III functions just
like a traditional KVM switch – allowing control
of up to 64 servers using a single keyboard,
monitor and mouse. You can switch between
servers by the browser- based user interface or
via a hotkey.

Can I consolidate the local ports of Yes. You can connect the local ports of multiple
multiple KX IIIs?
KX III switches to another KX III using the
"tiering" feature of the KX III. You can then
access the servers connected to your KX III
devices from a single point in the data center via
a consolidated port list.
When I am using the local port, do
I prevent other users from
accessing servers remotely?
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No. The Dominion KX III local port has a
completely independent access path to the
servers. This means a user can access servers
locally at the rack – without compromising the
number of users that access the rack remotely
at the same time.
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Question

Answer

Can I use a USB keyboard or
mouse at the local port?

Yes. The Dominion KX III has USB keyboard
and mouse ports on the local port. Dominion KX
III switches do not have PS/2 local ports.
Customers with PS/2 keyboards and mice
should utilize a PS/2 to USB adapter.

Is there an onscreen display
(OSD) for local, at-the-rack
access?

Yes, but Dominion KX III’s at-the-rack access
goes way beyond conventional OSDs. Featuring
the industry’s first browser-based interface for
at-the-rack access, Dominion KX III’s local port
uses the same interface for local and remote
access. Moreover, most administrative functions
are available at the rack.

How do I select between servers
while using the local port?

The local port displays the connected servers
using the same user interface as the remote
client. Users connect to a server with a simple
click of the mouse or via a hotkey.

How do I ensure that only
authorized users can access
servers from the local port?

Users attempting to use the local port must pass
the same level of authentication as those
accessing remotely. This means that:
If the Dominion KX III is configured to interact
with an external RADIUS, LDAP or Active
Directory® server, users attempting to access
the local port will authenticate against the same
server.
If the external authentication servers are
unavailable, Dominion KX III fails over to its own
internal authentication database.
Dominion KX III has its own stand-alone
authentication, enabling instant, out-of-the-box
installation.

Extended Local Port
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Question

Answer

What is the extended local port?

The Dominion KX2-808, KX2-832 and KX2-864
featured an extended local port. The
corresponding Dominion KX III models do not
have an extended local port. Instead all KX III
models have a tiering port.
To extend the KX III's digital local port, you can
use the Raritan Cat5 Reach DVI product for
local and remote access up to 500 meters.
See Connecting a KX III and Cat5 Reach DVI
- Provide Extended Local Port Functionality
(on page 100)

Dual Power Supplies
Question

Answer

Does Dominion KX III have a dual
power option?

Yes. All Dominion KX III models come equipped
with dual AC inputs and power supplies with
automatic failover. Should one of the power
inputs or power supplies fail, then the KX III will
automatically switch to the other.

Does the power supply used by
Dominion KX III automatically
detect voltage settings?

Yes. Dominion KX III’s power supply can be
used in AC voltage ranges from 100–240 volts,
at 50–60 Hz.

If a power supply or input fails, will
I be notified?

The Dominion KX III front panel LED will notify
the user of a power failure. An entry will also be
sent to the audit log and displayed on the KX
remote client user interface. If configured by the
administrator, then SNMP or syslog events will
be generated.

Intelligent Power Distribution Unit (PDU) Control
Question

Answer

What type of remote power control Raritan’s intelligent PDUs can be connected to
capabilities does Dominion KX III
the Dominion KX III to provide power control of
offer?
target servers and other equipment. For
servers, after a simple one-time configuration
step, just click on the server name to power on,
off or to recycle a hung server.
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Question

Answer

What type of power strips does
Dominion KX III support?

Raritan’s Dominion PX™ and Remote Power
Control (RPC) power strips.
These come in many outlet, connector and
amp variations. Note that you should not
connect the PM series of power strips to the
Dominion KX III as these power strips do not
provide outlet-level switching.

How many PDUs can be
connected to a Dominion KX III?

Up to eight PDUs can be connected to a
Dominion KX III device.

How do I connect the PDU to the
Dominion KX III?

The D2CIM-PWR is used to connect the power
strip to the Dominion KX III. The D2CIM-PWR
must be purchased separately; it does not
come with the PDU.

Does Dominion KX III support
servers with multiple power
supplies?

Yes. Dominion KX III can be easily configured
to support servers with multiple power supplies
connected to multiple power strips. Four power
supplies can be connected per target server.

Does the Dominion KX III display
statistics and measurements from
the PDU?

Yes. PDU-level power statistics, including
power, current and voltage, are retrieved from
the PDU and displayed to the user.

Does remote power control require Some servers ship with default BIOS settings
any special configuration of
such that the server does not automatically
attached servers?
restart after losing and regaining power. For
these servers, see the server’s documentation
to change this setting.
What happens when I recycle
power to a server?

Note that this is the physical equivalent of
unplugging the server from the AC power line,
and reinserting the plug.

Ethernet and IP Networking
Question

Answer

What is the speed of Dominion KX
III’s Ethernet interfaces?

Dominion KX III supports gigabit as well as
10/100 Ethernet. KX III supports two
10/100/1000 speed Ethernet interfaces, with
configurable speed and duplex settings (either
auto detected or manually set).
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Question

Answer

Can I access Dominion
KX III over a wireless connection?

Yes. Dominion KX III not only uses standard
Ethernet, but also very conservative bandwidth
with very high quality video. Thus, if a wireless
client has network connectivity to a Dominion
KX III, servers can be configured and managed
at the BIOS level wirelessly.

Does the Dominion KX III offer
dual gigabit Ethernet ports to
provide redundant failover or load
balancing?

Yes. Dominion KX III features dual gigabit
Ethernet ports to provide redundant failover
capabilities. Should the primary Ethernet port
(or the switch/router to which it is connected)
fail, Dominion KX III will failover to the
secondary network port with the same IP
address – ensuring that server operations are
not disrupted. Note that automatic failover must
be enabled by the administrator.

Can I use Dominion KX III with a
VPN?

Yes. Dominion KX III uses standard Internet
Protocol (IP) technologies from Layer 1 through
Layer 4. Traffic can be easily tunneled through
standard VPNs.

Can I use KX III with a proxy
server?

Yes. KX III can be used with a SOCKS proxy
server, assuming the remote client PC is
configured appropriately. Contact the user
documentation or online help for more
information.

How many TCP ports must be
open on my firewall in order to
enable network access to
Dominion KX III?

Two ports are required: TCP port 5000 to
discover other Dominion devices and for
communication between Raritan devices and
CC-SG; and, of course, port 443 for HTTPS
communication.

Are these ports configurable?

Yes. Dominion KX III’s TCP ports are
configurable by the administrator.

Can Dominion KX III be used with
Citrix®?

Dominion KX III may work with remote access
products like Citrix if configured appropriately,
but Raritan cannot guarantee it will work with
acceptable performance. Customers should
realize that products like Citrix utilize video
redirection technologies similar in concept to
digital KVM switches so that two KVM-over-IP
technologies are being used simultaneously.

Can the Dominion KX III use
DHCP?

DHCP addressing can be used; however,
Raritan recommends fixed addressing since the
Dominion KX III is an infrastructure device and
can be accessed and administered more
effectively with a fixed IP address.
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Question

Answer

I’m having problems connecting to
the Dominion KX III over my IP
network. What could be the
problem?

The Dominion KX III relies on your LAN/WAN
network. Some possible problems include:
Ethernet auto-negotiation. On some networks,
10/100 auto-negotiation does not work properly,
and the Dominion KX III unit must be set to 100
Mb/full duplex or the appropriate choice for its
network.
Duplicate IP address. If the IP address of the
Dominion KX III
is the same as another device, network
connectivity may be inconsistent.
Port 5000 conflicts. If another device is using
port 5000, the Dominion KX III default port must
be changed (or the other device must be
changed).
When changing the IP address of a Dominion
KX III, or swapping in a new Dominion KX III,
sufficient time must be allowed for its IP and
Mac® addresses to be known throughout the
Layer 2 and Layer 3 networks.

Local Port Consolidation, Tiering and Cascading
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Question

Answer

How do I physically connect
multiple Dominion KX III devices
together into one solution?

To physically connect multiple KX III devices
together for consolidated local access, you can
connect the Tiering ports of multiple "tiered" (or
"cascaded") KX III switches to a "base" KX III
using the Tiering port of the KX III. You can
then access the servers connected to your KX
III devices from a single point in the data center
via a consolidated port list.
The Tiering port must be used to connect the
tiered KX III switch to the base switch.
Access via the consolidated port list is
available in the data center or even from a
remote PC. All servers connected to the tiered
KX IIIs can be accessed via a hierarchical port
list or via search (with wildcards).
Two levels of tiering are supported; up to 1024
devices can be accessed in a tiered
configuration. Remote power control is also
supported.
Virtual media, smart card and blade server
access via tiered access will be supported in a
future release. Of course these features are
available when accessed via a standard
remote connection.
While remote IP server access via the
consolidated port list is available as a
convenience, remote accessing a tiered server
from CommandCenter or via the KX III the
server is connected to, is recommended for
optimal performance.
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Question

Answer

Do I have to physically connect
Dominion KX III devices together?

Multiple Dominion KX III units do not need to
be physically connected together. Instead,
each Dominion KX III unit connects to the
network, and they automatically work together
as a single solution if deployed with Raritan’s
CommandCenter Secure Gateway (CC-SG)
management appliance.
CC-SG acts as a single access point for
remote access and management.
CC-SG offers a significant set of convenient
tools, such as consolidated configuration,
consolidated firmware update and a single
authentication and authorization database.
Customers using CC-SG for centralized remote
access can make good use of the KX III’s
tiering (cascading) feature to consolidate the
local ports of multiple KX III switches and
locally access up to 1024 servers from a single
console when in the data center.

Is CC-SG required?

For customers wanting stand-alone usage
(without a central management system),
multiple Dominion KX III units still interoperate
and scale together via the IP network. Multiple
Dominion KX III switches can be accessed
from the KX III Web-based user interface.

Can I connect an existing analog
KVM switch to Dominion KX III?

Yes. Analog KVM switches can be connected
to one of Dominion KX III’s server ports. Simply
use a USB computer interface module (CIM),
and attach it to the user ports of the existing
analog KVM switch.
Analog KVM switches supporting hotkey-based
switching on their local ports can be tiered to a
Dominion KX III switch and switched via a
consolidated port list, both remotely and in the
data center.
Please note that analog KVM switches vary in
their specifications and Raritan cannot
guarantee the interoperability of any particular
third-party analog KVM switch. Contact Raritan
technical support for further information.

Computer Interface Modules (CIMs)

171

Appendix E: Frequently Asked Questions

Question

Answer

What type of video is supported by Our CIMs have traditionally supported analog
your CIMs?
VGA video. Three new CIMs support digital
video formats, including DVI, HDMI and
DisplayPort. These are the
D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI
and D2CIM-DVUSB-DP.
Can I use computer interface
modules (CIMs) from Paragon,
Raritan’s analog matrix KVM
switch, with Dominion KX III?

Yes. Certain Paragon computer interface
modules (CIMs) may work with Dominion KX
IIKX IIII. (Please check the Raritan Dominion
KX III Release Notes on the website for the
latest list of certified CIMs.)
However, because Paragon CIMs cost more
than Dominion KX III CIMs (as they incorporate
technology for video transmission of up to
1,000 feet [304 m]), it is not generally advisable
to purchase Paragon CIMs for use with
Dominion KX III. Also note that when
connected to Dominion KX III, Paragon CIMs
transmit video at a distance of up to 150 feet
(46 m), the same as Dominion KX III CIMs –
not at 1,000 feet (304 m), as they do when
connected to Paragon.

Does Dominion KX III support
Paragon Dual CIMs?

Yes. The Dominion KX III supports Paragon II
Dual CIMs (P2CIM-APS2DUAL and
P2CIM-AUSBDUAL), which can connect
servers in the data center to two different
Dominion KX III switches.
If one KX III switch is not available, the server
can be accessed through the second KX III
switch, providing redundant access and
doubling the level of remote KVM access.
Please note these are Paragon CIMs, so they
do not support the KX III advanced features
such as virtual media, absolute mouse, audio,
etc.

Security
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Question

Answer

Is the Dominion KX III FIPS 140-2
Certified?

The Dominion KX III uses an embedded FIPS
140-2 validated cryptographic module running
on a Linux platform per FIPS 140-2
implementation guidelines. This cryptographic
module is used for encryption of KVM session
traffic consisting of video, keyboard, mouse,
virtual media and smart card data.

What kind of encryption does
Dominion KX III use?

Dominion KX III uses industry-standard (and
extremely secure) 256-bit AES, 128-bit AES or
128-bit encryption, both in its SSL
communications as well as its own data
stream. Literally no data is transmitted between
remote clients and Dominion KX III that is not
completely secured by encryption.

Does Dominion KX III support AES Yes. The Dominion KX III utilizes the Advanced
encryption as recommended by
Encryption Standard (AES) for added security.
the U.S. government’s NIST and
256-bit and 128-bit AES is available.
FIPS standards?
AES is a U.S. government-approved
cryptographic algorithm that is recommended
by the National Institute of Standards and
Technology (NIST) in the FIPS Standard 197.
Does Dominion KX III allow
encryption of video data? Or does
it only encrypt keyboard and
mouse data?

Unlike competing solutions, which only encrypt
keyboard and mouse data, Dominion KX III
does not compromise security – it allows
encryption of keyboard, mouse, video and
virtual media data.

How does Dominion KX III
integrate with external
authentication servers such as
Active Directory, RADIUS or
LDAP?

Through a very simple configuration, Dominion
KX III can be set to forward all authentication
requests to an external server such as LDAP,
Active Directory or RADIUS. For each
authenticated user, Dominion KX III receives
from the authentication server the user group
to which that user belongs. Dominion KX III
then determines the user’s access permissions
depending on the user group to which he or
she belongs.

How are usernames and
passwords stored?

Should Dominion KX III’s internal
authentication capabilities be used, all
sensitive information, such as usernames and
passwords, is stored in an encrypted format.
Literally no one, including Raritan technical
support or product engineering departments,
can retrieve those usernames and passwords.
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Question

Answer

Does Dominion KX III support
strong passwords?

Yes. The Dominion KX III has
administrator-configurable, strong password
checking to ensure that user-created
passwords meet corporate and/or government
standards and are resistant to brute force
hacking.

Can I upload my own digital
Yes. Customers can upload self-signed or
certificate to the Dominion KX IIKX certificate authority-provided digital certificates
IIII?
to the Dominion KX III for enhanced
authentication and secure communication.
Does the KX III support a
configurable security banner?

Yes. For government, military and other
security-conscious customers requiring a
security message before user login, the KX III
can display a user-configurable banner
message and optionally require acceptance.

My security policy does not allow
the use of standard TCP port
numbers. Can I change them?

Yes. For customers wishing to avoid the
standard TCP/IP port numbers to increase
security, the Dominion KX III allows the
administrator to configure alternate port
numbers.

Smart Cards and CAC Authentication
Question

Answer

Does Dominion KX III support smart
card and CAC authentication?

Yes. Smart cards and DoD common access
cards (CAC) authentication to target servers
is supported.

What is CAC?

Mandated by Homeland Security
Presidential Directive 12 (HSPD-12), CAC is
a type of smart card created by the U.S.
government and used by U.S. military and
government staff. The CAC card is a
multitechnology, multipurpose card; the goal
is to have a single identification card. For
more information, see the FIPS 201
standards.

Which KX III models support smart
cards/CAC?

All Dominion KX III models are supported.
The Dominion KX III-101 models do not
currently support smart cards and CAC.
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Question

Answer

Do enterprise and SMB customers use Yes. However, the most aggressive
smart cards, too?
deployment of smart cards is in the U.S.
federal government.
Which CIMs support
smart card/CAC?

The D2CIM-DVUSB, D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and
D2CIM-DVUSB-DP are the required CIMs.

Which smart card readers are
supported?

The required reader standards are USB
CCID and PC/SC. Consult the user
documentation for a list of certified readers
and more information.

Can smart card/CAC authentication
work on the local port and via
CommandCenter?

Yes. Smart card/CAC authentication works
on both the local port and via
CommandCenter. For the local port,
connect a compatible smart card reader to
the USB port of the Dominion KX III.

Manageability
Question

Answer

Can Dominion KX III be remotely
managed and configured via Web
browser?

Yes. Dominion KX III can be completely
configured remotely via Web browser. Note
that this does require that the workstation have
an appropriate Java Runtime Environment
(JRE) version installed. Besides the initial
setting of Dominion KX III’s IP address,
everything about the solution can be
completely set up over the network. (In fact,
using a crossover Ethernet cable and
Dominion KX III’s default IP address, you can
even configure the initial settings via Web
browser.)

Can I back up and restore
Dominion KX III’s configuration?

Yes. Dominion KX III’s device and user
configurations can be completely backed up for
later restoration in the event of a catastrophe.
Dominion KX III’s backup and restore
functionality can be used remotely over the
network, or through your Web browser.
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Question

Answer

What auditing or logging does
Dominion KX III offer?

For complete accountability, Dominion KX III
logs all major user events with a date and time
stamp. For instance, reported events include
(but are not limited to): user login, user logout,
user access of a particular server,
unsuccessful login, configuration changes, etc.

Can Dominion KX III integrate with Yes. In addition to Dominion KX III’s own
syslog?
internal logging capabilities, Dominion KX III
can send all logged events to a centralized
syslog server.
Can Dominion KX III integrate with Yes. In addition to Dominion KX III’s own
SNMP?
internal logging capabilities, Dominion KX III
can send SNMP traps to SNMP management
systems. SNMP v2 and v3 are supported.
Can an administrator log-off a
user?

Yes, administrators can view which users are
logged into which ports and can log-off a user
from a specific port or from the device if
required.

Can Dominion KX III’s internal
clock be synchronized with a
timeserver?

Yes. Dominion KX III supports the
industry-standard NTP protocol for
synchronization with either a corporate
timeserver, or with any public timeserver
(assuming that outbound NTP requests are
allowed through the corporate firewall).

Documentation and Support
Question

Answer

Is online help available?

Yes. Online help is available from the KX III
user interface, and at raritan.com with the
documentation.
Online help includes KX III administration and
end user information on using the Remote
Console, Virtual KVM Client (VKC) Active KVM
Client (AKC) and Local Console, as well KX III
specifications, informational notes, using KX III
with Paragon II, connecting KX III to the Cat5
Reach DVI, connecting KX III to the
T1700-LED, and so on.
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Question

Answer

Where do I find documentation on
the Dominion KX III?

The documentation is available at raritan.com.
The documentation is listed by firmware
release.

What documentation is available?

A Quick Setup Guide, online help, a PDF
version of the help in the form of an
Administrators Guide and a Users Guide, as
well as Release Notes and other information
are available.

What CIM should I use for a
particular server?

Consult the CIM Guide available with the KX III
documentation. Note that DVI, HDMI and
DisplayPort video standards are supported with
the digital video CIMs.

How long is the hardware warranty The Dominion KX III comes with a standard
for the KX III?
two-year warranty, which can be extended to 5
years of warranty coverage.

Miscellaneous
Question

Answer

What is Dominion KX III’s default
IP address?

192.168.0.192

What is Dominion KX III’s default
username and password?

The Dominion KX III’s default username and
password are admin/raritan (all lower case).
However, for the highest level of security, the
Dominion KX III forces the administrator to
change the Dominion KX III default
administrative username and password when
the unit is first booted up.

I changed and subsequently forgot
Dominion KX III’s administrative
password; can you retrieve it for
me?

Dominion KX III contains a hardware reset
button that can be used to factory reset the
device, which will reset the administrative
password on the device to the default
password.
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Question

Answer

In general, KX II customers can continue to
How do I migrate from the
Dominion KX II to Dominion KX III? use their existing switches for many years. As
their data centers expand, customers can
purchase and use the new KX III models.
Raritan’s centralized management appliance,
CommandCenter Secure Gateway (CC-SG)
Release 6.0 supports KX II and KX III switches
seamlessly.
Will my existing KX II CIMs work
with Dominion KX III switches?
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Yes. Existing KX II CIMs will work with the
Dominion KX III switch. In addition, select
Paragon CIMs will work with the KX III. This
provides an easy migration to KX III for
Paragon II customers who wish to switch to
KVM over IP. However, you may want to
consider the D2CIM-VUSB and
D2CIM-DVUSB CIMs that support virtual
media, audio and Absolute Mouse
Synchronization. Additionally, digital video
CIMs supporting DVI, HDMI, and Display Port
are also available.
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