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Chapter 1

Introduction

Raritan Multi-Platform Client (MPC), Raritan Remote Client (RRC),
Virtual KVM Client (VKC), and the Active KVM Client (AKC) are graphical
user interfaces for the Raritan Dominion and IP-Reach product lines,
providing remote access to target servers connected to Raritan KVM
over IP devices.

By default, generation 2 Raritan devices use VKC and AKC is only
compatible with KX II 2.2 or later. However, generation 2 devices will not
work using RRC. Non-Windows® users must use Raritan Multi-Platform
Client and Windows users connecting to a generation 1 Raritan device
must use RRC.

The standalone Raritan Serial Console (RSC) is used to make direct
connections to a serial target without going through the device. The user
specifies the device address and the port number (target), and is then
connected.

In This Chapter

KVM and Serial Access Client USer GUIAE ........oooeveveeeeviieiiieeeiee e 1
Client Uses with Raritan ProdUCES ...........viiiveiiiiiee e 1

KVM and Serial Access Client User Guide

This user guide provides information on using Raritan's KVM and serial
clients. A PDF version of the user guide can be downloaded from
Raritan's Firmware and Documentation page on the Raritan website (see
www.raritan.com). Raritan recommends that you refer to the Raritan
website for the most up-to-date user guides available.

Client Uses with Raritan Products

m
i

Raritan.

The following table lists Raritan products and the client applications with
which they work:

Product Works with...

MPC RRC VKC RSC AKC
con o
G N
KX 11 2.2 (or later) v - v - v



Chapter 1: Introduction

KX 11-101

KX 101 G1

KSX G1

KSX 11 G2

SX

IP Reach G1

UST-IP G1

B
B
|
v’

v’

I
|

Legend:
G1 Generation 1

G2 Generation 2

Note: There are some differences in MPC when used with the Dominion
KX I, Dominion KX Il, and Dominion KSX Il devices; these differences
are noted in the respective device user guides.

Note: MPC and VKC are Java based. AKC is .NET based.

= 7
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Chapter 2

Virtual KVM Client (VKC)

In This Chapter

OVBIVIBW ...ttt ettt e et e et e e ettt e e et e e e et e e e e e nneas 3
RV SO oo ] | o T SRR 3
CONNECHION PrOPEITIES ...vveiieiiiiie ettt 6
Connection INFOrMALION ........ocvviiiiiie e e e e e 8
Keyboard OPLIONS.......ouai it e e e 8
VidEO PrOPEITIES ..cceiiiiiieeee e 12
MOUSE OPLIONS ...eeteiiieieeee ittt ettt e e e et e e e e e e e e e s e e e e e e e e annes 17
Smart Cards (VKC and MPC) .......ueiiiiiiiiiiiiiieieeee e 23
L0 T0] @] o) o] 1 O EERO 25
RV 1 A @] o] 1T LTS 27
[ [=1 1o @ o] 10 o SRS 27

Overview

Whenever you access a target server using the Remote Console, a
Virtual KVM Client (VKC) window opens. There is one Virtual KVM Client
for each target server connected. These windows can be accessed via
the Windows"® task bar.

Virtual KVM Client windows can be minimized, maximized, and moved
around your computer desktop.

Note: Refreshing your HTML browser will close the Virtual KVM Client
connection, so exercise caution.

Note: If you are using Firefox 3.0.3, you may experience problems
launching the application. If this occurs, clear the browser cache and
launch the application again.

VKC Toolbar

i

Raritan.

Note: The KX [I-101 VKC interface is different from the other Dominion
KX products. See VKC Toolbar for the KX 1I-101 (on page 5).

Button Button Description
Name

—h Connection  Opens the Modify Connection Properties dialog

= Properties from which you can manually adjust bandwidth
options (such as connection speed, color depth,
and so forth).
% Video Opens the Video Settings dialog, allowing you to
Settings manually adjust video conversion parameters.
3
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Button

1

i
s
%

T

i":]'T []
M

S i

Button
Name

Color
Calibration

Target
Screenshot

Synchronize
Mouse

Refresh
Screen

Auto-sense
Video
Settings

Smart Card

Send
Ctrl+Alt+Del

Single Cursor
Mode

Full Screen
Mode

Scaling

Description

Adjusts color settings to reduce excess color
noise.

Same as choosing Video > Color Calibrate.

Click to take a screenshot of the target server
and save it to a file of your choosing.

In dual-mouse mode, forces realignment of the
target server mouse pointer with the mouse
pointer.

Forces a refresh of the video screen.

Forces a refresh of the video settings (resolution,
refresh rate).

Opens a dialog that allows you to select from a
list of smart card readers connected to a client
PC.

Note: This function is only available on the KX II
2.1.10 or later.

Note: AKC does not support smart cards.

Sends a Ctrl+Alt+Del hot key combination to the
target server.

Starts Single Cursor mode in which the local
mouse pointer no longer appears onscreen.

Press Ctrl+Alt+O to exit this mode.
Alternatively, choose Single/Double Cursor

from the shortcut menu, which is opened by
pressing Ctrl+Left Alt+M.

Maximizes the screen real estate to view the
target server desktop.

Note: AKC uses an Exit Full Screen Mode icon

j:E to exit out of full screen mode once you are
in it.

Increases or reduces the target video size so you
can view the entire contents of the target server
window without using the scroll bar.

=i=Raritan.



i

Raritan.

Chapter 2: Virtual KVM Client (VKC)

VKC Toolbar for the KX 11-101

Following is a list and description of the standard toolbar buttons in VKC
for KX 11-101.

Button

(=L
=

1+

L]

E3
Fo

Button name Description

Connection
Properties

Video
Settings

Synchronize
Mouse

Refresh
Screen

Auto-sense
Video
Settings

Send
Ctrl+Alt+Del

Single Cursor
Mode

Full Screen
Mode

Scaling

Opens the Modify Connection Properties
dialog from which you can manually adjust
bandwidth options (such as connection
speed, color depth, and so forth).

Opens the Video Settings dialog, allowing
you to manually adjust video conversion
parameters.

In dual-mouse mode, forces realignment of
the target server mouse pointer with the
mouse pointer.

Forces a refresh of the video screen.

Forces a refresh of the video settings
(resolution, refresh rate).

Sends a Ctrl+Alt+Del hot key combination to
the target server.

Starts Single Cursor mode in which the local
mouse pointer no longer appears onscreen.
Alternatively, press Ctrl+Alt+O to exit single
cursor mode.

Maximizes the screen real estate to view the
target server desktop.

Increases or reduces the target video size so
you can view the entire contents of the target
server window without using the scroll bar.
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Connection Properties

The dynamic video compression algorithms maintain KVM console
usability under varying bandwidth constraints. The devices optimize KVM
output not only for LAN use, but also for WAN use. These devices can
also control color depth and limit video output, offering an optimal
balance between video quality and system responsiveness for any
bandwidth.

The parameters in the Properties dialog can be optimized to suit your
needs for different operating environments. Connection properties are
saved across subsequent connections to generation 2 devices once they
are set and saved.

Note: VKC for the KX 11-101 uses an icon set that differs from the icon
set used in VKC for other Dominion KX products. See VKC Toolbar for
the KX 11-101 (on page 5) for additional information.

P To set the connection properties:
1. Choose Connection > Properties or click the Connection Properties

button E in the toolbar. The Properties dialog appears.

Properties [z

Connection Speed -1 3 Ethetnet

Color Depth (15-hitRGB Calor v |

Smoothing < I ¥ Low

Ol | Cancel | |

Note: KX 11-101 does not support 1G Ethernet.

Note: VKC for the KX 11-101 uses an icon set that differs from the
icon set used in VKC for other Dominion KX products. See VKC
Toolbar for the KX 11-101 (on page 5) for additional information.

2. Choose the Connection Speed from the drop-down list. The device
can automatically detect available bandwidth and not limit bandwidth
use. However, you can also adjust this usage according to
bandwidth limitations.

= Auto
= 1G Ethernet

=i=Raritan.
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= 100 Mb Ethernet

= 10 Mb Ethernet

= 1.5Mb (MAX DSL/T1)
= 1 Mb (Fast DSL/T1)

= 512 Kb (Medium DSL/T1)
= 384 Kb (Slow DSL/T1)
= 256 Kb (Cable)

= 128 Kb (Dual ISDN)

= 56 kb (ISP Modem)

= 33 kb (Fast Modem)

= 24 kb (Slow Modem)

Note that these settings are an optimization for specific conditions
rather than an exact speed. The client and server always attempt to
deliver video as quickly as possible on the network regardless of the
current network speed and encoding setting. But the system will be
most responsive when the settings match the real world environment.

Choose the Color Depth from the drop-down list. The device can
dynamically adapt the color depth transmitted to remote users in
order to maximize usability in all bandwidths.

= 15-bit RGB Color
= 8-bit RGB Color

= 4-hit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so on), the full 24-bit or 32-bit color spectrum
made available by most modern video graphics cards is not
necessary. Attempting to transmit such high color depths wastes
network bandwidth.

Use the slider to select the desired level of Smoothing (15-bit color
mode only). The level of smoothing determines how aggressively to
blend screen regions with small color variation into a single smooth
color. Smoothing improves the appearance of target video by
reducing displayed video noise.

Click OK to set these properties.
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Connection Information

To obtain information about your Virtual KVM Client
connection:

Choose Connection > Connection Info. The Connection Info window
opens.

The following information is displayed about the current connection:

Device Name - The name of the device.
IP Address - The IP address of the device.

Port - The KVM communication TCP/IP port used to access the
target device.

Data In/Second - Data rate in.

Data Out/Second - Data rate out.

Connect Time - The duration of the connect time.

FPS - The frames per second transmitted for video.
Horizontal Resolution - The screen resolution horizontally.
Vertical Resolution - The screen resolution vertically.
Refresh Rate - How often the screen is refreshed.
Protocol Version - RFB Protocol version.

To copy this information:

Click Copy to Clipboard. The information is available to be pasted
into the program of your choice.

Keyboard Options

Keyboard Macros

Keyboard macros ensure that keystroke combinations intended for the
target server are sent to and interpreted only by the target server.
Otherwise, they might be interpreted by the computer on which the
Virtual KVM Client is running (your client PC).

Macros are stored on the client PC and are PC-specific. Therefore, if you
use another PC, you will not see your macros. In addition, if another
person uses your PC and logs in under a different name, that user will
see your macros since they are computer-wide.

Keyboard macros created in the Virtual KVM Client are available in MPC
and vice versa. However, keyboard macros created in AKC cannot be
used in VKC or MPC, and vice versa.

=i=Raritan.
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Building a Keyboard Macro

» To build a macro:

1. Click Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

2. Click Add. The Add Keyboard Macro dialog appears.

3. Type a name for the macro in the Keyboard Macro Name field. This
name will appear in the Keyboard menu after it is created.

4. From the Hot-Key Combination field, select a keyboard combination
from the drop-down list. This allows you to execute the macro with a
predefined keystroke. Optional

5. Inthe Keys to Press drop-down list, select each key you would like to
use to emulate the keystrokes that will be used to perform the
command. Select the keys in the order by which they are to be
pressed. After each selection, select Add Key. As each key is
selected, it will appear in the Macro Sequence field and a Release
Key command will automatically be added after each selection.

6. To use the Send Text to Target function for the macro, click the
Construct Macro from Text button.

7. For example, create a macro to close a window by selecting Left Ctrl
+ Esc. This will appear in the Macro Sequence box as follows:

Press Left Ctrl
Release Left Ctrl
Press Esc
Release Esc

8. Review the Macro Sequence field to be sure the macro sequence is
defined correctly.

a. Toremove a step in the sequence, select it and click Remove.

b. To change the order of steps in the sequence, click the step and
then click the up or down arrow buttons to reorder them as
needed.

9. Click OK to save the macro. Click Clear to clear all field and start
over. When you click OK, the Keyboard Macros dialog appears and
lists the new keyboard macro.
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10. Click Close to close the Keyboard Macros dialog. The macro will now
appear on the Keyboard menu in the application. Select the new
macro on the menu to run it or use the keystrokes you assigned to
the macro.

Keyboard Macros [$_<|

¥ Vihrede 1=
Mimmize All Windows Foun Macro

j

Add

Rermoue

Maodify

Cloze

1]

Selact a macro from the above list,

Running a Keyboard Macro

Once you have created a keyboard macro, execute it using the keyboard
macro you assigned to it or by choosing it from the Keyboard menu.

Run a Macro from the Menu Bar

When you create a macro, it appears under the Keyboard menu.
Execute the keyboard macro by clicking on it in the Keyboard menu.

Run a Macro Using a Keyboard Combination

If you assigned a keyboard combination to a macro when building it, you
can execute the macro by pressing its assigned keystrokes. For
example, press the keys Ctrl+Alt+0 simultaneously to minimize all
windows on a Windows target server.

Modifying and Removing Keyboard Macros

» To modify a macro:

Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Choose the macro from among those listed.
Click Modify. The Add/Edit Macro dialog appears.
Make your changes.

Click OK.

ok @D

=i=Raritan.



i

Connecktion 153 Profile

Chapter 2: Virtual KVM Client (VKC)

» To remove a macro:

1. Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Choose the macro from among those listed.

3. Click Remove. The macro is deleted.

Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro, used to reboot the
target computer, has been preprogrammed. Clicking on the

e
Ctrl+Alt+Delete button in the toolbar sends this key sequence to the
server or to the KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the
command would first be intercepted by your own PC due to the structure
of the Windows operating system, instead of sending the key sequence
to the target server as intended.

Note: VKC for the KX 11-101 uses an icon set that differs from the icon
set used in VKC for other Dominion KX products. See VKC Toolbar for
the KX 11-101 (on page 5) for additional information.

Setting CIM Keyboard/Mouse Options

» To access the DCIM-USBG2 setup menu:

Put the mouse focus on a window such as Note Pad (Windows®) or
an equivalent.

2. Press Left-Control and Num Lock simultaneously. The CIM setup
menu will appear in the active window.

Set the language and mouse settings.

4. Exit the menu to return to normal CIM functionality.

Santa M Wideo  Mouse  Tools  wiew  Wirkual Media  Help

= = o Send Chl4+-Al-Del
;" % 'E' E-‘E Se: CIM EevbaardMauss Ophons

Raritan.

Irmoark Keyboard Macros. .,
Exoort Eeyvboard Macros, .,

Keyboard Macros, .,

Minimize &l Windows ka4

11
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Video Properties

Refresh Screen

The Refresh Screen command forces a refresh of the video screen.
Video settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-sense Video Settings command automatically detects the
target server's video settings.

e The Calibrate Color command calibrates the video to enhance the
colors being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.

Note: VKC for the KX 11-101 uses an icon set that differs from the icon
set used in VKC for other Dominion KX products. See VKC Toolbar for
the KX 11-101 (on page 5) for additional information.

P To refresh the video settings, do one of the following:
e Choose Video > Refresh Screen or click the Refresh Screen button

ﬁ in the toolbar.

Auto-Sense Video Settings

The Auto-sense Video Settings command forces a re-sensing of the
video settings (resolution, refresh rate) and redraws the video screen.

Note: VKC for the KX 11-101 uses an icon set that differs from the icon
set used in VKC for other Dominion KX products. See VKC Toolbar for
the KX 1I-101 (on page 5) for additional information.

» To automatically detect the video settings, do the following:
e Choose Video > Auto-sense Video Settings or click the Auto-Sense

Video Settings button in the toolbar. A message stating that the
auto adjustment is in progress appears.
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Calibrating Color

Use the Calibrate Color command to optimize the color levels (hue,
brightness, saturation) of the transmitted video images. The color
settings are on a target server-basis.

Note: The Calibrate Color command applies to the current connection

only.

Note: The KX 11-101 does support color calibration.

P To calibrate the color, do the following:
e Choose Video > Calibrate Color or click the Calibrate Color button

IEI in the toolbar. The target device screen updates its color
calibration.

Adjusting Video Settings

Use the Video Settings command to manually adjust the video settings.

» To change the video settings:

1. Choose Video > Video Settings or click the Video Settings button

-7

in the toolbar to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings
the effects are immediately visible:

a. Noise Filter

bl )]

> @

The device can filter out the electrical interference of video output
from graphics cards. This feature optimizes picture quality and
reduces bandwidth. Higher settings transmit variant pixels only if
a large color variation exists in comparison to the neighboring
pixels. However, setting the threshold too high can result in the
unintentional filtering of desired screen changes.

Lower settings transmit most pixel changes. Setting this
threshold too low can result in higher bandwidth use.

Brightness: Use this setting to adjust the brightness of the target
server display.

Brightness Red - Controls the brightness of the target server
display for the red signal.

Brightness Green - Controls the brightness of the green signal.
Brightness Blue - Controls the brightness of the blue signal.
Contrast Red - Controls the red signal contrast.

Contrast Green - Controls the green signal.

Contrast Blue - Controls the blue signal.

13
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If the video image looks extremely blurry or unfocused, the
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the Clock and Phase
settings. Doing so may result in lost or distorted video and you may
not be able to return to the previous state. Contact Raritan Technical
Support before making any changes.

i. Clock - Controls how quickly video pixels are displayed across
the video screen. Changes made to clock settings cause the
video image to stretch or shrink horizontally. Odd number
settings are recommended. Under most circumstances this
setting should not be changed because the autodetect is usually
quite accurate.

j-  Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

k. Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor.

I.  Vertical Offset - Controls the vertical positioning of the target
server display on your monitor.

3. Select Auto Color Calibration to enable this feature.
4. Select the video sensing mode:
= Best possible video mode

The device will perform the full Auto Sense process when
switching targets or target resolutions. Selecting this option
calibrates the video for the best image quality.

= Quick sense video mode

With this option, the device will use a quick video Auto Sense in
order to show the target's video sooner. This option is especially
useful for entering a target server's BIOS configuration right after
a reboot.

5. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.

1 =i=Raritan.
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Note: Some Sun background screens, such as screens with very dark

borders, may not center precisely on certain Sun servers. Use a different

background or place a lighter colored icon in the upper left corner of the

screen.

Moise Filter
Brighthess Red
Brightniess Green
Brightness Blue
Cantrast Red
Contrast Green
ContrastBlue
Clock

Phaso

Haorizontal Offzet

Yerical Offset

< ' ?
£ | >
s ' 2
S | *
S L
& A -
5 [ -
L5 ' %
£ L
5 b
< 4

Iv ifuto Colar Calibration:

* Best possible video mode

" Quick sense video mode

Ok | Cancel | Al

2
45
B1
46

192
196
194
1008
10
14
23

Note: VKC for the KX 11-101 uses an icon set that differs from the icon

set used in VKC for other Dominion KX products. See VKC Toolbar for

the KX 11-101 (on page 5) for additional information.
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Using Screenshot from Target

You are able to take a screenshot of a target server using the
Screenshot from Target server command. You can then save this
screenshot to a file location of your choosing as a bitmap, JPEG or PNG
file.

Note: The Screenshot from Target function is not available for the KX II-
101.

P To take a screenshot of the target server:
Select Video > Screenshot from Target or click the Screenshot from
0.
Target button Eﬁ‘ on the toolbar.

2. Inthe Save dialog, choose the location to save the file, name the file,
and select a file format from the 'Files of type' drop-down.

3. Click Save to save the screenshot.

Save in: | My Downloads H |I}j| |ﬁ| ||j| E:E: E:

|j Mizcellaneous

B HTMLEbackground.jpg

File narme: Servar Screensh-:utl

Files of type: [JPEG image files -

| Save || Cancel |
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Changing the Maximum Refresh Rate

If the video card you are using on the target uses custom software and
you are accessing the target through MPC or VKC, you may need to
change the maximum refresh rate of the monitor in order for the refresh
rate to take affect on the target.

» To adjust the monitor refresh rate:

1. In Windows®, select Display Properties > Settings > Advanced to
open the Plug and Play dialog.

2. Click on the Monitor tab.
Set the 'Screen refresh rate' to any rate above 100Hz.

Click OK and then OK again to apply the setting.

Mouse Options

i

Raritan.

When controlling a target server, the Remote Console displays two
mouse cursors: one belonging to your client workstation and the other
belonging to the target server.

You can operate in either single mouse mode or dual mouse mode.
When in dual mouse mode, and provided the option is properly
configured, the mouse cursors will align.

When there are two mouse cursors, the device offers several mouse
modes:

e Absolute (Mouse Synchronization)
¢ Intelligent (Mouse Mode)
e Standard (Mouse Mode)

17
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Mouse Pointer Synchronization

When remotely viewing a target server that uses a mouse, you will see
two mouse cursors: one belonging to your remote client workstation and
the other belonging to the target server. When the mouse pointer lies
within the Virtual KVM Client target server window, mouse movements
and clicks are directly transmitted to the connected target server. While
in motion, the client mouse pointer slightly leads the target mouse pointer
due to mouse acceleration settings.

On fast LAN connections, you may want to disable the Virtual KVM
Client mouse pointer and view only the target server's pointer. You can
toggle between these two modes (single mouse and dual mouse).

Note: VKC for the KX 11-101 uses an icon set that differs from the icon
set used in VKC for other Dominion KX products. See VKC Toolbar for
the KX 1I-101 (on page 5) for additional information.

Mouse Synchronization Tips
Be sure to follow these steps when configuring mouse synchronization:

1. Verify that the selected video resolution and refresh rate are among
those supported by the device. The Virtual KVM Client Connection
Info dialog displays the actual values that the device is seeing.

2. Verify that the cable length is within the specified limits for the
selected video resolution.

3. Verify that the mouse and video have been properly configured
during the installation process.

4. Force an auto-sense by clicking the Virtual KVM Client auto-sense
button.

5. If that does not improve the mouse synchronization (for Linux, UNIX,
and Solaris KVM target servers):

a. Open a terminal window.
b. Enter the xset mouse 1 1 command.

c. Close the terminal window.

6. Click the "Virtual KVM Client mouse synchronization™ button ”}

=i=Raritan.
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Additional Notes for Intelligent Mouse Mode

e Be sure that there are no icons or applications in the upper left
section of the screen since that is where the synchronization routine
takes place.

¢ Do not use an animated mouse.
e Disable active desktop on KVM target servers.
Synchronize Mouse

In dual mouse mode, the Synchronize Mouse command forces
realignment of the target server mouse pointer with Virtual KVM Client
mouse pointer.

» To synchronize the mouse, do one of the following:
e Choose Mouse > Synchronize Mouse or click the Synchronize

Mouse button ”} in the toolbar.

Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization
algorithm using relative mouse positions. Standard Mouse mode requires
that mouse acceleration is disabled and other mouse parameters are set
correctly in order for the client and server mouse to stay synchronized.
Standard Mouse mode is the default.

» To enter Standard Mouse mode:
e Choose Mouse > Standard.

19
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Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing mouse
acceleration on the target. In this mode, the mouse cursor does a
“dance” in the top left corner of the screen and calculates the
acceleration. For this mode to work properly, certain conditions must be
met.

» To enter intelligent mouse mode:
e Choose Mouse > Intelligent.

Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the
Mouse menu, automatically synchronizes mouse cursors during
moments of inactivity. For this to work properly, however, the following
conditions must be met:

e The active desktop should be disabled on the target.
¢ No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of
the target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e Advanced mouse properties such as “Enhanced pointer precision” or
“Snap mouse to default button in dialogs” should be disabled.

e Choose “Best Possible Video Mode” in the Video Settings window.

e The edges of the target video should be clearly visible (that is, a
black border should be visible between the target desktop and the
remote KVM console window when you scroll to an edge of the
target video image).

e When using the intelligent mouse synchronization function, having a
file icon or folder icon located in the upper left corner of your desktop
may cause the function not to work properly. To be sure to avoid any
problems with this function, Raritan recommends you do not have file
icons or folder icons in the upper left corner of your desktop.

After autosensing the target video, manually initiate mouse
synchronization by clicking the Synchronize Mouse button on the toolbar.
This also applies when the resolution of the target changes if the mouse
cursors start to desync from each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.

=i=Raritan.
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Please note that mouse configurations will vary on different target
operating systems. Consult your OS guidelines for further details. Also
note that intelligent mouse synchronization does not work with UNIX
targets.

Absolute Mouse Mode

In this mode, absolute coordinates are used to keep the client and target
cursors in sync, even when the target mouse is set to a different
acceleration or speed. This mode is supported on servers with USB
ports.

» To enter absolute mouse mode:
e Choose Mouse > Absolute.

Note: The absolute mouse setting requires a USB target system and is
the recommended mouse setting for KX 11-101.

Note: Absolute Mouse Synchronization is available for use with the
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB)
only.

Single Mouse Cursor

Single Mouse mode uses only the target server mouse cursor and the
local mouse pointer no longer appears onscreen. While in single mouse
mode, the Synchronize Mouse command is not available (there is no
need to synchronize a single mouse cursor).

Note: VKC for the KX 11-101 uses an icon set that differs from the icon
set used in VKC for other Dominion KX products. See VKC Toolbar for
the KX 11-101 (on page 5) for additional information.

P To enter single mouse mode, do the following:
1. Choose Mouse > Single Mouse Cursor.
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2. Click the Single/Double Mouse Cursor button h in the toolbar.

. Single Cursor Mode

You are about to enter Single Cursor mode. While you are in this mode,
this software will have exclusive comtrol over the mouse and Keyboaril.
To exit Single Cursor mode you must press:

Ctri+Alt+0

I iScale the video {no scroll bars):

> To exit single mouse mode:
1. Press Ctrl+Alt+O on your keyboard to exit single mouse mode.

==
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Smart Cards (VKC and MPC)

i

Raritan.

Using the KX 11 2.1.10 or later, you are able to mount a smart card reader
onto a target server to support smart card authentication and related
applications.

Note: AKC does not support smart cards.

When accessing a server remotely, you will have the opportunity to
select an attached smart card reader and mount it onto the server. Smart
card authentication is used with the target server, it is not used to log into
the device. Therefore, changes to smart card PIN and credentials do not
require updates to device accounts. When mounted onto the target
server, the card reader and smart card will cause the server to behave
as if they had been directly attached. Removal of the smart card or smart
card reader will cause the user session to be locked or you will be logged
out depending on how the card removal policy has been setup on the
target server OS. When the KVM session is terminated, either because it
has been closed or because you switch to a new target, the smart card
reader will be automatically unmounted from the target server.

When PC-Share mode is enabled on the device, multiple users can
share access to a target server. However, when a smart card reader is
connected to a target, the device will enforce privacy regardless of the
PC-Share mode setting. In addition, if you join a shared session on a
target server, the smart card reader mounting will be disabled until
exclusive access to the target server becomes available.

After a KVM session is established to the target server, a Smart Card
menu and button are available in the Virtual KVM Client and Multi-
Platform Client. Once the menu is opened or the Smart Card button is
selected, the smart card readers that have been detected as attached to
the remote client are displayed. From this dialog you can attach
additional smart card readers, refresh the list of smart card readers
attached to the target, and detach smart card readers. You are also able
to remove or reinsert a smart card. This function can be used to provide
notification to a target server OS that requires a removal/reinsertion in
order to display the appropriate login dialog. Using this function allows
the notification to be sent to a single target without affecting other active
KVM sessions.

» To mount a smart card reader:
1. Click the Smart Card menu and then select Smart Card Reader.

Alternatively, click the Smart Card button \* in the toolbar.

2. Select the smart card reader from the Select Smart Card Reader
dialog.

3. Click Mount.
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4. A progress dialog will the open. Check the 'Mount selected card
reader automatically on connection to targets' checkbox to mount the
smart card reader automatically the next time you connect to a
target. Click OK to begin the mounting process.

» To update the smart card in the Select Smart Card Reader
dialog:

e Click Refresh List if a new smart card reader has been attached to
the client PC.

» To send smart card remove and reinsert notifications to the
target:

e Select the smart card reader that is currently mounted and click the
Remove/Reinsert button.

» To unmount a smart card reader:

e Select the smart card reader to be unmounted and click the Unmount
button.

E8 pominion-kX2_Port3 - Virtual KYM Client
Connection  LSE Profile Video Mouse Tooks View Virtual Media ard  Help

=lolx]

o 5 ] o [ e |

Select Card Reader

Card Reader Currently Mounted

i

Connecting & Card Re ader limits Victual Media bo one Mass Storage
A m:mmwmmummmmmnbmm Card Reader.

Mount, ., [ Feefresh List l Remove Reinsert Card I Ur-Haunk
disart| 3 @ o ‘.'|.J','-§=_'§ 12:59PM
| Dok Mouse tade -2 [wum[zaes Tacr
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Tool Options

i

Raritan.

From the Tools menu, you can specify certain options for use with the
Virtual KVM Client, including logging, setting the keyboard type, and
defining hot keys for exiting Full Screen mode and Single Cursor mode.

P To set the tools options:
1. Choose Tools > Options. The Options dialog appears.

2. Select the Enable Logging checkbox only if directed to by Technical
Support. This option creates a log file in your home directory.

3. Choose the Keyboard Type from the drop-down list (if necessary).
The options include:

= US/International

= French (France)

=  German (Germany)

= Japanese

= United Kingdom

= Korean (Korea)

= Belgian (Belgium)

= Norwegian (Norway)
= Portuguese (Portugal)
= Danish (Denmark)

= Swedish (Sweden)

= German (Switzerland)
= Hungarian (Hungary)
= Spanish (Spain)

= Jtalian (Italy)

= Slovenian

= Translation: French - US

= Translation: French - US International

Note: In AKC, the keyboard type defaults to the local client, so this
option does not apply.

4. Exit Full Screen Mode - Hotkey. When you enter Full Screen mode,
the display of the target server becomes full screen and acquires the
same resolution as the target server. This is the hot key used for
exiting this mode.
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Note: The Exit Full Screen Hotkey is not applicable in AKC. In AKC

an Exit Full Screen Mode icon j_E is displayed instead when you
move the mouse to the top of screen.

5. Exit Single Cursor Mode - Hotkey. When you enter single cursor
mode, only the target server mouse cursor is visible. This is the hot
key used to exit single cursor mode and bring back the client mouse
cursor. Click OK.

Keyboard Limitations
Slovenian Keyboards

The < key does not work on Slovenian keyboards due to a JRE
limitation.

Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key
Events for foreign-language keyboards configured using System
Preferences, Raritan recommends that you configure foreign keyboards
using the methods described in the following table.

Language Configuration method

uUs Intl Default

French Keyboard Indicator

German System Settings (Control Center)
Japanese System Settings (Control Center)
UK System Settings (Control Center)
Korean System Settings (Control Center)
Belgian Keyboard Indicator

Norwegian Keyboard Indicator

Danish Keyboard Indicator

Swedish Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Italian System Settings (Control Center)
Slovenian System Settings (Control Center)

Portuguese System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using
Gnome as a desktop environment.
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View Options
View Toolbar
You can use the Virtual KVM client with or without the toolbar display.
> To toggle the display of the toolbar (on and off):
e Choose View > View Toolbar.
Scaling
Scaling your target window allows you to view the entire contents of the
target server window. This feature increases or reduces the size of the
target video to fit the Virtual KVM Client window size, and maintains the
aspect ratio so that you see the entire target server desktop without
using the scroll bar.
P Totoggle scaling (on and off):
e Choose View > Scaling.
Target Screen Resolution
When you enter Full Screen mode, the display of the target server
becomes full screen and acquires the same resolution as the target
server. The hot key used for exiting this mode is specified in the Options
dialog (the default is Ctrl+Alt+M).
» To enter full screen mode:
e Choose View > Full Screen.
P To exit full screen mode:
e Press the hot key configured in the Tools Options dialog. The default

is Ctrl+Alt+M. AKC click the Exit Full Screen mode icon.
Help Options

i
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About Raritan Virtual KVM Client

This menu command provides version information about the Virtual KVM
Client, in case you require assistance from Raritan Technical Support.

» To obtain version information:
1. Choose Help > About Raritan Virtual KVM Client.

2. Use the Copy to Clipboard button to copy the information contained
in the dialog to a clipboard file so it can be accessed later when
dealing with support (if needed).
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Active KVM Client (AKC)

In This Chapter

OVBIVIEW ...ttt ettt ettt e et e e ettt e e et e e e e bt e e e neeas 28
Prerequisites for USINg AKC .......coiiiiiiiiiiie e 29
AKC Supported Operating Systems and Browsers..........cccccveeeeeeeivvnneen. 30

Overview
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The Microsoft Windows .NET-based Active KVM Client (AKC) is
available with the KX II 2.2 (or later) and supports all KX 1l models,
although the KX2-101 and KSX2 models are not currently supported.
AKC is based on Microsoft Windows .NET technology and allows users
to run the client in Windows environments without the use of the Java
Runtime Environment (JRE), which is required to run Raritan's Virtual
KVM and Multi-Platform clients. AKC also works with CC-SG.

AKC and VKC share similar features with the exception of the following:

e Minimum system requirements

e Supported operating systems and browsers

e Smart cards are not supported in AKC

e Managing favorites is not supported in AKC

e Keyboard macros created in AKC cannot be used in VKC.

See the Virtual KVM Client (VKC) (on page 3)section for information on
using these features. If there is a difference between how AKC functions
as compared to VKC, it is noted in the topic.

Also see Direct Port Access Overview and Enable AKC Download
Server Certificate Validation Overview in the Dominion KX Il User
Guide for configuration information on using AKC.

Note: If you are using direct port access with AKC, you must open a new
browser window or browser tab for each target you want to access. If you
try to access another target by entering the DPA URL into the same
browser window or browser tab you are currently accessing a target
from, you will not be able to connect and may receive an error.
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Prerequisites for Using AKC

i

Raritan.

In order to use AKC:

Ensure the cookies from the IP address of the device that is being
accessed are not currently being blocked.

Windows Vista, Windows 7 and Windows 2008 server users should

ensure that the IP address of the device being accessed is included

in their browser's Trusted Sites Zone and that Protected Mode is not
on when accessing the device.

Alternatively, if the KX Il (or CC-SG) administrator has enabled the
Enable AKC Download Server Certificate Validation option:

Administrators must upload a self-signed certificate to the KX Il or
generate a self-signed certificate on the KX II. The self-signed
certificate must have a valid host designation.

Each user must add the self-signed certificate to their browser's
Trusted Root CA store.

When launching AKC from the CC-SG Admin Client, you must have JRE
1.6.0_10 or above.
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AKC Supported Operating Systems and Browsers

.NET Framework

AKC requires Windows .NET® version 3.5, and will work with both 3.5
and 4.0 installed.

Operating Systems

When launched from Internet Explorer or as a standalone application,
AKC allows you to reach target servers via the KX Il 2.2 (or later). AKC is
compatible with the following platforms running Microsoft .NET
Framework 3.5:

e Windows XP® operating system
¢ Windows Vista® operating system
e Windows 7° operating system

Since .NET is required to run AKC, if you do not have .NET installed or
you have an unsupported version of .NET installed, you will receive a
message instructing you to check the .NET version.

Browser
e Internet Explorer 6 or later
If you attempt to open AKC from a browser other than IE 6 or later, you

will receive an error message instructing you to check your browser and
to switch to Internet Explorer.



Chapter 4

Multi-Platform Client and Raritan
Remote Client

Raritan Multi-Platform Client (MPC) and Raritan Remote Console are
graphical user interfaces for the Raritan product lines, providing remote
access to target servers connected to Raritan KVM over IP devices.
Non-Windows® users must use Raritan Multi-Platform Client and
Windows users running Internet Explorer must use Raritan Remote
Client.

In This Chapter

Requirements and Installation .............ocoveeoiiiiiiiii e 31
OPEIALION ..ttt 59
Administrative FUNCHIONS ........ccoiiiiiiiiiiicciecc e 133

Requirements and Installation
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MPC Requirements and Installation Instructions

Note to CC-SG Users

If you are using Dominion KX Il in a CC-SG configuration, do not use the
CC-SG proxy mode if you are also planning to use the Multi-Platform
Client (MPC).

MPC Minimum System Requirements

The minimum system requirements for the Multi-Platform Client are:

e CPU Speed: 1.0 GHz
e RAM: 512 Mbytes

Note: Running the client software on system configurations below either
of these specifications may impact performance and result in errors.
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MPC Supported Operating Systems and Browsers

Operating Systems

When launched as a web applet or as a standalone application, MPC
allows you to reach target servers via different Raritan Dominion devices
and IP Reach models.

Raritan MPC is compatible with the following platforms:
e Windows XP

e Windows 2000 SP4

e Windows Vista

e Red Hat Linux® 9.0

¢ Red Hat Enterprise Workstation 3.0 and 4.0

e SUSE Linux Professional 9.2 and 10

e Fedora Core 5 and above

e Mac®

e Solaris™

Note: If you are using a Mac 10.5, use Java 1.4.2.x in order to avoid
possible text length issues in the MPC interface. Specifically, IP
addresses in the MPC Navigator and menu text may be cut off if you are
not using Java 1.5.x with 10.5.

The JRE plug-in is available for the Windows 32-bit and 64-bit operating
systems. MPC and VKC can be launched only from a 32-bit browser, or
64-bit IE7 or IE8 browser.

Following are the Java 32-bit and 64-bit Windows operating system
requirements.

Mode Operating system Browser
Windows x64  Windows XP e IE6.0SP1+o0r7.0,IE8
32-bit mode

e Mozillal.4.Xor 1.7+
e Netscape 7.X
e Firefox 1.06 - 3



Mode

Windows x64
64-bit mode
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Operating system
Windows Server 2003

Windows Vista

Windows 7

Windows XP

Windows XP
Professional

Windows XP Tablet
Windows Vista
Windows Server 2003
Windows Server 2008
Windows 7

Browser

IE 6.0 SP1++,IE7,IE 8
Mozilla 1.4.X or 1.7+
Netscape 7.X

Firefox 1.06 - 3
IE7.00r8.0

IE7.00r8.0
Firefox 1.06 - 3

64bit OS, 32bit browsers:

IE 6.0 SP1+, 7.0 or 8.0
Mozilla 1.4.X or 1.7+
Netscape 7.X

Firefox 1.06 - 3

64bit mode, 64bit browsers:

IE7.00r 8.0
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Browsers
MPC supports the following browsers:

e Internet Explorer 6, 7 and 8

e Firefox® 1.5, 2.0 and 3.0 (up to build 3.0.10)
e Mozilla® 1.7

e Safari 2.0

Note: If you are using IE 7, you may run into permission issues when
trying to connect to a target server. To avoid this, do the following:

1. In IE7, click Tools > Internet Options to open the Internet Options
dialog.

2. In the "Temporary Internet files" section, click the Settings button. The
Settings dialog opens.

3. In the "Check for newer versions of stored pages" section, select
Automatically.

4. Click OK to apply the settings.

Note: If you are using IE 8 to access MPC and do not have Java installed
on your machine, an alert bar or a dialog will open asking you to
download the latest version of Java. However, in some instances, only a
blank window will open and you will not be prompted to perform the
download. If this occurs, set IE 8 to use Compatibility View. See
Microsoft Internet Explorer help for information on change IE to this view.

Note to IPv6 Users

Due to a browser limitation, MPC cannot be downloaded via the KX IPv6
address from Mozilla 1.7 if Pop-up Manager is enabled. Do one of the
following to avoid this issue:

e Use the hostname of the device for the MPC browser download.

e Set Mozilla to not block Pop-up windows via edit\Preferences\Privacy
and Security.

e Use IPV4 address.
e Use standalone MPC.
e Use the latest version of Firefox.
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Special Characters in MPC

The following table identifies the special characters that can be used in

MPC:

Character
!

Description
Exclamation point

Double quote
Pound sign
Dollar sign
Percent sign
Ampersand
Single quote
Left parenthesis
Right parenthesis
Asterisk

Plus sign
Comma

Dash

Period

Forward slash

Less than sign

Invalid MPC Username Characters

Character

Description
Colon

Semi-colon
Equal sign
Greater than sign
Question mark
At sign

Left bracket
Backward slash
Right bracket
Caret
Underscore
Grave accent
Left brace

Pipe sign

Right brace
Tilde

The following characters cannot be used in usernames for MPC.

Character

Description
Colon

Double quote
Ampersand

Single quote
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Installing and Opening Standalone MPC

Raritan recommends that you open only one standalone MPC session at
a time. Opening more than one standalone MPC session on the same
client at the same time may cause performance problems and system
errors.

Important: MPC modem connectivity is supported on Windows®.
When working in Windows, use Standalone MPC.

You must have the MPC JAR file to install MPC for any of these
operating systems.

» To check for the MPC JAR file:

1. Download the installation file, MPC-installer.jar from the Raritan
website (www.raritan.com) on the Support > Firmware and
Documentation page.

2. Locate the Dominion product you are working with and click the
Standalone Multi-Platform Client link.

3. If copying MPC-installer.jar from a known location, double-click the
file to start installation.

Windows

> To check the JRE version in Windows:
1. Do one of the following to check the JRE version in Windows:

= Determine your version of the JRE from the Java website:
http://www.java.com/en/download/help/testvm.xml.

= Click the Windows Start button at the bottom left of your page
and click Control Panel.

Tip: In the upper left corner of the page, you may see a panel named
Control Panel with the option Switch to Classic View or Switch to
Category View. For easier viewing, opt for Classic View.

a. Search the Control Panel files for a Java icon. When you locate
the Java icon, double-click it to open the Java Control panel.
Click the General tab and then click the About button to check
the current Java Runtime Environment (JRE).

b. If the JRE is version 1.5 or later, proceed with the MPC
Installation. If the Java icon does not exist in the Control Panel or
if the JRE version is prior to 1.5, go to the Sun Microsystems
website at http://java.sun.com/products/ to download the latest
version of JRE.

2. For future Java access and to automatically open it, set your path to
the Java executable.
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B Select the installation path:
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a. Right-click the My Computer icon on your desktop and click
Properties.
b. Click the Advanced tab and then click "Environment variables".

c. Edit the Path address so that it contains the path to the Java
executable.
For example, if Java is installed on C:\j2re1.5 and your path is
currently set to C:\WINDOWS\SYSTEM32, then change the path
to read C:\WINDOWS\SYSTEMS32;C:\j2rel.5

To install MPC for Windows:

Download the MPC-installer.jar installation file or copy the file from a
known location.

Double-click the jar file icon to open the installation dialog.

After the initial dialog appears, click Next.

IC:\Program Files\RaritanRaritan Mutti-Plat form Clientd 401 7 B Browse... |

[Made with IzPack - http: itaevewe izforge comf)

QPrevious | QNext I @Qu'rt |

4. Choose the directory where you want to install MPC and click Next.

Click Browse to locate a non-default directory.

Note: If you are using Windows 7, when User Access Control is
turned on, you will need to manually create a folder to contain the
MPC files. You will also need to assign the Admin user, at a
minimum, Write permissions to the folder from Properties dialog >
Security tab. Alternatively, you can turn off User Access Control.
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5.

6.

Click Next.

IzPack - Installation of Raritan Multi-Platform Clienkt

Accessaties
AuthorlT Y

|&xialis Software
CC Application

Fearitanfaritan bMuti-Platform Clientid 4017 z

In the Shortcut dialog, choose a shortcut location, determine who
should have the shortcut, and determine whether you want the
shortcut on the desktop. When finished, click Next.

==Raritan.
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Once the installation is complete, the final dialog indicates where you
will find an uninstaller program and provides an option for generating
an automatic installation script. Click Done to close the Installation
dialog.

88 1zPack - Installation of Raritan Multi-Platform Client B o ]

G Installation has completed successfully.

6 An uninstaller program has been created in:
CHProgram Files\RaritanRaritan Multi-Platform Client'd 401 T Uninstaller

: Generste an automstic installation script

[Made with IzPack - http: iteeese izforge comd)

» To open MPC in Windows:

Click the Windows Start menu and then choose All Programs >
Raritan Multi-Platform Client. Alternatively, double-click the MPC
desktop shortcut icon if you created one.

2. Double-click the desired device in the Navigator to establish a
connection.

3. Type your user name and password in the device dialog and then
click OK to log on.

Linux

Raritan recommends using Java® Runtime Environment (JRE) version
1.5 for optimum performance but MPC will function with JRE version
1.4.2_05 or greater (with the exception of JRE 1.5.0_02). JRE 1.6 is also
supported but has not been fully tested.

Determine your version of the JRE from the Java website:
http://www.java.com/en/download/help/testvm.xml.

You may need some configuration depending on your OS and browser.
Configuration instructions are provided with the JRE download.

Important: When launching MPC from a browser, it is highly
recommended that you disable the Java Applet caching.
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Although no actual problems have occurred when Java caching is turned
on, some non-impacting Java exceptions have occurred. Generation of
these Java-exceptions can appear in the Java Applet Console window
and may degrade performance.

For Linux/UNIX environments, the Java Control Panel is located in the
JRE's bin directory; the location varies based on where JRE was
installed by your Linux/UNIX administrator.

Tip: It is also recommended that you clear the Java cache.

> To disable Java caching and clear the cache (use these steps
with Microsoft Windows XP and JRE 1.5.0):

1. From the Start menu, click Control Panel.

2. Double-click on the Java icon to launch it. The Java Control Panel
dialog appears.

‘. Java Control Panel 10} x|

i abouk

Wiew version infarmation abouk Java Contral Panel,

About... |

. Mebwark Settings

Mebwork settings are used when making Inkernet conneckions, By defaulk, Java
will use the network settings in your web browser, Cnly advanced users should
modify these settings.

Metwork Setkings. ..

— Temporary Internet Files

Files you use in Java applications are stored in a special Folder For quick execution
later. Only advanced users should delete files or modify these settings,

Delete Files. .. | Settings. .. |

ITI Cancel | Apply |

3. To disable Java caching:

==
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a. From the General tab, click the Settings button. The Temporary
Files Settings dialog appears.

Temporary Files Settings ]

Delete Files. ., |

X

Wiew Applications. .. | Wiew Spplets,

—Setkings

Location:

armounk of disk,
space ko use:

Jar compression:

Iiu:un DatalSumJavalDeploymenticache . Change... I

£+ Unlimited
£ Maxirum |

o =]

K I I | I I | I I

I
High

(0] 4 Cancel

b. Click the View Applets button. The Java Applet Cache Viewer

opens.
£ Java Applet Cache Yiewer =1a =l
File Options Help
Mame Type Size Expiration Date Last Modified Wersion | URL
rclang_en.jar-1d68d502-222771... | Jar GKE 12/31/69 07:00 PM| 11/29/06 02:20 PM| M/& https:f192.168.61. 180/ rclang_en.jar ;I
rclang_en.jar-63ebSffc-5e2az17, .. | Jar GKE 1213169 07:00 PM| 12/21/06 02:35 PM| M/& https:f{192,1658.59, 45 rclang_sn.jar
rclang_en.jar-68eb6070-5c7a7 4. .. | Jar GKE 12/31/69 07:00 PM| 11/29/06 02:20 PM| M/& https:f192,168.59,80(rclang_an.jar
sClientLib. jar-5444cded-7d6268, . | Jar SBSKE | 12/31/69 07:00 PM| 02/26/00 02:11 ... | WA https:/192.168.50,29/sClientLib, jar
sClientLib.jar-7036985-47b3645. .. | Jar SESKE | 12/31/69 07:00 PM|02/26/00 01:15 ... | M/A https:/192.168.50, 154/sClientLib. jar
sClientLib. jar-7824070-6f67F aae. .. | Jar 619KB | 12/31/69 O07:00 PM| 05/22/06 07:02 PM| N/A https:/192,168,59, 222/ sClientLib. jar
sFoxtrot.jar-1a581382-6259a44, ., | Jar S4KE 123169 07:00 PM| 10/09/06 12:12 PM| N/A http:{sdeweb.raritan.com/rele asesMulkiPlatFarr
sFoxbrot, jar-4662ffd-500bc4f9 . zip | Jar S4kE 1213169 07:00 PM| 02/26/00 01:15 ... |M/& https:f{192,1658.50, 154 sFoxtrot. jar
sFoxtrot.jar-4e50382-19cFF606. zip | Jar C4KE 12/31/69 07:00 PM| 01/29/07 01:57 PM| MNjA https:/{192.168.59, 150/sFoxtrot . jar
sFoxtrot. jar-4e506e8-75cd7bec., . | Jar S4KE 1231/69 07:00 PM| 0522006 07:03 PM| M/& https:fi192.165.59, 222 sFoxtrot. jar
sFoxtrot.jar-51a793dc-416bead. .. | Jar S4KE 12/31/69 07:00 PM| 02/26/00 02:11 ... |N/A https:/192,168.50. 29)sFoxtrot. jar
sHM. jar-13984d35-5ce3ca3d zip | Jar Z1G9KE | 12/31/69 07:00 PM| 02/26/00 01:15 ... | M/A https: /{192, 168,50, 154/sHM . jar
sHM jar-14172423-331a8ac8.zip | Jar 2523KE | 12/31/69 07:00 PM| 05/22/06 07:03 PM| MjA https:/{192.168.59,222)sHM . jar
sHM,jar-60d9b117-6c86b984.2ip | Jar Z1G9KE | 12/31/69 07:00 PM| 02/26/00 02:11 ... | WA https:/192.168.50,23/sHM, jar
sMpc.jar-4Fc27F70-4Fc4306F Zip | Jar 3712KE | 12/31/69 07:00 PM| 01/29/07 01:57 PM| MNjA https:/{192.168.59, 150/sMpe.jar
sMpe.jar-799f6ef0-2c5cab18.zip | Jar 3161KE | 12/31/69 07:00 PM| 10/09/06 12:12 PM|M/A http:ffsdeweb,raritan,com/releasesMulkiPlatForr +
| 2
I Enatble Caching

Refresh | Delete | oK I

=i=Raritan.

c. Deselect the Enable Caching checkbox if it is already checked.
d. Click OK.

4. To clear the Java cache:

a. From the Temporary Files Settings dialog, click the Delete Files
button. The Delete Temporary Files dialog appears.
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b. Select the temporary files that you want to delete.

Delete Temporary Files | =

D ] ] Delete the Following kemparary files?
-

v Downloaded Applets
v Dowrnloaded applications

Zancel |

[+ Other Files

5. Click OK.

» To check the JRE version in Linux:
In a graphical environment, open a terminal dialog.

2. Type java version in the command line and press Enter on your
keyboard. The currently-installed version of Java Runtime
Environment (JRE) is displayed.

If your path variable is not set to where the java binaries have been
installed, you may not be able to see the JRE version.

3. Set your path:

a. To setyour path and assuming JRE 1.4.2_05 is installed in
lusr/local/java: you must set your PATH variable.

b. To set the path for bash shell, export
PATH=$PATH:/usr/localljava/j2rel.4.2_05/bin.

c. To set the path for tcsh or csh, set PATH = ($PATH
lusr/local/javal/j2rel.4.2_05/bin).

These commands can be typed at the terminal each time you login.
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for
csh, or tcsh so that each time you login the PATH is already set.

=i=Raritan.



Chapter 4: Multi-Platform Client and Raritan Remote Client

See your shell documentation if you encounter problems.

usrl@localhost:~

Eile Edit \ew Terminal Tabs Help

[usrl@localhost ~]§ java -version

java version "1.4.2_08"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)
Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)
[usrl@localhost ~]1% |:|

[2]

[<]

4. If the JRE is version 1.4.2_05 or higher, proceed with the MPC
installation. If the version is prior to 1.4.2_05, go to the Java website
at http://java.sun.com/products/ to download the latest Runtime
Environment.

» To install MPC for Linux:
You must have Administrative privileges to install MPC.
1. Download the MPC-installer.jar file or copy it from a known location.

2. Open a terminal dialog and open the directory where the installer is
saved.

3. Type java -jar MPC-installer.jar and press Enter to run the installer.

Raritan. 4

i




Chapter 4: Multi-Platform Client and Raritan Remote Client

4. After the initial page loads, click Next.

_V SzPack-insillation of RariEn AT T i

@ Select the installation path:

I.-'usr.n'local.n’Raritan.n’Raritan Multi-Platform Client/4 40.1.7 B Erowse... |

(Made with [zPack - http:f fvnes izforge.com

QPrevious |

5. Use the Browse function to select a directory to install MPC if the
directory is different from the default path displayed in the "Select the
installation path" field.

6. Click Next to open the Shortcut dialog.
7. On the Shortcut dialog:

= Choose a shortcut location from the "Select a Program Group for
the Shortcuts:" field.

= Select either "current user" or "all users" to define who should
have access to the shortcut.

= Check the "Create shortcut on the desktop" checkbox if you want
the shortcut to appear on the desktop.
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When finished, click Next.

elect a Program Group for the Shortcuts:

Raritan

create shartout far

(& current user

) all users

IRaritam’Raritan Multi-Platform Client/4.40.1.7 Reset I

¥ Create shortcut on the desktop

iMade with [zPack - http:d fvoww izforge.com®

() Previous |

=i=Raritan.

Note: Once MPC is installed successfully, a shortcut will be available
on the desktop. However, for Linux users, you will need to log off of
and then back into your session before the shortcut will be visible on

the desktop.

Once the installation is complete, the final page indicates where you
will find an uninstaller program and provides you with the option to

generate an automatic installation script.
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9.

_V SzPack-insillation of RariEn AT T i

Click Done to close the Installation dialog.

6 Installation has completed successfully.

@ An uninstaller program has been created in:
fusrflocalfRaritan/ Raritan Multi-Platfarm Client/4.40.1.7{Uninstaller

' Generate an automatic installation script

(Made with [zPack - http:f fvnes izforge.com

To open MPC in Linux:

Open a terminal window and change directories to the directory
where you installed MPC (default location: /usr/local/Raritan/Raritan
MPC/4.40.1.71).

Type ./start.sh and press Enter to open MPC.

Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

Solaris
To check the JRE version for Sun Solaris:

1.
2.

Launch a terminal window on the Sun Solaris desktop.

Type java version in the command line and press Enter. The
currently-installed version of Java Runtime Environment (JRE)
appears.

If your path variable is not set to where the java binaries have been
installed, you may not be able to see the JRE version.

a. To setyour path and assuming JRE 1.4.2_05 is installed in
lusr/local/java, you must set your PATH variable.

b. To set path for bash shell, export
PATH=$PATH:/usr/locall/java/j2rel.4.2_05/bin.

c. To set path for tcsh or csh, set PATH = ($PATH
lusr/local/java/j2rel.4.2_05/bin).

=i=Raritan.
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3. These commands can be typed at the terminal each time you login.
Alternatively, you can add it to your .bashrc for bash shell, .cshrc for
csh, or tcsh so that each time you login the PATH is already set. See

your shell documentation if you encounter problems.

Terminal

# java -version

java version "1.4.2_05"

Jawa(TM) 2 Runtime Environment, Standard Edition Chuild 1.4.2_05-b04)
Jawa HotSpot(THM) Client WM Cbuild 1.4.2_05-b04, nixed mode)

#

IE".._I

If the JRE is version 1.4.2_05 or higher, proceed with the MPC
installation. If the version is prior to 1.4.2_05, go to the Sun website
at http://java.sun.com/products/ to download the latest Runtime
Environment.

» To install MPC for Sun Solaris:

You must have administrative privileges to install MPC.

1.
2.

Open a terminal window and navigate to the directory where the
installer is saved.

Type java -jar MPC-installer.jar and press Enter to run the installer.

Download the MPC-installer.jar file or copy it from a known location.
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4. After the initial page loads, click Next.

IzFack — Installation of Raritan Multi-Platform Client

5. Use the Browse function to navigate to the directory you want to
install MPC or select the default directory displayed in the "Select the
installation path" field.

Click Next.
When installation is complete, click Next.
Click Next again.

Once the installation is complete, the final dialog will indicate where
you will find an uninstaller program and provides the option to
generate an automatic installation script.

* ==Raritan.
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9. Click Done to close the Installation dialog.

IzPack — Installation of Raritan Multi-Platform Client

To open MPC in Sun Solaris:

1. Open aterminal window and navigate to the directory where you
installed MPC (the default location is /usr/local/Raritan/Raritan
MPC/4.40.1.7).

Type ./start.sh and press Enter to open MPC.

Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

Macintosh

» To check JRE on Macintosh:
1. Launch a terminal window on the Macintosh desktop.

== Raritan. *
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2. Type the java version in the command line and press Enter. The
currently-installed version of the Java Runtime Environment (JRE) is

displayed.
r : ]
806 Terminal — sh — B0x24
Last login: Tue Mar 22 @9:64:25 on ttypl 5

Welcome to Darwin!

Raoritan-MIS-Computer :~ root# java -version

jowa version "1.4.2_BE"

Java(TM} 2 Runtime Envirorment, Stondord Edition (build 1.4.2_85-141.3)
Java HotSpot{TH} Client WM (build 1.4.2-38, mixed mode)
Raritan-MIS-Computer :~ root# I

4

3. |Ifthe JRE is version 1.4.2_05 or higher, proceed with the MPC
installation. If the version is prior to 1.4.2_05, go to the Apple website
to download the latest Runtime Environment.

» To install MPC on a Mac:
You must have administrative privileges to install MPC.
1. Download the MPC-installer.jar file or copy it from a known location.

2. Open a Finder window and locate the installer.

3. Double click the MPC-installer.jar file to run the installer.

=i=Raritan.
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4. After the initial dialog appears, click Next.

ra |en |1zPack - Installation of Raritan Multi-Platform Client

|4 Select the installation path:

.[I_,_f_.A_Rp_Iications_j Raritan/Raritan Multi-Platform Client_,f4.40.1.? ‘.

(Made with IzPack - http:/ /www.izforge.com/)

(Previous) (—Nﬂﬁw—) ( Quit )

5. Use the Browse function to select a directory to install MPC if the
directory is different from the default path displayed in the "Select the
installation path" field.

6. When installation is complete, click Next.

Once the installation is complete, the final dialog indicates where you
will find an uninstaller program and provides you with the option to
generate an automatic installation script.

7. Click Done to close the Installation dialog.
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@ Network
@ Macintosh HD
&~

ﬁ raritancompu..

=@ Applications

ﬁ Desktop

» To open MPC on a Mac:

1. Open a Finder window and navigate to the directory where you
installed MPC (the default location is /Applications/Raritan/Raritan

MPC/4.40.1.7).

|A Applications

Date Modified

= s
@ Internet Connect
ﬁ Internet Explorer
'#, iPhoto
& isync
J iTunes
B Mail
‘& Microsoft AutoUpdate
» [ Office 2004 for Mac Test Drive
ﬂ OmniGraffle
& omnioutliner
W Preview
» [ QuickBooks NUE &
€} QuickTime Player
v [J Raritan
v [ Raritan Multi-Platform Client
v [F 44017
2 Raritan Multi-Platform Client
» [ uninstaller

ST L, COUT, TIOU T T

Jan 27, 2005, 9:21 AM
Jun 3, 2003, 5:14 PM
Feb 11, 2005, 5:16 PM
Jun 16, 2004, 7:39 PM
May 19, 2005, 4:15 PM
Aug 14, 2003, 3:00 PM
Feb 11, 2005, 5:43 PM
Jan 19, 2005, 11:24 AM
Sep 1, 2004, 7:05 PM
Sep 1, 2004, 7:04 PM
Jan 27, 2005, 9:20 AM
Sep 1, 2004, 6:59 PM
May 25, 2005, 6:07 PM
Today, 3:31 PM
Today, 3:31 PM
Today, 3:31 PM
Today, 3:31 PM
Today, 3:31 PM

~ 1of40 selected, 63.43 GB available.

2. Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

"®O 0

I1zPack - Installation of Raritan Multi-Platform Client

6 Installation has completed successfully.

&# An uninstaller program has been created in:
fApplications /Raritan/Raritan Multi-Platform Client/4.40.1.7 /Uninstaller

(Generate an automatic installation script)

(Made with |zPack - http:/ /www.izforge.com/)
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3. Open a Finder window and navigate to the directory where you
installed MPC (the default location is /Applications/Raritan/Raritan
MPC/4.40.1.7).

[_j Applications

=
[Qr everywhere

| Date Modified

>
ﬁ Documents >
% Maovies v

@ Pictures }

JEQ L, U, 10U T
Jan 27, 2005, 9:21 AM
Jun 3, 2003, 5:14 PM

I -
@ Internet Connect
£ Internet Explorer

) iPhoto Feb 11, 2005, 5:16 PM
@ iSync Jun 16, 2004, 7:39 PM
@ iTunes May 19, 2005, 4:15 PM
& Mail Aug 14, 2003, 3:00 PM

‘® Microsoft AutoUpdate
|7 Office 2004 for Mac Test Drive

Feb 11, 2005, 5:43 PM
Jan 19, 2005, 11:24 AM

@ OmniGraffla Sep 1, 2004, 7:05 PM
@ OmniQutliner Sep 1, 2004, 7:04 PM
&L Preview Jan 27, 2005, 9:20 AM

[ QuickBooks NUE &
() QuickTime Player

Sep 1, 2004, 6:59 PM
May 25, 2005, 6:07 PM

[7 Raritan Today, 3:31 PM
v [ Raritan Multi-Platform Client Today, 3:31 PM
v [F 44017 Today, 3:31 FM

-] Raritan Multi-Platform Client

» [ Uninstaller

Today, 3:31 PM
Today, 3:31 PM

1 of 40 selected, 63.43 GB available

=& Raritan.

4. Double-click the desired device to establish a connection, type your
user name and password, and click OK to log on.

Connecting to a Server via MPC when Alternate RADIUS Authentication is
Enabled

When Alternate RADIUS Authentication is enabled, you are
authenticated exclusively against a remote authentication database. If
the remote authentication database is inaccessible, you will be
authenticated against a local authentication database and will be
prompted to enter your local authentication username and password.

Remote authentication will be attempted again on the next login after you
have successfully logged on and then logged out, or after the third
unsuccessful attempt to log on with your local authentication database
credentials.

See User Authentication Process in the Dominion KX [1-101 User Guide
for details about the Alternate RADIUS Authentication process and how it
works with MPC.

Launching MPC from a Web Browser

Important: Regardless of the browser you use, you must allow pop-
ups from the Dominion device's IP address in order to open MPC.
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1. To open MPC from a client running any supported browser, type
http://IP-ADDRESS/mpc into the address line, where IP-ADDRESS
is the IP address of your Raritan device. MPC will open in a new
window.

Note: The Alt+Tab command will toggle between windows only on
the local system.

When MPC opens, the Raritan devices that were automatically
detected and which are found on your subnet are displayed in the
Navigator in tree format.

2. If your device is not listed by name in the navigator, add it manually:

a. Choose Connection > New Profile. The Add Connection window
opens.

b. Inthe Add Connection window, type a device Description,
specify a Connection Type, add the device IP address, and click
OK. These specifications can be edited later.

3. Inthe Navigator panel on the left of the page, double-click the icon
that corresponds to your Raritan device to connect to it.

Note: Depending on your browser and browser security settings, you
may see various security and certificate check and warning messages. It
is necessary to accept the options in order to open MPC.

Note: If you are using Firefox 3.0.3, you may experience problems
launching the application. If this occurs, clear the browser cache and
launch the application again.

RRC Requirements and Installation Instructions

Important: RRC works only with Microsoft Internet Explorer. If you
are using a different web browser, MPC will load automatically.

Most users access RRC via Internet Explorer, while other users,
particularly those operating over a modem connection, access RRC
standalone. Both options are detailed in this guide.

Note: Modem use is not supported with Raritan's Dominion KX101.

RRC Minimum System Requirements

The minimum system requirements for the Raritan Remote Client are:

e CPU Speed: 1.0 GHz
e RAM: 512 Mbytes

Note: Running the client software on system configurations below either
of these specifications may impact performance and result in errors.

=i=Raritan.
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Installing and Opening Standalone RRC

Note: This step is optional. Devices can be accessed from a remote PC
either by installing RRC software or by opening RRC via a web browser.
Accessing Devices via a web browser does not require any software
installation on a remote PC.

This section lists the steps required to invoke RRC using standalone
software, which may be useful for accessing devices via modem or if you
wish to close firewall access to ports 80 and/or 443.

1.

Launch your web browser and go to Raritan's website
(http://www.raritan.com/).

Click Support in the top navigation bar and then click Firmware
Upgrades in the left navigation panel (or type the URL
http://www.raritan.com/support/firmwareupgrades).

Scroll down the page until you see the appropriate product name and
click onit.

Locate the version of the standalone RRC client you are using. The
entry for the standalone RRC client is a .zip file which contains the
release notes and the installer for standalone RRC. Check the
release notes for the latest information.

Download the .zip file or simply click on the .zip file entry.

Double-click on the installer executable in the .zip file and follow the
instructions in the InstallShield Wizard to complete the RRC
installation. Be sure to check the release notes for the latest
information and any release specific instructions.

Depending upon the configuration of your PC, the RRC installation
program may also automatically install DirectX and Microsoft
Foundation Class libraries (if they are required). If they are installed,
you will be asked to restart your PC after the installation.

A Raritan Remote Client icon will appear on your desktop after the
installation is complete. Click on this icon to open the standalone
RRC application.

The standalone application can be uninstalled using the Add or
Remove Programs function in the Windows® Control Panel.

Note: You must uninstall the application before installing a new version
of standalone RRC.
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Opening RRC from a Web Browser

Your device features web browser-access capabilities and can provide a
connection from any Windows®-based, remote PC running Microsoft
Internet Explorer 6.0/7.0.

Security Settings
To access a device via the web, your web browser must be configured
appropriately on the Internet Explorer security settings tab. Specifically:

e "Download Signed ActiveX controls” should be set to either Enable
or Prompt.

e "Run ActiveX controls and plug-ins" should be set to either Enable or
Prompt.

Consult your Microsoft Internet Explorer documentation for additional
information.

Note: Microsoft® Windows 2000°, Windows XP®, and Windows 2003°
restrict certain types of users from downloading and running ActiveX
controls and plug-ins regardless of the settings in Internet Explorer.
Consult your Microsoft Windows documentation for more information.

» To open RRC:

1. Ensure that your browser security settings are configured
appropriately and type the IP address assigned to your device in the
URL field of your web browser. See the Initial Configuration section
in the device user guide for additional information on configuring IP
addresses.

a Raritan-Enterprize - Microsoft Internet Explorer

Eile Edit ‘“iew Fawortes Toolz Help |
Address IE http: /#132.168.50.173

Note: Devices ship with the default IP address of 192.168.0.192.
Note that an IP address must be used. Host names are not currently
supported.

e
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You will be redirected to an HTTPS (128-bit) secure web page so
you can open RRC.

2} Raritan Remote Client - Microsoft Internet Explorer

File  Edit “iew Favorites Toolz Help |

Agdressl hitp: /419216850173 j P Ga

:IER(]I’“’G!‘I,, Raritan Remote Client

» 1.21.2003 16:56:34.358 Raritan Remote Client loading...

=
|ﬁj Done l_ l_ E |° Internet 7

2. Depending on your browser and its security configuration, you may

see any or all of the following dialogs asking you to confirm you want
to access and open an externally-provided application. Click Yes to
accept these prompts.

Security Alert Ed |

"'"’ﬂ |nformation you exchange with thiz zsite cannot be viewed or
?. changed by otherz. Howewer, there iz a problem with the site's
* gecurty certificate.

The securty certificate wag iszued by a company vou have
not chosen to trust, Yiew the certificate to determine whether
wou want ko trugt the certifying authority.

a The zecurnty certificate date is walid.

The name on the security certificate is invalid or does not
matzh the name of the zite

Do pou want o proceed?

Wiew Certifizate

|
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Internet Explorer |

FEQ Do pou want ko allow zoftware such az Actives controlz
?. and plug-inz to run?

Internet Explorer |

an thiz page which has been marked zafe for scripting.
Do pou want ko allows this?

& sonipt s accezsing 2ome zoftware [an Actives control]
:J.

Removing RRC from the Browser Cache

58

To remove RRC from your browser cache for any reason, follow the
standard procedure for your web browser software.

To remove cached files in Internet Explorer v6.0:

If you have used RRC recently, exit all instances of Internet Explorer
and restart Internet Explorer.

On the Internet Explorer Tools menu, choose Internet Options.

When the Internet Options dialog appears, click on the General
Settings tab and then click Delete Files.

Click on the Settings tab and then click View Objects.

Internet Explorer will display a list of cached objects. Select any
entries named “TeleControl Class,” “Raritan Console,” or “Power
Board” and delete them.

= -
—
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Operation

Window Layout

MPC Interface

MPC functions are grouped into six general sections on the page. As a
standalone product or using a web browser, the MPC window contains
these main sections.

Raritan Multi-Platferm Chent EN Erghsh (Uinked States)  +' Miorophone W3Tooks & Handwibing & DrawingPad ) T

o) losfeled [ &[s] 2]l MHw[T =[a] 7] T
s |_—;...-.-.._. 248 21,5807 232 Ports e
Fiaet| | L) B Hi LT AN

=i=Raritan.
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RRC Interface

The RRC window is almost identical to the MPC window.

Iy Doouments  Ad-Anere 5
Personal

@

Inbernet  Netscape 7.1

Exxplorer

P
57

Welcome 1o QuickTima

Els Ect Movie Favorbes ‘window Help

i
. Get connected to the Internet
sf - .
\ foryour guide to the best
in QuickTime content.

QuickTime

calf

LSRN R A S S

[ -

£ A £ £ @

‘ﬁ.‘?—“ FI=IT =1 i

S EAE 9D o

S
|
;

L0100 N o |
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Navigator

The navigator provides a tree view of every known Raritan device. From
this panel, you can access all Raritan networked devices for which a
connection profile exists and/or all Raritan devices automatically
identified on the network.

Note: Automatic Raritan device identification uses the UDP protocol and
will typically identify all Raritan devices on your subnet. Network
administrators rarely allow UDP broadcasts to function outside of a
subnet. Automatic Raritan device identification will find only those
Raritan devices that are configured to use the default TCP Port (5000) or
another broadcast port, which is defined on the Advanced tab of the
Options dialog (choose Tools > Options to access the Options dialog).

ﬁ Raritan Devices )ﬂ
----- [ B ENG_TR364 [192.163.53.183]

----- {4 B Ewa [192.168.53.110] {
----- [ B Jackie-101-P52 [192.168.52.94] %
----- [ & Jackies [192.163.52.95] :
----- @ ' Dominion K5 [192,168.51.154]

----- @ S IP-Reach [192.168.0.192]

----- & % TechSuppaort-IPR [192,168.51,207]
----- @ B Dominion KS¥ [192,168,51,202] {
----- @ B K5%-223[192,168.51.223]

----- @ S k52440 [192.168.51.157]

----- @ B kx116-112 [192.168.51.187]

----- @ B DK [192.168.51.204] .
..... @ B K432 [192.168.51.185] J',

..... & B USTIP_TS4192,166,5],205]
1 e o B el = ; ke

- e,
-

Device Naming in the MPC Navigator

In MPC, devices are named according to the Manager Name field on the
Manager's Network Configuration page. Dominion devices are named
according to the Device Name field on the Dominion Console Network
Settings page.

Devices in the RRC Navigator

In RRC, profiled devices are listed in the Navigator according to the data
in the Description field of the device's profile. Automatically-identified
devices will be identified according to the name assigned to them in that
device's network configuration setting.
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Device Ports in the Navigator

For each device to which you are connected, you are able to expand the
tree associated with it to see each device port to which you have access.
Ports with a green icon indicate that you are connected to that port. The
port that is bolded in the Navigator indicates that it is the port currently
displayed (active) in the remote desktop area of the application.

If no name is assigned to a port, by default it is listed in the Navigator as
'‘Unnamed' for Generation 1 devices and, for the KX II, as
Dominion_KX2_PortN (N = port number).

Depending on the maximum number of KVM sessions the device can
handle at once, if all device ports to which you are connecting are
already occupied, an alert message appears and you must wait until one
of the ports is available in order to connect.

Navigator Icons

Each device in the Navigator is assigned two icons. One icon represents
the device's connection profile and the other icon represents its network
status. A connection profile is generally created by a user in order to
store personalized information about specific devices (see Connection
Profiles (on page 79) for additional information). The connection status
indicates the current status of the device.

Device Connection Profile Icons (Left Icon)

Icon Description

| Profiled - A network connection profile exists for this
device.

Modem Profile - A modem connection profile exists for
this device.

@ Not Profiled - The device was found on the network but

a connection profile does not exist for it.

Device Network Status Icons (Right Icon)

=i=Raritan.
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Description

Connected (green) - You are currently authenticated
and connected to this device.

Available (black) - This device is currently available on
the network but you are not currently connected to it.

Unavailable - A profile exists for this device but it is not
currently available on the network. (Note that all devices
to which you are not currently connected and that have
modem profiles will use this icon.)

Port Connection Status Icons

For each server port listed in the Navigator, the following icons can be
associated with it depending on its status:

Icon

oy
=
N g

&

Description
Connected

Available for connection.

Unavailable (either no device is connected or access is
blocked).

In use by another user (may be unavailable depending
on permissions).

Customizing the Navigator

Use specific tools in the toolbar to customize some Navigator attributes:

Icon

Action Description
Display/Hide You can also select Navigator in the
Navigator View menu to toggle between

displaying and hiding the Navigator.

Refresh Navigator Updates the device status information

displayed in the Navigator.

Browse When enabled, Show Discovered
Discovered Devices will display devices that are
Devices “not profiled” but have been found on

the network. This option can also be
enabled by choosing View > Show >
Discovered Devices.

Note: The Browse Discovered Devices
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Icon Action Description

option is the only method of connecting
to a Raritan device configured to use a
DHCP IP address.

MPC Navigator Tabs

MPC tabs at the base of its Navigator pane. These tabs allow you to
change how you display devices. Click the View By Name tab to sort the
list alphabetically by name, click the View By IP tab to sort the list
numerically by IP address, or click on the View by Host Name tab to sort
the list alphabetically by display name.

View By Marne | iew By IP
View By Host Mame :

TTRTTUNTT LS, LG, T L |y
Connecking..., j
[Unknown 192,163,50,12]:
Connected
[Unknown 122,162,50,12]: Login
complete,

\,-“hr«-...f \._,, e O &

=5 oo e 3 1?14’--\4#\_\1- g «.-vu'-,\ 1 ."\\H’m\h :

[S

These tabs are available only in the MPC interface.

=i=Raritan.
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Navigator Display and Sort Options

To better organize your view of all ports, use the Show and Sort options
in the View menu. Note that you do not need an open connection to a
target to show and sort targets in the Navigation panel.

Showing Ports

e Discovered Devices - Shows or hides discovered devices from the
Navigator view. You will not see broadcast messages when this
option is disabled (not selected).

e Unassigned Channels - Shows or hides channels with no assigned
targets. Note that the default for Generation 1 (G1) devices is to
show unassigned channels (option is enabled), whereas the default
is to hide unassigned channels (option is disabled) for Generation 2
(G2) devices.

e Tools - Shows or hides the Admin and Diagnostic ports.

Note: These settings are saved from session to session.

Sorting Ports

Use the Sort options on the View menu to organize port information. Yo
are able to sort ports by channel number, channel name, or channel
status.

Connection USE Profile Serizl Keyboard Video Mouse Virkual Media Tools [Wiew Window Help

o]

o= el 4

s

g ¥ 2tandard Toolbar

=i=Raritan.

¥ Connected Server(s) Toolbar

mgtatus Bar

muauigator

¥ Meszage

Show »

Sark M channel
Full Screen [0 Marne
[0 scale video [0 status

e Channel Number - When sorted by channel (View > Sort > Channel
ports are listed numerically.

u

),
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o S Danininnek [ 97 158.51.54]
= % Cooniniorek [292.155.51, 184
L1 5UN Solaris
78 2: Winz000
' Mac Q5K

3

41 inux

O Dave
& tlice

71 Charley
& Sarbera

A= g Zlen

e Name - When sorted by name (View > Sort > Name), port names are
sorted alphanumerically within each group.

. o S Dominion-Kx [192.168.51,34]
[] & 2= Dominion-k¥ [192.168.51,184]

-4 arthur: 25

- H=W Darbara: 0
il 26

4= Charlene: 27
~N=W Charley: 7
~AE Dy 5

@ Dave 2: 15
LN Dave 0003 16
A neharahe 7R

-4 Eller: 9
-\ Evan: 30

i @ Framcine: 21

e Status - When sorted by status (View > Sort > Status), ports are
sorted in the following order:

= Active Channels
= Busy Channels

=  Available Devices

—, —
—
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= Unavailable Devices

----- @ %_; Larmman-kx [192,165.51,44]
=@ % Domninion-kx [192.168.51.184]
..... =, SUn Solaris: 1

----- E Winz000: 2

@ Alice: &

A= grthur: 25

.=} Barbara: 8

M Eill: 26

4=} Charlene: 27

=¥ Charley: 7

@ Drawve; 5

4= Dave 20 15

- N=} Dave 0003: 16

-.N=W Deborah: g

A= Ellem: 9
-4 Evan: 30

Note: Sorting ports does not apply to KX 11-101.

Toolbars

Standard Toolbar

The Standard toolbar provides one-click access to the most frequently-
used commands.

» To display the Standard toolbar:
e Choose View > Standard Toolbar.

Following is a list of the buttons in the standard toolbar as well as a
description of the action performed once the buttons are selected.
Additionally, if there are menu options or shortcut menu options that will
perform the same task, they are listed, too.

Button Button Description
name
| New Profile  Creates a new Navigator entry for a

Raritan device.

Same result as choosing Connection >
New Profile in the menu.

Connection  Opens the Modify Connection Properties

Properties  dialog from which you can manually adjust
bandwidth options (such as connection
speed, color depth, and so forth).

47
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Button

e 2]

m

Button
name

Video
Settings

Color
Calibration

Target
Screenshot

Synchronize
Mouse

Refresh
Screen

Auto-sense
Video
Settings

Smart Card

Enter On-
Screen
Menu

Description

Same as choosing Connection >
Properties or choosing Connection
Properties on the shortcut menu, which is
opened by pressing Ctrl+Left Alt+M.

Opens the Video Settings dialog, allowing
you to manually adjust video conversion
parameters.

Same as choosing Video > Video Settings
or choosing Video Settings on the shortcut
menu, which is opened by pressing
Ctri+Left Alt+M.

Adjusts color settings to reduce excess
color noise.

Same as choosing Video > Color Calibrate.

Click to take a screenshot of the target
server and save it to a file of your
choosing.

In dual-mouse mode, forces realignment of
the target server mouse pointer with the
mouse pointer.

Same as choosing Mouse > Synchronize
Mouse or choosing Synchronize Mouse on
the shortcut menu, which is opened by
pressing Ctrl+Left Alt+M.

Forces a refresh of the video screen.

Same as choosing Video > Refresh Screen
or choosing Refresh Screen on the
shortcut menu, which is opened by
pressing Ctrl+Left Alt+M.

Forces a refresh of the video settings
(resolution, refresh rate).

Same as choosing Video > Auto-sense
Video Settings.

Opens a dialog that allows you to select
from a list of mounted smart card readers.

Not applicable for the device. Used by the
application with other Raritan products.

Same as choosing Keyboard > Enter On-
Screen Menu.

=i=Raritan.
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Button

ESL

Button
name

Exit On-
Screen
Menu

Send
Ctrl+Alt+Del

Single
Cursor
Mode

Full Screen
Mode

Scaling

Show/Hide
Navigator

Refresh
Navigator

Show/Hide
Browse All
Devices

Chapter 4: Multi-Platform Client and Raritan Remote Client

Description

Not applicable for IP-Reach or Dominion.
Used by the application with other Raritan
products.

Alternatively, select Esc on the keyboard.
Same as choosing Keyboard > Exit On-
Screen Menu.

Note: This function is not available on the
KSX 1.

Sends a Ctrl+Alt+Del hot key combination
to the target server.

Same as choosing Keyboard > Send
Ctrl+Alt+Del.

Starts Single Cursor mode in which the
local mouse pointer no longer appears
onscreen.

Same as choosing Mouse > Single Cursor
Mode. Press Ctrl+Alt+X to exit this mode.
Alternatively, choose Single/Double Cursor
from the shortcut menu, which is opened
by pressing Ctrl+Left Alt+M.

Maximizes the screen real estate to view
the target server desktop.

Same as choosing View > Target Screen
Resolution (in MPC) or Full Screen (in
RRC). Alternatively, press Ctrl+Left Alt+M
to open the shortcut menu and then
choose Full/Normal Screen or press the F
key on your keyboard.

Increases or reduces the target video size
S0 you can view the entire contents of the
target server window without using the
scroll bar.

Toggles the Navigator panel between
visible and hidden.

Same as choosing View > Navigator.

Forces a refresh of the data displayed in
the Navigator.

Toggles between displaying and not
displaying Raritan devices in the Navigator
that are automatically identified on the
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Button Button Description
name
network and that do not have
preconfigured profiles associated with
them.

74 About Displays the application version
information.

Same as choosing Help in the menu bar.

MPC Connected Server(s) Toolbar

The Connected Server(s) toolbar is comprised of a button for each
connected target server port, thus enabling quick access to connected
targets. When you connect to a port, a button corresponding to that port
is added to the toolbar and labeled with the name of the port.
Conversely, when you disconnect from a port, the corresponding button
is removed from the toolbar.

Note: In Single Mouse mode, the Connected Server(s) Toolbar appears
on the target but cannot be accessed.

By default, the Connected Server(s) toolbar is enabled (visible). To
disable it, deselect Connected Server(s) Toolbar in the View menu.
Buttons corresponding to windows that do not support Full Screen mode
are not shown in the toolbar. For example, serial ports, generation one
(G1) admin ports, and G1 diagnostic ports will not be displayed in the
toolbar in Full Screen mode.

While in Full Screen mode, you are able to view the Connected Server(s)
toolbar by hovering your mouse over the top of the screen. To use this
feature, the Connected Servers Toolbar option must be selected in the
View menu.

B cao.|{§ad..| B winz...| Bichan... [l
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» To display the Connected Server(s) toolbar (when not already

visible):

e Choose View > Connected Server(s) Toolbar.

» To view the window for a target server:

e Click the button that corresponds to the appropriate connected target
server you want to view. The window for the corresponding target
server is displayed and the button for the selected port is highlighted.
In Full Screen mode, note that this action is window swapping, not

video switching.

When you click a button that is already highlighted, the corresponding
window is minimized. If you click that button again, the window is brought

forward and maximized.

Status Bars

MPC Status Bar

The status bar displays session information about your connection to a
Raritan device. This information includes:

Icon Session
information
2 Concurrent
connections
indicator
CAP, Lock key
NUM, indicators
SCRL

i

Raritan.

Description

Indicates that multiple remote users are
currently connected to the same target
server on the device.

One icon indicates a single user is
connected, and two icons indicates two or
more users are connected.

Concurrent connection ability can be set
globally under PC share mode on the
Manager Security Settings page or set
per individual user in the Concurrent
Access Mode setting on the Manager
User Account Settings page. For the
device, concurrent connection ability can
be set using the PC Share Mode option in
the Security Settings page: PC-Share
permits concurrent access and Private
limits server access to one user at a time.

Indicates the status of the current target
KVM Server, in respect to the activation of
the Caps-Lock, Num-Lock, and Scroll-
Lock keys. If these keys are enabled on
the target server being viewed, this
affirmative status will be reflected on the
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Icon Session Description
information
status bar.

Note: If a light is used on your keyboard to indicate the Scroll Lock, Num
Lock, and Caps Lock key is active, it may or may not be in sync with the
lock key indicator status displayed on the status bar. See the status bar

as your guide if this occurs.

RRC Status Bar

The status bar displays session information about your connection to a
Raritan device. This information includes:

v
1 4

[ Patih 3 (WM Part 3) [T =4[ € CaP INUM [SCRL 2

O 000 &

Diagram Session Description

key information

@ Video sensing  Indicates when video sensing occurs
status/path during connections to target KVM server
indicator ports.

@ Bandwidth Indicates how much of your total
usage indicator available bandwidth is currently being

used. The connection speed setting
determines total available bandwidth.

This setting is defined on the
Compression tab of the Connection
Properties dialog, which is accessed by
choosing Connection > Properties, or
pressing Ctrl+Left Alt+ M and then
choosing Connection Properties.

@ Security Indicates whether the current remote
indicator connection is protected by encryption.
Encryption requirements are set during

configuration of your Raritan device.

When a device is configured for no
encryption or SSL authentication, the
Security Indicator is represented on the
status bar by an open lock icon.

When SSL authentication, data
encryption, or SSL encryption is applied,
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Diagram Session

key information
Concurrent
connections
indicator

@ Lock key
indicators
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Description

the security indicator is represented on
the status bar by a closed lock.

Indicates that multiple remote users are
currently connected to the same target
server on the device.

One icon indicates a single user is
connected, and two icons indicates two
or more users are connected.

Concurrent connection ability can be set
globally under PC share mode on the
Manager Security Settings page or set
per individual user in the Concurrent
Access Mode setting on the Manager
User Account Settings page. For the
device, concurrent connection ability can
be set using the PC Share Mode option
in the Security Settings page: PC-Share
permits concurrent access and Private
limits server access to one user at a
time.

Indicates the status of the current target
KVM Server, in respect to the activation
of the Caps-Lock, Num-Lock, and Scroll-
Lock keys. If these keys are enabled on
the target server being viewed, this
affirmative status will be reflected on the
status bar.

Note: If a light is used on your keyboard to indicate the Scroll Lock, Num
Lock, and Caps Lock key is active, it may or may not be in sync with the
lock key indicator status displayed on the status bar. See the status bar

as your guide if this occurs.

Screen Modes

Besides a standard view, full screen view and a scaling option are
available. These options increase the remote desktop area and make
viewing the target video easier.
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MPC Full Screen Mode

Full Screen mode provides you with the ability to view the target server
desktop in Full Screen mode, which removes all toolbars from view.

Activate Full Screen mode once you are connected to a target by doing
one of the following:

e Click the Full Screen button ﬁ in the toolbar and then click OK in
the confirmation message that appears.

e Choose View > Full Screen and then click OK in the confirmation
message that appears.

e Press Ctrl+Left Alt+M to open the shortcut menu. Next, press the F
key on your keyboard or use your mouse to choose Full/Normal
Screen. Click OK in the confirmation message that appears.

== Raritan.
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To exit Full Screen mode, use the shortcut menu or click the Close icon

il that appears at the top right of the page when you hover your mouse
along the top of the screen.

Note: The Ctrl+Left Alt+M key combination does not work for certain
target servers if you are running JRE 1.5.0_01. To return from full page
mode, use Alt+Tab and choose MPC.

While in Full Screen mode, you are able to view the Connect Server
toolbar by hovering your mouse over the top of the screen. To use this
feature, the Connected Servers Toolbar option must be selected in the
View menu.

Additionally, while in Full Screen mode, your monitor's resolution may be
adjusted to match the resolution of the target server (provided your
graphics system supports it). If your graphics system does not support
the resolution of the target system, you will be unable to activate Full
Screen mode and a message will appear requesting that you change
your video resolutions first.

Tip: To view the video resolutions your system supports in a Windows®
environment, access your computer's Control Panel from the Windows
Start menu, double-click Display, and click the Settings tab.

ol |
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RRC Full Screen Mode

Full screen mode removes the surrounding RRC graphical interface and
your local desktop area, filling your screen with the video from the target
server. Your screen's resolution will be adjusted to match the resolution
of the target server (provided your graphics system supports it). If your
graphics system does not support the resolution of the target system,
you will be unable to activate full screen mode and a message will
appear requesting that you change your video resolutions first.

Note: To view the video resolutions your system supports in a Windows®
environment, access your computer's Control Panel from the Windows
Start menu, double-click on Display, and click on the Settings tab.

Activate full screen mode in one of the following ways once you are
connected to a target:

e Click the Full Screen icon = in the toolbar and then click OK in the
confirmation message that appears.

e Choose View > Full Screen and then click OK in the confirmation
message that appears.

e Press Ctrl+Left Alt+M to open the shortcut menu. Next, press the F
key on your keyboard or use your mouse to choose Full/Normal
Screen. Click OK in the confirmation message that appears.

SNIFFER.PCF
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MPC Scaling

Scaling your target window size allows you to view the entire contents of

the target server window. This feature increases or reduces the size of
the target video to fit the window size and maintains the aspect ratio.

This allows you to see the entire target server desktop while in standard

view.

P To activate Scaling, do one of the following:
e Choose View > Scale Video.

Connection USE Profile Serial Keyboard Wideo Mouse Widual Media Tools |Wiew window Help

DEEEE

¥ Status Bar

g: | || i| g ¥ Stamndard Taalbar
—|£ =1 ¥ Conneced Server(s] Toolbar

[¥ Mavigatar
¥ Message

Show
Sort

Full Screen

[ Scale Wideo

e Click the Scaling button @ on the toolbar.

e To exit this mode and return the target window to its previous size,
deselect Scale Video on the View menu or click the Scaling button
once again.

Note: Enabling Scale Video will scale the complete target video image to
fit the remote desktop area as it grows or shrinks. You can combine this
setting with target screen resolution for a 'full page' effect on targets with

a higher resolution than your desktop.
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RRC Scaling

Scaling your target window size allows you to view the entire contents of
the target server window. This feature increases or reduces the size of
the target video to fit the window size and maintains the aspect ratio.
This allows you to see the entire target server desktop while in standard
view.

To activate Scale Video mode, do one of the following:

e Choose View > Scale.

"] Connection  Keyboard  Wideo Mouse  Tools mw'indow Help

EMQ D 2= £ || v Toobar
w Status Bar

w Mavigaktar

Show 3
Sart 3

Full Screen

e Click the Scaling button # on the toolbar.

To exit this mode and return the target window to its previous size,
choose Scale on the View menu or click the Scaling button once again.

Note: Enabling Scale Video will scale the complete target video image to
fit the remote desktop area as it grows or shrinks. You can combine this
setting with target screen resolution for a full page affect on targets with
a higher resolution than your desktop.

Auto-Scroll

The auto-scroll feature automatically scrolls the video display in the
direction of the cursor as the cursor approaches the edge of the display.
A thin border appears around the perimeter of the remote desktop area
to indicate the function is on. When enabled, if you see scroll bars and
then move the cursor onto the border, the page will automatically scroll in
the appropriate direction.

The scroll border is activated by selecting Show Scroll Borders in the
Options dialog, which is accessed by choosing Tools > Options.

=i=Raritan.
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Connection Profiles

Connection profiles store important information about your Raritan
device such as the IP address, custom TCP ports, preferred
compression settings, and custom security keys. A profile is required to
access devices outside your subnet and to access devices using a dial-
up connection.

Through profiles, you can set up personalized connections. These
profiles are not shared among other users.

The information collected when creating a new connection profile will
differ based on Generation 1 and Generation 2 devices.

Tip: If your Raritan device is configured to use a custom TCP port or a
group security key, first create a connection profile so that you can
access the device.

Creating, Modifying and Deleting Profiles in MPC

» To create a profile:
1. There are two ways to create a profile:

= For automatically discovered devices, right-click the device name
in the Navigator and choose Add Profile from the shortcut menu.

= For other devices, choose Connection > New Profile.

The Add Connection dialog appears. Options are organized into
three tabs.

Note: The Connection and Security tabs are not available for
Generation 2 devices.

Connect Tab

2. Onthe Connect tab, type a meaningful description of the device in
the Description field. This description identifies the Raritan device in
the Navigator.

3. From the Product drop-down, choose the Raritan product you are
using.

TCP/IP connections
4. Select the type of connection from the Connection Type drop-down.

a. If TCP/IP Connection is selected for a LAN/WAN connection,
complete the information in the "Find Raritan device By" section:

= Type the IP address assigned to your Raritan device.

= Type the name assigned to your Raritan device during initial
setup.
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=  Type the Domain Name Server (DNS) name. Use this option if
you use a DNS server to resolve a DNS name to the IP address

assigned to your Raritan device.

Conned I Cormpression | Security |

Drescription: |

Product: |D0mini0n KX Gl

Connedion Type: |[TCR/IP Connecian

M
M

Find Raritan dewvice By:

@ 1P Address |

O Cevice Mame |

O Host Marme |

Use Default Port Murmber Fort Humber: |

=14 Cancel

Dial-up connections

a. Select Dial Up Connection from the Connection Type drop-down
for a direct analog modem connection to the Raritan device.
Type the parameters that should be used to establish a

connection.

= Enter the phone number for the dial-up connection. Remember to
include any additional codes that should be dialed to establish a
connection, such as country codes, area codes, or outside line

access codes.

= Select the modem (as configured in Windows) from the drop-
down list that will be used to dial and connect to your Raritan

device.

=i=Raritan.
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Note: For security reasons, you must use the MPC standalone client
if you require modem access. Further, one modem on a client PC
can be used for only one device connection.

Add Connection %]
Connad | Compression | Security |
Cescription: |
Product: |D0mini0n KX Gl v|
Connecion Type: |Dial Up Connection v|
Fhone Murmber: |
Modem: |Cone><ant HDw& D110 MDC V.92 Modem v|
Use Default Port Nurmber FPort Humber: |
=134 Cancel

Select the Use Default Port Number checkbox to use the default port
number (5000). For TCP Ports, devices are automatically configured
to use TCP Port 5000 when communicating with the client.

If you do not want to use the default port number, deselect the
checkbox and type the port number in the Port Number field.

Compression Tab
Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

» 1.5mb (Max DSL/T1)

= 1mb (Fast DSL/T1)

» 512 kb (Medium DSL/T1)
= 384 kb (Slow DSL/T1)

= 256 kb (Cable)

= 128 kb (Dual ISDN)
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= 56 kb (ISP Modem)
= 33 kb (Fast Modem)
= 24 kb (Slow Modem)

Note: Raritan recommends that if you are connecting to the device
via modem, you set the connection speed to 33kb.

Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-bit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-hit color spectrum made available by most video graphics
cards. Attempting to transmit such high color depths wastes network
bandwidth.

Note: If you are connecting to the device via a modem, Raritan
recommends setting the color depth to 4-bit gray.

Select Progressive Update to increase the usability in constrained
bandwidth environments. When Progressive Update is enabled, the
device initially sends an image of the remote desktop at lower color
depths. Higher color depth images are provided as the bandwidth
allows.

Note: When Color Depth is set to Auto Select Color (default),
Progressive Update is automatic. The device will enable/disable
Progressive Update as required, disabling it for fast connections and
enabling it for slow connections.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).
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10. Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

11.

Select "Frames per second". This setting instructs MPC on how often

to redraw the video display of the target. This only affects the client
display behavior and has no bearing on the data rate of the video
being sent to the client. Setting this option higher makes the video
appear smoother but also requires more processing power.

Add Connection E|
| Connect | Comprassion | Security
Connection Speed: |)§‘utn bgt_el_:‘t- -
Color Depth: |Aut0 Selact Color -
[ progressive Update
[ internat Flow Contral
o -
Smeothing: e High
Frarmes per zecond
@ S fps ()10 fps ) 20 fps
| K Cancel
Security Tab

12. Enter the private security key in the Private Key field if your device is
configured to use a private security key. Entering a security key
allows you to gain the authorization required to initiate a connection

to that device.

13. Retype the private security key in the Confirm Private Key field to
ensure no typographical errors were made.
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14. Click OK to create the connection profile.

X

Add Connection

| Connect | Compression| Security |

Private Key: I

Confirrm Private Key: |

he private key MUST rmatch the private key set by the Adrministrator
or connections will be denied,

ok || cancel
» To modify a profile:
1. Select the device in the Navigator panel and right-click it.
2. Choose Modify Profile. The Modify Connection dialog appears.
3. Update the fields as appropriate.
4. Click OK.
> To delete a profile:
1. Select the device with a profile in the Navigator and right-click it.
2. Choose Delete Profile.
3. When prompted to confirm the deletion, click Yes to delete the profile

for this device or click No to return to the application without deleting.

Note: The device only supports modem connections to the Administrative
functions in MPC. Port functions are not supported via modem.

Creating, Modifying and Deleting Profiles in MPC - Generation 2 Devices

> To create a profile:
1. There are two ways to create a profile:

= For automatically discovered devices, right-click the device name
in the Navigator and choose Add Profile from the shortcut menu.

= For other devices, choose Connection > New Profile.

The Add Connection dialog appears. Options are organized into
three tabs.

=i=Raritan.
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Note: The Connection and Security tabs are not available for
Generation 2 devices.

On the Connect tab, type a meaningful description of the device in
the Description field. This description identifies the Raritan device in
the Navigator.
From the Product drop-down, choose the Raritan product you are
using.
Select the type of connection from the Connection Type drop-down.
TCP/IP connections
a. If TCP/IP Connection is selected for a LAN/WAN connection,
complete the information in the "Find Raritan device By" section:
= Type the IP address assigned to your Raritan device.
= Type the name assigned to your Raritan device during initial
setup.
= Type the Domain Name Server (DNS) name. Use this option if
you use a DNS server to resolve a DNS name to the IP address
assigned to your Raritan device.
Add Connection [z|
Connect | o prEssian | Sty |
Description: |Deuice A
Product: |Dominion KX G2 ILI
Connection Type: |[TCRIP Connecdion ILI
Find R aritan device By:
(8 IP Address |
O Drevice Mame |
O Host Mame |
Use Default Port Murmber Port Humber: |
[s1:3 Cancel

Dial-up connection

a.

Select Dial Up Connection from the Connection Type drop-down
for a direct analog modem connection to the Raritan device.
Type the parameters that should be used to establish a
connection.

Enter the phone number for the dial-up connection. Remember to
include any additional codes that should be dialed to establish a
connection, such as country codes, area codes, or outside line
access codes.
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= Select the modem (as configured in Windows) from the drop-
down list that will be used to dial and connect to your Raritan
device.

Note: For security reasons, you must use the MPC standalone client
if you require modem access. Further, one modem on a client PC
can be used for only one device connection.

Add Connection g|
Connect | GO E T EESi RN | Security |
Description: |
FProduct: |D0mini0n Kx G2 ILI
Connedion Type: [Dial Up Connection |:|
Fhone Murmber: |
Maoderm: |C0ne><ant HOA D110 MDC V.92 Modem |L|
Use Default Port Hurmber Port Humber: |
(=18 Cancel

Select the Use Default Port Number checkbox to use the default port
number (5000). For TCP Ports, devices are automatically configured
to use TCP Port 5000 when communicating with the client.

If you do not want to use the default port number, deselect the
checkbox and type the port number in the Port Number field.

Note: Dial-up is not supported in KX 11-101.

w NpN Y

N N

To modify a profile:

Select the device in the Navigator panel and right-click it.
Choose Modify Profile. The Modify Connection dialog appears.
Update the fields as appropriate.

Click OK.

To delete a profile:
Select the device with a profile in the Navigator and right-click it.
Choose Delete Profile.

When prompted to confirm the deletion, click Yes to delete the profile
for this device or click No to return to the application without deleting.

=i=Raritan.
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Creating, Modifying and Deleting Profiles in RRC

P To create a profile:

There are two ways to create a profile:

= For automatically discovered devices, right-click the device name
in the Navigator and choose Add Profile from the shortcut menu.

= For other devices, choose Connection > New Profile.

The Add Connection dialog appears. Options are organized into

three tabs.

Note: The Connection and Security tabs are not available for

Generation 2 devices.

Add Cannec:tinn

Conncct ] Coonnpn essiur ] Secuily 1

Drescription ]l

Connection Type 1Dial IJ p Connection

Phone Mumber ]

b odern:

Iw Uze Default Port Mumber

Conexant HOA D110 MDC Y, 92 M adem

Connect Tab

2. Onthe Connect tab, type a meaningful description of the device in
the Description field. This description identifies the Raritan device in

the Navigator.

Select Dial Up Connection from the Connection Type drop-down for
a direct analog modem connection to the Raritan device. Type the
parameters that MPC or RRC should use to establish a connection.
Dial up connection does not apply to Generation 2 (G2) or KX101.
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= Enter the phone number for the dial-up connection. Remember to
include any additional codes that should be dialed to establish a
connection, such as country codes, area codes, or outside line
access codes.

= Select the modem (as configured in Windows) from the drop-
down list that will be used to dial and connect to your Raritan
device.

Note: For security reasons, you must use the MPC standalone client
if you require modem access. Further, one modem on a client PC
can be used for only one device connection.

Select the Use Default Port Number checkbox to use the default port
number (5000). For TCP Ports, devices are automatically configured
to use TCP Port 5000 when communicating with the client.

If you do not want to use the default port number, deselect the
checkbox and type the port number in the Port Number field.

Compression Tab
Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

* 1.5mb (Max DSL/T1)
= 1mb (Fast DSL/T1)

= 512 kb (Medium DSL/T1)
= 384 kb (Slow DSL/T1)
= 256 kb (Cable)

= 128 kb (Dual ISDN)

= 56 kb (ISP Modem)

= 33 kb (Fast Modem)

= 24 kb (Slow Modem)
Set the Color Depth.

=i=Raritan.
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Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-bit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics
cards. Attempting to transmit such high color depths wastes network
bandwidth.

Select Progressive Update to increase the usability in constrained
bandwidth environments. When Progressive Update is enabled, the
device initially sends an image of the remote desktop at lower color
depths. Higher color depth images are provided as the bandwidth
allows.

Note: When Color Depth is set to Auto Select Color (default),
Progressive Update is automatic. The device will enable/disable
Progressive Update as required, disabling it for fast connections and
enabling it for slow connections.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).
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9. Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

Add Connection f'>_<|

Mannent  Compression ! Renurity]

Connection Speed:

Color Depth: |.-’-‘-.ut-:| Select Color :J
[T Progressive Updats
[ Intemet Flow Contral

S moothing fE -—-_; M ax

Ok | Cancel

Security Tab

10. Enter the private security key in the Private Key field if your device is
configured to use a private security key. Entering a security key
allows you to gain the authorization required to initiate a connection
to that device.

11. Retype the private security key in the Confirm Private Key field to
ensure no typographical errors were made.
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12. Click OK to create the connection profile.

Add Connection

I:u:unneu:t] Compreszion S ecurity l

Private Key: |

Confirm Private Kew |

The private key MUST match the private
kew zet by the adminiztrator or connectiong
will be denied.

k. | Cancel

]
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Establishing a New Connection

Note: Depending on your version of the JRE, you might receive a
certificate message when using the standalone application to access a
Dominion device. You have to accept the certificate in order to establish
the connection.

To connect to a device, double-click the device's icon in the Navigator,
then type your user name and password to connect. You can also right-
click the device name in the Navigator and select New Connection.

Note: The default device login user name is admin and the default
password is raritan. You have administrative privileges using these login
credentials.

If you do not see an icon for your device in the Navigator, follow the
instructions on creating new profiles, which is available in this section.

If you are having problems connecting to a device, be sure to check the
following:

e User name - Raritan usernames are not case-sensitive.
e Password - Raritan passwords are case-sensitive.

e TCP Port - If you have configured your device to use a non-default
TCP Port, this information must be entered into its connection profile.

e Firewall Settings - If you are accessing a device through a firewall,
that firewall must be configured to allow two-way communication on
TCP Port 5000 (or the custom TCP Port to which your device has
been configured).

e Security Key - If you have configured your device to require a group
security key, that key must be entered into the device's connection
profile.

Note: If you are running MPC on Internet Explorer with both a Microsoft
firewall and a non-Microsoft firewall utility installed, IE will display a
message telling you that MPC is already running (even if it is not in fact
running). To avoid this, deactivate one of your firewalls, or use a browser
such as Mozilla or Firefox.

Connection Information

» To obtain information about your connection:

e Choose Connection > Connection Info. The Connection Info dialog
appears.
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The following information is displayed about a current connection to

Generation 1 devices:

Connection
information

Device name
IP address

Port

Data in/second

Data out/second
FPS

Connect time
Horizontal resolution
Vertical resolution
Refresh rate
Protocol version

Oldest supported
version

Hardware version
Software version
Post code

Network flags

Security flags

Options
Frame grabber info
KME info

Serial Info
Video devices count

Serial devices count

Description

The name of your device.
The IP address of your device.

The KVM Communication TCP/IP Port used to
access the target device.

Data rate in.

Data rate out.

The frames per second transmitted for video.
The duration of the connect time.

The page resolution horizontally.

The page resolution vertically.

How often the page is refreshed.

The RFB Protocol version.

The oldest supported version of the client
software.

0 - Obsolete
3 (Software version)
Power on self-test error code. 0 = no error.

A list of the various network options that have
been enabled or disabled such as DHCP, dial-
in, autodetection, and so on.

A list of the various security options that have
been enabled or disabled such as SSL
encryption, SNMP, and so on.

RFP and TR support enabled or disabled.
0 - not used

KME version number for systems that use the
KME.

Serial devices
Number of video devices detected.

Number of serial devices detected.
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Connection Description
information

Reserved 0 - not used

FPS* Frames per second

* Available only in MPC.

> To copy this information:

e Click Copy to Clipboard in the Connection Info dialog. The
information is now available to be pasted into the program of your
choice.

Generation 2 Devices

The following information is displayed about a current connection to
Generation 2 devices:

Connection Description

information

Device name The name of your device.

IP address The IP address of your device.

Port The KVM Communication TCP/IP Port used to
access the target device.

Data in/second Data rate in.

Data out/second Data rate out.

FPS The frames per second transmitted for video.

Connect time The duration of the connect time.

Horizontal resolution The page resolution horizontally.
Vertical resolution The page resolution vertically.
Refresh rate How often the page is refreshed.

Protocol version The RFB Protocol version.

» To copy this information:

e Click Copy to Clipboard in the Connection Info dialog. The
information is now available to be pasted into the program of your
choice.

=i=Raritan.



=i=Raritan.

Chapter 4: Multi-Platform Client and Raritan Remote Client

Connecting to a Remote KVM Console

Once you establish a connection with a Raritan device, that device's icon
in the Navigator can be expanded to display all ports enabled for remote
access.

ﬁ R.aritan Dewvices =]
L [1%& pill's kx232 [192.168.51.120]

— @ B billskx101 [192.168.51.53]
—Gll billsk=x121 [192.165.51.121]

— 1% rown Room Dominion-Ki [13:
: Channel 2 :

i Channel 2

¢ Channel 19

i Channel 4

i Channel

i Channel
¢ Channel
i Channel
i Channel

LI e R B e R |

Choose one of the following options to establish a remote KVM console
connection:

e Double-click the KVM port. This method closes any previous
connection before connecting to the new port.

e Right-click the port and choose Switch from the shortcut menu. This
method closes any previous connection before connecting to the
new port.

e Right-click the port and choose New Connection from the shortcut
menu. This method allows you to connect to the selected port
without closing any previous connections and creates a new
connection if the device supports multiple concurrent connections.

Once connected, Raritan KVM over IP devices display real-time video
output of the target server (this video is compressed and encrypted
according to the configuration settings specified by the administrator).
You now have complete, low-level control of the KVM console as if you
were physically located next to the server.

e To close a connection, right-click the connected device and choose
Disconnect.

e To exit completely, choose Connection > Exit.

Closing a Remote Connection

To close the connection:
Select the device in the Navigator and right-click it.

Choose Disconnect from the shortcut menu.

w NPy

To exit completely, click Exit on the Connection menu
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Shortcut Menu

To access the shortcut menu, use either the default keyboard
combination of Ctrl+Left Alt+M or the keyboard combination you assign.
See Changing the Shortcut Menu Keyboard Combination (on page
97) for more information.

TIP: If at some point you forget the keyboard combination used to open
the shortcut menu, press Ctrl+Left Alt at the same time. The keyboard
combination will be displayed across the bottom of the page for five
seconds.

== Raritan.

Full/varmal Saeen

Auto Senze

Zalibrate Colaor

Zanreckicn Infarmnation

Zonrecticn Properies

Widao Settings

Fefresh Screen

Fynchronize Mousze

Zinglef/Double cursar

Send CtrltAalt+Del

Zonreck Drive., .

Zonrect CO-RIDMIISO Imags...

Send Ctrl+alt+m

Zanoe| [Ezc)
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Shortcut Menu Key Options

Execute any of the commands on the shortcut menu by either choosing
the command in the menu or using a key combination. If you are using a
key combination to execute a command, you will press Ctrl+Left Alt+M
and then press the key on your keyboard that corresponds to the
underlined letter in the shortcut menu. For example, press Ctrl+Left
Alt+M+F to enter Full Screen mode. See the table below for information
on invoking commands from the shortcut menu using keyboard
combinations.

Note: You must use the Left Alt key on your keyboard when using the
Ctrl+Left Alt combination.

To Press Ctrl+Left Alt+M+

Toggle between Full/Normal screen F
mode*

Display connection information*
Display or set connection properties*
Display or set video settings*
Refresh the page

Synchronize mouse

nw < 1 < T

Change to/from single/double cursor
mode

Send Ctrl+Alt+Del to the target D
system

Connect Drive
Connect CD-ROM/ISO Image
Send Ctrl+Alt+M to the target system

Exit a dialog or menu without altering Esc
the keyboard state

* If Full Screen mode is active, executing this command will automatically
end Full Screen mode.

Changing the Shortcut Menu Keyboard Combination

> To change the keyboard combination, do the following:
1. Choose Tools > Options to open the Options dialog.

2. From the Keyboard Shortcut Menu HotKey drop-down, select the
keyboard combination you want to use to open the shortcut menu.
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98

3. Click OK or Apply.

Once a new keyboard combination is assigned, the new combination will
be displayed in the shortcut menu and in the onscreen message that

displays when the combination is used.

Options

General I Advancad |

[#] show =<rall borders,

[¥] Dizplay single carsor mode Instructions,

Kayboard Type

|L|S.|"Tnternal:iona| t]

Kaybasrd Shortout Manu Hotkey

Auto-Syne mouse in tvo-cursor mode. (Mot supported for KX Generation 2)

[¥] Autarmmatic Color Calibration (For KX Generation 1 only)

| DK || Cancel ” Apply J

Ctrl+alz+y |w
ChelHale+0
Chrl4alg+o
Ctrl+ale+P
Ctrl+alk+o
cril+ale+R | —
ChrlAlk+E
Crrl4ale4T r!
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Keyboard Macros

A hot key combination is a set of keystrokes that performs an action
when pressed. For example, the hot key combination Ctrl+Alt+0 might be
created to minimize all windows.

A keyboard macro is a shortcut that sends a hot key combination to a
target server. Using keyboard macros ensures that hot key combinations
intended to be used on the target server are sent to and interpreted only
by the target server, and not by the computer on which the client is
running.

Raritan strongly suggests the use of keyboard macros instead of hot key
combinations since certain hot key combinations have been found not to
work properly, depending on the platform and behavioral difference
between the application and web browser version. Specifically, using hot
keys can result in your own client PC intercepting the command and
performing the action instead of sending the command to the target
server as intended.

Note: In MPC, foreign keyboard layouts are not supported when using
keyboard macros, except for those keys listed in the Add Keyboard
Macro dialog for Japanese and Korean.

Note: Keyboard macros created in AKC cannot be used in MPC and vice
versa.

Building a Keyboard Macro

» To build a macro:

1. Click Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Click Add. The Add Keyboard Macro dialog appears.

3. Type a name for the macro in the Keyboard Macro Name field. This
name will appear in the Keyboard menu after it is created.

4. From the Hot-Key Combination field, select a keyboard combination
from the drop-down list. This allows you to execute the macro with a
predefined keystroke. Optional

5. Inthe Keys to Press drop-down list, select each key you would like to
use to emulate the keystrokes that will be used to perform the
command. Select the keys in the order by which they are to be
pressed. After each selection, select Add Key. As each key is
selected, it will appear in the Macro Sequence field and a Release
Key command will automatically be added after each selection.

6. To use the Send Text to Target function for the macro, click the
Construct Macro from Text button.
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7. For example, create a macro to close a window by selecting Left Ctrl
+ Esc. This will appear in the Macro Sequence box as follows:

Press Left Ctrl
Release Left Ctrl
Press Esc
Release Esc

8. Review the Macro Sequence field to be sure the macro sequence is
defined correctly.

a. Toremove a step in the sequence, select it and click Remove.

b. To change the order of steps in the sequence, click the step and
then click the up or down arrow buttons to reorder them as
needed.

9. Click OK to save the macro. Click Clear to clear all field and start
over. When you click OK, the Keyboard Macros dialog appears and
lists the new keyboard macro.

10. Click Close to close the Keyboard Macros dialog. The macro will now
appear on the Keyboard menu in the application. Select the new
macro on the menu to run it or use the keystrokes you assigned to
the macro.

Mimmize All Windows

|

Fun Macro

Add

Rermoue

Madify

Cloze

1]

Select a macro from the abowve list,
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Running a Keyboard Macro

Once you have created a keyboard macro, execute it using the keyboard
macro you assigned to it or by choosing it from the Keyboard menu.

Run a Macro from the Menu Bar

When you create a macro, it appears under the Keyboard menu.
Execute the keyboard macro by clicking on it in the Keyboard menu.

Canmedian  USE Prafile Sevizl |Kayboaard Vides Maouze Vikkual Madia Taaols View Windaw Help

s 1[N By “ mma e

Enter On-Screen Menu

Exit O n-Screen Menu Ezcape

Export Keyboard Macras.. .,
Immport Keyboard Macros. ..

Eeyboard Macros. ..

Minirnize All Windows ChrlHAlE-O

Run a Macro Using a Keyboard Combination

If you assigned a keyboard combination to a macro when building it, you
can execute the macro by pressing its assigned keystrokes. For
example, press the keys Ctrl+Alt+0 simultaneously to minimize all
windows on a Windows target server.

Modifying and Removing Keyboard Macros

» To modify a macro:

Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Choose the macro from among those listed.
Click Modify. The Add/Edit Macro dialog appears.
Make your changes.

Click OK.

ok w D

v

To remove a macro:

Choose Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

2. Choose the macro from among those listed.

3. Click Remove. The macro is deleted.
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Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro, used to reboot the
target computer, has been preprogrammed. Clicking on the

r--ﬂ_
Ctrl+Alt+Delete button in the toolbar sends this key sequence to the
server or to the KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the
command would first be intercepted by your own PC due to the structure
of the Windows operating system, instead of sending the key sequence
to the target server as intended.

Send Text to Target

You are able to paste text from the client machine to the target using the
Send Text to Target option on the Keyboard menu.

>

1.

To send text to a target:
Select Keyboard > Send Text to Target.

In the Send Text dialog, paste the text from the client machine in the
space provided.

If needed, select the "Target system is set to the US/International
keyboard layout" checkbox to specify that a US/International English
keyboard on the target.

Click OK.

Common Hot Key Exceptions for MPC

The following common hot key combinations are not sent to the target
system:

Hot Key Description
Combination

Ctrl+Alt+Delete  Reboots the computer. The sequence is sent to the

local system and the Windows® Security (Task
Manager, Shutdown, and so on) dialog is displayed.

Ctrl+Left Alt+M  Brings up the shortcut menu.

Print Scrn Treated locally and copies the page to the clipboard.

Alt+Tab Switches between open Windows on the local
machine.

Ctrl+Esc Opens the Start menu on the local machine.
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Hot Key Description
Combination
& Windows button + E launches Windows Explorer on

the local machine.

&L F Windows button + F is used to find files and folders
on the local machine.

24Mm Windows button + M minimizes all windows on the
local machine.

The following hot key combination exception affects both the remote
KVM target and local machine:

Hot Key Description
Combination
Alt + F4 Depending on the focus, this combination closes the

application window. Specifically, if the focus is on
the application, the application will close. If the focus
is on an application’s title bar in the target’s video,
that application closes.

Following are limitations to specific keyboards and hot key combinations:

Hot Key Description
Combination
Alt Gr Because of a limitation in the Java Runtime

Environment (JRE), Fedora, Linux, and Solaris
clients receive an invalid response from Alt Gr on
United Kingdom and US International language
keyboards.

Fedora, Linux, and Solaris do not pick up events
for the Alt Gr key combination for Java 1.5. Java
1.6 appears to improve on this, although the
keyPressed and keyReleased events for Alt Gr still
identify it as an “unknown key code”.

Further, a key pressed in combination with Alt Gr
(such as on the UK keyboard Alt Gr-4, which is the
Euro symboal), will only generate a keyTyped
followed by a keyReleased event for that value
without a keyPressed event. Java 1.6 improves
upon this by filling in the keyPressed event as well.

Alt+SysRqg+[key]  Since the SysRq keyboard stroke is used by some
operating systems as a print shortcut, the Alt +
SysRq + [key] combination is supported only as a
macro when using the device with RRC and MPC
to a Linux target.
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Common Hot Key Combinations for RRC

The following common hot key combinations are not sent to the target
system:

Hot Key Description
Combination

Ctrl+Alt+Delete  Reboots the computer. The sequence is sent to the
local system and the Windows® Security (Task
Manager, Shutdown, and so on) dialog is displayed.

Ctrl+Num Lock  This toggles the state of the Num Lock light if the
Num Lock state on the local system is not the same
as the target system.

Ctrl+Caps Lock  This toggles the state of the Caps Lock light if the
Caps Lock state of the local system is not the same
as the target system.

Ctrl+Scroll Lock  This toggles the state of the Scroll Lock light if the
Scroll Lock state of the local system is not the same
as the target system.

Ctrl+Left Alt+M  Brings up the shortcut menu.
Print Scrn Treated locally and copies the page to the clipboard.

Following are limitations to specific keyboards and hot key combinations:

Hot Key Description
Combination

Alt+SysRqg+[key]  Since the SysRq keyboard stroke is used by
some operating systems as a print shortcut, the
Alt + SysRq + [key] combination is supported
only as a macro when using the device with RRC
and MPC to a Linux target.
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Windows Key in MPC

When running MPC on a Windows® JRE 1.5.0_x platform, if you press
the Windows key & to display the Start menu, the Start menu will only
appear on the client machine. The key is not sent to the target device.

When running MPC on a Windows JRE 1.5.0_x platform, if you press the
Windows key, the Start menu appears on both the client and the target
devices. Use your mouse to manually close the Start menu if you do not
want to use.

Note that if you do not close the target device's Start menu properly, any
key that you touch on your keyboard (that has a Windows key
combination function) will send that command to the target device. For
example, if you press E, the target device will open a new Explorer
window. If you press D, all target windows will be minimized so you can
view the desktop. To close the Start menu on the target device, click the
Start button or click off of the Start menu.

Keyboard Type

Specifying a Keyboard Type in MPC

MPC will not autodetect the type of keyboard you use, so you must
specify your keyboard type to ensure accurate keyboard mapping.

> To specify a keyboard type:
1. Choose Tools > Options. The Options dialog will appear.

2. Click the Keyboard Type drop-down and select your keyboard type
from the list.

= US/International

= French (France)

= German (Germany)
= Japanese

= United Kingdom

= Korean (Korea)

= Belgian (Belgium)

= Norwegian (Norway)
= Danish (Denmark)

= Swedish (Sweden)

=  German (Switzerland)
= Hungarian (Hungary)

= Spanish (Spain)
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= Jtalian (Italy)
= Slovenian
3. Click OK.

Options

General | Advanced |

Show scroll borders,
Auto-Sunc mouse in two-cursar mode, (Mot supported for KX Generation 2]
Display single cursor mode instruckions,

Autornatic Color Calibration [For KX Generation 1 only)

Kevboard Type

UsfInternational -

U5/ International =
French [(France]
KdGerman [Garmany] btk ay
Japanesze

United Kingdorn

Kaorean [Kaoreal —
Belgian [Belgiur]
Maorwegian [(Morway) ﬂ

| (a]'4 || Cancel || Apply |

X
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Keyboard Limitations

Japanese Kanji Keyboards

For Kanji keyboards, when using DCIM-USBs and MPC, the remote

client cannot enter EISU mode by pressing the Caps Lock key (key#30).
Local port access is not affected. You can access the DCIM-USBs using

RRC or using the keyboard macro Shift + Caps Lock in MPC.

Slovenian Keyboards

The < key does not work on Slovenian keyboards due to a JRE

limitation.

Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key

Events for foreign-language keyboards configured using System

Preferences, Raritan recommends that you configure foreign keyboards

using the methods described in the following table.

Language
us Intl

French
German
Japanese
UK
Korean
Belgian
Norwegian
Danish
Swedish
Hungarian
Spanish
Italian
Slovenian

Portuguese

Configuration method
Default

Keyboard Indicator
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
Keyboard Indicator
Keyboard Indicator
Keyboard Indicator
Keyboard Indicator
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)
System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using

Gnome as a desktop environment.
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Video Properties

Refreshing the Screen

The Refresh Screen command forces a refresh of the video screen.
Video settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-sense Video Settings command automatically detects the
target server's video settings.

e The Calibrate Color command calibrates the video to enhance the
colors being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.

> To refresh the video settings, do one of the following:
e Choose Video > Refresh Screen or click the Refresh Screen button

:g in the toolbar.

If the video card you are using on the target uses custom software and
you are accessing the target through MPC or VKC, you may need to
change the maximum refresh rate of the monitor in order for the refresh
rate to take affect on the target.

> To adjust the monitor refresh rate:

In Windows®, select Display Properties > Settings > Advanced to
open the Plug and Play dialog.

Click on the Monitor tab.
Set the 'Screen refresh rate' to any rate above 100Hz.

Click OK and then OK again to apply the setting.

Auto-Sense Video Settings

The Auto-sense Video Settings command forces a re-sensing of the
video settings (resolution, refresh rate) and redraws the video screen.

» To automatically detect the video settings, do the following:
e Choose Video > Auto-sense Video Settings or click the Auto-Sense

=4
Video Settings button </ in the toolbar. A message stating that the
auto adjustment is in progress appears.
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Calibrating Color

Use the Calibrate Color command to optimize the color levels (hue,
brightness, saturation) of the transmitted video images. The color
settings are on a target server-basis.

Note: The Calibrate Color command applies to the current connection
only.

> To calibrate the color, do the following:
e Choose Video > Calibrate Color or click the Calibrate Color button

IEI in the toolbar. The target device screen updates its color
calibration.

Adjusting Video Settings

Use the Video Settings command to manually adjust the video settings.

» To change the video settings:
1. Choose Video > Video Settings or click the Video Settings button

% in the toolbar to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings
the effects are immediately visible:

a. Noise Filter

The device can filter out the electrical interference of video output
from graphics cards. This feature optimizes picture quality and
reduces bandwidth. Higher settings transmit variant pixels only if
a large color variation exists in comparison to the neighboring
pixels. However, setting the threshold too high can result in the
unintentional filtering of desired screen changes.

Lower settings transmit most pixel changes. Setting this
threshold too low can result in higher bandwidth use.

b. Brightness: Use this setting to adjust the brightness of the target
server display.

c. Brightness Red - Controls the brightness of the target server
display for the red signal.

d. Brightness Green - Controls the brightness of the green signal.

e. Brightness Blue - Controls the brightness of the blue signal.
f. Contrast Red - Controls the red signal contrast.

g. Contrast Green - Controls the green signal.

h. Contrast Blue - Controls the blue signal.
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If the video image looks extremely blurry or unfocused, the
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the Clock and Phase
settings. Doing so may result in lost or distorted video and you may
not be able to return to the previous state. Contact Raritan Technical
Support before making any changes.

i. Clock - Controls how quickly video pixels are displayed across
the video screen. Changes made to clock settings cause the
video image to stretch or shrink horizontally. Odd number
settings are recommended. Under most circumstances this
setting should not be changed because the autodetect is usually
quite accurate.

j-  Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

k. Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor.

I.  Vertical Offset - Controls the vertical positioning of the target
server display on your monitor.

Using Screenshot from Target

You are able to take a screenshot of a target server using the
Screenshot from Target server command. You can then save this
screenshot to a file location of your choosing as a bitmap, JPEG or PNG
file.

Note: The Screenshot from Target function is not available for the KX II-
101.

> To take a screenshot of the target server:
Select Video > Screenshot from Target or click the Screenshot from

b
Target button Eﬁ' on the toolbar.

2. Inthe Save dialog, choose the location to save the file, name the file,
and select a file format from the 'Files of type' drop-down.

10 =i=Raritan.



Chapter 4: Multi-Platform Client and Raritan Remote Client

3. Click Save to save the screenshot.

Saue jn: ([ My Downloads H |IE§|| |ﬁ| ||j| E:E: E:

File narne:

Files of type:

|j Mizcellaneous

B HTMLEackground.jpg

Servar Screenshntl

JPES irmage files -

| Save | | Cancel |

Changing the Maximum Refresh Rate

If the video card you are using on the target uses custom software and
you are accessing the target through MPC or VKC, you may need to
change the maximum refresh rate of the monitor in order for the refresh
rate to take affect on the target.

> To adjust the monitor refresh rate:

1. In Windows®, select Display Properties > Settings > Advanced to
open the Plug and Play dialog.

Click on the Monitor tab.

3. Set the 'Screen refresh rate' to any rate above 100Hz.

Click OK and then OK again to apply the setting.
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Mouse Options

Single Cursor Mode/Dual Cursor Mode

When remotely viewing a target server that uses a mouse, you will see
two mouse cursors on the remote desktop. When your mouse pointer
lies within the remote desktop area, mouse movements and clicks are
directly transmitted to the connected target server. The pointer,
generated by the operating system, slightly leads the target server's
mouse pointer during movement. This is a result of digital delay.

On fast LAN connections, you may want to disable the mouse pointer
and view only the target server's pointer. To toggle between these two
modes, choose Single/Double Cursor on the shortcut menu.

Alternatively, click the Single Mouse Pointer button b in the toolbar or
choose Mouse > Single Cursor Mode.

single Cursor Mode

Y'ou are about bo enter Single Cursor mode, “While you are if thiz mode,
thiz sofbware will have exclusive contral over the mouse and keyboard.

To et Single Cursor mode vou must press;

Ctrl + Alt + b, then S

W Show thiz dislog each time vou start Single Cursor mode.

k. | Cancel

When in Dual Cursor mode, press Ctrl+Left Alt+M and execute the
Synchronize Mouse shortcut to force realignment of the mouse cursors.
If the mouse cursors still remain out of sync, click the Auto-Sense Video

Settings button on the toolbar.

Note: When in Dual Cursor mode, if the dual mouse cursors are
synchronized but left idle for five minutes or longer, the target mouse
pointer will automatically align itself with the upper left corner of the
target window. Execute the Synchronize Mouse command to ensure
local and target mouse pointer alignment.

Single Mouse Cursor mode for Apple Mac target servers is supported for
MPC. Select Single Mouse Cursor on the Mouse menu in MPC to enter
this mode. While in this mode, the cursor will remain in the video window
for the Mac Server. To exit, open the shortcut menu and press S on the
keyboard.

e
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Mouse Synchronization Options

In addition to synchronizing mouse cursors or toggling between single
and dual cursor mode, the Mouse menu provides three options for
synching cursors when in dual cursor mode:

Menu option Description

Absolute When connected to selected Dominion devices and
targets with USB ports, the application will use
absolute coordinates to keep the cursors in sync.
See Absolute Mouse Mode for more information.

Intelligent Under certain conditions, the application can detect
the target mouse settings and synchronize the
mouse cursors accordingly, accelerating the mouse
on the target device. See Intelligent Mouse Mode
(on page 20) for more details.

Standard This is the standard mouse synchronization
algorithm. See Standard Mouse Mode (on page 19)
for more information.

Note: The Intelligent and Standard Mouse modes are available to all
device targets. Absolute Mouse mode are only available to Mac and
Windows® USB targets.

Automatic Mouse Synchronization

For Generation 1, devices When in Dual Cursor mode, the system will
automatically align the mouse cursors when the cursor is inactive for 15
seconds. Enable this feature by clicking the Synchronize Mouse button

in the toolbar or selecting Tools > Options and selecting the "Auto-
Sync mouse in two-cursor mode" checkbox.

Automatic Mouse Synchronization is available for Generation 2 devices
when:

e A new connection is established
e Auto-sense is enabled
e Color calibration is enabled

Enable this feature in Generation 2 devices by clicking the Synchronize

Mouse button ”k in the toolbar or selecting Mouse > Synchronize
Mouse.
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Absolute Mouse Mode

In this mode, absolute coordinates are used to keep the client and target
cursors in sync, even when the target mouse is set to a different
acceleration or speed. This mode is supported on servers with USB
ports.

» To enter absolute mouse mode:
e Choose Mouse > Absolute.

Note: The absolute mouse setting requires a USB target system and is
the recommended mouse setting for KX 11-101.

Note: Absolute Mouse Synchronization is available for use with the
virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB)
only.
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Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing mouse
acceleration on the target. In this mode, the mouse cursor does a
“dance” in the top left corner of the screen and calculates the
acceleration. For this mode to work properly, certain conditions must be
met.

» To enter intelligent mouse mode:
e Choose Mouse > Intelligent.

Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the
Mouse menu, automatically synchronizes mouse cursors during
moments of inactivity. For this to work properly, however, the following
conditions must be met:

e The active desktop should be disabled on the target.
¢ No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of
the target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e Advanced mouse properties such as “Enhanced pointer precision” or
“Snap mouse to default button in dialogs” should be disabled.

e Choose “Best Possible Video Mode” in the Video Settings window.

e The edges of the target video should be clearly visible (that is, a
black border should be visible between the target desktop and the
remote KVM console window when you scroll to an edge of the
target video image).

e When using the intelligent mouse synchronization function, having a
file icon or folder icon located in the upper left corner of your desktop
may cause the function not to work properly. To be sure to avoid any
problems with this function, Raritan recommends you do not have file
icons or folder icons in the upper left corner of your desktop.

After autosensing the target video, manually initiate mouse
synchronization by clicking the Synchronize Mouse button on the toolbar.
This also applies when the resolution of the target changes if the mouse
cursors start to desync from each other.

If intelligent mouse synchronization fails, this mode will revert to standard
mouse synchronization behavior.
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Please note that mouse configurations will vary on different target
operating systems. Consult your OS guidelines for further details. Also
note that intelligent mouse synchronization does not work with UNIX
targets.

Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization
algorithm using relative mouse positions. Standard Mouse mode requires
that mouse acceleration is disabled and other mouse parameters are set
correctly in order for the client and server mouse to stay synchronized.
Standard Mouse mode is the default.

» To enter Standard Mouse mode:
e Choose Mouse > Standard.

Connection and Video Properties

Dynamic video compression algorithms maintain KVM console usability
under varying bandwidth constraints. The device optimizes KVM output
not only for LAN use but also for WAN and dial-up use. These devices
can also control color depth and limit video output, offering an optimal
balance between video quality and system responsiveness for any
bandwidth constraint.

The parameters discussed in this section can be optimized in the
Connection Properties dialog and Video Settings dialog. Connection
properties are saved across subsequent connections to generation 2
devices once they are set and saved.
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MPC Connection Properties - Generation 1 Devices

» To adjust connection properties:
Choose Connection > Properties or click the Connection Properties

button E‘ in the toolbar. Update the settings in the Compression

tab.
Proparties Dialopg X |
Compression |
Connecion Speed: |ﬁ;l.+'f-:| Cretect -
Color Depth: |Auto Select Color -
|:| Progressive Update
|:| Internet Flow Contral
Srmooth (.2 '
RBE LR s High
Frarmes per second
W 5 fps 10 fp= 20 Fps
| la] 4 | | Cancel | | Apple |

2. Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

= 1.5mb (Max DSL/T1)

= 1mb (Fast DSL/T1)

» 512 kb (Medium DSL/T1)
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= 384 kb (Slow DSL/T1)
= 256 kb (Cable)

= 128 kb (Dual ISDN)

= 56 kb (ISP Modem)

= 33 kb (Fast Modem)

= 24 kb (Slow Modem)
Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-hit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics
cards. Attempting to transmit such high color depths wastes network
bandwidth.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).

Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

Select "Frames per second". This setting instructs MPC on how often
to redraw the video display of the target. This only affects the client
display behavior and has no bearing on the data rate of the video
being sent to the client. Setting this option higher makes the video
appear smoother but also requires more processing power.

Click OK to create the connection profile.
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MPC Connection Properties - Generation 2 Devices

>

To adjust connection properties:
Choose Connection > Properties or click the Connection Properties

button E‘“ in the toolbar. Update the settings in the Compression
tab.

Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

= Auto Detect

= 1G Ethernet

= 100mb Ethernet

= 10mb Ethernet

* 1.5mb (Max DSL/T1)
= 1mb (Fast DSL/T1)

= 512 kb (Medium DSL/T1)
= 384 kb (Slow DSL/T1)
= 256 kb (Cable)

= 128 kb (Dual ISDN)

= 56 kb (ISP Modem)

= 33 kb (Fast Modem)

= 24 kb (Slow Modem)

Note: KX 1I-101 does not support 1G Ethernet.

Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-bit Color
= 4-bit Gray
= 3-bit Gray
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= 2-bit Gray
= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics
cards. Attempting to transmit such high color depths wastes network
bandwidth.

Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

5. Click OK to create the connection profile.

Properties Dialog E'
Cormpression |
Connection Speed: |Auto Detect |
Color Depth: [15-bit RGE Color -
Emoothing! I\_/} " Low
| Caf | | Cancel | | Apply |
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RRC Connection Properties

>

Modify Connection

To adjust connection properties:
Choose Connection > Properties or click the Connection Properties

button E‘ in the toolbar. Update the settings in the Compression
tab.

Compression i

Connection Speed:

Color Depth: !.ﬁ.utl:u Select Color :J
r Fiogiessve U pdale
I Interrnel Flow Corbul

S mioothing Off — | b 2

o |

Cancel J doply

Set the Connection Speed.

Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. Devices can automatically
detect available bandwidth and not limit bandwidth use. However,
you can also adjust this usage according to your needs. Depending
on the Raritan device in use, different options may be available:

Auto Detect

1G Ethernet

100mb Ethernet

10mb Ethernet

1.5mb (Max DSL/T1)
1mb (Fast DSL/T1)

512 kb (Medium DSL/T1)
384 kb (Slow DSL/T1)
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= 256 kb (Cable)

= 128 kb (Dual ISDN)
= 56 kb (ISP Modem)
= 33 kb (Fast Modem)
= 24 kb (Slow Modem)
Set the Color Depth.

Devices can dynamically adapt the color depth transmitted to remote
users in order to maximize usability in all bandwidths. Select from
among the options in the drop-down list. Depending on the Raritan
device in use, different options may be available:

= 15-bit RGB Color
= 8-bit RGB Color

= 4-hit Color
= 4-bit Gray
= 3-bit Gray
= 2-bit Gray

= Black and White

Important: For most administrative tasks (server monitoring,
reconfiguring, and so forth), administrators do not require the full 24-
bit or 32-bit color spectrum made available by most video graphics
cards. Attempting to transmit such high color depths wastes network
bandwidth.

Select Progressive Update to increase the usability in constrained
bandwidth environments. When Progressive Update is enabled, the
device initially sends an image of the remote desktop at lower color
depths. Higher color depth images are provided as the bandwidth
allows.

Note: When Color Depth is set to Auto Select Color (default),
Progressive Update is automatic. The device will enable/disable
Progressive Update as required, disabling it for fast connections and
enabling it for slow connections.

Selecting the Internet Flow Control checkbox ensures that packets
transmitted by the device are received and reconstructed by the
client application in the correct order. This is useful when using a
device over an unpredictable public WAN (particularly in international
scenarios).
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Use the slider to select the desired level of video Smoothing (15-bit
mode only). The level determines how aggressively to blend page
regions with small color variation into a single, smooth color.
Smoothing improves the appearance of the target video by reducing
the video noise that is displayed.

Click OK to create the connection profile.

Video Settings

Video Settings - Generation 1 Devices

Following are instructions on configuring video settings for Generation 1
devices. These settings can be refreshed using the Color Calibration
command by manually forcing a device to autodetect the video settings
(on the Video menu, click Auto-sense Video Settings) or by changing the
settings in this page. After you change a value, click Apply to test the
setting. See Color Calibration (on page 128).

> To configure Generation 1 devices:

1.

Choose Video > Video Settings or click the Video Settings button
@ in the toolbar to open the Settings dialog.

Adjust the following settings as required:
a. Noise Filter

Devices can filter out the electrical interference of video output
from graphics cards. This feature optimizes picture quality and
reduces bandwidth. Higher settings transmit variant pixels only if
a large color variation exists in comparison to the neighboring
pixels. However, setting the threshold too high can result in the
unintentional filtering of desired page changes. Lower settings
transmit most pixel changes. Setting this threshold too low can
result in higher bandwidth use.

Note: The default Noise Filter is 4. Raritan recommends that you
lower this value to 0 (zero). Although higher settings will stop the
needless transmission of false color variations, true and intentional
small changes to a video image may not be transmitted.

b. PLL Settings

If the video image looks extremely blurry or unfocused, the PLL
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the clock and phase
settings since doing so may result in lost or distorted video and you
may not be able to return to the previous state. Contact Raritan
Technical Support before making any changes.
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Clock - Controls how quickly video pixels are displayed across
the video page. Changes made to clock settings cause the video
image to stretch or shrink horizontally. Odd number settings are
recommended. Under most circumstances this setting should not
be changed because the autodetect is usually quite accurate.

Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

Color Settings -Gain control can be thought of as contrast
adjustment. Offset control can be thought of as brightness
adjustment.

Select the Link Color Controls checkbox to make all slide
adjusters move in unison when any one option is moved.

Red Gain - Controls the amplification of the red signal.
Red Offset - Controls the bias of the red signal.

Green Gain - Controls the amplification of the green signal.
Green Offset - Controls the bias of the green signal.

Blue Gain - Controls the amplification of the blue signal.
Blue Offset - Controls the bias of the blue signal.

Color Settings - Gain control can be thought of as contrast
adjustment. Offset control can be thought of as brightness
adjustment.

Select the Link Color Controls checkbox to make all slide
adjusters move in unison when any one option is moved.

Red Gain - Controls the amplification of the red signal.
Red Offset - Controls the bias of the red signal.

Green Gain - Controls the amplification of the green signal.
Green Offset - Controls the bias of the green signal.

Blue Gain - Controls the amplification of the blue signal.

Blue Offset - Controls the bias of the blue signal.

3. Select the video sensing mode:

Best possible video mode - Devices will perform the full Auto
Sense process when switching targets or target resolutions.
Selecting this option calibrates the video for the best image

quality.

Quick sense video mode - Selecting this option will cause the
device to use a quick video Auto Sense in order to show the
target's video sooner. This option is especially useful for entering
a target server's BIOS configuration right after a reboot.
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4. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.

Note: Some Sun background screens, such as screens with very dark
borders, may not center precisely on certain Sun servers. Use a different
background or place a lighter colored icon in the upper left corner of the

page.

Settings E|

Wideo Setting |

Moise Filter

Moize Filter: ’EE : {\_/I

PLL Settings

Clock: 1,3445 Phaze: ZZE
Color Settings

Brightness: 645 L
L

Fed Contrazt: 1z

Green Contrast: iz2s

e Tc e

Blue Contrast: 128

[] Link color Contrals

Video Senzing

@ Best possible video mode
) Guick sense video mode

| (o148 || Cancel || apply ‘

Video Settings - Generation 2 Devices

> To configure Generation 1 devices:
Choose Video > Video Settings or click the Video Settings button

% in the toolbar to open the Settings dialog.
2. Adjust the following settings as required:
a. Noise Filter

Devices can filter out the electrical interference of video output
from graphics cards. This feature optimizes picture quality and
reduces bandwidth. Higher settings transmit variant pixels only if
a large color variation exists in comparison to the neighboring
pixels. However, setting the threshold too high can result in the
unintentional filtering of desired page changes. Lower settings
transmit most pixel changes. Setting this threshold too low can
result in higher bandwidth use.
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Note: The default Noise Filter is 4. Raritan recommends that you
lower this value to 0 (zero). Although higher settings will stop the
needless transmission of false color variations, true and intentional
small changes to a video image may not be transmitted.

b. PLL Settings

If the video image looks extremely blurry or unfocused, the PLL
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the clock and phase
settings since doing so may result in lost or distorted video and you
may not be able to return to the previous state. Contact Raritan
Technical Support before making any changes.

= Clock - Controls how quickly video pixels are displayed across
the video page. Changes made to clock settings cause the video
image to stretch or shrink horizontally. Odd number settings are
recommended. Under most circumstances this setting should not
be changed because the autodetect is usually quite accurate.

= Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

a. Color Settings

These settings control the brightness, contrast, and positioning of
the target server display. Select the Link Color Controls checkbox
to make all slide adjusters move in unison when any one option

is moved.

= Brightness Red - Controls the brightness of the red signal; range
is0-127.

= Brightness Green - Controls the brightness of the green signal,
range is 0 - 127.

= Brightness Blue - Controls the brightness of the blue signal;
range is 0 - 127.

= Contrast Red - Controls the red signal contrast; range is 0 - 255.

= Contrast Green - Controls the green signal contrast; range is 0 -
255.

= Contrast Blue - Controls the blue signal contrast; range is O -
255.

= Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor; range is 0 - 512.

= Vertical Offset - Controls the vertical positioning of the target
server display on your monitor; range is 0 - 128.

=i=Raritan.



i

Raritan.

Chapter 4: Multi-Platform Client and Raritan Remote Client

To preview the change prior to making the selection, check the
Preview checkbox.

Check the Automatic Color Calibration checkbox to enable this
feature.

Select the video sensing mode:

= Best possible video mode - Devices will perform the full Auto
Sense process when switching targets or target resolutions.
Selecting this option calibrates the video for the best image
quality.

Quick sense video mode - Selecting this option will cause the device
to use a quick video Auto Sense in order to show the target's video
sooner. This option is especially useful for entering a target server's
BIOS configuration right after a reboot.

Select the video sensing mode:

= Best possible video mode - Devices will perform the full Auto
Sense process when switching targets or target resolutions.
Selecting this option calibrates the video for the best image
quality.

= Quick sense video mode - Selecting this option will cause the
device to use a quick video Auto Sense in order to show the
target's video sooner. This option is especially useful for entering
a target server's BIOS configuration right after a reboot.
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8. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.

Settings §|
Video Setking |
Moise Filber
I . ]
Maize Filkar: | 2
PLL Settimgz
Clock: 1,0565 Phaze: 155

Color Settings

T
Brightness Red: 405 L L 1

Brightness Grasn: 605 L [} 1

Erightmess Blus: SDE L [} 1

Contrast Red: 139 L e, 1

Contrast Green: i7s E [} 1
Contrast Blue: 1?55 L [

Horizontal Offset: 212 r lj:l

Wertical Offzet: ZZE IZC} 1

I:l Preuiew

Autornatic Color Calibration

Wideo Sensing

(@ Best pozsible video mode

) Quick sense video mode

| QK || Cancel || Apply |

Port Access Page Sort

» To change the display sort order:

e Click the column heading by which you want to sort. The list of KVM
target servers is sorted by that column.

Color Calibration

Use the Color Calibration command if the color levels (hue, brightness,
and saturation) of the transmitted video images do not seem accurate.
The device color settings remain the same when switching from one
target KVM server to another, so you can perform color calibration once
to affect all connected target servers.

1. Open aremote KVM connection to any server running a graphical
user interface.

2. Ensure that a solid white color covers approximately 15% or more of
the target server's desktop.
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TIP: Open Microsoft Notepad and maximize the window.
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On the Video menu, choose Calibrate Color or click the Color

Calibration button .E. on the toolbar. The target device page will
update its calibration.

Tip: You can also specify automatic color calibration using Tools >
Options. See General Options in MPC (on page 134)for more
information.
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Help Options

This menu command provides version information about the Virtual KVM
Client, in case you require assistance from Raritan Technical Support.

> To obtain version information:
e Choose Help > About Raritan Multi-Platform Client.

Use the Copy to Clipboard button to copy the information contained in
the dialog to a clipboard file so it can be accessed later (if needed).

About Raritan Multi-Platform Client

== Raritan.

Raritan Multi-Platfarrn Client

Version: £,0,0,1,13_ 2003090222100
WM Wersion: 1.3.0_10
M Vendor: Sun Microsysterns Inc,
Operating Systern: Windaows XP

Cperating Systern Wersion: 5.1
Systern Architecture: =56

Copyright () 2004 - 2008 Raritan Cormputer, Inc All rights rezerved.

| (o] 4 || Copy to Clipboard
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Smart Cards (VKC and MPC)

Using the KX 11 2.1.10 or later, you are able to mount a smart card reader
onto a target server to support smart card authentication and related
applications. For a list of supported smart cards, smart card readers, and
additional system requirements, see Supported and Unsupported Smart
Card Readers and Minimum System Requirements.

Note: AKC does not support smart cards.

When accessing a server remotely, you will have the opportunity to
select an attached smart card reader and mount it onto the server. Smart
card authentication is used with the target server, it is not used to log into
the device. Therefore, changes to smart card PIN and credentials do not
require updates to device accounts. When mounted onto the target
server, the card reader and smart card will cause the server to behave
as if they had been directly attached. Removal of the smart card or smart
card reader will cause the user session to be locked or you will be logged
out depending on how the card removal policy has been setup on the
target server OS. When the KVM session is terminated, either because it
has been closed or because you switch to a new target, the smart card
reader will be automatically unmounted from the target server.

When PC-Share mode is enabled on the device, multiple users can
share access to a target server. However, when a smart card reader is
connected to a target, the device will enforce privacy regardless of the
PC-Share mode setting. In addition, if you join a shared session on a
target server, the smart card reader mounting will be disabled until
exclusive access to the target server becomes available.

After a KVM session is established to the target server, a Smart Card
menu and button are available in the Virtual KVM Client and Multi-
Platform Client. Once the menu is opened or the Smart Card button is
selected, the smart card readers that have been detected as attached to
the remote client are displayed. From this dialog you can attach
additional smart card readers, refresh the list of smart card readers
attached to the target, and detach smart card readers. You are also able
to remove or reinsert a smart card. This function can be used to provide
notification to a target server OS that requires a removal/reinsertion in
order to display the appropriate login dialog. Using this function allows
the notification to be sent to a single target without affecting other active
KVM sessions.

» To mount a smart card reader:
Click the Smart Card menu and then select Smart Card Reader.

Alternatively, click the Smart Card button \* in the toolbar.

2. Select the smart card reader from the Select Smart Card Reader
dialog.

3. Click Mount.
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4. A progress dialog will the open. Check the 'Mount selected card
reader automatically on connection to targets' checkbox to mount the
smart card reader automatically the next time you connect to a
target. Click OK to begin the mounting process.

» To update the smart card in the Select Smart Card Reader
dialog:

e Click Refresh List if a new smart card reader has been attached to
the client PC.

» To send smart card remove and reinsert notifications to the
target:

e Select the smart card reader that is currently mounted and click the
Remove/Reinsert button.

» To unmount a smart card reader:

e Select the smart card reader to be unmounted and click the Unmount
button.

Smart card reader mounting is also supported from the Local Console.
See Local Console Smart Card Access.

B8 bominion-kx2_port3 - Virtual kKvM Client L =101 x|
Connection  UISE Profile board Video Mouse Tools View Virtual Media | SmartCard

5 [58] ]  3]  [ mees |

Select Card Reader

Card Re-ader Currently Mounted

rmcrwnemmmmumnmmm

o Alse, if you intend on a, do so before g Card Read:
Refresh List l Aemove/Reincert Card I
't’mh;} @ 0| [ Ay nsm
| Double Mouse Mod= [= Twom [caes [achr
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Administrative Functions

i

Raritan.

Although your device provides a remote interface to administrative
functions through the device manager, the client provides an interface to
frequently-used administrative functions directly from its own interface.
When logged into a device as an administrator, you can perform the
administrative tasks discussed here.

Note: Most of the commands discussed here are available in both the
Tools menu and in the shortcut menu that appears when you right-click
the device in the Navigator panel.

Note to MPC Users

MPC assigns users one of two permissions: Administrator or User. You
must belong to the Administrator group in order to receive administrative
permissions. It is only when the user belongs to the Administrator group
that they have access to backup, restore, and restart functions. This is
true regardless of any device user group settings that may be applied to
the user.
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General Options

General Options in MPC

The Options available in the Tools menu provide options that allow you
to customize scroll borders, mouse mode settings, Single Cursor mode,
auto color calibration, hot key configuration, keyboard type, broadcast
port, and logging.

» To configure the general options in MPC:

1. Choose Tools > Options. The Options dialog appears and displays
the General tab by default.

0 ptians E|

General Advanced

Show scroll borders,

Auto-Syenc mouse in two-cursor mode. (Mot supparted for KX Generation 2]
Display single cursor mode instructions,

Automatic Color Calibratian (For k¥ Generation 1 only)

Keyboard Type
Us/International -

Keyboard Shortcut Menu Hotkey

Chri+alt+n | e

| OK, || Cancel || apply |

2. Select the "Show scroll borders" checkbox to view the thin scroll
borders designating the autoscroll area.

3. Select the "Auto-Sync mouse in two-cursor mode" checkbox to
enable automatic mouse synchronization.

4. If you select the "Display single cursor mode instructions" checkbox,
the Single Cursor Mode dialog will appear each time Single Cursor is
enabled in the application. See Mouse Options (on page 112) for
more information.

5. Select the Automatic Color Calibration checkbox to enable automatic
color calibration. This option is available for KX generation 1 (G1)
only.
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Select the Keyboard Type from the drop-down list (depending on the

Raritan device in use, different options may be available):
= US/International

= French (France)

= German (Germany)

= Japanese

= United Kingdom

= Korean (Korea)

= Belgian (Belgium)

= Norwegian (Norway)
= Danish (Denmark)

= Swedish (Sweden)

=  German (Switzerland)
= Hungarian (Hungary)
= Spanish (Spain)

= |talian (Italy)

=  Slovenian

From the Keyboard Shortcut Menu HotKey drop-down, select the key
combination you would like to use to invoke the Shortcut Menu (on

page 96).
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8. For advanced options, open the Advanced tab.

Oiptions

General Advanced |

S

KM Switch OSUI Hot Key
@ Scrall Lack + Scrall Lack
() Mum Lock + Hum Lock

) Gaps Lotk + Caps Lock

Broadcast Port

Port |S000

IPwE Metworking

I:l Enable IPvE Metworking

Logging

El Enable Lagging

| [=1.3 || Cancel || Apply |

10.

11.

12.

13.
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From the KVM Switch OSUI Hot Key section, select the hot key to
use when switching between target server displays.

For the Broadcast Port, type the broadcast port number in the Port
field if you want to use a port other then 5000.

Select the Enable IPv6 Networking checkbox for IPv6 to enable IPv4
and IPv6 dual-stack operation.

Note: KSX Il and KX 11-101 devices are not IPv6 enabled, so this
section will not apply to those devices.

Select the Enable Logging checkbox only if directed to by Technical
Support. This option creates a log file in your home directory.

Click OK when finished. Click Apply any time while making
selections to apply it.
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General Options in RRC

The Options available in the Tools menu provide options that allow you
to customize scroll borders, mouse mode settings, single cursor mode,
auto color calibration, hot key configuration, keyboard type, broadcast
port, and logging.

» To configure the general options in RRC:
1. In RRC, choose Tools > Options to open the Options dialog.

X

Qptions

General ]

[ Skow seroll barders,
¥ Avto-Syac mouse in bwo curscr moce:
¥ Dizplay single curzor mode insuctions,

¥ &to-Color Czlibratian,

X Switzh OSU| Hat Kev

& Scoll Lozk + Scroll Lock
" Mum Lock + Murn Lock
" Caps Lock + Caps Lock

K.epboard Shorlcut b enu Hotk ey
Hotkey | Cirl + Ak + b '1

- Broadcasz: Port

Port | 500C

~ Logaing-
[” Erable Logging

(LS | Cancel

2. Select the "Show scroll borders" checkbox to view the thin scroll

borders that show the Auto-Scroll area.

3. Select the "Auto-Sync mouse in two cursor mode" checkbox to

enable Automatic Mouse Synchronization.
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4. If you select the "Display single cursor mode instructions" checkbox
the Single Cursor Mode dialog will open each time Single Cursor is
enabled in the application (see Mouse Options (on page 112) for
more information).

Select Auto-Color Calibration to enable it.

In the KVM Switch OSUI Hot Key panel, select the radio button next
to the hot key combination you would like to use.

7. Inthe Keyboard Type panel, click on the drop-down arrow and click
on your keyboard choice.

8. Inthe Broadcast Port panel, type the broadcast port number in the
Port field.

9. Click OK when finished. Click Apply any time during your selection to
apply an option you have chosen.

Upgrading Device Firmware

> To update a device's firmware:

Connect to the device by highlighting the device's icon in the
Navigator.

2. Click Tools > Update > Update Device to perform firmware
upgrades.

3. You will be prompted to locate a Raritan firmware distribution file
(*.RFP format), which can be found on the Raritan website
(www.raritan.com) on the Firmware Upgrades page.

Ensure that you read all instructions included in Firmware Upgrade
Guide carefully before upgrading a device.

Note: Copy the firmware update file on the Raritan website to a local
machine before uploading. Do not load the file from a network drive.

Clearing ActiveX Controls

After upgrading the device to a newer firmware version, if you still see
the previous RRC version, please use the steps below to clear the
ActiveX cache.

» To remove TeleControl class files:

1. InInternet Explorer 7, click Tools > Manage Addons > Enable or
Disable Addons.

2. Select "Download ActiveX control 32 bit" from the Show drop down.
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Select TeleControl class and then click Delete.
Close any open sessions of IE7.

5. Open a new IE7 session and go to Raritan's website to download the
newest version of RRC.

Changing a Password

> To update your password
Connect to a target by selecting it in the Navigator.

2. Highlight the target's icon in the Navigator and then choose Tools >
Update > User Password. The Change Password dialog appears.

Change Password 3 x|

~Info

2ld Pazsword |**********

Mew Password |

Confirm Mew Password |

| Ok | | Cancel |

Type your current password in the Old Password field.
Type the new password in the New Password field.
Retype the password in the Confirm New Password field.
When finished, click OK.

o 0k~ w

Restarting a Device

» To restart a device:
1. Select the device in the Navigator.

2. On the Tools menu, choose Restart Device.

Backup and Restore Functions

In addition to using backup and restore for business continuity purposes,
you can use this feature as a time-saving mechanism. For instance, you
can quickly provide access from another Dominion device to your team
by backing up the user configuration settings from the device in use and
restoring those configurations to the new Dominion device.
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Backing Up and Restoring an Entire System (Dominion KX Il only)

» To backup the entire system (both user and device
configuration):

1. Choose Tools > Backup All. The Backup All dialog appears.
Backupal
Sawve in: ||j My Docurnents - | Eﬂ ﬁ ||j

Y BUOZ0907.p [ ki-2-0-0-1-4938.fp [ ] KX-2-0-0-1-5045.rfp

Y evtlag.txt [ ki-2-0-0-1-4342.fp [ ] KX-2-0-0-1-5077.rfp
Y JavaConsole.txt [ ku-2-0-0-1-4345.fp [ Ki-2-0-0-1-5094.rfp
Y JavaConzola2txt  [) KH-2-0-0-1-4990.fp [ ] K¥-2-0-0-2-5122.¢p

YlavaConzola3itxt [ ) K¥-2-0-0-1-5006./fp [ ) K¥-2-0-0-2-5129.rp

Y K#-2-0-0-0-5146.fp [ ) K¥-2-0-0-1-5038.rfp [ ] K¥-2-0-0-2-5135.rfp

File name:  [MPCO315.fp

Files of type: |RFP Files (*.+rfp) - |

Sauve || [Cancel |

2. Navigate to the desired directory and give the backup file a name.
(Backup files have an extension of .rfp).

3. Click Save. A message is displayed confirming the successful
backup.

4. Click OK.
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Note: Backups are always complete system backups. Restores can be
complete or partial depending on your selection.

» To restore:

1. Choose Tools > Restore Configuration. The Restore Device
Configuration dialog appears.

Restore Device Configuration

Laak

in: ||j My Docurnents e | \EI \@I |§_|

x|

=

2.
0.rfp
2.Hp
0.Hp
1.+p

4.rfp

)

[ kx-z-0-0-2-5265.ifp [ ) K#-2-0-0-2-5324.fp [ ] U-BOOT-18-22.1fp

[y kx-z-0-0-2-5274.fp [ ] Ki-2-0-0-2-5333.1p
[ ku-2-0-0-2-5279.fp  [) KH-2-0-0-2-5343.p
[ kx-2-0-0-2-5282.fp [ ] K¥-2-0-0-2-5351.rfp

[ kx-z-0-0-2-5288.p |[ ] MPCO315.fp

[y kx-z-0-0-2-5310.fp [ ) Tast.fp

File name:  [MPCO315.p

Filez of type: | RFP Files (*.Hp]

Open || Cancel |

2. Navigate to the appropriate directory and select the backup file.

Click Open. The Restore Packages dialog appears.

Select the type of restore you want to run:

a.

Full Restore - A complete restore of the entire system; generally
used for traditional backup and restore purposes.

Protected Restore - Everything is restored except device-specific
information such as serial number, MAC Address, IP Address,
name, port names, etc. With this option, you can setup one
Dominion device and copy the configuration to multiple Dominion
devices.

Custom Restore - The following options are available:

User and Group Restore - This option includes only user and
group information. Use this option to quickly setup users on a
different Dominion device. This option restores the certificate and
the private key file that were currently active when the backup
occurred.
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= Device Settings Restore- This option includes only device
settings such as power associations, USB profiles, blade chassis
related configuration parameters, and Port Group assignments.
Use this option to quickly copy the device information.

5. Click OK.

Backing Up and Restoring a Device Configuration

» To back up adevice:

Download the device configuration to your local computer by
selecting the device in the Navigator.

2. Click Tools > Save Device Configuration.

> To restore adevice configuration:

Upload the archived device configuration by selecting the device in
the Navigator.

2. Click Tools > Restore Device Configuration.

Note that device configuration is specific to a particular device and
should not be restored to another device.

Backing Up and Restoring a User Configuration

» To back up adevice's user configuration:
Select the device in the Navigator.

2. Click Tools > Save User Configuration.

> To restore a user configuration:

Upload a device's archived user configuration by selecting the device
in the Navigator.

2. Click Tools > Restore User Configuration.

Note: Use these commands to easily transfer user and group information
from one device to another.

Log Files

Activity Log
> To download a detailed activity log for review or

troubleshooting:
1. Select the device in the Navigator.
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2. Onthe Tools menu, choose Save Activity Log.

Diagnostic Log (excluding KX II)

» To download a detailed diagnostic log for reporting or analysis:
1. Select the device in the Navigator.

2. Onthe Tools menu, choose Save Diagnostic Log.

Broadcast Port

By default, all Raritan devices send data through Port 5000. This network
traffic includes the autodiscovery broadcast. In the case of conflicts or to
deal with firewall issues, you may want to use a different broadcast port.

MPC Broadcast Port

» To change the autodiscovery port from the default broadcast
port of 5000:

Select the device in the Navigator.
2. Choose Tools > Options. The Options dialog appears.

On the Advanced tab, type the new port number in the Port field of
the Broadcast Port section and then click OK.
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Note: If you want the application to autodiscover Raritan devices on the
new broadcast port you entered in the Options dialog, you must
configure all Raritan devices to use the new port number.

O'ptians [g|
General Advanced |

KWM Switch ©3UI Hot Key

@ 3croll Lock + Scrall Lock
() Murn Lock + Hurm Lock

O Caps Lock + Caps Lock

Broadcast Port

Port [S000

IPvE Metworking

I:‘ Enable IPYE Metworking

Logging

D Enable Logging

| DK || Cancel || Apply |

RRC Broadcast Port

» To change the autodiscovery port from the default broadcast
port of 5000:

1. Select the device in the Navigator.
2. On the Tools menu, choose Options. The Options dialog appears.

3. Inthe Broadcast Port field, type the new port number in the Port field
and then click OK.
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Note: If you want the application to autodiscover Raritan devices on the

new broadcast port you entered in the Options window, you must

configure all Raritan devices to use the new port number.

=i=Raritan.
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[~ Skow zcroll barders.
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0 Scmll Lozk + Scroll Lack
£ Mum Lock + Mum Lock
" Caps Losk + Caps Lock

i~ F.eyboard Shaorlcut beenu Hotkey
Huotkey | Chel + Al + b *]

- Broadcas: Port

Part | 500

Logging
[~ Erable Logging

X

(LS | Cancel

If you do not want to use the broadcasting function at all, it can be turned

off.

P To turn off broadcasting:
1. In RRC, select View > Show.

2. Deselect the Discovered Devices checkbox.
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Broadcasting will be turned off and the devices will not be displayed
in the navigator.

Connection USE Profile Zerial Keyboard Wideo Mousze Vidual Media Tools |Wiew Window Help

il

Epal [z @ ==0me e

¥ Standard Toalbar

¥ Connected Server(s] Toolbar
¥ Status Bar

¥l Nauigataor

¥ Message

Show M ¥ Dizcovered Davices
Sart ]

[J Unassigned Channels

Target Screen Resolution M Tools

[0 Scale wideo |

Remote Power Management

AC power to associated targets can be managed when used with a
properly configured Raritan Remote Power Control Strip (RPC strip).
Three options are available when performing remote target power
management:

e Power On
e Power Off
e Cycle Power

» To change the power status of a target:
1. Select the device in the Navigator.

2. Onthe Tools menu, choose Power On, Power Off, or Cycle Power.

Import/Export Keyboard Macro Definitions

The functions contained in this section describe how to exchange
keyboard macro definitions between users using import and export
functions. The primary purpose of this function is to exchange data
between copies of the client application.

Import/Export MPC Keyboard Macros

» To import MPC macros:

Choose Tools > Import Macros to open the Import Macros dialog. By
default, the macro will exist on the desktop.

2. Click on the macro file and click Open to import the macro.

a. If too many macros are found in the file, an error message will be
displayed and the import will terminate once OK is selected.

b. If the import fails, an error dialog will appear and will display a
message regarding why the import failed. Select OK to continue
the import without importing the macros that cannot be imported.
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Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Deselect All options.

Click OK and the import will begin.

a.

If a duplicate macro is found, the Import Macros dialog will
appear. Do one of the following:

Click Yes to replace the existing macro with the imported
version.

Click Yes to All to replace the currently selected and any
other duplicate macros that are found.

Click No to keep the original macro and proceed to the next
macro

Click No to All keep the original macro and proceed to the
next macro. Any other duplicates that are found will be
skipped as well.

Click Cancel to stop the import.

Alternatively, click Rename to rename the macro and import
it. If Rename is selected, the Rename Macro dialog will
appear. Enter a new name for the macro in the field and click
OK. The dialog will close and the process will proceed. If the
name that is entered is a duplicate of a macro, an alert will
appear and you will be required to enter another name for
the macro.

If during the import process the number of allowed, imported
macros is exceeded, a dialog will appear. Click OK to attempt to
continue importing macros or click Cancel to stop the import
process.
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The macros will then be imported. If a macro is imported that contains a
hot key that already exists, the hot key for the imported macro will be
discarded.

» To export MPC macros:

1. Choose Tools > Export Macros to open the Select Keyboard Macros
to Export dialog.

Select Keyboard Macros to Export E'
Minirmize All wWindaows | calac All
2l
| Ceszelact All
| Ok | | Cancel |

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Deselect All options.

3. Click OK. The selected macro file(s) will be moved to your desktop
(by default).

A dialog from which you can locate and select the macro file will then
appear. By default, the macro will exist on your desktop.

=i=Raritan.
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Locate the macro file, click it to select it and then click Save. If the
macro already exists, you will receive an alert message. Select Yes
to overwrite the existing macro or No to close the alert without
overwriting the macro.

Save In: |]j Desktop LvJ @ L‘ﬁ_| @ E:ES|E

|j My Docurnents
|j My Cormputer

3 My Metwork Places
|j WS Folders

File narme: |

Files of type: |><ML Files (*,=ml) -

| Save | | Cancel |

Import/Export RRC Keyboard Macros

>

To export RRC macros:

1. Choose Tools > Export Macros to open the Export Macros dialog.

-

-

Raritan Remote Client Export Macros

[w]AltPrintScreen

Cancel

Select Al

Unselect Al

[z
[E=E)

2

. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Unselect All options.

Click OK. The selected macro file(s) will be moved to your desktop
(by default).

A select dialog from which you can locate and select the macro file
will then appear. By default, the macro will exist on your desktop.
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4. Locate the macro file, click on it to select it and then click Save. If the
macro already exists, you will receive an alert message. Select Yes
to overwrite the existing macro or No to close the alert without

overwriting the macro.

Raritan Remote Client Export Macros

Save in: l@ Desktop

> -_2 My Docurments
3 My Computer

by Recent ‘QMV Metwork Places
Documents |#] keyboardMacros.kbm
Deskiop

My Computer
My Network — File name: IKQ}lhoaTdMa_E:ros.kBm j Save I
Places
Save as bupe: |Haritan Keyboard Macros [* kbm) LI Cancel |

> To import RRC macros:

1. Choose Tools > Import Macros to open the Import Macros dialog. By
default, the macro will exist on the desktop.

Raritan Remote Client Import Macros

Look in: l@ Desklop j
2 [E:]My Dacurents
52 My Computer
My Recent ‘aMy Mebwark Places
Documents m keyboardMacros. kbm
Deskiop

My Documents

My Computer
My Netwark.  File name: IKeyboardM acros.kbm j Open I
Places
Files of type: IHaritan Keyboard Macros [*kbm) j Cancel |

2. Click on the macro file and click Open to import the macro.
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a. If too many macros are found in the file, an error message will be
displayed and the import will terminate once OK is selected.

- = = |

Raritan Remote Client Import Macros '

" "-'.‘ ¥ou cannot import more than 32 keyboard macros,
[

b. If the import fails, an error dialog will open and will display a
message regarding why the import failed. Select OK to continue
the import without importing the macros that cannot be imported.

Raritan Remote Client lmport Macros '

infornatiaon and will nok be imported.

Cancel |
Bad Data

® The following macros contain unsupporked

3. Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Unselect All options.

4. Click OK and the import will begin.

F. &

Raritan Remote Client Import Macros ﬁ

[w]AlPrintScreen

Cancel

Select All

Unselect Al

[==a
===

a. If a duplicate macro is found, a dialog will appear. Do one of the
following:
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F.

Click Yes to replace the existing macro with the imported
version.

Click Yes to All to replace the currently selected and any
other duplicate macros that are found.

Click No to keep the original macro and proceed to the next
macro

Click No to All keep the original macro and proceed to the
next macro. Any other duplicates that are found will be
skipped as well.

Click Cancel to stop the import.

Raritan Remote Chient Import Macros

The Following macro already exisks;

Would wou like to replace the macro?

Yes to Al Mo Mo To Al Rename

Cancel

Alternatively, click Rename to rename the macro and import
it. If Rename is selected, Raritan Remote Client Rename
Macro dialog will open. Enter a new name for the macro in
the field and click OK. The dialog will close and the process
will proceed. If the name that is entered is a duplicate of a
macro, an alert will appear and you will be required to enter
another name for the macro.

-

=,

"F_!aritan Femote Client Rename Macro E

Ik I Cancel |
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b. If during the import process the number of allowed, imported
macros is exceeded, a message will appear. Click OK to attempt
to continue importing macros or click Cancel to stop the import
process.

Raritan Remote Client Import Macros E

" "-'q The maximumn number of macros (32) has already been reached.
LB

Cancel |

The macros will then be imported. If a macro is imported that
contains a hot key that already exists, the hot key for the imported
macro will be discarded.
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Accessing the MPC Diagnostic Interface (excluding KX II)

» To access adevice's diagnostic console:

¢ In the Navigator, scroll through the list of the targets associated with
the device and then double-click the Diagnostic icon at the bottom of
the target list.

E Raritan Multi-Platform Clie

Connecion Serial Tool: Wiew Window Help

o =Gl sl o W &1 5 ) el ] mmal e e

E'rﬁ Faritan Devices
OB [Dorminionkx] Kxz-52.129
(%8 [Dominionkx] KXII Jennifer
t 1: SE_KHZ_232_Portd
*ﬁ Adrmin
[—}D% [KH_KIM-0050] KH_KIM aus . e log

E 11 KVM Port

Kl Adrnin 2 nd a network ping
oo Diagnostc v y el

OIS [5E_Kxz_232] Netwark
—D [unknown ] new test

—D [unknown ] Mewlersey_Rerm Type
L0 [unknown ] Sydney_Rermot

J | Bl

Wiew By Mame | ~ View By IP
| “Wiew By Host Marme

Irvalid uzer narme or passward, j
latternpting to connect to device at
192.168.59.248

[Cominionkyx 192, 168,59, 248]:
Connecting...

[Cominionksx 192, 165,59, 248]:
Conneced

[Cominionky 192, 168,59, 248]:
Login cormplete,

latternpting to connec to device at
192,168.50,12

[Ki¥_KIM-0050 192,168, 50,12]:

Connecting...
[k¥_KIM-0050 192,168, 50,12]:
Connected
[Kx_KIM-0050 192,162,50,12]: j
I Amin Faranlata
P = . g -
w-\m,vM"A e = 8 = N
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Virtual Media
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Prerequisites for Using Virtual Media

With the virtual media feature, you can mount up to two drives (of
different types) that are supported by the USB profile currently applied to
the target. These drives are accessible for the duration of the KVM
session.

For example, you can mount a specific CD-ROM, use it, and then
disconnect it when you are done. The CD-ROM virtual media “channel”
will remain open, however, so that you can virtually mount another CD-
ROM. These virtual media “channels” remain open until the KVM session
is closed as long as the USB profile supports it.

To use virtual media, connect/attach the media to the client or network
file server that you want to access from the target server. This need not
be the first step, but it must be done prior to attempting to access this
media.

The following conditions must be met in order to use virtual media:

Dominion Device

e For users requiring access to virtual media, the device permissions
must be set to allow access to the relevant ports, as well as virtual
media access (VM Access port permission) for those ports. Port
permissions are set at the group-level.

e A USB connection must exist between the device and the target
server.

e If you want to use PC-Share, Security Settings must also be enabled
in the Security Settings page. Optional

e You must choose the correct USB profile for the KVM target server
you are connecting to.
Client PC

e Certain virtual media options require administrative privileges on the
client PC (for example, drive redirection of complete drives).

Note: If you are using Microsoft Vista or Windows 7, disable User
Account Control or select Run as Administrator when starting
Internet Explorer. To do this, click the Start Menu, locate IE, right-
click and select Run as Administrator.

Target Server
e KVM target servers must support USB connected drives.

e KVM target servers running Windows 2000 must have all of the
recent patches installed.

e USB 2.0 ports are both faster and preferred.
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Using Virtual Media via VKC and AKC in a Windows Environment

Windows XP® operating system Administrator and standard user
privileges vary from those of Windows Vista® operating system and
Windows 7° operating system.

When enabled in Vista or Windows 7, User Access Control (UAC) will
provide the lowest level of rights and privileges a user needs for an
application. For example, a Run as Administrator option is provided for
Internet Explorer to explicitly allow users to perform Administrator level
tasks, otherwise these will not be accessible even though the user has
an Administrator login. Further, a Run as Administrator feature is
provided in Internet Explorer. This feature allows users to perform
Administrator level tasks in the Windows Environment.

Both of these features affect the types of virtual media that can be
accessed by users via Virtual KVM Client (VKC) and Active KVM Client
(AKC). See your Microsoft help for additional information on these
features and how to use them.

Following is a list virtual media types users can access via VKC and AKC
when running in a Windows environment. The features are broken down
by client and the virtual media features that are accessible to each
Windows user role.

Windows XP

e If you are running VKC and AKC in a Windows XP environment,
users must have Administrator privileges to access any virtual media
type other than ISOs and ISO images.

Windows Vista and Windows 7

e If you are running VKC and AKC in a Windows Vista or Windows 7
environment and UAC is enabled, the following virtual media types
can be accessed depending on the Windows role of the user:

Client Administrator Standard User
VKC Access to: Access to:
e Fixed drives and fixed ¢ Removable drives

drive partitions

ISO images
e Removable drives

e CD/DVD drives
e |SOimages

Remote ISO images

e Remote ISO images
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Client Administrator Standard User
AKC Access to: Access to:
e Fixed drives and fixed ¢ Removable drives
drive partitions e CD/DVD drives

e Removable drives
e CD/DVD drives
e ISO images

e |SOimages
e Remote ISO images

e Remote ISO images

Using Virtual Media

See Prerequisites for Using Virtual Media before proceeding with using
virtual media.

> To use virtual media:

1. If you plan to access file server ISO images, identify those file
servers and images through the Remote Console File Server Setup
page. See File Server Setup (File Server ISO Images Only) (on
page 159).

Note: ISO9660 format is the standard supported by Raritan.
However, other CD-ROM extensions may also work.

2. Open a KVM session with the appropriate target server.
a. Open the Port Access page from the Remote Console.
b. Connect to the target server from the Port Access page:
= Click the Port Name for the appropriate server.

= Choose the Connect command from the Port Action menu. The
target server opens in a Virtual KVM Client window.

3. Connect to the virtual media.

For: Select this VM option:

Local drives Local Drives

Local CD/DVD drives CD-ROM/DVD-ROM/ISO Images
ISO Images Connect CD-ROM/ISO Image
File Server ISO Images Connect CD-ROM/ISO Image

Upon completion of your tasks, disconnect the virtual media. See
Disconnecting Virtual Media (on page 163).
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File Server Setup (File Server ISO Images Only)

i

Homa = Fila Senvar Setup

File Server Setup

Note: This feature is only required when using virtual media to access file
server ISO images.

1ISO9660 format is the standard supported by Raritan. However, other
CD-ROM extensions may also work.

Use the Remote Console File Server Setup page to designate the files
server(s) and image paths that you want to access using virtual media.
File server ISO image(s) specified here will become available for
selection in the Remote Server ISO Image Hostname and Image drop-
down lists in the Map Virtual Media CD/ISO Image dialog. See CD-
ROM/DVD-ROM/ISO Images (on page 161).

P To designate file server ISO images for virtual media access:

Choose Virtual Media from the Remote Console. The File Server
Setup page opens.

2. Check the Selected checkbox for all media that you want accessible
as virtual media.

3. Enter information about the file server ISO images that you want to
access:

= |P Address/Host Name - Host name or IP address of the file
server.

= Image Path - Full path name of the location of the ISO image.

Note: The host name cannot exceed 232 characters in length.

4. Click Save. All media specified here will now be available for
selection in the Map Virtual Media CD/ISO Image dialog.

IPvd4 Address‘Host Name: Enter name of the host name or IP Address of shared drive containing ".iso™ image.
Image Path: Enter path to ".iso" image on shared drive. Do not inciude host name or [P Address in the path.

O

Selected Host Name WPAddress Image Path

= (i

o|o|o|g|o|o

O

Save | | cancel
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Connecting to Virtual Media

Local Drives

This option mounts an entire drive, which means the entire disk drive is
mounted virtually onto the target server. Use this option for hard drives
and external drives only. It does not include network drives, CD-ROM, or
DVD-ROM drives. This is the only option for which Read/Write is
available.

Note: KVM target servers running certain versions of the Windows
operating system may not accept new mass storage connections after an
NTFS-formatted partition (for example, the local C drive) has been
redirected to them.

If this occurs, close the Remote Console and reconnect before
redirecting another virtual media device. If other users are connected to
the same target server, they must also close their connections to the
target server.

Note: In the Dominion KX Il 2.1.0 and above, when you mount an
external drive, such as a floppy drive, the LED light on the drive will
remain on because the device is checking the drive every 500
milliseconds to verify the drive is still mounted.

> To access adrive on the client computer:

1. From the Virtual KVM Client, choose Virtual Media > Connect Drive.
The Map Virtual Media Drive dialog appears.

Map Virtual Media Drive: DominionKXIl Port 1 |z|

Select a local drive for mounting onto the target server.
Local Drive :

: (Hard Disk) 4 |

Cnnnecti Cancel i

2. Choose the drive from the Local Drive drop-down list.

3. If you want Read and Write capabilities, select the Read-Write
checkbox. This option is disabled for nonremovable drives. See the
Conditions when Read/Write is Not Available (on page 161) for
more information. When checked, you will be able to read or write to
the connected USB disk.

160 =i=Raritan.



i

Raritan.

Chapter 5: Virtual Media

WARNING: Enabling Read/Write access can be dangerous!
Simultaneous access to the same drive from more than one entity
can result in data corruption. If you do not require Write access,
leave this option unselected.

Click Connect. The media will be mounted on the target server
virtually. You can access the media just like any other drive.

Conditions when Read/Write is Not Available

Virtual media Read/Write is not available in the following situations:

For all hard drives.

When the drive is write-protected.

When the user does not have Read/Write permission:
= Port Permission Access is set to None or View.

= Port Permission VM Access is set to Read-Only or Deny.

CD-ROM/DVD-ROM/ISO Images
This option mounts CD-ROM, DVD-ROM, and ISO images.

Note: ISO9660 format is the standard supported by Raritan. However,
other CD-ROM extensions may also work.

>

*ap Wirtual Media CD TS0 Imege: LPmnachine . _E'
Select a COUDVD drive or an 150 image To moant onto the arget server.
= [Local CODVD Drive])
| co-ROM) |
~ B0 mage:
Imaga Path:

To access a CD-ROM, DVD-ROM, or ISO image:

From the Virtual KVM Client, choose Virtual Media > Connect CD-
ROM/ISO Image. The Map Virtual Media CD/ISO Image dialog
appears.

" Remote Senver 120 Irnage
Hostn ame: I

File Servr Usemame: File Server Passward:

-] I -]

I
connest | Cancel |
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2. For internal and external CD-ROM or DVD-ROM drives:
a. Choose the Local CD/DVD Drive option.

b. Choose the drive from the Local CD/DVD Drive drop-down list.
All available internal and external CD and DVD drive names will
be populated in the drop-down list.

c. Click Connect.

3. For ISO images:

a. Choose the ISO Image option. Use this option when you want to
access a disk image of a CD, DVD, or hard drive. ISO format is
the only format supported.

b. Click the Browse button.

c. Navigate to the path containing the disk image you want to use
and click Open. The path is populated in the Image Path field.

d. Click Connect.

4. Forremote ISO images on a file server:

a. Choose the Remote Server ISO Image option.

b. Choose Hosthame and Image from the drop-down list. The file
servers and image paths available are those that you configured
using the File Server Setup page. Only items you configured
using the File Server Setup page will be in the drop-down list.

c. File Server Username - User name required for access to the file
server.

d. File Server Password - Password required for access to the file
server (field is masked as you type).

e. Click Connect.

The media will be mounted on the target server virtually. You can
access the media just like any other drive.

Note: If you are working with files on a Linux target, use the Linux Sync
command after the files are copied using virtual media in order to view
the copied files. Files may not appear until a sync is performed.

Note: If you are working with Windows 7, Removable Disk is not
displayed by default in the Window's My Computer folder when you
mount a Local CD/DVD Drive or Local or Remote ISO Image. To view
the Local CD/DVD Drive or Local or Remote ISO Image in this folder,
select Tools > Folder Options > View and deselect "Hide empty drives in
the Computer folder".

Note: You cannot access a remote 1SO image via virtual media using an
IPv6 address due to technical limitations of third-party software used by
the KX2.

=i=Raritan.
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Disconnecting Virtual Media

i
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» To disconnect the virtual media drives:
e For local drives, choose Virtual Media > Disconnect Drive.

e For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media >
Disconnect CD-ROM/ISO Image.

Note: In addition to disconnecting the virtual media using the Disconnect
command, simply closing the KVM connection closes the virtual media
as well.
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Raritan Serial Console

The standalone Raritan Serial Console (RSC) is used to make direct
connections to a serial target without going through the device. The user
specifies the device address and the port number (target), and is then
connected.

In This Chapter

RSC System ReQUIFEMENTS. ....cuiiieiiiiiiiieieee e e e eeiiieee e e e e e s ssinrreeneee e e 164
Installing RSC 0N WINAOWS .......cooiiiiiiiiiiieeiieeee e 169
Installing RSC for Sun Solaris and LinUX ...........coovvieniiiieiiiiieeieenn 171
Opening RSC from the Remote CoNnsole .........cccccovviveieiiiiiiieiiieee e 172
Raritan Serial Console INterface ...........cccceeeiiiiiiiiiiiiee e 174

RSC System Requirements

The following requirements must be met to support the Raritan Serial
Console:

e The RSC will function with JRE version 1.4.2_05 or later (except for
JRE version 1.5.0_02). However, for optimum performance, Raritan
recommends using JRE 1.5.0 (except for version 1.5.0_02).

e Your system may require configuration adjustments depending on
the operating system and browser. The JRE provides configuration
instructions with the JRE download. Browse to the page at
http://www.java.com/en/download/help/testvm.xml
(http://www.java.com/en/download/help/testvm.xml \o
http://www.java.com/en/download/help/testvm.xml) to determine the
JRE version currently installed on your system. If you do not have a
compatible version of the JRE, go to http://www.java.com
(http://www.java.com) and click the Download Now button.

Note: Raritan does not support JRE version 1.5.0_02 for use with the
RSC.

e Minimum 1 GHz PC with 512 MB RAM.

Ensure that Java can be started from the command line. To do this,
environment variables must be configured. Make a note of the exact path
where Java was installed. (The path information will be used later.)

IMPORTANT: When launching RSC from a browser, Raritan highly
recommends that Java Applet Caching be disabled and that you
perform the following steps to make sure that Java does not create
problems for the system's memory.

164


http://www.java.com/en/download/help/testvm.xml o http://www.java.com/en/download/help/testvm.xml�
http://www.java.com/en/download/help/testvm.xml o http://www.java.com/en/download/help/testvm.xml�
http://www.java.com/�

Chapter 6: Raritan Serial Console

Setting Windows OS Variables
1. Choose Start > Control Panel > System.
2. Click the Advanced tab and then click Environment Variables.

System Properties

3. Inthe System variables section, click New.
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4. In the New System Variable dialog, add JAVA_HOME to the Variable
name block and the path you wrote down earlier in the Variable
value block.

New System Variable

unaz!cmd,m
4

C\WINDOWS\system3Z;C: \WINDOWS; .. _ﬂ

Click OK.
Select the PATH variable and click Edit.

Add %JAVA_HOME%\bin to the end of the current Variable value.
Ensure a semicolon (;) separates the new value from the last value
in the string.

e ==Raritan.
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8. Click OK.

Edit System Wariable

PATHEXT JCOM; .EXE; BAT;.

PROCESSOR_A... xB6 !
PROCESSOR_ID... x86 Family 15 Model 3 Stepping 4, Genu. ..
PROCESSOR_LE... 15 -

9. Select the CLASSPATH variable and click Edit.

10. Ensure the CLASSPATH Variable value is configured properly; that
is, its value must have a period (.) in it. If, for any reason, there is no
CLASSPATH variable defined, create one.

== Raritan. o7
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Setting Linux OS Variables

To set Java for a specific user, open and edit the .profile file located in
the /home/Username folder.

To set Java for all users, open the .profile file in your /etc folder:

1. Find the line where you set your path:

export
PATH=$PATH:/home/username/somefolder

2. Before that line you must set your JAVA_HOME and then modify
your PATH to include it by adding the following lines:

export
JAVA HOME=/home/username/j2sdkl.4.2/
export PATH=$PATH:$JAVA HOME/bin

3. Save the file.

Setting UNIX OS Variables

To check the latest JRE version on Sun Solaris:

1. Launch aterminal window on the Sun Solaris desktop.

2. Type java -version in the command line and press Enter. The
currently-installed version of Java Runtime Environment (JRE)
appears.

168

If your path variable is not set to where the Java binaries have
been installed, you may not be able to see the JRE version.

Assuming JRE 1.4.2_05 is installed in /usr/local/java: you must
set your PATH variable.

To set a path for the bash shell:

export
PATH=$PATH:/usr/local/java/j2rel_4_.2_05/bin

To set path for tcsh or csh:

set
PATH = ($PATH /usr/local/java/j2rel.4.2_05/bin)
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= These commands can either be typed at the terminal each time
you log in, or you can add them to your .bashrc for bash shell or
.cshrc for csh and tcsh so that each time you log in, the path is
already set. See your shell documentation if you encounter
problems.

Window Edit Options Help

# java -version

java version "1.4.2_05"

Jaya(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_05-b04)
Java HotSpot(TH) Client WM (build 1.4.2_05-b04, mixed mode)

#

3. Ifthe JRE is version 1.4.2_05 or later, proceed with the RSC
installation. If the JRE is version 1.5.0_02 or is an older version than
1.4.2_05, go to the Sun website at (http://java.sun.com/products/) to
download the latest Runtime Environment.

Installing RSC on Windows

You must have administrative privileges to install RSC.

P To install RSC on Windows"®:
Log on to a Windows machine.

2. Download, or copy from a known location, the RSC-installer.jar
installation file.

3. Double-click the executable file to start the installer program. The
splash page appears.

Click Next. The installation path page appears.
Change the path, if desired.
Click Next. The installation progress page appears.
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Note: The standalone version of Raritan Serial Console (RSC) is
available from the Raritan website (www.raritan.com) on the Support

page.

of IzPack - Installation of Raritan Serial Console

&9 Pack installation progress:
ﬁ Crverall inskallstion progress:

171

(Made with TzPack - http: ey izf orge. com))

@revous || Qe || Gor |
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7. Click Next. The Windows shortcut page appears.

& IzPack - Installation of Raritan Serial Consale

Select a Program Group For the Shortouts:

Accezsores -

Administratiee Tooks

Acdobe

Arverica Orline crasbe dhorbout Fol
Cisco Systems YPN Chank ) eurrark user
CWIENT e

Dl Acoessories @) Bl merd
Dedl Wiredess

Games

Google Deskiop o

Raritan Serial Consols Rt

C-rud:c sharbcut on the dl:sk!np

{Made with LzPack - http: [ iz orge. comf)

L Oprevius || @next || Gon |

8. Specify the desired Program Group for the shortcut.
9. Click Next. The installation finished page appears.
10. Click Done.

Installing RSC for Sun Solaris and Linux

You must have administrative privileges to install RSC.
1. Log into your Sun Solaris machine.

2. Download, or copy from a known location, the RSC-installer.jar
installation file.

3. Open a terminal window and change to the directory where the
installer is saved.

Type java -jar RSC-installer.jar and press Enter to run the installer.

Click Next after the initial page loads. The Set Installation Path page
opens.

a. Select the directory where you want to install RSC and click
Next.

b. Click Browse to navigate to a non-default directory.

c. Click Next when the installation is complete.
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d. Click Next again. The installation is complete. The final page
indicates where you will find an uninstaller program and provides
the option to generate an automatic installation script.

6. Click Done to close the Installation dialog.

Opening RSC from the Remote Console

> To open the Raritan Serial Console (RSC) from the Remote
Console:

1. Select the Port Access tab.

L

Port Access

Click on the individual port name to see allowable operations.

0 of 1 Remote KVM channels currently in use.
4 Port Number Port Name Port Type Status Availabil!
1 Win Target R up idle
2 Dominion_KSX2_Port2 ot Avaiable down idle
3 Dominion_KSX2_Port3 ot Avaiable down idle
4 KSH-GZ Admin WM up iclle:
5 Diominion_KSX2_Ports ot Available L= iclle:
[ Darminian_KSX2_Porl§ Plat Available down idle
7 Darminian_KSX2_Port? hlat Available sdown ide
8 Dominion_KSX2_Ports ot Avaiable down idle
5 Cisoo 2501 Serial up idle
10 P2 Serial up idle
11 Serial Part 3 Serial up iclle:
12 Serial Part 4 Serial up iclle:
13 N B Serial up idle
19 W Serial Port & Serial u idle
15 Serial Port 7 Serial up idle
16 Serial Port & Serial up idle

2. Click the name of the serial port you want to access for the RSC.

Note: A security pop-up screen appears only if you used https to
connect to the RSC.

3. If you're using Dominion DSX:
= Click Yes. A Warning - Security pop-up screen appears.

= Click Yes to access the Raritan Serial Console from the Port
page.

Note: If you click Always, you will not receive the security page for
future access.

= The Raritan Serial Console window appears.
If you're using Dominion KSX or KX:

= Click Connect to start connecting to the target port for RSC, and
the Raritan Serial Console window appears.

= The Raritan Serial Console window appears.

17 =i=Raritan.
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Note: You can download the standalone Raritan Serial Console from the
Raritan website (www.raritan.com) on the Support page.

P To open RSC from the Windows® desktop:

Double-click the shortcut or use the Start menu to open the
standalone RSC. The Raritan Serial Console Login connection
properties window appears.

2. Enter the device's IP address, account information, and the desired
target (port).

3. Click Start. RSC opens with a connection to the port.

Note: If you experience unrecognized characters or blurry pages in the
RSC window due to localization support, try changing the font to Courier
New. Click Emulator > Settings > Display and select Courier New for
Terminal Font Properties or GUI Font Properties.

Note: When RSC connects to a serial target, hitting Ctrl + _ or Ctrl + ~ +
_ does not cause information to be sent. However, hitting the Ctrl + Shift
+ _or the Ctrl + Shift + ~ will cause information to be sent.

» To open RSC on Sun Solaris:

Open a terminal window and change to the directory where you
installed the RSC.

Type ./start.sh and press Enter to open RSC.
Double-click the desired device to establish a connection.
Type your user name and password.

Click OK to log on.

ok DN
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Raritan Serial Console Interface

Important: The Raritan Serial Console page usually opens in a
separate window behind the Port page. With some versions of Java
on Windows®, the page opens in front of the Port page.

E Raritan Serial Console: Sexial Port 7 (15)

Emulator Edit Tools Chat Help

1. 5EZ:E000/LE" please walt ...

[ Write Access  Code Set: UTF-8  Logoing: off  Users: 1

Default RSC Option Values

The following default values apply to the GUI font properties, colors and
fonts defined in RSC:

Item Value
Font properties Lucida Console

GUI font properties  Lucida Console
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Item Value

Colors Black foreground and white
background

Emulator

1. Change the default user Idle Timeout setting before launching the
RSC for the first time or it will timeout in 10 minutes and display a
host termination message.

2. Click the Emulator drop-down menu to display a list of topics.

E Raritan Serial Console: Sexial Port 7 (15)

Emulator Edit Tools Chat Help

Setting=s. ..

et History J1EB.E1. EZ:E000/LE' please wait ...

Clear History

Get Write Lock

Eend Break
Connected Users...

Exit

[ Write Access  Code Set: UTF-8  Logoing: off  Users: 1
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Settings

1.

Choose Emulator > Settings. The Settings page displays the General
tab with the default settings.

Sethings: Serial Fort 1 {9)

[f General f Display

GUI Interface

Main Menu Shortcut: Show Confirmation Dialog on Exit

Hone -

Terminal Compatibility
Terminal Size: History Buffer Size:

80 % 25 e 200}{

Backspace Sends:

ASCH DEL -

Cursor type
@ Block Cursor

i Line cursor

0k Cancel Default

Accept the Main Menu Shortcut default of None or choose one of the
following from the Main Menu Shortcut drop-down menu:

= F10
= Alt
Accept the Show Confirmation Dialog on Exit default or uncheck it.

Accept the Terminal Size default or choose a size from the Terminal
Size drop-down menu.

Accept the Backspace Sends default of ASCII DEL or choose
Control-H from the Backspace Sends drop-down menu.

Accept the History Buffer Size default of 75 or use the arrows to
change the buffer size.
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7. Accept the Cursor type default of Block Cursor or select Line Cursor.
8. Click OK.

Display Settings

1. Choose Emulator > Settings, and then click the Display tab.

Settings: Serial Port 7 {15) X

Font Directories

[+

l/TErITIiII.al Font Properties rGI.E Font Properties

|Mnnuspaced
Monospaced =
NSimSun Font size:
Raawi il 11 E
Shruti =
SimHei =
Colors- Locale

Encoding:
Foreground: Background: ||_|TF_3 | - |

~ | - | onuave

|English |v|

Preview-

Font Prewview

0k Cancel Default

2. Click Default to accept the Default settings. Then click Ok to close
the Display Settings dialog. However, if you want to change the
settings, perform the following steps:

3. Accept the Terminal Font Properties default of Lucida Console or
choose a font from the scrolling list of Terminal Font Properties.

4. If you want to change the size of the font, choose a font size by
clicking the up or down arrows. The result of selected font and font
size is displayed in the Preview box.
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5. Click the GUI Font Properties tab and accept the default of Lucida
Console or choose a font from the scrolling list of GUI Font

Properties.

Settings: Serial Fort 7 {15)

3

Font Directories

]

rTBI‘]TIIi_llal Font Properties |/GI.II Font Properties

|ru1|:| nospaced
Monospaced =
NSIimSun
Raawvi |
Shruti =
SimHei =
Colors- Locale
Encoding:
Foreground: Background: ||_|TF_3 | - |
- w || | Language :
|English | . 8 |
Preview-

Ok

Cancel

Default

Note: For Simplified Chinese characters, Raritan Serial Console
supports EUC-CN encoding system.

6. Choose the following from their drop-down menus:

= Foreground Color

= Background Color

7. Choose one of the following from the Encoding drop-down menu:

= US-ASCII
= [|SO-8859-1
= |SO-8859-15

= -
—
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Shift-JIS
EUC-JP
EUC-CN
EUC-KR
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Choose one of the following from the Language drop-down menu:

English

Bulgarian

Japanese

Korean

Chinese

Click Ok to close the Display Settings dialog. If you changed the
Language setting, the RSC changes to that language when the

Display Settings dialog is closed.
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Note: If you experience unrecognized characters or blurry pages in the
RSC window due to localization support, try changing the font to Courier
New.

Get History

History information can be useful when debugging, troubleshooting, or
administering a target device. The Get History feature allows you to view
the recent history of console sessions by displaying the console
messages to and from the target device.

When the size limit is reached, the text will wrap, overwriting the oldest
data with the newest.

Note: The history data is displayed only to the user who requested the
history.

e To view the session history, choose Emulator > Get History.

Clear History
e To clear the history, choose Emulator > Clear History.
Get Write Access

Only administrators and operators can get Write access. The user with
Write access can send commands to the target device. Write access can
be transferred among users working in the Raritan Serial Console via the
Get Write Access command.

To enable Write access, choose Emulator > Write Access.
e You now have Write access to the target device.
e When another user assumes Write access from you,

= The RSC displays a red block before Write access in the status
bar.

= A message alerting the user who currently has Write access
appears to tell that user that another user has taken over access
to the console.
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Get Write Lock

e Choose Emulator > Get Write Lock. If the Get Write Lock is not
available, a request rejected message appears.

Write Unlock
e Choose Emulator > Write Unlock.
Send Break

Some target systems, such as Sun Solaris servers, require the
transmission of a null character (break) to generate the OK prompt. This
is equivalent to issuing a STOP-A from the Sun keyboard.

e Only users with Administrator privileges can send a break.
e Users who are Operator or Observers cannot send a break.

» To send an intentional break to a Sun Solaris server:

1. Verify that you have Write access. If not, follow the instructions in the
previous section to obtain Write access.

2. Choose Emulator > Send Break. A Send Break Ack
(Acknowledgement) pop-up appears.

3. Click OK.

181



Chapter 6: Raritan Serial Console

Connected Users
The Connected Users command allows you to view a list of other users
who are currently connected on the same port.

1. Choose Emulator > Connected Users, a Connected Users page is
displayed.

% Connected Osers: Serial Fort 1 (9) |Z|

Tzer Name WMrite Access

adunin

2. A check mark appears in the Write access column after the name of
the user who has Write access to the console.

3. Click Close to close the Connected Users window.
Exit

1. Choose Emulator > Exit to close the Raritan Serial Console. The Exit
Confirmation page appears.

2. Click Yes.
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Edit

Use the Copy, Paste, and Select All text commands to relocate and/or
re-use important text.

E Ramitan Serial Console: Serial Port 7 (15)

Emulator Ed:l.t Tools Chat Help

' - T
| Copy
d Paste F_ 182 _61_5Z-5000515"

| Select All

please wait ...

[ Write hAccess  Code Set: UTF-8  Loguing: off  Users: 1

To copy and paste all text:
Choose Edit > Select All.

Choose Edit > Copy.

Position the cursor at the location where you want to paste the text.
Click once to make that location active.

Choose Edit > Paste.

o c N =Y
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Note: The copy-paste limit of text in Raritan Serial Console is 9999 lines.

Keyboard shortcuts that you can use to highlight, copy, and paste all or
partial lines of text:

e Click and drag your mouse over the text you wish to copy.
e Use Ctrl+C to copy text.

e Position the cursor where you want to paste the text and click in that
location to make it active.

e Use Ctrl+V to paste text.

Tools

Click the Tools menu to display a list of topics.

arnitan Seral Console: Seral Foxt 7 (15)

Emulator Edit |[Tools Chat Help
& b‘d Start Logging

-

= 5000715 please wait ...
Send Keystroke
SEend Text File
Togyle Power

[ Write Access Code Set: UTF-8 Logoying: off Users: 1
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The Start Logging function allows you to collect raw console data from
the target device and save it to a file on your computer. When you start
RSC, the Logging indicator on the status bar indicates whether logging is

on or off.

1. Choose Tools > Start Logging.

2. Choose an existing file or provide a new file name in the Save RSC
Log dialog.

= When an existing file is selected for logging, data gets appended
to the contents.

= |If you provide a new file name, a new file is created.

% Save RSC Log

X

Save In: |[] My Documents - |:| E
File Name: | |
Files of Type: |Log Files |
| Save | | Cancel |

3. Click Save after selecting or creating a file.
185
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Stop Logging
Choose Tools > Stop Logging. The logging stops.

Send Keystroke

1. Choose Tools > Send Keystroke. A Send Keystroke dialog appears:

Send KeyStroke: Serial Port 1 {(9) |E|

Eeystroke combination:
Mare

[Jctrl [ ]Alt [ |Shift

Eey code:
None -
Send Clear Cancel

2. Enter the keystroke combinations that you want and select a Key
Code name from the drop-down menu.

3. Send the keystroke combinations.

Send Text File

1. Choose Tools > Send Text File. A Send Text File screen appears.
Open the directory of the Text file.

2
3. Click on or enter the File Name of the Text file.
4

Click Open.
= When you click Open, it sends whatever file you selected directly
to the port.

= If there is a loopback plug inserted, you will see the file displayed.

= If there is currently no target connected, then nothing will be
visible on the screen.
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Toggle Power

The Toggle Power function lets you power on or off the device that is
connected to the associated outlet on a Power Distribution Unit (PDU).
For example, if a router is connected to one of the outlets on the PDU,
you can toggle the router’s power on or off.

You must configure the association of outlets to the target port of the
device before you can use the Toggle Power feature. Go to the Power
Control tab on remote console's GUI to configure the outlets. If you have
not done this, the system displays a message stating that the target is
not associated with a power outlet.

Note: If RSC is launched through CC-SG (version 4.x onwards) by users
without the permission to toggle power, the option Toggle Power will
appear as disabled.

1. Select Toggle Power to turn the device (router) on or off. A prompt
appears displaying the current status of the outlet(s). You can turn
the device on or off depending on its current status.

If you select No, the system returns you to the RSC screen.

If you select Yes, the system sends the power command to either
turn on or off the outlets associated to the target port of the device.

If you receive a:
e Hardware error message: this means that the PDU command failed.

Software error message: this means that another user is controlling the
power outlet and the power control command cannot be sent.
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Chat

When using browser access over SSL, an interactive chat feature called
Chat allows you and other users on the same port to communicate. You
can conduct an online dialog for training or collaborative diagnostic
activities. The maximum length of a chat message is 300 characters.

Note: When a chat is initiated, a chat window appears on the monitors of
all SSL users logged on to the port. If a user is logged into a port multiple
times, multiple chat messages will not appear to that user.

> To open chat:

e Choose Chat > Chat.

E5 Chat: Serial Port 1 {9)

1]

Mes=age :

Remaining: 200

[ b

1]

| Send H Clear H Close

> To clear text in a chat text box:
e Click Clear to delete the typed text.

188
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Help

Help Topics include online assistance for operating the Raritan Serial
Console and release information about Raritan Serial Console.

Help Topics

> To access help topics:
e Choose Help > Help Topics.

About Raritan Serial Console

The About Raritan Serial Console dialog displays the copyright and
version information (name and revision nhumber) of the console terminal
emulation software. When contacting Raritan for technical support or
when performing a software upgrade, you may be asked for this
information.

> To access 'About' information:

e Choose Help > About Raritan Serial Console. An About Raritan
Serial Console message appears.
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> U.S./Canada/Latin America

Monday - Friday

8am.-6p.m. ET

Phone: 800-724-8090 or 732-764-8886

For CommandCenter NOC: Press 6, then Press 1

For CommandCenter Secure Gateway: Press 6, then Press 2
Fax: 732-764-8887

Email for CommandCenter NOC: tech-ccnoc@raritan.com
Email for all other products: tech@raritan.com

» China

Beijing

Monday - Friday

9 a.m. - 6 p.m. local time
Phone: +86-10-88091890

Shanghai

Monday - Friday

9 a.m. - 6 p.m. local time
Phone: +86-21-5425-2499

GuangZhou
Monday - Friday

9 a.m. - 6 p.m. local time
Phone: +86-20-8755-5561

> India

Monday - Friday
9 a.m. - 6 p.m. local time
Phone: +91-124-410-7881

P Japan

Monday - Friday

9:30 a.m. - 5:30 p.m. local time
Phone: +81-3-3523-5991

Email: support.japan@raritan.com

» Europe

Eu rope

Monday - Friday

8:30 a.m. -5 p.m. GMT+1 CET
Phone: +31-10-2844040

Email: tech.europe@raritan.com

United Kingdom
Monday - Friday

8:30 a.m. to 5 p.m. GMT
Phone +44(0)20-7090-1390

France

Monday - Friday

8:30 a.m. -5 p.m. GMT+1 CET
Phone: +33-1-47-56-20-39

Germany

Monday - Friday

8:30 a.m. - 5:30 p.m. GMT+1 CET
Phone: +49-20-17-47-98-0
Email: rg-support@raritan.com

» Melbourne, Australia

Monday - Friday
9:00 a.m. - 6 p.m. local time
Phone: +61-3-9866-6887
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9 a.m. - 6 p.m. GMT -5 Standard -4 Daylight
Phone: +886-2-8919-1333

Email: support.apac@raritan.com
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