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CHAPTER 1: INTRODUCTION AND INSTALLATION 1

Chapter 1: Introduction and Installation

Raritan Multi-Platform Client (MPC) and Raritan Remote Client (RRC) are graphical user
interfaces for the Raritan Dominion KX and IP-Reach product lines, providing remote access to
target servers connected to Raritan KVM over IP devices. Non-Windows users must use Raritan
Multi-Platform Client, and Windows® users running Internet Explorer must use Raritan Remote
Client.

Use with Raritan Products

Raritan Multi-Platform Client (MPC) and Raritan Remote Client (RRC) are intended for use with
the following products:

ProbDuUCT MPC RRC

Dominion KX 1l (G2)
Dominion KX 1 (G1)
Dominion KX101 (G1)
Dominion KSX (G1)
IP-Reach

UST-IP (G1)

NESESASANN ©
ASANANANAN

L egend:
Gl Generation 1
G2 Generation 2

There are some differences between MPC when used with the Dominion KX | and Dominion KX
Il devices; these differences are noted in the user manual.

Note: RRC cannot be used with Dominion KX |l devices.

Minimum System Requirements
The minimum system requirements for the Raritan Multi-Platform Client and Raritan Remote
Client are:

e CPU Speed: 1.0 GHz
e RAM: 512 Mbytes

Note: Running the client software on system configurations below either of these specifications
may impact performance and result in errors.

Note to CC-SG Users

If you are using Dominion KX 1l in a CC-SG configuration, do not use the CC-SG proxy mode if
you are aso planning to use the Multi-Platform Client (MPC).

=& Raritan.



2 RARITAN MPC AND RRC UseR GUIDE

Java Runtime Environment (JRE) Requirements

Raritan recommends using Java® Runtime Environment (JRE) version 1.5 for optimum
performance, but MPC will function with JRE version 1.4.2_05 or greater (with the exception of
JRE 1.5.0_02). JRE 1.6 is also supported, but has not been fully tested.

Determine your version of the JRE on the Java webpage:

http://www.java.com/en/downl oad/hel p/testvm.xml

Y ou may need some configuration depending on your OS and browser; configuration instructions

are provided with the JRE download. Please note that modem use is not supported with Raritan’s
Dominion KX101.

Important: When launching MPC from a browser, it is highly recommended to
disable the Java Applet caching.

Although no actual problems have occurred when Java caching is turned on, some non-impacting
Java exceptions have occurred with the caching turned on. Generation of these Java-exceptions
can appear in the Java Applet Console window, and may degrade performance.

For Linux/UNIX environments, the Java Control Panel is located in the JRE’s bin directory; the
location varies based on where JRE was installed by your Linux/UNIX administrator.

Tip: Itisalso recommended that you clear the Java cache.

To disable Java caching and clear the cache (these steps use Microsoft Windows XP and
JRE 1.5.0):

1. From the Start menu, click Control Panel.

2. Double-click on the Javaicon to launch it. The Java Control Panel opens:
Control Panel 10 =]

Update | Java | security | Advanced |

Aot

YWiewy version information about Java Control Panel,

About... I

- Metwork Settings

Metwork settings are used when making Internet connections. By default, Java
will use the netwark settings in your web browser, Only advanced users should
modify these settings.

Mebwork Settings. ..

[~ Temporary Internet Files -

Files wou use in Java applications are stored in a special Folder For quick execution
later. Only advanced users should delete files or modify these settings.

Delete Files. .. | Settings. .. |

(4 I Cancel | Amply |

Figure 1: Java Control Panel
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3. Todisable Java caching:

A. From the General tab, click the Settings button in Temporary Internet Files. The
Temporary Files Settings dialog opens:

Temporary Files Settings = 1[

Delete Files. .. | View Applications. .. | | ! Wiew Applets...
5etkings

Location: Iiu:un DatalsuntJavalDeploymenticache . Change... |

Arnount af disk = Unlimitd

space to use! [ Maximuml IMB j

Jar compression: |

K | | | | | | | |
Mone High
O | Cancel |

Figure 2: Temporary Files Settings

B. Click the View Applets button. The Java Applet Cache Viewer opens:

i
File Options Help
Marne: Type Size Expiration Date Last Modified Wersion | URL
rolang_en. jar-1d6dS02-222771... | Jar EKE 12/31/89 07:00 PM| 11/29/06 02;20 PM| Nf& | hittps:{192.168.61.180frclang_en jar |
rolang_en jar-68ebSFc-5eaa217. ., | Jar 6K 12/31/69 07:00 PM| 12/21/06 02136 PM| NfA | hitps:/192.168.53.48jrclang_sn.jar
rolang_en jar-68eb6070-5c7a7a. .. | Jar EKE 12/31/69 07:00 PM| 11/23/06 02:20 FM| NfA | hitps://192.168.53.80jrclang_sn.jar
sClientLib jar-5444cded-7d6268. .. | Jar SEEKE | 12/31/63 07:00 PM| D2/26(00 0Z: 11 ... | MfA | hitps:{{182.168.50.25/5ClientLib.jar
sClientLib. jar-7036985-47b3645, ., | Jar S85KE 12/31J69 07:00 PM| 02/26/00 01:15 ... | M/A https:ff192,168.50.154/sClientLib. jar
sClientLib jar-7824070-6F67Faae, ., | Jar 619KE 12/31J69 07:00 PM| 05)22(06 07:02 PM| M/A https:ff192,168.53,222/sClientLib. jar
SFooxtrot. jar-1a581362-6259a44, .. | Jar S4B 12/31/69 07:00 PM| 10f03/06 12:12 PM| NfA | httpe:jfsdeweb.raritan, comjreleases MUlbFlator
SFooxtrot, jar-4662FFd-S00bc4S.2ip | Jar S4B 12/31/69 07:00 PM| 0202600 01:15 ... | NfA | https:(192.168.50. 154 sFoxtrot. jar
SFooxtrot, jar-4e50362-19cF606.2ip | Jar S4B 12/31/69 07:00 PM| 01023/07 01:57 PM| NfA | hittps:§/192.168.53. 150/sFoxtrok. jar
sFoxtrot jar-4e506e8-75cd7bec. . | Jar 54KE 12/31J69 07:00 PM| 05)22(06 07103 PM| M/A https:ff192,168.53,222/sFoxtrot. jar
sFoxtrot. jar-51a793dc-4160ead. . | Jar S4KE 12/31/69 07:00 PM| 02/26/00 02:11 ... | NfA& | https:fj192.168.50. 29 sFoxtrot jar
SHM.jar-13964036-5e3ca38.2p | Jar Z169KE | 12/31j60 07:00 PM| 02/26/00 01115 ... | NfA | htps:j192. 168,50, 154]sHM.jar
SHW.jar-14172423-331aBac8.2p | Jar Z523KE | 12/31j69 07:00 PM| 05/22i06 07:03 Pﬁ NfA | hbtps:i192.168.59.222)sHM.jar
SHI.jar-60d9b1 17-6oa6boa4.2p | Jar Z189KE | 12/31j69 07:00 PM| 02/26/00 02: 11 ... | NjA | hitps:j152. 168.50,28(sHM.jar
SMipc.jar-4Fc27ET0-4Fc 4306 2p | Jar 3712KE | 12/31j69 07:00 M| 01/23/07 01:57 FM| NjfA | hitps:j1592. 168,59, 150jsMpc.jar
<M. jar-799F6ef0-2cheab18.2ip | Jar SIB1KE | 12/31j69 07:00 PM| 10/03/06 12:12 FM| M | hitp://sdeweb. raritan. comjreleasss MultFlatfort +
< I i

[ Ensbles Carking

Refresh Delste

Figure 3: Java Applet Cache Viewer

C. Clear the Enable Caching checkbox.

D. Click OK.
4. To clear the Java cache:

A. From the Temporary Files Settings dialog, click the Delete Files button. The Delete
Temporary Files dialog opens:

Delete Temporary Fi , |

0 | Delete the Following termporary files?
-t
[+ Downloaded Applets
[+ Downloaded &pplications

[+ other Files

Cancel |

Figure 4: Delete Temporary Files

B. Click OK.

—=V=

=& Raritan.
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MPC Supported Browsers

MPC supports the following browsers:

Internet Explorer 6 and 7
Firefox® 1.5 and 2.0
Mozilla® 1.7

Safari 2.0

Raritan Multi-Platform Client (MPC) Supported Operating
Systems

When launched as web applet or as a standalone application, MPC alows you to reach target
servers viadifferent Raritan Dominion KX and | P Reach models.

Raritan MPC is compatible with the following platforms:

Windows XP

Windows 2000 SP4

Windows Vista

Red Hat Linux® 9.0

Red Hat Enterprise Workstation 3.0 and 4.0
SUSE Linux Professional 9.2 and 10
Fedora Core 5 and above

Mac®

Solaris™
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Launching MPC from a Web Browser

Important: Regardless of the browser you use, you must allow pop-ups from
the Dominion device’s IP address in order to launch MPC.

1. To launch MPC from a client running any supported browser, type http://IP-ADDESS/mpc
into the address line, where I|P-ADDESS is the I P address of your Raritan device. MPC will
launch in a new window that does not contain a menu bar, tool bar, scroll bar, or address bar.
Work in this window and toggle to other open windows using the ALT+TAB command.

2. When MPC launches, a device tree of al automatically detected Raritan devices found on
your subnet is displayed on the left side of the screen. If you do not find your unit listed by
name, create an icon manually by selecting Connection > New Profile. The Add Connection
window opens.

3. Type a device Description, specify a Connection Type, add the device IP Address, and
click OK. These specifications can be edited later.

4. In the Navigator panel on the left of the screen, double-click on the icon that corresponds to
your Raritan device.

If you prefer, install MPC as a standal one appl et (see next section).

Note: Depending on your browser and browser security settings, you may see various security
and certificate check and warning dialog boxes. It is necessary to accept the options in order to
launch MPC.

Installing and Launching Standalone MPC

Please see Appendix A: Installing and Launching Standalone MPC for instructions on
installing the standalone version of MPC on various operating systems.

Direct Dial Modem applies to devices running on Windows, Linux, and Sun Solaris, but not on
Macintosh®. If you are using Microsoft® Windows with MPC, you must use the Standalone
version.
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Raritan Remote Client (RRC)

Important:. RRC works only with MS Internet Explorer. If you are using a
different Web browser, MPC will load automatically.

Most users access RRC via Internet Explorer, while other users, particularly those operating over
amodem connection, invoke RRC standalone. Both options are detailed below. Modem use is not
supported with Raritan’s Dominion KX101.

Launching RRC from a Web Browser

Your IP-Reach and Dominion units feature Web browser-access capabilities and can provide a
connection from any Windows-based Remote PC running Microsoft Internet Explorer 6.0.

Security Settings

To access |P-Reach or Dominion KX via Web browser, your Web browser must be configured
appropriately under the Internet Explorer security settings tab:

e Download Signed ActiveX controls should be set to either “Enable” or “Prompt”
e Run ActiveX controlsand plug-ins should be set to either “Enable” or “Prompt”
Please consult your Microsoft Internet Explorer documentation for additional information.

Note: Microsoft Windows 2000, Microsoft Windows XP, and Microsoft Windows 2003 restrict
certain types of users from downloading and running ActiveX controls and plug-ins, regardless of
the above settings in Internet Explorer. Please consult your Microsoft Windows documentation
for more information.

Launching RRC

1. Ensure that your browser security settings are configured appropriately and type the IP
address assigned to your |P-Reach or Dominion unit (please see the Initial Configuration
section in the appropriate product user guide for additional information) in the URL field of
your Web browser.

a Raritan-Enterprize - Microzoft Internet Explorer

File  Edit “iew Favortezr Toole Help ‘
Agdress [ &) T EEPRIEINNE

Figure 5: Launching RRC in |IE

Note: IP-Reach and Dominion units ship with the default IP address of 192.168.0.192. Please
note that an |P address must be used. Hosthames are not currently supported.
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2.

Y ou will beredirected to an HTTPS (128-bit) secure Web page so you can launch RRC.

<2 Raritan Remote Client - Microsoft Intemnet Explorer

File  Edit “iew Favorites Toolz Help |

bodiess | hitp://132.188.50.173 ~| @6o
=V= .
E_LERGI'IIOI'L Raritan Remote Client

w 1.21,2003 16:56:34.358 Raritan Remote Client loading...

Figure 6: RRC Loading Screen

Depending on your browser and its security configuration, you may see any or al of the
following dialog boxes, confirming access and launch of an externally-provided program.
Click Yesto advance through any of these prompts.

Security Alert
Infarmation vou exchange with this site cannot be viewed or
changed by others. Howewver, there is a problem with the site’s
security certificate,

& The security certificate was issued by a company you have

not chosen to tust. Yiew the certificate to determine whether
you want to trust the certifying autharity.

a The security certificate date iz valid.

The name on the secuity certificate i invalid or does not
match the name of the site

Do pou want to proceed?

Yes Y Wiew Cerlificate
Internet Explorer Internet Explorer
i@ Do you want to allow software such az Active controls r{Q A zonipt is acoessing some software [an Activel control)
?. ahd plug-ing b run’? ?. oh thiz page which has been marked safe for scripting.

Do you want to allow this?

Figure 7: Possible Security Alert Screens

Removing RRC from the Browser Cache

To remove RRC from your browser cache for any reason, follow the standard procedure for your
Web browser software.

Directionsfor Internet Explorer v6.0:

1.

If you have used RRC recently, exit al instances of Internet Explorer, and restart Internet
Explorer.

On the Internet Explorer Tools menu, click Internet Options.

When the Internet Options dialog box appears, click on the General Settings tab, and click
Delete Files.

Click on the Settings tab, and then click View Objects.

Internet Explorer will display a list of cached program objects. Select any entries named
“TeleControl Class,” “Raritan Console,” or “Power Board” and delete them.

=& Raritan.
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Installing and Launching Standalone RRC

Note: This step is optional. IP-Reach or Dominion can be accessed from a Remote PC either by
installing RRC software or by launching RRC via Web browser. Accessing IP-Reach or
Dominion via Web browser does not require any software installation on the Remote PC. This
section lists the steps required to invoke RRC using standalone software, which may be useful for
accessing IP-Reach or Dominion via modem or if you wish to close firewall access to ports 80
and/or 443.

1.

Launch your Web browser and go to Raritan’'s Web site (http://www.raritan.com/). Click
Support in the top navigation bar, and then click Firmware Upgrades in the left navigation
bar (or type the URL http://www.raritan.com/support/firmwareupgrades).

Scroll down the page until you see the appropriate product name and click oniit.
L ocate the appropriate version of the standalone RRC client for the Release you are using.

The entry for the standalone RRC client is a .zip file which contains the release notes and the
Installer for Standalone RRC. Check the release notes for the latest information.

Y ou can download the .zip file to your client machine or simply click on the .zip file entry.

Double-click on the Installer executable in the .zip file and follow the on-screen instructions
in the InstallShield Wizard to complete RRC ingtallation on your Remote PC. Be sure to
check the release notes for the latest information and any release specific instructions.

Depending upon the configuration of your PC, the RRC instalation program may aso
automatically install DirectX and Microsoft Foundation Class libraries, if they are required.
If s0, you will be asked to restart your PC after installation.

A Raritan Remote Client icon will appear on your desktop. Click on thisicon to launch the
standalone RRC client.

The standalone client can be uninstalled in the Add or Remove Programs applet in the
Windows Control Panel. You must uninstall before installing a new version of Standalone
RRC.



http://www.raritan.com/
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Chapter 2: Operation

Window Layout
MPC Interface

MPC functions are grouped into six general sections on the screen. As a standal one product, or as
aWeb applet, the MPC window contains these main sections:

Menu Bar — offers
drop-down menus
of commands and

Navigator— displays all known Raritan
networked devices. Connect to adevice to
control the server or KVM switch attached

Toolbar — shortcut buttons
to launch frequently-used
features and commands.

to that port.

W Raritan Devices

& Bl ASTDH B-VE
|- CI=5 Bl 120 1
- B billskd 01 182.168.51
- B billskecd 21 [182.168.51

— & Sm Diorninion-k:3 (192,168
- B Darminion-ke [192 1684
|-« = Dorinion-ke (192 168 6|
|- (1% £ 788 [192.168.53.18

| =5 Eviat 05 [192.168.53.10:

- D% Ewea 104 [192.168.53.211
& Ba Gerryicod 32 [192.166.51
=1 Channel 1

=) 2: Channel 3

B 35732 RH 8.0,

48 4 Port1

48 5 Channel 5

W8 6 Port 2

W8 7 PP
W8 & Channel 2
W8 9 Channel @ -]
K 2
View By Name | View ByIP
Searching for Raritan device at ﬂ

192.168.481.184

[Germykaaa? 192.168.51.184]
Connecting...

[Germylad 32 192.168.51.184]
Connected

[Gerrylad32 192.168.51.184]: Login
complete.

Iy K

i#start H & 9

Welcome to QuickTime

File Edit Movie Favortes ‘window Help

e Edit Wew Go Bookmarks Tools Window Help

¢ & a3 =

Back Forward  Reload

Mt nrmanntnad tn dlan Tasnma s

o L

-
-| 0, =mai J%AIM £ Home 3 Radio [adnetscape C4 Search Eookmarks

| [ S uneted) ]

{1 welcome ko QuickTime |

[GernyKX432 192.168.51.184]: Login complete.

Remote KVM Console —
target device display.

[BYACSEDY B 0o

atus Bar — provides real -
time information on
connection parameters.

Figure 8: MPC Window Layout

Z&Raritan.
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RRC Interface

The RRC window is amost identical to the MPC window.

Menu Bar —offers Toolbar — shortcut buttons
drop-down menus to launch frequently-used
of commands and features and commands.
preferences.

[GerryKX432 - GerryKX43: M= E

] Connection KRy d Video Mouse Tools Wiew ‘Window Help _|5|5|

Oepo N mBEEH:E| - = 28nElal 2

(%

E-a Raritan Devices
Y % ASTDKH416-VER13 [192,168.5 =
@ % billske101 [192.168.51.86] = YWelcome to QuickTime
@ &1_; billsk:120 [192.168.51.120] ents L
@ %_; billskxx121 [192.168.51.121]
@ % Dominion-kx [192, 168.51,83]
e % Dominion-K4 [192,168.51,187]
e @ % Dominion-kx [192, 1686.51.252]

R
T e ot e . Get connected to the Internet
- @ B Gerrykxaaz [192.165.51.184] for vour guide tO the best
= 1: Channel 1 L . .
in QuickTime content.

-.{& 2: Channel 3
=) 315732 RH&0.e,

File Edit Movie Favortes Window Help

A= 4 port 1 I
48 5: Channel 5 J— A
4= e port 2 ’ y= S
4B 7: I-winie : —
4= & Channel & e
- 48 9: Charinel 9 { QUICkTImE

4= 10: channel 10
-4 11: Charnel 11
4= 12: Channel 12
-4 13: Channel 13
4= 14: Channel 14 bee
4= 15: channel 15
48 16: Chanrel 16
4= 17: channel 17
-4 18: Channel 18
48 19: Chanrel |
4= 20: channel 2
48 21: Channel 3 S &= A G | ooe
&8 z2; channel 3 ‘
-8 23: Channel 3

8 24: Channel 4 Hstart ||| 1) @ & | @i welcome to guickTime (Bl emMIed =

-8 25: Charnel 3

4= 26: Channel |
| _'l—I

3
Raritan Remate Client |Buto Sensing Video | = ¢ [ nm

Navigator— displays all known Status Bar — providesreal-
Raritan networked devices. time information on
Connect to adevice to control Remote KVM Console — connection parameters.
the server or KVM switch target device display.

attached to that port.

Figure 9: RRC Window Layout

Z&Raritan.
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Connection Profiles

Connection profiles store important information about your Raritan device, such as IP address,
custom TCP ports, preferred compression settings, and custom security keys. A profileis required
to access devices outside your subnet and to access devices using dial-up connection.

Through profiles, you can set up personalized connections; these profiles are not shared among
other users.

Tip: If your Raritan device is configured to use a custom TCP port or a group security key, first
create a connection profile so that you can access the device.

Creating Profiles

Tocreateaprofile:
1. There are two waysto create a profile:

e For automatically discovered devices, right-click on the device name in the Navigator
and select Add Pr ofile from the shortcut menu.

e For other devices, select Connection > New Profile,

The Add Connection window opens. Options are organized into three tabs.
2. Update the Connect tab:

Add Connection x|

Only the Connect
Tab isavailable for
Generation 2 (G2)
Raritan devices

Description: |

Praduct : |Dc\rninic\n K G2 - |

Connection Type: | TSR IR Connectior v |

-Find Raritan dewvice By:

@ IP Address |c|.c|.c|.c|

D Marmea |

[¢¥] Use Default Port Humber Faort Murmbe S00C

| QK || Cancel |

Figure 10: Add Connection — Connect Tab

— Description: Type a meaningful description (up to 32 characters, aphanumeric, specia
characters allowed). This description identifies the Raritan device in the Navigator.

— Product: Select the Raritan product you are using from the drop-down list: Dominion
KX G2 (Dominion KX 1), Dominion KX G1, Dominion KSX G1, IP-Reach, UST-IP G1,
and KX101 G1.

=& Raritan.
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Screen variation

3.

Connection Type: Use the drop-down list box to select the type of connection. Please
note that only TCP/IP is available for Generation 2 (G2) Raritan devices.

Add Connection x| Add Connection %]
Connect | Compression LSecurity Connect I Complessionl Securityl
Cescription: | Desctiption I
Product : ||Dominion KX G1 - | .
L Connection Type
Connection Type: |Dia| Up Connection - |
|
FPhone Mumber
Phane Mumber: [0 M oder: I d

Select TCP/IP Connection for aLAN/WAN connection.
¢ Find Raritan device by (select one of these options):

v' |P Address: Type the IP Address assigned to your Raritan device.

v Name: Type the name assigned to your Raritan device during initial
setup.

v" DNS: Type the Domain Name Server (DNS) name. Use this option if
you have a DNS server to resolve a DNS name to the IP Address
assigned to your Raritan device. Please note that you cannot use this
option for Raritan Generation 2 (G2) devices.

Select Dial Up Connection for a direct analog modem connection to the Raritan
device. Type the parameters that MPC or RRC should use to establish a connection.
Dial up connection does not apply to Generation 2 (G2) or KX101.

v" Phone Number. Include any additional codes that MPC or RRC should
dia to establish a connection, such as country codes, area codes, or
outside line access codes.

v" Modem. Select the modem (as configured in Windows) from the drop-
down list that MPC or RRC should use to dia and connect to your
Raritan device.

Important: MPC modem connectivity is supported on Windows, Linux,
and Sun Solaris, but not Macintosh.

Note: For security reasons, you must use the MPC standalone client if you require
modem access. In addition, one modem on a client PC can be used for only one
device connection.

Modem: ! Conexant D110 MDGC W, 92 Modem ™

¥ Use Dafaulk Port Number Eart iumter IU

E Use Default Port Number Fo lumbes 5000
| (o114 | Cancel QK. I Cancel |
MPC Release 5.0+ MPC (Pre-5.0 Release)

Figure 11: Add Connection — Dial Up Connection Type Detalil

Use Default Port Number: For TCP Ports, Dominion KX and IP-Reach are
automatically configured to use TCP Port 5000 when communicating with MPC/RRC.
If you do not want to use the Default Port Number:

v Clear the Use Default Port Number check box.
v Type the configured TCP Port to be used in the Port Number field.

Update the Compression tab (not available for Generation 2 (G2) Raritan devices):

=& Raritan.



CHAPTER 2: OPERATION 13

Add Connection |
Connack | Somprassion | Security |

Connection Speed: |Auto Detect H
Color Depth: [Auto Select Colar H
|:| Progrezsive Update
[ ] internet Flow Control
Srnoothing: O !

Low High
Frarmes per second

S fps )10 fps ) 20 fps

| Ok | | Cancel |

Figure 12: Add Connection — Compression Tab

Add Connection |

Connect Compression | Securit}ll

Connection Speed:

Color Depth: I.-’-‘«utu:u Select Color j

= Eragressive pdate

™ Internet Flow Contral

i |
Smioathing it — | LT

ak. I Cancel |

Figure 13: Add Connection Window in RRC

Connection Speed: Select the Connection Speed from the drop-down list. IP Reach and
Dominion can automatically detect available bandwidth and not limit bandwidth use; but
you can also adjust this usage according to bandwidth limitations. Depending on the
Raritan device in use, different options may be available.

=V=

=& Raritan.
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Auto Detect

100mb Ethernet

10mb Ethernet

1.5mb (Max DSL/T1)
1mb (Fast DSL/T1)
512 kb (Medium DSL/T1)
384 kb (Slow DSL/T1)
256 kb (Cable)

128 kb (Dual ISDN)
56 kb (ISP Modem)

33 kb (Fast Modem)
24 kb (Slow Modem)

Color Depth: Select the Color Depth from the drop-down list. IP-Reach and Dominion
can dynamically adapt the color depth transmitted to remote users in order to maximize
usability in al bandwidth constraints. Depending on the Raritan device in use, different
options may be available.

Important:. For most administrative tasks (server monitoring,
reconfiguring, etc.), administrators do not require the full 24-bit or 32-
bit color spectrum made available by most video graphics cards.
Attempting to transmit such high color depths wastes network
bandwidth.

Auto Select Color
15-bit RGB Color
12-bit RGB Color
8-hit RGB Color
5-bit Color

4-hit Color

4-bit Gray

3-bit Gray

2-bit Gray

Black and White

* Progressive Update increases the usability in constrained bandwidth environments.
When Progressive Update is enabled, IP-Reach or Dominion initially sends an
image of the remote desktop at lower color depths, and then provides higher color
depth images as bandwidth allows.

Note: When Color Depth is set to Auto Select Color (default), Progressive Update is
automatic. IP-Reach or Dominion will enable/disable Progressive Update as
required, disabling it for fast connections and enabling it for slow connections.

» |nternet Flow Control: When using IP-Reach or Dominion over an unpredictable
public WAN (particularly in international scenarios), checking the Internet Flow
Control check box ensures that packets transmitted by 1P-Reach or Dominion are
received and reconstructed by MPC/RRC in the correct order.

» Smoothing (15-bit mode only): Use the dlider to select the desired level of video
Smoothing. The level determines how aggressively to blend screen regions with
small color variation into a single smooth color. Smoothing improves the appearance
of target video by reducing displayed video noise.
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— (MPC Only) Frames Per Second: This setting instructs MPC how often to redraw the
video display of the target. This only affects the client display behavior and has no
bearing on the data rate of the video being sent to the client. Setting this option higher
makes the video appear smoother but also requires more processing power.

4. Update the Security tab (not available for Generation 2 (G2) Raritan devices):

Please note that the Security tab is disabled for Generation 2 Raritan devices. If your
Dominion or IP-Reach unit is configured to use a private security key, input that key to
gain the authorization required to initiate a connection to that 1P-Reach or Dominion unit.

Add Connection |

| connect | compression | Security |

Private Key: |

Confirm Private Kew: |

The private key MUST rmatch the private key set by
tthe Adrninistrator or connections will be denied.

| Ok | | Cancel

Figure 14: Add Connection — Security Tab

— Typethe private security key in the Private Key field.

— Retype the private security key in the Confirm Private Key field to ensure no
typographical errors were made.

5. Click OK to create the connection profile.

=& Raritan.
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Modifying Profiles

Tomodify aprofilein MPC or RRC:
1. Select the device in the Navigator panel and right-click on it.

2. Select Maodify Profile. The Modify Connection window opens:

Connect | Eumplessiunl Sec:urit_l,ll

Dezcription

Connection Type ITEF‘;’IF‘ Connection j

Find R aritan device By:
& |P Address | 192 . 168 . 51 . 180

™ Mame I

" DNS Mame |

v Usze Default Port Mumber Hart urmber IU

] I Cancel | e 1] |

Figure 15: Modify Connection Screen

3. Update the fields as appropriate.
4. Click OK.

Deleting Profiles

Todeleteaprofilein MPC or RRC:
1. Select the device with a profile in the Navigator and right-click on it.

2. Select Delete Profile.

3. When prompted to confirm the deletion, click Yes to delete the profile for this device, or
click No to return to MPC or RRC without deleting.

=& Raritan.
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Establishing a New Connection

Note: Depending on your version of the JRE, you might receive a certificate message when using
the MPC standalone application to access a Dominion KX Il device. You have to accept the
certificate in order to establish the connection.

Double-click the icon of a Raritan networked device in the Navigator, then type your user name
and password to connect. You can aso right-click on the device name and select New
Connection from the shortcut menu.

Note: The default IP-Reach or Dominion login user name is admin, with the password raritan.
This user has administrative privileges. Passwords are case sensitive and must be entered in the
exact case combination in which they were created. The default password raritan must be entered
entirely in lowercase letters. To ensure security, change the default username password as soon
as possible.

If you do not see an icon for your IP-Reach or Dominion in the Navigator, please follow the
instructions in the Creating Profiles section in this chapter to create a new connection profile for
your IP-Reach or Dominion.

If you are having problems connecting to a Raritan device, be sure to check the following:

e Username: Raritan usernames are not case-sensitive.

e Password: Raritan passwords are case-sensitive.

e TCP Port: If you have configured your Raritan Device to use a non-default TCP Port, this
information must be entered into its connection profile.

e Firewall Settings: If you are accessing a Raritan Device through a firewall, that firewall
must be configured to allow two-way communication on TCP Port 5000 (or the custom TCP
Port to which your Raritan Device has been configured).

e Security Key: If you have configured your Raritan Device to require a group security key,
that key must be entered into the device' s connection profile.

Note: If you are running MPC on Internet Explorer with both a Microsoft Firewall and a non-
Microsoft Firewall utility installed, when you launch MPC — even if MPC is not open — IE will
launch a message telling you that MPC is already running. To avoid this, deactivate one of your
Firewalls, or use a browser such as Mozilla or Firefox.

Closing a Remote Connection

To close the IP-Reach or Dominion connection, select the device in the Navigator and right-click
on it. Select Disconnect from the shortcut menu.

To exit MPC or RRC completely, on the Connection menu, click Exit.

Note: RRC client PC can support only one modem connection at one time.
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Connection Info

To obtain information about your MPC connection:

Select Connection > Connection Info. The Connection Info window opens:

Connection Info

Itern

LS BN I = L o) B L o i

Ceszcription

| Crata

X
|

Tanmerts ~ATL

IP Address 192,1658,59.97
Part 3
Cata InfSecond 746
Cata QutfSecond z0
FP5 2
Connect Time oo0:01:12
Harizontal Resolution TE6E
Wertical Resolution &0 Hz
Refrezh Rate 01,19
Copy to Clipboard | | Claze |

=)

Figure 16: Connection Info

The following information is displayed about the current connection:

Device Name. The name of your Dominion or |P-Reach device.

IP Address. The IP Address of your Dominion or |P-Reach device.

Port. The KVM Communication TCP/IP Port used to access the target device.
Data In/Second. Datarate in.
Data Out/Second. Data rate out.
FPS. The frames per second transmitted for video.
Connect Time. The duration of the connect time.
Horizontal Resolution. The screen resolution horizontally.
Vertical Resolution. The screen resolution vertically.
Refresh Rate. How often the screen is refreshed.

Protocol Version. The RFB Protocol version.

To copy thisinformation:
Click Copy to Clipboard. The information is now available to be pasted into the program of

your choice.

=
g

Raritan.



CHAPTER 2: OPERATION 19

Navigator

The MPC and RRC Navigator panels provide a tree view of every known Raritan device so you
can access al Raritan networked appliances for which a connection profile exists and/or all
Raritan devices automatically identified on the network.

Note: Automatic Raritan device identification uses the UDP protocol, and will typically identify
all Raritan devices on your subnet. Network administrators rarely allow UDP broadcasts to
function outside of a subnet. Automatic Raritan device identification will find only those Raritan
devices that are configured to use the default TCP Port (5000) or another “ broadcast” port as
set in the Options panel on the Tools menu.

E? Raritan Devices

----- [ = ENG_TR364 [192.165.53.183]
----- [ S Ewa [192.165.53.110]

----- [ B Jackie-101-PS2 [192,165.52.94]
----- [ B Jackies [192.165.52.55]

----- & B Dominion KSX [192,168.51,184]
----- & B IP-Reach [192.168.0.192]

----- @ &1_; Techsupport-IPR [192,165.51,207]
----- @ S Dominion kS [192.168.51.202]
----- @ B K5%-223 [192.168.51.223]

----- & [ KSH440 [192.165.51.157]

----- & B kol 16-112 [192,168,51,167]

----- & B Dk [192,168.51,204]

----- & B K%432[192.168.51.188]

----- & S USTIP_TS [192.168.51.205)

----- @ S K224 [192.165.51.224]

----- @ B ClientSwGrp [192.168.51.245]
----- @ B Diowd [192.168.51.203]

----- & [ Dominion-KX [192, 165.51,40]
----- & [ Dominion-KX [192,168.51,213]
----- & B billskx<120 [192,168.51,120]

----- & S K_KIM-0007 [192.168.51.139]
----- @ S KX _KIM-0011 [192.168.51.70]
----- @ B GB-232-51_176 [192.165.51.176]

Figure 17: Expanded Navigation Tree

Each device entry in the Navigator provides two icons to communicate network status and
connection profile information. A connection profileis generally created by an MPC or RRC user
in order to store personalized information about specific devices (please see the section Creating
Profilesin this chapter for additional information).

In MPC, devices are named according to the Manager Name field in KX Manager’s Network
Configuration screen. Dominion KX 1l devices are named according to the Device Name field
in Dominion KX Il Console Network Settings screen.

In RRC, profiled devices are listed in the Navigator according to the data in the Description field
of the device's profile. Automatically-identified devices will be identified according to the name
assigned to them in that device’s network configuration setting.

Left Icon (Connection Profile | con)
O | Profiled — A network connection profile exists for this device.
Modem Profile — A modem connection profile exists for this device.

Not Profiled — MPC/RRC found this device on the network, but a connection profile
does not exist for it.

]
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Right Icon (Network Status | con)

Connected (green) — Y ou are currently authenticated and connected to this device.

Available (black) — This device is currently available on the network, but you are
= not currently connected to it.

Unavailable — A profile exists for this device, but it is not currently available on the
& | network. (Note that all devices with modem profiles to which you are not currently
connected will display thisicon.)

For each Raritan device to which you are connected, the Navigator expands its display tree to
show each port for which you have access.

o Portsdisplayed with agreen icon indicate that you are connected to that port.

e Bold type indicates which port is currently displayed (active) in the remote desktop area of
the client.

For each server port entry, the Navigator displays the following icons:

Connected (green)

Available for connection

Unavailable (no device connected, or accessis blocked)

| 7 | e | T

In use by another (may be unavailable depending on permissions)

Note: Blank port names are displayed as ‘Unnamed.” If you make a port name blank, it will
revert to this default when you reconnect to the device.

Navigator Customization
Use specific tools in the Toolbar to customize some Navigator attributes:

Display / Hide Navigator — Toggle Navigator visibility. You can also use View —
Navigator in the Menu Bar to toggle Navigator visibility.

0w Refresh Navigator — Update the device status information displayed in the
e Navigator.

Show Browsed Devices — Toggle whether the Navigator should display “Not

a Profiled” devices found on the network, or should show only devices for which

profiles exist. This option can aso be reached using View — Show — All in the
Menu Bar.

Note: The Browse connection method is the only method of connecting to a Raritan Device
configured to use DHCP IP addressing.
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Display and Sorting Options

To better organize your view of all ports, use the Show and Sort options. Please note that you do
not need an open connection to atarget to Show and Sort targets in the Navigation panel.

Showing Ports

In MPC and RRC, you can select which ports to view in the Navigation panel by selecting Show
options on the View menu.

o Discovered Devices: shows or hides discovered devices from the navigator view; you will
not see broadcast messages when this option is disabled.

¢ Unassigned Channels. shows or hides channels with no attached targets. Please note that the
default for generation 1 (G1) devices is to show unassigned channels (option is enabled),
wheress, the default is to hide unassigned channels (option is disabled) for generation 2 (G2)
devices.

e Tools: showsor hides the Admin and Diagnostic ports.

Wiew Help

¥ standard Toolbar

¥ Connected Server(s) Toolbar =

¥ statuz Bar

¥ Mavigator
[0 Mezzage

Show % ¥ ¥ Dizcovered Devices
Sort [0 Unaszigned Cchannels
M Tools

Figure 18: View, Show Menu Options

-

Note: These settings are saved from session to session.

=& Raritan.
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Sorting Ports

Use the Sort options on the View menu to organize KX port information; sort ports by channel
number, channel name, or channdl status.

Sort by Channel Number
When sorted by channel, ports are listed numerically.

i | Wiew Help
;E v Toolbar
v Statug Bar

Wl v Mawigator

T T [T T
T1G Test [192.168."
TIP M9 1RA A1 10

Figure 19: Sort Ports by Channel

EEsRaritan Remote Client

Connection | Tools  Wiew Help

[DlEmQls 2 m|=E

. B Dominion-Kx [192.168,51.34] -]
- & S Dominion-K¥ [192.168.51.184]
..... =) 1: SUN Solaris

..... 7= 2: Winz000

4= 3 Mac 05

4B 4 Linux

@ 5: Dave

4 & Alice

@ 71 Charley

4= 5: Barbara

-4 9 Ellen

4= 10: Frank

4= 11 Gail

@ 12: Henry

@ 13: Irene

4 14: Jack

4= 15: Dave 2
4= 16! Dave 0003
4= 17: Karen
4= 18 Larry
@ 19 Mary
4= 20; Meil
4= 21; Olivia
@ 22t Peter
4= 23 Quixote
4= 24: Randy
48 25: Arthur
4= 26 Bil

48 27: Charlene
4= 25 Deborah
@ 29: Kavier
@ 30: Evan

.- 4= 31: Francine
4= 32: Gerry
m Adrnin
Diagnostic
----- @ % Dominion-K3% [192,168,51.231]

----- @ Bl Dominion-Kx [192. 168.51,252]
o B R v 107 182 ©1 1761 LI

Raritan Remoke Client

Figure 20: Navigator in Channel Order
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Sort by Name

When sorted by name, port names are sorted al phanumerically within each group.

Wiew Help

v Toolbar
v Status Bar

o LD e bt )

-

v Mavigator

Show k
'
16 Test [192.168.8
P92 1RR AT 1N

Statuz

Figure 21: Sort Ports by Name
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Figure 22: Navigator in Name Order
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Sort by Status

Ports are sorted in the following order:

Active Channels
Busy Channels
Available Devices
Unavailable Devices

i Yiew Help

[iw Toolbar
= Status Bar

A vt Wawigator
i 1178
Show L !
' BT e
T I ame

106G Test [192.168.F
P [192.168.51.10

[ R R PR |

Figure 23: Sort Ports by Status

5 Raritan Remote Client
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= @ Sk Dominion-k¥ [192.168.51.184]
..... =) 50N Solaris: 1
..... 7B win2000: 2
- AE plice: &
4= arthur: 25
4= Barbara: &
4= il 26
4@ Charlene: 27
4 Charley: 7
4= Dave: 5
@ Dave 2: 15

4= Dave 0003 16
.48 Deborah: 28
4= Ellen: 9
@ Evan: 30
48 Francine: 31
4= Frank; 10
= Gail: 11
4 Gerry: 32
48 Henry: 12
@ Irene: 13
4 Jack: 14
4= Karen: 17
-4 Larry: 18
@ Linus: 4
4= Mac 05%: 3
4 Mary: 19
A eil: 20
A Oliviar 21
4= Peter: 22
4= Quixote: 23
A= Randy: 24
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Figure 24: Navigator in Status Order
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MPC Navigator Tabs

MPC tabs at the base of its Navigator pane. These tabs allow you to change how you display
devices.

Click the View By Name tab to sort the list alphabetically by name, or click the View By IP tab
to sort the list numerically by IP address.

I—@ B 1101 -kim-tyler [192. 168,
K

4 |

Wigw By Mame | Wisw By IP

Figure 25: MPC Navigator Tabs

Please note that these tabs are available only in the MPC interface.

In both MPC and RRC, if al ports of the device to which you are connecting are aready
occupied, an alert message appears and you must try to connect when one or the portsis available.
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Toolbars and Shortcuts
Standard Toolbar

The Standard Toolbar provides one-click access to the most frequently-used commands.
To display the standard toolbar:
Select View > Standard Toolbar.

IDEmQ e BEE & =8 DRa 2

Figure 26: MPC / RRC Standard Toolbar

BuUTTON BuTTON NAME FuNcCTION

New Profile Creates a new Navigator entry for a Raritan device; same results as
selecting Connection = New Profile in the menu bar.

Connection Opens Modify Connection Properties dialog box to manually adjust
Properties bandwidth-correlated options (Connection Speed, Color Depth, etc.).

Opens the Video Settings dialog box to manually adjust video conversion

Video Settings parameters

Color Calibration | Adjusts color settings to reduce excess color noise.

Synchronize In dual-mouse mode, forces realignment of target server mouse pointer
Mouse with Raritan Remote Client mouse pointer.

Refresh Screen | Forces refresh of video screen.

Auto-sense Video Forces refresh of video settings (resolution, refresh rate).

El 0 8| v 2|0 | 0

Settings
Enter On-Screen | Not applicable for IP-Reach or Dominion. Used by MPC/RRC with other
Menu Raritan products.
Exit On-Screen | Not applicable for IP-Reach or Dominion. Used by MPC/RRC with other
Menu Raritan products (on keyboard, press ESC)
A Send
CEL CTRL+ALT+DEL Sendsa CTRL+ALT+DEL key sequence to the target server.

Single Cursor | Enters Single Cursor Mode, in which the local PC's mouse pointer no
Mode longer appears on-screen. Press CTRL+ALT+X to exit this mode.

Full Screen Mode | Maximizes the screen real estate to view the target server desktop.

Increases or reduces target video size so you can view the entire contents

Scaling of the target server window without using the scroll bar.
Show / Hide . . .
Navigator Toggles Navigator panel from visible to hidden.

B EHE O£ <

Refresh Navigator | Forces arefresh of the data displayed by the RRC Navigator.

Show / Hide Toggles whether or not the RRC Navigator displays Raritan Devices

a “Browsed” automatically identified on the network (that do not have pre-configured
Devices profiles associated with them).
? About Displays version information about MPC and RRC.

i)
(0

i=Raritan.
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Connected Server(s) Toolbar

The Connected Server(s) Toolbar is comprised of a button for each connected target server (port)
enabling quick access to connected targets. When you connect to a port, a button corresponding
to that port is added to the toolbar, labeled with the name of the port. When you disconnect from
a port, the corresponding button is removed from the toolbar. And when the Raritan device is
disconnected, all of the buttons corresponding to the ports of that device are removed from the
toolbar.

8 cso. W Ad. | B winz..| B chan...

Figure 27: Connected Server(s) Toolbar

The default for the Connected Server(s) Toolbar isthat it is enabled (visible).

Todisplay the Connected Server(s) Toolbar (when not already visible):
Select View > Connected Server(s) Toolbar.

Toview thewindow for atarget server:

Click the button for the appropriate connected target server. The window for the
corresponding port is brought forward, and the button for the selected port is highlighted.

Note: When you click a button that is already highlighted, the corresponding window is
minimized. If you click that button again, the window is brought forward and maximized.

Notes for Full Screen Mode

e Without getting out of full screen mode, click on the Connected Server(s) Toolbar button
to open the video window for the appropriate target server. Please note that this action is
window swapping (not video switching).

e Buttons corresponding to windows that do not support full screen are not shown in the
toolbar (for example, serial ports, generation one (G1) admin ports, and G1 diagnostic
ports).

e When you move your local cursor to the top while in full screen mode, the Connected
Server(s) Toolbar appears.

e The Connected Server(s) Toolbar does not appear in Single Mouse mode.
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Status Bar

The Status Bar displays session information about your connection to a Raritan |P-Reach or
Dominion unit.

-
4 »

| Path 3 (KM Port 3) I = [ € CAP [NUM [SCRL

/ Bandwvidth Usage Indicatar
Video Sensing Status ¢ Path Indicatar | | E | / Cackiieyjindicatons

Security Indicator Concurrent Connections

Indicatar

Figure 28: Status Bar

Video Sensing Status / Path Indicator: indicates the occurrence of video sensing, during
connections to target KVM Server ports.

Bandwidth Usage Indicator: indicates how much of your total available bandwidth is
currently being used. The Connection Speed setting, found under the Compression tab of the
Connection Properties screen, determines total available bandwidth.

Security Indicator: indicates whether the current remote connection is protected by
encryption. Encryption requirements are set during 1P-Reach or Dominion configuration of
your Raritan KVM over IP device. When a Raritan IP-Reach or Dominion device is
configured for No encryption or SSL Authentication, NO data encryption, the Security
Indicator is represented on the Status Bar as an open lock. When SSL authentication, data
encryption or SSL authentication, SSL encryption is selected, the Security Indicator is
represented on the Status Bar as a closed lock.

Concurrent Connections Indicator: indicates if multiple remote users are currently
connected to the same IP-Reach or Dominion target server on the device, showing one icon
for asingle connected user, and two iconsif two or more users are connected.

Concurrent connection ability can be set globally under PC share mode on the KX Manager
Security Settings screen, or set per individual user in the Concurrent Access M ode setting
on the KX Manager User Account Settings screen. For Dominion KX [I, concurrent
connection ability can be set using the PC Share Mode option in the Dominion KX I
Security Settings page: PC-Shar e permits concurrent access; Private limits server access to
one user at atime.

Lock Key Indicators. indicates the status of the current target KVM Server, with respect to
the activation of the Caps-Lock, Num-Lock, and Scroll-Lock keys. If these keys are enabled
on the target server being viewed, this affirmative status will be reflected on the Status Bar as
indicated.

Note: The Lock Key (Scroll Lock, Num Lock, Caps Lock) LEDs on your keyboard that indicate
whether the Lock Key is active may or may not be in sync with the Lock Key Indicators on the
RRC Status Bar. Please use the Status Bar as your guide.




CHAPTER 2: OPERATION 29

Remote KVM Console Control

Once you establish a connection with a Raritan |P-Reach or Dominion KX device, that unit’' sicon
in the Navigator expands to display al ports enabled for remote

i raritan Devices ]
[ C%a pill's kxz32 [192.168.51.120]
—Q. billsk=101 [192.1658.51.53]
—@ﬁ billsk=121 [192,165.51.121]
—Dn: Brown Room Dominion-K& [192
Channel 2

t Chanrnel 2

t Channel 19

t Channel 4

t Channel 5

t Channel &

= 7: Channel 7

j 8 Channel 8

B 2 Channel 9

Figure 29: Navigation Tree

Choose one of the following options to establish a remote KVM console connection:

o Double-click on the KVM port you want to control — this method closes any previous
connection befare connecting to the new port

e Right-click on the port and select Switch from the shortcut menu — this method closes any
previous connection before connecting to the new port

e Right-click on the port and select New Connection from the shortcut menu — this method
alows you to connect to the selected port without closing any previous connections, creating
anew connection if the device supports multiple concurrent connections

Once connected, Raritan KVM over |IP devices display rea-time video output of the target server
(this video is compressed and encrypted according to the configuration settings specified by the
Administrator). You now have complete, low-level control of the KVM console as if you were
physically located next to the server.

To close a connection, right-click on the connected device and click Disconnect.
To exit MPC or RRC completely, on the Connection menu, click Exit.
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Keyboard Shortcut Menu

To access the MPC or RRC keyboard shortcut menu, use either the default keyboard combination
of CTRL+LEFT ALT+M or the keyboard combination you assign (please see next section for
directions on changing the default keyboard combination). Execute any of the commands on the
shortcut menu either by pressing (on your keyboard) the underscored letter on the button face, or
by clicking the button in the menu with your mouse cursor.

Note: You must usethe LEFT ALT key on your keyboard.

=i=Raritan.

Auto Senze

Connechion [nfarmatian

Connechon Properties

Wideo Settings

Refrezh Screen

Caolor Calibrate

Synchronize mouge

Single/Double curzor

Send CH+alk+Del

Send Ch+alt+hd

Cancel [Ezc)

Figure 30: Hot Key Shortcut Menu

To:

Toggle to/from Full/Normal Screen Mode*

PRESSCTRL+LEFT ALT+M, AND THEN PRESS.
=

Perform video Auto Sensing**

A

Display connection information*

Display or Set connection properties*

Display or Set Video Settings*

Refresh screen

Color Calibrate**

Synchronize mouse

Change to/from Single/Double cursor mode

Send CTRL+ALT+DEL to the target system

Send CTRL+ALT+M to the target system

ZI O wn < 0 1 <|T

Exit the Dialog/Menu without altering the
keyboard state

rn
8

* |f Full Screen Mode is active, executing this command will automatically end Full Screen Mode.

** |f Full Screen Mode is active, executing this command will automatically end Full Screen Mode only in RRC.

=& Raritan.
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Windows Key and Keyboard Shortcuts in MPC

Windows Key and the Start Menu

When running MPC on a Windows JRE 1.4.2_x platform, if you press the Windows Key 2 to
display the Start Menu, the Start Menu will only appear on the Client machine, the key is not
sent to the Target device.

When running MPC on a Windows JRE 1.5.0 x platform, if you press the Windows Key, the
Start Menu appears both on the Client and the Target devices. Use your mouse to manually close
the Start Menu you do not want to use.

Please note that if you do not close the Target device Start Menu properly, any key that you touch
on your keyboard (that has a Windows Key combination function) will send that command to the
Target device; for example, if you press E, the Target device will launch a new Explorer window;
if you press D, all Target windows will be minimized so you can view the Desktop. To close the
Start Menu on the Target device, click on the Start button or click away from the Start Menu.

Changing the Keyboard Menu Shortcut Hotkey Combination

Tools— Options
New section: Keyboard Menu Shortcut Hotkey — drop down with CTRL+LEFT ALT + [A-Z]
The menu will change, the onscreen message will change; both take on the newly assigned combo.

If you forget the combo, press CTRL+LEFT ALT together and the Keyboard Menu Shortcut
Hotkey appears across the bottom of the screen for five seconds. Press to toggle.

In Full screen mode, need the KM SH to get back to regular view.

Single Mouse Mode / Dual Mouse Mode

When remotely viewing a target server that uses a pointing device, you will see two mouse
pointers in the Remote Desktop. When your mouse pointer lies within the Remote Desktop area
of MPC or RRC, mouse movements and clicks are directly transmitted to the target server
connected. The MPC/RRC mouse pointer, generated by the operating system on which
MPC/RRC is running, slightly leads the target server’'s mouse pointer during movement, a
necessary result of digital delay.

On fast LAN connections, you may want to disable the MPC/RRC mouse pointer and view only
the target server’s pointer. To toggle between these two modes, use the CTRL+LEFT ALT+M
Hot Key combination to activate the Hot Key menu, then press the letter S on your keyboard to
select Single/Double Cursor (or press the Single M ouse Pointer mode icon in the Toolbar).
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Figure 31: RRC Remote Desktop
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Figure 32: MPC Remote Desktop

Single Cursor Mode

You are about to enter Single Cursar mode. While you are in this mode,
thiz software will have excluzive contral over the mouse and keyboard.

To exit Single Curzor mode you must press:

Ctil + 2k + M, then 5

W Show this dialog each time you start Single Cursor mode.

OF. I Cancel

Figure 33: Single Cursor Mode Window

=& Raritan.
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When in Dual Cursor mode, press CTRL+LEFT ALT+M and execute the Synchronize Mouse
shortcut to force realignment of the mouse pointers. If the mouse pointers still remain out of sync,
click on the Auto-Sense Video Settings button on the Toolbar.

[EI Auto-Sense Video Settings button

Note: When in Dual Cursor mode, if the dual mouse pointers are synchronized, but left idle for
five minutes or longer, the target mouse pointer will automatically align itself with the upper left
corner of the target window. Execute the Synchronize Mouse command to ensure local and
target mouse pointer alignment.

Automatic Mouse Synchronization

When in Dual Cursor mode, the system will automatically align the mouse pointers when the
cursor is inactive for 15 seconds. Enable this feature by selecting Options from the Tools menu
and clicking on the checkbox before Auto-Sync mousein two-cur sor mode.
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Mouse Synchronization Options

In addition to synchronizing mouse pointers or toggling Single Cursor Mode, RRC's Mouse

menus provide three options for syncing pointers when in Dual Cursor mode:

e Absolute: When connected to selected Dominion KX units and targets with USB ports, MPC
will use absolute coordinates to keep the pointersin sync.

o Inteligent: Under certain conditions, MPC can detect the target mouse settings and
synchronize the mouse pointers accordingly, allowing the user to have mouse acceleration on
the target device. See Appendix B: Conditions for Intelligent Mouse Synchronization for
more details.

e Standard: Thisis the standard mouse synchronization algorithm. For the proper target mouse
settings, see the User Guide of your Raritan KVM over |P device.

Please note that only Intelligent and Standard mouse are available to MPC and RRC users
working on Dominion KX units.

Screen Modes

Full Screen / Target Screen Resolution

Besides a standard view, MPC and RRC provide a Full Screen view and a Scaling option, which
increase the Remote Desktop Area, making viewing the target video easier. In MPC, thisoption is
called Target Screen Resolution mode and in RRC, it is called Full Screen mode.

Use the Full Screen M ode shortcut on the Toolbar to activate Full Screen mode, or use the menu
commands as described.

=)

Note: Full Screen Mode is not available in MPC only on a Dominion KX unit when the KX unit
isunder CommandCenter Secure Gateway (CC-SG) control.
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MPC - Target Screen Resolution Mode

Target Screen Resolution mode removes the surrounding MPC graphical interface (except for
scrollbars) and your local desktop area, completely filling your monitor with the target server
video. Y our monitor’s resolution may be adjusted to match the resolution of the target server.

To view which video resolutions your system supports, access your computer’s Control Panel
from the Windows Start menu, double-click on Display, and click on the Settingstab.

Activate Target Screen Resolution mode, once connected to a target, from the View menu. On
the View menu, click Target Screen Resolution. If you prefer to use the Hot Key menu, press
CTRL+LEFT ALT+M and then the letter F on your keyboard to select Full/Normal Screen.

If your graphic system does not support the resolution of the target system, you will be unable to
activate Full Screen mode and a message will appear, requesting that you change your video
resolutions first.

uuuuuuuuuuuuu
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Figure 34: Target Screen Resolution Mode in MPC

Note: The CTRL+LEFT ALT+M key combination does not work for certain target serversif you
are running JRE 1.5.0_01. To return from full screen mode, use Alt+Tab and select MPC.

Z&Raritan.
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RRC - Full Screen Mode

Full Screen mode removes the surrounding RRC graphical interface and your local desktop area,
filling your monitor with the video from the target server. Y our monitor’ s resolution will be
adjusted to match the resolution of the target server, if your graphics system supportsit.

To view which video resolutions your system supports, access your computer’s Control Panel
from the Windows Start menu, double-click on Display, and click on the Settings tab.

Activate Full Screen mode, once connected to atarget, from the View menu. On the View menu,
click Full Screen. If you prefer to use the Hot Key menu, press CTRL+LEFT ALT+M and then
the letter F on your keyboard to select Full/Normal Screen.

If your graphic system does not support the resolution of the target system, you will be unable to
activate Full Screen mode and a message will appear, requesting that you change your video
resolutions first.

Atmel Procornm Pl

e 2MHdls e H > [FBNVERAST & a25pPm
Figure 35: Full Screen Mode in RRC
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Scaling

Scaling your target window size alows you to view the entire contents of the target server
window. This feature increases or reduces the size of the target video to fit the MPC/RRC
window size and maintains aspect ratio, so that you see the entire target server desktop while in
the full standard MPC/RRC view.

To activate Scale Video mode and increase the size of the target video window, on the View
menu, click Scale, or use the Scaling shortcut on the Toolbar. To exit this mode and return the
target window to its previous size, on the View menu, click Scale, or click the Scaling shortcut
once again.

7]

%Raritan Multi-Platform Client o[]S
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Figure 36: Scale Video Mode
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Auto-Scroll

The auto-scroll feature automatically scrolls the video display in the direction of the cursor as the
cursor approaches the edge of the display. A thin border appears around the perimeter of the
Remote Desktop Area (this border can be activated using the Tools menu). If you see scroll bars,

when you move the mouse cursor onto the border, the screen will automatically scroll in the
appropriate direction.

Ml GB-232-51_176 - GB-232-51_176 at 192.168.51.176 :: Channel 5

The blank border L % FHODETES

around the target —

video isthe Auto- =Y Enccuwtio—] Mail
Scroll area.

e D E lste] (N Eor

Sieqijse =il
—a

il o

»
&

Finiel Filz Ml SUSHESH oM BE

e
I ql

N

Figure 37: Auto-Scroll View with Border Indicated

Note: Enabling Scale Video will scale the complete target video image to fit the Remote Desktop
Area as it grows or shrinks. You can combine this setting with Target Screen Resolution for a
full screen affect on targets with a higher resolution than your desktop.

—=V=
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Keyboard Handler

RRC sends all keystroke combinations to the target system with the following exceptions:

e CTRL+ALT+DEL — Reboots the computer; the sequence is sent to the local system and the
Windows Security (Task Manager, Shutdown, etc.) dialog is displayed.

e CTRL+Num Lock — This toggles the state of the Num Lock LED if the Num Lock state of
the local system disagrees with that on the target system.

e CTRL+Caps Lock — This toggles the state of the Caps Lock LED if Caps Lock state of the
local system disagrees with that on the target system.

e CTRL+Scroll Lock — This toggles the state of the Scroll Lock LED if Scroll Lock state of
the local system disagrees with that on the target system.

e CTRL+LEFT ALT+M - Brings up a diadog/menu providing normal RRC shortcuts
(described below).

o Keystrokes used to generate user-defined keyboard macros.

e Print Scrn — Treated locally and copies the screen to the clipboard.

There are no other exceptions. For example, AL T+F4 closes the current program on the target
system.

Keyboard Macros

IP-Reach or Dominion’s Keyboard Macro feature ensures that keystroke combinations intended
for the target server are sent to, and interpreted only by, the target server. Otherwise, they might
be interpreted by the computer on which MPC or RRC is running.

CTRL+ALT+Delete Macro

Due to its frequent use, a CTRL+AL T+Delete macro, used to reboot the target computer, has
been pre-programmed into MPC and RRC.

Send Sends a CTRL+ALT+DEL macro to the target
EEtl |CTRL+ALT+DEL server.

Clicking on the CTRL+AL T+Delete shortcut in the Toolbar sends this key sequence to the
server or KVM switch to which you are currently connected. In contrast, if you were to physically
press the CTRL+ALT+Delete keys while using MPC or RRC, the command would first be
intercepted by your own PC due to the structure of the Windows operating system, instead of
sending the key sequence to the target server asintended.
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Building a Keyboard Macro

These directions describe how to create a keyboard macro for the Windows command Minimize
All Windows/Show Desktop. Follow these steps, substituting the appropriate key combination
for the command you want, to create your own macro.

For example: In Windows, pressing a keyboard macro is a shortcut that sends a command to your
PC. When connected to a target server with MPC or RRC, a keyboard macro is one means to
accomplish this task on the target server — because pressing the key combination results in your
own client PC intercepting the command and performing it — instead of sending the command to
the target server as intended.

1. Onthe Keyboard menu, click Keyboard Macros.

2. When the Keyboard Macros window appears, click Add to add a new macro. The Add
Keyboard Macro window appears.

Add Keyboard Macro x|
Keyboard Macra Mame I
Hot-Key Combination INU Hot-Key j
Keyps to Press
Keys to Release Macro Sequence
IAII Keyps 'l

Left Chl -
Right Clrl

Left &t

Right &t

Left Shift

Right Shift

Left Windows Key
Right "wfindows Key
tenu Key

Frint Screen/SyzRg
Pause

ol Lock =
Eress Key | Eelease Key | Eemoye | j j
[E{ear, | Lancel | QK I

Figure 38: Add Keyboard Macro Window

3. Build the Keyboard Macro by editing the fields in the Add Keyboard M acr o window:

A. Typeanamein the Keyboard Macro Name field. This name will appear on the MPC or
RRC Menu Bar after the macro is created. In this example, type Minimize All Windows.

B. Optional: In the Hot-Key Combination field, select a keyboard combination from the
drop-down list. This allows you to execute the macro with a predefined keystroke when
MPC is running. In this example, select the CTRL+ALT+1 keystroke from the drop-
down list.

C. Inthe Keys to Press drop-down list, scroll through and select each key for which you
would like to emulate key presses — in the order by which they are to be pressed. Click
Press Key after each selection. As each key is selected, it will appear in the Keys to
Release field. In this example, select two keys: the Windows key and the letter D key.

D. In the Keys to Release field, select each key for which you would like to emulate key
releases — in the order by which they are to be released. Click Release Key after each
selection. In this example, both keys pressed must also be released.
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E. Review the Macro Sequence field — the contents are automatically generated depending
on the Keys to Press and Keys to Release selections. Ensure that the contents list the
exact key seguence you want. To remove a step in the sequence, select it, and click
Remove. To change the order of steps in the sequence, select the step and click M and ¥

to re-order the steps.

Add Keyboard Macio

Kewboard Macro Mame IMimmize Al indows
Haot-K.ey Combination ICTHL+ALT+1 j
Keys ta Press
Keyps to Release Macro Sequence
IAII Keys 'I
B ;I Press Left Windows Kep
C Press D
D Releaze Left Windows Key
E Release D
F
G
H o
|
J
K.
L
M [
Eress key | Eeleaze Hey | Fremove: | J ﬂ
Clear | LCancel | [0]:4 |: I

Figure 39: Add Keyboard Macro Window

4. Click OK to save the macro, or Cancel to close the window without saving. Click Clear to
clear al field and start over. When you click OK, the Keyboard M acros window appears,

listing the new keyboard macro.

Keyboard Macros x|

Minimize Al Windows

Select a macro from the above list.

Bk zerm

[ it
[ s
e

EEmeve

el ity

Figure 40: Keyboard Macros Window

5. Click Closeto close the window.

=
g
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Running a Keyboard Macro

Once you have created a keyboard macro, execute it from the Keyboard menu or by using the
Hot Key (keyboard) combination if you assigned one while creating the macro.

Menu Bar Activation

When you create a macro, it appears under the K eyboard menu. Execute the keyboard macro by
clicking on its name on the K eyboar d menu.

Eﬂalilan Remote Client - [Headquarters - PM_IP-Beach at 192 168.50.173
#l Cornection | Keyboard Wideo Mouze Toolks Wiew ‘window Help

Send Chri+al+Delete Childil+D
Enter On-Screen Menu
Exit On-Screen Menu

ESC

K.eyboard Macros...

Mirimize

My Documnents

Figure 41: Macro Listed on the Keyboard Menu

Hot Key Activation
If you assigned a Hot Key combination to a macro when building it, you can execute the macro

by pressing its assigned keystroke. In this example, press the keys CTRL+ALT+1
simultaneously to minimize all windows on a Windows target server.

=V=
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Connection and Video Properties

The IP-Reach and Dominion dynamic video compression algorithms maintain KVM console
usability under varying bandwidth constraints. The IP-Reach and Dominion units optimize KVM
output not only for LAN use, but also for WAN and dialup use. These units can also control color
depth and limit video output, offering an optimal balance between video quality and system

responsiveness for any bandwidth constraint.

The following parameters in the Connection Properties and Video Settings windows can be
optimized to suit your requirements for different operating environments.

Connection Properties

Connection
Properties

ﬂ'_.
(=1
—--

smoothing, etc.).

Manually adjust bandwidth-related options (connection speed, color depth,

To set the connection properties:

1. Select Connection > Properties. In MPC, the Properties Dialog opens. In RRC, the M odify

Connection window opens.

Properties Dialog f | X
Compression |
Compression |
Connection Speed: ‘Auto Detect - ‘
Connection Spead! !Auto Detact iv Color Depth: ‘Autu Selact Color v‘
Caolor Depth: IlS-bit RERE Calor iv
[[] Internet Flow Contral
Srneocthing: O Laow Smaothing: .
Frames per zecond
5 fps () 10 fps ) 20 fps
| Ok H Cancel || = Ra] U1 |
| ok || coneer || e |
Generation 2 (G2)
Generation 1 (G1)
Figure 42: Properties Dialog in MPC
Modify Connection
Compreszion I
Connection Speed: If—'«utn Detect j
Color Depth: IAutD Select Color j
2| Brogressive pdate
" Intemet Flow Contral
Smoothing ] -—J' GER
Cancel Appli
Figure 43: Modify Connection in RRC
2. Update the settings in the Compression tab.
=¥ .
=&Raritan.
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— Connection Speed: Use this setting to manually adjust the connection speed to
accommodate bandwidth constraints. 1P-Reach and Dominion can automatically detect
available bandwidth and not limit bandwidth use; but you can aso adjust this usage
according to your needs. Depending on the Raritan device in use, different options may
be available.

Auto Detect

1G Ethernet

100mb Ethernet

10mb Ethernet

1.5mb (Max DSL/T1)

1mb (Fast DSL/T1)

512 kb (Medium DSL/T1)

384 kb (Slow DSL/T1)

256 kb (Cable)

128 kb (Dual ISDN)

56 kb (ISP Modem)

33 kb (Fast Modem)

24 kb (Slow Modem)

— Color Depth: IP-Reach and Dominion can dynamically adapt the color depth transmitted
to remote users in order to maximize usability in all bandwidths. Select from among the
options in the drop-down list (depending on the Raritan device in use, different options
may be available):

15-bit RGB Color

8-bit RGB Color
4-hit Color

4-bit Gray

3-hit Gray

2-hit Gray

Black and White

— Please refer to Connection Profiles for information about the Progressive Update,
Internet Flow Control, Smoothing (15-bit mode only), and Frames per second (MPC
only) options.

Important: For most administrative tasks (server monitoring, reconfiguring,
etc.), administrators do not require the full 24-bit or 32-bit color spectrum
made available by most video graphics cards. Attempting to transmit such
high color depths wastes network bandwidth.

3. Click OK to change the Connection Properties or Cancel to close the window without saving
changes.
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Video Settings
Video settings can be refreshed in several ways:
e Using Video > Refresh Screen

e Directing IP-Reach or Dominion to automatically detect the video settings (Video > Auto-
sense Video Settings)

e Using the Color Calibration command to calibrate the video, enhancing the colors displayed

e Changing the settings from the Video Settings screen

- Video Settings | Opens Video Settings for manual adjustment of video parameters.

To change the video settings:
1. Seect Video > Video Settings. The Settings window opens:

Settings

Video Setting |

~Maise Filtzr

“|
Maize Filter: | 2 £
= ; ;
-PLL Settings -
Clack: 1,688,—j Phaze: ﬂ%
-Color Settings
= =
Brightness Rad: 35,—::
Brightness Green: 82,—:: E
Brightness Blue: 46,—j L
~ =
Caontrast Red: 1??,—j L
B e
Contrast Green: 13655 F
= Tl
Contrast Blue: 148
— e
Horizantal Offset: 392,—:: L

L
]

37

=
m
3
n
w
Q
e
"
m
b

D Preview

[[] Autornatic Color Calibration

~Widea Sensing

@ Best possible video mode

o

Quick sense video mode

| Ok, H Cancel H Apply ‘

Figure 44: Settings (Video)

2. Update the desired settings:

— Noise Filter: IP Reach and Dominion can filter out the electrical interference of video
output from graphics cards. This feature optimizes picture quality and reduces bandwidth.
Higher settings transmit variant pixels only if alarge color variation exists in comparison
to the neighboring pixels. However, setting the threshold too high can result in the
unintentional filtering of desired screen changes. Lower settings transmit most pixel
changes. Setting this threshold too low can result in higher bandwidth use.

=& Raritan.



46

RARITAN MPC AND RRC UseR GUIDE

Note: Lower Noise Filter settings (approximately 1 to 4) are recommended. Although
higher settings will stop the needless transmission of false color variations, true and
intentional small changes to a video image may not be transmitted.

PLL Settings: If the video image looks extremely blurry or unfocused, the PLL Settings
for clock and phase can be adjusted until a better image appears on the active target
server.

Warning: Please exercise caution when changing the Clock and Phase
settings; doing so may result in lost or distorted video and you may not
be able to return to the previous state. Contact Raritan Technical
Support before making any changes.

= Clock: Controls how quickly video pixels are displayed across the video screen.
Changes made to clock settings cause the video image to stretch or shrink
horizontally; odd number settings are recommended. Under most circumstances this
setting should not be changed because the auto-detect is usually quite accurate.

» Phase: Phase values range from 0 to 31 and will wrap around. Stop at the phase
value that produces the best video image for the active target server.

Color Settings. These settings control the brightness, contrast, and positioning of the

target server display.

= Brightness Red. Controls the brightness of the red signal; rangeis 0 — 127.

= Brightness Green. Controls the brightness of the green signal; rangeis0 — 127.

» Brightness Blue. Controls the brightness of the blue signal; rangeis 0 — 127.

= Contrast Red: Controlsthered signal contrast; range is 0 — 255.

= Contrast Green: Controlsthe green signal contrast; rangeis 0 — 255.

= Contrast Blue: Controls the blue signal contrast; range is 0 — 255.

= Horizontal Offset: Controlsthe horizontal positioning of the target server display on
your monitor; rangeis 0 —512.

= Vertical Offset: Controlsthe vertical positioning of the target server display on your
monitor; rangeis 0 — 128.

3. To preview the change prior to making the selection, check the Preview checkbox.

e

Check the Automatic Color Calibration checkbox to enable this feature.

5. Video Sensing: Select the video sensing mode:

Best possible video mode: IP-Reach or Dominion will perform the full Auto Sense
process when switching targets or target resolutions. Selecting this option calibrates the
video for the best image quality.

Quick sense video mode: Selecting this option will cause |P-Reach or Dominion to use a
quick video Auto Sense in order to show the target's video sooner. This option is
especially useful for entering atarget server’s BIOS configuration right after a reboot.

6. After you change avalue, click Apply.

7. Click OK to change the Video Settings or Cancel to close the window without saving
changes.

Note: Some Sun background screens, such as screens with very dark borders, may not center
precisely on certain Sun servers. Use a different background or place a lighter colored icon in
the upper left corner of the screen.
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Video Settings (Generation 1 Only)

Opens the Video Settings dialog box to manually
adjust video conversion parameters.

I. ] Video Settings

1. OntheVideo menu, click Video Settings. The Settings window appears.

Setings __________________K

“Wideo Setting |
— Moige Filter
Moize Filter: I 2 _|::' j
— PLL Settings
Clock: |1 056 3: Phasze: |1 3:
— Calor Settings
Fed Gain: |1 g5 3: J'
Red Offzet; |33 3, J'
Green Gair: |1 E5 3: J'
. = 1
Green Offset: |33 3 |
BlueGain:  [165 = i
. = 1
Blue Dffset: |33 3_ |
v Link Calar Conbrals
WVideo Sensing

% Best possible video mode

= Quick sense video mode

Cancel | Apply |

%

Figure 45: Video Settings (Generation 1)

These settings can be refreshed using the Color Calibration command, described in the next
section, by manually forcing IP-Reach or Dominion to auto-detect the video settings (on the
Video menu, click Auto-sense Video Settings), or by changing the settings in this screen. After
you change avalue, click Apply to test the setting.

— Noise Filter: 1P-Reach or Dominion can filter out electrical interference of video output
from graphics cards. This feature optimizes picture quality and reduced used bandwidth.

Note: The default Noise Filter is4; Raritan recommends that you lower this valueto O (zero).

= Higher: Noise Filter settings instruct IP-Reach or Dominion to transmit a variant
pixel of video only if alarge color variation exists in comparison to its neighbors.
However, setting the threshold too high can result in the unintentional filtering of
desired screen changes.

= Lower: Noise Filter settings instruct IP-Reach or Dominion to transmit most pixel
changes. Setting this threshold too low can result in higher bandwidth use.

=& Raritan.
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Note: Lower Noise Filter settings (approximately 1 to 4) are recommended. Although higher
settings will stop the needless transmission of false color variations, true and intentional small
changes to a video image may not be transmitted.

Analog-to-Digital Settings: The following parameters are best left to IP-Reach or
Dominion to automatically detect (on the RRC Menu Bar, select Video > Auto-sense
Video Settings), but a brief description of each isincluded here.

PLL Settings: If the video image looks extremely blurry or unfocused, the PLL Settings

for clock and phase can be adjusted until a better image appears on the active target

server.

» Clock: Horizontal sync divider to produce pixel clock. Controls how quickly video
pixels are displayed across the video screen. Changes made to clock settings cause
the video image to stretch or shrink horizontally. Odd number settings are
recommended.

» Phase: Phase values range from 0 to 31 and will wrap around. Stop at the phase
value that results in the best video image for the active target server.

Color Settings: Gain control can be thought of as contrast adjustment. Offset control can

be thought of as brightness adjustment.

= Red Gain: Controls the amplification of the red signal.

» Red Offset: Controlsthe bias of the red signal.

= Green Gain: Controlsthe amplification of the green signal.

= Green Offset: Controls the bias of the green signal.

» Blue Gain: Controls the amplification of the blue signal.

= Blue Offset: Controls the bias of the blue signal.

= Link Color Controls. Makes al the gain dlide adjusters move in unison when any
one color'sgain slideis moved and all the offset slide adjusters move in unison when
any one color’s offset dideis moved.

Best possible video mode: 1P-Reach or Dominion will perform the full Auto Sense

process when switching targets or target resolutions. Selecting this radio button will

cause | P-Reach or Dominion to calibrate the video for the best image quality.

Quick sense video mode: Selecting this radio button will cause |P-Reach or Dominion to

use a quick video Auto Sense in order to show the target’s video sooner. This option is

especially useful for entering atarget server’s BIOS configuration right after a reboot.

2. Click OK to set Video Settings or Cancel to close the window without saving changes.

Note: Some SUN background screens, such as screens with very dark borders, may not center
precisely on certain SUN servers. Use a different background or place a lighter colored icon in
the upper left corner of the screen.
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Video Settings (KX101)

Video Setting |
~ Muise Filter
NoseFiter [ 8= — J—
—PLL Setting
Clack: Im Phase: lm
i~ Color Setting:
Bighness: 9% o ——————
Fed Contrast,  [128 B — }——r
Green Contrast: [128 3: —J—
Blue Cortrast:  [128 J—
¥ Link Color Contrals

Videa Sensing
¥ Best possible viden mode

" Quick sense video mods

(1]:4 I Cancel | Lppl

Figure 46: Video Settings for Dominion KX101

Raritan’s Dominion KX101 Color Settings window varies from those of other Dominion KX

units.

1. IntheColor Settings panel, adjust the following options:

= Brightness: Controls the backlight on your screen.

= Red Contrast: Controlsthe level of red tone on your screen.
= Green Contrast: Controlsthe level green tone on your screen.
= BlueContrast: Controlsthe level of blue tone on your screen.

» Click ontheLink Color Controls check box to make all above dide adjusters move
in unison when any one option is moved.

2. Click OK when finished.

—=V=
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Color Calibration

Color

&Y |calibration Adjusts color settings to reduce excess color noise.

Use the Color Calibration command if the color levels (hue, brightness, saturation) of transmitted
video images do not seem accurate. IP-Reach or Dominion color settings remain the same when
switching from one target KVM Server to another, so you can perform Color Calibration once to
affect all connected target servers.

1. Openaremote KVM connection to any server running a graphical user interface.

2. Ensure that a solid white color covers approximately 15% or more of the target server's
desktop (suggestion: open Microsoft Notepad and maximize the window).

T T h

e o e g s e e e e [N

Figure 47: Example of Sizing the Notepad Window

3. On the Video menu, click Calibrate Color. The target device screen will update its
calibration.

Tip: You can also specify automatic color calibration using Tools > Options. Refer to General
Options for more information.

—=V=

=& Raritan.



CHAPTER 2: OPERATION 51

Keyboard Type (MPC Only)

MPC will not auto-detect the type of keyboard you use, so you must specify your keyboard type
to ensure accurate keyboard mapping. Options include US/International, French, German,
Japanese and UK English.

1. OntheVideo menu, click Options.

2. Click on the Keyboard Type drop-down arrow and select your keyboard type from the list.

COTE— x4 EIEE— x
{denaral | aduance d | General |
[¥] show scrall barders. Show scroll borders,
[¥] Auto-Sync mouse in two-cursor mode, (Mot supported for KX Generation 2) Auta-Sync mouse in two-cursor made.
[¥] Display single curser rode instructions, Dizplay single cursor mode instructions,
[¥] Autarnstic Color Calibration (For ki Generation 1 anly) [] Autarnatic Colar Calibration
Keyboard Type KUM Switch ©EUT Hot Key
—— (@ Scroll Lock + Scroll Lock
‘Llﬁflntsmatianal -

) Murm Lock + Hum Lock

() Caps Lock + Caps Lack
Kevboard Shortcut Menu Hotkey

Keyboard Type

‘Ctr\+A|t+M |v
U/ International \LI
LS International
| ok || il || e | g —
BrlGerman [Germany)
[lapaneze
United Kingdom
| ok || Cancel || |
Generation 2 (G2) Generation 1 (G1)
Figure 48: Keyboard Type Selection (MPC Only)
3. Click OK.

Note: Because of a limitation in the Java Runtime Environment (JRE), Fedora, Linux, and
Solaris clients receive an invalid response from Alt Gr on United Kingdom and US International
language keyboards. Fedora, Linux, and Solaris do not pick up events for the Alt Gr key
combination for Java 1.4.2 or 1.5. Java 1.6 appears to improve on this, although the keyPressed
and keyReleased events for Alt Gr till identify it as an “ unknown key code” .

Also, a key pressed in combination with Alt Gr (such as on the UK keyboard Alt Gr-4), which is
the Euro symbol), will only generate a keyTyped followed by a keyReleased event for that value,
without a keyPressed event. Java 1.6 improves upon this by filling in the keyPressed event as well.

=V=
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Chapter 3: Virtual Media

Overview

Important: Virtual Media is available for Dominion KX Il only.

Virtual media extends KVM capabilities by enabling target servers to remotely access media
from the client PC and network file servers. With this feature, media mounted on the client PC
and network file serversis essentially mounted virtually by the target server. The target server can
then read from and write to that media as if it were physically connected to the target server itself.
Virtual media can include internal and USB-mounted CD and DVD drives, USB mass storage
devices, PC hard drives, and I SO images (disk images).

Virtual media provides the ability to perform additional tasks remotely, such as:

transferring files

running diagnostics
installing or patching applications
complete installation of the operating system

This expanded KVM control eliminates most trips to the data center, saving time and money,

thereby making virtual media very powerful.

- U0I193UU0YD) [BNUIA -

Virtual Media
(Drives)

Target Server
[
wy, D2CIM-VUSB
1
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[ " ]

Dominion KX Il

Desktop PC
(Client)

CD/DVD Drive =
> ﬁ Remote File Server
) = {150 Images)
ﬂgg gi":i Hard Drive
Image Files

Figure 49: Virtual Media
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Prerequisites for Using Virtual Media

The following conditions must be met in order to use virtual media:
Device Permissions

e For user (S) requiring access to the virtual media, port permissions must be set to allow
virtual media access.
Client PC

e Certain virtual media options require administrative privileges on the client PC (e.g.,
drive redirection of complete drives).

Note: If you are using Microsoft Vista, turn User Account Control off: Control Panel >
User Accounts > User Account Control > turn off.

If you would prefer not to change Vista account permissions, run Internet Explorer as an
administrator. To do this, click on the Start Menu, locate IE, right click it and select Run
as Administrator.

e USB 2.0 ports are both faster and preferred.
Target Server

o Target servers must support USB connected drives.
e Target servers running Windows 2000 must have all of the recent patchesinstalled.

Using Virtual Media

With the Dominion KX Il virtual media feature, you can mount up to two drives (of different
types). These drives are accessible for the duration of the KVM session.

For example, you can mount a specific CD-ROM, use it, and then disconnect it when you are
done. The CD-ROM virtual media“channel” will remain open, however, so that you can virtually
mount another CD-ROM. These virtual media “channels’ remain open until the KVM session is
closed.

Note: Target servers running Windows will not accept any new medium after making a virtual
media connection to an NTFS partition, until the device is disconnected.

Tousevirtual media:

1. Connect/attach the mediato the client or network file server that you want to access from the
target server. This need not be the first step, but it must be done prior to attempting to access
this media.

2. Verify that the appropriate prerequisites are met.

3. (Fileserver 1 SO images only) If you plan to access file server 1SO images, identify those file
servers and images through the Dominion KX I Remote Console File Server Setup page.

4. OpenaKVM session with the appropriate target server.
5. Connect to the virtual media

FoR: SELECT THISVM OPTION:

 Local drives | Connect Drive |
Local CD/DVD Drives Connect CD-ROM/ISO Image
SO Images Connect CD-ROM/ISO Image
File Server 1SO Images Connect CD-ROM/ISO Image

6. Upon completion of your tasks, disconnect the virtual media.
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Connecting to Virtual Media

For Local Drives

This option mounts an entire drive; the entire drive is mounted virtually onto the target server.
Use this option for hard drives and external drives only; it does not include network drives, CD-
ROM, or DVD-ROM drives. Thisisthe only option for which Read-Writeis available.

Note: Target servers running certain version of the Windows operating system may not accept
new mass storage connections after an NTFS-formatted partition (e.g., the local C drive) has
been redirected to them. If this occurs, close the KX Il Remote Console and reconnect before
redirecting another virtual media device. If other users are connected to the same target server,
they must also close their connections to the target server.

To accessa driveon the client computer:

1. From MPC, select Virtual Media > Connect Drive. The Map Virtual Media Drive dialog
opens:

Map ¥irtual Media Drive: Dominion-kEX2_ Porkl x|
Select a local drive for mounting onto the target sarver,

Lacal Drive:

i [Hard Disk) | *

I
L

1
| Connect || Cancel

Figure 50: Map Virtual Media Drive

2. Select the drive from the L ocal Drive drop-down list.

3. If you want read and write capabilities, check the Read-Write option checkbox. This option
is disabled for non-removable drives. Please refer to the conditions when read-write is not
available for more information. When checked, you will be able to read or write the
connected USB disk.

WARNING: Enabling Read-Write access can be dangerous! Simultaneous
access to the same drive from more than one entity can result in data
corruption. If you do not require write access, leave this option unchecked.

4. Click Connect. The mediawill be mounted on the target server virtualy. Y ou can access the
mediajust like any other drive

Conditions when Read-Write is not Available
Virtual mediaread-write is not available in the following situations:

e For all hard drives.
e  When the drive is write-protected.
e When user does not have read-write port permission.
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For CD-ROM/DVD-ROM/ISO Images

This option mounts CD-ROM, DVD-ROM, and | SO images.
To accessa CD-ROM, DVD-ROM, or I SO image:

1. From MPC, select Virtual Media > Connect CD-ROM/ISO Image. The Map Virtua
Media CD/I1SO Image dialog opens.

Map ¥irtual Media CD /IS0 Image: Dominion-KX2_Porkl R Li

Select 3 CO/DVD drive or an ISO image to mount onto the target server,

@) Local CO/DVD Drive:

|D: (co-ROM) |~]

() 180 Image

Irmage Path:

) Rermote Server IS0 Image
Hostnare: Irmage:
! [~ | !

Filz Server Usernarna: File Servar Passward:

Connect || Cancal

Figure 51: Map Virtual Media CD/ISO Image

2. For internal and externa CD-ROM or DV D-ROM drives:

A. Select theLocal CD/DVD Drive option.
B. Select the drive from the Local CD/DVD Drive drop-down list. All available internal
and external CD and DV D drive names will be populated in the drop-down list.
C. Click Connect.
3. For ISO images:
A. Select the ISO Image option. Use this option when you want to access a disk image of a
CD, DVD, or hard drive. ISO format is the only format supported.
B. Click the Browse button.
C. Navigate to the path containing the disk image you want to use and click Open. The path
is populated in the I mage Path field.
D. Click Connect.
4. For remote | SO images on afile server:

A. Select the Remote Server | SO I mages option.

B. Select Hosthame and I mage from the drop-down lists. The file servers and image paths
available are those that you configured using the Dominion KX Il Remote Console File
Server Setup page. Only items you configured using the Dominion KX |l File Server
Setup page will be in the drop-down list.

C. FileServer Username. Username required for accessto the file server.

D. File Server Password. Password required for access to the file server (field is masked as
you type).

E. Click Connect.

The media will be mounted on the target server virtually. You can access the mediajust like any
other drive.
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Disconnecting Virtual Media

To disconnect the Virtual Mediadrives:
e Forloca drives, select Virtual Media > Disconnect Drive

e For CD-ROM, DVD-ROM, and ISO images, select Virtual Media > Disconnect CD-
ROM/ISO Image

Note: In addition to disconnecting the Virtual Media using the Disconnect option, simply closing
the KVM connection disconnects the Virtual Media as well.
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File Server Setup (File Server ISO Images Only)

Important: These steps are completed using the Dominion KX Il Remote
Console.

Note: Thisfeatureisonly required when using virtual media to accessfile server |SO images.

Use the Dominion KX Il Remote Console File Server Setup page to designate the files server(s)
and image paths that you want to access using Dominion KX 1l Virtual Media. File server 1SO
image(s) specified here will become available for selection in the Remote Server 1SO Image
Hostname and | mage drop-down lists (in the Map Virtual Media CD/ISO Image dialog).

To designatefile server 1 SO imagesfor virtual media access:

1. Select Virtual Media from the Dominion KX 1l Remote Console. The File Server Setup page
opens:

ZFile Server Setup | ¥irtual Media | Home - Microsoft Internet Explorer ] [ B3]

File Edt View Favorites Tools Help |f,‘

@Ba[k gD - Iﬂ @ -_;*, /T]SEarEh \:‘\?Favnntes (j“ I= ﬁ,; |- ) i 3
Address [&] https://192.168.59,57 home. asp | Ese |Links ”|65nag1t 1=

Google |G+ “leod & B~ | L Boskmarks~ | W check vy Autclik v G Auorl () settings=

RUSEREHR| user Management | evice Settings [ Securty | Maintenance | Diagnostics |

Home > File Senver Setup Logout

Time & Session:

March 16, 2007 09:36:51 Fllg servarSetup

User: admin

State: 111 sec idle Selected Host NameNPAddress Image Path
“Your P 192168 .59 93
Lasst Login: Mar 15, 2007 16:31 = 121881 133 Jimagesdist iou

Device Information:
Device Name: KX2device

IP Address: 192 1668 58 87
Firmweare; 2,002 5351
Poreerind: on

Powverin; off

Port States:
2 Ports up

13 Parts down
15 Ports idie

Connected Users:

admin (192.168.59.113)
1031 mir iclle:

admin (192.165.59.93)
active

adlmin (192.168.59.413)

1038 min idle -
4| | »

[&] bone T T [& [mteme 7

{5 o e o o N R

Figure 52: File Server Setup

2. Input information about the file server 1SO images that you want to access.
e Host Name/l P Address. Host name or IP Address of the file server.
e Image Path. Full path name of the location of the 1SO image.

Check the Selected checkbox for all mediathat you want accessible as virtual media.

Click Save. All media specified here will now be available for selection in the Map Virtual
Media CD/I1SO Image dialog.

To cancel without saving:
Click Cancel.

—=V=

=& Raritan.
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Chapter 4: Administrative Functions

Note: MPC users must belong to the administrator group in order to receive administrative
permissions. MPC uses one permission: administrator or normal user. It is only when the user
belongs to the ADMIN group that they have access to the backup/restore/restart type functions
(regardless of any device user group settings).

Although your IP-Reach or Dominion unit provides a remote interface to administrative functions
through IP-Reach or Dominion Manager, MPC and RRC provide an interface to frequently-used
administrative functions directly from its own interface. When logged into an IP-Reach or
Dominion unit as an Administrator, you can perform the following administrative tasks.

Note: Most of the commands below are available both in the Tools drop-down menu and in the
shortcut menu that appears when you right-click on the device in the Navigator panel

Upgrading Device Firmware

To update adevice' s firmware, first connect to the device. Highlight the device’ sicon in the MPC
Navigator, and click on the Tools menu, click Update and then click Update Device to perform
firmware upgrades.

MPC / RRC will prompt you to locate a Raritan firmware distribution file (*.RFP format), found
on the Raritan Website Firmwar e Upgr ades page when available:
http://www.raritan.com/support/firmwareupgrades. Please ensure that you read al instructions
included in firmware ZIP files carefully before upgrading a device.

Note: Copy the firmware update file on the Raritan Website to a local PC before uploading. Do
not load the file from a network drive.

Changing a Password

To update your password, first connect to an IP-Reach or Dominion target. Highlight the target’s
icon in the Navigator, and on the Tools menu, click Update and then click User Password. The
Change Password window appears.

Change Password x|

Info

Cld Pazsword [Féddkkdkdd

Mew Password
Confirm Mew Password

OK Cancal

Figure 53: Change Password Window

Type your current password in the Old Password.

Type the new password in the New Password field.
Retype the password in the Confirm New Password field.
When finished, click OK.

A DN P
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Restarting Device
Select the device in the MPC Navigator. On the Tools menu, click Restart Device.

Backing Up Device Configuration

To download the IP-Reach or Dominion KX device configuration to your local computer, first
select the device in the MPCRRC Navigator. On the Tools menu, click Save Device
Configuration.

Restoring Device Configuration

To upload the archived IP-Reach or Dominion KX device configuration, first select the device in
the MPCRRC Navigator. On the Tools menu, click Restor e Device Configuration.

Please note that device configuration is specific to a particular device and should not be restored
to another device.

Backing Up User Configuration

To back up a unit’s user configuration, first select the device in the MPCRRC Navigator. On the
Tools menu, click Save User Configuration.

Restoring User Configuration

To upload a device's archived user configuration, first select the device in the MPCRRC
Navigator. On the Tools menu, click Restore User Configuration

Note: Use these commands to easily transfer user and group information from one IP-Reach or
Dominion KX unit to another.
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Backup and Restore (Dominion KX Il only)

In addition to using backup and restore for business continuity purposes, you can use this feature
as a time-saving mechanism. For instance, you can quickly provide access to your team from
another Dominion KX 11, by backing up the user configuration settings from the KX Il devicein
use and restoring those configurations to the new Dominion KX 1.

Note: Backups are always complete system backups. Restores can be complete or partial

depending on your selection.

Tools YWiew Window Help

Options...

Restart Device

Backup All

Restore Configuration

Update

Figure 54: Backup and Restore Menu Options

To backup the entire system (both user and device configuration):
1. Select Tools> Backup All. The Backup All dialog opens:

Backup all x|
: . sl ) | oo o—
SGave in: My Docurnents |:¢j | |j o0 O—
7Y BUD3007.p [ k#-2-0-0-1-4936.ifp [ ] KX-2-0-0-1-5045.fp [ ] KH-2
7Y evtlog.txt [ k#-2-0-0-1-4942.fp [ ] KX-2-0-0-1-5077.rfp [ ] KH-2
Ty JauaConsole.txt [ k#-2-0-0-1-4949.fp [ K¥-2-0-0-1-5094.rfp [ ] Ki-3
Y JauaConsolez.bxt [ kx-2-0-0-1-4990.fp [ K¥-2-0-0-2-S122.fp [ ] KH-2
Y avaConsole3bxt ] KH-2-0-0-1-5006.rfp [ ] KX-2-0-0-2-5129.fp [ ] KX-Z
Y KX-2-0-0-0-5146.fp [ ] KH-2-0-0-1-5088.¢fp [ ] KX-2-0-0-2-5135.fp [ ] KX-3
4 _ immmen | L
File name:  [MPCOZ1S.rfp
Files of type: |RFF‘ Files (*.Hpl - |
Saue | | Cancel |

Figure 55: Backup All

2. Navigate to the desired directory and give the backup file a name. (Backup files have an

extension of .rfp).

Click Save. A message is displayed confirming the successful backup.

Click OK.

=& Raritan.
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Torestore:
1. Select Tools > Restore Configuration. The Restore Device Configuration dialog opens.

Restore Device Configuration b il
Look in: ‘lj My Docurments v‘ ||:+j Iﬁ |j ﬁlg

aufp [ K¥-2-0-0-2-5265.fp [ ] K¥-2-0-0-2-5324.fp | ] U-BOGT-18-22.fp

ofp [) K¥-2-0-0-2-5274.0fp [ KX-2-0-0-2-5333.rfp
Bafp [ K¥-2-0-0-2-527%.fp [ ] K¥-2-0-0-2-5343.rfp
oufp [ K¥-2-0-0-2-5282.fp [} K¥-2-0-0-2-5351.p
Lfp [ K¥-2-0-0-2-5288.¢fp ] MPSO315.fp

arfp [ K#-2-0-0-2-5310.p [ Test.rip

4l 53

File name:  [MPCDZ1S.fp

Files of type: |RFF‘ Filaz (*.rfp]) - |
Jpen | | Cancel |

Figure 56: Restore Device Configuration

2. Navigate to the appropriate directory and select the backup file.
3. Click Open. The Restore Packages dialog opens:

i@ Full Restors

'::' Protected Restore

) Custom: Restore
Customn Packages Available

| 8], || Cancal

Figure 57:Restore Packages

4, Select the type of restore you want to run:

e Full Restore. A complete restore of the entire system; generally used for traditional
backup and restore purposes.

e Protected Restore. Everything is restored except device-specific information such as
serial number, MAC Address, IP Address, name, port names, etc. With this option, you
can setup one Dominion KX |1 and copy the configuration to multiple KX Il devices.

e Custom Restore. With this option, the following options are available. Check the
appropriate checkboxes:
» User and Group Restore. This option includes only user and group information.
Use this option to quickly setup users on adifferent Dominion KX II.

» Device Settings Restore. This option includes only device settings. Use this option
to quickly copy the device information.

5. Click OK.

=& Raritan.
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Log Files
Activity Log

To download a detailed activity log for review or troubleshooting, first select the device in the
Navigator. On the Tools menu, click Save Activity L og.

Diagnostic Log (excluding Dominion KX I1)

To download a detailed diagnostic log for reporting or anaysis, first select the device in the
Navigator. On the Tools menu, click Save Diagnostic L og.
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Broadcast Port

By default, all Raritan devices send data through Port 5000. This network traffic includes MPC’s
and RRC’ s auto-discovery broadcast. In the case of conflicts, or to deal with firewall issues, you
may want to use a different broadcast port.

To change the auto-discovery port from the default broadcast port of 5000, select the device in
the RRC Navigator. On the Tools menu, click Options. The Options window appears.

Options

General |

V' Auto-Sync mouse in hwo cursor mode.
[V Display single cursor mode instructions.

I Auto-Color Calibration.

— kA Switch OSUI Hat Key

@ Seroll Lock + Scroll Lock
= Num Lock + Num Lock
" Caps Lock + Caps Lock

 Keyboard Type

US Anternational j

- Broadzast Port

P0ﬂ|5DDD

Ok I Cancel | Lpply

Figure 58: Options Window

In the Broadcast Port panel at the bottom of the window, type the new port number in the Port
field, and then click OK.

Note: If you want MPC / RRC to auto-discover Raritan devices on the new broadcast port you
entered in the Options window, you must configure all Raritan devices to use the new port
number.

Remote Power Management

MPC and RRC can manage AC Power to associated targets when used with a properly configured
Raritan Remote Power Control Strip (RPC Strip). RRC provides three options for the remote
power management of targets. Power On, Power Off, and Cycle Power.

To change the power status of atarget, first select the device in the RRC Navigator. On the Tools
menu, click Power On, Power Off, or Cycle Power.
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Launching Administrator and Diagnostic Interfaces

Administrator Interface

For further control of a selected device, scroll down the Navigator list of al the targets associated
to a specific device (you may have to expand your view of the device by clicking on the + sign
before its name) and double-click on the Admin icon at the bottom of the target list.

The Administrator login screen for the selected device appears. Please refer to the specific
Raritan device User Guide for additional information and managing the device using the Raritan
User Manuals & Quick Setup Guides CD included with the device shipment, or by downloading
the user documentation from Raritan’s Product Documentation page:
http://www.raritan.com/support/productdocumentation.

Diagnostic Interface (excluding Dominion KX II)

To access the device's diagnostic console by double clicking on the Diagnostic icon at the
bottom of the target list. Scroll down the Navigator list of all the targets associated to a specific
device (you may have to expand your view of the device by clicking on the + sign before its name)
and double-click on the Diagnostic icon at the bottom of the target list.

ESRaritan Multi-Platform Client TS

Connection  Serial Tools View Window Help
T

Hm) 21 Channel 21 -
l’!m 22: Channel 22

-lg_ 231 Channel 23

lgm 24: Channel 24

-lg_ 25: Channel 25

lETm 26: channel 26

-lg_ 27: Channel 27

'g 28 Channel 28

-lg_ 29: Channel 29

18 50 Channel 3

tic

ion-Kx [192,168.51,204]
rainien-Ki [192,168.51,230]

- @ S Dominion- K [192,168.51,245]

| o &0 pominion-kx [192 165,52, 140] |

- @ B Dominion- Kx-Pra [192.168,52.13

B £-1pR-M1 [192.166.52.32)

- S G-1PR-M2 [192.168,52.57]

—05 H-TPR-M1 [152.168.52.88]

@ 8= IP-Reach [192,168.0,192]

- B Jaysons- M2 [132.168.51.531]

—9% KSH-850_37 [192.166.52.37]

=

View By Name | View By IP

Searching for Raritan device at
192,152.51,200

[Dorminian-Kg 192.168.51.200]:
ng...

n-Kx 192.168.51.200]:
iconnected

[Dorninien-Ky 122.168.51,2001: Login
complete,

=)
Applet Dominian KX Manager applet started | [ | | | [ I

Figure 59: Launching Diagnostic Console for KX Manager
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Tools Options

The Options available in the Tools menu provide settings for customization of scroll borders,
mouse mode settings, hotkey configuration, keyboard type, broadcast port, and logging.

To configure the general options:

1. Select Tools > Options. The Options screen opens to the General tab:

optons x|

i Seneral | Advanced |

IZ! Show scrall borders,
E Auto-Senc mouse in two-cursor mode, (Mot supported for KX Generation 2]
@ Dizplay single cursor rmode instruckions,

E} Autornatic Colar Calibration [For KX Generation 1 anly)

Keyboard Type
Us/ Intarnational -

Keyboard Shortcut Menu Hotkey

|Ctr|+A|t+M | -

| el | | Cancel | | Arply |

Figure 60: Options — General Tab

2. Check the Show scroll borders check box to view the thin scroll borders designating the
auto-scroll area.

3. Check the Auto-Sync mouse in two-cursor mode check box to enable automatic mouse
synchronization.

4. Check the Display single cursor mode instructions check box if you wish to see the
following instructions when entering single cursor mode:

Single Cursor Mode 1 ﬁl

You are about to enter Single Cursor mode, While you are in this mode,
thiz software will have exclusive control over the mousze and keyboard.

To exit Single Cursor mode vou rmust press:

Crrl+alt+M, then S
V] Show this dislog each time you start Single Cursor mode.

‘ Lol H Cancel ‘

Figure 61: Single Cursor Mode

5. Check the Automatic Color Calibration check box to enable automatic color calibration.
This option is available for KX generation 1 (G1) only.

=& Raritan.
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6. Select the Keyboard Type from the drop-down list (depending on the Raritan device in use,
different options may be available):

UY/International

French (France)

German (Germany)

Japanese

United Kingdom

Korean (Korea)

7. Keyboard Shortcut Menu Hotkey. Select the key combination you would like to use to
invoke the Keyboard Shortcut Menu. Select from among the options in the drop-down list:
Ctrl + Alt + (any uppercase |etter).

8. For advanced options, open the Advanced tab:
options X
lmr_- Advanced |

KWM Switch OSUT Hot Key

® Scroll Lock + Serall Lock
) Murn Lock + Murn Lack

() Caps Lock + Caps Lack

Broadcast Port

Port 13000

Lagging

|:i Enable Lagging

| el | | Cancel | | |

Figure 62: Options — Advanced Tab

9. KVM Switch OSUI Hot Key. Select the hotkey to use when switching between target server
displays.

10. For the Broadcast Port, type the broadcast port number in the Port field if you want to use a
port other then 5000.

11. Check the Enable Logging checkbox only if directed to by Technical Support. This option
creates alog file in your home directory.

12. Click OK when finished or click Cancel to exit this window without saving changes. Click
Apply any time during your selection to apply an option you have chosen.

=& Raritan.
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General Options (RRC Only)
1. On the Tools menu, click Options to view the Options screen. You can customize your
keyboard and video options to optimize use.

General |

V' Auto-Sync mouse in bwo cursar mode.
[V Display single cursor mode instructions.

™ Auto-Color Calibration.

— kKAM Swaitch OSUI Hot Key

& Scroll Lock + Scroll Lock
= Num Lock + Num Lock
" Caps Lock + Caps Lock

—kevboard Type

L]

US Anternational

— Broadzast Port

P0ﬂ|5DDD

Ok I Cancel | Lpply

Figure 63: General Options Window

2. Click on the check box before Show scroll borders to view the thin scroll borders that show
the Auto-Scroll area.

3. Click on the check box before Auto-Sync mouse in two cursor mode to enable Automatic
Mouse Synchronization.

4. Click on the check box before Display single cursor mode instructions if you wish to see
the following instructions when entering Single Cursor Mode.

Single Cursor Mode E3

“r'ou are about to enter Single Curgor mode. While you are in this mode,
thiz software will have exclusive control over the mouse and kepboard.

To exit Single Cursor mode you must press:

Chrl + Alt + M, then 5

¥ Show this dislog each time you start Single Cursor mode,

Ok I Cancel

Figure 64: Single Cursor Mode Confirmation Screen

5. Inthe KVM Switch OSUI Hot Key panel, click on the radio button before your choice of hot
key combinations.

6. In the Keyboard Type panel, click on the drop-down arrow and click on your keyboard

choice.

In the Broadcast Port Panel, type the broadcast port number in the Port field.

8. Click OK when finished or click Cancel to exit this window without saving changes. Click
Apply any time during your selection to apply an option you have chosen.

~
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Appendix A: Installing and Launching Standalone
MPC

This section guides you through installation and initial launch of the standalone MPC application
for various operating systems.

Raritan recommends that you launch only one standalone MPC session at atime. Launching more
than one standalone MPC session on the same client at the same time may cause performance
problems and system errors.

Note: Please note that the file names of the installers, as well as the install directories or folder
paths may differ slightly from what is outlined in this manual.

Important: MPC modem connectivity is supported on Windows, Linux, and Sun
Solaris, but not Macintosh. When working in Windows, use Standalone MPC.

Y ou must have the MPC JAR fileto install MPC for any of these operating systems.

1. Download the installation file, MPC-installer.jar from the Raritan Website on the Support —
Firmware Upgrades page (http://www.raritan.com/support/firmwareupgrades). Click on
Dominion Family and scroll to the Standalone Multi-Platform Client link.

2. If copying MPC-installer.jar from a known location, double-click on the file to start
installation.

Windows

Checking JRE Version in Windows

1. Click onthe Windows Start button at the bottom left of your screen and click Control Panel.
In the upper left corner of the screen, you may see a panel named Control Panel with the
option Switch to Classic View or Switch to Category View. For easier viewing, opt for
Classic View.

2. Search the Control Panel files for a Java icon. When you locate Java, double-click on it to
launch the Java Control Panel. Click on the General tab, and then click on the About
button to check the current Java Runtime Environment (JRE).

3. If the JRE isversion 1.4.2_05 or greater, proceed with the MPC Installation. If the Javaicon
does not exist in the Control Panel, or if the JRE is older, please go to the Sun Microsystems
Website at http://java.sun.com/products to download the latest JRE.

A. For future Java access and automatic launch, set your path to the Java executable: on your
desktop, right-click on the My Computer icon and click Properties.

B. Click onthe Advanced tab and then click Environment variables.

C. Edit the Path address so that it contains the path to the Java executable.
For example: if Java is instaled in C:\j2rel.4.2 05 and your path is currently set to
CAWINDOWS\SY STEM 32, then change the path to read
C:\WINDOWS\SYSTEM 32;C:\j2rel.4.2_05
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Installing MPC for Windows

1. Log on to your Windows machine.
2. Download, or copy from a known location, the M PC-installer jar instalation file.
3. After theinitial screen loads, click Next.

=loix]

B Select the installation path:

| Browse...

|C:\Program Files\RaritariRaritan Mutti-Platform Clientd.40.1.7

(Madle with 1zPack - http: itnsase izforge.comi)

() Previous | £ hest I .9 cuit |

Figure 65: Choose Install Path

4. Select the directory where you want to install MPC and click Next. Click Browse to navigate
to anon-default directory.
5. After the progress bars have moved across the screen, click Next.

@8 IzPack - Installation of Raritan Multi-Platform Client ==

Select & Program Group for the Shodcuts:

Aocessoties

AuthorlT Wd

Axialis Software

CC Application create shortcut for
evitan & current user
Startup

T allusers

IRar'rtan.l'Rarrtan Multi-Platform Clientsd 40.1.7

[V Create shortout on the desktop

Reset

(Made with ZPack - http: iteeseee izforge.comi)

@Previous | QNext @Quﬂ |

Figure 66: Shortcut Options

6. On the Shortcut screen, choose a shortcut |ocation, determine who should have the shortcut,
and whether you want the shortcut on the desktop. When finished, click Next.

=& Raritan.
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7. The installation is complete; the final screen indicates where you will find an uninstaller

program, and allows the option of generating an automatic installation script. Click Done to
close the Installation window.

88 IzPack - Installation of Raritan Multi-Platform Client 21=1=l

6} Installation has completed successfully.

‘:i An uninztaller program has been created in:
C\Program Files\Raritan\Raritan Multi-Platform Clientid 401 T\Wninstaller

' Genetate an automatic installation script

[Mace with 1ZPack - http: e izforge.comi)

Figure 67: Final Installation Screen

Launching MPC in Windows

1. Click on the Windows Start menu, click All Programs, and then click Raritan Multi-
Platform Client, or double-click the desktop shortcut if you created one.

2. Double-click on the desired device to establish a connection, type your Username and

Password and click OK to log on. Please refer to Chapter 2: Operation for additiona
operation instructions.

£ .t am Mt Pt orm Chient ol=l=]
Connastion Toss Yiax Hele

Vinx by Nama | ety e

MBS fondud! I

Figure 68: Launching MPC in Windows
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Linux

Checking JRE Version in Linux

1. Inagraphical environment, launch aterminal window.

2. Typejava —version inthe command line and press ENTER. The currently-installed version
of Java Runtime Environment (JRE) appears.

A. If your path variable is not set to where the java binaries have been installed, you may not
be able to see the JRE version.

B. To set your path: Assuming JRE 1.4.2 05 is installed in /usr/local/java: you must set
your PATH variable.

C. To set path for bash shell: export PATH=3$PATH:/usr/local/javalj2rel.4.2_05/bin.
D. To set path for tcsh or csh: set PATH = ($PATH /usr/local/javalj2rel.4.2_05/bin).

E. These commands can either be typed at the terminal each time you login, or you can add
it to your .bashrc for bash shell or .cshrc for csh or tcsh so that each time you login, the
PATH is aready set. Please refer to your shell documentation if you encounter problems.

usrl@® localhost:~

File Edit Miew Terminal Tabs Help
[usrl@localhost ~]§ java -version [+]
java version "1.4.2_06"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)

Java HotSpot(TM) Client VM (build 1.4.2_06-b03, mixed mode)

[usrl@localhost ~]% |:|

Figure 69: Check JRE Version in Linux

3. If the JRE isversion 1.4.2_05 or greater, proceed with the MPC installation. If the version is
older, please go to the Java website at http://[ava.sun.com/products/ to download the latest
Runtime Environment.

Installing MPC for Linux

Y ou must have Administrative privilegesto install MPC.
1. Logontoyour Linux machine.

2. Download, or copy from a known location, the M PC-installer .jar installation file.
3. Open aterminal window and change to the directory where the installer is saved.
4. Typejava—jar MPC-ingtaller.jar and press ENTER to run theinstaler.

=& Raritan.
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lﬂ' Select the installation path:

|.n’usr.n’local.n’Raritan.n’Raritan Multi-Platform Client/4.40.1.7 [,J Browse...

(Made with lzPack - http:/ fvwe izforge comf

(3 Previous Cj Mext €3 Quit

Figure 70: Set Installation Path
6. Select the directory where you want to install MPC and click Next. Click Browse to navigate
to anon-default directory.
When installation is complete, click Next.
On the Shortcut screen, choose a shortcut location, determine who should have the shortcut,

Select a Program Group for the Shortouts

Raritan

create shortout for
(®) current user

) alllusers

Raritan/Raritan Multi-Platform Client/4 40.1.7 Reset

[ Create shortcut on the desktop

(Made with 1zPack - hitp:f A izforge.comd)

L3 Previous .4 Quit

Figure 71: Shortcut Options
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9. The installation is complete; the final screen indicates where you will find an uninstaller
program, and allows the option of generating an automatic installation script. Click Done to
close the Installation window.

& Installation has completed successtully,

(j An uninstaller program has been created in:
fustflocal!Raritan/Raritan Multi-Platform Client/4 40,17 {Uninstaller

| Generate an automatic installation script

(Made with IzPack - http:/ frwe.izforge comf

Figure 72: Final Installation Screen

Launching MPC in Linux

1. Open aterminal window and change directories to the directory where you installed MPC
(default location: /usr/local/Raritan/Raritan MPC/4.40.1.7/).

2. Type ./start.sh and press ENTER to launch MPC.

] CIEE S el |

Figure 73: MPC Launched in Linux

3. Double-click on the desired device to establish a connection, type your Username and
Password and click OK to log on. Please refer to Chapter 2: Using MPC for additional
operation instructions.
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Solaris

Checking JRE Version on Sun Solaris

1. Launch atermina window on the Sun Solaris desktop.

2. Typejava —version inthe command line and press ENTER. The currently-installed version
of Java Runtime Environment (JRE) appears.

A. If your path variable is not set to where the java binaries have been installed, you may not
be able to see the JRE version.

B. To set your path: Assuming JRE 1.4.2 05 is installed in /usr/local/java: you must set
your PATH variable.

C. To set path for bash shell: export PATH=3$PATH:/usr/local/javalj2rel.4.2_05/bin.
D. To set path for tcsh or csh: set PATH = ($PATH /usr/local/javalj2rel.4.2_05/bin).

E. These commands can either be typed at the terminal each time you login, or you can add
it to your .bashrc for bash shell or .cshrc for csh or tcsh so that each time you login, the
PATH isaready set. Please refer to your shell documentation if you encounter problems.

[~ Terminal

Window Edit Options

# java -version

java version "1.4.2_05"

Taval(TH) 2 Runtime Environment, Standard Edition Cbuild 1.4.2_05-b043)
Tava HotSpot{TH) Client WM C(build 1.4.2_05-h04, mized model

H#

Figure 74: Check JRE Version in Sun Solaris

3. If the JRE isversion 1.4.2_05 or greater, proceed with the MPC installation. If the version is
older, please go to the Sun website at: http://java.sun.com/products’ to download the latest
Runtime Environment.

==
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Installing MPC for Sun Solaris

Y ou must have administrative privilegesto install MPC.
Log on to your Sun Solaris machine.

Download, or copy from a known location, the MPC-installer .jar installation file.
Open atermina window and change to the directory where the installer is saved.
Typejava—ar MPC-installer.jar and pressENTER to run theinstaller.

After theinitial screen loads, click Next.

© g &~ w NP

After theinitial screen loads, click Next.

Figure 75: Set Installation Path
7. Select the directory where you want to install MPC and click Next. Click Browse to navigate
to anon-default directory.
When installation is complete, click Next.
Click Next again.

Z=Raritan.
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10. The installation is complete; the final screen indicates where you will find an uninstaller
program, and allows the option of generating an automatic installation script. Click Done to
close the Installation window.

Figure 76: Final Installation Screen

Z=Raritan.
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Launching MPC on Sun Solaris

1. Open a termina window and change to the directory where you installed MPC (default
location: /usr/local/Raritan/Raritan MPC/4.40.1.7).

2. Type ./start.sh and press ENTER to launch MPC.

= Raritan Multi=Flatform Cllent

Cammastivn Tesk Vi

O 5 < o S ¢
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Figure 77: Launching MPC in Sun Solaris

3. Double-click on the desired device to establish a connection, type your Username and
Password and click OK to log on. Please refer to Chapter 2: Using MPC for additional
operation instructions.

—=V=
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Macintosh
Checking JRE Version in Mac OSX

1. Launch atermina window on the Macintosh desktop.

2. Typejava —version in the command line and press ENTER. The currently-installed version
of Java Runtime Environment (JRE) appears.

FBO ﬂ Terminal — sh — 80x24

Last login: Tue Mar 22 B89:84:25 on ttvpl 5
Welcome to Darwin!

Raritan-MIS-Computer :~ root# jova -version

java version "1.4.2_BR"

Jova{TMy 2 Runtime Environment, Stondord Edition {build 1.4.2_B5-141.3)

Jova HotSpot{TM} Client WM (build 1.4.2-38, mixed mode)

Rariton-MIS-Computer i~ root# I

Figure 78: Check JRE Version in Mac OSX

3. If the JRE isversion 1.4.2_05 or greater, proceed with the MPC installation. If the version is
older, please go to the Apple website to download the latest Runtime Environment.

Installing MPC for Mac OSX

Y ou must have administrative privileges to install MPC.
1. Log on to your Macintosh.

2. Download, or copy from a known location, the M PC-installer jar installation file.
3. Open aFinder window and locate where the installer was saved.
4. Double click on the file named M PC-installer .jar to run theinstaller.

5. After theinitial screen loads, click Next.

rBO_ IzPack - Installation of Raritan Multi-Platform Client

[ Select the installation path:

/Applications /Raritan/Raritan Multi-Platform Client/4.40.1.7 .;' Browse... "'I

(Made with |zPack - http:/ /www.izforge.com/) -

\ Previous ) ( Next ) |_\' Quit )

Figure 79: Select Installation Path

6. Select the directory where you want to install MPC and click Next. Click Browse to navigate
to anon-default directory.

7. When installation is complete, click Next.
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8. The installation is complete; the final screen indicates where you will find an uninstaller
program, and allows the option of generating an automatic installation script. Click Done to
close the Installation window.

re 8.6 IzPack - Installation of Raritan Multi-Platfarm Client 7

&9 Installation has completed successfully.

&9 An uninstaller program has been created in:
/Applications /Raritan/Raritan Multi-Platform Client/4.40.1.7 /Uninstaller

(Gensrate an automatic installation script )

(Made with IzPack - http://www.izforge.com/)

f Done }

Figure 80: Final Installation Screen

Launching MPC in Mac OSX

1. Open a Finder window and navigate to the directory where you installed MPC (default
location: /Applications/Raritan/Raritan MPC/4.40.1.7).

{Fe (@lla) |4 Applications )
| |
iﬁ Network: ) ;1 ! L~ "?-a:n;- T _I §=aberéuui%--vvj L _ |
e O Internet Connect Jan 27, 2005, 9:21 AM |
1. Q Macintosh HD | g Internet Explorer Jun 3, 2003, 5:14 PM 1
1= # iPhoto Feb 11, 2005, 5:16 PM i
| ;,‘ MPC = & isync Jun 16, 2004, 7:39 PM |
: bl & iTunes May 19, 2005, 4:15 PM ‘
“ Desktop & mail Aug 14, 2003, 3:00 PM ‘
i L] Microsoft AutoUpdate Feb 11, 2005, 5:43 PM |
M raritancompu. » [ @ Office 2004 for Mac Test Drive Jan 19, 2005, 11:24 AM |
§ i ‘% OmniGraffle Sep 1, 2004, 7:05 PM |
; E'{ OmniQutliner Sep 1, 2004, 7:04 PM

‘ _‘ 'at Preview Jan 27, 2005, 9:20 AM

|| !l“ﬁ Documents » [© QuickBooks NUE & Sep 1, 2004, 6:59 PM

1= €1 QuickTime Player May 25, 2005, 6:07 PM
1 % Movies v [F Raritan Today, 3:31 PM i
}: ¥ [0 Raritan Multi-Platform Client Today, 3:31 PM ‘
| é Music | v [ 44017 Today, 3:31 PM ||
= . - _Ed Raritan Multi-Platform Cliant ___________Today. 33LPM |
‘ Q Pictures » [ Uninstaller Today, 3:31 PM vl
- e —————— = ~ KM |
L 1 of 40 selected, 63.43 GB available |

<4

Figure 81: Finding And Launching MPC in Mac OSX

2. Double-click on the desired device to establish a connection, type your Username and
Password and click OK to log on. Please refer to Chapter 2: Using MPC for additional
operation instructions.

—=V=—
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Modem Connectivity

To Make Modem Connectivity Available on Unix/Linux for Non-
Root Users

1.

o~ W DN

Asroot, change group for /etc/ppp directory and required files:

A. chgrp uucp /etc/ppp

B. chgrp uucp /etc/ppp/pap-secrets

C. chgrp uucp /etc/ppp/peers

Change permissions for /etc/ppp chmod g+rwx /etc/ppp

Change permissions for /etc/ppp/pap-secrets chmod g+rwx /etc/ppp/pap-secrets
Change permissions for /etc/ppp/peers chmod g+rwx /etc/ppp/peers

Set suid bit to pppd chmod u+s /usr/shin/pppd (/usr/bin/pppd depending on the location of
pppd)

Assign users to the uucp group
A. /usr/shin/fusermod —G { existing groups for user1} ,uucp userl
B. /usr/shinfusermod —G { existing groups for user2} ,uucp user2, etc.

and when logged in as the normal user, update PATH for access to pppd and chat
export PATH=3PATH:/usr/sbin (/usr/bin depending on the location of pppd)

Note: Ensure that the options file exists under /etc/ppp
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Appendix B: Conditions for Intelligent Mouse
Synchronization

Intelligent Mouse Synchronization, available on the M ouse drop-down menu in Dominion KX
units, automatically resynchronizes mouse cursors during moments of inactivity. For this to work
properly, the following conditions should be met:

Active Desktop should be disabled on the target.

No windows should appear at the top left corner of the target screen.

There should not be an animated background in the top left corner of the target screen.

The target mouse cursor shape should be normal and not animated.

Target mouse speeds should not be set to very slow or very high speed values.

“Enhanced pointer precision” or any such mouse property should be disabled.

Other fancy mouse features, such as “snap mouse to default button in dialog boxes,” should
be disabled.

Users must choose “Best Possible Video Mode” in the Video Settings window.

e The edges of the target video should be clearly visible (that is, a black border should be
visible between the target desktop and the Remote KVM Console window when you scroll
to an edge of the target video image).

After auto sensing the target video, users should manualy initiate mouse synchronization by
clicking the Synchr onize M ouse button on MPC toolbar. This also applies when the resolution of
the target changes if the mouse cursors start to de-sync from each other.

If Intelligent Mouse Synchronization fails, this mode will follow the Standard mouse
synchronization behavior.

Note: Absolute mouse setting requires a USB target system, and is the recommended mouse
setting for KX101.

Please note that mouse configurations will vary on different target operation systems; consult
your OS guidelines for further details. Also note that Intelligent Mouse Synchronization does not
work with UNIX targets.
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Appendix C: Special Characters

The following table identifies the special characters that can be used in MPC:

CHARACTER DESCRIPTION CHARACTER ‘ DESCRIPTION
! Exclamation point : Colon

" Double quote ; Semi-colon

# Pound sign = Equal sign

$ Dollar sign > Greater than sign
% Percent sign ? Question mark

& Ampersand @ At sign

' Single quote [ L eft bracket

( Left parenthesis \ Backward slash

) Right parenthesis ] Right bracket

* Asterisk A Caret

+ Plus sign _ Underscore

, Comma ) Grave accent

- Dash { L eft brace

. Period | Pipe sign

/ Forward slash } Right brace

< Lessthan sign ~ Tilde
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