Dominion KX II®
Quick Installation and Setup Guide
Congratulations on your purchase of the Dominion KX II, the industry's most full-featured, enterprise class, secure digital
KVM (Keyboard, Video, Mouse) switch. This Quick Setup Guide explains how to install and configure the Dominion KX
II. Follow the instructions carefully to ensure a quick and easy installation. For more detailed information on any aspect
of the Dominion KX II, consult the accompanying User Guide accessible from the Raritan User Manuals & Quick Setup
Guides CD or from the Raritan web site Product Documentation Support page.

I. Configure Target Servers
For optimal bandwidth efficiency and video performance, set
the OS desktop background to a pre-dominantly solid, plain,
light-colored graphic.

Resolutions
640x480
@100 Hz

1024x768
@70 Hz

1280x1024
@60 Hz

Ensure that the server video resolution and refresh rate are
supported by Dominion KX II (and that the signal is noninterlaced).

640x480
@120 Hz

1024x768
@72 Hz

1280x1024
@75 Hz

720x400
@70 Hz

1024x768
@75 Hz

1280x1024
@85 Hz

720x400
@84 Hz

1024x768
@85 Hz

1600x1200
@60 Hz

The Dominion KX II supports these resolutions:

Resolutions
640x350
@70 Hz

720x400
@85 Hz

1024x768
@90 Hz

640x350
@85 Hz

800x600
@56 Hz

1024x768
@100 Hz

640x400
@56 Hz

800x600
@60 Hz

1152x864
@60 Hz

640x400
@84 Hz

800x600
@70 Hz

1152x864
@70 Hz

640x400
@85 Hz

800x600
@72 Hz

1152x864
@75 Hz

The Dominion KX II operates in several mouse modes:
Absolute Mouse Synchronization™ (D2CIM-VUSB is
required), Intelligent Mouse Mode (do not use an animated
mouse), and Standard Mouse Mode. Mouse parameters do
not have to be altered for Absolute Mouse Synchronization.
For both the Standard and Intelligent mouse modes, mouse
parameters must be set to specific values, which are
described in the following paragraphs in this section.

640x480
@60 Hz

800x600
@75 Hz

1152x864
@85 Hz

Mouse configurations will vary on different target operating
systems; consult your OS documentation for additional detail.

640x480
@66.6 Hz

800x600
@85 Hz

1152x870
@75.1 Hz

Windows® Vista Settings

640x480
@72 Hz

800x600
@90 Hz

1152x900
@66 Hz

To configure KVM target servers running Microsoft
Windows Vista:

640x480
@75 Hz

800x600
@100 Hz

1152x900
@76 Hz

640x480
@85 Hz

832x624
@75.1 Hz

1280x960
@60 Hz

640x480
@90 Hz

1024x768
@60 Hz

1280x960
@85 Hz

1. Configure the mouse settings:
a. Choose Start > Settings > Control Panel > Mouse.
b. Click the Pointer Options tab.
c. In the Motion group:
 Set the mouse motion speed setting to exactly the
middle speed.
 Disable the "Enhanced pointer precision" option.
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 Click OK.
2. Disable animation and fade effects:
a. Select the System option from the Control Panel.
b. Select Performance Information then Tools >
Advanced Tools > Adjust to adjust the appearance and
performance of Windows.
c. Click the Advanced tab.
d. Click the Settings button in the Performance group.
The Performance Options dialog appears.
e. Under Custom options, deselect the following
checkboxes:
 Animation options:
 Animate controls and elements inside windows
 Animate windows when minimizing and maximizing
 Fade options:
 Fade or slide menus into view
 Fade or slide ToolTips into view
 Fade out menu items after clicking
3. Click OK.
4. Close the Control Panel.

Windows® XP and 2003 Settings
To configure KVM target servers running Microsoft
Windows XP/2003:
1. Configure the mouse settings:
a. Choose Start > Control Panel > Mouse.
b. Click the Pointer Options tab.
c. In the Motion group:
 Set the mouse motion speed setting to exactly the
middle speed.
 Disable the Enhanced pointer precision option.
 Disable the Snap To option.
 Click OK.
2. Disable transition effects:
a. Select the Display option from the Control Panel.
b. Click the Appearance tab.
c. Click the Effects button.
d. Deselect the "Use the following transition effect for
menus and tooltips" option.
e. Click OK.
3. Close the Control Panel.



Set the mouse motion speed setting to exactly the
middle speed.
 Click OK.
2. Disable transition effects:
a. Select the Display option from the Control Panel.
b. Click the Effects tab.
c. Deselect the "Use the following transition effect for
menus and tooltips" option.
d. Click OK.
e. Close the Control Panel.

Linux® Settings
(Standard Mouse Mode only) Set the mouse acceleration to
exactly 1 and set the threshold to exactly 1. Enter this
command: xset mouse 1 1. This should be set for execution
upon login.

Sun Solaris™ Settings
1. Set the mouse acceleration value to exactly 1 and the
threshold to exactly 1.
2. Ensure that your video card is set to a supported
resolution and that its output is VGA (not composite
sync).

Apple® Macintosh Settings
Use the D2CIM-VUSB and Absolute Mouse Synchronization.

IBM® AIX Settings
Go to the Style Manager, click on Mouse Settings and set
Mouse Acceleration to 1.0 and Threshold to 3.0.
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II. Network Firewall Settings
To enable remote access to the Dominion KX II, your network
and firewall must allow communication on TCP Port 5000.
You can also configure the Dominion KX II to use a different
TCP port, then allow communication on that port.
To access he Dominion KX II via Web browser, your firewall
must also allow access to TCP Port 443 (Standard HTTPS).
Access to TCP Port 80 (Standard HTTP) enables automatic
redirection of "HTTP" requests to "HTTPS".
QS Rule

Windows® 2000 Settings
To configure KVM target servers running Microsoft
Windows 2000:
1. Configure the mouse settings:
a. Choose Start > Control Panel > Mouse.
b. Click the Motion tab.
 Set the acceleration to None.
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III. Connect Devices
D. Local Access Port (Local PC)
For convenient access to target servers while at the rack, use
the Dominion KX II Local Access port. While the local port is
required for installation and setup, it is optional for subsequent
use. The local port also provides a graphical user interface
(the KX II Local Console) for administration and target server
access.
Attach a multi-sync VGA monitor, mouse, and keyboard to the
respective Local User ports, using either a PS/2 or USB
keyboard and mouse.

E. Target Server Ports
A. AC Power

The Dominion KX II uses standard UTP cabling (Cat5/5e/6) to
connect to each target server.

To connect the power supply:
1. Attach the included AC power cord to the Dominion KX II
and plug into an AC power outlet.
2. For dual power failover protection, attach the second
included AC power cord and plug it into a different power
source than the first power cord.
Note: If you only attach one power cord, the power LED on
the KX II front panel will display red, because the system is
set to automatically detect both power sources. Please refer
to Step V for more information about turning off the automatic
power detection for the power source not in use.

B. Modem Port (Optional)
Please see the Dominion KX II User Guide for information on
connecting modems.

To connect a target server to the Dominion KX II:
1. Use the appropriate Computer Interface Module (CIM).
2. Attach the HD15 video connector of your CIM to the video
port of your target server. Ensure that your target server's
video has already been configured to a supported
resolution and refresh rate. For Sun servers, also ensure
that your target server's video card has been set to output
standard VGA (H-and-V sync) and not composite sync.
3. Attach the keyboard/mouse connector of your CIM to the
corresponding ports on your target server. Using a
standard straight-through UTP (Cat5/5e/6) cable, connect
the CIM to an available server port on the back of your
Dominion KX II device.
A new switch position takes effect only after the CIM is powercycled. To power-cycle the CIM, remove the USB connector
from the target server and plug it back in a few seconds later.
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C. Network Port
The Dominion KX II provides two Ethernet ports for failover
purposes (not for load-balancing). By default, only LAN1 is
active and the automatic failover is disabled. When enabled, if
the Dominion KX II internal network interface or the network
switch to which it is connected becomes unavailable, LAN2
will be enabled using the same IP address.
To connect the network:
1. Connect a standard Ethernet cable (included) from the
network port labeled LAN1 to an Ethernet switch, hub, or
router.
2. To make use of the optional Dominion KX II Ethernet
failover capabilities:
 Connect a standard Ethernet cable from the network
port labeled LAN2 to an Ethernet switch, hub, or
router.
 Enable Automatic Failover on the Network
Configuration page.
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IV. Dominion KX II Initial Configuration
Change the Default Password
The Dominion KX II unit ships with a default password. The
first time you start the Dominion KX II you are required to
change that password.
1. Power ON the Dominion KX II using the power switch(es)
at the back of the unit. Please wait for the Dominion KX II
unit to boot. (A beep signals completion of the boot.)
2. Once the unit has booted, the KX II Local Console is
visible on the monitor attached to the Dominion KX II local
port. Type the default username (admin) and password
(raritan) and click Login. The Change Password screen is
displayed.
3. Type your old password (raritan) in the Old Password
field.
4. Type a new password in the New Password field; retype
the new password in the Confirm New Password field.
Passwords can be up to 64 characters long and can
consist of English alphanumeric and printable special
characters.
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5. Click Apply.
6. You will receive confirmation that the password was
successfully changed. Click OK. The Port Access page
opens.

Assign an IP Address
These procedures describe how to assign an IP address on
the Network Settings page.
1. From the Dominion KX II Local Console, choose Device
Settings > Network. The Network Settings page opens.
2. Specify a meaningful Device Name for your Dominion KX
II device using up to 16 alphanumeric characters, valid
special characters, and no spaces.
3. In the IPv4 section, enter or select the appropriate IPv4specific network settings:
a. Enter the IP Address if needed. The default IP address
is 192.168.0.192.
b. Enter the Subnet Mask. The default subnet mask is
255.255.255.0.
c. Enter the Default Gateway if None is selected from the
IP Auto Configuration drop-down.
d. Enter the Preferred DHCP Host Name if DHCP is
selected from the IP Auto Configuration drop-down.
Note: The host name cannot exceed 232 characters in
length.
e. Select the IP Auto Configuration. The following options
are available:
 None (Static IP) - This option requires that you
manually specify the network parameters.
This is the recommended option because the
Dominion KX II is an infrastructure device and its IP
address should not change.


DHCP - Dynamic Host Configuration Protocol is used
by networked computers (clients) to obtain unique IP
addresses and other parameters from a DHCP server.
With this option, network parameters are assigned by
the DHCP server. If DHCP is used, enter the
Preferred host name (DHCP only). Up to 63
characters.

4. If IPv6 is to be used, enter or select the appropriate IPv6specific network settings in the IPv6 section. See the
Dominion KX II User Guide for information on configuring
IPv6 settings.
5. Select Obtain DNS Server Address Automatically if DHCP
is selected and Obtain DNS Server Address is enabled.
When Obtain DNS Server Address Automatically, the DNS
information provided by the DHCP server will be used.
6. If Use the Following DNS Server Addresses is selected,
regardless of whether DHCP is selected or not, the
addresses entered in this section will be used to connect
to the DNS server.
Enter the following information if the Following DNS
Server Addresses option is selected. These addresses
KX II QSG

are the primary and secondary DNS addresses that will
be used if the primary DNS server connection is lost due
to an outage.
a. Primary DNS Server IP Address
b. Secondary DNS Server IP Address
7. When finished, click OK. Your Dominion KX II device is
now network accessible.

Name Target Servers
To name the target servers:
1. Connect all of the target servers if you have not already
done so.
2. Using the Dominion KX II Local Console, choose Device
Settings > Port Configuration. The Port Configuration page
opens.
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V. Specify Power Supply Auto Detection
The Dominion KX II provides dual power supplies, and can
automatically detect and provide notification regarding the
status of these power supplies. Use the Power Supply Setup
page to specify whether you are using one or both of the
power supplies. Proper configuration ensures that the
Dominion KX II sends the appropriate notifications should a
power supply fail. For example, if power supply number one
fails, the power LED at the front of the unit will turn red.
To enable automatic detection for the power supplies
in use:
1. Choose Device Settings > Power Supply Setup. The
Power Supply Setup page opens.
2. If you are plugging power input into power supply number
one (left-most power supply at the back of the unit), then
select the Powerln1 Auto Detect option.
3. If you are plugging power input into power supply number
two (right-most power supply at the back of the unit), then
select the Powerln2 Auto Detect option.
4. Click OK.
Note: If either of these checkboxes is selected and power
input is not actually connected, the power LED at the front of
the unit turns red.
QS Rule

VI. Create User Groups and Users
To add a new user group:
1. Open the Group page by selecting User Management >
Add New User Group or clicking the Add button from the
User Group List page.
The Group page is organized into the following
categories: Group, Permissions, Port Permissions, and IP
ACL.
2. Type a descriptive name for the new user group into the
Group Name field.
3. Set the permissions for the group. Select the checkboxes
4

before the permissions you want to assign to all of the
users belonging to this group.
4. Set the port permissions. Specify the server ports that can
be accessed by users belonging to this group (and the
type of access).
5. Set the IP ACL. This feature limits access to the Dominion
KX II device by specifying IP addresses. It applies only to
users belonging to a specific group, unlike the IP Access
Control list feature that applies to all access attempts to
the device (and takes priority). Optional
6. Click OK.
To add a new user:
1. Open the User page by choosing User Management >
Add New User or clicking the Add button on the User List
page.
2. Type a unique name in the Username field (up to 16
characters).
3. Type the person's full name in the Full Name field (up to
64 characters).
4. Type a password in the Password field and retype the
password in the Confirm Password field (up to 64
characters).
5. Choose the group from the User Group drop-down list.
The list contains all groups you have created in addition to
the system-supplied default groups (<Unknown> (default
setting), Admin, Individual Group).
If you do not want to associate this user with an existing
User Group, select Individual Group from the drop-down
list.
6. To activate the new user, select the Active checkbox. The
default is activated (enabled).
7. Click OK.

VIII. Access and Control Target Servers
Remotely
The Dominion KX II Port Access page provides a list of all
Dominion KX II ports, the connected target servers, their
status, and availability.

Access a Target Server
To access a target server:
1. Click the Port Name of the target you want to access. The
Port Action Menu is displayed.
2. Choose Connect from the Port Action menu. The video
display switches to the target server interface.

Switch between Target Servers
To switch between KVM target servers:
1. While already using a target server, access the Dominion
KX II Port Access page.
2. Click the port name of the target you want to access. The
Port Action menu is displayed.
3. Choose Switch From from the Port Action menu. The
Virtual KVM Client window switches to the new target
server you selected.

Disconnect a Target Server
To disconnect a target server:
1. Click the port name of the target you want to disconnect.
The Port Action menu is displayed.
2. Choose Disconnect on the Port Action menu.
QS Rule

IX. For Additional Information

QS Rule

VII. Launch the Dominion KX II Remote
Console
To launch the Dominion KX II Remote Console:
1. Log on to any workstation with network connectivity to
your Dominion KX II and Java Runtime Environment
installed (JRE is available at http://java.sun.com/
http://java.sun.com).
2. Launch a supported web browser such as Internet
Explorer (IE) or Firefox.
3. Type the following URL: http://IP-ADDRESS, where IPADDRESS is the IP address that you assigned to your
Dominion KX II. You can also use https, the DNS name of
the Dominion KX II assigned by the administrator
(provided that a DNS server has been configured), or just
simply type the IP address in the browser (Dominion KX II
always redirects the IP address from HTTP to HTTPS.)
The Login page opens.
4. Type your Username and Password. Click Login.

For more information about the Dominion KX II and the entire
Raritan product line, refer to the Raritan User Guide & Quick
Setup Guides CD ROM or Raritan's website
http://www.raritan.com/support. For technical issues, contact
Raritan Technical Support by telephone (732) 764-8886, fax
(732) 764-8887, or email tech@raritan.com, Monday - Friday
8:00 AM to 8:00 PM EST.
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