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The following sections have changed or information has been added to 
the User Guide based on enhancements and changes to the equipment 
and/or user documentation.  

• Import/Export Keyboard Macro Definitions (on page 103) - Newly 
added functionality. 

• Launching MPC from a Web Browser (on page 12) - Updated with 
information on using Alt + Tab to toggle between windows on local 
systems. 

• Keyboard Macros (on page 64) - Information on using macros for hot 
keys in MPC has been added. 

Please see the Release Notes for a more detailed explanation of the 
changes applied to this version of the application. 
 

What's New in the MPC and 
RRC User Guide 
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Raritan Multi-Platform Client (MPC) and Raritan Remote Client (RRC) 
are graphical user interfaces for the Raritan Dominion KX and IP-Reach 
product lines, providing remote access to target servers connected to 
Raritan KVM over IP devices. Non-Windows users must use Raritan 
Multi-Platform Client, and Windows® users running Internet Explorer 
must use Raritan Remote Client. 

 

In This Chapter 
Use with Raritan Products ........................................................................... 7 
Minimum System Requirements ................................................................. 8 
Raritan Multi-Platform Client (MPC) Supported Operating Systems..... 11 
Raritan Remote Client (RRC) ..................................................................... 12 
 
 

Use with Raritan Products 

Raritan Multi-Platform Client (MPC) and Raritan Remote Client (RRC) 
are intended for use with the following products: 

Product MPC RRC 
Dominion KX II (G2) X  

Dominion KX I (G1) X X 

Dominion KX101 (G1) X X 

Dominion KSX (G1) X X 

IP-Reach X X 

UST-IP (G1) X X 

Legend: 

G1 Generation 1 

G2 Generation 2 

There are some differences between MPC when used with the Dominion 
KX I and Dominion KX II devices; these differences are noted in the user 
manual. 

Note: RRC cannot be used with Dominion KX II devices. 
 

Chapter 1 Introduction and Installation 
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Minimum System Requirements 

The minimum system requirements for the Raritan Multi-Platform Client 
and Raritan Remote Client are: 

• CPU Speed: 1.0 GHz 

• RAM: 512 Mbytes 

Note: Running the client software on system configurations below either of these 
specifications may impact performance and result in errors. 
 

Note to CC-SG Users 

If you are using Dominion KX II in a CC-SG configuration, do not use 
the CC-SG proxy mode if you are also planning to use the Multi-
Platform Client (MPC). 
 

Java Runtime Environment (JRE) Requirements 

Raritan recommends using Java® Runtime Environment (JRE) version 
1.5 for optimum performance, but MPC will function with JRE version 
1.4.2_05 or greater (with the exception of JRE 1.5.0_02). JRE 1.6 is also 
supported, but has not been fully tested. 

Determine your version of the JRE on the Java webpage: 
http://www.java.com/en/download/help/testvm.xml 
(http://www.java.com/en/download/help/testvm.xml) 

You may need some configuration depending on your OS and browser; 
configuration instructions are provided with the JRE download. Please 
note that modem use is not supported with Raritan's Dominion KX101. 

Important: When launching MPC from a browser, it is highly 
recommended to disable the Java Applet caching. 
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Although no actual problems have occurred when Java caching is turned 
on, some non-impacting Java exceptions have occurred with the caching 
turned on. Generation of these Java-exceptions can appear in the Java 
Applet Console window, and may degrade performance. 

For Linux/UNIX environments, the Java Control Panel is located in the 
JRE's bin directory; the location varies based on where JRE was installed 
by your Linux/UNIX administrator. 

Tip: It is also recommended that you clear the Java cache. 

 To disable Java caching and clear the cache (these 
steps use Microsoft Windows XP and JRE 1.5.0): 

1. From the Start menu, click Control Panel. 

2. Double-click on the Java icon to launch it. The Java Control Panel 
opens: 

 

3. To disable Java caching: 
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a. From the General tab, click the Settings button in Temporary 
Internet Files. The Temporary Files Settings dialog opens: 

 

b. Click the View Applets button. The Java Applet Cache Viewer 
opens: 

 

c. Clear the Enable Caching checkbox. 

d. Click OK. 

4. To clear the Java cache: 
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a. From the Temporary Files Settings dialog, click the Delete Files 
button. The Delete Temporary Files dialog opens: 

 

b. Click OK. 
 

MPC Supported Browsers 

MPC supports the following browsers: 

• Internet Explorer 6 and 7 

• Firefox® 1.5 and 2.0 

• Mozilla® 1.7 

• Safari 2.0 
 

Raritan Multi-Platform Client (MPC) Supported Operating Systems 

When launched as web applet or as a standalone application, MPC 
allows you to reach target servers via different Raritan Dominion KX and 
IP Reach models. 

Raritan MPC is compatible with the following platforms: 

• Windows XP 

• Windows 2000 SP4 

• Windows Vista 

• Red Hat Linux® 9.0 

• Red Hat Enterprise Workstation 3.0 and 4.0 

• SUSE Linux Professional 9.2 and 10 

• Fedora Core 5 and above 

• Mac® 

• Solaris™ 
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Launching MPC from a Web Browser 

Important: Regardless of the browser you use, you must allow pop-ups 
from the Dominion device's IP address in order to launch MPC. 

1. To launch MPC from a client running any supported browser, type 
http://IP-ADDESS/mpc into the address line, where IP-ADDESS is 
the IP address of your Raritan device. MPC will launch in a new 
window that does not contain a menu bar, tool bar, scroll bar, or 
address bar. Work in this window and toggle to other open windows 
using the ALT+Tab command. 

Note: The ALT+Tab command will toggle between windows only on 
the local system. 

2. When MPC launches, a device tree of all automatically detected 
Raritan devices found on your subnet is displayed on the left side of 
the screen. If you do not find your unit listed by name, create an icon 
manually by selecting Connection > New Profile. The Add 
Connection window opens. 

3. Type a device Description, specify a Connection Type, add the 
device IP Address, and click OK. These specifications can be edited 
later. 

4. In the Navigator panel on the left of the screen, double-click on the 
icon that corresponds to your Raritan device. 

If you prefer, install MPC as a standalone applet (see next section). 

Note: Depending on your browser and browser security settings, you may see 
various security and certificate check and warning dialog boxes. It is necessary 
to accept the options in order to launch MPC. 
 

Installing and Launching Standalone MPC 

Please see Appendix A: Installing and Launching Standalone MPC for 
instructions on installing the standalone version of MPC on various 
operating systems. 

Direct Dial Modem applies to devices running on Windows, Linux, Sun 
Solaris, and Macintosh®.  
 

Raritan Remote Client (RRC) 

Important: RRC works only with MS Internet Explorer. If you are 
using a different Web browser, MPC will load automatically. 
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Most users access RRC via Internet Explorer, while other users, 
particularly those operating over a modem connection, invoke RRC 
standalone. Both options are detailed below. Modem use is not 
supported with Raritan's Dominion KX101. 
 

Launching RRC from a Web Browser 

Your IP-Reach and Dominion units feature Web browser-access 
capabilities and can provide a connection from any Windows-based 
Remote PC running Microsoft Internet Explorer 6.0. 

Security Settings 

To access IP-Reach or Dominion KX via Web browser, your Web 
browser must be configured appropriately under the Internet Explorer 
security settings tab: 

• Download Signed ActiveX controls should be set to either “Enable” 
or “Prompt” 

• Run ActiveX controls and plug-ins should be set to either “Enable” 
or “Prompt” 

Please consult your Microsoft Internet Explorer documentation for 
additional information. 

Note: Microsoft Windows 2000, Microsoft Windows XP, and Microsoft 
Windows 2003 restrict certain types of users from downloading and running 
ActiveX controls and plug-ins, regardless of the above settings in Internet 
Explorer. Please consult your Microsoft Windows documentation for more 
information. 

Launching RRC 

1. Ensure that your browser security settings are configured 
appropriately and type the IP address assigned to your IP-Reach or 
Dominion unit (please see the Initial Configuration section in the 
appropriate product user guide for additional information) in the 
URL field of your Web browser. 
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Note: IP-Reach and Dominion units ship with the default IP address 
of 192.168.0.192. Please note that an IP address must be used. 
Hostnames are not currently supported. 

2. You will be redirected to an HTTPS (128-bit) secure Web page so you 
can launch RRC. 
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3. Depending on your browser and its security configuration, you may 
see any or all of the following dialog boxes, confirming access and 
launch of an externally-provided program. Click Yes to advance 
through any of these prompts. 
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Removing RRC from the Browser Cache 

To remove RRC from your browser cache for any reason, follow the 
standard procedure for your Web browser software. 

Directions for Internet Explorer v6.0: 

1. If you have used RRC recently, exit all instances of Internet Explorer, 
and restart Internet Explorer. 

2. On the Internet Explorer Tools menu, click Internet Options. 

3. When the Internet Options dialog box appears, click on the General 
Settings tab, and click Delete Files. 

4. Click on the Settings tab, and then click View Objects. 

5. Internet Explorer will display a list of cached program objects. Select 
any entries named “TeleControl Class,” “Raritan Console,” or 
“Power Board” and delete them. 
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Installing and Launching Standalone RRC 

Note: This step is optional. IP-Reach or Dominion can be accessed from a 
Remote PC either by installing RRC software or by launching RRC via Web 
browser. Accessing IP-Reach or Dominion via Web browser does not require 
any software installation on the Remote PC. This section lists the steps required 
to invoke RRC using standalone software, which may be useful for accessing IP-
Reach or Dominion via modem or if you wish to close firewall access to ports 80 
and/or 443. 

1. Launch your Web browser and go to Raritan's Web site 
(http://www.raritan.com/). Click Support in the top navigation bar, 
and then click Firmware Upgrades in the left navigation bar (or type 
the URL http://www.raritan.com/support/firmwareupgrades). 

2. Scroll down the page until you see the appropriate product name 
and click on it. 

3. Locate the appropriate version of the standalone RRC client for the 
Release you are using. 

4. The entry for the standalone RRC client is a .zip file which contains 
the release notes and the Installer for Standalone RRC.  Check the 
release notes for the latest information. 

5. You can download the .zip file to your client machine or simply click 
on the .zip file entry. 

6. Double-click on the Installer executable in the .zip file and follow the 
on-screen instructions in the InstallShield Wizard to complete RRC 
installation on your Remote PC.  Be sure to check the release notes 
for the latest information and any release specific instructions. 

7. Depending upon the configuration of your PC, the RRC installation 
program may also automatically install DirectX and Microsoft 
Foundation Class libraries, if they are required.  If so, you will be 
asked to restart your PC after installation. 

8. A Raritan Remote Client icon will appear on your desktop. Click on 
this icon to launch the standalone RRC client. 

9. The standalone client can be uninstalled in the Add or Remove 
Programs applet in the Windows Control Panel.  You must uninstall 
before installing a new version of Standalone RRC. 
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Window Layout 

MPC Interface 

MPC functions are grouped into six general sections on the screen. As a 
standalone product, or as a Web applet, the MPC window contains these 
main sections: 

 
 

Chapter 2 Operation
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RRC Interface 

The RRC window is almost identical to the MPC window. 

 
 

Connection Profiles 

Connection profiles store important information about your Raritan 
device, such as IP address, custom TCP ports, preferred compression 
settings, and custom security keys. A profile is required to access devices 
outside your subnet and to access devices using dial-up connection. 

Through profiles, you can set up personalized connections; these profiles 
are not shared among other users. 

Tip: If your Raritan device is configured to use a custom TCP port or a group 
security key, first create a connection profile so that you can access the device. 
 

Creating Profiles 

 To create a profile: 

1. There are two ways to create a profile: 
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• For automatically discovered devices, right-click on the device name 
in the Navigator and select Add Profile from the shortcut menu. 

• For other devices, select Connection > New Profile. 

The Add Connection window opens. Options are organized into 
three tabs. 

1. Update the Connect tab: 

 
• Description: Type a meaningful description (up to 32 characters, 

alphanumeric, special characters (on page 136) allowed). This 
description identifies the Raritan device in the Navigator. 

• Product: Select the Raritan product you are using from the drop-
down list: Dominion KX G2 (Dominion KX II), Dominion KX G1, 
Dominion KSX G1, IP-Reach, UST-IP G1, and KX101 G1. 

• Connection Type: Use the drop-down list box to select the type of 
connection. Please note that only TCP/IP is available for Generation 2 
(G2) Raritan devices. 

 Select TCP/IP Connection for a LAN/WAN connection. 

Find Raritan device by (select one of these options): 
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 IP Address: Type the IP Address assigned to your Raritan 
device. 

 Name: Type the name assigned to your Raritan device during 
initial setup. 

 DNS: Type the Domain Name Server (DNS) name. Use this 
option if you have a DNS server to resolve a DNS name to 
the IP Address assigned to your Raritan device. Please note 
that you cannot use this option for Raritan Generation 2 (G2) 
devices. 

 Select Dial Up Connection for a direct analog modem connection 
to the Raritan device. Type the parameters that MPC or RRC 
should use to establish a connection. Dial up connection does not 
apply to Generation 2 (G2) or KX101. 
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 Phone Number. Include any additional codes that MPC or 
RRC should dial to establish a connection, such as country 
codes, area codes, or outside line access codes. 

 Modem. Select the modem (as configured in Windows) from 
the drop-down list that MPC or RRC should use to dial and 
connect to your Raritan device. 

Note: For security reasons, you must use the MPC standalone client if you 
require modem access. In addition, one modem on a client PC can be used for 
only one device connection. 
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• Use Default Port Number: For TCP Ports, Dominion KX and IP-

Reach are automatically configured to use TCP Port 5000 when 
communicating with MPC/RRC.  
If you do not want to use the Default Port Number: 
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 Clear the Use Default Port Number check box. 

 Type the configured TCP Port to be used in the Port Number 
field. 

1. Update the Compression tab (not available for Generation 2 (G2) 
Raritan devices): 
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• Connection Speed: Select the Connection Speed from the drop-down 

list. IP Reach and Dominion can automatically detect available 
bandwidth and not limit bandwidth use; but you can also adjust this 
usage according to bandwidth limitations. Depending on the Raritan 
device in use, different options may be available. 
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Auto Detect 

100mb Ethernet 

10mb Ethernet 

1.5mb (Max DSL/T1) 

1mb (Fast DSL/T1) 

512 kb (Medium DSL/T1) 

384 kb (Slow DSL/T1) 

256 kb (Cable) 

128 kb (Dual ISDN) 

56 kb (ISP Modem) 

33 kb (Fast Modem) 

24 kb (Slow Modem) 

• Color Depth: Select the Color Depth from the drop-down list. IP-
Reach and Dominion can dynamically adapt the color depth 
transmitted to remote users in order to maximize usability in all 
bandwidth constraints. Depending on the Raritan device in use, 
different options may be available. 

Important: For most administrative tasks (server monitoring, 
reconfiguring, etc.), administrators do not require the full 24-bit or 32-
bit color spectrum made available by most video graphics cards. 
Attempting to transmit such high color depths wastes network 
bandwidth. 

Auto Select Color 

15-bit RGB Color 

12-bit RGB Color 

8-bit RGB Color 

5-bit Color 

4-bit Color 

4-bit Gray 

3-bit Gray 

2-bit Gray 

Black and White 
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 Progressive Update increases the usability in constrained 
bandwidth environments. When Progressive Update is enabled, 
IP-Reach or Dominion initially sends an image of the remote 
desktop at lower color depths, and then provides higher color 
depth images as bandwidth allows. 

Note: When Color Depth is set to Auto Select Color (default), Progressive 
Update is automatic. IP-Reach or Dominion will enable/disable Progressive 
Update as required, disabling it for fast connections and enabling it for slow 
connections. 

 Internet Flow Control: When using IP-Reach or Dominion over 
an unpredictable public WAN (particularly in international 
scenarios), checking the Internet Flow Control check box ensures 
that packets transmitted by IP-Reach or Dominion are received 
and reconstructed by MPC/RRC in the correct order. 

 Smoothing (15-bit mode only): Use the slider to select the desired 
level of video Smoothing. The level determines how aggressively 
to blend screen regions with small color variation into a single 
smooth color. Smoothing improves the appearance of target 
video by reducing displayed video noise. 

• (MPC Only) Frames Per Second: This setting instructs MPC how 
often to redraw the video display of the target. This only affects the 
client display behavior and has no bearing on the data rate of the 
video being sent to the client. Setting this option higher makes the 
video appear smoother but also requires more processing power. 

1. Update the Security tab (not available for Generation 2 (G2) Raritan 
devices): 
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Please note that the Security tab is disabled for Generation 2 Raritan 
devices. If your Dominion or IP-Reach unit is configured to use a 
private security key, input that key to gain the authorization 
required to initiate a connection to that IP-Reach or Dominion unit. 

 
• Type the private security key in the Private Key field. 

• Re-type the private security key in the Confirm Private Key field to 
ensure no typographical errors were made. 

1. Click OK to create the connection profile. 
 

Modifying Profiles 

 To modify a profile in MPC or RRC: 

1. Select the device in the Navigator panel and right-click on it. 
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2. Select Modify Profile. The Modify Connection window opens: 

 

3. Update the fields as appropriate. 

4. Click OK. 
 

Deleting Profiles 

 To delete a profile in MPC or RRC: 

1. Select the device with a profile in the Navigator and right-click on it. 

2. Select Delete Profile. 

3. When prompted to confirm the deletion, click Yes to delete the 
profile for this device, or click No to return to MPC or RRC without 
deleting. 
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Establishing a New Connection 

Note: Depending on your version of the JRE, you might receive a certificate 
message when using the MPC standalone application to access a Dominion KX 
II device. You have to accept the certificate in order to establish the connection. 

Double-click the icon of a Raritan networked device in the Navigator, 
then type your user name and password to connect. You can also right-
click on the device name and select New Connection from the shortcut 
menu. 

Note: The default IP-Reach or Dominion login user name is admin, with the 
password raritan. This user has administrative privileges. Passwords are case 
sensitive and must be entered in the exact case combination in which they were 
created. The default password raritan must be entered entirely in lowercase 
letters. To ensure security, change the default username password as soon as 
possible. 

If you do not see an icon for your IP-Reach or Dominion in the 
Navigator, please follow the instructions in the Creating Profiles section 
in this chapter to create a new connection profile for your IP-Reach or 
Dominion. 

If you are having problems connecting to a Raritan device, be sure to 
check the following: 

• Username: Raritan usernames are not case-sensitive. 

• Password: Raritan passwords are case-sensitive. 

• TCP Port: If you have configured your Raritan Device to use a non-
default TCP Port, this information must be entered into its 
connection profile. 

• Firewall Settings: If you are accessing a Raritan Device through a 
firewall, that firewall must be configured to allow two-way 
communication on TCP Port 5000 (or the custom TCP Port to which 
your Raritan Device has been configured). 

• Security Key: If you have configured your Raritan Device to require 
a group security key, that key must be entered into the device's 
connection profile. 

Note: If you are running MPC on Internet Explorer with both a Microsoft 
Firewall and a non-Microsoft Firewall utility installed, when you launch MPC - 
even if MPC is not open - IE will launch a message telling you that MPC is 
already running. To avoid this, deactivate one of your Firewalls, or use a 
browser such as Mozilla or Firefox. 
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Closing a Remote Connection 

To close the IP-Reach or Dominion connection, select the device in the 
Navigator and right-click on it. Select Disconnect from the shortcut 
menu. 

To exit MPC or RRC completely, on the Connection menu, click Exit. 

Note: RRC client PC can support only one modem connection at one time. 
 

Connection Info 

 To obtain information about your MPC connection: 

Select Connection > Connection Info. The Connection Info window 
opens: 
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The following information is displayed about the current connection: 

• Device Name. The name of your Dominion or IP-Reach device. 

• IP Address. The IP Address of your Dominion or IP-Reach device. 

• Port. The KVM Communication TCP/IP Port used to access the 
target device. 

• Data In/Second. Data rate in. 

• Data Out/Second. Data rate out. 

• FPS. The frames per second transmitted for video. 

• Connect Time. The duration of the connect time. 

• Horizontal Resolution. The screen resolution horizontally. 

• Vertical Resolution. The screen resolution vertically. 

• Refresh Rate. How often the screen is refreshed. 

• Protocol Version. The RFB Protocol version. 

 To copy this information: 

Click Copy to Clipboard. The information is now available to be 
pasted into the program of your choice. 

 



 Chapter 2: Operation 
 

 
33

Navigator 

The MPC and RRC Navigator panels provide a tree view of every known 
Raritan device so you can access all Raritan networked appliances for 
which a connection profile exists and/or all Raritan devices automatically 
identified on the network. 

Note: Automatic Raritan device identification uses the UDP protocol, and will 
typically identify all Raritan devices on your subnet. Network administrators 
rarely allow UDP broadcasts to function outside of a subnet. Automatic Raritan 
device identification will find only those Raritan devices that are configured to 
use the default TCP Port (5000) or another “broadcast” port as set in the 
Options panel on the Tools menu. 
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Each device entry in the Navigator provides two icons to communicate 
network status and connection profile information. A connection profile 
is generally created by an MPC or RRC user in order to store 
personalized information about specific devices (please see the section 
Creating Profiles in this chapter for additional information). 

In MPC, devices are named according to the Manager Name field in KX 
Manager's Network Configuration screen. Dominion KX II devices are 
named according to the Device Name field in Dominion KX II Console 
Network Settings screen. 

In RRC, profiled devices are listed in the Navigator according to the data 
in the Description field of the device's profile. Automatically-identified 
devices will be identified according to the name assigned to them in that 
device's network configuration setting. 

Left Icon (Connection Profile Icon) 

 Profiled - A network connection profile exists for this device. 

 
Modem Profile - A modem connection profile exists for this 
device. 

 
Not Profiled - MPC/RRC found this device on the network, but a 
connection profile does not exist for it. 

Right Icon (Network Status Icon) 

 
Connected (green) - You are currently authenticated and 
connected to this device. 

 
Available (black) - This device is currently available on the 
network, but you are not currently connected to it. 

 

Unavailable - A profile exists for this device, but it is not 
currently available on the network. (Note that all devices with 
modem profiles to which you are not currently connected will 
display this icon.) 

For each Raritan device to which you are connected, the Navigator 
expands its display tree to show each port for which you have access. 

• Ports displayed with a green icon indicate that you are connected to 
that port. 

• Bold type indicates which port is currently displayed (active) in the 
remote desktop area of the client. 

For each server port entry, the Navigator displays the following icons: 
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Connected (green) 

 
Available for connection 

 
Unavailable (no device connected, or access is blocked) 

 
In use by another (may be unavailable depending on 
permissions) 

Note: Blank port names are displayed as 'Unnamed.' If you make a port name 
blank, it will revert to this default when you reconnect to the device. 

Navigator Customization 

Use specific tools in the Toolbar to customize some Navigator attributes: 

 

 
Display / Hide Navigator - Toggle Navigator visibility. You can 
also use View ® Navigator in the Menu Bar to toggle Navigator 
visibility. 

 
Refresh Navigator - Update the device status information 
displayed in the Navigator. 

 

Show Browsed Devices - Toggle whether the Navigator should 
display “Not Profiled” devices found on the network, or should 
show only devices for which profiles exist. This option can also 
be reached using View ® Show ® All in the Menu Bar. 

Note: The Browse connection method is the only method of connecting to a 
Raritan Device configured to use DHCP IP addressing. 
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Display and Sorting Options 

To better organize your view of all ports, use the Show and Sort options. 
Please note that you do not need an open connection to a target to Show 
and Sort targets in the Navigation panel. 

Showing Ports 

In MPC and RRC, you can select which ports to view in the Navigation 
panel by selecting Show options on the View menu. 

• Discovered Devices: shows or hides discovered devices from the 
navigator view; you will not see broadcast messages when this 
option is disabled. 

• Unassigned Channels: shows or hides channels with no attached 
targets. Please note that the default for generation 1 (G1) devices is to 
show unassigned channels (option is enabled), whereas, the default 
is to hide unassigned channels (option is disabled) for generation 2 
(G2) devices. 

• Tools: shows or hides the Admin and Diagnostic ports. 
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Note: These settings are saved from session to session. 

Sorting Ports 

Use the Sort options on the View menu to organize KX port information; 
sort ports by channel number, channel name, or channel status.  

Sort by Channel Number 

When sorted by channel, ports are listed numerically. 
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Sort by Name 

When sorted by name, port names are sorted alphanumerically within 
each group. 
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Sort by Status 

Ports are sorted in the following order: 

• Active Channels 

• Busy Channels 

• Available Devices 

• Unavailable Devices 
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MPC Navigator Tabs 

MPC tabs at the base of its Navigator pane. These tabs allow you to 
change how you display devices. 

Click the View By Name tab to sort the list alphabetically by name, or 
click the View By IP tab to sort the list numerically by IP address. 

 

Please note that these tabs are available only in the MPC interface. 

In both MPC and RRC, if all ports of the device to which you are 
connecting are already occupied, an alert message appears and you must 
try to connect when one or the ports is available. 
 

Toolbars and Shortcuts 

The Toolbar provides one-click access to the most frequently-used 
commands. 
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Button Button 
Name 

Function 

 New Profile 
Creates a new Navigator entry for a Raritan 
device; same results as selecting Connection à 
New Profile in the menu bar. 

 
Connection 
Properties 

Opens Modify Connection Properties dialog 
box to manually adjust bandwidth-correlated 
options (Connection Speed, Color Depth, 
etc.). 

 
Video 
Settings 

Opens the Video Settings dialog box to 
manually adjust video conversion 
parameters. 

 

Color 
Calibration 

Adjusts color settings to reduce excess color 
noise. 

 
Synchronize 
Mouse 

In dual-mouse mode, forces realignment of 
target server mouse pointer with Raritan 
Remote Client mouse pointer. 

 
Refresh 
Screen Forces refresh of video screen. 

 

Auto-sense 
Video 
Settings 

Forces refresh of video settings (resolution, 
refresh rate). 

 
Enter On-
Screen Menu

Not applicable for IP-Reach or Dominion. 
Used by MPC/RRC with other Raritan 
products. 

 
Exit On-
Screen Menu

Not applicable for IP-Reach or Dominion. 
Used by MPC/RRC with other Raritan 
products (on keyboard, press ESC) 

 

Send 
CTRL+ALT+
DEL 

Sends a CTRL+ALT+DEL key sequence to the 
target server. 

 
Single 
Cursor Mode

Enters Single Cursor Mode, in which the local 
PC's mouse pointer no longer appears on-
screen. Press CTRL+ALT+X to exit this mode. 

 
Full Screen 
Mode 

Maximizes the screen real estate to view the 
target server desktop. 
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Button Button 
Name 

Function 

 
Scaling 

Increases or reduces target video size so you 
can view the entire contents of the target 
server window without using the scroll bar. 

 
Show / Hide 
Navigator 

Toggles Navigator panel from visible to 
hidden. 

 
Refresh 
Navigator 

Forces a refresh of the data displayed by the 
RRC Navigator. 

 

Show / Hide 
“Browsed” 
Devices 

Toggles whether or not the RRC Navigator 
displays Raritan Devices automatically 
identified on the network (that do not have 
pre-configured profiles associated with 
them). 

 About Displays version information about MPC and 
RRC. 

 
 

Standard Toolbar 

The Standard Toolbar provides one-click access to the most frequently-
used commands. 

 To display the standard toolbar: 

Select View > Standard Toolbar. 
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Button Button 
Name 

Function 

 New Profile 
Creates a new Navigator entry for a Raritan 
device; same results as selecting Connection à 
New Profile in the menu bar. 

 
Connection 
Properties 

Opens Modify Connection Properties dialog 
box to manually adjust bandwidth-correlated 
options (Connection Speed, Color Depth, 
etc.). 

 
Video 
Settings 

Opens the Video Settings dialog box to 
manually adjust video conversion 
parameters. 

 

Color 
Calibration 

Adjusts color settings to reduce excess color 
noise. 

 
Synchronize 
Mouse 

In dual-mouse mode, forces realignment of 
target server mouse pointer with Raritan 
Remote Client mouse pointer. 

 
Refresh 
Screen Forces refresh of video screen. 

 

Auto-sense 
Video 
Settings 

Forces refresh of video settings (resolution, 
refresh rate). 

 
Enter On-
Screen Menu

Not applicable for IP-Reach or Dominion. 
Used by MPC/RRC with other Raritan 
products. 

 
Exit On-
Screen Menu

Not applicable for IP-Reach or Dominion. 
Used by MPC/RRC with other Raritan 
products (on keyboard, press ESC) 

 

Send 
CTRL+ALT+
DEL 

Sends a CTRL+ALT+DEL key sequence to the 
target server. 

 
Single 
Cursor Mode

Enters Single Cursor Mode, in which the local 
PC's mouse pointer no longer appears on-
screen. Press CTRL+ALT+X to exit this mode. 

 
Full Screen 
Mode 

Maximizes the screen real estate to view the 
target server desktop. 
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Button Button 
Name 

Function 

 
Scaling 

Increases or reduces target video size so you 
can view the entire contents of the target 
server window without using the scroll bar. 

 
Show / Hide 
Navigator 

Toggles Navigator panel from visible to 
hidden. 

 
Refresh 
Navigator 

Forces a refresh of the data displayed by the 
RRC Navigator. 

 

Show / Hide 
“Browsed” 
Devices 

Toggles whether or not the RRC Navigator 
displays Raritan Devices automatically 
identified on the network (that do not have 
pre-configured profiles associated with 
them). 

 About Displays version information about MPC and 
RRC. 

 
 

Connected Server(s) Toolbar 

The Connected Server(s) Toolbar is comprised of a button for each 
connected target server (port) enabling quick access to connected targets. 
When you connect to a port, a button corresponding to that port is added 
to the toolbar, labeled with the name of the port. When you disconnect 
from a port, the corresponding button is removed from the toolbar. And 
when the Raritan device is disconnected, all of the buttons 
corresponding to the ports of that device are removed from the toolbar. 

The default for the Connected Server(s) Toolbar is that it is enabled 
(visible). 

 

 To display the Connected Server(s) Toolbar (when not 
already visible): 

Select View > Connected Server(s) Toolbar. 
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 To view the window for a target server: 

Click the button for the appropriate connected target server. The 
window for the corresponding port is brought forward, and the 
button for the selected port is highlighted. 

Note: When you click a button that is already highlighted, the corresponding 
window is minimized. If you click that button again, the window is brought 
forward and maximized. 

Notes for Full Screen Mode 

• Without getting out of full screen mode, click on the Connected 
Server(s) Toolbar button to open the video window for the 
appropriate target server. Please note that this action is window 
swapping (not video switching). 

• Buttons corresponding to windows that do not support full screen 
are not shown in the toolbar (for example, serial ports, generation 
one (G1) admin ports, and G1 diagnostic ports). 

• When you move your local cursor to the top while in full screen 
mode, the Connected Server(s) Toolbar appears. 

• The Connected Server(s) Toolbar does not appear in Single Mouse 
mode. 
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Status Bar 

The Status Bar displays session information about your connection to a 
Raritan IP-Reach or Dominion unit. 

• Video Sensing Status / Path Indicator: indicates the occurrence of 
video sensing, during connections to target KVM Server ports. 

• Bandwidth Usage Indicator: indicates how much of your total 
available bandwidth is currently being used. The Connection Speed 
setting, found under the Compression tab of the Connection 
Properties screen, determines total available bandwidth. 

• Security Indicator: indicates whether the current remote connection 
is protected by encryption. Encryption requirements are set during 
IP-Reach or Dominion configuration of your Raritan KVM over IP 
device. When a Raritan IP-Reach or Dominion device is configured 
for No encryption or SSL Authentication, NO data encryption, the 
Security Indicator is represented on the Status Bar as an open lock. 
When SSL authentication, data encryption or SSL authentication, SSL 
encryption is selected, the Security Indicator is represented on the 
Status Bar as a closed lock. 

• Concurrent Connections Indicator: indicates if multiple remote users 
are currently connected to the same IP-Reach or Dominion target 
server on the device, showing one icon for a single connected user, 
and two icons if two or more users are connected.   Concurrent 
connection ability can be set globally under PC share mode on the 
KX Manager Security Settings screen, or set per individual user in 
the Concurrent Access Mode setting on the KX Manager User 
Account Settings screen. For Dominion KX II, concurrent connection 
ability can be set using the PC Share Mode option in the Dominion 
KX II Security Settings page: PC-Share permits concurrent access; 
Private limits server access to one user at a time. 

• Lock Key Indicators: indicates the status of the current target KVM 
Server, with respect to the activation of the Caps-Lock, Num-Lock, 
and Scroll-Lock keys. If these keys are enabled on the target server 
being viewed, this affirmative status will be reflected on the Status 
Bar as indicated. 

Note: The Lock Key (Scroll Lock, Num Lock, Caps Lock) LEDs on your keyboard 
that indicate whether the Lock Key is active may or may not be in sync with the 
Lock Key Indicators on the RRC Status Bar. Please use the Status Bar as your 
guide. 
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Diagram Key 

 

 
Video Sensing Status/Path Indicator 

 
Bandwidth Usage Indicator 

 
Security Indicator 

 
Concurrent Connections Indicator 

 
Lock Key Indicators 

 
 

Remote KVM Console Control 

Once you establish a connection with a Raritan IP-Reach or Dominion 
KX device, that unit's icon in the Navigator expands to display all ports 
enabled for remote 
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Choose one of the following options to establish a remote KVM console 
connection: 

• Double-click on the KVM port you want to control - this method 
closes any previous connection before connecting to the new port 

• Right-click on the port and select Switch from the shortcut menu - 
this method closes any previous connection before connecting to the 
new port 

• Right-click on the port and select New Connection from the shortcut 
menu - this method allows you to connect to the selected port 
without closing any previous connections, creating a new connection 
if the device supports multiple concurrent connections 

Once connected, Raritan KVM over IP devices display real-time video 
output of the target server (this video is compressed and encrypted 
according to the configuration settings specified by the Administrator). 
You now have complete, low-level control of the KVM console as if you 
were physically located next to the server. 

• To close a connection, right-click on the connected device and click 
Disconnect. 

• To exit MPC or RRC completely, on the Connection menu, click Exit. 
 

Keyboard Shortcut Menu 

To access the MPC or RRC keyboard shortcut menu, use either the 
default keyboard combination of CTRL+LEFT ALT+M or the keyboard 
combination you assign (please see next section for directions on 
changing the default keyboard combination). Execute any of the 
commands on the shortcut menu either by pressing (on your keyboard) 
the underscored letter on the button face, or by clicking the button in the 
menu with your mouse cursor. 

Note: You must use the LEFT ALT key on your keyboard. 
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To: Press CTRL+LEFT 
ALT+M, and then 
press:  

Toggle to/from Full/Normal Screen Mode* F 

Perform video Auto Sensing** A 

Display connection information* I 

Display or Set connection properties* P 

Display or Set Video Settings* V 

Refresh screen R 

Color Calibrate** C 

Synchronize mouse Y 

Change to/from Single/Double cursor 
mode 

S 

Send CTRL+ALT+DEL to the target system D 

Send CTRL+ALT+M to the target system N 

Exit the Dialog/Menu without altering the 
keyboard state 

Esc 

* If Full Screen Mode is active, executing this command will 
automatically end Full Screen Mode. 

** If Full Screen Mode is active, executing this command will 
automatically end Full Screen Mode only in RRC. 
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Windows Key and Keyboard Shortcuts in MPC 

Windows Key and the Start Menu 

When running MPC on a Windows JRE 1.4.2_x platform, if you press the 
Windows Key   to display the Start Menu, the Start Menu will only 
appear on the Client machine, the key is not sent to the Target device. 

When running MPC on a Windows JRE 1.5.0_x platform, if you press the 
Windows Key, the Start Menu appears both on the Client and the Target 
devices. Use your mouse to manually close the Start Menu you do not 
want to use. 

Please note that if you do not close the Target device Start Menu 
properly, any key that you touch on your keyboard (that has a Windows 
Key combination function) will send that command to the Target device; 
for example, if you press E, the Target device will launch a new Explorer 
window; if you press D, all Target windows will be minimized so you 
can view the Desktop. To close the Start Menu on the Target device, click 
on the Start button or click away from the Start Menu. 
 

Changing the Keyboard Menu Shortcut Hotkey 
Combination 

• Tools - Options 

• New section: Keyboard Menu Shortcut Hotkey - drop down with 
CTRL+LEFT ALT + [A-Z] 

• The menu will change, the onscreen message will change; both take 
on the newly assigned combo. 

• If you forget the combo, press CTRL+LEFT ALT together and the 
Keyboard Menu Shortcut Hotkey appears across the bottom of the 
screen for five seconds. Press to toggle. 

• In Full screen mode, need the KMSH to get back to regular view. 
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Single Mouse Mode / Dual Mouse Mode 

When remotely viewing a target server that uses a pointing device, you 
will see two mouse pointers in the Remote Desktop. When your mouse 
pointer lies within the Remote Desktop area of MPC or RRC, mouse 
movements and clicks are directly transmitted to the target server 
connected. The MPC/RRC mouse pointer, generated by the operating 
system on which MPC/RRC is running, slightly leads the target server's 
mouse pointer during movement, a necessary result of digital delay. 

On fast LAN connections, you may want to disable the MPC/RRC mouse 
pointer and view only the target server's pointer. To toggle between 
these two modes, use the Keyboard Menu Shortcut Hotkey to activate 
the Hot Key menu, then press the letter S on your keyboard to select 
Single/Double Cursor (or press the Single Mouse Pointer mode icon in 
the Toolbar). 
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When in Dual Cursor mode, press CTRL+LEFT ALT+M and execute the 
Synchronize Mouse shortcut to force realignment of the mouse pointers. 
If the mouse pointers still remain out of sync, click on the Auto-Sense 
Video Settings button on the Toolbar. 

 Auto-Sense Video Settings button 

Note: When in Dual Cursor mode, if the dual mouse pointers are synchronized, 
but left idle for five minutes or longer, the target mouse pointer will 
automatically align itself with the upper left corner of the target window. 
Execute the Synchronize Mouse command to ensure local and target mouse 
pointer alignment. 

Single Mouse Cursor Mode for Apple Mac target servers is now 
supported for MPC.  Select :Single Mouse Cursor on the Mouse menu in 
MPC to enter this mode.  While in this mode, the cursor will remain in 
the video window for the Mac Server.  To exit, type the Keyboard Menu 
Shortcut Hotkey, then type “s”. 
 

Automatic Mouse Synchronization 

When in Dual Cursor mode, the system will automatically align the 
mouse pointers when the cursor is inactive for 15 seconds. Enable this 
feature by selecting Options from the Tools menu and clicking on the 
checkbox before Auto-Sync mouse in two-cursor mode. 
 

Mouse Synchronization Options 

In addition to synchronizing mouse pointers or toggling Single Cursor 
Mode, RRC's Mouse menus provide three options for syncing pointers 
when in Dual Cursor mode: 

• Absolute: When connected to selected Dominion KX units and 
targets with USB ports, MPC will use absolute coordinates to keep 
the pointers in sync. 

• Intelligent: Under certain conditions, MPC can detect the target 
mouse settings and synchronize the mouse pointers accordingly, 
allowing the user to have mouse acceleration on the target device. 
See Appendix B: Conditions for Intelligent Mouse Synchronization 
for more details. 

• Standard: This is the standard mouse synchronization algorithm. For 
the proper target mouse settings, see the User Guide of your Raritan 
KVM over IP device. 

Please note that only Intelligent and Standard mouse are available to 
MPC and RRC users working on Dominion KX units. 
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Screen Modes 

Full Screen / Target Screen Resolution 

Besides a standard view, MPC and RRC provide a Full Screen view and 
a Scaling option, which increase the Remote Desktop Area, making 
viewing the target video easier. In MPC, this option is called Target 
Screen Resolution mode and in RRC, it is called Full Screen mode. 

Use the Full Screen Mode shortcut on the Toolbar to activate Full Screen 
mode, or use the menu commands as described. 

 

Note: Full Screen Mode is not available in MPC only on a Dominion KX unit 
when the KX unit is under CommandCenter Secure Gateway (CC-SG) control. 

MPC - Target Screen Resolution Mode 

Target Screen Resolution mode removes the surrounding MPC graphical 
interface (except for scrollbars) and your local desktop area, completely 
filling your monitor with the target server video. Your monitor's 
resolution may be adjusted to match the resolution of the target server. 

To view which video resolutions your system supports, access your 
computer's Control Panel from the Windows Start menu, double-click on 
Display, and click on the Settings tab. 

Activate Target Screen Resolution mode, once connected to a target, 
from the View menu. On the View menu, click Target Screen Resolution. 
If you prefer to use the Hot Key menu, press CTRL+LEFT ALT+M and 
then the letter F on your keyboard to select Full/Normal Screen. 

If your graphic system does not support the resolution of the target 
system, you will be unable to activate Full Screen mode and a message 
will appear, requesting that you change your video resolutions first. 
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Note: The CTRL+LEFT ALT+M key combination does not work for certain 
target servers if you are running JRE 1.5.0_01. To return from full screen mode, 
use Alt+Tab and select MPC. 

RRC - Full Screen Mode 

Full Screen mode removes the surrounding RRC graphical interface and 
your local desktop area, filling your monitor with the video from the 
target server. Your monitor's resolution will be adjusted to match the 
resolution of the target server, if your graphics system supports it. 

To view which video resolutions your system supports, access your 
computer's Control Panel from the Windows Start menu, double-click on 
Display, and click on the Settings tab. 

 

Activate Full Screen mode, once connected to a target, from the View 
menu. On the View menu, click Full Screen. If you prefer to use the Hot 
Key menu, press CTRL+LEFT ALT+M and then the letter F on your 
keyboard to select Full/Normal Screen. 

If your graphic system does not support the resolution of the target 
system, you will be unable to activate Full Screen mode and a message 
will appear, requesting that you change your video resolutions first. 
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Scaling 

Scaling your target window size allows you to view the entire contents 
of the target server window. This feature increases or reduces the size of 
the target video to fit the MPC/RRC window size and maintains aspect 
ratio, so that you see the entire target server desktop while in the full 
standard MPC/RRC view. 

To activate Scale Video mode and increase the size of the target video 
window, on the View menu, click Scale, or use the Scaling shortcut on 
the Toolbar. To exit this mode and return the target window to its 
previous size, on the View menu, click Scale, or click the Scaling shortcut 
once again. 
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Auto-Scroll 

The auto-scroll feature automatically scrolls the video display in the 
direction of the cursor as the cursor approaches the edge of the display. 
A thin border appears around the perimeter of the Remote Desktop Area 
(this border can be activated using the Tools menu). If you see scroll 
bars, when you move the mouse cursor onto the border, the screen will 
automatically scroll in the appropriate direction. 

 

Note: Enabling Scale Video will scale the complete target video image to fit the 
Remote Desktop Area as it grows or shrinks. You can combine this setting with 
Target Screen Resolution for a full screen affect on targets with a higher 
resolution than your desktop. 
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Keyboard Handler 

RRC sends all keystroke combinations to the target system with the 
following exceptions: 

• CTRL+ALT+DEL - Reboots the computer; the sequence is sent to the 
local system and the Windows Security (Task Manager, Shutdown, 
etc.) dialog is displayed. 

• CTRL+Num Lock - This toggles the state of the Num Lock LED if the 
Num Lock state of the local system disagrees with that on the target 
system. 

• CTRL+Caps Lock - This toggles the state of the Caps Lock LED if 
Caps Lock state of the local system disagrees with that on the target 
system. 

• CTRL+Scroll Lock - This toggles the state of the Scroll Lock LED if 
Scroll Lock state of the local system disagrees with that on the target 
system. 

• CTRL+LEFT ALT+M - Brings up a dialog/menu providing normal 
RRC shortcuts (described below). 

• Keystrokes used to generate user-defined keyboard macros. 

• Print Scrn - Treated locally and copies the screen to the clipboard. 

There are no other exceptions. For example, ALT+F4 closes the current 
program on the target system. 
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Keyboard Macros 

IP-Reach or Dominion's Keyboard Macro feature ensures that keystroke 
combinations intended for the target server are sent to, and interpreted 
only by, the target server. Otherwise, they might be interpreted by the 
computer on which MPC or RRC is running. 

Raritan strongly suggests the use of macros for hot key combinations 
since certain hot key combinations have been found to not work 
properly depending on the platform and behavioral difference between 
the MPC application and web browser version. 

Note: This limitation applies only to MPC and not RRC. 

CTRL+ALT+Delete Macro 

Due to its frequent use, a CTRL+ALT+Delete macro, used to reboot the 
target computer, has been pre-programmed into MPC and RRC. 

 Send CTRL+ALT+DEL Sends a CTRL+ALT+DEL macro to the 
target server. 

Clicking on the CTRL+ALT+Delete shortcut in the Toolbar sends this key 
sequence to the server or KVM switch to which you are currently 
connected. In contrast, if you were to physically press the 
CTRL+ALT+Delete keys while using MPC or RRC, the command would 
first be intercepted by your own PC due to the structure of the Windows 
operating system, instead of sending the key sequence to the target 
server as intended. 

Building a Keyboard Macro 

These directions describe how to create a keyboard macro for the 
Windows command Minimize All Windows/Show Desktop. Follow 
these steps, substituting the appropriate key combination for the 
command you want, to create your own macro. 

For example: In Windows, pressing a keyboard macro is a shortcut that 
sends a command to your PC. When connected to a target server with 
MPC or RRC, a keyboard macro is one means to accomplish this task on 
the target server - because pressing the key combination results in your 
own client PC intercepting the command and performing it - instead of 
sending the command to the target server as intended. 

1. On the Keyboard menu, click Keyboard Macros. 
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2. When the Keyboard Macros window appears, click Add to add a 
new macro. The Add Keyboard Macro window appears. 

 

3. Build the Keyboard Macro by editing the fields in the Add Keyboard 
Macro window: 

a. Type a name in the Keyboard Macro Name field. This name will 
appear on the MPC or RRC Menu Bar after the macro is created. 
In this example, type Minimize All Windows. 

b. Optional: In the Hot-Key Combination field, select a keyboard 
combination from the drop-down list. This allows you to execute 
the macro with a predefined keystroke when MPC is running. In 
this example, select the CTRL+ALT+1 keystroke from the drop-
down list. 

c. In the Keys to Press drop-down list, scroll through and select 
each key for which you would like to emulate key presses - in 
the order by which they are to be pressed. Click Press Key after 
each selection. As each key is selected, it will appear in the Keys 
to Release field. In this example, select two keys: the Windows 
key and the letter D key. 
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d. In the Keys to Release field, select each key for which you would 
like to emulate key releases - in the order by which they are to be 
released. Click Release Key after each selection. In this example, 
both keys pressed must also be released. 

e. Review the Macro Sequence field - the contents are automatically 
generated depending on the Keys to Press and Keys to Release 
selections. Ensure that the contents list the exact key sequence 
you want. To remove a step in the sequence, select it, and click 
Remove. To change the order of steps in the sequence, select the 
step and click á and â to re-order the steps. 
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4. Click OK to save the macro, or Cancel to close the window without 
saving. Click Clear to clear all field and start over. When you click 
OK, the Keyboard Macros window appears, listing the new 
keyboard macro. 

 

5. Click Close to close the window. 
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Note: Foreign keyboard layouts are not supported when using Keyboard Macros, 
except for those keys listed in the “Add Keyboard Macro” dialog for Japanese 
and Korean. 

Running a Keyboard Macro 

Once you have created a keyboard macro, execute it from the Keyboard 
menu or by using the Hot Key (keyboard) combination if you assigned 
one while creating the macro. 

Menu Bar Activation 

When you create a macro, it appears under the Keyboard menu. Execute 
the keyboard macro by clicking on its name on the Keyboard menu. 

 

Hot Key Activation 

If you assigned a Hot Key combination to a macro when building it, you 
can execute the macro by pressing its assigned keystroke. In this 
example, press the keys CTRL+ALT+1 simultaneously to minimize all 
windows on a Windows target server. 
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Connection and Video Properties 

The IP-Reach and Dominion dynamic video compression algorithms 
maintain KVM console usability under varying bandwidth constraints. 
The IP-Reach and Dominion units optimize KVM output not only for 
LAN use, but also for WAN and dialup use. These units can also control 
color depth and limit video output, offering an optimal balance between 
video quality and system responsiveness for any bandwidth constraint. 

The following parameters in the Connection Properties and Video 
Settings windows can be optimized to suit your requirements for 
different operating environments. 

Connection Properties 

 
Connection 
Properties 

Manually adjust bandwidth-related options 
(connection speed, color depth, smoothing, etc.). 

 To set the connection properties: 

1. Select Connection > Properties. In MPC, the Properties Dialog opens. 
In RRC, the Modify Connection window opens. 
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2. Update the settings in the Compression tab. 
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 Connection Speed: Use this setting to manually adjust the 
connection speed to accommodate bandwidth constraints. IP-
Reach and Dominion can automatically detect available 
bandwidth and not limit bandwidth use; but you can also adjust 
this usage according to your needs. Depending on the Raritan 
device in use, different options may be available. 

Auto Detect 

1G Ethernet 

100mb Ethernet 

10mb Ethernet 

1.5mb (Max DSL/T1) 

1mb (Fast DSL/T1) 

512 kb (Medium DSL/T1) 

384 kb (Slow DSL/T1) 

256 kb (Cable) 

128 kb (Dual ISDN) 

56 kb (ISP Modem) 

33 kb (Fast Modem) 

24 kb (Slow Modem) 

 Color Depth: IP-Reach and Dominion can dynamically adapt the 
color depth transmitted to remote users in order to maximize 
usability in all bandwidths. Select from among the options in the 
drop-down list (depending on the Raritan device in use, 
different options may be available): 

15-bit RGB Color 

8-bit RGB Color 

4-bit Color 

4-bit Gray 

3-bit Gray 

2-bit Gray 

Black and White 

 Please refer to Connection Profiles (on page 19) for information 
about the Progressive Update, Internet Flow Control, Smoothing 
(15-bit mode only), and Frames per second (MPC only) options. 
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Important: For most administrative tasks (server monitoring, 
reconfiguring, etc.), administrators do not require the full 24-bit or 
32-bit color spectrum made available by most video graphics cards. 
Attempting to transmit such high color depths wastes network 
bandwidth. 

3. Click OK to change the Connection Properties or Cancel to close the 
window without saving changes. 
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Video Settings 

Video settings can be refreshed in several ways: 

• Using Video > Refresh Screen 

• Directing IP-Reach or Dominion to automatically detect the video 
settings (Video > Auto-sense Video Settings) 

• Using the Color Calibration (on page 80) command to calibrate the 
video, enhancing the colors displayed 

• Changing the settings from the Video Settings screen 

 Video Settings Opens Video Settings for manual 
adjustment of video parameters. 

 To change the video settings: 

1. Select Video > Video Settings. The Settings window opens: 
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2. Update the desired settings: 
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 Noise Filter: IP Reach and Dominion can filter out the electrical 
interference of video output from graphics cards. This feature 
optimizes picture quality and reduces bandwidth. Higher 
settings transmit variant pixels only if a large color variation 
exists in comparison to the neighboring pixels. However, setting 
the threshold too high can result in the unintentional filtering of 
desired screen changes. Lower settings transmit most pixel 
changes. Setting this threshold too low can result in higher 
bandwidth use. 

Note: Lower Noise Filter settings (approximately 1 to 4) are 
recommended. Although higher settings will stop the needless 
transmission of false color variations, true and intentional small 
changes to a video image may not be transmitted. 

• PLL Settings: If the video image looks extremely blurry or 
unfocused, the PLL Settings for clock and phase can be adjusted 
until a better image appears on the active target server. 

 Warning: Please exercise caution when changing the Clock 
and Phase settings; doing so may result in lost or distorted 
video and you may not be able to return to the previous 
state. Contact Raritan Technical Support before making any 
changes. 

 Clock: Controls how quickly video pixels are displayed 
across the video screen. Changes made to clock settings 
cause the video image to stretch or shrink horizontally; odd 
number settings are recommended. Under most 
circumstances this setting should not be changed because 
the auto-detect is usually quite accurate. 

 Phase: Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that produces the best video image 
for the active target server. 

• Color Settings: These settings control the brightness, contrast, and 
positioning of the target server display. 

 Brightness Red. Controls the brightness of the red signal; range is 
0 - 127. 

 Brightness Green. Controls the brightness of the green signal; 
range is 0 - 127. 

 Brightness Blue. Controls the brightness of the blue signal; range 
is 0 - 127. 

 Contrast Red: Controls the red signal contrast; range is 0 - 255. 
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 Contrast Green: Controls the green signal contrast; range is 0 - 
255. 

 Contrast Blue: Controls the blue signal contrast; range is 0 - 255. 

 Horizontal Offset: Controls the horizontal positioning of the 
target server display on your monitor; range is 0 - 512. 

 Vertical Offset: Controls the vertical positioning of the target 
server display on your monitor; range is 0 - 128. 

1. To preview the change prior to making the selection, check the 
Preview checkbox. 

2. Check the Automatic Color Calibration checkbox to enable this 
feature. 

3. Video Sensing: Select the video sensing mode: 

 Best possible video mode: IP-Reach or Dominion will perform 
the full Auto Sense process when switching targets or target 
resolutions. Selecting this option calibrates the video for the best 
image quality. 

 Quick sense video mode: Selecting this option will cause IP-
Reach or Dominion to use a quick video Auto Sense in order to 
show the target's video sooner. This option is especially useful 
for entering a target server's BIOS configuration right after a 
reboot. 

4. After you change a value, click Apply. 

5. Click OK to change the Video Settings or Cancel to close the window 
without saving changes. 

Note: Some Sun background screens, such as screens with very dark borders, 
may not center precisely on certain Sun servers. Use a different background or 
place a lighter colored icon in the upper left corner of the screen. 

Video Settings (Generation 1 Only) 

 

 
Video Settings Opens the Video Settings dialog box to manually 

adjust video conversion parameters. 

1. On the Video menu, click Video Settings. The Settings window 
appears. 
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These settings can be refreshed using the Color Calibration command, 
described in the next section, by manually forcing IP-Reach or Dominion 
to auto-detect the video settings (on the Video menu, click Auto-sense 
Video Settings), or by changing the settings in this screen. After you 
change a value, click Apply to test the setting. 

• Noise Filter: IP-Reach or Dominion can filter out electrical 
interference of video output from graphics cards. This feature 
optimizes picture quality and reduced used bandwidth. 

Note: The default Noise Filter is 4; Raritan recommends that you lower this 
value to 0 (zero). 
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 Higher: Noise Filter settings instruct IP-Reach or Dominion to 
transmit a variant pixel of video only if a large color variation 
exists in comparison to its neighbors. However, setting the 
threshold too high can result in the unintentional filtering of 
desired screen changes. 

 Lower: Noise Filter settings instruct IP-Reach or Dominion to 
transmit most pixel changes. Setting this threshold too low can 
result in higher bandwidth use. 

Note: Lower Noise Filter settings (approximately 1 to 4) are recommended. 
Although higher settings will stop the needless transmission of false color 
variations, true and intentional small changes to a video image may not be 
transmitted. 

• Analog-to-Digital Settings: The following parameters are best left to 
IP-Reach or Dominion to automatically detect (on the RRC Menu 
Bar, select Video > Auto-sense Video Settings), but a brief description 
of each is included here. 

• PLL Settings: If the video image looks extremely blurry or 
unfocused, the PLL Settings for clock and phase can be adjusted 
until a better image appears on the active target server. 

 Clock: Horizontal sync divider to produce pixel clock. Controls 
how quickly video pixels are displayed across the video screen. 
Changes made to clock settings cause the video image to stretch 
or shrink horizontally. Odd number settings are recommended. 

 Phase: Phase values range from 0 to 31 and will wrap around. 
Stop at the phase value that results in the best video image for 
the active target server. 

• Color Settings: Gain control can be thought of as contrast 
adjustment. Offset control can be thought of as brightness 
adjustment. 

 Red Gain: Controls the amplification of the red signal. 

 Red Offset: Controls the bias of the red signal. 

 Green Gain: Controls the amplification of the green signal. 

 Green Offset: Controls the bias of the green signal. 

 Blue Gain: Controls the amplification of the blue signal. 

 Blue Offset: Controls the bias of the blue signal. 

 Link Color Controls: Makes all the gain slide adjusters move in 
unison when any one color's gain slide is moved and all the 
offset slide adjusters move in unison when any one color's offset 
slide is moved. 
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• Best possible video mode: IP-Reach or Dominion will perform the 
full Auto Sense process when switching targets or target resolutions. 
Selecting this radio button will cause IP-Reach or Dominion to 
calibrate the video for the best image quality.  

• Quick sense video mode: Selecting this radio button will cause IP-
Reach or Dominion to use a quick video Auto Sense in order to show 
the target's video sooner. This option is especially useful for entering 
a target server's BIOS configuration right after a reboot. 

1. Click OK to set Video Settings or Cancel to close the window 
without saving changes. 

Note: Some SUN background screens, such as screens with very dark borders, 
may not center precisely on certain SUN servers. Use a different background or 
place a lighter colored icon in the upper left corner of the screen. 

Video Settings (KX101) 

 

Raritan's Dominion KX101 Color Settings window varies from those of 
other Dominion KX units. 

1. In the Color Settings panel, adjust the following options: 

 Brightness: Controls the backlight on your screen. 

 Red Contrast: Controls the level of red tone on your screen. 

 Green Contrast: Controls the level green tone on your screen. 
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 Blue Contrast: Controls the level of blue tone on your screen. 

 Click on the Link Color Controls check box to make all above 
slide adjusters move in unison when any one option is moved. 

2. Click OK when finished. 
 

Color Calibration 

 

 

Color 
Calibration 

Adjusts color settings to reduce excess color 
noise. 

Use the Color Calibration command if the color levels (hue, brightness, 
saturation) of transmitted video images do not seem accurate. IP-Reach 
or Dominion color settings remain the same when switching from one 
target KVM Server to another, so you can perform Color Calibration 
once to affect all connected target servers. 

1. Open a remote KVM connection to any server running a graphical 
user interface. 

2. Ensure that a solid white color covers approximately 15% or more of 
the target server's desktop (suggestion: open Microsoft Notepad and 
maximize the window). 

 

3. On the Video menu, click Calibrate Color. The target device screen 
will update its calibration. 
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Tip: You can also specify automatic color calibration using Tools > Options. 
Refer to General Options (see "Tools Options" on page 110) for more 
information. 
 

Keyboard Type (MPC Only) 

MPC will not auto-detect the type of keyboard you use, so you must 
specify your keyboard type to ensure accurate keyboard mapping. 
Options include US/International, French, German, Japanese and UK 
English. 

1. On the Video menu, click Options. 

2. Click on the Keyboard Type drop-down arrow and select your 
keyboard type from the list. 

3. Click OK. 
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Note: Because of a limitation in the Java Runtime Environment (JRE), Fedora, 
Linux, and Solaris clients receive an invalid response from Alt Gr on United 
Kingdom and US International language keyboards. Fedora, Linux, and Solaris 
do not pick up events for the Alt Gr key combination for Java 1.4.2 or 1.5. Java 
1.6 appears to improve on this, although the keyPressed and keyReleased events 
for Alt Gr still identify it as an “unknown key code”.  
 
Also, a key pressed in combination with Alt Gr (such as on the UK keyboard Alt 
Gr-4), which is the Euro symbol), will only generate a keyTyped followed by a 
keyReleased event for that value, without a keyPressed event. Java 1.6 improves 
upon this by filling in the keyPressed event as well. 
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Overview 

Important: Virtual Media is available for Dominion KX II only. 

Chapter 3 Virtual Media
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Virtual media extends KVM capabilities by enabling target servers to 
remotely access media from the client PC and network file servers. With 
this feature, media mounted on the client PC and network file servers is 
essentially mounted virtually by the target server. The target server can 
then read from and write to that media as if it were physically connected 
to the target server itself. Virtual media can include internal and USB-
mounted CD and DVD drives, USB mass storage devices, PC hard 
drives, and ISO images (disk images). 

Virtual media provides the ability to perform additional tasks remotely, 
such as: 

• transferring files 

• running diagnostics 

• installing or patching applications 

• complete installation of the operating system 

This expanded KVM control eliminates most trips to the data center, 
saving time and money, thereby making virtual media very powerful. 
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Prerequisites for Using Virtual Media 

The following conditions must be met in order to use virtual media: 

Device Permissions 

• For user (s) requiring access to the virtual media, port permissions 
must be set to allow virtual media access. 

Client PC 

• Certain virtual media options require administrative privileges on 
the client PC (e.g., drive redirection of complete drives). 

Note: If you are using Microsoft Vista, turn User Account Control off: Control 
Panel > User Accounts > User Account Control > turn off. 

If you would prefer not to change Vista account permissions, run Internet 
Explorer as an administrator. To do this, click on the Start Menu, locate IE, 
right click it and select Run as Administrator. 

• USB 2.0 ports are both faster and preferred. 

Target Server 

• Target servers must support USB connected drives. 

• Target servers running Windows 2000 must have all of the recent 
patches installed. 
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Using Virtual Media 

With the Dominion KX II virtual media feature, you can mount up to 
two drives (of different types). These drives are accessible for the 
duration of the KVM session. 

For example, you can mount a specific CD-ROM, use it, and then 
disconnect it when you are done. The CD-ROM virtual media “channel” 
will remain open, however, so that you can virtually mount another CD-
ROM. These virtual media “channels” remain open until the KVM 
session is closed. 

Note: Target servers running Windows will not accept any new medium after 
making a virtual media connection to an NTFS partition, until the device is 
disconnected. 

 To use virtual media: 

1. Connect/attach the media to the client or network file server that you 
want to access from the target server. This need not be the first step, 
but it must be done prior to attempting to access this media. 

2. Verify that the appropriate prerequisites  (see "Prerequisites for 
Using Virtual Media" on page 87)are met. 

3. (File server ISO images only) If you plan to access file server ISO 
images, identify those file servers and images through the Dominion 
KX II Remote Console File Server Setup page (see "File Server Setup 
(File Server ISO Images Only)" on page 92). 

4. Open a KVM session with the appropriate target server. 

5. Connect to the virtual media. 

For: Select this VM option: 
Local drives Connect Drive (see "For Local 

Drives" on page 89) 

Local CD/DVD Drives Connect CD-ROM/ISO Image (see 
"For CD-ROM/DVD-ROM/ISO 
Images" on page 90) 

ISO Images Connect CD-ROM/ISO Image 

File Server ISO Images Connect CD-ROM/ISO Image 

6. Upon completion of your tasks, disconnect the virtual media (see 
"Disconnecting Virtual Media" on page 92). 
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Connecting to Virtual Media 

For Local Drives 

This option mounts an entire drive; the entire drive is mounted virtually 
onto the target server. Use this option for hard drives and external drives 
only; it does not include network drives, CD-ROM, or DVD-ROM drives. 
This is the only option for which Read-Write is available. 

Note: Target servers running certain version of the Windows operating system 
may not accept new mass storage connections after an NTFS-formatted 
partition (e.g., the local C drive) has been redirected to them. If this occurs, close 
the KX II Remote Console and reconnect before redirecting another virtual 
media device. If other users are connected to the same target server, they must 
also close their connections to the target server. 

 To access a drive on the client computer: 

1. From MPC, select Virtual Media > Connect Drive. The Map Virtual 
Media Drive dialog opens: 

 

2. Select the drive from the Local Drive drop-down list. 

3. If you want read and write capabilities, check the Read-Write option 
checkbox. This option is disabled for non-removable drives. Please 
refer to the conditions when read-write is not available for more 
information. When checked, you will be able to read or write the 
connected USB disk. 

WARNING: Enabling Read-Write access can be dangerous! 
Simultaneous access to the same drive from more than one entity can 
result in data corruption. If you do not require write access, leave 
this option unchecked. 
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4. Click Connect. The media will be mounted on the target server 
virtually. You can access the media just like any other drive 

Conditions when Read-Write is not Available 

Virtual media read-write is not available in the following situations: 

• For all hard drives. 

• When the drive is write-protected. 

• When user does not have read-write port permission. 
 

For CD-ROM/DVD-ROM/ISO Images 

This option mounts CD-ROM, DVD-ROM, and ISO images. 

 To access a CD-ROM, DVD-ROM, or ISO image: 

1. From MPC, select Virtual Media > Connect CD-ROM/ISO Image. The 
Map Virtual Media CD/ISO Image dialog opens: 

 

2. For internal and external CD-ROM or DVD-ROM drives: 

a. Select the Local CD/DVD Drive option. 
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b. Select the drive from the Local CD/DVD Drive drop-down list. 
All available internal and external CD and DVD drive names 
will be populated in the drop-down list. 

c. Click Connect. 

3. For ISO images: 

a. Select the ISO Image option. Use this option when you want to 
access a disk image of a CD, DVD, or hard drive. ISO format is 
the only format supported. 

b. Click the Browse button. 

c. Navigate to the path containing the disk image you want to use 
and click Open. The path is populated in the Image Path field. 

d. Click Connect. 

4. For remote ISO images on a file server: 

a. Select the Remote Server ISO Images option. 

b. Select Hostname and Image from the drop-down lists. The file 
servers and image paths available are those that you configured 
using the Dominion KX II Remote Console File Server Setup (see 
"File Server Setup (File Server ISO Images Only)" on page 92) 
page. Only items you configured using the Dominion KX II File 
Server Setup page will be in the drop-down list. 

c. File Server Username. Username required for access to the file 
server. 

d. File Server Password. Password required for access to the file 
server (field is masked as you type). 

e. Click Connect. 

The media will be mounted on the target server virtually. You can access 
the media just like any other drive. 
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Disconnecting Virtual Media 

 To disconnect the Virtual Media drives: 

• For local drives, select Virtual Media > Disconnect Drive 

• For CD-ROM, DVD-ROM, and ISO images, select Virtual Media > 
Disconnect CD-ROM/ISO Image 

Note: In addition to disconnecting the Virtual Media using the Disconnect 
option, simply closing the KVM connection disconnects the Virtual Media as 
well. 
 

File Server Setup (File Server ISO Images Only) 

Important: These steps are completed using the Dominion KX II 
Remote Console. 
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Note: This feature is only required when using virtual media to access file server 
ISO images. 

Use the Dominion KX II Remote Console File Server Setup page to 
designate the files server(s) and image paths that you want to access 
using Dominion KX II Virtual Media. File server ISO image(s) specified 
here will become available for selection in the Remote Server ISO Image 
Hostname and Image drop-down lists (in the Map Virtual Media 
CD/ISO Image dialog (see "For CD-ROM/DVD-ROM/ISO Images" on 
page 90)). 

 To designate file server ISO images for virtual media 
access: 

1. Select Virtual Media from the Dominion KX II Remote Console. The 
File Server Setup page opens: 

 

2. Input information about the file server ISO images that you want to 
access: 

 Host Name/IP Address. Host name or IP Address of the file 
server. 

 Image Path. Full path name of the location of the ISO image. 
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3. Check the Selected checkbox for all media that you want accessible 
as virtual media. 

4. Click Save. All media specified here will now be available for 
selection in the Map Virtual Media CD/ISO Image dialog. 

 To cancel without saving: 

Click Cancel. 
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Note: MPC users must belong to the administrator group in order to receive 
administrative permissions. MPC uses one permission: administrator or normal 
user. It is only when the user belongs to the ADMIN group that they have 
access to the backup/restore/restart type functions (regardless of any device user 
group settings). 

Although your IP-Reach or Dominion unit provides a remote interface to 
administrative functions through IP-Reach or Dominion Manager, MPC 
and RRC provide an interface to frequently-used administrative 
functions directly from its own interface. When logged into an IP-Reach 
or Dominion unit as an Administrator, you can perform the following 
administrative tasks. 

Note: Most of the commands below are available both in the Tools drop-down 
menu and in the shortcut menu that appears when you right-click on the device 
in the Navigator panel 

In This Chapter 
Upgrading Device Firmware ..................................................................... 96 
Changing a Password................................................................................. 96 
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Upgrading Device Firmware 

To update a device's firmware, first connect to the device. Highlight the 
device's icon in the MPC Navigator, and click on the Tools menu, click 
Update and then click Update Device to perform firmware upgrades. 

MPC / RRC will prompt you to locate a Raritan firmware distribution file 
(*.RFP format), found on the Raritan Website Firmware Upgrades page 
when available:  http://www.raritan.com/support/firmwareupgrades. 
Please ensure that you read all instructions included in firmware ZIP 
files carefully before upgrading a device. 

Note: Copy the firmware update file on the Raritan Website to a local PC before 
uploading. Do not load the file from a network drive. 
 

Changing a Password 

To update your password, first connect to an IP-Reach or Dominion 
target. Highlight the target's icon in the Navigator, and on the Tools 
menu, click Update and then click User Password. The Change Password 
window appears. 

 
Change Password Window 

1. Type your current password in the Old Password. 

2. Type the new password in the New Password field.  

3. Retype the password in the Confirm New Password field. 

4. When finished, click OK. 
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Restarting Device 

Select the device in the MPC Navigator. On the Tools menu, click Restart 
Device. 
 

Backing Up Device Configuration 

To download the IP-Reach or Dominion KX device configuration to your 
local computer, first select the device in the MPCRRC Navigator. On the 
Tools menu, click Save Device Configuration. 
 

Restoring Device Configuration 

To upload the archived IP-Reach or Dominion KX device configuration, 
first select the device in the MPCRRC Navigator. On the Tools menu, 
click Restore Device Configuration. 

Please note that device configuration is specific to a particular device and 
should not be restored to another device. 
 

Backing Up User Configuration 

To back up a unit's user configuration, first select the device in the 
MPCRRC Navigator. On the Tools menu, click Save User Configuration. 
 

Restoring User Configuration 

To upload a device's archived user configuration, first select the device 
in the MPCRRC Navigator. On the Tools menu, click Restore User 
Configuration 

Note: Use these commands to easily transfer user and group information from 
one IP-Reach or Dominion KX unit to another. 
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Backup and Restore (Dominion KX II only) 

In addition to using backup and restore for business continuity 
purposes, you can use this feature as a time-saving mechanism. For 
instance, you can quickly provide access to your team from another 
Dominion KX II, by backing up the user configuration settings from the 
KX II device in use and restoring those configurations to the new 
Dominion KX II. 

Note: Backups are always complete system backups. Restores can be complete or 
partial depending on your selection. 
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 To backup the entire system (both user and device 
configuration): 

1. Select Tools > Backup All. The Backup All dialog opens: 

 

2. Navigate to the desired directory and give the backup file a name. 
(Backup files have an extension of .rfp). 

3. Click Save. A message is displayed confirming the successful 
backup. 

4. Click OK. 
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 To restore: 

1. Select Tools > Restore Configuration. The Restore Device 
Configuration dialog opens. 

 

2. Navigate to the appropriate directory and select the backup file. 

3. Click Open. The Restore Packages dialog opens: 

 

4. Select the type of restore you want to run: 
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• Full Restore. A complete restore of the entire system; generally used 
for traditional backup and restore purposes. 

• Protected Restore. Everything is restored except device-specific 
information such as serial number, MAC Address, IP Address, 
name, port names, etc. With this option, you can setup one 
Dominion KX II and copy the configuration to multiple KX II 
devices. 

• Custom Restore. With this option, the following options are 
available. Check the appropriate checkboxes: 

 User and Group Restore. This option includes only user and 
group information. Use this option to quickly setup users on a 
different Dominion KX II. 

 Device Settings Restore. This option includes only device 
settings. Use this option to quickly copy the device information. 

1. Click OK. 
 

Log Files 

Activity Log 

To download a detailed activity log for review or troubleshooting, first 
select the device in the Navigator. On the Tools menu, click Save Activity 
Log. 
 

Diagnostic Log (excluding Dominion KX II) 

To download a detailed diagnostic log for reporting or analysis, first 
select the device in the Navigator. On the Tools menu, click Save 
Diagnostic Log. 
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Broadcast Port 

By default, all Raritan devices send data through Port 5000. This network 
traffic includes MPC's and RRC's auto-discovery broadcast. In the case of 
conflicts, or to deal with firewall issues, you may want to use a different 
broadcast port. 

To change the auto-discovery port from the default broadcast port of 
5000, select the device in the RRC Navigator. On the Tools menu, click 
Options. The Options window appears. 

 

In the Broadcast Port panel at the bottom of the window, type the new 
port number in the Port field, and then click OK. 

Note: If you want MPC / RRC to auto-discover Raritan devices on the new 
broadcast port you entered in the Options window, you must configure all 
Raritan devices to use the new port number. 
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Remote Power Management 

MPC and RRC can manage AC Power to associated targets when used 
with a properly configured Raritan Remote Power Control Strip (RPC 
Strip). RRC provides three options for the remote power management of 
targets:  Power On, Power Off, and Cycle Power. 

To change the power status of a target, first select the device in the RRC 
Navigator. On the Tools menu, click Power On, Power Off, or Cycle 
Power. 
 

Import/Export Keyboard Macro Definitions 

The functions contained in this section describe how to exchange 
keyboard macro definitions between users using import and export 
functions. The primary purpose of this function is to exchange data 
between copies of RRC.  

 To export macros: 

1. Click Tools > Export Macros to open the Raritan Remote Client 
Export Macros dialog. 

 

2. Select the macros to be exported by checking their corresponding 
checkbox or using the Select All or Unselect All options.  

3. Click OK. The selected macro file(s) will be moved to your desktop 
(by default). 

A select dialog will then open from which you can locate and select 
the macro file. By default, the macro will exist on your desktop.  
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4. Locate the macro file, click on it to select it and then click Save. If 
Cancel is selected, you will be returned to the Raritan Remote Client 
Export Macros dialog. If the macro already exists, you will receive an 
alert message. Select Yes to overwrite the existing macro or No to 
close the alert without overwriting the macro. 
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 To import macros: 

1. Click Tools > Import Macros to open the Raritan Remote Client 
Import Macros dialog. By default, the macro will exist on the 
desktop. 

 

2. Click on the macro file and click Open to import the macro. Click 
Cancel to close the dialog without importing the macro file. The 
Raritan Remote Client Import Macros dialog will open. 

a. If too many macros are found in the file, an error message will be 
displayed and the import will terminate once OK is selected. 
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b. If the import fails, an error dialog will open and will display a 
message regarding why the import failed. Select OK to continue 
the import without importing the macros that cannot be 
imported or select Cancel to close the dialog and stop the import 
process. 

 

3. Select the macros to be imported by checking their corresponding 
checkbox or using the Select All or Unselect All options. 

4. Click OK and the import will begin. 

 

a. If a duplicate macro is found, the Raritan Remote Client Import 
Macros dialog will appear. Do one of the following: 
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 Click Yes to replace the existing macro with the imported 
version. 

 Click Yes to All to replace the currently selected and any 
other duplicate macros that are found. 

 Click No to keep the original macro and proceed to the next 
macro 

 Click No to All keep the original macro and proceed to the 
next macro. Any other duplicates that are found will be 
skipped as well. 

 Click Cancel to stop the import.  

 

 Alternatively, click Rename to rename the macro and import 
it. If Rename is selected, Raritan Remote Client Rename 
Macro dialog will open. Enter a new name for the macro in 
the field and click OK. The dialog will close and the process 
will proceed. If the name that is entered is a duplicate of a 
macro, an alert will appear and you will be required to enter 
another name for the macro. 
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b. If during the import process the number of allowed, imported 
macros is exceeded, the following dialog will open.  Click OK 
TO attempt to continue importing macros or click Cancel to stop 
the import process. 

 

The macros will then be imported. 

If a macro is imported that contains a hot key that already exists, the 
hot key for the imported macro will be discarded.  

 

Launching Administrator and Diagnostic Interfaces 

Administrator Interface 

For further control of a selected device, scroll down the Navigator list of 
all the targets associated to a specific device (you may have to expand 
your view of the device by clicking on the + sign before its name) and 
double-click on the Admin icon at the bottom of the target list. 

The Administrator login screen for the selected device appears. Please 
refer to the specific Raritan device User Guide for additional information 
and managing the device using the Raritan User Manuals & Quick Setup 
Guides CD included with the device shipment, or by downloading the 
user documentation from Raritan's Product Documentation page: 
http://www.raritan.com/support/productdocumentation. 
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Diagnostic Interface (excluding Dominion KX II) 

To access the device's diagnostic console by double clicking on the 
Diagnostic icon at the bottom of the target list. Scroll down the Navigator 
list of all the targets associated to a specific device (you may have to 
expand your view of the device by clicking on the + sign before its name) 
and double-click on the Diagnostic icon at the bottom of the target list. 
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Tools Options 

The Options available in the Tools menu provide settings for 
customization of scroll borders, mouse mode settings, hotkey 
configuration, keyboard type, broadcast port, and logging. 

 To configure the general options: 

1. Select Tools > Options. The Options screen opens to the General tab: 

2. Check the Show scroll borders check box to view the thin scroll 
borders designating the auto-scroll area. 

3. Check the Auto-Sync mouse in two-cursor mode check box to enable 
automatic mouse synchronization. 
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4. Check the Display single cursor mode instructions check box if you 
wish to see the following instructions when entering single cursor 
mode: 

 

5.  Check the Automatic Color Calibration check box to enable 
automatic color calibration. This option is available for KX 
generation 1 (G1) only. 

6. Select the Keyboard Type from the drop-down list (depending on 
the Raritan device in use, different options may be available): 

 US/International 

 French (France) 

 German (Germany) 

 Japanese 

 United Kingdom 

 Korean (Korea) 

7. Keyboard Shortcut Menu Hotkey. Select the key combination you 
would like to use to invoke the Keyboard Shortcut Menu (on page 
51). Select from among the options in the drop-down list: Ctrl + Alt + 
(any uppercase letter). 
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8. For advanced options, open the Advanced tab: 

9. KVM Switch OSUI Hot Key. Select the hotkey to use when switching 
between target server displays. 

10. For the Broadcast Port, type the broadcast port number in the Port 
field if you want to use a port other then 5000. 

11. Check the Enable Logging checkbox only if directed to by Technical 
Support. This option creates a log file in your home directory. 

12. Click OK when finished or click Cancel to exit this window without 
saving changes. Click Apply any time during your selection to apply 
an option you have chosen. 
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General Options (RRC Only) 

1. On the Tools menu, click Options to view the Options screen. You 
can customize your keyboard and video options to optimize use. 

 

2. Click on the check box before Show scroll borders to view the thin 
scroll borders that show the Auto-Scroll area. 

3. Click on the check box before Auto-Sync mouse in two cursor mode 
to enable Automatic Mouse Synchronization. 
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4. Click on the check box before Display single cursor mode 
instructions if you wish to see the following instructions when 
entering Single Cursor Mode. 

 

5. In the KVM Switch OSUI Hot Key panel, click on the radio button 
before your choice of hot key combinations. 

6. In the Keyboard Type panel, click on the drop-down arrow and click 
on your keyboard choice. 

7. In the Broadcast Port Panel, type the broadcast port number in the 
Port field. 

8. Click OK when finished or click Cancel to exit this window without 
saving changes. Click Apply any time during your selection to apply 
an option you have chosen. 
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This section guides you through installation and initial launch of the 
standalone MPC application for various operating systems. 

Raritan recommends that you launch only one standalone MPC session 
at a time. Launching more than one standalone MPC session on the same 
client at the same time may cause performance problems and system 
errors. 

Note: Please note that the file names of the installers, as well as the install 
directories or folder paths may differ slightly from what is outlined in this 
manual. 

 

Important: MPC modem connectivity is supported on Windows, 
Linux, and Sun Solaris, but not Macintosh. When working in 
Windows, use Standalone MPC. 

You must have the MPC JAR file to install MPC for any of these 
operating systems. 

1. Download the installation file, MPC-installer.jar from the Raritan 
Website on the Support - Firmware Upgrades page 
(http://www.raritan.com/support/firmwareupgrades). Click on 
Dominion Family and scroll to the Standalone Multi-Platform Client 
link. 

2. If copying MPC-installer.jar from a known location, double-click on 
the file to start installation. 
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Windows 

Checking JRE Version in Windows 

1. Click on the Windows Start button at the bottom left of your screen 
and click Control Panel. In the upper left corner of the screen, you 
may see a panel named Control Panel with the option Switch to 
Classic View or Switch to Category View.  For easier viewing, opt for 
Classic View. 

2. Search the Control Panel files for a Java icon. When you locate Java, 
double-click on it to launch the Java Control Panel. Click on the 
General tab, and then click on the About button to check the current 
Java Runtime Environment (JRE). 

3. If the JRE is version 1.4.2_05 or greater, proceed with the MPC 
Installation. If the Java icon does not exist in the Control Panel, or if 
the JRE is older, please go to the Sun Microsystems Website at 
http://java.sun.com/products/ to download the latest JRE. 

a. For future Java access and automatic launch, set your path to the 
Java executable: on your desktop, right-click on the My 
Computer icon and click Properties. 

b. Click on the Advanced tab and then click Environment variables. 

c. Edit the Path address so that it contains the path to the Java 
executable.   
For example: if Java is installed in C:\j2re1.4.2_05 and your path 
is currently set to C:\WINDOWS\SYSTEM32, then change the 
path to read  C:\WINDOWS\SYSTEM32;C:\j2re1.4.2_05 

 
 

Installing MPC for Windows 

1. Log on to your Windows machine. 

2. Download, or copy from a known location, the MPC-installer.jar 
installation file. 
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3. After the initial screen loads, click Next. 

 

4. Select the directory where you want to install MPC and click Next. 
Click Browse to navigate to a non-default directory. 
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5. After the progress bars have moved across the screen, click Next. 

 

6. On the Shortcut screen, choose a shortcut location, determine who 
should have the shortcut, and whether you want the shortcut on the 
desktop. When finished, click Next. 
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7. The installation is complete; the final screen indicates where you will 
find an uninstaller program, and allows the option of generating an 
automatic installation script. Click Done to close the Installation 
window. 

 
 

Launching MPC in Windows 

1. Click on the Windows Start menu, click All Programs, and then click 
Raritan Multi-Platform Client, or double-click the desktop shortcut if 
you created one. 
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2. Double-click on the desired device to establish a connection, type 
your Username and Password and click OK to log on. Please refer to 
Chapter 2: Operation for additional operation instructions. 

 
 

Linux 

Checking JRE Version in Linux 

1. In a graphical environment, launch a terminal window. 

2. Type java -version in the command line and press ENTER. The 
currently-installed version of Java Runtime Environment (JRE) 
appears. 

a. If your path variable is not set to where the java binaries have 
been installed, you may not be able to see the JRE version. 

b. To set your path: Assuming JRE 1.4.2_05 is installed in 
/usr/local/java: you must set your PATH variable. 

c. To set path for bash shell: export 
PATH=$PATH:/usr/local/java/j2re1.4.2_05/bin. 

d. To set path for tcsh or csh: set PATH = ($PATH 
/usr/local/java/j2re1.4.2_05/bin). 
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e. These commands can either be typed at the terminal each time 
you login, or you can add it to your .bashrc for bash shell or 
.cshrc for csh or tcsh so that each time you login, the PATH is 
already set. Please refer to your shell documentation if you 
encounter problems.  

3. If the JRE is version 1.4.2_05 or greater, proceed with the MPC 
installation. If the version is older, please go to the Java website at 
http://java.sun.com/products/ to download the latest Runtime 
Environment. 

 

Installing MPC for Linux 

You must have Administrative privileges to install MPC. 

1. Log on to your Linux machine. 

2. Download, or copy from a known location, the MPC-installer.jar 
installation file. 
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3. Open a terminal window and change to the directory where the 
installer is saved. 

4. Type java -jar MPC-installer.jar and press ENTER to run the installer. 

5. After the initial screen loads, click Next. 

 

6. Select the directory where you want to install MPC and click Next. 
Click Browse to navigate to a non-default directory. 

7. When installation is complete, click Next. 



 Chapter 5: Installing and Launching Standalone MPC 
 

 
123

8. On the Shortcut screen, choose a shortcut location, determine who 
should have the shortcut, and whether you want the shortcut on the 
desktop. When finished, click Next. 
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9. The installation is complete; the final screen indicates where you will 
find an uninstaller program, and allows the option of generating an 
automatic installation script. Click Done to close the Installation 
window. 

 
 

Launching MPC in Linux 

1. Open a terminal window and change directories to the directory 
where you installed MPC (default location: /usr/local/Raritan/Raritan 
MPC/4.40.1.7/). 
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2. Type ./start.sh and press ENTER to launch MPC. 

 

3. Double-click on the desired device to establish a connection, type 
your Username and Password and click OK to log on. Please refer to 
Chapter 2: Using MPC for additional operation instructions. 

 

Solaris 

Checking JRE Version on Sun Solaris 

1. Launch a terminal window on the Sun Solaris desktop. 

2. Type java -version in the command line and press ENTER. The 
currently-installed version of Java Runtime Environment (JRE) 
appears. 

a. If your path variable is not set to where the java binaries have 
been installed, you may not be able to see the JRE version. 

b. To set your path: Assuming JRE 1.4.2_05 is installed in 
/usr/local/java: you must set your PATH variable. 

c. To set path for bash shell: export 
PATH=$PATH:/usr/local/java/j2re1.4.2_05/bin. 

d. To set path for tcsh or csh: set PATH = ($PATH 
/usr/local/java/j2re1.4.2_05/bin). 
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e. These commands can either be typed at the terminal each time 
you login, or you can add it to your .bashrc for bash shell or 
.cshrc for csh or tcsh so that each time you login, the PATH is 
already set. Please refer to your shell documentation if you 
encounter problems. 

 

3. If the JRE is version 1.4.2_05 or greater, proceed with the MPC 
installation. If the version is older, please go to the Sun website at: 
http://java.sun.com/products/ to download the latest Runtime 
Environment. 

 

Installing MPC for Sun Solaris 

You must have administrative privileges to install MPC. 

1. Log on to your Sun Solaris machine. 

2. Download, or copy from a known location, the MPC-installer.jar 
installation file. 

3. Open a terminal window and change to the directory where the 
installer is saved. 

4. Type java -jar MPC-installer.jar and press ENTER to run the installer. 

5. After the initial screen loads, click Next. 
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6. After the initial screen loads, click Next. 

 

7. Select the directory where you want to install MPC and click Next. 
Click Browse to navigate to a non-default directory. 

8. When installation is complete, click Next. 

9. Click Next again. 
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10. The installation is complete; the final screen indicates where you will 
find an uninstaller program, and allows the option of generating an 
automatic installation script. Click Done to close the Installation 
window. 

 
 

Launching MPC on Sun Solaris 

1. Open a terminal window and change to the directory where you 
installed MPC (default location: /usr/local/Raritan/Raritan 
MPC/4.40.1.7). 
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2. Type ./start.sh and press ENTER to launch MPC. 

 

3. Double-click on the desired device to establish a connection, type 
your Username and Password and click OK to log on. Please refer to 
Chapter 2: Using MPC for additional operation instructions. 

 

Macintosh 

Checking JRE Version in Mac OSX 

1. Launch a terminal window on the Macintosh desktop. 
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2. Type java -version in the command line and press ENTER. The 
currently-installed version of Java Runtime Environment (JRE) 
appears. 

 

3. If the JRE is version 1.4.2_05 or greater, proceed with the MPC 
installation. If the version is older, please go to the Apple website to 
download the latest Runtime Environment. 

 

Installing MPC for Mac OSX 

You must have administrative privileges to install MPC. 

1. Log on to your Macintosh. 

2. Download, or copy from a known location, the MPC-installer.jar 
installation file. 

3. Open a Finder window and locate where the installer was saved. 

4. Double click on the file named MPC-installer.jar to run the installer. 
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5. After the initial screen loads, click Next. 

 

6. Select the directory where you want to install MPC and click Next. 
Click Browse to navigate to a non-default directory. 

7. When installation is complete, click Next. 
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8. The installation is complete; the final screen indicates where you will 
find an uninstaller program, and allows the option of generating an 
automatic installation script. Click Done to close the Installation 
window. 
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Launching MPC in Mac OSX 

1. Open a Finder window and navigate to the directory where you 
installed MPC (default location: /Applications/Raritan/Raritan 
MPC/4.40.1.7). 

 

2. Double-click on the desired device to establish a connection, type 
your Username and Password and click OK to log on. Please refer to 
Chapter 2: Using MPC for additional operation instructions. 

 

Modem Connectivity 

To Make Modem Connectivity Available on Unix/Linux and 
MAC OS for Non-Root Users 

1. As root, change group for /etc/ppp directory and required files: 

a. chgrp uucp /etc/ppp 

b. chgrp uucp /etc/ppp/pap-secrets 

c. chgrp uucp /etc/ppp/peers 

2. Change permissions for /etc/ppp chmod g+rwx /etc/ppp 

3. Change permissions for /etc/ppp/pap-secrets chmod g+rwx 
/etc/ppp/pap-secrets 

4. Change permissions for /etc/ppp/peers chmod g+rwx /etc/ppp/peers 
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5. Set suid bit to pppd chmod u+s /usr/sbin/pppd (/usr/bin/pppd 
depending on the location of pppd) 

6. Assign users to the uucp group 

a. /usr/sbin/usermod -G {existing groups for user1},uucp user1 

b. /usr/sbin/usermod -G {existing groups for user2},uucp user2, etc. 

7. When logged in as the normal user, update PATH for access to pppd 
and chat export PATH=$PATH:/usr/sbin (/usr/bin depending on the 
location of pppd) 

Note: For both root and non-root users, ensure that the options file exists under 
/etc/ppp 
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Intelligent Mouse Synchronization, available on the Mouse drop-down 
menu in Dominion KX units, automatically resynchronizes mouse 
cursors during moments of inactivity. For this to work properly, the 
following conditions should be met: 

• Active Desktop should be disabled on the target. 

• No windows should appear at the top left corner of the target screen. 

• There should not be an animated background in the top left corner of 
the target screen. 

• The target mouse cursor shape should be normal and not animated. 

• Target mouse speeds should not be set to very slow or very high 
speed values. 

• “Enhanced pointer precision" or any such mouse property should be 
disabled. 

• Other fancy mouse features, such as “snap mouse to default button 
in dialog boxes,” should be disabled. 

• Users must choose “Best Possible Video Mode” in the Video Settings 
window. 

• The edges of the target video should be clearly visible (that is, a 
black border should be visible between the target desktop and the 
Remote KVM Console window when you scroll to an edge of the 
target video image). 

After auto sensing the target video, users should manually initiate 
mouse synchronization by clicking the Synchronize Mouse button on 
MPC toolbar. This also applies when the resolution of the target changes 
if the mouse cursors start to de-sync from each other. 

If Intelligent Mouse Synchronization fails, this mode will follow the 
Standard mouse synchronization behavior. 

Note: Absolute mouse setting requires a USB target system, and is the 
recommended mouse setting for KX101. 

Please note that mouse configurations will vary on different target 
operation systems; consult your OS guidelines for further details. Also 
note that Intelligent Mouse Synchronization does not work with UNIX 
targets. 
 

Chapter 6 Conditions for Intelligent 
Mouse Synchronization 
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The following table identifies the special characters that can be used in 
MPC: 

Character Description Characte
r 

Description 

! Exclamation point : Colon 

" Double quote ; Semi-colon 

# Pound sign = Equal sign 

$ Dollar sign > Greater than sign 

% Percent sign ? Question mark 

& Ampersand @ At sign 

' Single quote [ Left bracket 

( Left parenthesis \ Backward slash 

) Right parenthesis ] Right bracket 

* Asterisk ^ Caret 

+ Plus sign _ Underscore 

, Comma ` Grave accent 

- Dash { Left brace 

. Period | Pipe sign 

/ Forward slash } Right brace 

< Less than sign ~ Tilde 

 
 

Chapter 7 Special Characters
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