m

==Raritan.

{1/

Dominion SX

User Guide
3.4.0

Copyright © 2013 Raritan, Inc.
DSX-v3.4.0-X-E

February 2013
255-60-2000-00




This document contains proprietary information that is protected by copyright. All rights reserved. No
part of this document may be photocopied, reproduced, or translated into another language without
express prior written consent of Raritan, Inc.

© Copyright 2013 Raritan, Inc. All third-party software and hardware mentioned in this document are
registered trademarks or trademarks of and are the property of their respective holders.

FCC Information

This equipment has been tested and found to comply with the limits for a Class A digital device,
pursuant to Part 15 of the FCC Rules. These limits are designed to provide reasonable protection
against harmful interference in a commercial installation. This equipment generates, uses, and can
radiate radio frequency energy and if not installed and used in accordance with the instructions, may
cause harmful interference to radio communications. Operation of this equipment in a residential
environment may cause harmful interference.

VCCI Information (Japan)

COREIS. FHRLBREFBEREEEERNGHES (VCC 1) OREHE
KEDCIVTAABHEMEEBTY, COKBEZRERRETHEATSILER
BEESIERITIEPHVET, COBEICEIFERENS B EXNKEET
B3LOBRENBEDPHVET,

Raritan is not responsible for damage to this product resulting from accident, disaster, misuse, abuse,
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To avoid potentially fatal shock hazard and possible damage to Raritan
equipment:

e Do not use a 2-wire power cord in any product configuration.

e Test AC outlets at your computer and monitor for proper polarity and
grounding.

e Use only with grounded outlets at both the computer and monitor.

e When using a backup UPS, power the computer, monitor and
appliance off the supply.

In Raritan products that require rack mounting, follow these precautions:

Operation temperature in a closed rack environment may be greater than

room temperature. Do not exceed the rated maximum ambient
temperature of the appliances (see Specifications (on page 259)).

e Ensure sufficient airflow through the rack environment.

e Mount equipment in the rack carefully to avoid uneven mechanical
loading.

e Connect equipment to the supply circuit carefully to avoid
overloading circuits.

e Ground all equipment properly, especially supply connections, such
as power strips (other than direct connections), to the branch circuit.
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Case 1. Upgrading SX Firmware via Web Browser

Upgrade the SX firmware version for enhanced features or service
patches.

During the upgrade, SX verifies there is enough space on the device to
perform the upgrade. If there is not, the SX restarts and the upgrade
does not take place. If the upgrade fails due to lack of space, clear the
local logs on the device and try upgrading again. Contact Raritan
Technical Support if you still cannot upgrade after clearing the local logs.

>

1.

To upgrade the SX:

Check the Raritan support website for the latest firmware version:
(http://www.raritan.com/support/firmwareupgrades and look for SX
under Dominion Family)

Download the new SX firmware stored as UpgradePack from Raritan
website to an FTP server, for example, a FileZilla server, assuming
that FTP server has an IP address of 192.168.51.204. Extract the zip
file to a folder under FTP root directory, for example:
\home\downloads\firmware\UpgradePack_2.5.6_3.1.0.5.2\Pack10f1.
Make sure the folder is accessible via an FTP user account.

Log in to the SX through a web browser. Choose Maintenance >
Firmware Upgrade.

Enter the FTP server IP address, FTP username and password, and
the FTP folder path where the extracted files are stored (in this
example: /UpgradePack _2.5.6_3.1.0.5.2\Pack1of1), and click
Upgrade.

After the firmware upgrade is completed, log in to the SX and check
the firmware version by clicking aintenance > Firmware Version. You
can also check firmware upgrade history to make sure:

Maintenance > Firmware Upgrade History.

See Upgrade the Firmware (on page 139) for detalils.

Case 2. Configuring and Using Direct Port Access via SSH

;

Raritan.

>

To allow users to directly SSH into the serial target without
using SX GUI:

Determine an IP address or TCP port on SX IP to use for DPA or any
port on SX. Since the network administrator has no spare IP address,
reuse the SX IP address with a different port.
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Log back in to the SX and select the port enabled for DPA in Setup >
Port Configuration.

Edit the DPA SSH TCP Port to which SSH client connects. Click OK.

Log in to the SX via a web browser. Click Setup > Services, select
TCP port on Direct Port Access Mode, and click OK.

Launch an SSH client, such as Plink or PUTTY. Enter the IP address
and change the default TCP Port to connect to the enabled port (for
example, plink -ssh -P 2203 192.168.51.9).

See Direct Port Access (on page 76) for details.

Case 3. Using Exclusive Write Access via RSC

>

To ensure that you are the only user who has write access to a
serial target:

After logging in to SX via a web browser, the Port Access tab is
selected by default.

Connect to Port 4 by clicking on the Port 4 link.

The Raritan Serial Console (RSC) launches with Write Access
enabled unless the port is taken by another user.

In the RSC window, click Emulator > Get Write Lock. The icon on the
status line displays Write Access (Lock), meaning all users can only
view the port connection.

Note: If another has previously obtained Write Access, perform "Get
Write Access" first from the Emulator menu of RSC)

Log in to the device connected to the port and try interacting with the
device using the RSC panel. See Get Write Access for detalils.

To relinquish write lock in the RSC window, choose Emulator > Write
Unlock, and the icon on status line displays Write Access again,
meaning any other privileged users regains Write Access.

Case 4. Configuring LDAP

;

Raritan.

>

To configure SX to use LDAP/Active Directory® server for login
authentication:

After logging in to SX via a web browser, choose Setup > Remote
Authentication.

If the LDAP server has a backup server, enter the same parameters
(except the IP address) for the secondary LDAP server.
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3.

Click OK.

See Configuring LDAP (on page 69) for detalils.

Case 5. Creating Power Association Group

See Power Strip Configuration (on page 239) for details on how to add
power strips to SX management first. If this wasn't already done, see
Port Power Associations section to map power strip outlet to a target
server connected to an SX serial port, and then see Power Association
Groups (on page 239) for details on how to group multiple power outlets
physically connected to that same target server.

>

XVi

To associate the target server with more than one power outlets
physically connected to it:

Log in to SX via a web browser and then make sure a power strip
has been configured. To add a power strip:

a. Choose Setup > Power Strip Configuration. See Power Strip
Configuration (on page 239) for details.

Choose Setup > Port Power Association List and click Add.

Use the drop-down menu to select the SX port connected to the
dual-powered server device with which you want to associate outlets.
Enter a description for it, such as "Internal Web Server Pronto”. See
Port Power Associations (on page 237) for detalils.

Use the drop-down menu to select the power strip and outlet that
matches how the unit is connected to the power. Click Add. The
information appears in the text box as "[Power Strip Name] \ [outlet
1"

Select the same power strip and another outlet, then click Add.
Another line displays in the text box as "[Power Strip Name] \ [outlet
2]". Click OK to commit the changes.

Choose Setup > Power Association Group List and click Add. See
Power Association Groups (on page 239) for details.

Enter a group name and description, then select the port ID(s) from
the "Available" box. Click Add.

Click OK to commit changes.

i
i

==Raritan.



How to - Dominion SX Essentials

Case 6. Performing Factory Reset on SX

>

To set the SX configuration back to the factory defaults through
the GUI:

Log in to SX via a web browser.

Choose Maintenance > Factory Reset. Confirm your decision when
prompted.

Do not power off the SX as it reboots.

You are redirected to the login page after the SX is rebooted. When
you log in for the first time after a reset, you are advised that you are
now in the factory default mode and prompted to change the
username and password.

Note: Passwords cannot contain"'<> \ &

See Performing a Factory Reset on the SX (on page 141) for details.

Case 7. Managing User Profiles on SX

N

To create, update, or delete an SX user:
Log in to SX via a web browser.

Choose User Management > User List.

To create a user profile, click Add New User.

To modify an existing user profile, see Modify a User Profile (on
page 61) for details.

To delete an existing user profile, see Delete a User Profile (on
page 62) for details.

See Create a User Profile (on page 59) for details.

Case 8. Accessing Port Access on SXvia RSC

;
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To access an SX serial target through Raritan Serial Client
(RSC):

Log in to the SX via a web browser.

Click the Port Access tab, and click the port name you wish to
access.
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Select Yes to proceed through the security warning(s). The Raritan
Serial Console (RSC) launches in a separate window. Press the
Enter key to "wake up" the session.

Type the target system's native commands in the RSC
window/console.

Choose Emulator > Exit. Click Yes on the confirmation dialog to
exit.

See Raritan Serial Console (on page 78) for details.

Case 9. Port Configuration

These steps allow you to configure SX serial ports to set up correct serial
communications parameters such as baud rate, data bits, stop bit, flow
control; the terminal emulation mode to match the serial targets
connected to the ports; and name the ports to more easily identify the

targets.

> To configure_ the SX serial ports to set up correct serial
communications parameters:

1. Loginto SX via a web browser.
Click Setup > Port Configuration.

3. Check the box associated with the port number you wish to configure,

and click Edit.

See Port Configuration (on page 74) for detalils.

Case 10. CLI/ SSH Connection to SX Port

XViii

>

To access the SX and SX ports using text-based command
lines:

SSH access from a Windows® PC:
a. Launch the SSH client software (such as Plink or PuTTY).

b. Enter the IP address of the SX server (for example,
192.168.0.192), and the TCP port if applicable.

c. Select SSH using default configuration port 22, and click Open.

d. Log in using the default log in credentials admin/raritan. The
console displays all ports on the SX with port numbers.

e. Enter a port number at the prompt, for example: admin> 1

==
= oo
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To return to the SX console, enter the escape sequence
characters. For example, simultaneously press the control and
closed bracket key (]).

To exit the target serial console session, enter the letter "g" to
quit. You are redirected to the SX console, and the port serial
console session is now closed.

2. SSH access from a UNIX® Workstation

a.

Enter the following command to log in: ssh -1 admin
192.168.0.192

Enter the admin username and raritan as the password. The
console displays all the ports on the SX with port numbers.

Enter a port number at the prompt, for example: admin> 1

To return to the SX console, enter the escape sequence
characters. For example, simultaneously press the control and
closed bracket key (]).

To exit the target serial console session, enter the letter "q" to
quit. You are redirected to the SX console, and the port serial
console session is now closed.

See SSH Connection to the SX for details.
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The SX Series of Serial over IP Console Servers offers convenient and
secure remote access and control through LAN/WAN, Internet, or Dial-up
modem to all networking devices.

The SX:

e Provides a non-intrusive solution for managing network elements
and does not require any installation of software agents on the target
device

e Connects to any networking device (server, firewall, load balancer,
and so forth) through the serial port and provides the ability to
remotely and securely manage the device using a Web browser

SX is a fully configured stand-alone product in a standard 1U high 19"
rack mount chassis.

20
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SX Connections and Ports
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AC unit diagram key

Power connections and power on/off

Internal modem (not available on all SX models)

Terminal port/console port

Unit status indicators

In normal operation, the LED blinks whenever there is network
or serial activity detected.

When booting, the LED blinks three (3) times if the unitis in a
factory reset state.

The Activity and 10/100 LEDs are tied to the network port.
Activity blinks when there is network activity.

10/100 displays the link status (10Mgbit/s or 100Mgbit/s) of
the network.

Note: On some SX models, the 10/100 and Activity LED are
attached directly to the LAN port, and are not labeled.

Ethernet port

Reset button

Server ports

;

Raritan.



Chapter 1: Introduction

23

=&=Raritan.



24

Chapter 1: Introduction

DC unit diagram key

Models

DSX4

Power connections

Power on/off

Internal modem (not available on all SX models)

Terminal port/console port

Unit status indicators

In normal operation, the LED blinks whenever there is network
or serial activity detected.

When booting, the LED blinks three (3) times if the unitis in a
factory reset state.

The Activity and 10/100 LEDs are tied to the network port.
Activity blinks when there is network activity.

10/100 displays the link status (10Mgbit/s or 100Mgbit/s) of
the network.

Note: On some SX models, the 10/100 and Activity LED are
attached directly to the LAN port, and are not labeled.

Ethernet port

Reset button

Server ports

4 Port SX
Single-feed Console 19" Internal
AC power  port rack-mount kit modem
v’ v ) v’ (optional)
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Models Single-feed Console 19" Internal
AC power  port rack-mount kit modem
DSXB-4-M v v (@) v" (optional) V"
4 Port SX Models — Port
Numbering

Lidad
OOOO

8 Port SX
Models Single-feed Dual-feed  Single-feed Console 19" Internal
AC power AC power DC power ports rack-mount kit modem
DSX8 v’ v’ (2) v’ (optional)
DSXA-8 v v (1) v v
DSXB-8-M v’ v’ 1) v’ (optional) v

DSXB-8-DC v (-36-72V) v’ ) v’ (optional)

8 Port SX Models — Port
Numbering

10[0]0I0,

OO

16 Port SX

25
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Models Dual-feed Dual Console Local 19" Internal
AC power Ethernet  port access rack-mount modem
port kit
DSXA-16 v v (1) v v
DSXA-16-DL
v v Vo v
II\D/ISXA-16-DL v v v (1) v v
16 Port SX Models — Port Numbering
s R | u
) | | ‘ | 1
32 Port SX
Models Dual-feed Dual Console Local 19" Internal
AC power Ethernet  port access rack-mount  modem
ports kit
DSXA-32
v v v v
DSXA-32-AC ,/ ,/ @) ,/
DSXA-32-DL
v v Vo v
I\D/ISXA-SZ-DL v v v 1) v v
DSXA-32-DC v v (1) v v
—

{
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32 Port SX Models — Port Numbering

B0 BEEE GEEOE BBEE

m i i e T T T TTT]
| 1!!!!J PEYE FUEES

D00 OO0 CEEE EEEE

48 Port SX
Models Dual-feed Dual-feed Dual Console 19" Internal
AC power DC power Ethernet port rack-mount modem
kit
DSXA-48 v v 1) v v
DSXA-48-AC ./ v v @) v
DSXA-48-DC v v v (1) v v

48 Port SX Models — Port Numbering

QEOEeEEEE BEBEEE®EE 6EOEEEE®E
SEvssves sevesves sEvsTES
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WEMOOOEE EBE0E 00 0@ H®EEE
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Product Features

Comprehensive Console Management

28

Remote Management: Access, monitor, administer, and troubleshoot
up to 48 target units (depending on the model) via Secure Socket
Shell (SSH), Telnet, Local Port, or Web browser with only one IP
address

Direct Port Access via TCP/IP address per port, or one IP address
and TCP Port numbers

Notification: Create notification messages by email alerts

Collaborative Management and Training: Access ports
simultaneously; up to 10 users per port at any time

SecureChat™: “Instant message” and other Secure Sockets Layer
(SSL) users can securely collaborate on unit management,
troubleshooting, and training activities

Get History: Get up to 256 KB (64KB on units with 64MB SDRAM,;
256KB on units with 128MB SDRAM) of recent console history to
assist with debugging

Supports VT100, VT220, VT 320, and ANSI terminal emulation
Up to a 5,000 line copy-paste buffer

Local port access

SNMP traps

SYSLOG

Logging to Network File System (NFS) Server

Comprehensive SNMP traps

Port alerts with keyword triggers

Three Levels of User Access:

= Administrator: Has read and write access to the console window;
can modify the configuration of unit.

= Operator: Has read and write access to the console window;
cannot modify the configuration of unit (except own password).

= Observer: Has read-only access to the console window; cannot
modify the configuration of unit (except own password).

i
i

==Raritan.



;

Raritan.

Chapter 1: Introduction

Strong Security and User-Authentication
e SSHv2 Support

e Encryption Security: 128-bit SSL handshake protocol and RC4
encryption

e User Authentication Security: local database, remote authentication

e Supports RADIUS, TACACS+, LDAP, LDAP(S), Microsoft Active
Directory®, and NTP

e Supports user-defined and installable security Certificates

Reliable Connectivity

e Optional Modem Connectivity: For emergency remote access if the
network has failed

e Target Device Connectivity: Simplified RJ45-based CAT 5 cable
scheme; serial port adapters are available from Raritan

e Local Access for "crash-cart" applications

See Connectivity (on page 264) for a list of necessary SX hardware
(adapters and/or cables) for connecting the SX to common
Vendor/Model combinations.

Simplified User Experience
e Telnet
e SSH

e Browser-based Interface: The new GUI provides intuitive access to
target devices (click the appropriate button to select the desired
target device)

e Upgrades: Built-in firmware upgrade capability through FTP or LPA
and integrated with Command Center (CC) and SSH

29
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Package Contents

AC Models

Amount
included

1

N T

DC Models

Amount
included

1

R R Rk R

Item

SX with mounting kit (rack-mount kit is optional on
some units)

AC power cord
RJ45 serial loop-back plug

DB9 Factory Reset Adapter for some units (other
units have a reset switch and do not require an
adapter)

SX Quick Setup Guide
Warranty card
Release notes

Packing list

Item

SX unit with mounting kit (rack-mount kit is optional
on some units)

RJ45 serial loop-back plug

DB9 Factory Reset Adapter for some units (other
units have a reset switch and do not require an
adapter)

SX Quick Setup Guide
Warranty card
Release notes

Packing list

1]
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Installation and Configuration

In This Chapter

(@ VT LY/ =Y 31
gL [y r= 11 = 1[0 ] o 32
Hardware INStallation ...........ceeiieiiiiieie e 32

Overview
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Raritan.

There are two ways of completing the initial network installation of the
SX:

e Using a serial cable with a VT100/equivalent, such as a PC with
HyperTerminal

e Using Ethernet (with an installation computer)

This section describes the steps necessary to configure SX for use on a
local area network (LAN). The following table describes the factory
default network settings that come with the SX. After devices are
connected to the network, these factory default settings allow you to
configure the SX for normal use.

Default Network Settings

Internet Address (IP) 192.168.0.192

Gateway Address 192.168.0.192

Subnet Mask 255.255.255.0

CSC Port Address 5000

Port Address for CC 5000

Discovery

Username admin (all
lowercase)

Password raritan (all
lowercase)

Note: The settings listed in the table above are applicable only if no
DHCP server is running on the network. If a DHCP server is running on a
local network, the SX is assigned a different IP address than the default
by the DHCP server.
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Pre-Installation

Ensure that you have the correct cabling ready to connect to the serial
consoles of the target server(s) or other serially managed devices that
provide a console port.

The following sections describe information that you must supply to
complete the configuration of the SX. Obtain all required configuration
information prior to performing the configuration steps. If you are
uncertain of any information, contact your system administrator for
assistance.

Client Configuration

1.

Disable Proxies in the installation computer web browser. Use "no
Proxies" or temporarily add 192.168.0.192 to the list of URLSs for
which no proxy is configured.

Enable Java Applet Execution in the installation computer web
browser for the console client application (RSC).

Access the SX through your installation computer web browser on
the same subnet by typing the URL https://192.168.0.192 in the
address bar.

Hardware Installation

Physical Installation of Dominion SX for Initial Configuration

1.

Use a computer with a network card and crossover network cable.
This computer is referred to as the 'installation computer.'

Physically mount the SX in an ergonomically sound manner. The SX
is designed to be easily rack-mounted, and rack mounting is
recommended.

Connect the crossover network LAN cable to the primary LAN
connection (LAN 1 on models with two Ethernet interfaces) on the
back of the chassis.

Connect the other end of the network LAN cable to the network card
in the installation computer.

Connect the female end of the external power cord to the back of the
chassis.

Connect the male end of the external power cord to the power supply
outlet.

Power on the SX.

1]
il

Raritan.



;

Raritan.

Chapter 2: Installation and Configuration

Note: The SX performs a hardware and firmware self-test, then start the
software boot sequence, which takes a short time. It is complete when
the light turns on and remains on.

After completion of the hardware and firmware self-test and the software
boot sequence, perform the initial configuration tasks using the Graphical
User Interface (GUI) or the Command Line Interface (CLI) as described
in the following sections.

LED State

On the front panel of the SX, there are LED indicators on each side. The
green LED is lit at the same time the blue LED is lit. The blue LED
indicator blinks blue in the following three cases:

o Ethernet packets are received or transmitted
e Serial data are received or transmitted

e Watchdog timer is reset to 0. The LED blinks on a periodic basis as
the watchdog timer reaches a certain value, and then is reset to O

Initial Configuration Using the Graphical User Interface (GUI)
> To initially configure the SX from the GUI:

Network Access

1. Ensure that the installation computer has the route for 192.168.0.192
and that it can communicate with IP address 192.168.0.192.

2. To check the route table in Windows®, type the command route print
in a Command window on the installation computer. If 192.168.0.192
is on the gateway list, proceed to step 3. Otherwise, add
192.168.0.192 to the gateway list using the appropriate DOS or
UNIX® CLI command:

=  Windows 98/2000/NT system: route add 192.168.0.192
<INSTALLATION COMPUTER IP ADDRESS>.
[Example: route add 192.168.0.192 15.128.122.12

= UNIX (including Sun Solaris) system:
route add 192.168.0.192 <CLIENT HOST IP ADDRESS>

-interface.
[Example: route add 192.168.0.192 15.128.122.12
-interface]

3. Typeping 192.168.0.192. Go to step 4 if you receive a
successful reply from the SX. If an error occurs, verify that the
default IP address is entered correctly and that a route to that IP
address exists.
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4. Use the installation computer to connect to the device by launching a
browser and typing the factory default IP address 192.168.0.192 in
the Web browser's address bar.

5. The computer displays the security screens before you can log in.

If you click View Certificate on the Security Alert-Certificate page, a
Certificate dialog appears. See Security (on page 106) and
Appendix C: Certificates (see "Certificates" on page 274) for
information about installing certificates.

Certificate

" ¥
General glzetaiiﬁ . Cerliﬁca!_:iun Path_‘_

Certificate Information

This CA Root certificate is not trusted. To enable trust,
install this certificate in the Trusted Root Certification

Authorities store.

Issued to: DominionS¥

Issued by: DominionS¥

Yalid from 4/4/2006 to 4/4/2007

6. Atthe Log In page, enter the default username admin and password
raritan. Use all lowercase letters.

7. After login, the SX prompts you to change the default password.

3 =i=Raritan.
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Note: Passwords cannot contain"'<> \ &

Click OK. The SX Port Access page opens. See Initial Software
Configuration (on page 38) for details.

Initial Configuration Using the Command Line Interface

>

To initially configure the SX from the Command Line Interface:

Connect the serial port of your installation computer to the Terminal
serial port on your SX. This port is a DB9-Male port on most models,
except ALL dual-power, dual-LAN models, including DSXA-48, which
have an RJ45 connector for a terminal port.

Open a terminal emulation program, such as HyperTerminal, to
connect to the SX. The serial communication parameters are 9600
bps, No parity, 8 data bits, 1 stop bit and None flow control.

Power ON the SX.

Log in using the default username admin and the default password
raritan when prompted. Once logged in, a prompt to change the
password appears.

Type a new password, and then retype it (Remember this password).
A page opens, showing the SX's status and serial channel ports.

Note: Passwords cannot contain " '<> \ &

Note: If the password entered does not follow the password rules, an
error message appears as a warning. You are logged out and must
start over to set your password.

Network Access

1.

Ensure that the installation computer has the route for 192.168.0.192
and that it can communicate with IP address 192.168.0.192.

To check the route table in Windows®, type the command route print
in a Command window on the installation computer. If 192.168.0.192
is on the gateway list, proceed to step 3. Otherwise, add
192.168.0.192 to the gateway list using the appropriate DOS or
UNIX® CLI command:

= Windows 98/2000/NT system: route add 192.168.0.192
<INSTALLATION COMPUTER IP ADDRESS>.
[Example: route add 192.168.0.192 15.128.122.12]

= UNIX (including Sun Solaris) system:
route add 192.168.0.192 <CLIENT HOST IP ADDRESS>
-interface.
[Example: route add 192.168.0.192 15.128.122.12
-interface]
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w N Ry

Type ping 192.168.0.192. Go to step 4 if you receive a
successful reply from the SX. If an error occurs, verify that the
default IP address is entered correctly and that a route to that IP
address exists.

Use the installation computer to connect to the device by launching a
browser and typing the factory default IP address 192.168.0.192 in
the Web browser's address bar.

To set the date and time:
Type Configuration to change the device's configuration.
Type Time to select the Date/Time configuration.

Type Timezonelist and find the numerical code that corresponds
to your time zone.

Type clock [tz timezone] [datetime datetime-string]. For
example:

admin > Config > Time > clock tz 9 datetime "2007-02-05
09:22:33"

In this example, 9 is the time zone code (Step 3) and "2007-02-05
09:22:33" the date/time string in the format "YYYY-MM-DD
HH:MM:SS" (quotes required).

Network Configuration

Type Configuration to change the device's configuration.

Type Network to select the network configuration.

Type:

aégin > Config > Network > interface enable true if
lanl1ip192.16.151.12mask255.255.255gw192.168.51.12
Upon successfully entering the data, a report displays the new
network configuration and you are prompted to reboot the SX.

Type yes to reboot the SX.
Remove the serial cable.

Reconnect from the installation computer browser to the SX using
the new IP address and password.

User Configuration

1.
2.

Type Configuration to change the device's configuration.

Type Users to select the user configuration.

=Raritan.
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> To Add a User Group

Type addgroup name <group name> class <class type> ports
<nl,n2,n3...>where <group name> is the name of the group and
<class type> is

= Op for operator
= Ob for observer

<nl,n2,n3...> is a list of port numbers to which this group has access,
separated by commas but no spaces. You can configure port ranges
using the same parameters, or use the wildcard asterisk (*). For
example:

= "config port 3-7 exitstring #0" (this disables exit strings for ports
3,4,5,6,7)

= config port * bps 115200 (this sets all ports to a communications
speed of 115200 bps)

» To Add a User

1. Type adduser user <user name> fullname <full name> group
<group name> password <password> info <information>
dialback <dialback number> active <status> where:

= <user name> is user's login name

= <full name> is a user's descriptive name (no spaces)

= <group name> is the user's assigned group

= <password> is the user's password

= <information> is extra information (optional, no spaces)

= <dialback number> is the user's phone number (optional)
= <status> is true or false, allowing the user to login or not

2. Type top to return to the top level of the CLI menu.
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Initial Software Configuration

After the hardware installation, perform the initial software configuration.

Log in to the SX from either a browser or through a Command Line
Interface (see Command Line Interface (on page 146) for CLI
information).

In This Chapter

Dominion SX Initial Software Configuration ...........ccccccveeeveiiiiiiieeeee e
(=701 ()Y, 1 41T o | SRS PSERRR

Dominion SX Initial Software Configuration

1. Loginto the SX using your new password. A Port Access page
opens according to your user type.

Port Access

1 Puetd
2 Port2
3 Foet3

¥ E|F|F

Port Access
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2. Click the Setup tab. The Setup page opens, containing links to the
Configuration and Logging pages.

Configuration

Remoate Authertication
Metwork

Services

Madem

Static Routes

Date / Time

Port Configuration

Port Keywords

Port Power Association List
Powver Strip Configuration

Power Association Group List

Logging

Log
Events
NFS
SNMP

Important: After you complete each configuration task, you must
return to the Setup tab to perform the next configuration task.
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Date/Time Configuration

1. Choose Setup > Date/Time. The Date/Time Configuration page
opens.

Date / Time

Current Date & Time:
April 17, 2008 07:59:30

UTC Offset:
’ (GMT-05:00) Eastern Time Zone (US & Canada) v

@ User Specified Time
Date (Month, Day, Year):
| apri w17 |[2008 |

Time (Hour, Minute):

O Synchronize with HTP Server
Primary Time Server:

Secondary Time Server:

‘17 0.00 ’

I OK I I Cancel I

2. Select the correct time zone from the UTC Offset drop-down menu.

3. Select one of the following:

= User Specified Time - Click this radio button and enter the date
and time manually in the corresponding fields.

= Synchronize with NTP Server - Click this radio button and enter
the IP address of a Network Time Protocol (NTP) server in the
Primary Time Server. If you have a backup NTP server, enter its
IP address in the Secondary Time Server field.

4. Click OK.

Note: Features such as certificate generation depend on the correct
Timestamp, used to check the validity period of the certificate. In
addition, the Syslog and NFS logging features also use the system
time for time-stamping log entries.

—v=

=i=Raritan.
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After you click OK, the system displays one of the following pages:

A confirmation page, which contains the settings you chose and a
confirmation message at the top of the page.
Date / Time Settings successtully applied.

An error page, which contains the original Date/Time page and the
error message.

ERROR: Date / Time Settings NOT successfully applied.

Network Configuration

1.

Choose Setup > Network. The Network Configuration page opens.

Note: If you have a dual LAN model, the Enable Ethernet Failover
checkbox is selected by default. Uncheck it as needed.

Note: Your network administrator usually assigns the values for the
following parameters.

If Enable Ethernet Failover is selected, enter the failover interval in
seconds in the "Interval (seconds)" field.

Configure the LAN interface 1:

a. Check the Enable LAN Interface 1 checkbox to enable the
feature.

b. Select either None or DHCP from the drop-down menu to
determine a method for IP Auto Configuration. The default is
DHCP.

c. Type an IP address for the SX in the IP Address field.
d. Type the subnet mask in the Subnet Mask field.

e. Type the IP address of the gateway router in the Gateway IP
Address field.

f. Select the speed from the drop-down menu in the Mode field.
Your choices are Auto (default) or 100 Mbps.

Configure the LAN interface 2 (if needed):

a. Check the Enable LAN Interface 2 checkbox to enable the
feature.

b. Select either None or DHCP from the drop-down menu to
determine a method for IP Auto Configuration. The default is
DHCP.

c. Type an IP address for the SX in the IP Address field.
d. Type the subnet mask in the Subnet Mask field.

e. Type the IP address of the gateway router in the Gateway IP
Address field.
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f.  Select the speed from the drop-down menu in the Mode field.
Your choices are Auto (default) or 100 Mbps.

5. Type your domain name in the Domain field.
Type a name in the Unit Name field.
7. Inthe Ports section:
= Type 5000 or another port number in the CSC Port field.

= Type 5000 or another port number in the Discovery Port field.

—v=
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8. Click OK.

Chapter 3: Initial Software Configuration
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Setup > Network

Network Basic Settings

. 4
Enable Ethernet Failover C5C Port: -
Interval (seconds): S000
20 Discovery Port:
5000

Enable LAN Interface 1:
IP Auto Configuration:
MNone -

IP Address:
182 1628.61.210

Subnet Mask:
2552552550

Gateway IP Address:
192.168.61.126

Mode:
Auto -

Enable LAN Interface 2:
IP Auto Configuration:
| MNone -

IP Address:
192 168.0.152

Subnet Mask:
255 255.255.0

Gateway IP Address:
1592.168.0.192

Mode:
Auto -

Domain:

Unit Name:
ww SX-COLDBOOT-TEST

_u..ﬂ-""_r:a'- ! -r ’-».._‘ jr ._.4--1.-_} \*;._J “’,._4_I
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Deployment

;

Raritan.

Remotely access the SX through a LAN connection or a modem
connection (optional). The SX can access target devices only through a
serial connection.

LAN Connection

After the initial software configuration phase, configure the SX for
operation on the LAN.

1. Ensure that you have an Ethernet cable connected to the network for
use with the SX.

2. Physically mount the SX in an ergonomically sound manner.

3. Connect the LAN cable to the primary LAN connection (LAN 1) on
the back of the chassis. If the device has a failover module, connect
the secondary network LAN connection (LAN 2).

4. Perform a quick connectivity check by connecting to the device using
the Web browser.

5. Enter https://<IPAddress> in the address line, where
<IPAddress> is the IP address of the device as previously
configured.

Note: Verification that the SX has been properly configured and can
be accessed from the network is displayed at log in.

6. Log in with username admin and the password you created earlier.

7. Onthe Home page, click the Setup tab and select the various
configuration options for configuring the SX and each console port.

Modem Connection (Optional)

> To configure the SX for a modem connection:
1. Connect a phone line to the modem port.

2.  Write down the phone number for this line because it is needed
when you configure a client for dialup networking.

See Appendix E: Modem Configuration (see "Modem Configuration”
on page 294) for detalils.
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Configuring the Basic Network Settings

;

Raritan.

Network basic settings include:

Enabling/disabling Ethernet failover, and enabling/disabling LAN
Interface 1 and 2 - see Configure the Network Settings of SX (on
page 49)

Specifying the SX unit name - see Name the SX (on page 50)

Configuring the discovery ports - see Change the Discovery Ports
(on page 50)
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Setup > Network

-
Network Basic Settings
Enable Ethernet Failover CSC Port:
Interval (seconds): 0o
20 Discovery Port:
000

Enable LAN Interface 1:
IP Auto Configuration:

MNone -
IP Address:

182 1628.61.210

Subnet Mask:
2552552550

Gateway IP Address:
192.168.61.126

Mode:
Auto -

Enable LAN Interface 2:
IP Auto Configuration:
| MNone -
IP Address:

192 168.0.152

Subnet Mask:
255 255.255.0

Gateway IP Address:
1592.168.0.192

Mode:
Auto -

Domain:

Unit Name:
ww SX-COLDBOOT-TEST

\M‘\\\&N\‘\ J\'\\pﬁ\“ LR T YRR NPy

I Y A 2P e
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Configure the Network Settings of SX

> To configure the network settings:

Choose Setup > Network. The Network Basic Settings and Ports
page opens.

Note: If you have a dual LAN model, the Enable Ethernet Failover
checkbox is selected by default. Uncheck it as needed.

2. |If Enable Ethernet Failover is selected, enter the failover interval in
seconds in the "Interval (seconds)" field.

3. Configure the LAN interface 1:

a. Check the Enable LAN Interface 1 checkbox to enable the
feature.

b. Select either None or DHCP from the drop-down menu to
determine a method for IP Auto Configuration. The default is
DHCP.

c. Type an IP address for the SX in the IP Address field.
d. Type the subnet mask in the Subnet Mask field.

e. Type the IP address of the gateway router in the Gateway IP
Address field.

f.  Select the speed from the drop-down menu in the Mode field.
Your choices are Auto (default) or 100 Mbps.

4. Configure the LAN interface 2 (if needed):

a. Check the Enable LAN Interface 2 checkbox to enable the
feature.

b. Select either None or DHCP from the drop-down menu to
determine a method for IP Auto Configuration. The default is
DHCP.

c. Type an IP address for the SX in the IP Address field.
d. Type the subnet mask in the Subnet Mask field.

e. Type the IP address of the gateway router in the Gateway IP
Address field.

f.  Select the speed from the drop-down menu in the Mode field.
Your choices are Auto (default) or 100 Mbps.

5. Type your domain name in the Domain field.

49
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6.

Click OK.

Setup > Network

| ey

Network Basic Settings

Enable Ethernet Failover

Interval (seconds):
20

Enable LA Interface 1:

IP Auto Configuration:
None -

IP Address:
1582.168.61.210

Subnet Mask:
2552552550

Gateway IP Address:
192.168.61.126

Mode:
Auto -

[C] Enable LAN Interface 2:
IP Auto Configuration:

IP Address:
182.168.0.182

Subnet Mask:
255.255.2585.0

Gateway IP Address:
182.168.0.152

Mode:

Domain:

ol

¥
}
-
Y

\r"""’\--\_/'\ Ama AL Ny LN~

Name the SX

>

To give the SX a name to help identify it:

Choose Setup > Network. The Network Basic Settings and Ports

page opens.

Type a name in the Unit Name field.

Click OK.

Change the Discovery Ports

>

To change the discovery ports:

Choose Setup > Network. The Network Basic Settings and Ports

page opens.

The SX has two discovery ports:

=i=Raritan.
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= TCP 5000 Common Socket Connection (CSC) discovery
= UDP 5000 Command Center (CC) discovery

2. If either of these ports is used by another application, change the
discovery port number in the SX in the appropriate field and click OK.

Note: The port range for internal port configuration (CSC, HTTP, HTTPS,
SSH, Telnet, DPA SSH , DPA Telnet) is 1 ~ 64510, while the
configurable port range for socket creation is limited to 1024 ~ 64510.
External port configuration (LDAP,RADIUS, TACACS+,SNMP) is not
affected by this port range limitation, but allowed with full range of
configuration.

Configuring the Network Service Settings

Following are the default settings for the various network access

services:

Service Default Setting

HTTP Enabled. The default port is 80. This can be
changed.
HTTPS redirect is enabled by default. If HTTPS
is also enabled, all HTTP requests are
automatically redirected to the HTTPS port (see
below).

HTTPS Enabled. The default port is 443. This can be
changed.

Encryption Encryption is set to SSL, but this can be
changed to TLS.

Telnet Disabled for security reasons. This can be

enabled and the port configured.
23 is the default Telnet port.

SSH Disabled by default. This can be enabled and
the port configured.

The configurable option labeled Fixed TCP
Window is enabled by default when SSH access
is enabled, making SSH connection work under
Windows Vista® operating system.

Available authorization methods are:
e Both certificate and password

e Password

e Certificate

22 is the default Telnet port.

51
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Service
Local Port Access

Direct Port Access
Mode

Allow DPA via the
username for
SSH/Telnet

Default Setting
Enabled. The baud rate is set to 9600 bps, but
this can be changed.

Set to Normal by default, but this can be
changed to IP or TCP port.

Configure direct port access for SSH and Telnet
based on username. Disabled by default.

{

=Raritan.
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Setup > Services 5

Hetwork Service Settings

Enable HTTP

Enable HTTP to HTTPS Redirect

HTTP Port:
&0

Enable HTTPS

HTTPS Port:
443

Encryption:
SSL -

Enable TELNET Access

Telnet Port:
23

Enable SSH Access

&5H Port:
22

Auth Method
Both Certificate and Pas: -

Enable Local Port Access

Bits Per Second:
115200 -

Direct Port Access Mode:
TCP Port *

Allow DPA via the username for 55HTelnet.

N W N T WL L D Y

Fixed TCP Window

OK Cancel .
P -ttt f“ —

AW

eV

=& Raritan.
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Change Network Service Settings

>

To change network service settings:

Choose Setup > Services. The Network Service Settings page
opens.

Make any necessary changes to the appropriate fields.

Fixed TCP Window is checked by default, enabling SSH connection
to work under the Windows Vista® operating system.

Note: Some operating systems may require TCP window scaling for
successful SSH connections, in which case the ‘Fixed TCP Window’
option needs to be disabled.

Note: Customers experiencing slow SSH connectivity in SX 3.1.5 or
select theSX 3.1.6 after upgrading to SX 3.1.7 should enable the ssh
enable true setting to avoid this issue in the future.

Click OK.

Configuring Modem Access

>

1.

To set up SX access via a modem:

Choose Setup > Modem. The Modem Settings page opens.

Setup = Maodem

2.
3.

Modem Settings

Enable Modem

Modem Access Modes:
Al v|

PPP Server IP:
10.0.0.1 |

PPP Client IP:
10.00.2 |

|:| Enable Modem Dial Back

OK Cancel

Select the Enable Modem check box to enable modem access.

For the Modem Access Mode, do one of the following:

=¥ oo

=Raritan.
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a. Select All to allow modem access to all modems. Looks for a
PPP signal and falls back to allow console access if the PPP
signal is not detected. In this mode, Modem Dial Back cannot be
enabled.

b. Select PPP Only to allow only PPP connections. Allows GUI,
SSH and Telnet access (if enabled).

c. Select Console Only to allow only console connections. Allows
only CLI access through a terminal emulation programs such as
Hypertreminal.

If you selected All or PPP Only as the modem access mode:

a. Type the IP addresses of the Point-to-Point (PPP) server in the
PPP Server IP field. The default is 10.0.0.1

b. Type the IP address of the PPP client in the PPP Client IP field.
The default is 10.0.0.2.

If you selected PPP Only as the modem access mode:

a. If you want to enable modem dialback, select the Enable Modem
Dial Back check box.

Click OK. Modem access is enabled. Reboot the modem so the
changes to take effect.

Configuring IP Forwarding and Static Routes

;

Raritan.

You can enable IP forwarding. You can also create static routes if your
SX has two LAN ports or is configured for modem access.

Enable IP Forwarding

>

3.

To enable IP forwarding:
Choose Setup > Static Routes. The Static Routes page opens.

Go to the IP Forwarding panel and click the Enable IP Forwarding
checkbox.

IP Forwmarding

Enable IP Forwarding

| OK | | Cancel |

Click OK. IP forwarding is enabled.

55



56

Chapter 4: Network Settings and Services

Add a New Static Route

> To add a new Static Route:
1. Choose Setup > Static Routes. The Static Routes page opens.

Static Route List

4 Interface

[0 Lan1 19285760 255.255.2550 0000 0 0 1] 0

‘ [ Lang 0000 0000 19216860126 2 0 0 i} l

I Delete I[ Add Hew Route E

2. Go to the Static Routes List and click Add New Route.

Interface:
|LAN1 v

Destination:

Mazsk:

Gateway:

MS5:

Window:

IRTT:

Flags:
| Host w |

| 0K | | Cancel |

3. For an SX with one LAN interface, LAN appears automatically in the
Interface field. On an SX with two LAN interfaces, select the one you
want from the drop-down menu in the Interface field.

= LAN1 = ethO
= LAN2 =ethl

4. Type the IP address, subnet mask, and gateway of the destination
host in the Destination, Mask, and Gateway fields.

=i=Raritan.
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5. Type the TCP maximum segment size (MSS) in bytes in the MSS
field.

6. Type the TCP windows size for connections over this route in bytes
in the Window field.

7. Type the initial round trip time (IRTT) for TCP connections over this
route in milliseconds (1-12000) in the IRTT field.

8. Select your route type from the Flags drop-down menu.
= Host means this route is for a host machine.
= Net means this route is for a subnet.

9. Click OK.

Delete a Static Route

> To delete a static route:

Choose Setup > Static Routes. The Static Routes page opens,
containing an Enable IP Forwarding panel and a Static Routes List.

2. Go the Static Routes List and select the checkbox next to the route
you want to delete.

Click Delete. You are prompted to confirm the deletion.
Click OK. The route is deleted.
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Managing User Profiles

User List

| O
|l
O

User profiles serve two purposes:

e To provide users with a username and password to log into the SX.

e To associate the user with a user group. The user group determines
which system functions and ports the user can access.

The SX is shipped with one user profile built in: the admin user. This
profile is associated with the Admin user group and has full system and
port permissions. This profile cannot be modified or deleted.

Up to 140 users are supported by the SX. You can create individual user
profiles for each person who is logging into the SX, or you can create a
limited number of profiles and allow more than one person to use each
profile.

Display a List of User Profiles

1. To display a list of existing user profiles, choose User Management >
User List. The User List page opens.

Full Hame Dialback Group Active

Ml

|4}
O

| O
| O
=]

Delete

admin

Add New User

Admiristrator Adrin Yes |

2. The User List page shows every user profile created to date, and for

each one, lists:
= Username
= Full name

= Dialback number (if one has been defined)
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= User group

The User List page also indicates whether the user profile is active or
inactive.

Create a User Profile

>

3.

4.

To create a new user profile:

Choose User Management > User List. The User List page opens
(as shown in Display a List of User Profiles (on page 58)).

Click Add New User. The New User page opens.

Username:

Full Hame:

Dialback:

Information:

Password:

Confirm Password:

User Group:
| iy |

Active

I OK I | Cancel |

Type a login name in the Username field. This is the name the user
enters to log into the SX. This field is required.

= You can enter any number of characters up to a maximum of
255.

= You can enter any printable character except "'<>\&
= The user name is case sensitive.

Type the user's full name in the Full Name field. This field is required.
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5. Type the user's telephone number in the Dialback field. This field is
optional.

6. Type any comments about the user profile in the Information field.
This field is to help you identify the profile and is optional.

7. Type the password in the Password field, and then type it again in
the Confirm Password field. This field is required.

= You can enter any number of characters up to a maximum of 64.
= You can enter any character except"'<>\ &

= The password is case sensitive.

Note: If the strong password feature is enabled, there are other
password requirements. See Port Configuration and Port Access
Application (on page 72) for details.

8. Select a user group from the drop-down menu in the User Group
field. By default, the Admin group is entered.

Tip: If the user group you want has not yet been created, you can
create it and then return to the user profile and select it. For now,
keep the default.

9. Decide whether or not to activate this profile immediately. By default,
the Active checkbox is selected. To deactivate this account, deselect
this checkbox. You can return at any time and activate the user when
necessary.

10. Click OK. The user profile is created and should appear in the User
List page.

SSH Connections for Users

If needed, configure a SSH (Secure Shell) via client certificate for a user.
The user must first be created before the client certificate can be added.

> To add a SSH client certificate to the user:
Create the user. See Create a User Profile (on page 59).

2. From the User page, click on the name of the user you want to add a
SSH client certificate to. The User's page opens.

Select the Add SSH Key radio button.

Enter the SSH key data in the SSH Key Data box. This data is the
rsa_id.pub key generated for your client.

5. Click Apply.
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6. When you SSH with this user, the key data should be used for
authentication and you should not have to enter a password.

Stored 55H Keya : 0 :

) Delete S5H Key
55H Key Index: L}

@ Add SSH Key
55H Key Data:

Apply Cancel

i A e o

To delete an SSH key:

Click on the Delete SSH Key radio button.

In the SSH Key Index, enter the SSH key's index.
Click Apply.

w NPy

Modify a User Profile

> To modify an existing user profile:

Choose User Management > User List. The User List page opens
(as shown in Display a List of User Profiles (on page 58)).

2. Click the Username of the profile you want to edit. The Edit User
page opens. It looks exactly like the New User page (as shown in

Create a User Profile (on page 59)).

3. You can change any of the fields except the Username field.
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4. For security reasons, the password is not displayed. To change the
profile's password, type a new password in the Password and
Confirm Password fields. If you leave these fields as is, the
password is unchanged.

Note: Passwords cannot contain"'<> \ &

5. Click OK when finished. The user profile is modified.

Delete a User Profile

> To delete an existing user profile:

Choose User Management > User List. The User List page opens
(as shown in Display a List of User Profiles (on page 58)).

2. Click the checkbox to the left of the user profile you want to delete.
You can select more than one.

Click Delete. You are prompted to confirm the deletion.

Click OK. The selected user profiles are deleted.

Managing User Groups

User groups serve two purposes:

e To determine which system functions the users associated with a
group are permitted to perform

e To determine which ports the users associated with a group are
permitted to access

The SX is shipped with one user group built in: the Admin user group.
Users associated with this group can perform all system functions and
access all ports. This group cannot be modified or deleted.

You can create as many other user groups as necessary.

Display a List of User Groups

To display a list of existing user groups, choose User Management >
User Group List. The Group List page opens.

Graup List

[nelete | | Addl llew User Group
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The Group List page shows every user group created to date, and for
each one gives the group's name and class.

Create a User Group

P> To create a new user group:

1. Choose User Management > User Group List. The Group List page
opens (as shown in Display a List of User Groups (on page 62)).
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2. Click Add New User Group. The New Group page opens.

Group Hame:

| |

Class:
| Operator v I

Port Sharing

Port Access:

[] setect an

D 01: Triana

[ 03: Henchman 21
[] 05: Ports

[J o7: Portz

[[] 09: Ports

] 11: Port11

] 13: Port13

[] 15: Port15

] 02: Henchman 24 PCS12-2
[] 04: ThePerfectMan

[] 06: Ports

[] o8: ports

] 10: Port10

[ 12: Port12

[J 14: Port14

[] 16: Port1s
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[ 17: Port17 [] 18: Port1s
[J 19: Port19 ] 20: Port20
[ 21: Port21 [ 22: port22
[ 23: port23 (] 24: Port24
[ 25: Port2s [ 26: Port26
[ 27: Port27 [ 28: Port2s
] 29: Port29 ] 30: Port3o
D 31: Loop Back D 32: Loop Back

Power Access:
[ select AN

D 01: Triana
|:| 02: Henchman 24 PCS12-20

D 03: Henchman 21
D 04: ThePerfecthMan

[] 05: Ports
[] 06: Ports

[] o7: Port7
[] 0s: Ports

[] 09: Porto
[] 10: Portto

[ 11: Port11
[J 12: Port12

[] 13: Port13
[ 14: Port1a
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D 15: Port15
[] 16: Port1s

[] 17: Port17
[ 18: Port1s

[] 19: Port19
[] 20: Port20

[ 21:
[ 22:

[ 23

Port21
Port22

Port23

[ 24: Port2a

[] 25:
[ 26:
[ 27:
[] 28:
[ 29:
D 30:

[ 31:
[ 32:

Port25
Port26

Port27
Port2g

Port29
Port30

Loop Back
Loop Back

I OK I | Cancel |

3. Type a group name in the Group Name field.

You can enter any number of characters up to a maximum of
255.

You can enter all letters and numbers, as well as the underscore
character ().

The user name is case sensitive.

4. Select the class from the drop-down menu in the Class field. Your

cho

ices are:

Operator - This is the default. Users associated with the Operator
class have read/write access to the console window, and cannot
change any system configuration parameters except their own
password.

Observer - Users associated with the Observer class have
read-only access to the console window, and cannot change any
system configuration parameters except their own password.

5. Port Sharing: By checking this option, users in the group are allowed
to access a port that already has users connected to it, if the port
access mode is set to Share. (See Login Settings (see "Login
Handling" on page 108) for information about port access mode.)

=¥ oo
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Select the ports that the users associated with this group are
permitted to access. You can select all ports or you can select any
combination of individual ports.

Select the ports for which users associated with the group are
allowed to access the power commands. Only administrators can
access the power strips via CLI directly.

Click OK. The user group is created and should appear in the User
List page.

Modify a User Group

>

To modify an existing user group:

Choose User Management > User Group List. The Group List page
opens (as shown in Display a List of User Groups (on page 62)).

Click the Group Name of the group you want to edit. The Edit Group
page opens. It looks exactly like the New Group page (as shown in
Create a User Group (on page 63)).

You can change any of the fields except the Group Name field.

Click OK when finished. The user group is modified.

Delete a User Group

>

To delete an existing User Group:

Choose User Management > User Group List. The Group List page
opens (as shown in Display a List of User Groups (on page 62)
section).

Select the checkbox to the left of the user group you want to delete.
You can select more than one.

Select Delete. You are prompted to confirm the deletion. Click OK.
The selected user group is deleted.
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Remote Authentication
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Configuring RADIUS

You can use Remote Dial-In User Service (RADIUS) to authenticate SX
users instead of local authentication. To configure RADIUS:

1. Choose Setup > Remote Authentication. The Remote
Authentication page opens, displaying a RADIUS panel.

'@} Radius
Primary Radius

IP Adddress:
1100.100.100.100 |

Port:
1812 |

Secret:

|:| Secondary Radius

IP Address:
0.0.0.0 |

Port:
11812 |

Secret:

2. Inthe RADIUS panel, click the RADIUS button to enable RADIUS
authentication.

3. Under Primary Radius, type the following information:
= |P address of the RADIUS server
= Port on which the RADIUS server is listening (default is 1812)
= Shared secret

4. If you have a backup RADIUS server, enter the same information in
the Secondary Radius fields.
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5. Click OK. RADIUS authentication is enabled.

Configuring LDAP

i

Raritan.

You can use the Lightweight Directory Access Protocol (LDAP) to
authenticate SX users instead of local authentication. To configure
LDAP:

1. Choose Setup > Remote Authentication. The Remote
Authentication page opens, displaying an LDAP panel.

O Lpap Secondary LDAP

LDAPS Certificate Settings IP Address:

Primary LDAP

IP Address: Port:

Port: Secret:

Secret: Base DH:

1

Base DH: Query:
]

Query: Search:

Search: Dialback Ouery String:

Dialback Query String:

2. Inthe LDAP panel, click the LDAP button to enable LDAP
authentication.

3. Under Primary LDAP, type the IP address of the LDAP server and
the port it is listening on (default is 389) in the IP Address and Port
fields.

4. Type the root password to access the directory server/manager in
the Secret field. The name for this field depends on the Directory
Server. For example, Microsoft Windows Active Directory® refers to
the field as Password, while the SUN iPlanet directory server uses
Secret.

5. Type the 'root' point to bind to the server in the Base DN field. This is
the same as Directory Manager DN (for example, BaseDn:
cn=Directory Manager).

6. Type a string in the Query field. Make sure the same string is added
as an attribute in the Search field. For example, if the authorization
query string is SX, an attribute named SX must be added under the
given domain specified by the Search field. On top of that, a user
group must have been created in SX to map with the one in
Windows Active Directory for these configurations to work correctly.
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7.

10.

Type the domain name where the search starts in the Search field.
The Search field is the sub-tree of the Base DN to direct the search
to the path of the user information such as UID and speed up search
time. In other words, it is the domain name. This is where the search
starts for the user name. The user name is created in this domain
(for example, Search: dc=raritan, dc=com) to process LDAP
authentication queries from SX.

If you are using a modem to connect to the LDAP server, type a
dialback string in the Dialback Query String field.

If you have a backup LDAP server, enter the same information in the
Secondary LDAP fields.

Click OK. LDAP authentication is enabled.

Configuring TACACS+

You can use the Terminal Access Controller Access-Control System
Plus (TACACS+) to authenticate SX users instead of using local
authentication. To configure TACACS+:

1.

Choose Setup > Remote Authentication. The Remote
Authentication page opens, displaying a TACACS+ panel.

O TACACS+
Primary TACACS+
IP Adidress:

0.0.0.0 |

Port:

43

Secret:

Secondary TACACS+

IP Address:

0000 |

Port:

|48

Secret:

In the TACACS+ panel, click the TACACS+ button to enable
TACACS+ authentication.

Under Primary TACACS+, type the IP address of the TACACS+
server and the port on which it is listening (default is 49) in the IP
Address and Port fields.

=¥ oo
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4. Type the root password to access the directory server/manager in
the Secret field. The name for this field depends on the Directory
Server. For example, Microsoft Windows Active Directory® refers to
the field as Password, while the SUN iPlanet directory server refers
to it as Secret.

5. If you have a backup TACACS+ server, enter the same information
in the Secondary TACACS+ fields.

6. Click OK. TACACS+ authentication is enabled.
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Port Keywords

i

Raritan.

You can create port keywords and associate them with:
e Events

e Local/remote syslog messages

e SNMP traps

Port keywords work as a filter. If a keyword is detected, a corresponding
message be logged in a local/NFS port log. A corresponding event is
sent via SMTP (if configured) and corresponding trap is sent via SNMP
(if configured).

Port keywords are useful for notifying administrators if a particular event
occurs on a port, but they do not affect NFS log sizes.

Note: The SMTP notification (event.amp.keyword) is selected from the
Event configuration page.

Note: For keywords to trigger when no users are connected to the port,
"Always Active" in port configuration should be set to True. See Port
Configuration (on page 74) for details.

1. Choose Setup > Port Keywords. The Port Keywords page opens.

Keyword:
|

Port{s):

1
ﬁ Cancel

Keyword List

2. Type a keyword in the Keyword field.
3. Type the Port(s) you want to associate with that keyword.
4. Click OK.
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Port Configuration

Pert Contiguration

Pori2

> To configure one or more ports:

1. Choose Setup > Port Configuration. The Port Configuration page

opens.

Application Baud Rate Parity Bits Xon /X off HW Flow
RartanCeonscle SE00 MHores Enabled Cisabled
RartanConsole 3600 Mcnes Disabiled Disabled |
RartanConzoie 3600 MicwneE Dizabaled Cizabled

RartanConzoke 9600 Mones Dizsblad Disabla |

Select All

Select the port(s) you want to configure. You can select one port or
several ports, providing that all selected port configurations are
identical.

= To select specific ports, click the checkboxes to the left of the
port numbers and then click Edit.

= To select all ports, click Select All.
The Edit Port page opens.

Make sure the port values match the target system's serial port
configuration for the first three values.

= Select the value of Bits Per Second from the Bits Per Second
drop-down menu.

= Select the Parity Bits from the Parity Bits drop-down menu.
= Select the Flow Control from the Flow Control drop-down menu.

In the Detect field, indicate whether you want the SX to detect or not
detect the physical connection to the target. The default is Do Not
Detect. Change this by selecting Detect Physical Connection to the
Target from the drop-down menu in the Detect field.

Type a command in the Exit Command field, for example, logout.
This is the command that is sent to your system when a user with
write permission disconnects from the port. The main function of
this command is to ensure that the user's session on the target
machine is closed; however, it is not imperative to have an Exit
command configured on a port.

Select the Escape Mode. The default is None. The escape sequence
affects only the CLI .  When entering the escape mode, the user is
given a menu of commands that can be performed (for example,
gethistory, power commands, and so forth), a command to return to
the port session, and a command to exit the port connection.

Change as follows:

=¥ oo
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= Select control from the drop-down menu in the Escape Mode
field.

= Type the character in the Escape Character field. The default for
the SX is ] (closed bracket).

Note: See Configuring Ports (on page 186) for details on port
configuration commands.

Select the terminal emulation type from the drop-down menu in the
Emulation field. The choices are:

= VT100
= VT220
= VT320
= ANSI

Set Encoding if you want the RSC for this port to always use a
specific character encoding. It overrides the global RSC setting for
this port to whatever value you set. The choices are:
DEFAULT,US-ASCII,ISO8859-1, 1ISO8859-15,UTF-8, Shift-JIS,
EUC-JP, EUC-CN, EUC-KR.

If you need to configure the length of the send break signal for
targets that require a short or longer sendbreak duration, enter the
send break time in the Send Break Duration field. The send break is
configurable from 100ms - 1000ms in 100ms increments.

If you plan to use Direct Port Access (DPA), you must enter either an
IP address or one/both of the following TCP ports, depending on
your choice of the DPA service mode:

= The port number, such as 7700, in the DPA SSH TCP Port field

= The port number, such as 8800, in the DPA Telnet TCP Port
field.

In the Always Active field, indicate if you want to log activities coming
into a port even if no user is connected. The default option is Do not
maintain port access without a connected user, which means: ignore
data coming into a port when no user is connected. Change by
selecting Maintain port access continuously from the drop-down
menu in the Always Active field. This option is for NFS port data logs.

Note: When no users are logged into a port session, port traffic, by
default, is discarded .

Select none or all from the drop-down menu of Messages
suppressed field to indicate if any message should be displayed
during a DPA connection, such as "Authentication successful."
Otherwise, it goe directly to the port without displaying any message.
The default is none.

Note: Anonymous access should be enabled for DPA to succeed.
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13.

14.

Select from the Multiple Writers drop-down if you want multiple
clients to be able to write to the port at the same time. The default
behavior is that only one user may have write access to the port at a
single time.

Click OK.

Direct Port Access

To configure direct port access:

Choose Setup > Services. The Network Service Settings page
opens.

In the Direct Port Access Mode field, the default is Normal, which
means CLI DPA access is disabled. To enable DPA, select either IP
or TCP Port from the drop-down menu.

Click OK to save this information. The page displays the following
message: "Reboot for the changes to take effect.”

You may reboot now if you have already set up the ports for DPA or
are otherwise prepared for the DPA mode to become effective.

Choose Setup > Port Configuration. The Port Configuration page
opens (as shown in Port Configuration (on page 74)).

Select the ports to configure for direct port access:

= To select specific ports, click the checkboxes to the left of the
port number. You can select more than one. When you have
finished, click Edit.

= To select all the ports, click Select All.

The Edit Port Configuration page opens (as shown in Port
Configuration (on page 74)). The DPA fields are at the bottom of the

page.

Type the DPA IP address of the SX and the DPA ports used for SSH
and Telnet in the appropriate fields.

Click OK.

Reboot the SX. This is necessary for the direct port access settings
to take effect.

i
i
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Direct Port Access via Username for SSH and Telnet

You are able to configure direct port access for SSH and Telnet based
on username.

>

To enable direct port access via username for SSH and Telnet:

Choose Setup > Services. The Network Service Settings page
opens.

Select the "Allow DPA via the username for SSH/Telnet" checkbox.

Direct Port Access Mode: 3

IP -

Allow DPA via the username for 55HTelnet. r’
. A - adhin Mt ‘ * R

Click OK to save this information. The page displays the following
message: "Reboot for the changes to take effect.”

You may reboot now if you have already set up the ports for DPA or
are otherwise prepared for the DPA mode to become effective.

With the DPA for username setting, it automatically applies to all
ports without needing any configuration.

To access a port with this username based DPA, use the following
ssh command to connect to the SX: ssh -l name[:porthname/number]
where name is the username, portname is the port name and
number is the port number.

Direct Port Access via HTTP

i

Raritan.

You can connect directly to a port on the SX without having to log in to a
GUI interface by using HTTP.

>

To access the a SX port using HTTP:
Use the following address:

http://<sxIPAddress>/dpa.php?username=<SXUserName>&passwor
d=<SXPassword>&port=<PortNumber>
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Anonymous Port Access

Anonymous port access allows users to access DPA configured ports
without entering a password.

» To enable the feature:

Choose Security > Login Settings. The Login Settings page opens
(as shown in Login Settings (on page 107)).

2. Make sure the Anonymous Port Access checkbox at the bottom of
the page is selected.

3. Click the User Management tab, and the click User Group List. The
Group List appears (as shown in Display a List of User Groups (on
page 62)).

Note: See User Profiles and Groups (on page 58) for additional
information about user groups.

4. The Anonymous Group automatically appears in the User Group
List.

5. The default group belongs to Operator class and has no port
permission assigned.

6. Select the ports for which you want anonymous port access in the
Port Access field.

7. Click OK.

Raritan Serial Console

Use the following steps to launch the Raritan Serial Console (RSC).

1. Click the Port Access tab.

Port Access

i No Hame Status

Port1 -RedHaiLinux?

1
2 Port2-RedHalLinu:
3 Port3

4 Postd

5 Ports
]
7
8

Ports
Port?-HPE000 Switch

SlE|E|5 5 555

PortS

2. Click the Name of the port you want to access for the RSC, for
example, Portl or Port2. Firefox users are prompted to enter the
personal client certification key.

=¥ oo
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Note: A Security message appears only if you use HTTPS to connect
to the RSC.

Click Yes. A Warning - Security pop up appears.

4. Click Yes to access the Raritan Serial Client from the Port page.

Note: If you click Always, security pop up is displayed when the SX is
accessed in the future.

The Raritan Serial Console window appears. See Raritan Serial
Client Interface (see "Raritan Serial Console Interface" on page
82).

Raritan Serial Console Requirements for Java

)
i

Raritan.

The Raritan Serial Console (RSC) requires a PC of minimum 1.0 GHz
CPU speed with 512 MB RAM. Java™ must be installed to access targets
(managed devices) before you can use the RSC.

Java Runtime Environment (JRE)

The RSC functions with JRE™ version 1.4.2_05 or later (except for JRE
version 1.5.0_02). However, for optimum performance, Raritan
recommends using JRE 1.5.0 (except for version 1.5.0_02).

Depending on your operating system and browser, it is possible that you
must adjust JRE configurations to prevent problems with the system's
memory.

Note: Raritan does not support JRE version 1.5.0_02 for use with the
RSC.

JRE provides configuration instructions with the JRE download.
Determine the JRE version on your system by going to the Java™ Web
page at:

http://www.java.com/en/download/help/testvm.xml
(http://lwww.java.com/en/download/help/testvm.xml \o
http://www.java.com/en/download/help/testvm.xml)

IMPORTANT: When launching RSC from a browser, Raritan highly
recommends that Java Applet Caching be disabled and that you
perform the following steps to make sure that Java does not create
problems for the system's memory.
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Java Applets and Memory Considerations

Usually, a browse- based RSC does not need to make any changes to
the Runtime parameters for Java™ Applets. Following these steps if you
notice any "Out of Memory" errors happening when executing RSC via a
web browser:

Change the Runtime settings for Java Applets.

Use the following links to find out how to use Runtime settings in the
Java Control Panel.

http://java.sun.com/j2se/1.5.0/docs/guide/deployment/deployme
nt-guide/jcp.html
(http://java.sun.com/j2se/1.5.0/docs/guide/deployment/deployme
nt-guide/jcp.html)

http://java.sun.com/j2se/1.4.2/docs/guide/plugin/developer_guid
e/control_panel.html
(http:/fjava.sun.com/j2se/l.4.2/docs/guide/plugin/developer_guid
e/control_panel.html)

To increase the heap settings so that more RSC applets can be
launched to access multiple SX targets:

1.

£ Java Runtime Settings

Launch the Java Control Panel, located in the:
= Advanced Tab in JRE™ 1.4.x
= Java Tabin JRE 1.5

Locate Java Runtime Settings.

Java Runtime Versions

Product Name Version

Location Java Runtime Parameters

RE 15.0_03

+\Program Files\Javaljre1.5.0_03

CilProgram Fles\Javalirel.5.0 06 VR v N e

Insert the values of the Java Runtime Parameters using the syntax in
the following table, which contains the non-standard options.

Values - Syntax Description Default/Comments
-Xms<Size> Sets the initial 2097152 (2MB)

in bytes size of the

= The -server flag increases the

Java heap default size to 32M.

= The values must be a multiple of,
and greater than, 1024 bytes
(1KB).

= Append the letter “m” or “M” to
indicate megabytes and “k” or

=&=Raritan.
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Values - Syntax Description Default/Comments
“K” to indicate kilobytes.

-Xmn<Size> Sets the initial 640K
in bytes nga heap = The -server flag increases the
size for the default size to 2M
Eden '
generation = Append the letter “m” or “M” to
indicate megabytes and “k” or
“K” to indicate kilobytes.
-Xmx<Size> Sets the 64M
in bytes maximum size The -server flag increases the
to which the default size to 128M
Java heap can '
grow =  The maximum heap limit is

approximately 2 GB (2048MB).

= Append the letter “m” or “M” to
indicate megabytes and “k” or
“K” to indicate kilobytes..

Command Example:
-Xms128M -Xmnl28M -Xmx512M

See the following links for additional information and for all the
non-standard options:

http://java.sun.com/j2se/1.4.2/docs/tooldocs/windows/java.html
(http:/ljava.sun.com/j2se/l.4.2/docs/tooldocs/windows/java.html)

http://java.sun.com/docs/hotspot/VMOptions.html
(http://java.sun.com/docs/hotspot/vmoptions.html)
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Raritan Serial Console Interface

Important: The Raritan Serial Console page usually opens in a
separate window behind the Port page. With some versions of
Java™ on the Windows® operating system, the page opens in front

of the Port page.

Raritan Serial Console: Serial Port 7 (15)

Emulator Edit Tools Chat Help
Connecting at 'sxp://1l9Z.168.61.5Z:5000/15"'
Successfully Connected!

[ Write Access Code Set: UTF-8 Logging: off Users: 1

82 =i=Raritan.
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Emulator

1. Click the Emulator drop-down menu to display a list of topics.

5;25 Raritan Serial Console: Serial Poxt 7 (15)

Emulator ‘_ Edit Tools Chat Help

Settings...

Get History
Clear History

Get Write Lock

Send Break
Connected Users...

Exit

[ write Access Code Set: UTF-8 Logging: off Users: 1

IMPORTANT: RSC sessions are affected by the Idle Timeout which
is set, by default, to 10 minutes for security purposes. If you have
not changed the Idle Timeout setting from the default, your RSC
session could be closed automatically if your RSC configuration
time exceeds the Idle Timeout period. See Security (on page 106)
for details on changing the Idle Timeout setting.

Warning

OK

1. Change the default Idle Timeout setting and then launch the RSC.

83



84

Chapter 7: Port Configuration and Port Access Application

Note: If the RSC Idle timeout expires, the SX Idle timeout period
begins.

Settings

Note: An Administrator can set Terminal emulation settings using
Setup > Port Configuration.

1. Choose Emulator > Settings. The Settings screen displays the
General tab with the default settings.

Settings: Serial Port 1 (9)
ﬂ General ] Display

GUI Interface

Main Menu Shortcut: Show Confirmation Dialog on Exit

Hone A 4

Terminal Compatibility
Terminal Size: History Buffer Size:

8025 v 2001

Backspace Sends:

ASCI DEL v

Cursor type
i@ Block Cursor

yLine cursor

0Ok Cancel Default

2. The Main Menu Shortcut default is None; accept this, or choose one
of the following from the Main Menu Shortcut drop-down menu:

= F10
= Alt

3. The Show Confirmation Dialog on Exit checkbox is selected by
default, but you can deselect it based on preference.

=¥ oo

=Raritan.
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4. The Terminal Size default is selected, or you can choose a different
size from the drop-down menu.

5. The Backspace Sends default is ASCII DEL, or you can choose
Control-H from the Backspace Sends drop-down menu.

6. The History Buffer Size default is 200, or you can use the arrows to
change the buffer size.

7. The Cursor type default is Block Cursor, or you can select the Line
Cursor radio button.

8. Click OK.

Display Settings
1. Choose Emulator > Settings and click the Display tab.

Settings: Serial Port 7 (15) (%]
" General ['::—Displaltr

-Font Directories-

G

l Terminal Font Properties GUI Font Properties ‘

iMonospaced ]
[Monospaced -
!NSimSun Font size:
Raavi L :E“
Shruti 1=
SimHei =
rColors | rLocale
Encoding:
Foreground: Background: luTF-s l v ‘
]
\Englisn I'I
Preview

Font Preview

0k Cancel Default

2. Click Default to accept the Default settings, and then click Ok to
close the Display Settings window. To change the settings, follow
these steps:

Raritan. 8
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a. The Terminal Font Properties default is Arial, or you can choose a
font from the Terminal Font Properties scrolling list.

b. The Antialiase Font checkbox is selected by default, or you can
deselect the checkbox.

c. To change the font size, select the Lock Font Size checkbox and
then use the arrows to choose a font size in the the Font size field.

d. Click the GUI Font Properties tab

e. The default font property is Monospaced, or you can choose a font
from the GUI Font Properties scrolling list.

Settings: Serial Port 7 {15) %]
( General [:_Displa]r

-Font Directories-

EE

] Terminal Font Properties " GUL Font Properties

iMonospaced
lMonospaced
INSimSun
Raavi

Shruti
SimHei

[»

«[ Tl

rColors | rLocale

Encoding:

Foreground: Background: [UTF-Q , v}

| [English i v { |

0Ok Cancel Default

Note: For Simplified Chinese characters, Raritan Serial Console
supports EUC-CN encoding system.

3. Choose the following from their respective drop-down menus:

= Foreground Color

=&=Raritan.
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= Background Color
4. Choose one of the following from the Encoding drop-down menu:
= US-ASCII
= |SO-8859-1
= |S0O-8859-15

5. Choose one of the following from the Language drop-down menu:

= English

= Japanese
= Korean

= Chinese

6. Click Ok to close the Display Settings window. If you changed the
Language setting, the RSC changes to that language when the
Display Settings window is closed.

Note: In case of unrecognized characters or blurry screens that might
appear when RSC is launched, due to localization support, try changing
the font to Courier New.

Get History

History information can be useful when debugging, troubleshooting, or
administering a target device. The Get History feature:

e Allows you to view the recent history of console sessions by
displaying the console messages to and from the target device.

e Displays up to 256 KB (64KB only on models with 64MB SDRAM,;
256KB available on 128MB SDRAM Models) of recent console
message history. This allows a user to see target device events over
time.

When the size limit is reached, the text wraps, overwriting the oldest data
with the newest.

Notes: Verify the memory on your unit from the Maintenance >
Configuration menu. History data is displayed only to the user who
requested the history.

To view the Session History, choose Emulator > Get History.

Clear History
= To clear the history, choose Emulator > Clear History.
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Get Write Access

Only Administrators and Operators can get write access. The user with
Write Access can send commands to the target device. Write Access
can be transferred among users working in the Raritan Serial Console
via the Get Write Access command.

To enable Write Access, choose Emulator > Click Get Write Access.
e You now have Write Access to the target device.
e When another user assumes Write Access from you:

= The RSC displays a red block icon before Write Access in the
status bar.

= A message appears to the user who currently has Write Access,
alerting that user that another user has taken over access to the
console.

Get Write Lock

Write lock prevents other users from taking the write access while you
are using it.

1. To get write lock, choose Emulator > Get Write Lock.

2. If Get Write Lock is not available, a request rejected message
appears.

Write Unlock
To get Write Unlock, choose Emulator > Write Unlock.

Send Break

Some target systems such as Sun Solaris servers require the
transmission of a null character (Break) to generate the OK prompt. This
is equivalent to issuing a STOP-A from the Sun keyboard.

e Only users with Administrator privileges can send a break.
e Users who are Observers cannot send a break.
To send an intentional “break” to a Sun Solaris server:

1. Verify that you have Write Access. If not, follow the instructions in the
previous section to obtain write access.

2. Choose Emulator > Send Break. A Send Break Ack
(Acknowledgement) message appears.

3. Click OK.

i
i
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Connected Users

The Connected Users command allows you to view a list of other users
who are currently connected on the same port.

1. Choose Emulator > Connected Users.

== Connected Use erial Po 8 m
User Nane Write Access
admin
Close

2. A check mark appears in the Write Access column after the name of
the User who has Write Access to the console.

3. Click Close to close the Connected Users window.
Exit

1. Choose Emulator > Exit to close the Raritan Serial Console. The
Exit Confirmation dialog appears.

2. Click Yes.
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Edit

Use the Copy, Paste, and Select All text commands to relocate and/or
re-use important text.

&5 Raritan Serial Console: Serial Port 7 (15)
Emulator EdJ.t Tools Chat Help

E

1
,;5 | Copy ‘

Connecting Paste 168, S000/15' please wait ...

ERLLEEESR Select ALl

I

[ write Access Code Set: UTF-8 Logging: off Users: 1

To copy and paste all text:

Choose Edit > Select All.

Choose Edit > Copy.

Position the cursor at the location where you want to paste the text.

Click once to make that location active.

a c 0N =Y

Choose Edit > Paste.

90 =¥ o
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Note: The copy-paste limit of text in Raritan Serial Console is 9999 lines.

Keyboard shortcuts to highlight, copy, and paste all or partial lines of
text:

e Click and drag your mouse over the text you wish to copy.
e Use Ctrl+C to copy text.

e Position the cursor where you want to paste the text and click in that
location to make it active.

e Use Ctrl+V to paste text.

Tools

Click the Tools drop-down menu to display a list of topics.

Raritan Serial Console: Serial Port 7 (15)

Emulator Edit |Tools Chat Help
= =, G e
o Start Logging ‘

Connecting at 'k GaLIYg £:5000/15' please wait ...

PGS PNRE S Send Keystroke
D Send Text File
Toggle Power

[ write Access Code Set: UTF-8 Logging: off Users: 1

=i=Raritan
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Start Logging

The Start Logging function allows you to collect raw console data from
the target device and save it to a file on your computer. When you start
RSC, the Logging indicator on the status bar indicates whether logging is
on or off.

1. Choose Tools > Start Logging.

2. Choose an existing file or provide a new file name in the Save RSC
Log dialog.

= When an existing file is selected for logging, data gets appended
to the contents.

= |f you provide a new file name, a new file is created.

Save In: | My Documents - D E

File Name: ﬂ

|
Files of Type: |Log Files l v]

I Save H Cancel ’

3. Click Save after selecting or creating a file.

=i=Raritan.
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Choose Tools > Stop Logging. The logging stops.

Send Keystroke

1. Choose Tools > Send Keystroke. A Send Keystroke dialog appears:

Send KeyStroke: Serial Port 1 (9)

Keystroke combination:

None
l:] Ctrl [] Alt D Shift
Key code:
None v
Send Clear Cancel

2. Enter the keystroke combinations that you want and select a Key

Code name from the drop-down menu.

3. Send the keystroke combinations.

Send Text File

1. Choose Tools > Send Text File. A Send Text File screen appears.

Open the directory of the Text file.

2
3. Click on or enter the File Name of the Text file.
4

Click Open.

= When you click Open, it sends whatever file you selected directly

to the port.

= If there is currently no target connected, then nothing will be

visible on the screen.

If there is a loopback plug inserted, you will see the file displayed.
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Toggle Power

The Toggle Power function lets you power on or off the device that is
connected to the associated outlet on a Power Distribution Unit (PDU).
For example, if a router is connected to one of the outlets on the PDU,
you can toggle the router’s power on or off.

You must configure the association of outlets to the target port of the
device before you can use the Toggle Power feature. Assign a power
port to the serial target from the Device Settings > Port Configuration tab
of the device. If you have not done this, the system displays a message
stating that the target is not associated with a power outlet.

Note: If RSC is launched through CC-SG (version 4.x onwards) by users
without the permission to toggle power, the option Toggle Power will
appear as disabled.

1. Select Toggle Power to turn the device (router) on or off. A prompt
appears displaying the current status of the outlet(s). You can turn
the device on or off depending on its current status.

If you select No, the system returns you to the RSC screen.

3. If you select Yes, the system sends the power command to either
turn on or off the outlets associated to the target port of the device.

If you receive a:
e Hardware error message: this means that the PDU command failed.

Software error message: this means that another user is controlling the
power outlet and the power control command cannot be sent.



Chapter 7: Port Configuration and Port Access Application

Chat

When using browser access over SSL, an interactive chat feature called
Chat allows you and other users on the same port to communicate. The
maximum length of a chat message is 300 characters.

Note: When a chat is initiated, a chat window appears on the monitors of
all SSL users logged on to the port. If a user is logged into a port multiple
times, multiple chat messages do not appear to that user.

> To open chat:
e Choose Chat > Chat.

Chat: Serial Port 1 (9)

w

Message: Remaining: 300

-

<]

l Send || Clear H Close

> To clear text in a chat text box:
e Click Clear to delete the typed text.
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Help

Help Topics include online assistance for operating the Raritan Serial
Console and release information about Raritan Serial Console.

Help Topics

> To access help topics:
e Choose Help > Help Topics. A list of help topics are displayed.

About Raritan Serial Console

The About Raritan Serial Console dialog displays the copyright and
version information (name and revision number) of the console terminal
emulation software. When contacting Raritan for technical support or
when performing a software upgrade, you may be asked for this
information.

» To access 'About’ information:

e Choose Help > About Raritan Serial Console. An About Raritan
Serial Console message appears.

Standalone Raritan Serial Console Installation

Note: You can download the Standalone Raritan Serial Client from the
Raritan support Web site: http://www.raritan.com/support
http://www.raritan.com/support

The standalone Raritan Serial Client (RSC) is used to make direct
connections to the target without going through the SX application. The
user specifies the SX address and the port number (target) and then is
connected.

The steps in this section install the standalone Raritan Serial Client
(RSC).

i
i
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Standalone Raritan Serial Client Requirements

;

Raritan.

The following requirements must be met to support the Raritan Serial
Console:

The RSC functions with JRE™ version 1.4.2_05 or later (except for
JRE version 1.5.0_02) . However, for optimum performance,
Raritan recommends using JRE 1.5.0 (except version 1.5.0_02).

Your system may require configuration adjustments depending on
the operating system and browser. The JRE provides configuration
instructions with the JRE download. See
http://www.java.com/en/download/help/testvm.xml
(http://www.java.com/en/download/help/testvm.xml \o
http://www.java.com/en/download/help/testvm.xml) to determine
the JRE version currently installed on your system.

If you do not have a compatible version of the JRE, go to
http://www.java.com (http://www.java.com) and click the
Download Now button.

Note: Raritan does not support JRE version 1.5.0_02 for use with the
RSC.

Minimum 1 GHz PC with 512 MB RAM.

Ensure that Java™ can be started from the command line. To do this,
you must configure environment variables. Make a note of the
exact path where Java was installed (the path information is used
later).

Setting Windows OS Variables
1. Choose Start > Control Panel > System.
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2. Click the Advanced tab and then click Environment Variables.

System Properties

In the System variables section, click New.

In the New System Variable dialog, add JAVA_HOME to the Variable
name block and the path you wrote down earlier in the Variable
value block.

5. Click OK.
Select the PATH variable and click Edit.

7. Add %JAVA_HOME%\bin to the end of the current Variable value.
Ensure a semicolon (;) separates the new value from the last value
in the string.

% ==Raritan.
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8. Click OK.

Edit System Yariable

PATHEXT .COM; EXE; BAT;.CMD; . VBS;.VBE;.
PROCESSOR_A... x86

PROCESSOR_ID... x86 Family 15 Model 3 Stepping 4, Genu. ..
PROCESSOR_LE... 15 3

9. Select the CLASSPATH variable and click Edit.

10. Ensure the CLASSPATH Variable value is configured properly; that
is, its value must have a period (.) in it. If, for any reason, there is no
CLASSPATH variable defined, create one.

B Edit System Yariable

CQLASSPATH

B-:\Program Fies\Javalyre1.5.0_06\iblex!

=& Raritan. %
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Setting Linux OS Variables

To set Java™ for a specific user, open and edit the .profile file located in
the /home/Username folder.

To set Java for all users, open the .profile file in your /etc folder:

1. Find the line where you set your path:

3.

export

PATH=S$SPATH: /home/username/somefolder

Before that line you must set your JAVA_HOME and then modify
your PATH to include it by adding the following lines:

export
JAVA HOME=/home/username/j2sdkl.6/
export PATH=$PATH:$JAVA HOME/bin

Save the file.

Setting UNIX OS Variables

To check the latest JRE™ version on Sun Solaris™:

1.
2.

Launch a terminal window on the Sun Solaris desktop.

Type java-version in the command line and press Enter. The
currently-installed version of Java™ Runtime Environment (JRE)
appears.

= |f your path variable is not set to where the Java binaries have
been installed, you may not be able to see the JRE version.

= Assuming JRE 1.6 is installed in /usr/local/java: you must set
your PATH variable.

= To set a path for the bash shell:

export

PATH=$PATH: /usr/local/java/j2rel.6/bin

= To set path for tcsh or csh:

set

PATH = ($PATH /usr/local/java/j2rel.6/bin)

= These commands can either be typed at the terminal each time
you log in, or add them to your .bashrc for bash shell or .cshrc
for csh and tcsh so that each time you log in, the path is already
set. See your shell documentation if you encounter problems.

If the JRE is version 1.6 or later, proceed with the RSC installation. If

the JRE is an older version than 1.6, go to the Sun website at
(http://java.sun.com/products/) to download the latest Runtime
Environment.

==
— $ s
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Installing Standalone RSC for Windows

You must have administrative privileges to install RSC.

1.
2.

Log in to a Windows® machine.

Download, or copy from a known location, the RSC-installer.jar
installation file.

Double-click on the executable file to start the installer program. The
splash page opens.

Click Next. The installation path page opens.
Change the path, if desired.

Click Next. The installation progress page opens.

Note: The standalone version of RSC is available from the Raritan
Support website:
http://www.raritan.com/support/sup_upgrades.aspx
(http://www.raritan.com/support/sup_upgrades.aspx)

o% IzPack - Installation of Raritan Serial Console

&9 Pack installation progress:

ﬁ Overall installation progress:

{Made with IzPack - http:fjwaww.izforge.com/)

[Finished]

@rrevions | [ Qnext ][ €9 Quit ]

i
i
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7. Click Next. The Windows shortcut page opens.

@8 IzPack - Installation of Raritan Serial Console E] @

Select a Program Group for the Shorkcuts:

\Accessories A
‘Administrative Tools

\Adobe

|America Online create shortcut for
(Cisco Systems VPN Client
CWSNT [
[Dell Accessoties | @Whaluserg
Dell Wireless

(Games

|Google Desktop <

() current user

;RaritanSeriaICOnsole ‘ | Reset |

Create shortcut on the desktop

{Made with IzPack - http:/fwww.izforge.com/) -

[ () Previous ]] €) Next ][ €3 Quit ]

8. Select the Program Group for the Shortcut.
9. Click Next. The installation finished page opens.
10. Click Done.

=i=Raritan.
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Launching RSC on Windows Systems

1. Double-click the shortcut or use Start Programs to launch the
standalone RSC. The Raritan Serial Console Login connection
properties dialog appears.

= Raritan Serial Console Login

Fnter connection properties:

User Name: Password:

Host Address: TCP Port:
192.168.51.183 | |5000

Start

2. Enter the Dominion SX IP address, account information, and the
desired target (port).
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3. Click Start. The RSC opens with a connection to the port.

# Raritan Serial Console: Port? -RodHstl inux (2]

Frulalcs B8 Tools Chal  Help
-
- e

m X

B Write Access  Code et USASCE  Line: @ Colurn: 1 Logging off  Users 1

Note: In case of unrecognized characters or blurry screens in RSC
window due to localization support, try changing the font to Courier
New. Choose Emulator > Settings > Display, and select Courier
New for Terminal Font Properties or GUI Font Properties.

Installing RSC for Sun Solaris and Linux

104

You must have administrative privileges to install RSC.
1. Log in to your Sun Solaris™ machine.

2. Download, or copy from a known location, the RSC-installer.jar
installation file.

3. Open aterminal window and change to the directory where the
installer is saved.

4. Type java -jar RSC-installer.jar and press Enter to run the installer.

Click Next after the initial page loads. The Set Installation Path page
opens.

a. Select the directory where you want to install RSC and click
Next.

b. Click Browse to navigate to a non-default directory.

c. Click Next when the installation is complete.

=¥ oo
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d. Click Next again. The installation is complete. The final page
indicates where you can find an uninstaller program and
provides the option to generate an automatic installation script.

Click Done to close the Installation dialog.

Launching RSC on Sun Solaris

;

Raritan.

1.

a > D

Open a terminal window and change to the directory where you
installed the RSC.

Type ./start.sh and press the Enter key to launch RSC.
Double-click on the desired device to establish a connection.
Type your Username and Password.

Click OK to log in.
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Security

In This Chapter

SECUIMLY SELINGS....iiiteiiiie e et e e s a e e e s e rareaee s 106
LOGIN SEHINGS ..ottt e et e e e e e e e e e s et e e e e e e e e aans 107
Configure KErbEIOS .....uvviiiii ettt 109
CertifiCates. ..o, 110
SSL Client CertifiCate .........cooiiiiiiiiiiie e 114
BaNNET e 118
SECUNLY Profil@S....cciiiiiiiiiiit e 119
FIFEWALL ... 120

Security Settings

Choose the Security tab to view security-related tools. The Security
Settings page opens.

Security Settings

Login Settings
Kerberos

Certificate

SSL Client Certificates
Banner

Security Profiles

Firewvall
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Login Settings

e Choose Security > Login Settings. This panel includes Local
Authentication, Login Handling, and Strong Password Settings.

Local Authentication Strong Password Settings

Enable Local Authentication D Strong Passwords Required for All Users
Minimum Password Length:

Inactive Login Expiry (days): l::: |

!330 ‘ Maximum Password Length:

s
Invalid Login Retries: [13 I

‘3 l Password Reuse Restriction:

Lockout Period on Invalid Login (minutes):

is | Password Expiration Period:

[=11]
Strong Password Requirements:
Passwords must contain at least one lower case letter
Passwords must contain at least one upper case letter
Passwords must contain at least one number

Passwords must contain at least one special character

Login Handling

User ldle Timeout (minutes):
0 |

D Single Login per User

Anonymous Port Access

Port Access Mode:
‘ Share ™ }

I 0K I | Cancel

Local Authentication

1. Go to the Local Authentication panel and select the Enable Local
Authentication checkbox.

2. The system displays these defaults in the following fields:
= Inactive Login Expiry (days): 330
= Invalid Login Retries: 3

= Lockout Period on Invalid Login (minutes): 5
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3. Accept the system defaults or type your own.

Login Handling

1. Go to the Login Handling panel and enter a value in the User Idle
Timeout (minutes) field. This is the length of inactive time, after
which the user is timed out. Default time is 10 (minutes).

Note: If no port connections are established from CC-SG to SX
within the configured time of User Idle Timeout, service sessions
from both devices are disconnected.

2. To enable single login only, select the Single Login per User
checkbox. Only one user can log in at a time using the same profile.

3. Select the Anonymous Port Access checkbox to turn this feature on.
An Anonymous User Group is created by default and it cannot be
deleted, even by the Administrator. It is visible in the Group List if
Anonymous Port Access is selected, but invisible in Group List if
Anonymous Port Access is deselected.

Note: See Port Configuration and Port Access Application (on
page 72) for additional information about anonymous port access.

4. Select Share in the Port Access Mode drop-down menu if port
access should be shared, allowing users to connect to the port while
another user is using it. The default value is Share. Change this to
Private if you want to keep other users from connecting to a port
while a user is using it.

Strong Password Settings

To enable strong passwords, go to the Strong Password panel and
select the requirements for a strong password. This includes maximum
and minimum length and special character requirements.

Note: Passwords cannot contain " '<> \ &

108
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Configure Kerberos

i
i

Raritan.

O enatsie Kerboros
Hoats Filez
Ketlseros Configun aticn File:
Biowign
Kerheros Keytab File:
Click Enable Kerberos.

Type the name of the file you want for your Hosts File in the Hosts
File field or click on the Browse drop-down menu and select your file.

3. Type the name of the file you want for your Kerberos Configuration

File in the Kerberos Configuration File field or click on the Browse
drop-down menu and select your file.

4. Type the name of the file you want for your Kerberos Keytab File in

the Kerberos Keytab File field or click on the Browse drop-down
menu and select your file.

5. Click OK.
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110

Certificates

The Certificate feature allows you to generate a Certificate Signing
Request (CSR), install a user key on the SX, and install a user certificate
on the SX.

If you are using Firefox®, you must install a Java® client authentication
certificate. To do this, open the Java Control Panel and select Security >
Certificates. Select Client Authentication from the certificate types and
import the .p12 certificate.

This certificate does not need to be installed if you connect to a port with
another certificate.

Note: By default, SSL certificates are good for one year after they are
installed. Install a new certificate, as needed, after it expires. A warning
letting you know the certificate is expired is displayed when you access
the SX after the expiration date. You are still able to fully communicate
with the SX even after an SSL certificate expires.

i
i
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Generate a Certificate Signing Request

> To generate a Certificate Signing Request (CSR):
1. Choose Security > Certificate. The Certificate page opens.

Certificate

() Activate Default Certificate
) Activate User Certificate
'O Generate Default Certificate

(*) Generate Certificate Signing Request
Bits:
1024 v|

Hame:

Country:

State:

Larcality:

Organization:

Uniit:

Email:

Click the Generate a Certificate Signing Request radio button.

3. Click on the drop-down menu in the Bits field. Keep the 1024 default
or change it to 512.

4. Type the following in the corresponding fields:

= Name

= Country
= State

= Locality
= Unit

=  Email address

111
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5. To view the default certificate or the CSR, click the appropriate radio
buttons.

6. Click OK. The CSR is generated.

Install a User Key

> Toinstall a user key on the SX:

1. Choose Security > Certificate. The Certificate page opens.

D Install User Key

IP Address:

Lagin:

Password:

Remote Path:

Remote File:

Select the Install User Key radio button.

3. Type the following in the corresponding fields:
= |P address of the host with the key
= Login on host
= Password on host
= Remote Path containing the key
= Remote File containing the key
4. Click OK.

Note: If the SX is not used to generate the certificate signing request and
an external certificate is used instead, encryption needs to be removed
from the private key before installing it on the SX. If this is the case, to
remove the encryption from the key, a command such as openssl rsa -in
server.key -out server2.key and server2.key should be used. Encrypted
private keys are used to prevent the web server from being started by
unauthorized users. Since SX does not allow users to access the web
server directly, encrypted private keys are not required and does not
compromise security.

Note: When the SX is used to generate the certificate signing request,
the private key is not required since SX keeps the private key exclusive.

112 =
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Install a User Certificate

> To install auser certificate on the SX:

1. Choose Security > Certificate. The Certificate page opens.

'C' Install User Certificate

IP Address:

Login:

Password:

Remote Path:

Remote File:

1. Select the Install User Certificate radio button.

2. Type the following information in the corresponding fields:
= The IP address of the host with the certificate
= Login on the host
= Password on the host
= Remote Path containing the certificate
= Remote File containing the certificate
3. Click OK.

o
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SSL Client Certificate

114

SSL Security certificates are used in browser access to ensure that the
device to which you are attached is the device that is authorized to be
connected. See Appendix C: Certificates (see "Certificates" on page
274) for details on SSL Certificates. This section describes only how to
configure the certificates, but you can find additional SSL Certificate
information at:
http://www.microsoft.com/technet/prodtechnol/ie/reskit/6/part2/c06i
ebrk.mspx?mfr=true
(http://Iwww.microsoft.com/technet/prodtechnol/ie/reskit/6/part2/c06i
ebrk.mspx?mfr=true)

i
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[ Enable SSL Client Certificates

[[] mstal Certificate Authority
IP Address:

Entgwond:

Remote Path:
Remote File:

CA Name: )
D Remove Certificate Authority
CA lHame:

[ view Certificate Authority
CA Hame:

|

[[] Add Certificate Revocation List
1P Address:

]

Lo_uin: ]
Password: .
Remote Path:

Remote File:

Ul

[ |

CRL Hames

[ petete Certificate Revocation List
CRL Hame:

[[] view Certificate Revocation List
CRL Hame:

]

Enable Client Certificate Authentication

> To enable Client Certificate Authentication:
1. Select the Enable SSL Client Certification checkbox.

2. Click OK to enable the Client Certificate authentication.

115
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Install a New Trusted Certificate Authority

To install a new trusted Certificate Authority (CA) to the SX, the CA
certificate must be on an accessible FTP server.

1. Select the Install Certificate Authority checkbox.
2. Fill in the data needed to retrieve the certificate from the FTP server.
3. Click OK to retrieve and install the CA certificate to the SX.

Remove a User-Added Certificate Authority

» Toremove a user-added CA from the SX:
Select the Remove Certificate Authority checkbox.

2. Inthe CA Name field, type the name that was specified when the CA
certificate was added.

3. Click OK to remove the certificate.

View a Certificate Authority

To view a CA:

Select the View Certificate Authority checkbox.

In the CA Name field, type the name of the CA you want to view.
Click OK to retrieve the list of CAs.

w N =Y

Manage the Client Certificate Revocation List (CRL)

The SX comes with VeriSign and Thawte CA certificates and CRLs
preinstalled. If a user adds a custom CA to the SX, a corresponding CRL
should be added to keep track of revoked certificates. For the CRL to be
automatically retrieved when it expires, it should be retrievable from a
web server to which the SX can connect.

Add a New Certificate Revocation List to the SX

To add a new CRL to the SX, the CRL list must be on an accessible FTP
server.

1. Select the Add Certificate Revocation List checkbox.
2. Fill in the fields to access the FTP Server.

= The CRL Name field should match the name that was used to
add the CA.

= The URL field should be the numeric dot notation of the IP
address of the HTTP server.

==
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3. Click OK to add the CRL.

Delete a Certificate Revocation List from the SX

» To delete a CRL from the SX:
Select the Delete Certificate Revocation List checkbox.

2. Inthe CRL Name field, type the name of the CA to which this CRL
belongs.

3. Click OK to delete the CRL.

View a Certificate Revocation List

» Toview aCRL:
1. Select the View Certificate Revocation List checkbox.
2. Click OK to retrieve the list of CRLs.
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Banner

SX optionally supports a customizable welcome banner of maximum
5000 words, 8 words per row, that appears after log in. The banner
identifies where the user has logged into. SX also allows you to add a
consent banner that forces the user to accept stated conditions prior to
advancing into operation of the console server.

Note: When you are logged in to the SX via GUI, a banner using a fixed
width typeface and a common dimension like 80x25 appears. Even if the
source banner is very large, the banner displayed on the GUI does not
increase the overall page size, as it is contained within a self-scrolled
text area.

O Dizplay Restricted Service Banner

Require Acceptance of Restricted Service Banner
(# Restricted Service Banner Message:
I.I'mlhm:eﬂ access prohibited, ol access and activities not
| ecpbicitly suthorized by management are unauthorized. Al
|activities are montored and ogged, There ks no privacy on

[thiz system. Unauthorized access and sclivities or any
|eximireal sctivly will be reported to appropriate suthorities.

) pestricted Service Banner File:

_ |(Biowwes ]
.

1. Select one of the following checkboxes.
= Display Restricted Service Banner

= Require Acceptance of Restricted Service Banner

2. Click one of the following radio buttons:

= Restricted Service Banner Message

= Restricted Service Banner File

3. If you selected Restricted Service Banner File, click on the Browse

drop-down menu

=¥ oo
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4. Locate and select the file that contains the Restricted Service Banner
message you want to display on the SX login dialog.

5. Click OK.

Security Profiles

i

Raritan.

The SX provides three security profiles for your use. The profiles simplify
the task of assigning permissions to users and groups by defining basic
permissions that automatically apply to all users.

About Security Profiles
The three security profiles are:

e Standard - Custom defaults
e Secure - All functions in Custom are checked
e Custom - Can be configured by a user

If you enable the Standard or Secure profiles, you cannot enable/disable
manually any of the features they include. You must disable the profile to
make those changes.

If a profile is disabled, the features in the profile keep the states they had
when the profile was enabled. For example, if the default TLS Required
feature is deselected and you enable the Secure profile, this feature
becomes selected. When you disable the Secure profile, the TLS
Required feature remains selected.

Select a Security Profile

> To select a security profile:

1. Choose Security > Security Profiles. The Security Profiles page
opens.

Security Profiles

[] Enable Security Profile
Profile:

Edit Custom Profile

| OK | | Cancel |

2. Click the Enable Security Profile checkbox.

3. Select the profile from the drop-down menu in the Profile field.
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4. Click OK.

Edit the Custom Profile

> To edit the Custom profile:

Choose Security > Security Profiles. The Security Profiles page
opens.

2. Click the Edit Custom Profile link. The Edit Custom Security Profile
page opens.

Edit Custom Security Profile

Hame:
Custom

Telnet Access

Strong Password Required
|:| Single Login Per User

|:| Timeout Required

|:| TLS Required

Redirect HTTP to HTTPS

| OK | | Cancel

3. Check one or more of the following checkboxes.
= Telnet Access
= Strong Password Required
= Single Login Per User
= Timeout Required
= TLS Required
= Redirect HTTP to HTTPS
4. Click OK.

Firewall

The SX provides a firewall function to provide protection for the IP
network and to control access between the internal router and LAN 1,
LAN 2, and the dial modem interfaces.

120 =
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Enable the Firewall

> To enable the firewall:

1. Choose Security > Firewall. The Firewall page opens, displaying
the existing IPTables rules.

D Enable Firewall IPTables Command:

| |

| Apply || Cancel

I OK ] I Cancel

IPTables Rules

Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT 0 -- localhost.localdomain anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Select the Enable Firewall checkbox.
3. Click OK.

Note: When you enable IP forwarding for Dual LAN units, use
IPTables rules to create policies for traffic being forwarded between
LAN interfaces

Add an IPTables Rule

» To add an IPTables rule:

1. Choose Security > Firewall. The Firewall page opens, displaying
the default IPTables rules.

2. Go to the Add/Delete IPTables Rule field and enter a rule.

3. Click Apply, and then click Save. The rule is displayed on the screen.

4. Delete some or all of the default rules if you choose to.

5. Add new rules if you choose to.
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Note: Rules are added using the IPTables command to the kernel.
These rules take effect immediately but persist permanently only
after clicking the Save button. If there is a mistake in the rules and as
a result, the unit becomes inaccessible, while the Save action allows
you to recover from the mistake. Reboot the system. If you do not
Save the rules, you lose them in the reboot.

{
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Logging

In This Chapter
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Configuring Local Event Logging

i
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To configure the local log settings, choose Setup > Log. The Log
Settings page opens. It contains a number of individual logging panels.

Enable the Event Log File

This feature enables event log messages to be stored locally on the SX
unit.

> To enable the Event Log File:

1. Go tothe Event Log panel and select the Enable Event Log File
checkbox. To turn this feature off, deselect this checkbox.

Enable Event Log File
Style:

| Werag L |

Size:
65535 |

2. Select the log file style in the Style field. This determines how the file
reacts when the maximum file size is reached. Your choices are:

= Wrap: This causes the log file to circle around to the beginning
when the end of the file is reached.

= Flat: This causes logging to stop when the end of the file is

reached.
3. Enter the maximum size of the file in the Size field. The default is
65535 bytes.
4. Click OK.
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Enable System Logging

This feature sends event log messages to a remote Syslog server. The
messages from the SX unit are sent to the LOCALO channel of the
Syslog server for more efficient parsing. To set this feature up:

1. Go to the System Logging panel and click the Enable System
Logging checkbox. (To turn this feature off, clear this checkbox.)

Enable System Logging
Primary IF Address:

Secondary IP Address:

2. Type the IP address of the remote Syslog server in the Primary IP
Address field.

3. If you have a backup Syslog server, types its IP address in the
Secondary IP Address field.

4. Click OK.

Enable Port Syslog

This feature enables port data to be logged to a syslog server. Output
from all ports is logged to the same file in syslog. Please use NFS Port
Logging if you prefer separate files for each port's data.

> To enable Port Syslog:

1. Go to the System Logging panel and select the Enable Port Syslog
checkbox. To turn this feature off, deselect this checkbox.

Enable Port Syslog
Syzlog Category
| Locals A |

Primary IP Address:
182.188.1.106 |

Secondary IP Address:
0.0.0.0 |

2. Select a channel from the drop-down menu of Syslog Category, and
the messages from the SX unit are sent to the selected channel (for
example, Local5) of the Syslog server.

124 =
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Note: If no specific IPs are entered for the port data destination
servers, port logs are sent to the Syslog server configured in the
System Logging section. If the Syslog category is set to Local0, then
system events and port logs are sent to all servers configured in the
System Logging"section and Port Syslog section.

3. Type the IP address of the remote Syslog server in the Primary IP
Address field.

4. If you have a backup Syslog server, type its IP address in the
Secondary IP Address field.

5. Click OK.

Enable Port Logging

Configure NFS port logging after you have enabled NFS Logging (see
Configuring NFS Logging for details).

This feature enables port data to be logged to a Network File System
(NFS) server, allowing you to save and access the log files over a
network.

NFS supports file sharing, which means you can store the files on the
network that you want other people to access, while keeping your secure
files on the SX unit. NFS stores the port sessions as viewed by the
user, as well as adding messages when a user connects to or
disconnects from a port.

> To setup portlogging:

1. Go to the Port Logging panel and select the Enable NFS Port
Logging checkbox. To turn this feature off, deselect this checkbox.

Enable NFS Port Logging
File Prefix:

| domSX-NFS |

Size (bytes):
65535 |

Timestamp (Interval):
20 |

NF 5 Update Frequency (seconds):
20 |

Out Directory:
| output |

2. Type the prefix to the port data file's name on the NFS server in the
File Prefix field.
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Sep 3 11:31:20 sxB DomSX:
Sep 3 11:31:20 sx8 DomSX:
Sep 3 11:21:20 sx& DomSX:
Sep 3 12:03:17 sx& DomSX:
Sep 3 12:03:17 sxB Dom3X:
Sep 3 12:03:17 sx6 DomSX:

7.

Type the maximum file size allowed in the Size field. Once this size
is reached, a new file is created to store the port log data. If you
enter a value of 0, the SX creates a new file.

Type the time interval (in seconds) between two timestamp
messages in the log file in the Timestamp (Interval) field. If you enter
a value of 0, this disables timestamps in the log file. The maximum
value is 99999. This field is optional, but if a timestamp is configured,
the syslog has timestamps interspersed with the same timestamp
interval.

Type the time interval (in seconds) between two updates of the port
log file in the NFS Update Frequency (seconds) field. Data is
buffered until the internal buffer is full or this timestamp occurs. Then
the data is written to the file. This prevents severe network traffic on
port activity where every character would trigger a write to the NFS
server.

Type the subdirectory on the configured NFS server to write the
output port data to in the Out Directory field. This is the default log
file and contains the port sessions as visible to the user.

Click OK.

The following is an example of an output file.

DominionSX Port 1 : Portl : edition of this book, which has naturally been very pleasant for me.
DominionSX Part 1 : Portl : However, every now and then someane will have complaints, and for
DominionSX Port 1 : Portl : -- DominionSX UP — Tue Sep 03-2008 15:30:28

DominicnSX Port 2 : Port2 : -- DominionSX UP — Tue Sep 03-2008 16:02:23

DominienSX Port 3 : Port3 : -- DominionSX UP -- Tue Sep 03-2008 16:02:23

DominicnSX Port 4 : Portd : -- DominionSX UP -- Tue Sep 03-2008 16:02:23

%8 DomSX: DominionSX Port 1 : Portl @
<HostIP>= DomSX: <hostname= Port <portnumber=> : <Portname=: <port data>

126

Configure Input Port Logging

> To configure input port logging:
1.

Go to the Input Port Logging panel and select the Enable Input Port
Logging checkbox. To turn this feature off, deselect this checkbox.

Enable Input Port Logdaging

In Mrectony:

|input

2.
3. Click OK.

Type a directory for input in the In Directory field.

=Raritan.
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Configure Encryption

> To configure encryption:

1. Go to the Encryption panel and select the Encryption checkbox. To
turn this feature off, deselect this checkbox.

Encryption

HFS Encryption Key (RC4):
baSH9a0e3ata0f2f0de254

2. Accept the default encryption key or type a new one in the NFS
Encryption Key (RC4) field.

3. Click OK.

Block Port Access On Failure

This feature specifies NFS mount behavior. This feature appears as
checked by default, and NFS behaves as a soft mount. When it is a soft
mount, NFS is re-mounted if an operation goes wrong on the file system.
If the re-mount succeeds, logging continues; otherwise, further logging
events are inhibited.

Block Port Access On Failure

Configuring SMTP Logging

;

Raritan.

To configure SMTP logging, choose Setup > Events. The SMTP
Logging screen appears, containing SMTP Settings panel and a New
SMTP Event panel.
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Enable SMTP Logging

> To enable SMTP logging:

1. Go to the SMTP Settings panel and select the Enable SMTP Server
checkbox.

SMTP Settings

|:| Enable SMTFP Server
SMTP Server IP Address:

Usernanme:

Password:

Source address:

| OK | | Cancel |

2. Type the IP address of the SMTP server in the SMTP Server IP
Address field.

3. Type the username and password in the Username and Password
fields. These are required to access the SMTP server.

Type your source address in the Source Address field.
Click OK.
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Select a New SMTP Event

» To select anew SMTP event:

1. Go to the New SMTP Event panel and select a new event from the
Event drop-down list.

New SMTP Bvent

Event:

| event.amp.natice port.connection b |

Destination:

| 0K | | Cancel |

Available events include:

event.amp.notice.port.connection
event.amp.notice.user.logoff
event.amp.notice.backup
event.amp.notice.restore
event.amp.notice.config.directaccesslockout
event.amp.notice.reboot
event.amp.notice.boot
event.amp.notice.config.datacom
event.amp.notice.config
event.amp.notice.upgrade
event.amp.keyword
event.amp.strongpasssword
event.amp.banner

event.amp.firewall
event.amp.iptablesaved
event.amp.security.clientauth
event.amp.security.clientcert.ca
event.amp.security.clientcert.crl.expired

event.amp.security.clientcert.crl.updated

2. Inthe Destination field, type the email address to which you want to
send the event.
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3. Click OK.

Test SMTP Logging

It is important that the SMTP server information be accurate so that the
SX unit can send messages using that SMTP server.

To verify that the information is correct and working:

1. Send atest email by selecting an event such as:
event.amp.notice.port connection

2. Connect to a port and see if the message is received by the intended
emalil target. If there are problems, contact your SMTP administrator
to make sure your SMTP server IP address and authorization
information are correct.

130

Configuring NFS Logging

Network File System (NFS) logging allows you to log all port activity to
an NFS shared directory. All user activity and user port logins and
logouts are logged. There are two log files:

= |nput: Records all input (keystrokes) from users.

= Qutput: Contains all the messages that come from the server into
the console server. This includes all user input that is echoed
back from the managed device/server.

i
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You must also enable port logging. For more information on port logging,
see Enable Port Logging.

Note: The NFS server must have the exported directory with write
permission for the port logging to work.

To configure NFS Logging:
1. Choose Setup > NFS. The NFS Settings page opens.

NFS Settings

] Enable HFS
Primary IP:

Primary Directory:

Secondary IP:

Secondary Directory:

| 0K | | Cancel |

Select the Enable NFS checkbox to enable NFS logging.

3. Type the IP address of the NFS server in the Primary IP field, and
then enter the path to the log file in the Primary Directory field.

4. If you have a backup NFS server, enter the same information for this
server in the Secondary IP field and Secondary Directory fields. If the
primary server fails, port logging is redirected to the secondary
server.

5. Click OK.

Configuring SNMP Logging

i
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The SX supports Simple Network Management Protocol (SNMP) traps
and logging.

Information on SNMP traps that the SX sends can be found in the MIB
file, which can be viewed from the SNMP page. After the "-- Start the
Traps" header in the document, all of the traps are listed, as well as the
data elements that are sent in each trap. Each data element is defined in
the MIB file before this section of the document.
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Enable SNMP Logging

> To enable SNMP logging:
Choose Setup > SNMP. The SNMP page opens.

2. Go to the SNMP Setting panel and select the Enable SNMP
checkbox.

3. Select the SNMP Trap Version - either 1 or 2c.

SNMP Settings j

[] Enable sHMP

SHMP Trap Version:
1

Public Community:
public

View SHMP-MIB

OK | Cancel |

P P A

A AL b

4. Type an SNMP public community in the Public Community field. The
default is Public. The public community determines which SNMP
management stations receive SNMP alerts.

If needed, click View SNMP-MIB to view the MIB.
Click OK.

Enable SNMPv3 Logging

> To enable SNMPv3logging:
1. Choose Setup > SNMPv3. The SNMP page opens.
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2. Go to the SNMP Setting panel and select the Enable SNMP v3

checkbox.
SNMP v3 Settings ,
[V Enable SNMP v3 ’
Engine ID :
8000352e03000d54000000 ¥

View SHMP-MIB [
u

0K | Cancel | /
. ’--._,-dul-— a ..‘ . *j ’* ...’.--. ’f

3. If needed, click View SNMP-MIB to view the MIB.
4. Click OK.

Create a New SNMP Destination

SNMP destinations determine which SNMP management stations
receive SNMP traps.

> To create a new SNMP destination:

1. Go the SNMP Destination panel and type the IP address of the new
destination in the IP Address field.

New Destination

IP Address:

| |
Port:

162 |
| 0K | | Cancel |

2. By default, the new destination uses the standard SNMP port of 162.
Change this to another port by entering a different port number in the
Port field. Click OK.

Note: To display the SNMP Management Information Base (MIB),
click the View SNMP-MIB link in the SNMP Settings Panel (as shown
in Enable SNMP Logging (see "Enable SNMPv3 Logging" on
page 132)).
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Managing the Local Event Log

The SX allows you to display the contents of the event log, clear the log,
and send the log to a remote FTP server.

Display the Local Event Log

To display the contents of the local event log, choose Maintenance >
View Event Log. The following figure shows a typical event log.

Date/Time Event

Dec 18 19:13:44 TheMonarch DomSX: [RDMDEBUG] Command()

Dec 18 19:13:44 TheMonarch DomSX: [RDMDEBUG] Running command ick: 1

Dec 18 19:13:44 TheMonarch DomSX: [RDMDEBUG] -272651163 send() result 4

Dec 18 19:13:44 TheMonarch DomSX: [RDMDEBUG] -272651063 send() result 126

Dec 18 19:13:59 TheMonarch DomSX: [RDMDEBUG] begin

Dec 18 19:13:58 TheMonarch DomSX: [RDMPRIMT] length = 845

Dec 18 19:13:59 TheMonarch DomSX: [RDMDEBUG] -272635850 UDP Sending CSC_Info
Dec 18 19:13:59 TheMonarch DomSK: [RDMPRINT] TheMonarch

Dec 18 19:14:29 TheMonarch DomSX: [RDMDEBUG] begin

Dec 18 19:14:29 ThehMonarch DomSx: [RDMPRINT] length = 848

Dec 18 19:14:29 TheMonarch DomSX: [RDMDEBUG] -272605820 UDP Sending CSC_Info
Dec 18 19:14:29 TheMonarch DomSX: [RDMPRINT] TheMonarch

Dec 18 19:14:45 TheMonarch DomSX: [RDMDEBUG] -272530434 recv() result 4

Dec 18 19:14:45 TheMonarch DomSX: [RDMDEBUG] RDM
Dec 18 19:14:45 TheMonarch DomSX: [RDMDEBUG] -272590425 recv() result 127
Dec 18 19:14:45 TheMonarch DomSX: [RDMDEBUG] -272580383 recv() result 1

Dec 1819:14:45 TheMonarch DomSX: [RDMDEBUG] VJ*
Dec 18 19:14:45 TheMonarch DomSK: [RDMDEBUG]

Dec 18 19:14:45 TheMonarch DomSX: [RDMDEBUG] Command()

Dec 18 19:14:45 TheMonarch DomSX: [ROMDEBUG] Running command id: 1

134
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Note: If the number of events in the log exceeds the size of one page,
click the Next link that appears under “Event Log” at the top of the screen
to display the next page.

For each event, the log gives the date and time the event was logged
and a brief description. The following are typical events:

Feb 5 12:55:23 DominionSX DomSX: DominionSX notice
SXRebootCompleted

Feb 5 12:55:25 DominionSX DomSX: DominionSX notice
SXSystemReady

Feb 1 16:30:35 DominionSX DomSX: DominionSX notice
SXSettingSaved User Elaine changed

configuration for Logging

Clear the Event Log

> To clear the event log:

Choose Maintenance > Clear Event Log. You are prompted to
confirm the clear action.

2. Click Yes. The log is cleared of all contents. (If you change your
mind, click No.)

Send the Event Log

> To send the contents of the event log to a remote FTP server:

1. Choose Maintenance > Send Event Log. The Send Event Log
page opens.

Send Event Log

IP Address:

Login:

Password:

Remote Path:

Remote File:

| Send || Cancel |
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Enter the IP address of the FTP server in the |IP address field.

Enter a login name and password on the FTP server in the Login and
Password fields. This is necessary to access the FTP server.

Enter the path to the location where the event log is stored in the
Remote Path field.

Enter the name of the file to store the event log in the Remote File
field.

Click Send.

Displaying a Configuration Report

The Configuration Report provides detailed information about the SX unit.
To display the report, choose Maintenance > Configuration Report. The
report shows:

Version and firmware information

Port settings

User and group settings

HTTP, HTTPS, SSH, and Telnet ettings

RADIUS, LDAP, TACACS+, and Kerberos settings
Local authentication settings

Other settings

136

Backing Up and Restoring the SX

When you back up the SX, the system makes a copy of the SX
configuration (without network settings) and writes the copy to an FTP
server. The file can be recovered using a Restore operation, if
necessary.

1]
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Back Up the SX

>

1.

To back up the SX unit:
Choose Maintenance > Backup. The Backup page opens.

IP Address:

Login:

Password:

Remote Path:

Remote File:

| 0K | | Cancel |

2.

Type the IP address of the target FTP server where the backup is
written in the IP Address field.

Type the login name of the account on the system where the backup
is stored in the Login field.

Type the password of the account on the system where the backup
is stored in the Password field.

Type the path to the backup file in the Remote Path field.

Type the name of the file in which the backup is saved in the Remote
File field.

Click OK.
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Restore the SX

Restoring the SX retrieves a copy of the SX configuration from the FTP
server where it has been backed up and writes the file to the SX.

> To perform arestore operation:
1. Choose Maintenance > Restore. The Restore page opens.

IP Address:

Lagin:

Password:

Remote Path:

Remote File:

| OK | | Cancel |

2. Type the IP address of the source FTP server system from which the
restore data is retrieved in the IP Address field.

3. Type the login name of the account on the system where the restore
data is stored in the Login field.

4. Type the password of the account on the system where the restore
data is stored in the Password field.

5. Type the path to the restore file in the Remote Path field.

6. Type the name of the file in which the restore is saved in the Remote
File field.

7. Click OK.

Upgrading Firmware

You can display the version of the firmware currently running on the SX,
upgrade the firmware to a later version, and display a history of firmware
upgrades.

Note: The SX can only be upgraded, while downgrade is not possible.

138 =Y e
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Display the Current Firmware Version

To display the current version of firmware running on an SX unit, choose
Maintenance > Firmware Version. The Firmware Version page opens,
displaying the Firmware Version, RSC, Kernel, and PMON.

Firmware Version

Firmware Versiom 31752
RS(C: 300537

Kernel: 2413
PMOH: 201

Upgrade the Firmware

During the upgrade, SX verifies there is enough space on the device to
perform the upgrade. If there is not, the SX restarts and the upgrade
does not take place. If the upgrade fails due to lack of space, clear the
local logs on the device and try upgrading again. Contact Raritan
Technical Support if you still cannot upgrade after clearing the local logs.

Before you perform a firmware upgrade, you must:

1. Download the upgrades file(s), which are in WinZip format onto a
folder on the local FTP server.

Obtain the IP address of the FTP server.

Obtain the file path to the upgrade file(s). This is the path to the
extracted upgrade files, for example, cert_pact.tgz, on the FTP
server.

4. Obtain a user account (optional) if “anonymous” access to the FTP
server is not supported.

The Firmware Upgrade feature allows you to upgrade the SX unit's
firmware to a newer version. These upgrades preserve user-defined
settings. You do not need to re-configure the unit after the upgrade is
complete.

Important: During an upgrade procedure, do not attempt to access
any unit features or functions, including, but not limited to, Reset
and Exit. Interrupting the upgrade procedure can cause memory
corruption and render the unit non-functional. Such an action may
void your warranty or service contract, and in such a case unit
repair/replacement costs are solely the responsibility of the user.

Note: Many upgrades can be performed "anonymously" from the
FTP server.

139



Chapter 10: Maintenance

>

1.

To perform the upgrade:

Choose Maintenance > Firmware Upgrade. The Firmware Upgrade
page opens.

Firmware Upgrade

IP Address:

Login:

Password:

File Path:

| Uparade | | Cancel |

2. Type the IP Address of the FTP server in the IP Address field.

3. Type your login name in the Login field.

4. Type your password in the Password field.

5. Type the path to the firmware file in the File Path field (for example,

140

/home/downloads/firmware/UpgradePack 2.5.6 3.1.0.5.2/Packlofl).
Click Upgrade.

The upgrade lasts about 20 minutes. After about half the time, the SX
unit will restart. The upgrade will continue for another 20 minutes or
so after the restart.

Once the upgrade is initiated, the upgrade status message indicates
the progress of the upgrade. The files are copied and the unit is reset.
You receive the following message:

Upgrade is Complete, The unit is now resetting.

The blue light on your SX will turn off, flash once while it is extracting
more files, turn off, then turn on and remain on. You are logged out. It
should now be running the new firmware.

Note: If the upgrade fails, the system will display an error message
detailing the failure.

=Raritan.
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Display a Firmware Upgrade History

To display the firmware upgrade history for an SX unit, choose
Maintenance > Firmware Upgrade History. The Firmware Upgrade
History page opens, displaying the version of each past firmware
upgrade and the date and time the upgrade was performed.

31012 Tue Feb 20 1613019 2007

| 3101 5 Thu Mar 15 15:14:32 2007 |

Performing a Factory Reset on the SX

Performing a factory Reset returns the SX unit to its default factory
settings. Be very careful when doing this, because it will erase all the
data and settings on the SX unit and return it to the state in which it was
originally shipped.

To perform a factory reset, choose Maintenance > Factory Reset. You
are prompted to confirm the reset. Click Yes to proceed. If you change
your mind, click No.

Note: In case you are not aware of the administrative password to log in

the SX GUI to perform a factory reset, you may want to try resetting from
the SX hardware. To do so, insert a pin into the RESET hole on the back
panel of the SX unit and hold for about 15 seconds. The SX is then reset
to factory defaults.

Rebooting the SX

;

Raritan.

Performing a reboot powers the SX off and then back on. Be careful
when doing this, because it will log all current users off the system.

To perform a reboot, choose Maintenance > Reboot You are prompted
to confirm the reboot. Click Yes to proceed. If you change your mind,
click No.
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In This Chapter

Network INfrastructure TOOIS ......ocevveieeieeeeeeeeee e 142
Administrator TOOIS - ProCeSsS StatUsS .........covvvvvvviiiieieeeieeiiiiie e eeeeeeeevnann 145

Network Infrastructure Tools

Network infrastructure tools allow you to view the status of the active
network interfaces and important network statistics. You can also
perform ping and trace route operations.

Status of Active Network Interfaces

1. Choose Diagnostics > Status of Active Network Interfaces. The
system displays status information about the active network
interfaces.

Status of Active Network interfaces

Result:

echl Link encap:Echernet HWaddr 00:0D:S5D:00:E2:4D
inet addr:l92.168.51. 183 Boast:192.168.51.255 Mask:255.255.255.0
UP ERDADCAST RUNNING MULTICAST NIU:1500 Hetric:l
BX packets: 2525902 errors:0 dropped:0 overrun=:0 frame:0
TE packets: 168545 errors:0 dropped:0 owerruns:0 carcier:0
colliziona:0 oxgueuslen: 10D
B bytes:227412923 (216.8 Mb) TX bytes:d47829101 (45.6 Mb)
Interrupt: 19 Base address:0x1000

lo Link encap:local Loopback

inec addr:l27.0.0.1 HMask:255.0.0.0

UP LOOPEBACK RUNMING MTU:16436 Mecric:l

BX packets3:331334 errors:0 dropped:0 overruns:0 frame:0
T packers:331334 errors:0 dropped:0 overruns:0 carcier:0
colliziona:0 oxgueuelen:O

BX bytes:57001364 [63.8 Mb) Ti byte=:57000L364 (63.8 Mb)

2. Click Refresh to update the information.

142
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Network Statistics

1. Choose Diagnostics > Network Statistics.

page opens.

Network Statistics

|-l

v

Result:

Active Internet connections (servers and established)
Proto Recw-0 Send-0

top
top
top
top
top
top
top
top
top
top
top
top
top
top
top
top
udp

1]

L o O e Y e O s A s s e O o s s s s Y o s o |

Proto RefCnt Flags

unix
i
urnix
urnix
unix
rix
unix

2

[

ACC
ACC
ACC
ACC

]

0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

[ S S '

The Network Statistics

Local Address Foreign Address State
*; 5000 wLw LIATEN
* 2 T woF LIATEN
*:3s5h wrE LISTEN
*rtelnetld wrE LISTEN
w1443 L LIZTEN
192,165, 50,132: 443 192,165, 55.58: 2298 TIME WATT
localhost: 5000 localhost: 1363 ESTAELISHED
192,165, 50,132: 443 192,165, 55.58: 2299 TIME WaTT
192,165, 50,132 443 192,165, 55,55 2296 TIME WaTT
192,165, 50,132 443 192,165, 558.88: 2297 TIME WiIT
192,168, 50,132: 443 192,168, 58,88 2302 ESTABRLISHED
localhost: 1363 lacalhost: 5000 ESTAELTSHED
192,165, 50, 132: 443 192,165, 58,88 2292 TIME WATT
192,165, 50,132: 443 192,165, 55.58: 2300 TIME WATT
192,165, 50.132: 443 192,165, 55.58: 2293 TIME WaTT
192,165, 50,132: 443 192,165, 55.58: 2301 ESTABLISHED
*; 5000 wLw
Aotive UNIE domain sockets [(serwers and established)

Type State I-Node Path

STREAM LIATENING 43 Adew/log

STREAM LISTENING 122 frupfinternal rdmp

STREAM LISTENING 130 Stupsfilteriock

STREAM LISTENING 173 Atmp . 150

STREANM CONNECTED 17371 fdevilog

STREAM CONHNECTED 17370

STREAM CONNECTED &9 Adev/log

STREAM CONNECTED 47

urnix

;

L N R P ot T % T N

[
[
[
[
[
[
[

Raritan.

]
1
]

By default, all statistics are shown. To show specific statistics, select
an entry from the drop-down menu in the Options field. Your choices
are:

Route
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= Interfaces

= Groups
= Statistics
= Program

3. Click Refresh to update the information.

Ping Host
1. Choose Diagnostic > Ping Host. The Ping Host page opens.

Ping Host

IP Address:
|

2. Type the IP address of the host to be pinged in the IP Address field.

3. Click Ping. The page displays the results of the ping.

Trace Route to Host

Trace Route to Host

IP Address:

Maximum Hops: -
30 W

[ Trace Route I

1. Choose Diagnostics > Trace Route to Host. The Trace Route to Host
page opens.

2. Type the IP address of the host in the IP Address field.

3. Select the maximum amount of hops from the drop-down menu in
the Maximum Hops field.

4. Click Trace Route. The page displays the results of the Trace Route.

144 =V
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Administrator Tools - Process Status

i

Raritan.

1. Choose Diagnostics > Process Status.
opens.

Resalt:

PID
1

w3 oA A R

18
62
it
72
74
75
an
83
84
a7
92
L)
L0k

2. Click Refresh to update the information.

Uid
EOBE
EO0T
oot
EOBL
ook
oot
oot
oot
Eopt
oot
o0t
oot
LOnE
oot
LO0T
Eopt
14114
Koot
oot
oot

5
3
3
3
]
]
a3
3
3
5
2
3
]
3
5
a2
1
3
5
3
3

tat Command

[svapper]
[Eeventd]

[ksofeizgd CFUO)
[kavapd]

[bdflush]

[Eupdaced]

init

[3EEa2 god_medl]

[ethd]

Sebindkelagd
Sabinsayalogd
Sata/kernel/logwatch
Jbin/ah JebinSewn_dom. 2k
Sataskerne) fdon
Srap/aeriald woden
Juse/sbin/inecd
Juse/bin/sconzels --

The Process Status page

ashd =p 22 -p 3001 -p 3002 -p 3003 -p FOO04 -p J005 -p 3006

saca/karnsl fdon
Satas/kernel fdon
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Command Line Interface

In This Chapter
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Command Line Interface Overview

The SX Serial Console supports all serial devices, including:

Servers, including Windows Server 2003° when using the
Emergency Management Console (EMS-) Special Administration
Console, or SAC with BIOS redirection in the server BIOS

Routers

Layer 2 switches
Firewalls

Power strips

Other user equipment

The SX allows an Administrator or User to access, control, and manage
multiple serial devices. You can use the Command Line Interface (CLI)
to configure the SX or to connect to target devices. The RS-232 interface
may operate at all standard rates from 1200 bps to 115200 bps.

The following common commands can be used from all levels of the CLI
to the preceding figure:

top
history
logout
quit
show
help

Accessing the SX Using CLI

Access the SX using one of these methods:

TELNET via IP connection

HTTP and HTTPS via IP connection
SSH (Secure Shell) via IP connection
Local Port-via RS-232 serial interface

Many SSH/TELNET clients are available and can be obtained from the
following locations:

;

Raritan.

PUTTY - http://www.chiark.greenend.org.uk/~sgtatham/putty/
http://www.chiark.greenend.org.uk/~sgtatham/putty/

SSH Client from ssh.com - www.ssh.com http://www.ssh.com

Applet SSH Client - www.netspace.org/ssh
http://www.netspace.org/ssh

OpenSSH Client - www.openssh.org http://www.openssh.org
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SSH Connection to the SX

Use any SSH client that supports SSHv2 to connect to the SX. You must
enable SSH access from Network Service Settings page (See Change
Network Service Settings (on page 54)).

Note: For security reasons, SSH V1 connections are not supported by
the SX.

SSH Access from a Windows PC

To open an SSH session from a Windows® PC:

Launch the SSH client software.

Enter the IP address of the SX server. For example, 192.168.0.192.
Choose SSH, which uses the default configuration port 22.

Click Open.

The login as: promptappears.

o~ N PV

SSH Access from a UNIX/Linux Workstation

> To open an SSH session from a UNIX®*/Linux® workstation and
log in as the user admin, enter the following command:

ssh -1 admin 192.168.30.222

The Password prompt appears.

Login

> Tologin, enter the user name admin as shown:
Login: admin
The password prompt appears. Enter the default password: raritan

Password:

148
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The welcome message appears. You are now logged in as an
Administrator.

admin

JuouzZs

g Z nan 24 P [U] 3 hman 21 [U]
[P] ThePerfec [U,B] ! O [ [ [U]

Port? [U] 3 ) 2 ]
Porti0 [U] 3 ] 12 2 [U]
Portl3 [U] 4 Portld [U : 15 [U]
Portls [U] 7 Portil? =1 3 [U]
Por (U] J (7]
Por [1] : & i 24 4 [U]
Por [u] 0 J 27 7 [U]
[ 29 - ] : .30 [1U]
ck [U]
Current Time: Thu Apr 17

admin > I

After reviewing Navigation of the CLI (on page 151), perform the initial
configuration tasks.

Telnet Connection to the SX

Due to the lack of security, user name, password and all traffic is in
clear-text on the wire. Telnet access is disabled by default.

Enabling Telnet

To use Telnet to access the SX, first access the SX from the CLI or a
browser.

CLI

1. Use the following command:
Admin Port > Config > Services > telnet enable true

The system returns the following message:

The system will need to be rebooted for changes to take
effect.

—e=Y,
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Note: By default, the telnet port is set to 23. You may change it by
issuing the following command:

Admin Port > Config > Services > telnet enable true
port <preferred port number>

2. Reboot the system.

Browser (GUI)
Enable Telnet access in the Setup > Services menu.

Accessing the SX Unit

Once Telnet access is enabled, use it to access the SX unit and set up
the remaining parameters.

Accessing Telnet from a Windows PC

To open a Telnet session from a Windows® PC:
Choose Startup > Run.

Type Telnet in the Open text box.

Click OK. The Telnet page opens.

AP 0N =V

At the prompt enter the following command: Microsoft Telnet>
open <IP address> where <IP address> is the SX IP address.

5. Press the Enter key. The following message appears: Connecting
To <IP address>... The login as prompt appears.

Local Port Connection to the SX

If your SX's terminal port uses an RJ45 jack, a special cable (CRLVR) is
used with an ASCSDB9F connector on the client machine. The CRLVR
may also be used if RJ45-RJ45 connection to local port is established -
that is, if you connect the local port of an SX as a serial target to another
SX.

Port Settings

Ensure that the port settings (serial communication parameters) are
configured as follows:

e Databits=8

e Parity = None

e Stop bits =1

e Flow Control = None

150
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Connection

> To make alocal port connection:
1. Open a HyperTerminal application or equivalent.

2. Ensure the HyperTerminal is configured to communicate with the
port that is connected to the SX unit.

3. Disable Flow control.

4. Press the Enter key and the following prompt appears: user name

See Login (on page 148) for details.

To Change the Local Port Parameters:

The local port is enabled by default and is enabled on both serial ports
for units with two local ports at 9600 bps.

> To change the local port parameters:

As an example, to change the baud rate from the default 9600 bps to

115200 bps, type:
Admin Port > Config > Services > lpa enable true bps

115200

> To disable local port access:

Admin Port > Config > Services > lpa enable false

Navigation of the CLI

i

Raritan.

Before using the CLI, it is important to understand CLI navigation and
syntax. There are also some keystroke combinations that simplify CLI
use.

Completion of Commands

The CLI supports the completion of partially-entered commands. After
entering the first few characters of an entry, press the Tab key. If the
characters form a unique match, the CLI will complete the entry.

e If no match is found, the CLI displays the valid entries for that level.
e If multiple matches are found, the CLI displays all valid entries.

Enter additional text to make the entry unique and press the Tab key to
complete the entry.
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CLI Syntax -Tips and Shortcuts

Tips

e Commands are listed in alphabetical order.

¢ Commands are not case sensitive.

e Parameter names are single word without underscore.

e Commands without arguments default to show current settings for
the command.

e Typing a question mark ( ?) after a command produces help for that
command.

e A pipe symbol (| ) indicates a choice within an optional or required
set of keywords or arguments.

Shortcuts
e Press the Up arrow key to display the last entry.
e Press Backspace to delete the last character typed.

e Press Ctrl + C to terminate a command or cancel a command if you
typed the wrong parameters.

e Press Enter to execute the command.

e Press Tab to complete a command. For example, Admin Port >
Conf. The system then displays the Admin Port > Config >
prompt.

Common Commands for all Command Line Interface Levels

CLI Commands lists the commands that are available at all CLI levels.
These commands also help navigate through the CLI.

Commands Description

top Return to the top level of the CLI hierarchy, or the
“username” prompt

history Display the last 200 commands the user entered
into the SX CLI
show Show the settings for the given parameter or show
all configurations by default
help Display an overview of the CLI syntax
quit Places the user back one level
logout Logs out the user session
152 =V R e
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Show Command

The show command displays various configuration settings and is
available at all levels.

The syntax of the show command is:

show [ clock | version | network | route | firewall |
ipforwarding | modem | dpa |

anon | port | idletimeout | users | groups |

lpa | ssh | telnet | http | https |

encryption | clientcert | ntp | keywords |

smtp | snmp | eventlogfile | syslog | nfs | portlog |
ldap | radius | tacacs | kerberos | security profile |

strongpassword | inactiveloginexpiry |
invalidloginretries |

lockoutperiodoninvalidlogin | localauth |
singleloginperuser |

powerstrip | powerdelay | association | powergroup ] [all]

Command Example
The following command shows the general settings of the SX unit:

Admin Port > show

SX4 [64Mb] Serial: WACEA00008
Current time: 2006-09-20 23:08:42

Date /Time Settings:
Date : 2006-09-20 23:08:42
Timezone : 13

Version Information :

Firmware Version : 3.0.0.1.15

Kernel Version : 2.4.12

PMON Version: 2.0.1

RSC Version: 1.0.0.1.16
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Supporting software:
OpenSSH_4.3p2, OpenSSL 0.9.7i 14 Oct 2005
HTTP Server version: Apache/2.2.0
HTTP Server built: Mar 29 2006 16:06:30

TELNET Linux NetKit 0.17

Note: SX security is not impacted if the version of Apache 2.2 installed
on the remote host is older than 2.2.9.

Initial Configuration

SX units come from the factory with default factory settings. When you
first turn on and connect to the unit, you must set the following basic
parameters so the unit can be accessed securely from the network:

1. Reset the administrator password.

All SX units are shipped with the same default password; therefore,
to avoid security breaches it is imperative that you change the admin
password from “raritan” to one customized for the administrators who
will manage the SX.

Note: Passwords cannot contain " '<> \ &

2. Assign the IP address, subnet mask, and gateway IP address to
allow remote access.

3. Set the time and date.

After the preceding parameters are set, the rest of the system
configuration can be performed.

Setting Parameters

To set parameters, you must be logged on with administrative privileges.
At the top level, you will see the "Username" > prompt, which for the
initial configuration is "admin". Enter the top command to return to the
top menu level.

Note: If you have logged on with a different user name, that user name
will appear instead of admin.
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Date and Time Configuration

Note: It is important to set the date and time correctly to ensure that log
entries and events contain the correct timestamp.

Return to the top menu level by entering the top command. Use the
following command to view the current date and time settings:

Admin Port > Config > Time > clock

The system displays the current settings. For example:
Date /Time Settings:
Date : 2006-09-20 23:20:24
Timezone : 13
Use the following steps to set the user date and time.
1. Admin Port > Config > Time > timezonelist

2. Admin Port > Config > Time > clock tz 21 datetime
"2006-09-23 13:22:33"

Setting Network Parameters
Network parameters are configured using the interface command.

Admin Port > Config > Network > dhcp false interface enable
true if lanl ip 192.16.151.12 mask 255.255.255 gw
192.168.51.12

When the command is accepted, the unit automatically reboots and
drops the connection. You must reconnect to the unit using the new IP
address and the username admin and password newp/w entered in the
resetting factory default password section.

Important: If the password is forgotten, the SX must be reset to
factory default from the reset button on the rear panel and the initial
configuration tasks must be performed again.

The SX now has the basic configuration and can be accessed remotely
via SSH, GUI or locally using the local serial port. Next, you must
configure the users and groups, services, security, and serial ports to
which the serial targets are attached to the SX.
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CLI Prompts

The Command Line Interface prompt indicates the current command

level. The root portion of the prompt is the login nam

e. For a direct admin

serial port connection with a terminal emulation application, Admin Port

is the root portion of a command.

admin >

For Telnet/SSH, admin is the root portion of the com

mand:

admin > config > network >

0

CLI Commands

Command
config

authentication
Idap
primaryldap
secondaryldap
Idaps
getservercert
removecert
viewcert
radius
primaryradius
secondaryradius
tacacsplus
primarytacacs
secondarytacacs
events
add
delete

smtp

log

156

Definition

Switches to config menu

Switches to authentication menu
Switches to Idap menu

Primary LDAP Server settings
Secondary LDAP Server Settings
Switches to Idaps menu

FTP Retrieval of LDAP certificate file
Remove LDAPS Certicicate

View LDAPS Certificate

Switches to radius menu

Primary RADIUS Server Settings
Secondary RADIUS Server Settings
Switches to tacacsplusmenu
Primary TACACS+ Server Settings
Secondary TACACS+ Server Settings
Switches to evetns menu

Add an SMTP Event

Delete SMTP event

SMTP Server Configuration

Switches to log menu

1]
i
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Command
cleareventlog

eventlogfile
eventsyslog

nfsgetkey

nfssetkey

portlog
portsyslog
sendeventlog
vieweventlog
modem
dialback
dialin
network
ethernetfailover
interface
ipforwarding
name
ports
route
routeadd
routedelete
nfs
nfs
port
config
keywordadd
keyworddelete
services
dpa

encryption

;
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Definition

Clear Contents of the local log

Local log configuration for logging of events
Syslog configuration for logging of events

Get the NFS Encryption key used for
encrypting port log

Set the encryption key to be used for
encrypting port log

Configure logging of port data
Portlog Syslog Server configuration
Send local logfile to remote FTP server
View local syslog

Switches to modem menu

Set/Get modem dialback parameters
Set/Get modem dialin parameters
Switches to network menu

Set/Get ethernet parameters
Set/Get ethernet parameters

IP Forwarding configuration
Network name configuration
Network port configuration

Show kernel routing table

Add route to kernel routing table
Delete route of kernel routing table
Switches to nfs menu

NFS Server configuration

Switches to port menu

Port configuration command

Add keyword notification for port
Delete keyword notification for port
Switches to services menu
Per-port Direct Port Access type

Encryption configuration
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Definition
TCP Window Tuning Parameter

Command
fixedtcpwindow

deletegroup

deletesshkey

http HTTP configuration
https HTTPS configuration
Ipa Local Port configuration
ssh SSH configuration
telnet Telnet configuration

snmp Switches to snmp menu
add Add SNMP destination
addv3 Add SNMP destination
delete Delete SNMP destination
deletev3 Delete SNMP v3 destination
snmp SNMP Server configuration
snmpv3 SNMP Server configuration

time Switches to time menu
clock Set/Get time parameters
ntp Set/Get ntp parameters
timezonelist Timezone List

users Switches to users menu
addgroup Add new group to system
addsshkey Add SSH keys to a user
adduser Add a new user

Delete a group

Delete SSH keys for a user

deleteuser Delete a user
editgroup Edit existing group in system
edituser Edit an existing user
groups Show details of groups
users Show details of users
viewsshkey View SSH keys for a user
connect Connect to a port
diagnostics Switches to diagnostics menu
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Command
ifconfig

netstat

ping
Ps
traceroute

uptime

getconfig

ipmi

ipmidiscover

ipmitool

listports

logout

maintenance

backup

cleareventlog

factoryreset

firmware

logoff

reboot

restore

sendeventlog

upgrade

upgradehistory

upgradestatus

userlist

vieweventlog

password

power

associate

;
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Definition

Show detailed network configuration
Print network connections

Ping a remote system

report system process status

Print the route to a remote system
Print system uptime information
Retrieve remote configure script
Switches to ipmi menu

discover all the IPMI enabled devices
send command to remote ipmi device
List accessible ports

Logout of the current CLI session

Switch to System Maintenenace commands
menu

Backup system

Erase contents of local event log file

Reset the system to factory default state

Get current firmware version

Force logoff (terminate) a user or port session
Restart the SX

Restore system

Send local logfile to remote FTP server
Upgrade system

Retrieve upgrade history

Display current file being upgraded. This is
applicable when upgrade is in progress.

List active user sessions

View local event log file

Set the current user's password. Eg., password
Hello123%

Switch to Power Control menu

Associate a Power Strip outlet to a SX Port
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Command

160

association
cycle

off

on

outlet
powerdelay
powergroup
powerstatus
powerstrip

setpowerport

unassociate

unsetpowerport

runconfig
security
banner
banner
ftpgetbanner
certificate
client
add
addcrl
clientcert
delete
deletecrl
viewcacert
viewcrl
server
activatedefaultcert

activateusercert

Definition

View Currently configured associations
Power cycle specified ID

Power off specified ID

Power on specified ID

Edit Outlet information

Configure global Power Strip delays
Switch to Power Group Menu

Get Power Strip status

Edit Power Strip information

Configure an SX Port to contain a Power Strip
device

Remove a power outlet association from a SX
Port

Configure an SX Port to remove a Power Strip
device

Run Configuration Script

Switch to security menu

Switches to banner menu

Banner display and audit configuration settings
Get customized banner.txt using FTP
Switches to certificate menu

Switches to client menu

Install a User Certificate

Install a CA's CRL

Activate Client Side Certificate Verification
Remove Client CA Certificate

Remove Client CA's CRL

View Client CA Certificate

View Client CA CRL Certificate

Switches to server menu

Activate Default System SSL Certificate
Activate User SSL Certificate

i
i
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Command

generatecsr

generatedefaultcert

installusercert
installuserkey
viewcsr

viewdefaultcert

firewall

firewall

iptables

iptables-save

Kerberos

gethostnamefile
getkrbconfig
kadmin

kerberos

Kinit

klist

loginsettings
idletimeout
inactiveloginexpiry
invalidloginretries
localauth
lockoutperiod
portaccess
singleloginperuser

strongpassword

unauthorizedportaccess

securityprofiles
profiledata

securityprofiles

Raritan.
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Definition
View Default System Cert
Generate Default System SSL Certificate

Install a User Certificate

Install a User Certificate Key

View The Certificate Signing Request
View Default System Cert

Switches to firewall menu
Enable/Disable firewall

administration tool for IPv4 packet filtering and
NAT

save IP Tables to make firewall rules persistent
Switches to Kerbos menu

Get /etc/hosts in case of DNS failure file
Get kerberos 5 configuration file

Kerberos admin client

Kerberos based Network Authentication
get kerberos ticket

list kerberos ticket

Switches to loginsettings menu

Set system wide idletimeout

Configure local login expiry time

Configure local login max number of retries
Configure local authentication

lockout period on invalid login attempt
Allow/Restrict concurrent users per port
Restrict to a single login session per user
Configure strong password rules

Unauthorized (Anonymous) port access

Switches to securityprofilesmenu
View or modify a Security Profile

Enable and select a Security Profile
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Command
userlist

162

Definition
List active user sessions

Security Issues
Elements to consider when addressing security for console servers:

e Encrypting the data traffic sent between the operator console and the
SX unit.

e Providing authentication and authorization for users.

e Logging data relevant to the operation for later viewing and auditing
purposes. In some cases, this data is required for compliance with
governmental or company regulations.

e  Security profile.

SX supports each of these elements; however, they must be configured
prior to general use.

Encryption of traffic between the operator console and the SX unit is
determined by the access methodology being used. SSH and encrypted
browser access (HTTPS) are enabled by default. SSH and HTTPS, by
definition, support 128-bit encryption of the traffic between the two ends
of the link. To accept unencrypted connections, you must manually
enable the HTTP and Telnet services.

Welcome Banner Configuration

The SX optionally supports a customizable (maximum 6000 words)
welcome banner that is displayed after login. When you log in to a SX via
a GUI, a banner with a fixed width typeface and a common dimension
like 80x25 appears. If the banner is very large, that is, over 9000 lines,
the banner displayed on GUI will not increase overall page size because
it is contained within a self-scrolled text area.

The banner identifies the location to which the user has logged in. You
can also add a consent banner that forces the user to accept stated
conditions prior to advancing into operation of the console server.

Defining SSL Security Certificates

SSL Security certificates are used in browser access to ensure that the
unit you are attaching to is the unit that is authorized to be connected.
This section describes only how to configure the certificates on the
console server. See Appendix C: Certificates (see "Certificates" on
page 274) for details on SSL Certificates.

i
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Enabling Firewall Protection

SX provides a firewall function to provide protection for the IP network
and to control access between the internal router, LAN (or LAN1 and
LAN2 if dual-LAN units) and the dial modem interfaces.

Enabling Security Profiles

SX provides the ability to define security profiles which simplify the
assigning of permissions to users and groups. There are three types of
profiles. Two are predefined: standard and secure. The third allows for
the definition of custom profiles; this allows assignment of all permissions
by assigning one security profile. Multiple custom security profiles may
be defined.

Configuring Logging and Alerts

As part of the security capabilities of the SX, facilities are provided to log
data and to provide alerts based on activities between the users, SX, and
the target device. These facilities provide an audit trail that allows
authorities to review what has happened in the system, determine who
implemented what action, and when.

Among these facilities are event logging and SNMP traps. Events may
be logged locally using Syslog. Local events are maintained in a 256K
per port buffer and can be stored, reviewed, cleared, or sent periodically
to an FTP server.

Configuring Users and Groups

Users and groups are related. SX allows the administrator to define
groups with common permissions and attributes. They can then add
users to the groups and each user takes the attributes and permissions
of that group. By enabling groups, the permissions for each user do not
have to be configured individually, reducing the time to configure users
one by one.

Command Language Interface Permissions
Administrators can execute all commands.
Operators and Observers can execute only the following commands:

e connect (the port list appears after returning from connect command)
e ? (functions as help)

e logout

e password

e history
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Target Connections and the CLI

The purpose of the SX is to let authorized users establish connections to
various targeted devices using the connect command. Before connecting
to a target, the terminal emulation and escape sequence must be
configured. When a target is disconnected, the appropriate disconnect
message appears. The SX also provides the ability to share ports among
users.

Setting Emulation on a Target

> To set emulation on the target:

e Ensure that the encoding in use on the host matches the encoding
configured for the target device, that is, if the character-set setting on
a Sun™ Solaris™ server is set to 1ISO8859-1, the target device should
also be set to ISO8859-1.

Note: ISO9660 format is the standard supported by Raritan.
However, other CD-ROM extensions may also work.

e Ensure that the terminal emulation on the target host connected to
the SX serial port is set to VT100, VT220, VT320 or ANSI.

On most UNIX® systems, export TERM=vt100 (or vt220|vt320]|ansi)” sets
the preferred terminal emulation type on the UNIX target device, that is, if
the terminal type setting on a HP-UX® server is set to VT100, the Access
Client should also be set to VT100.

The setting for terminal emulation on the SX is a property associated
with the port settings for a particular target device. Ensure that the
settings for terminal emulation in the client software such as Telnet or
SSH client are capable of supporting the target device.

Set Escape Sequence

To set the Escape sequence, ensure that the default Escape sequence
set on the SX server does not conflict with a key sequence required by
either the Access Client or the host operating system. The Escape key
sequence is user-configurable. Console sub-mode should be displayed
when the default escape key sequence "] (programmable) is pressed.

The escape sequence is programmable per port because different target
operating systems and host applications may trap different escape key
seguences.
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Port Sharing Using CLI

Access Client users can share ports with other authenticated and
authorized users, regardless of whether they are Access Client users or
SSH/Telnet users. Port sharing is used for training or for troubleshooting
applications.

e Users are notified in real time if they have Write access or Read Only
access at any point during the port-sharing session.

e Users can request Write permission to a port.

Configuring Authorization and Authentication (AA) Services

;

Raritan.

SX supports both local and remote authentication and authorization (AA)
services. Local databases for AA are maintained in an encrypted format
to prevent unauthorized access.

Remote Services

For remote services, SX supports LDAP, Active Directory®, TACACS+
and Kerberos. The SX server supports an additional level of security
services that further enhance protection of the console server. These
services are:

e I|dle timeout for inactive users
e User defined certificates
e Security profiles

Command Description

ldaps getservercert
removecert
viewcert

primaryldap

secondaryldap

radius primaryradius

secondaryradius
tacacsplus primarytacacs

secondarytacacs
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Note: When configuring the LDAP server, the query string format on the
server should contain the name of a group configured on the SX.

When configuring the Radius server, the Filter-ID format for the users on
the server should have the following format
“raritan:G{GroupOnSX}:D{DialbackNumber}*,

When configuring the TACACS+ server, the user-group format for the
user on the server should contain the name of a group configured on the
SX.

If you use older formats of "op:1:2:4" or “a:*”, the system will allow you to
log in and will restrict port accessibility according to user types and their
limitations. The SX will not have any database information about groups
at this time and will therefore display the following message in the
banner after login.

Error: Cannot get group information

The port display will show all ports because the client will not know which
port limitations exist.

LDAP Configuration Menu

The LDAP configuration menu offers commands to set up LDAP and
LDAPS.

LDAP is entered by typing Idap at the following prompt:

admin > Config > Authentication > ldap

LDAP Description
Command
ldaps Switches to the Idaps menu which includes

the following commands:

getservercert - FTP Retrieval of Idap
certificate

removecert - Remove LDAPS Certificate
viewcert - View LDAPS Certificate
primaryldap Used to configure the primary Idap settings.

secondaryldap  Used to configure the secondary Idap
settings.

166

i
i

==Raritan.



i

Raritan.

Chapter 12: Command Line Interface

LDAP Command Examples
admin > Config > Authentication > ldap

admin > Config > Authentication > ldap > ldaps

admin > Config > Authentication > ldap > ldaps > viewcert
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RADIUS Command

The RADIUS menu provides access to commands used to configure
access to a RADIUS server.

Syntax

primaryraduius <>

RADIUS Command Example

admin > Config > Authentication > radius > primaryradius

Following is information using the Raritan-Vendor-Specific attribute,
which is defined in the custom dictionary file.

The dictionary file must be created at following location
/usr/share/freeradius/

Dictionary File Configuration
# —*- text —-*-

#

# dictionary.raritan
#

# Version: S$Id$

#

VENDOR Raritan 8267
#

# Standard attribute

#

BEGIN-VENDOR Raritan

ATTRIBUTE Raritan-Vendor-Specific 26

string
END-VENDOR Raritan

Update Radius users to use the new attribute in the users file, which is
usually located at /etc/raddb/.

Raritan-Vendor-Specific = "G{Administrator}"

Note: If both filter ID and vendor specific attribute are present, the vendor
specific attribute will take preference.
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TACACS+ Command

The TACACS+ menu offers commands used to configure access to a
TACACS+.

Syntax

primarytacacs <>

TACACS+ Command Example

admin > Config > Authentication > radius > primarytacacs

Administering the SX Console Server Configuration Commands

Note: CLI commands are the same for SSH, Telnet, and Local Port
access sessions.

The configuration menu provides commands to help configure the SX:
e authentication
e events
e log
modem
network
nfs
ports
services
snmp
time
users

Configuring Events

;

Raritan.

The Events menu provides access to commands used to configure
SMTP events and servers.

Command Description

add Add an SMTP event.
delete Delete an SMTP event.
smtp Configure the SMTP server

settings.
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Events Menu Command Examples

admin > Config > events
admin > Config > events > add

admin > Config > events > smtp

170

Configuring Log

Configuration log commands allow you to manage the logging features of
the SX server:

e cleareventlog
o eventlogfile

e eventsyslog

e nfsgetkey

o nfssetkey

e portlog

e sendeventlog
e vieweventlog

Cleareventlog Command

The cleareventlog command clears the contents of the local event log.

Syntax

cleareventlog

Cleareventlog Command Example

admin > Config > Log > cleareventlog

Eventlogfile Command
The eventlogfile command controls and configures the logging of events
to the local log.

Syntax

eventlogfile [enable <truel|false>] [size value] [style
<wrap|flat>]

eventlogfile Description

Command

enable <true|false> Enable or disable the system event log
logging.



;
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eventlogfile Description

Command

size value Maximum size of local log file (in bytes).
style <wrap|flat> Specifies what action to take when the

maximum size is reached:

= wrap will cause the log to circle
around when end is reached.

= flat will cause logging to stop when
the end is reached.
Eventlogfile Command Example

admin > Config > Log > eventlogfile enable true size 256000
style wrap

eventsyslog Command

The eventsyslog command controls system event logging.
The syntax of the eventsyslog command is:
eventsyslog [enable <true|false>] [primip ipaddress] [secip ipaddress]

The eventsyslog command options are described in the following table.

Command Description

enable <true|false> Enable or disable the system event log
logging.

primip ipaddress Primary FTP server address

secip ipaddress Secondary FTP server address

Eventsyslog Command Example

admin > Config > Log > eventsyslog enable true primip 192.168.134.11
secip 192.168.245.11

portsyslog Command

The portsyslog command controls system event logging.

Syntax

portsyslog [enable <truel|false>] [primaryip ipaddress]
[secondaryip ipaddress] [category category]

portsyslog Command Description

enable <true|false> Enable or disable logging of port data
to remote a NFS server and also to the
Syslog server.
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portsyslog Command Description

primaryip ipaddress Primary Portlog Syslog server address

secondaryip ipaddress Secondary Portlog Syslog server
address

category category Portlog Syslog message category

0 ~ 7 corresponds to LocalO ~ Local7

portsyslog Command Example

admin > Config > Log > portsyslog enable true primaryip
192.168.134.11 secondaryip 192.168.245.11 category 5

nfsgetkey Command

The nfsgetkey command gets an NFS encryption key to be used for
encrypting port log data. Use the key value as input to the nfssetkey
command.

Syntax
nfsgetkey [type <rcdlaesl28>]

nfsgetkey Description
Command

type <rc4|aes128> Type of encryption key used for
encryption (rc4 or aes128)

nfsgetkey Command Example

admin > Config > Log > nfsgetkey type aesl28

nfssetkey Command

The nfssetkey command sets the type of encryption and the key.
Because NFS is insecure, it can be easily accessed and the data
misused. With SX, you can encrypt the data stored on the NFS server.
Consequently, if the data were to be accessed inappropriately, it would
be of no use to anyone without the encryption key.

The key can be set and obtained only from the SX.

Syntax
nfssetkey [type <rc4dlaesl28>] [key string]

nfssetkey Description
Command

type <rc4|aes128> Type of encryption type to be used

key string Provide key string to be used for encryption
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Note: aes128 is not supported in 3.0.

nfssetkey Command Example

admin > Config > Log > nfssetkey type aesl28 key
D2F05B5ED6144138CAB920CD

NFS Encryption Enable Command

To enable port logging and encryption of data:

admin > Config > Log > portlog enable true encrypt true

Raritan.

;

Portlog Command

The portlog command enables and configures the logging of port data.

Syntax

portlog [enable <truel|false>]
[timestamp intervall]
[indir name]
[block <true|false>]

<truel|false>]
<truel|false>]

portlog Command
enable <true|false>

prefix name
size value

timestamp interval

update interval

inputlog <true|false>

indir name

outdir name

encrypt <true|false>

block on failure
<true|false>

[prefix name]
[update interval] [inputlog
[outdir name] [encrypt

Description

Enable/Disable logging of port data to remote
NFS server.

Prefix for log file name.
Maximum Size (in bytes) for the log file.

Time interval (in seconds) between two
timestamps in the log file. A value of 0 will
disable timestamp logging. The default value
is 20. The max value is 99999.

Time interval (in seconds) between two
updates to the remote log file The default
interval is 20. The max value is 99999.

Enable/Disable logging of user input data on
the port. Input implies data sent to the target;
that is, keystrokes entered by the user).

Filename for storing input log

Filename for storing output log. Output
implies data sent from target to the SX port.

Enable/Disable Encryption of log data sent to
the remote NFS Server.

Indicate whether the NFS Server is a soft
mount (when set to false) or a hard mount
(when set to true).

[size value]
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Portlog Command Example

portlog enable true prefix DomSXlsize 1000000 timestamp
1 update 20 inputlog false indir /nfs_ SX DomIn outdir
SX Dom Out encrypt true

The following command displays the default portlog values:
admin > Config > Log > portlog
Portlog Settings
Enable : false
File Prefix: domSX-NFS
File Size : 65535
UpdateFrequency : 20
TimestampFrequency : 20
Input Log Enable : false
Input Log Directory: input
Output Log Directory: output
Encrypted : false

Block on Failure : true

Decrypt Encrypted Log on Linux-based NFS Server
To decrypt nfs encryption on Linux® platform, follow these steps:

1. Retrieve the current nfs encryption key:
admin > Config > Log > nfsgetkey type rci4

2. Cut and paste the response of this command into a file, for example,
dsx-encrypt.key.

3. Retrieve decryption application and either place it on the Linux
machine or compile its source.

4. Save the encryption key file (dsx-encrypt.key) in the same directory
where the decryption application is stored.

Copy the encrypted portlog file to the same directory.

Decrypt the file using the command:
./decrypt -f <portlogfile> -e <keyfilename> -o
<outputfile>

7. The decrypted file should be saved in <outputfile>.
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Sendeventlog Command

The sendeventlog command sends the local logfile to a remote FTP
server.

Syntax

sendeventlog [ip ipaddress] [login login] [password
password] [path pathname] [file filename]
sendeventlog Description

Command

ip ipaddress FTP server IP address

login login FTP Server login name

password FTP Server password

password

path pathname FTP server path, for example, /ftphome
file filename Filename on FTP server to save log.

For example, sxlogdfile

sendeventlog Command Example

sendeventlog ip 72.236.162.187 login acy password
pasraritansword path sxlogfile file log 32

Vieweventlog Command

The vieweventlog command displays the local log file.

Syntax

vieweventfile

vieweventlog Command Example

admin > Config > Log > vieweventlog
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Configuring a Modem

The Modem menu offers commands used to configure modem access.
Callback (dialback) occurs when the originator of a call is immediately
called back in a second call as a response to the first dial-in. Both Dial-in
and Dialback must be enabled, and the dialback number for a user must
be configured in the authentication service used on the unit (local,
RADIUS, LDAP, or TACACSH+).

Once you have configured the modem, the SX needs to be rebooted in
order for the changes to take effect (you will receive a message
prompting you to do this once you have made and applied your
changes).

The modem can be configured to allow a PPP connection, a direct
modem connection via Hyperterm, or both.

e All - Allows modem access to all modems. Looks for a PPP signal
and falls back to allow console access if the PPP signal is not
detected. In this mode, Modem Dial Back cannot be enabled.

e PPP Only - Allows only PPP connections. Allows GUI, SSH and
Telnet access (if enabled). Dialback is only allowed when utilizing a
PPP-Only configuration since allowing direct modem access would
circumvent this security protection.

e Console Only - Allows only console connections. Only CLI access is
allowed through a terminal emulation programs such as
Hypertreminal.

If All or PPP Only are used:

e The IP addresses of the Point-to-Point (PPP) server must be entered.
The default is 10.0.0.1

e The IP address of the PPP client must be entered. The default is
10.0.0.2.

If PPP Only is used:

e If you want to enable modem dialback, select the Enable Modem
Dial Back check box.

Command Description

dialback Enable/Disable the modem dial-back.
Modem must be enabled for this to work.

dialin Enable/Disable Modem and PPP settings.

[enable <true|false>] [serverip ipaddress]
[clientip ipaddress]

accessmodes [accessmodes <All|PPPOnNly|ConsoleOnly]
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Modem Menu Command Examples

admin > Config > modem > dialin enable true serverip
10.0.13.211

clientip 10.0.13.212 accessmodes PPPOnly

admin > Config > modem > dialback enable true

admin > Config > Modem > show modem

Modem Settings

Dialin Enabled: false

Access Mode: All

Server Address: 10.0.13.211

Client Address: 10.0.13.212

Dialback with local user

Before a modem connection can be established, the local user for dial-in
authentication should be configured. A new user can be added or an
existing one can be reconfigured with a correct dialback. An example
configured user (dialback number is 129) should have the following
settings:

PPP dial back works for 3 digit extensions and 7 and 11 digit numbers. If
you are using 7 and 11 digit numbers, you must use commas to separate
the 9 used for dialing an outside line and the 1 that precedes an area
code from the rest of the number. For example, 9,1,5555551212.
User Settings:
Login Modem
Name Dialback
Info: SX
Dialback: 129
Group :Admin
Active 1

When this configuration is set, the modem connection can be established.
The user may use various types of modem dial-up clients to accomplish
a successful modem connection to the SX.

Dialback with remote Radius user (Cistron Radius v1.6.7)

Dialin and Dialback should be enabled on the SX used for modem
communication. Primary (or/and Secondary) RADIUS Server Settings
should be configured correctly and enabled on the SX:

admin > Config > Authentication > RADIUS > primaryradius
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RADIUS Server Settings
Primary Server
Enabled - true
IP Address - 10.0.0.188
Port - 1812
Secret - gazlwsx

On the Remote Radius Server, the user's configuration should contain
the following line:

Filter-Id = "raritan:G{<local user group>}:D{<number for
dialback>}"

Dialback with remote LDAP user (OpenLdap v.2 & v.3)

Dial-in and Dialback should be enabled on the SX used for modem
communication. Primary (or/and Secondary) LDAP Server Settings
should be configured correctly and enabled on the SX:

LDAP Server Settings
Primary Server
Enabled - true

IP Address - 10.0.0.188

Port - 389
Secret - root
Base DN - cn=root,o=bianor

Base Search - o=bianor
Auth Query String -rciusergroup

Dialback Query String - telephoneNumber
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4. Edit - [cn=bobo, o=bianor]
File Edit

objectClass: |top

objectClass: |inetOrgPersan

objectClass: |ga

telephoneNumber: |129

uid: |boho

userPassword: |HA}YaE1C.Jﬁs\fhovgBF’eT?ASdeGAsz|| Verify ” Set || Save as ” Insert from |

rciusergroup: |Admin

sh: |bobo

cn: |b0b0

| Apphy || Cancel |

The Remote LDAP Server user's configuration should be:

Dialback with remote TACACS user (Tacacs+ v.4.0.3a)

Dial-in and Dialback should be enabled on the SX used for modem
communication. Primary (or/and Secondary) TACACS Server Settings
should be configured correctly and enabled on the SXs:

Primary Server
Enabled - true
IP Address - 10.0.0.188
Port - 49
Secret - alabala

On the Remote Tacacs Server user's configuration should own the
following line:

user—-dialback='129"

Configuring Network

The Network menu commands allow you to configure the SX network
adapter.

Commands Description
ethernetfailover Enable/Disable network failover

interface The SX network interface configuration
ipfowarding IP forwarding configuration

name Network name configuration

ports Network port configuration

route Show kernel routing table

routeadd Add route to kernel routing table
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Commands Description
routedelete Delete route of kernel routing table

Note: All operations that normally trigger a reboot or prompt the user for
feedbacks are now added a new parameter named force. This force
parameter prevents reboot, prompting or both from taking place until all
configurations are completed. The commands that now have a force
parameter are: ethernetfilover (See "Ethernetfailover
Command" on page 180), interrface (See "Interface Command"on
page 180), name (see "Name Command'on page 181), ports (see
"Ports Command'on page 182), factoryreset (see
"Factoryreset Command'on page 213) and reboot (see "Reboot
Command" on page 214).

Ethernetfailover Command

The ethernetfailover command is used to enable and disable the ability
to failover from one LAN to another.

Syntax

ethernetfailover [enable <true|false>] [interval value]
[force <true|false>]

Interface Command

The interface command is used to configure the SX network interface.
When the command is accepted, the unit automatically reboots and
drops the connection. You must then reconnect using the new IP
address and the username admin and password newp/w in the resetting
factory default password section.

Syntax

interface [enable <true|false>] [if <lanl | lan2>] [dhcp
<truel|false>] [ip ipaddress] [mask subnetmask] [gw
ipaddress] [mode <auto | 100fdx>] [force <truel|false>]

interface Command  Description

enable <true|false> Enable/Disable Interface

dhcp Enable DHCP as ip configuration

if <lanl | lan2> Select LAN interface you are configuring
ip ipaddress IP Address of the SX assigned for access

from the IP network

mask subnetmask Subnet Mask obtained from the IP
administrator
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interface Command  Description

gw ipaddress Gateway IP Address obtained from the IP
administrator.

mode <auto | 100fdx> Set Ethernet Mode to auto detect or force
100Mbps full duplex (100fdx)

force <truelfalse> The force parameter is used so that
sequences of commands can be inserted
without need for user interaction.

interface Command Example

The following command enables the interface number 1, sets the IP
address, mask, and gateway addresses, and sets the mode to auto
detect.

Admin Port > Config > Network > interface enable true if
lanl ip 192.16.151.12 mask 255.255.255 gw 192.168.51.12
mode auto

Admin Port > Config > Network > interface if lanl ip
10.0.13.98 force true

IPForwarding Command

The ipforwarding command is used to configure the ability to forward
between two networks.

Syntax

ipforwarding [enable <truel|false>]

ipforwarding Command Example
The following command enables the IP Forwarding:

admin > Config > Network > ipforwarding enable true

Name Command

The name command is used to configure the unit and host name.

Syntax

name [unitname name] [domain name] [force <true|false>]

name Command Example
The following command sets the unit name:

Admin Port > Config > Network > name unitname <unit name>
domain <host name> force trues

181

Raritan.



182

Chapter 12: Command Line Interface

Ports Command
The ports command is used to configure the network ports.
Syntax

ports [discoveryport value] [csc value] [force
<truel|false>]

e discoveryport - udp discovery port used with Command Center -
Secure Gateway

e csc - CSC Protocol tcp port used with Command Center - Secure
Gateway

ports Command Example
The following command configures the network ports:

Admin > Config > Network > ports discoveryport 5000 csc
5000

Route Command

The route command is used to view the kernel routing table.

Syntax

route <>

route Command Example
The following command displays the routing table:

Admin Port > Config > Network > route

=Raritan.
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Routeadd Command

The routeadd command is used to add a route to the kernel routing table.

Syntax

routeadd [if <ethO | ethl>] [flags <net|host>] [dest
ipaddress] [mask mask] [gw ipaddress] [mss value] [window
value] [irtt wvalue]

If Interface [ethO | eth1], LAN1 is mapped to ethO, LANZ2 is mapped to
ethl

o flags net - Route for a subnet host/host machine

e (dest - Destination host IP Address or subnet

e mask - Netmask

e gw - Gateway IP Address

e mss - Set the TCP Maximum Segment Size (MSS) in bytes

e window - Set the TCP window size for connections over this route in
bytes

e irtt - Set the initial round trip time (irtt) for TCP connections over this
route in milliseconds (1-12000)

routeadd Command Example
The following command adds a route to the routing table:

admin > Config > Network > routeadd if ethO flags net dest
192.56.76.0 mask 255.255.255.0

Routedelete Command

The routedelete command is used to remove a route from the kernel
routing table.

Syntax
routedelete <>

routedelete Command Example
The following command remove a route from the routing table:

admin > Config > Network > routedelete
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Getconfig Command

The getconfig command retrieves the script from an FTP server. This
command appears only in the administrator's help menu.

You can write a script using the same sequence and commands used in
a normal CLI session, also known as a recorded session. The script can
be used to set up commonalities among multiple SX units, including
remote authentication servers, users, and security settings. The script ca
nalso be used by technicians who know little about the SX to set up
machines after the administrator has written the script.

getconfig Command Example

The following command retrieves remote configure script from an FTP
server.

admin > getconfig [ip ipaddress] [login login] [password
password] [path pathname]

ip IP Address of FTP Server
login FTP Server login name
password FTP Server password

path FTP server path.for config file Eg.,
/ftphome/config.txt

Runconfig Command

The runconfig command attempts to run the configuration script
downloaded by the getconfig command. This command appears only in
the administrator's help menu.

runconfig Command Example

admin > runconfig
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Configuring NFS

The nfs command enables all keystrokes echoed from the target device
to be logged to a remote NFS server located within the network. The logs
can be reviewed at a later time.

admin > Config > NFS > nfs

Syntax

nfs [enable <truel|false>] [primaryip primaryip]
[secondaryip secondaryip] [primarydir primarydir]
[secondarydir secondarydir]



i
i

Raritan.

Chapter 12: Command Line Interface

nfs Command Description
enable <truelfalse> Enable or disable NFS logging.
primaryip primaryip IP address of the primary NFS server.

secondaryip secondaryip IP address of the secondary NFS server.
primarydir primarydir Primary Server mount directory

secondarydir Secondary Server mount directory
secondarydir

nfs Command Example
The following command displays the current NFS settings:

admin > Config > NFS > nfs
NFS Settings
Enable : O
Primary IP : 0.0.0.0
Pimary Directory: /export/domSX/
Secondary IP : 0.0.0.0
Secondary Directory: /export/domSXLog/

Use the following command to enable remote NFS logging and configure
the NFS Server:

admin > Config > NFS > nfs enable true primaryip
72.236.162.172 secondaryip 72.236.161.173 primarydir
/nfs/domloggingl secondarydir /nfs/domlogging?
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Configuring Ports

Ports Configuration Menu

Target serial ports are configured from the CLI using the ports menu. In
addition to the description of the physical nature of the ports, other
services may also be defined, including:

e The escape sequence used to disconnect from the port to access the
emulator to send breaks or control multi user functions such as Ctrl +
a.

e The exit string sent to the target when an idle timeout occurs. By
sending the exit string, the port is disconnected from the SX and the
next user logging in to the port will have to log in to the target as well.
(Cisco router example: logout)

e The addresses used for direct port addressing. Direct port
addressing can use an individual IP address per port or a unique
TCP Port address per port. Direct Port Addressing is supported by
both Telnet and SSH. See Direct Port Access (on page 76) for
details.

Ports Config Command

Syntax

config [port <number|range|*>] [name string] [bps value]
[parity <nonel|even|odd>] [flowcontrol <none|hw|sw>]
[detect <true|false>] [escapemode <none|control>]
[escapechar char] [emulation type] [sendbreak <duration>]
[exitstring <cmd[#delay;]>] [dpalp ipaddress] [telnet
port] [ssh port] [alwaysactive <truel|false>] [suppress
<nonelall>] [encoding type] [ multiwrite <truel|false>]
[chardelay delay] [linedelay delay]

ports config Description

Command

port Single port or range of ports (1-n or 1,3,4 or * for all

<number|range|*> ports)

name string Port Name

bps value Port speed (bitrate) in bits-per-second
(1200|1800|2400]|4800]|9600|19200|38400|57600|1152
00)

parity Port parity type

<none|even|odd>

flowcontrol Port flowcontrol type

<none|hw|sw> hw = hardware flow control

186 )/ *
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ports config
Command

detect <true|false>

escapemode
<nonej|control>

escapechar char

emulation type

sendbreak duration

exitstring
<cmd[#delay;]>

dpaip ipaddress
telnet port
ssh port

alwaysactive

suppress

encoding

multiwrite
chardelay delay

linedelay delay

Chapter 12: Command Line Interface

Description

sw =X on/X off)
Enable/Disable detection of port connection

Use Ctrl-key (escapemode=control) or single key
(escapemode=none) as escape sequence; for
example,

Ctrl-] => escapemode=control, escapechar=]

Escape character
Target Emulation type: VT100[VT220|VT320|ANSI

Duration of the sendbreak signal.
(100]200]300]|400]500|600|700|800]900|1000)

Execute exit string when port session closes, for
example, config port 1 exitstring logout (execute
logout on exit)

config port 1 exitstring #0 (disable exit string for the

port)

IP Address assigned for direct port access

TCP Port assigned for direct port access via Telnet
TCP Port assigned for direct port access via ssh

Determine whether data coming into a port is logged,
for example, config port 1 alwaysactive true (always
log activities coming into a port even if no user is
connected)

config port 1 alwaysactive false (ignore data coming
into a port when no user is connected)

Determine whether none or all messages should be
displayed during a DPA connection, such as
"Authentication successful"

Target Encoding type
(DEFAULT|US-ASCII|ISO-8859-1|ISO-8859-15|UTF-8
[Shift-JIS|EUC-JP|EUC-CN|EUC-KR)

Port set in Multiple Writer Mode.
Delay inserted between writing characters (0-9999ms)

Delay inserted between writing lines (0-9999ms)
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ports config Command Example

admin > ports >config port 1 name 1ldl bps 115200 parity
odd flowcontrol hw detect true escapemode none emulation
VT100

The following command displays the current settings for port 1:
admin > Config > Port > config port 1
Port number 1:
Name: Portl
BPS: 9600
Parity: O
Flow control: O
RSC Terminal Emulation: VT100
Disconnect: Disabled
Application: RaritanConsole
Exit String:
Escape: Control-]
DPA:
IP: 0.0.0.0
Telnet Port: O
SSH Port: O
Always Active: False

Messages suppressed: none

The following example configures DPA port settings when the you
choose DPA mode IP. The IP Address is assigned for direct port access
using the following command:

admin > Config > Port > config port 1 dpaip 10.0.13.1
admin > Config > Services > dpa mode IP (upper case for IP!)

After this option is enabled, the SX unit is restarted. DPA changes will
not be available until after the SX is rebooted.

ssh -1 sx user 10.0.13.1

Password:

~=Yea-
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Authentication successful.
Port 1: Configuration Saved.

After entering the password, you have direct access to port 1, using the
newly assigned IP specifically for port 1.

The following example configures DPA port settings for a group of ports
(make sure a free range of IPs are available for dpa IP mode usage):

admin > Config > Port > config port 1-32 dpaip 10.0.13.200
or
admin > Config > Port > config port * dpaip 10.0.13.200

In both cases above, port 1 will have an IP assigned as 10.0.13.200,
while port 2 will have 10.0.13.201, port 3 10.0.13.203, and so on.

The following example configures DPA port settings when you choose
DPA mode TCPPort. You must set the SSH or Telnet port value
assigned for direct port access:

admin > Config > Port > config port 1 ssh 7000 telnet 8000
admin > Config > Services > dpa mode TCPPort

After this option is enabled, the SX is restarted. DPA changes will not be
available until after the SX is rebooted.

try ssh -1 sx user -p 7000 10.0.13.13 or telnet -1 sx user
10.0.13.13 8000

Password:
Authentication successful.
Port 1: Configuration Saved.

After entering the password, you have direct access to port 1, using the
newly assigned TCPPorts(either ssh or telnet), specifically for port 1.

The following example configures DPA port settings for a group of ports
(make sure no TCPPorts have been assigned, and a free range of
TCPPorts are available for dpa TCPPort mode usage):

admin > Config > Port > config port 1-32 ssh 7000 telnet
8000

or

admin > Config > Port > config port * ssh 7000 telnet 8000
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In both cases above, port 1 will have ssh port 7000 and telnet port 8000
assigned for direct port access, port 2 will have ssh port 7001 and telnet
port 8001, and so on.

Other DPA TCPPort options:
config <port *> <ssh tcpport>
config <port portnumber> <ssh tcpport>
config <port port range> <ssh tcpport>
config <port *> <telnet tcpport>
config <port portnumber> <telnet tcpport>

config <port port range> <telnet base tcpport>

To configure all ports using a block of contiguous port numbers, use the
<port *> command. If port_range is specified, a block of contiguous port
numbers are used. The given value of base_tcpport is used as starting
value. For individual port configuration, the <port portnumber> command
can be used.

Note: Large char and line delays on a port (2 seconds +) should only be
used in interactive sessions. If a large file is cut/pasted into the terminal
when a large delay is present, it is possible for some of the data to get
dropped instead of written to the port.

Ports Keywordadd Command

Keywords can be configured per port. After a keyword is configured for a
port, if the event is selected for notification, an SMTP notification is sent
upon detecting this keyword in the data coming from the target
connected to the port.

Syntax

keywordadd [port <number|rangel|*>] [keyword value]

keywordadd Command Example

admin > configuration > ports > keywordadd port 1 keyword
11
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Ports Keyworddelete Command

The keyworddelete command removes an existing keyword.

Syntax

keyworddelete

keyworddelete Command Example

[keyword value]

admin > configuration > ports > keyworddelete keyword 11

Configuring Services

i

Raritan.

These commands provide the ability to configure the SX server services:

DPA
Encryption
HTTP

HTTPS

Logout

LPA

SSH

Telnet
fixedtcpwindow
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dpa Command

The permitted TCP Port Range is 1024-64510. When run without the
mode parameter, the system displays the current dpa type.

The general syntax of the dpa command is:

dpa [mode <Normal|IP|TCPPort>]

The syntax for accessing a port directly using tcp port# is:
ssh -1 sx user -p tcp port N sx ip addr

sx user@sx ip addr's password: <prompted by ssh>

telnet -1 sx user sx_ip addr tcp port N

Password: <prompted by telnet>

The syntax for accessing a port directly using the ip address assigned
per port is:

ssh -1 sx user dpa ip addr

sx_user@dpa ip addr's password: <prompted by ssh>

telnet -1 sx user dpa ip addr

Password: <prompted by telnet>

The dpa command options are described in the following table.

dpa Command Description

mode Per-port Direct Port Access type mode

<Normal|IP[TCPPort> Normal - a default value that means DPA

access cannot be established

IP - access target port directly by unique IP
Address via ssh/telnet/http/https

TCPPort - access target port directly by unique
TCP port via ssh/telnet

=Raritan.
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Note: There is currently no way to set the unit back to the default DPA IP
of 0.0.0.0.

dpa Command Example
The following example chooses the DPA IP mode IP:

admin > Config > Services > dpa mode IP

Note: When any changes are made over DPA mode and ports DPA
configuration, the SX needs to be rebooted to apply new settings. DPA
changes will not be available until after the SX is rebooted.

After a successful DPA connection, try the following:
ssh -1 sx user 10.0.13.1

Password:

Authentication successful.

Starting DPA for port 1

Authentication successful.

Escape Sequence is: Control-]

You can now go directly to port 1 using the newly assigned IP.

To disable DPA (set by default, this option could be used after you have
explicitly enabled DPA before):

admin > Config > Services > dpa mode Normal

Enabling unauthorizedportaccess to a set of ports assigned to
‘Anonymous' group.

Unauthorized port access is available only for configured DPA methods.
Use the following command:

admin > Security > LoginSettings > unauthorizedportaccess
enable true

When unauthorizedportaccess is enabled, it automatically enables
Anonymous group and the user is able to configure it according to his
requirement:

admin > Security > LoginSettings > unauthorizedportaccess
Unauthorized Port Access Settings:

Enable: 1
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Group Settings:
Name: Anonymous
Class: Operator
Ports:

To configure Anonymous group settings choose config > user and
execute the following command:

admin > Config > User > editgroup name Anonymous class
op ports 1,2,3,4,5

Editing group...

Group Anonymous: Configuration Saved

The 'Anonymous' group is successfully configured.

DPA Anonymous access

The DPA is already configured (see the DPA configuration settings
section).

DPA Mode is IP, IP 10.0.13.240 is assigned to port 1.

When accessing the serial port with Anonymous port access, user name
should be "anonymous" and empty password <blank> as shown below.
Anonymous access is granted if both username and password fields are
empty (<blank>).

Note: If "anonymous" with a lower case a is entered, the application will
allow access without prompting for a password.

ssh -1 anonymous 10.0.13.240
Password:

Authentication successful.
Starting DPA for port 1
Authentication successful.
Escape Sequence is: Control-]

If suppress option is "all", no authentication credentials are shown and
you jump directly to the target prompt.

configuration > ports > config port 1 suppress all
ssh -1 anonymous 10.0.13.240

If option suppress is "none", authentication credentials are shown
(username: password:).

=¥ oo

=Raritan.

{



;

Raritan.

Chapter 12: Command Line Interface

configuration > ports > config port 1 suppress none

ssh -1 anonymous 10.0.13.240
Password:

Authentication successful.
Starting DPA for port 1
Authentication successful.

Escape Sequence is: Control-]

You are now master for the port.

Encryption Command

The encryption command sets the type of encryption for HTTPS.

Note: The factory default value of this protocol is SSL.

Syntax
encryption [prot <TLS|SSL>]

encryption Description
Command

prot <TLS|SSL> Select TLS or SSL encryption

encryption Command Example
The following example sets SSL encryption for HTTPS:

admin > Config > Services > encryption prot SSL

HTTP Command

The http command is used to control http access and redirection and to
define the port.

Syntax

http [enable <truel|false>] [port value] [redirect
<truel| false>]

http Command Description
enable <true|false> Enable/Disable HTTP access

port value HTTP server default listen port (tcp)

redirect <true|false> Enable/Disable redirection from HTTP to
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HTTPS

http Command Example
The example below enables http access and redirection to https and sets
the default port to 2.

admin > Config > Services > http enable true port 2 redirect
true

HTTPS Command

The https command is used to control https access and define the port.

Syntax
https [enable <truel|false>] [port value]

https Command Description
enable <true|false> Enable/Disable HTTP access
port value HTTP server default listen port (tcp)

https Command Example
admin > Config > Services > https

Https Settings:
Enabled : true

Port : 443

Logout Command

The logout command is used to log out of the current CLI session.

You can log out at any command level.

LPA Command

The Ipa command is used to display and set local port access
configuration. SX units have one or two local ports, depending on the
model. See Appendix A (see "SX Serial RJ-45 Pinouts" on page 265)
for pinouts on DB9-M and RJ45-F ports.

Syntax
lpa [enable <true|false>] [bps value]

I[pa Command Description

none The Ipa command with no parameters
specified displays the current LPA

==
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Ipa Command Description
configuration.

enable <true|false>  enable Enable/Disable Local Port access

[bps value] Local Port speed (bit rate) in bit/s. Possible
values are:
(9600]19200|38400|57600|115200)

Ipa Command Example

The following command enables local port access and sets the baud

rate.

admin > Config > Services > lpa enable true 115200

SSH Command

Syntax
ssh [enable <truel|false>] [port value]
ssh Command Description

enable <true|false> Enable or disable SSH access.

port value SSH server tcp listen port

ssh Command Example

admin > Config > Services > ssh enable true port 4

The system displays this message after entering the preceding
command.

The system must be rebooted for changes to take effect.

Note: Customers experiencing slow SSH connectivity in SX 3.1.5 or SX
3.1.6 after upgrading to SX 3.1.7 should invoke the ssh enable true
command to avoid this issue in the future.

Telnet Command

Syntax

telnet [enable <truel|false>] [port value]

telnet Command Description
enable <true|false> Enable or disable Telnet access.

port value Telnet server tcp listen port
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telnet Command Example
The command below enables telnet access on port 23.

admin > Config > Services > telnet enable true port 23

fixedtcpwindow Command

The fixed TCP Window is enabled by default. The Fixed TCP window
command is used to disable automatic TCP window scaling. This is
necessary for some Windows Vista® clients to be able to properly
connect to the SX. If you notice connection issues to the SX, you may
need to disable this.

Syntax

fixedtcpwindow [enable <truel|false>]

enable <true|false> enable fixed tcp windows, or
disable (allow TCP

window scaling)

fixedtcpwindow Command Example
admin > Config > Services > fixedtcpwindow enable true
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Configuring SNMP

The SX server supports sending SNMP alerts to a predefined SNMP
server. The Raritan SNMP MIB is found in the FAQs in the support
section of the Raritan web site. The following commands configure the
SNMP features:

e add
e delete
e snmp

SMNP Add Command

The add command adds trap recipients. A recipient is an IP address with
an optional space- separated port number. Traps may be sent to multiple
ports with the same IP address.

Syntax
add [dest ipaddress] [port value]

add Command Description
dest ipaddress SNMP destination IP
address

i
i
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port value SNMP destination port

SNMP add Command Example
admin > Config > SNMP > add 72.236.162.33 78

SNMP Delete Command

The SNMP delete command deletes trap recipients. A recipient is an IP
address with an optional space-separated port number. When removing
a recipient with a port number, include the port number in the delete
command. Traps may be sent to multiple ports with the same IP address.

Syntax
delete [dest ipaddress]

delete Description

Command

dest ipaddress SNMP destination ip address to be
deleted

SNMP delete Command Example
admin > Config > SNMP > delete 72.236.162.33

SNMP Command

The SNMP command controls SNMP traps and specifies the community
name used to send traps.

Syntax

snmp [enable <true|false>] [public community-string]

snmp Command Description
enable <truelfalse> Enable/Disable SNMP

public community-string ~ Community string

snmp Command Example
admin > Config > SNMP > snmp enable true public XyZzZyl

Configuring Time

;
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Time-related configuration mode commands:

clock

e ntp
e timezonelist
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Clock Command

The clock command allows you to set the time and date for the server.

Syntax
clock [tz timezone] [datetime datetime-string]

clock Command Description

tz timezone The timezone index is a number
corresponding to the desired time zone.

datetime The date and time string for the console

datetime-string server unit. Enter in the following format:
"YYYY-MM-DD HH:MM:SS"

timezonelist Using this option displays a list of time zones

and index values. Use the index values with
the [tz] option.
clock Command Example
The following command sets the SX date and time to 12-Jul-06, 09:22:33
AM, in time zone 21.

admin > Config > Time > clock tz 21 datetime "2006-07-12
09:22:33"

NTP Command

The ntp command lets you determine if a Network Time Protocol (NTP)
server should be used to synchronize the SX clock to a reference.

Syntax

ntp [enable <true | false>] [primip primip] [secip secip]

ntp Description
Command
enable Enable or disable the use of NTP.

primip primip ~ The primary NTP server to use first.

secip secip The NTP server to use if the primary is not
available.

ntp Command Example
The following command enables NTP.

admin > Config > Time > ntp enable true primip 132.163.4.101

i
i
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Timezonelist Command

The timezonelist command returns a list of timezones and associated
index values. The index values are then used as part of the clock
command.

Syntax

timezonelist

Configuring Users
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The following commands allow you to manage users:
e addgroup

e adduser

e deletegroup

e deleteuser

e editgroup
e edituser
e groups

e users

Addgroup Command

The addgroup command creates a group with common permissions.

Syntax
addgroup [name groupname] [class <op|ob>] [ports
<number|range|*>] [power <number|range|*>] [sharing

<true|false>]

addgroup Command Description
name groupname Group name
class <op|ob> Group user class <op>erator or <ob>server

ports <numberjrange[*>  Port(s) assigned to the group. Single port or
range of ports (1-n or 1,3,4 or * for all ports)

power <number|range|*> Power strip assigned to the group. Single
power strip or range of power strips.

sharing <true|false> Indicate whether users in the group are
allowed to access a port that already has
users connected to it if the port access mode
is set to Share.
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addgroup Command Example

admin > Config > User > addgroup name unixgroup class op
ports 1,2,3 power 1,2,3

Adduser Command

The adduser command is used to manage information about a specified
user.
Syntax

adduser [user loginname] [fullname user's-fullname]
[group name] [dialback phonenumber] [password password]
[info user-information] [active <true|false>]

adduser Command Description
user loginname Login Name (Required)

fullname user's-fullname  User's full name (required)

group name Group to associate with user (required)

dialback phonenumber Dialback phone number for this user
(optional)

password password User's password (required)

info user-information Miscellaneous user information

active <true|false> Activate/Deactivate user account

adduser Command Example
The following command shows how to add a user:
admin > Config > User > adduser user jjones fullname

John-Jones groupunixdialback 12146908003 password 123abc
info AP-Systems active true

Deletegroup Command

The deletegroup command deletes an existing group.

Syntax

deletegroup [name groupname]

deletegroup Description
Command
name groupname Group name

deletegroup Command Example

admin > Config > User > deletegroup name unixgroup
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Deleteuser Command

The deleteuser command is used to remove a specified user.

Syntax

adduser [user loginname]

deleteuser Description
Command
user loginname Login Name (Required)

deleteuser Command Example

admin > Config > User > deleteuser user jjones

Editgroup Command

The editgroup command edits an existing group.

Syntax
editgroup [name groupname] [class <op|ob>] [ports
<number|range|*>] [power <number|range|*>] [sharing

<truel|false>]

editgroup Command Description

name groupname Group name

class <op|ob> Group user class <op>erator or
<ob>server

ports <number|range|*>  Port(s) assigned to the group. Single port
or range of ports (1-n or 1,3,4 or * for all
ports)

power <number|range|*> Single power strip or range of power strips
assigned to the group.

sharing <true|false> Indicate whether port access is shared
while the port is being utilized.

editgroup Command Example

admin > Config > User > editgroup name unixgroup class

op ports 1,4 power 1,4
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Edituser Command

The edituser command is used to manage information about a specified
user.

Syntax

edituser [user loginname] [fullname user's-fullname]
[group name] [dialback phonenumber] [password password]
[info user-information] [active <true|false>]

edituser Command Description
user loginname Login Name (Required)

fullname user's-fullname User's full name
group name Group to associate with user

dialback phonenumber  Dialback phone number for this user

password password User's password
info user-information Miscellaneous user information
active <true|false> Activate/Deactivate user account

edituser Command Example
The following command shows how to change a user's password:

admin > Config > User > edituser user admin password newp/w

Groups Command

The groups command shows the details of existing groups.

Syntax

groups

groups Command Example
admin > Config > User > groups

Users Command

The users command shows the details of existing users.

Syntax

users

users Command Example

admin > Config > User > users

i
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Connect Commands

The connect commands allow you to access ports and their histories.

Command
connect

clearhistory
close, quit, q

gethistory

getwrite
return

sendbreak

writelock
writeunlock
powerstatus
powertoggle

uptime

Description

Connect to a port. The port
sub-menu, reached using escape
key sequence.

Clear history buffer for this port.
Close this target connection.

Display the history buffer for this
port.

Get write access for the port.
Return to the target session.

Send a break to the connected
target.

Lock write access to this port.
Unlock write access to this port.
Query Power status of this port.
Toggle Power On/Off of this port.

Prints the current system uptime
information.

Configuring Power

;

Raritan.

The following power commands allow you to manage power strips

attached to the SX.

Command
associate

association

cycle

off

Description
Associate a Power Strip outlet to a SX Port.

View Currently configured associations.

Power cycle specified ID.

Note: If you are connecting a PX to the SX, itis
recommended you set the power cycle time to 5
seconds.

Power off specified ID.
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Command
on

outlet
powerdelay
powergroup
powerstatus
powerstrip
setpowerport

unassociate

unsetpowerport

Description
Power on specified ID.

Edit outlet information.

Configure global Power Strip delays.

Switch to Power Group Menu.

Get Power Strip status.

Edit Power Strip information.

Configure an SX Port to contain a power strip.

Remove a power outlet association from an SX
Port.

Configure an SX Port to remove a power strip.

See CLI Command for Power Control (on page 243) for details about
power command scenarios.

Diagnostic Commands

The diagnostic commands allow you to gather information for

troubleshooting.

Command Description

ifconfig Show detailed network configuration
netstat Print network connections

ping Ping a remote system

ps Report system process status
traceroute Trace the network route to a host

[-dnrv] [-m maxttl] [-p port#] [-q nqueries] [-S
srcaddr] [-t tos] [-w wait] host [data size]

uptime Print the current system uptime information

IPMI Commands

IPMIDiscover and IPMITool commands allow you to work with
IPMI-supported devices.
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IPMIDISCOVER

The ipmidiscover tool is user to discover Intelligent Platform
Management Interface (IPMI) servers in the network.

e The IP address range can be set using startlP and endIP.

e Only users belonging to the Administrator group are able to configure
the support of IPMI. The supported IPMI version 2.0.

Syntax
ipmidiscover [OPTIONS] startIP endIP

All discovered targets supporting IPMI version 2.0 is listed, allowing the
user to select one and execute the IPMI operations.

ipmidiscover Description
Command

[OPTIONS] Two options are supported:
-t timeout [seconds] to complete the discovery
-i interval [seconds] between each ping
startIP Beginning IP address
endIP Ending IP address

ipmidiscover Command Example
admin> IPMI > ipmidiscover -t 20 10.0.22.1 10.0.22.10

Discovering IPMI Devices
IPMI IP: 10.0.22.2
IPMI IP: 10.0.22.7

It is possible for the IP address range to span different subnets.

IPMITOOL

This command lets you manage the IPMI functions of a remote system,
including printing FRU information, LAN configuration, sensor readings,
and remote chassis power control. The ipmitool command controls
IPMI-enabled devices. The user name to access the IPMI device is
ADMIN, password ADMIN.

Syntax
ipmitool [-c|-h|-v|-V] -I lanplus -H<hostname> [-p <port>]
[-U <username>] [-L <privlvl>] [-a|-E|-P|-f <password>]
[-0 <oemtype>] [-C <ciphersuite>]
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ipmitool
Command

-V

-1 <interface>
-H <address>
[-p <port>]

[-U <username>
]

[-L <privivI>]

[-al-E|-P|-f
<password>]

[-0 <oemtype>]

[-C <ciphersuite
>]

<command>

Description

Present output in CSV (comma separated variable)
format. This is not available with all commands.

Get basic usage help from the command line.

Increase verbose output level. This option may be
specified multiple times to increase the level of debug
output. If given three times you will get hexdumps of all
incoming and outgoing packets.

Display version information.

Selects IPMI interface to use. Supported interfaces that
are compiled in are visible in the usage help output.

Remote server address, can be IP address or
hostname. This option is required for lan and lanplus
interfaces.

Remote server UDP port to connect to. Default is 623.

Remote server username, default is NULL user.

Force session privilege level. Can be CALLBACK,
USER, OPERATOR, ADMIN. Default is ADMIN.

-a Prompt for the remote server password.

-E The remote server password is specified by the
environment variable IPMI_PASSWORD.

-P <password> Remote server password is specified on
the command line. If supported it is obscured in the
process list.

-f <password_file> Specifies a file containing the remote
server password. If this option is absent, or if
password_file is empty, the password will default to
NULL.

Select OEM type to support. This usually involves minor
hacks in place in the code to work around quirks in
various BMCs from various manufacturers. Use -0 list to
see a list of current supported OEM types.

The remote server authentication, integrity, and
encryption algorithms to use for IPMIv2 lanplus
connections. See table 22-19 in the IPMIv2
specification. The default is 3 which specifies
RAKP-HMAC-SHAL1 authentication, HMAC-SHA1-96
integrity, and AES-CBC-128 encryption algorithms.

raw - Send a RAW IPMI request and print response

i2c - Send an 12C Master Write-Read command and
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Description

print response

lan - Configure LAN Channels

chassis - Get chassis status and set power state
power - Shortcut to chassis power commands

event - Send pre-defined events to MC

mc - Management Controller status and global enables
sdr - Print Sensor Data Repository entries and readings
sensor - Print detailed sensor information

fru - Print built-in FRU and scan SDR for FRU locators
sel - Print System Event Log (SEL)

pef - Configure Platform Event Filtering (PEF)

sol - Configure and connect IPMIv2.0 Serial-over-LAN

tsol - Configure and connect with Tyan IPMIv1.5
Serial-over-LAN

isol - Configure IPMIv1.5 Serial-over-LAN

user - Configure Management Controller users
channel - Configure Management Controller channels
session - Print session information

firewall - Configure firmware firewall (IPMIv2.0)
sunoem - OEM Commands for Sun servers

picmg - Run a PICMG/ATCA extended cmd

fwum - Update IPMC using Kontron OEM Firmware
Update Manager

shell - Launch interactive IPMI shell
exec - Run list of commands from file

set - Set runtime variable for shell and exec
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ipmitool Command Example

The following command allows the user to get the chassis status and set

the power state.

admin> IPMI > ipmitool -TI lan -H 10.0.22.7 -U ADMIN chassis

status

Password:

System Power on

Power Overload false
Power Interlock inactive
Main Power Fault false
Power Control Fault false
Power Restore Policy always-off
Last Power Event command
Chassis Intrusion active
Front-Panel Lockout inactive
Drive Fault false
Cooling/Fan Fault false

See http://ipmitool.sourceforge.net/manpage.html for additional

information.

Listports Command

Command Description
listports List accessible ports.
admin > listports
Port no. Port name
1 Portl [U]
2 Port2 [U]
3 Port3 [U]
4 Port4 [U]
column Can be 1,2,3. Indicates the number of columns to

display the port list in.

210 =

=Raritan.

{



Chapter 12: Command Line Interface

Port names up to 23 characters are displayed when two columns are
needed to display the available ports. When three columns are needed
to list the ports, the port names are limited to 13 characters in order to
ensure the entire port list fits on a standard 80x25 screen.

Longer port names are truncated to 22 characters, with a $ sign at the
end. The letter after the port name describes the state of each port. This
includes:

e D, B-Down, Busy
U, B - Up, Busy

D - Down

U-Up

Maintenance Commands

;
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The maintenance commands allow you to perform maintenance-related
tasks on the SX firmware:

e backup
e cleareventlog
factoryreset
firmware

logoff

reboot

restore
sendeventlog
upgrade
upgradehistory
upgradestatus
userlist

e vieweventlog

Note: All operations that normally trigger a reboot or prompt the user for
feedbacks are now added a new parameter named force. This force
parameter prevents reboot, prompting or both from taking place until all
configurations are completed. The commands that now have a force
parameter are: ethernetfilover (See "Ethernetfailover
Command' on page 180), interrface (See "Interface Command"0On
page 180), name (see "Name Command'on page 181), ports (see
"Ports Command'on page 182), factoryreset (see
"Factoryreset Command'on page 213) and reboot (see "Reboot
Command' on page 214).
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Backup Command

The backup command makes a copy of the SX configuration and writes
the backup onto an ftp server. The current SX configuration is saved to
the computer with the IP set in the command parameters in an encrypted
format. All device settings except network settings are stored in the file,
wh can be recovered if a Restore operation becomes necessary.

Syntax

backup [ip ipaddress] [login login] [password password]
[path pathname] [file filename]

backup Command  Description

[ip ipaddress] IP address of the target system where the
backup is written.

<login login> Username of the account on the system where
the backup is stored.

<password Password of the account on the system where

password> the backup is stored.

[path pathname] Specifies the path to the backup file.

[file filename] Specifies the name of the file in which the

backup is saved.

backup Command Example

In this example, the console server data is sent to a system at the IP
address 192.168.51.220. The guest account and password are used.
The data is saved at the top level of the guest account as a file named
backupfile.

admin > system > backup ip 10.0.0.188 login sx password
gazlwsx path /home/backup file bac

Cleareventlog Command

The cleareventlog command clears the contents of the local event log.

Syntax

Cleareventlog

cleareventlog Command Example
admin > Config > Log > cleareventlog
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Factoryreset Command

The factoryreset command returns the SX console server to its default
factory settings.

Important: If you choose to revert to the factory settings, you will
erase all your custom settings and will lose your connection to the
SX because, upon rebooting, the IP address of the unit is reset to
the factory default IP address of 192.168.0.192. If the network is
running a DHCP server, the unit is reset to a different IP address,
because DHCP is enabled by default when the unit is reverted to
factory settings.

Syntax

factoryreset

factoryreset Command Example

admin > Maintenance > factoryreset
Network Settings:

Name: DominionSX
Domain raritan.com
CSC Port: 5000
Discover Port: 5000

DHCP Client: true

IP: 192.168.0.192
Net Mask 255.255.255.0
Gateway 192.168.0.192
Failover true
Do you wish to commit these settings (no/yes) (default:
no)
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Firmware Command

The firmware command provides the versions of the firmware.

Syntax

firmware

firmware Command Example

admin > Maintenance > firmware
Version Information

Firmware Version : 3.0.0.1.15
Kernel Version : 2.4.12

PMON Version: 2.0.1

RSC Version: 1.0.0.1.16

Logoff Command

Command Description
logoff Force logoff (terminate) a user or port
session.

Reboot Command

The reboot command restarts the SX console server. This command is
only available to users with administrative privileges. All user sessions
are terminated without warning, and no confirmation is required. It is
highly recommended that you ask all users to log off before you reboot
the unit. The userlist command can be used to display a list of connected
users and sessions.

Syntax

reboot

reboot Command Example

admin > Maintenance > reboot
The system responds with the following messages:
Rebooting the system will log off all users.

Do you want to proceed with the reboot? (no/yes) (default:
no) vyes

i
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Restore Command

The restore command retrieves a copy of the SX system from a system
and writes the file to the SX server.

Syntax

restore [ip ipaddress] [login login] [password password]
[path pathname] [file filename]

restore Command Description

[ip ipaddress] IP address of the target system from which
the restore data is retrieved

<login login> Username of the account on the system
where the restore data is stored

<password Password for the above account

password>

[path pathname] Specifies the path to the backup file to be

restored to a similar system with the same
port density

[file filename] Specifies the name of the file in which the
backup data was saved

restore Command Example

In this example, the console server data is being retrieved from a system
at IP address 192.168.51.220. The guest account and password are
used. The data is pulled from the top level of the guest account in a file
named backupfile.

admin > system > restore ip 192.168.51.220 login guest
password guestpassword path /home/bac file backupfilel

Sendeventlog Command

The sendeventlog command sends the local logfile to a remote FTP
server.

Syntax

sendeventlog [ip ipaddress] [login login] [password
password] [path pathname] [file filenamel]
sendeventlog Description

Command

ip ipaddress FTP server IP address

login login FTP Server login name

password password FTP Server password
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sendeventlog Description

Command

path pathname FTP server path. For example, /ftphome
file filename Filename on FTP server to save log. For

example, sxlogdfile

sendeventlog Command Example

admin > Config > Log > sendeventlog ip 72.236.162.187 login
acy password pasraritansword path sxlogfile file log 32

Upgrade Command

Note: To perform an upgrade, there must be a configured remote ftp
server.

The upgrade command upgrades one version of the system to another
version, for example v2.5 to v3.0.

During the upgrade, SX verifies there is enough space on the device to
perform the upgrade. If there is not, the SX restarts and the upgrade
does not take place. If the upgrade fails due to lack of space, clear the
local logs on the device and try upgrading again. Contact Raritan
Technical Support if you still cannot upgrade after clearing the local logs.

Syntax

upgrade [ip ipaddress] [login login] [password password]
[path pathname]

upgrade Description

Command

ip ipaddress IP Address of FTP Server
login login FTP Server login name
password FTP Server password
password

path pathname FTP server path. For example,

[ftphome/UpgradePack/Pack1ofl

upgrade Command Example

admin > Maintenance > upgrade ip 10.0.0.188 login sx
password gazlwsx path
/var/ftp/UpgradePack 2.5.6 3.0.0.1.15/Packlofl
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Upgradehistory Command

The upgradehistory command provides information about the last time
you upgraded the system.

Syntax
upgradehistory

upgradehistory Command Example

admin > Maintenance > upgradehistory
Overall Upgrade History:

3.0.0.1.15 Wed Sep 13 19:07:38 2006

Userlist Command

The userlist command displays a list of all users who are logged in, their
source IP Addresses and any ports to which they are connected.

Syntax

userlist

Vieweventlog Command

The vieweventlog command displays the local log file.

Syntax

Vieweventfile

vieweventlog Command Example

admin > Config > Log > vieweventlog

Security Commands

;
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SX controls the ability to hack into the system by using random logins.
These security command menus provide access to the commands
needed to configure the SX security features:

e banner

e certificate

o firewall

e kerberos

¢ loginsettings

e securityprofiles
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Banner Command

The banner command controls the display of a security banner
immediately after login.

Syntax
banner [display <truel|false>] [audit <true|false>]

banner Command Description
display <truelfalse>  Enable/Disable banner display

audit <truelfalse> Enable/Disable audit for the banner,
when banner display is enabled

banner Command Example

admin > Security > banner > banner display true audit false

Ftpgetbanner Command

The ftpgetbanner command directs the SX to go to this site to retrieve
the welcome banner. The welcome banner and the audit statement are
maintained on an external FTP site.

Syntax

ftpgetbanner [ip ipaddress] [login login] [password
password] [path pathname]

ftpgetbanner Description

Command

ip ipaddress FTP server IP address

login login FTP Server login name

password FTP Server password

password

path pathname FTP server path for the banner file

banner.txt. for example,/ftphome/banner.txt

ftpgetbanner Command Example

admin > Security > Banner> ftpgetbanner ip 72.236.162.171
login raritan password acy path /ftphome/banner.txt
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Certificate Command Menu

The certificate command menu provides the client and server commands
to create and manage security certificates.

Note: If the SX is not used to generate the certificate signing request and
an external certificate is used instead, encryption needs to be removed
from the private key before installing it on the SX. If this is the case, to
remove the encryption from the key, a command such as openssl rsa -in
server.key -out server2.key and server2.key should be used. Encrypted
private keys are used to prevent the web server from being started by
unauthorized users. Since SX does not allow users to access the web
server directly, encrypted private keys are not required and does not
compromise security.

Note: When the SX is used to generate the certificate signing request,
the private key is not required since SX keeps the private key exclusive.

Syntax

certificate <>

Raritan.

;

Note: For a description of how to enable LDAP over SSL with a
third-party certification authority, see
http://support.microsoft.com/default.aspx?scid=kb;en-us;321051. The
document requires the exchange of certificate of authority created by the
MS Server.

certificate Description

Command

add Install a User Certificate

addcrl Install a CA's CRL

clientcert Activate Client Side Certificate Verification
delete Remove Client CA Certificate

deletecrl Remove Client CA's CRL

viewcacert View Client CA Certificate

viewcrl View Client CA CRL Certificate
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Certificate Client Command Example
Enable SSL Client Certificates:

admin > Security > certificate > clientcert enable true
Install Certificate Authority:

admin > Security > certificate > add ip 10.0.0.189 login
root password passwordword path /home/cert/ SXCert file
cacert.pem ca ca_test

Add Certificate Renovation List:

admin > Security > certificate >addcrl ip 10.0.0.189 login
root password pass path /home/cert/SXCert file demoCA.crl
ca crl test

Delete Certificate Renovation List:

admin > Security > certificate > deletecrl ca crl test

certificate Description
Command

activatedefaultcert  Activate Default System SSL Certificate

activateusercert Activate User SSL Certificate
generatecsr View Default System Cert
generatedefaultcert  Generate Default System SSL
Certificate

installusercert Install a User Certificate
installuserkey Install a User Certificate Key
viewcsr View The Certificate Signing Request
viewdefaultcert View default system certificate
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Server Command Example
Install User Certificate:

admin > Security > certificate > installusercert ip
10.0.0.189 login root password pass path /home/SXCert file
SX.pem

Install User Key:

admin > Security > certificate > installuserkey ip
10.0.0.189 login root password pass path /home/ SXCert
file sx.pem

Activate User Certificate:
admin > Security > certificate > activateusercert
Generate Certificate Signing Request:

admin > Security > certificate > generatecsr bits 1024
name test csr country BG state Ko locality Seoul org Bnr
unit SX email sx@bir.net

Raritan.

i

Firewall Command
The firewall command provides control for the turning on or off the
firewall.

Syntax

firewall [enable <true|false>]

firewall Command Description

enable <true|false> Enable/Disable firewall with true or
false

firewall Command Example

admin > Security > Firewall > firewall enable true

Note: Use the following when working with the Firewall.

Chain FORWARD (policy ACCEPT)
target prot opt source destination

When you enable IP forwarding for Dual LAN units, use IPTables rules to
create policies for traffic being forwarded between LAN interfaces.
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IPtables Command

The iptables command is an administration tool for IPv4 packet filtering
and Network Address Translation (NAT). The iptables command

provides an interface to the linux iptables. The command parameters and

options are the same as the linux system command.

iptables Command
-A input

--dport
--flush
-j target

-list

--log-prefix DOM_IPACL
-m state

P

-s

-save

--state NEW <enter rule
to trigger here>

-t filter

Description

Append one or more rules to specified
chain.

Destination port.
Clear the iptables.

Jump based on the following target
keywords:

ACCEPT - Packet is passed through (i.e.
for INPUT chain, processed by local stack,
for OUTPUT, sent)

DROP -Packet is dropped and no further
processing is performed

LOG -

QUEUE - Passes datagram to user space
(if supported by kernel)

RETURN - Terminates processing by this
chain and resumes the calling chain (or
executes the chain policy if there is no
calling chain)

View the current iptables.

Load a match extension module.
The protocol of the traffic.
Source address.

Save the IP Tables.

i
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iptables Command Examples

Iptables can be configured in a plethora of ways that is outside the scope
of this document. The examples below show some simple configuration
options created with iptables.

The following example enables a log for iptables:

admin > firewall > iptables -A INPUT -t filter -3j LOG
--log-prefix DOM IPACL -m state --state NEW -s <IP>

Adding a default local rule

The default local rule is included as part of the standard SX
implementation.

Restricting Access from an IP Address

To restrict access to the SX from a specific IP address (192.168.1.100):
admin > Security > firewall > iptables -A INPUT -t filter
-3 DROP

-s 192.168.1.100

Logging a message when IP Address connects

To send a syslog message when an IP Address connects to the SX:

admin > Security >firewall >iptables -A INPUT -t filter
-j LOG

--log-prefix DOM IPACL -m state --state NEW -s
192.168.1.100

Allowing Access from an IP Range

To allow access to the SX from a specific IP range
(192.168.0.1-192.168.0.255).

admin > Security > firewall > iptables -A INPUT -t filter
-j ACCEPT -s 192.168.0.0/255.255.255.0

Disable all ICMP traffic
To disable ICMP protocol traffic, and have the SX not respond to pings.

admin > Security > firewall > iptables -A INPUT -p icmp
-3 DROP

Prevent Access to the Telnet port from an IP Address
To disable acccess to the telnet port for a particular ip address

admin > Security > firewall > iptables -A INPUT -p tcp
-—-dport 23
-3 DROP -s 192.168.0.100

View the current iptables
To view the current iptables rule:

admin > Security > firewall > iptables --list
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or

admin > Security > firewall > iptables -xvnL

Clear the iptables rules
To clear the iptables rules.

admin > Security > firewall > iptables --flush

Save the configured settings
To save the iptables rules into the local database.

admin > Security > firewall > iptables-save

Note: No spaces between iptables and save.

Execute this command once you have configured all the settings.

Kerberos Command

The Kerberos command menu offers access to the commands used to
configure the Kerberos network authentication protocol:

Kerberos Description
Command

gethostnamefile  Get /etc/hosts in case of DNS failure file.

getkrbconfig Get Kerberos 5 configuration file.
kadmin Kerberos admin client.

kerberos Kerberos-based Network Authentication.
kinit get kerberos ticket.

klist list kerberos ticket.

Kerberos and SX

The SX can use Kerberos authentication with the following steps and as
a result, Kerberos-based network mutual authentication, and symmetric,
also called private/secret, key cryptography can be achieved in the CLI
and GUI of the SX for remote user authentication.

See the MIT Kerberos website for information about Kerberos, KDC,
kadmin, client machine setup, and the FAQs related to these topics.

1. Set your krb5.conf stanzas and ftp it using getkrbconfig
[configuration settings available in:
http://www.fags.org/fags/kerberos-fag/general/section-38.html]

2. Get a ticket using Kinit.
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3. Use kadmin to add the keys to /etc/krb5.keytab for
HTTP/FQDN@REALM and host/FQDN@REALM. These keys are
consistent across boots.

4. Remote authentication and authorization can be set up along with
Kerberos authentication. HTTP and telnet access will prompt you to
enter username and password. Currently Kerberos does not
automatically map to local or remote usernames.

5. Enable Kerberos.

6. After a reboot, the SX is ready for secure telnet and HTTP protocol
remote access.

Diagnostic Tips:

Use the name command in the network menu to set the FQDN for
the SX.

Disable HTTP redirect from the services menu.

Synchronize the time of the client machine, SX, KDC and kadmin
machines using time menu and ntp option.

The above 3 machines should be pingable by FQDN. Get the hosts
file using gethostnamefile from the Kerberos menu.

Use klist to check the ticket expiration.
Most of the kadmin error messages are associated with ticket
expiration

Kadmin: List principal and add missing principal if it doesn't already
exist in the KDC database.

Browser rule: Do not include the REALM part when the browser
prompts for principal.

Telnet access: Use -x -l and -k option appropriately. Telnet will
initially print that authentication

Key and Definitions:
1. For KDC, kadmind, the application server, and client machine, see

MIT Kerberos FAQ
[http://www.cmf.nrl.navy.mil/CCS/people/kenh/kerberos-fag.htmi]

2. FQDN: Fully Qualified Domain Name

Note: Information about setting up KDC kadmind is not in the scope of
this document. Use the references mentioned in this section for this
information.

Kerberos Command Example
1. admin > Security > Kerberos > getkrbconfig ip 192.168.52.197 login

vijay password vijayv path /home/vijay/krb5.conf

Success
2. kadmin: addprinc host/dsx-182.domain.com@REALM
kadmin: addprinc HTTP/dsx-182.raritan.com@RARITAN.COM
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Loginsettings Commands

The loginsettings command menu offers commands used to configure
the systemwide login settings:

Command Description

idletimeout Set systemwide idletimeout.

inactiveloginexpiry Configure local login expiry time.

invalidloginretries Com‘igure local login max number of
retries.

localauth Configure local authentication.

lockoutperiod Lockout period on invalid login attempt.

singleloginperuser Restrict to a single login session per user.

strongpassword Configure strong password rules.

unauthorizedportaccess Unauthorized (Anonymous) port access.

portaccess Configure port access shared by user
group.
profiledata Modify or view a security profile.

Idletimeout Command

The idletimeout command sets or changes the amount of idle time
allowed before the system disconnects the user.

Syntax

idletimeout [time value]

idletimeout Command Example

admin > Security > LoginSettings > idletimeout time 99

Inactiveloginexpiry Command

The inactiveloginexpiry command sets the number of days before an
account will expire due to inactivity.

Syntax

inactiveloginexpiry [days value]

inactiveloginex Description
piry Command

days <value> Number of days before account will expire for

226 ==



;

Raritan.

Chapter 12: Command Line Interface
local users on inactivity

Command Example

admin > Security > LoginSettings > inactiveloginexpiry
days 5

Invalidloginretries Command

The invalidloginretries command specifies the number of failed invalid
login attempts before the account is deactivated.

Syntax

invalidloginretries [number value]

invalidloginre Description

tries

Command

number value  Number of failed login retries allowed
before account is deactivated

invalidloginretries Command Example

admin > Security > LoginSettings > invalidloginretries
number 5

Localauth Command

The localauth command is used to configure local authentication.

Syntax
localauth [enable <true|false>]

localauth Command Example

admin > Security > LoginSettings > localauth enable false

Lockoutperiod Command

The lockoutperiod command defines the lockout period on invalid login
attempts.

Syntax

lockoutperiod [time time]

lockoutperiod Description

Command

time time Period of time (in minutes) for which the
user cannot login after account
deactivation.
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lockoutperiod Command Example
admin > Security > LoginSettings > lockoutperiod time 120

Singleloginperuser Command

The singleloginperuser command enables or disables multiple logins per
user.

Syntax

singleloginperuser [enable <true|false>]

singleloginperuser Description
Command

enable <true|false> Enable/Disable multiple login
sessions per user.

singleloginperuser Command Example

admin > Security > LoginSettings > singleloginperuser
enable true

Strongpassword Command
The SX server supports both standard and strong passwords.

e Standard passwords have no rules associated with them; they can
be in any format and will not expire

e Strong passwords increase the effectiveness of the password by
setting rules around content, length, and expiration dates

e Strong passwords allow the administrator to pick the rules they want
to implement from the following table

e The maximum length of a strong password is 64 characters

Syntax

strongpassword [enable <true|false>] [minlength value]
[maxlengthvalue] [expirytime] [historyvalue] [uppercase
<true|false>] [lowercase <true|false>] [numeric
<truel|false>] [other <true|false>]

strongpassword Description

Command

enable <true|false> Enable/Disable strong password rules

for local users.

minlength Minimum password length.

maxlength Maximum password length.

expiry Number of days before password will
==Rari
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strongpassword Description

Command
expire for local users.

history Number of passwords to store in
password history.

uppercase If true, force uppercase characters in

<truelfalse> password.

lowercase <true|false> If true, force lowercase characters in
password.

numeric <true|false>  If true, force numeric characters in
password.

other <truelfalse> If true, force other characters in
password.

strongpassword Command Example
The following example sets the Strong Password rules in effect:
e Strong password is enabled.

e The minimum length of the password when you create user is 6
symbols.

e The maximum length of the password is 30.
e The password will expire in 30 days.
e Number of password changes to be kept in history is 3 times.

e There should be at least one and more uppercase/numeric/other
symbols in the password.

e There could be 0 or more lowercase symbols in the password.

admin > Security > LoginSettings > strongpassword enable
trueminlength 6 maxlength 30 expiry 30 history 3 uppercase
true numeric true other true

Unauthorizedportaccess Command

Syntax

unauthorizedportaccess [enable <true|false>]

unauthorizedportacce Description
ss Command

enable <true|false> Enable/Disable unauthorized access to a set
of ports assigned to 'Anonymous' group

unauthorizedportaccess Command Example

admin > Security > LoginSettings > unauthorizedportaccess
enable false
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Portaccess Command

Syntax

portaccess <share|private>

portaccess Description
Command
portaccess Indicate whether port access should

<share|private> be private or shared.

portaccess Command Example

admin > Security > LoginSettings > portaccess share

admin > Security > LoginSettings > portaccess private

Securityprofiles Commands

The securityprofiles command menu provides access to the commands
used to configure and control security profiles.

securityprofiles Description

Command

profiledata View or modify a Security
Profile.

securityprofiles Enable and select a

Security Profile.

Profiledata Command

The profiledata command allows you to modify or view a security profile.
SX provides the ability to define security profiles that simplify assigning
permissions to users and groups. There are three types of profiles:

e Two are predefined and are standard and secure.

e The third allows definition of custom profiles to allow assignment of
all permissions by assigning one security profile.
Multiple custom security profiles may be defined.

Syntax
profiledata [name <Standard|Secure|Custom>] [telnet
<truel| false>

<true|false>
<true|false>

single <true|false>] [redirect
tls required <true|false>]

e e

a
[strongpass <truel|false>] [timeout
[
[
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profiledata Command

[name
<Standard|Secure|Custom>]

[telnet <truelfalse>]
[strongpass <truel|false>]
[timeout <truelfalse>]

[single <truelfalse>]

[redirect <true|false>]

[tls_required <truelfalse>]

Profiledata Command Example

Chapter 12: Command Line Interface

Description

Specifies the type of security
profile.

Enable/Disable telnet.
Enable/Disable strong password.
Enable/Disable idle timeout.

Enable/Disable single login per
user.

Enable/Disable redirection from
HTTP to HTTPS.

Enable/Disable forcing of
Transport Layer Security (TLS) on
HTTPS.

The following example defines the custom security profile with telnet
disabled, strong passwords required, idle timeout enabled, multiple
logins allowed, HTTP to HTTPS redirection disabled, and the forcing of
Transport Layer Security (TLS) on HTTPS.

admin > Security > SecurityProfiles > profiledata name
Custom telnet false strongpass true timeout true single
false redirect false tls required true
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In This Chapter
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Discover IPMI Devices

> To discover IPMI servers on the network:

1. Choose IPMI > Discover IPMI Devices. The Discover IPMI Devices
page opens.

Discover IPMI Devices

Options:

Start IP Address:

End IP Address:

OK Clear Help

2. Leave the Options field blank or enter -t timeout [seconds].

3. Type starting and ending IP addresses in the corresponding fields.
SX will discover all IPMI devices within this range of IP addresses.

4. Click the IPMI Discover button.

o
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Example

The following is an example of the output when nothing has been
entered in the Options field:

Result:
Discovering IPMI Devices
-—— ipmidiscover statistics ---

448 requests transmitted, 0 responses received in time,
100.0% packet loss

IPMI Configuration

IPMI configuration allows you to manage the IPMI functions of a remote
system, including printing FRU information, LAN configuration, sensor
readings, and remote chassis power control.

1. Choose IPMI > IPMI Configuration. The IPMI Configuration page
opens.

IPMI Configuration

IP Address:

Username:

Password:

Options:

Command:

OK Clear Help

2. Click the Help button to get IPMI configuration information, which
appears on the IPMI Configuration page.

Help:
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ipmitool version 1.8.7

usage: ipmitool [options...]

format
-l intf

-H hostname
interface

-p port

-U username
-f file

-S sdr

-a

-e char

-C ciphersuite
interface

-k key

-L level

This help
Show version information
Verbose (can use multiple times)

Display output in comma separated

Interface to use

Remote host name for LAN

Remote RMCP port [default=623]
Remote session username

Read remote session password from file

Use local file for remote SDR cache

Prompt for remote password

Set SOL escape character

Cipher suite to be used by lanplus

Use Kg key for IPMIv2 authentication

Remote session privilege level

[default=ADMINISTRATOR]

-A authtype

Force use of auth type NONE,

PASSWORD, MD2, MD5 or OEM

-P password
-E

Remote session password

Read password from

IPMI_PASSWORD environment variable

-m address

-b channel
request

-l lun
-t address

-0 oemtype
available OEM types)

Set local IPMB address

Set destination channel for bridged

Set destination lun for raw commands
Bridge request to remote target address

Setup for OEM (use 'list' to see

-O seloem Use file for OEM SEL event
descriptions

Interfaces:
open Linux OpenlPMI Interface [default]
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lan
Commands:

raw

i2c

print response

lan

chassis

power

event

mc
enables

sdr
readings

sensor

fru
locators

sel
pef

sol

Chapter 13: Intelligent Platform Management Interface

Intel IMB Interface
IPMI v1.5 LAN Interface

Send a RAW IPMI request and print response

Send an 12C Master Write-Read command and

Configure LAN Channels

Get chassis status and set power state
Shortcut to chassis power commands
Send pre-defined events to MC

Management Controller status and global

Print Sensor Data Repository entries and

Print detailed sensor information
Print built-in FRU and scan SDR for FRU

Print System Event Log (SEL)
Configure Platform Event Filtering (PEF)

Configure and connect IPMIv2.0

Serial-over-LAN

tsol

Configure and connect with Tyan IPMIv1.5

Serial-over-LAN

isol
user
channel
session
firewall
sunoem
picmg
fwum

Configure IPMIv1.5 Serial-over-LAN
Configure Management Controller users
Configure Management Controller channels
Print session information
Configure firmware firewall (IPMIv2.0)

OEM Commands for Sun servers
Run a PICMG/ATCA extended cmd
Update IPMC using Kontron OEM Firmware

Update Manager

shell
exec

set

Launch interactive IPMI shell
Run list of commands from file

Set runtime variable for shell and exec

3. Type the IP address in the IP Address field.

i

Raritan.
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Type your username in the Username field.
Type your password in the Password field.
Type an option in the Option field.

Type a command in the Command field.

© N o g &

Click the IPMI Discover button. The system displays the results of
your command.
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Port Power Associations

;

Raritan.

Important: A maximum of 31 powerstrips can be run with the SX.

You can associate one or more outlets on a powerstrip connected to the
SX to specific SX ports.

Create a Port Power Association

> To create a port power association:
1. Choose Setup > Port Power Association List.
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2. Click Add. The Port Power Association page opens.

Port Power Associations

Port:
| Partt v|

Description:

Associated Outlets:

Fonwier St Cutlet:

| ¥ | ez

| OK | | Cancel |

Select the port from the drop-down menu in the Port field.

Select the power strip name from the drop-down menu in the Power
Strip field.

5. Select the outlet to associate with the port from the drop-down menu
in the Outlet field.

6. Click Add.

Note: It is not recommended to access the port associated with a

power strip via RSC or CLI. Accessing the power strip directly will

display a raw character stream of commands between SX and the
power strip and you are write-locked from any control.

Delete a Port Power Association

> To delete a port power association:

1. Choose Setup > Port Power Association List.
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2. Click Add. The Port Power Association page opens.
3. Select the association in the Outlet Association list.
4. Click Delete.

Power Strip Configuration

Important: A maximum of 31 powerstrips can be run with the SX.

> To configure a power strip:
1. Choose Setup > Power Strip Configuration.

2. Click Add. The Power Strip Configuration page opens.

Hame:

Description:

Humber of Chutlets:
£ v

Port:

| OK | | Cancel |

Type a name and description in the Name and Description fields.

4. Select the number of outlets from the drop-down menu in the
Number of Outlets field.

Type the port number in the Port field.
Click OK.

Power Association Groups

> To create a power associations group:

1. Choose Setup > Power Association Groups List.
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2. Click Add. The Power Association Groups page opens.

Group Hame:

Description:

| |

Available: selected:
Add > |
< Remove |

| OK | | Cancel |

3. Type a name and description in the Group Name and Description
fields.

4. Select the number of outlets from the drop-down menu in the
Number of Outlets field.

5. Click OK.

Power Control

Click the Power Control tab to display the power control-related tools.

Power Control

Azsocistions Powver Control
Powwer Strip Povwer Contral

Powwer Strip Statusz

240
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Associations Power Control

Choose Power Control > Associations Power Control to access the tool
to manage power control associations.

Group and Port Power Associations

Name Type Outlet Status
O Furlz Furl SMADFF
[on ] (o |[cee ]
.

Note: When executing power on/off operation, about ~5 seconds are
added to the configured sequential interval, resulting in an operational
delay time (minimum amount of time to operate). If power cycle is
selected, all associated outlets are powered off sequentially, and then
powered on sequentially. The cycle delay time reacted here determines
the minimum length of time needed to turn back on the outlets after
they're shut down, which is user-specified by administrator. The delay
time to experience would be operational delay + user-specified delay.

Note: If you are connecting a PX to the SX, it is recommended you set
the power cycle time to 5 seconds.

Note: If you disconnect the Dominion PX after creating an association in
SX, the association would appear empty until you re-plug-in the PX into
the same port.
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Power Strip Power Control

Choose Power Control > Power Strip Power Control to access the Outlet
Control page, where you can manage power strips.

242

A

Outlet Slale
| Cuthed 1 OFF
[# Cutiel 2 CFF
O Chudiet 3 CFF
0 Chdied 4 O
Cudied 5 OFF
[] et OFF
| it 7 oM
O e B OFF
Outlet 9 OFF
£ Cutiet 10 CFF
O e 11 . Select All |
N Chutied 12 OFF
O Cuied 13 OFF
[] Cned 14 OFF
0 Outlel 15 OFF
| Ol 16 CFF
O Ol 17 OFF
a Outed 16 OFF
0 Outlet 19 OFF
C Cuthed 20 on

on |[ o || Cyste ]
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Power Strip Status

Choose Power Control > Power Strip Status to check power strip status.

DPX Status:

Povwver strip:

Outlet Breaker Status: 4

True RMS Currert: 0.0

Maxium Detected Current: 0.4
True RMS Yaltage : 113.0
Irternal Temperature : 45.0
Average Povwer [

Apparent Pover 0

Cutlets: 20

L Outlet 1 Off

L Outlet 20 Off

L Outlet 30 Off
Outlet 40 On

L Outlet 50 Off

L Outlet B Off
COutlet 7 On
Dutlet & Off
9. Cutlet 90 Off
10, Outlet 10 : Off
11, Outlet 11 ; Off
12, Cutlet 12 ; Off
13, Outlet 13 ; Off
14, Outlet 14 : Off
15, Outlet 15 ; Off
16, Cutlet 16 ; Off o

oo~ M h e L) b —

CLI Command for Power Control
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CLI Port Power Association

Description:

SX port

Power Control menu - Associate a power strip outlet to an

Scenario #1  Port power association - add outlet
Pre-condition  Administrator user is logged in via CLI.

Action

CLI Input

Power strip (DPX) is physically connected to SX
named PowerStrl.

User is in power menu.
Type command.
Press Enter.

associate port 1 powerstrip PowerStrl outlet 1
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Scenario #2  Port power association - associate 6 outlets to one
port

Pre-condition  Administrator user is logged in via CLI.

Power strip (DPX) is physically connected and
configured to DSX named PowerStrl.

User is in power menu.

Action Type command - associate [port port] [powerstrip
powerstrip] [outlet outlet] to associate Outletl to Portl

Press Enter.
Repeat steps 3 and 4 for Outlet 2, 3, 4, 5 and 6.

CLI Input associate port 1 powerstrip PowerStrl outlet 1-6

Scenario #3 Port power association - associate 6 outlets to one
port spread across two PDUs

Pre-condition  Administrator user is logged in via CLI.

Two Power strip (DPX) are physically connected and
configured to the SX, respectively named PowerStrl
and PowerStr2.

User is in power menu.

Action Type command - associate [port port] [powerstrip
powerstrip] [outlet outlet] to associate Outletl of
PowerStrl to Portl

Press Enter.
Repeat steps 1 and 2 for Outlet 2 and 3.

Type command - associate [port port] [powerstrip
powerstrip] [outlet outlet] to associate Outletl of
PowerStr2 to Portl

Press Enter.
Repeat steps 4 and 5 for Outlet 2 and 3.
CLI Input associate port 1 powerstrip PowerStrl outlet 1,2,3

associate port 1 powerstrip PowerStr2 outlet 1,2,3

Scenario #4  Port power association - associate one outlet to
two ports

Pre-condition  Administrator user is logged in via CLI.

Power strip (DPX) is physically connected and
configured to the SX named PowerStrl.

User is in power menu.
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Scenario #4

Action

CLI Input

Scenario #5

Pre-condition

Action

CLI Input

Scenario #6

Pre-condition

Action

CLI Input

Scenario #7

Pre-condition

Chapter 14: Power Control

Port power association - associate one outlet to
two ports

Enter command
Press Enter
associate port 1 powerstrip PowerStrl outlet 1

associate port 2 powerstrip PowerStrl outlet 1

Port power association - associate all available
outlets to ports

Administrator user is logged in via CLI.

Power strip (DPX) is physically connected and
configured to the SX named PowerStrl.

User is in power menu
Enter command.
Press Enter.

Repeat steps 1 and 2 for all available Outlets with up
to 6 outlets associated to a single port.

associate port 1 powerstrip PowerStrl outlet 1

Port power association - associate outlets to one
port from different power strips

Administrator user is logged in via CLI.

Two Power strip (DPX) are physically connected and
configured to the SX respectively named PowerStrl
and PowerStr2.

User is in power menu.

Enter command to associate Portl to Outletl from
PowerStrl.

Press Enter.

Enter command to associate Portl to Outletl from
PowerStr2.

Press Enter.
associate port 1 powerstrip PowerStrl outlet 1

associate port 1 powerstrip PowerStr2 outlet 1

Port power association - associate outlets from 6
different power strips to one port

Administrator user is logged in via CLI.
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Scenario #7  Port power association - associate outlets from 6
different power strips to one port

6 Power strip (DPX) are physically connected and
configured to SX.

User is in power menu.

Action Enter Command to associate Portl to Outletl of
PowerStrl.

Press Enter.

Repeat steps 1 and 2 to associate Portl with Outletl
from each of the other PDUs.

CLI Input associate port 1 powerstrip PowerStrl outlet 1
associate port 1 powerstrip PowerStr2 outlet 1
associate port 1 powerstrip PowerStr3 outlet 1
associate port 1 powerstrip PowerStr4 outlet 1
associate port 1 powerstrip PowerStr5 outlet 1

associate port 1 powerstrip PowerStr6 outlet 1

Scenario #8  Port power association - edit outlet names
Pre-condition  Administrator user is logged in via CLI.

Power strip (DPX) is physically connected and
configured to SX named PowerStrl.

User is in power menu.
Action Enter Command to edit outletl name of PowerStrl.
Press Enter.

CLI Input outlet name PowerStrl outlet 1 newname TestName

Remove Port Power Association

Description: Power Control Menu - Remove a power outlet association
from an SX port.

Scenario #1  Remove port power association
Pre-condition  Administrator user is logged in via CLI.

Power strip (DPX) is physically connected and
configured to SX named PowerStrl.

User is in power menu.

Action Enter command.
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Scenario #1

CLI Input

Scenario #2
Pre-condition

Action

CLI Input

Chapter 14: Power Control

Remove port power association
Press Enter.

Command: unassociate port 1 powerstrip PowerStrl
outlet 1

Delete multiple outlets association
Administrator user is logged in via CLI.

Power strip (DPX) is physically connected and
configured to the SX named PowerStrl.

User is in power menu.
Enter command.
Press Enter.

Command: unassociate port 1 powerstrip PowerStrl
outlet 1,4,7

CLI Power Strip Configuration
Description: Power Control Menu

Scenario #1

Pre-condition

Action

CLI Input

Scenario #2
Pre-condition

Action

CLI Input

Configure an SX port to contain a power strip
device (the port is previously connected to a
power strip)

Administrator user is logged in via CLI.

Power strip (DPX) is physically connected to Portl of
SX. Administrator is in power menu.

Enter command.
Press Enter.

setpowerport name PowerStrl type DPCS12 port 1

Power strip configuration after factory reset

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

SX user has already configured the port as a power
strip.

Log in to SX unit with administrator privileges via CLI.

Go to Maintenance menu
Perform Factory Reset

Command: factoryreset
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CLI Power Association Group
Description: Power > PowerGroups menu

Scenario #1
Pre-condition

Action

CLI Input

Scenario #2
Pre-condition

Action

CLI Input

Scenario #3
Pre-condition

Action

CLI Input

Scenario #4
Pre-condition

Create new power group
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in Power > PowerGroups menu.
Enter Command.
Press Enter.

Command: addpowergroup name "Test Group”
description "Test group”

Add a port to a power group
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in Power > PowerGroups menu.
Enter Command.
Press Enter.

Command: addpowergroupport name "test Group"
port port 2

Add multiple ports to a power group
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in Power > PowerGroups menu.
Enter Command.
Press Enter.

Command: addpowergroupport name "test Group"
port port 2-4,10

Remove group member
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.
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Scenario #4

Action

CLI Input

Scenario #5
Pre-condition

Action

CLI Input

Chapter 14: Power Control

Remove group member
Administrator is in Power > PowerGroups menu.

Enter Command.

Press Enter.

Command: deletepowergroupport name "Test Group"

port 2

Delete power group
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in Power > PowerGroups menu.
Enter Command.
Press Enter.

Command: deletepowergroup name "Test Group

CLI Power Strip Power Control

Description: Power Control Menu

Scenario #1
Pre-condition

Action

CLI Input

Scenario #2
Pre-condition

Action

Switch on/off a single Outlet
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in power menu.
Enter Command.

Press Enter.

on powerstrip PowerStrl outlet 1

off powerstrip PowerStrl outlet 1

Switch on/off all Outlets
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in power menu.

Enter Command.
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Scenario #2

CLI Input

Scenario #3
Pre-condition

Action

CLI Input

Scenario #4
Pre-condition

Action

CLI Input

Scenario #5
Pre-condition

Action

CLI Input

Switch on/off all Outlets
Press Enter.

on powerstrip PowerStrl outlet *

off powerstrip PowerStrl outlet *

Switch on/off group of outlets
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in power menu.
Enter Command.

Press Enter.

on powerstrip PowerStrl outlet 1,3,7

off powerstrip PowerStrl outlet 1,3,7

Power rescycle group of outlets
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in power menu.
Enter Command.
Press Enter.

cycle powerstrip PowerStrl outlet 1,3,7

Sequence interval for switch off operation
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in power menu.

Enter command to set sequence interval.
Press Enter.

Enter command to switch off group of outlets.
Press Enter.

powerdelay sequence 2

off powerstrip PowerStrl outlet 1,3,7
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Scenario #6
Pre-condition

Action

CLI Input

Scenario #7
Pre-condition

Action

CLI Input

Chapter 14: Power Control

Sequence interval for switch on operation
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in power menu.

Enter command to set sequence interval.
Press Enter.

Enter command to switch on group of outlets.
Press Enter.

powerdelay sequence 2

off powerstrip PowerStrl outlet 1,3,7

Power Recycle Interval
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in power menu.

Enter command to set sequence and power recycle
interval.

Press Enter.

Enter command to power recycle group of outlets.
Press Enter.

powerdelay sequence 2 cycle 5

cycle powerstrip PowerStrl outlet 1,3,7

CLI Association Power Control - Port Association

Description: Power Control Menu

Scenario #1 Association Power Control - Recycle Port

Pre-condition

Association (Target is associated to One
Outlet)

Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Port Power Association named Target2 is already
created and available in the list.
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Scenario #1

Action

CLI Input

Scenario #2

Pre-condition

Action

CLI Input

Scenario #3

Pre-condition

Association Power Control - Recycle Port
Association (Target is associated to One
Outlet)

Outlel of PowerStrl is associated to Target2.

Administrator is in Power Control > Associations
Power Control menu.

Select Port Association named Target2
Click on Power Recycle Interval and enter value:
Press Recycle button.

Power Recycle Interval value: 1 sec.

Association Power Control - Recycle Port
Association (Target is associated to Two Outlets
from one power strip)

Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Port Power Association named Target2 is already
created and available in the list.

Outlel of PowerStrl is associated to Target2.

Administrator is in Power Control > Associations
Power Control menu.

Select Port Association named Target2
Click on Power Recycle Interval and enter value:
Press Recycle button.

Power Recycle Interval value: 1 sec.

Association Power Control - Recycle Port
Association (Target is associated to Two Outlets
from two different power strips)

Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Port Power Association named Target? is already
created and available in the list.

Outlel of PowerStrl is associated to Target2.

Administrator is in Power Control > Associations
Power Control menu.
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Scenario #3 Association Power Control - Recycle Port
Association (Target is associated to Two Outlets
from two different power strips)

Action Select Port Association named Target2
Click on Power Recycle Interval and enter value
Press Recycle button.

CLI Input Power Recycle Interval value: 1 sec.

Scenario #4 Association Power Control - Recycle Port
Association (outlets in the association are with
different statuses)

Pre-condition  Administrator user is logged in via GUI.

Two power strips (DPX) named PowerStrl and
PowerStr2 are physically connected to SX Ports.

Port Power Association named Target2 is already
created and available in the list.

Outlel of PowerStrl and Outlet2 of PowerStr2 are
associated to Target2.

Outletl and Outlet2 are with different statuses.

Administrator is in Power Control > Associations
Power Control menu.

Action Select Port Association named Target2
Click on Power Recycle Interval and enter value:
Press Recycle button.

CLI Input Power Recycle Interval value: 1 sec.

CLI Association Power Control - Group Association

Description: Power Control Menu

Scenario #1  Turn ON Group Association
Pre-condition  Administrator user is logged in via CLI.

Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created.

Action Enter Command.
Press Enter.

CLI Input Command: on nodegroup Groupl
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Scenario #2

Pre-condition

Action

CLI Input

Scenario #3
Pre-condition

Action

CLI Input

Scenario #4

Pre-condition

Action

CLI Input

Scenario #5
Pre-condition

Action

Turn ON Group Association (outlets in
association are with different statuses)

Administrator user is logged in via CLI.
Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created. Outlets in Groupl are with different
statuses.

Enter Command.
Press Enter.

Command: on nodegroup Groupl

Turn OFF Group Association
Administrator user is logged in via CLI.

Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created.

Enter Command.
Press Enter.

Command: off nodegroup Groupl

Turn OFF Group Association (outlets in
association are with different statuses)

Administrator user is logged in via CLI.
Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created. Outlets in Groupl are with different
statuses.

Enter Command.
Press Enter.

Command: off nodegroup Groupl

Recycle Group Association
Administrator user is logged in via CLI.

Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created.

Enter Command.
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Scenario #5

CLI Input

Scenario #6

Pre-condition

Action

CLI Input

Scenario #7

Pre-condition

Action

CLI Input

Scenario #8

Pre-condition

Action

Chapter 14: Power Control

Recycle Group Association
Press Enter.

powerdelay sequence 2 cycle 5

cycle nodegroup Groupl

Recycle Group Association (outlets in
association are with different statuses)

Administrator user is logged in via CLI.
Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created. Outlets in Groupl are with different
statuses.

Enter Command.
Press Enter.
powerdelay sequence 2 cycle 5

cycle nodegroup Groupl

Turn ON Group and Port Association
simultaneously

Administrator user is logged in via CLI.
Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created. Port3 is already associated with
outlet8 of PowerStrl which has been created and
available in the list.

Enter Command.
Press Enter.
powerdelay sequence 2 cycle 5

on port 3 nodegroup Groupl

Turn OFF Group and Port Association
simultaneously

Administrator user is logged in via CLI.
Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created. Port3 is already associated with
outlet8 of PowerStrl which has been created and
available in the list.

Enter Command.
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Scenario #8

CLI Input

Scenario #10

Pre-condition

Action

CLI Input

Turn OFF Group and Port Association
simultaneously

Press Enter.
powerdelay sequence 2 cycle 5

off port 3 nodegroup Groupl

Recycle Group and Port Association
simultaneously

Administrator user is logged in via CLI.
Administrator is in power menu.

Group Association named Groupl (shown in Fg.1) is
already created. Port3 is already associated with
outlet8 of PowerStrl which has been created and
available in the list.

Enter Command.
Press Enter.
powerdelay sequence 2 cycle 5

cycle port 3 nodegroup Groupl.

CLI Power Strip Status

Description: Power Control Menu

Scenario #1
Pre-condition

Action

CLI Input

Result

Power Strip Status
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Administrator is in Power menu.

Enter Command.

Press Enter.

Command: powerstrip name PowerStrl

Status of PDU should correctly display the following
parameters:

Power Consumption
Average Power

Apparent Power

1]
i

Raritan.



Scenario #1

Scenario #2

Pre-condition

Action

CLI Input

Scenario #3
Pre-condition

Action

CLI Input

Scenario #4

Pre-condition

;

Raritan.

Chapter 14: Power Control

Power Strip Status
True RMS Voltage

True RMS Current
Maximum Current
Status of the outlet breaker

Internal Temperature

Status of Power Strip that is actually turn off or
disconnected

Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is disconnected
from Portl or turned off.

Administrator is in Power menu.
Enter Command.
Press Enter.

Command: powerstrip name PowerStrl

Power Strip Status - Outlet status
Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Check the current status of outlets - outletl is turn on
Turn off outlet1.

Go to Power menu and check the status of outletl.
powerstrip name PowerStrl

off powerstrip PowerStrl outlet 1

powerstrip name PowerStrl

Power Strip Status - Outlet status when port
association is removed

Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Outletl and Outlet2 are associated with Portl.
Outletl and Outlet2 are with status "ON".

Administrator is in Power menu.
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Scenario #4  Power Strip Status - Outlet status when port
association is removed

Action Check the current status of outlets - outletl is turn on

Remove Outletl and Outlet2 from outlet association to
Portl.

Go to Power menu and check the status of outletl.
CLI Input powerstrip name PowerStrl
unassociated port 1 powerstrip PowerStrl outlet 1,2

powerstrip name PowerStrl

Scenario #5  Power Strip Status - Outlet status when group
association is removed

Pre-condition  Administrator user is logged in via CLI.

Power strip (DPX) named PowerStrl is physically
connected to Portl of SX.

Group association named Groupl is created.
Outlet1 and Outlet2 are with status “ON”.
Administrator is in Power menu.
Action Check the current status of outlets - outletl is turn on
Remove Groupl.
Go to Power menu and check the status of outletl.
CLI Input powerstrip name PowerStrl
deletepowergroup name Groupl

powerstrip name PowerStrl
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The following table lists the SX models by the number of ports (4 - 48) in
the unit.

Model Ports  Built-In  # of # of Power
Modem Local Ethernet Supply
Ports Ports

DSX4 4 No 2 1 Single
AC
DSXB-4-M 4 Yes 1 1 Single
AC
DSX8 8 No 1 1 Single
AC
DSXA-8 8 Yes 1 1 Dual AC
DSXB-8-M 8 Yes 1 1 Single
AC
DSXA-16 16 Yes 1 1 Dual AC
DSXA-16-DL 16 No 2 2 Dual AC
DSXA-16-DL 16 Yes 1 2 Dual AC
M
DSXA-32 32 Yes 1 1 Dual AC
DSXA-32-AC 32 No 2 1 Dual AC
DSXA-32-DL 32 No 2 2 Dual AC
DSXA-32-DL 32 Yes 1 2 Dual AC
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Model

M
DSXA-48
DSXA-48-AC

Ports  Built-In  # of # of Power
Modem Local Ethernet Supply

Ports  Ports

48 Yes 1 2 Dual AC
48 No 2 2 Dual AC

The following table lists the SX models, their dimensions, and weights.

MODEL

DSX4
DSXB-4-M
DSX8
DSXA-8

DSXB-8-M
DSXA-16

DSXA-16-DL
DSXA-16-DL
M

DSXA-32
DSXA-32-AC
DSXA-32-DL
DSXA-32-DL
M

DSXA-48

DSXA-48-AC

260

DIMENSIONS
(W) x (D) x (H)

11.41"x 10.7" x 1.75"; 290 x 270 x 44 mm
11.41"x 10.7" x 1.75"; 290 x 270 x 44 mm
11.41"x 10.7" x 1.75"; 290 x 270 x 44 mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

11.41"x 10.7" x 1.75"; 290 x 270 x 44 mm

17.32" x 11.41" x 1.75", 440 x 290 x 44
mm

17.32" x 11.41" x 1.75", 440 x 290 x 44
mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

17.32" x 11.41" x 1.75"; 440 x 290 x 44
mm

i
i

WEIGHT

4.61 Ibs; 2.08 kg
4.61 Ibs; 2.08 kg
4.81 Ibs; 2.17 kg
8.00 Ibs; 3.60 kg

4.81 Ibs; 2.17 kg
8.28 Ibs; 3.756 kg

8.58 Ibs; 3.86 kg

8.58 Ibs; 3.86 kg

8.40 Ibs; 3.78 kg

8.40 Ibs; 3.78 kg

8.78 Ibs; 3.95 kg

8.78 Ibs; 3.95 kg

8.97Ibs; 4.04 kg

8.97Ibs; 4.04 kg
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The following table lists the information of Cables/Adapters/Brackets.

Appendix A: Specifications

The SX is able to support long distance cables. The actual distance you

may achieve is dependent on many factors including baud rate, cable

quality, environmental radiation, and the target serial device’s
specifications, quality and tolerances. You may achieve higher or lower

lengths based on these factors.

your environment to validate the desired distance.

Part Number
ASCSDB9F

ASCSDBO9M
ASCSDB25F
ASCSDB25M
ASCSDB9F-DCE
CRLVR-15

CSCSPCS-10

CRLVR-1

CRLVR-1-5PK

CSCSPCSs-1

CSCSPCS-1-5PK

RUST-LM304

Description
RJ-45(F) to DB9(F) serial adapter

RJ-45(F) to DB9(M) serial adapter
RJ-45(F) to DB25(F) serial adapter
RJ-45(F) to DB25(M) serial adapter
Serial Adapter for DB9 DCE Port to SX

15’ (4.5m) serial rollover Cat5 cable - for most
Cisco and Sun serial RJ-45 ports (Note: This is
NOT a standard or a crossover Ethernet cable.)

10’ (3m) Catbe cable to connect the SX to a
Raritan remote power control unit

1’ (0.3m) serial rollover Cat5 adapter cable
(RJ45 Male to RJ45 Female) - for most Cisco
and Sun serial RJ-45 ports

Package of 5 CRLVR-1 (1’; 0.3m) serial rollover
Catb adapter cables (RJ45 Male to RJ45
Female) - for most Cisco and Sun serial RJ-45
ports

1’ (0.3m) Catb5e adapter cable (RJ45 Male to
RJ45 Female) to connect the SX to a Raritan
remote power control unit

Package of 5 CSCSPCS-1 (1’; 0.3m) adapter
cables (RJ45 Male to RJ45 Female) to connect
the SX to a Raritan remote power control unit

19” (482.6mm) standard rack mount brackets
for DSX4, DSXB-4-M, DSX8, and DSXB-8-M

Raritan recommends that you test in

Only RoHS and WEEE compliant units are available in the EU and other
selected areas. RoHS and WEEE compliant units can be provided
elsewhere upon request.

CRLVR-15:

1. A Cat5 cable in YELLOW color with a length of 15 feet.

2. RJ-45 male terminators, wired with the following pin-out:
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Pin Pin

0 N oo 0o B~ WwDN
P N W~ 0o N

Maximum Number of Connections for a Single User

The following maximum number of connections for a single user apply to
the SX;

o All SX models support a maximum of twelve (12) simultaneous RSC
port sessions per user per host. A maximum of six (6) SSH port
sessions per user are supported.

e In order to use 48 port connections, a single user must connect from
four (4) different hosts (for example, 4 hosts/12 RSC sessions per
user per host).

e If you are running RSC and SSH sessions simultaneously, use one
of the following scenarios:

= 6 RSC connections plus 2 SSH sessions with a single user for
same host, or

= 10 RSC sessions/1 SSH session, or
= 2 RSC/5 SSH sessions

Maximum Number of CLI Sessions

In order to avoid expending the SX device’s memory, 64Mb machines
are limited to 12 CLI sessions at a time, and 128Mb machines are limited
to 32 CLI sessions at a time.

Requirements

The following table lists the requirements for the SX.
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Requirements Description

Form factor 1U, rack mountable (brackets included on
DSX16, DSX32, DSXA-8 and DSX48)

Power 110/240VAC auto-switching: 50-60 Hz

Max. power 4-Port SX: 5.75W

consumption 8-port SX: 6W

16-port SX: 8W
32-port SX: 9.375W
48-port SX: 12.5W

Environmental requirements

Operating 32°to 104° F (0° to 40° C)

temperature

Humidity 20% - 85% RH non-condensing

Altitude Operates properly at any altitude from 0 to
10,000 feet

Approvals CE, FCC Part 15 Class A, US and

Canadian UL, VCCI-A

Remote Connection

Network One (1) or two (2) 10/100 Ethernet Base-T;
RJ-45 connection
Protocols TCP/IP, PPP, PAP, HTTP, HTTPS, SSL,

SSH, TACACS+, LDAP(S), RADIUS,
SNMP, Kerberos

Warranty Two Years with Advanced Replacement*

*To qualify for advanced replacement under the standard warranty, you

must register the product at http://Raritan.com/standard_warranty
(p://[Raritan.com/standard_warranty). Specifications are subject to
change without notice.
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Supported Operating Systems

e WIN XP Professional SP2 - SUN JRE™ 1.5.0_06
e WIN XP Home Edition SP2 - SUN JRE 1.5.0_06
e WIN 2000 Professional SP4 SUN JRE 1.5.0 06
e WIN XP Home Edition SP2 - SUN JRE 1.5.0_06
e WIN 2000 Professional SP2 SUN JRE 1.4.2_05
e Fedora Core® 4 JRE 1.4.2 05

e Slackware® 10.2

e FreeBSD"6.1

Supported Browsers

SX supports the following browsers:
e Internet Explorer® 7 through 9

e Firefox® 4 or later

e Safari® 3 or later

Connectivity

The following table lists the necessary SX hardware (adapters and/or
cables) for connecting the SX to common Vendor/Model combinations.

Vendor Device Console Serial Connection
Connector

Checkpoint™ Firewall DB9M ASCSDB9F adapter
Cisco® PIX Firewall and a CAT 5 cable

Cisco Catalyst RJ-45 CRLVR-15 rollover
cable; or CRLVR-1
adapter cable and a
CATS cable

CRLVR-1 cable for
connecting a terminal
port (RJ-45 Connector
type) of SX-48 models
that have this connector
to another SX.

Cisco Router DB25F ASCSDB25M adapter
and a CAT 5 cable

Hewlett UNIX® Server DB9M ASCSDB9F adapter
Packard® and a CAT 5 cable
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Vendor

Silicon
Graphics®

Sun®

Sun

Sun

Various

Raritan

Device

Origin

SPARCStation

Netra T1

Cobalt

Windows NT®

RPCU

Console Serial Connection

Connector

DB25F ASCSDB25M adapter
and a CAT 5 cable

RJ-45 CRLVR-15 cable; or
CRLVR-1 adapter and
a CAT5 cable

DB9M ASCSDB9F adapter
and a CAT 5 cable

RJ-45 CSCSPCS-10 cable or

CSCSPCsS-1 adapter
cable

Appendix A: Specifications

Contact your reseller or Raritan Support for further information on cables
and adapters.

SX Serial RJ-45 Pinouts
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To provide maximum port density and to enable simple UTP (Category 5)

cabling, SX provides its serial connections via compact RJ-45 ports.
However, no widely adopted industry-standard exists for sending serial
data over RJ-45 connections.

The following tables list the RJ-45 pinouts for the RJ-45 connector,
located on the back of the SX.

RJ-45 PIN

0 N OO o B~ W N P

SIGNAL
RTS

DTR
TxD
GND
Signal GND
RxD
DSR
CTS
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See http://www.raritan.com/support for the latest information about the
SX serial pinouts (RJ-45).

DB9F Nulling Serial Adapter Pinouts

RJ-45 (female) DB9 (female)
8

1,6

0 N o 0o A~ W N R
92}
I
m
—
r—

DB9M Nulling Serial Adapter Pinouts

RJ-45 (female) DB9 (male)
8

1,6

o N o 0o A~ W N P
[92)
I
m
—
—

DB25F Nulling Serial Adapter Pinouts

RJ-45 (female) DB25 (female)
1 5

266

i

Raritan.



i

Raritan.

RJ-45 (female)

0 N oo o b~ W N

DB25 (female)
6,8

3

1

7

2

20
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DB25M Nulling Serial Adapter Pinouts

RJ-45 (female)

0 N OO 0o~ W N P

DB25 (male)
5

6,8
3

1

7

2
20
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SX Terminal Ports

All SX models, except the DSX16 and DSX32, have the same pinouts on
the two DB9M serial ports. This applies to models with two serial ports.
All dual-LAN (dual-power) models have one RJ-45 serial port. The
DSX16 and DSX32 models have only one external DBOM serial port
(labeled TERMINAL). All dual-LAN (dual-power) models have one RJ-45
serial port. The DSX16 and DSX32 models have only one external
DBIM serial port (labeled TERMINAL).

Both ports support a VT100 terminal or equivalent (that is, a PC running
VT100 emulation software such as HyperTerminal® or Linux® Minicom).
Local port access must be enabled and set to the same speed as the
managed device for it to work. Local port access can be enabled or
disabled from the GUI and the CLI using the Ipa command through SSH
or Telnet, if it is enabled. The telnet server on the SX is disabled by
default.

Models with two terminal ports support an external modem only on the
port with the RI signal. On models with only one serial port, a modem is
built in. The externally accessible serial port does not include the RI
signal, so it supports only devices such as a VT100 terminal or
equivalent.

The following table identifies the first DBOM serial port pinouts.

DB9M PIN SIGNAL
DCD

RxD
TxD
DTR
GND
DSR
RTS
CTS
RI

© 00 N o 0o B~ W N P

The second DB9M serial port supports only two pins as identified in the
following table (Pin 4 and pin 7 are fixed too high).

DB9M PIN SIGNAL
1

2 RxD

i
i
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DB9M PIN SIGNAL
XD

DTR (H)
GND

RTS (H)

© 00 N o 0o b~ W

SX16 and SX32 Terminal Ports

A modem should not be connected to the terminal ports on DSX16 and
DSX32 because the Ring Indicator (RI) signal is not present. These
models have a built-in modem that can be enabled or disabled. The
modem is disabled by default.

DB9M PIN Color SIGNAL

1 Brown GND

2 Red RxD

3 Orange TxD

4 -- --

5 Green GND

6 No Connection

7 Purple RTS

8 Gray CTS

9 Blue BUSY-Reserved
for Factory Reset
Plug

269

Raritan.

;



270

Appendix A: Specifications

Additional information about the SX16 and SX32 Terminal Ports:

Pins 1 and 9 are used to factory reset units shipped after August
2004.

Units shipped prior to August 2004 have the DB9M port labeled
RESERVED (not TERMINAL/RESERVED), since this port was used
to factory reset the unit, with a Factory reset adapter shipped with
each SX. Pins 1 and 6 were used for factory reset. The reset
adapters for these early units are different from the current units,
which have local port functionality.

DSX16 and DSX32 units shipped from the factory with the SX 2.2 (or
higher) release support the local port capability.

SX versions through 2.5 have the local port disabled by factory
default.

In SX 3.1 or higher, the local port is enabled by default.

{
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Initiate Port Access

Use the following information for initiating port access:

Initiate port access using Ports Kept open or Closed Directions

HTTP Ports 80, 443 and 5000 must be Both
kept open in the firewall for the unit
to operate. Port 5000 can be

configured.
HTTPS SSL(S) only TCP port 443 needs to be open,; Both
port 80 can be closed
SSH TCP port 22 needs to be open Both
Telnet TCP port 23 needs to be open Both
RADIUS TCP port 1812 needs to be open Outgoing
LDAP Port 389 needs to be open Outgoing
SNMP Port 162 needs to be open Outgoing
TACACS+ Port 49 needs to be open Outgoing
Notes
For FTP Upgrades Port 21 needs to be open Outgoing
For syslog UDP port 514 needs to be open Outgoing

You may have to open additional ports when NFS logging, LDAP servers,
and so forth. These ports may vary from installation to installation,
depending on network topologies, virtual Local Area Networks (VLANS),
and firewall configurations. Contact your network administrator for
site-specific information and settings.

Supported Character Length of Various Field Types

The following table lists the supported character length of various field
types:
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Field Type
username

user full name

user information

user password

group name

Remote Auth Secret
LDAP BaseDN

LDAP Query

LDAP Search

LDAP Dialback Query
Remote Auth Port
Network Failover Interval
Network Domain Name
Network Unit Name
CSC port

CSC Discovery Port
HTTP/HTTPS Port
Telnet /SSH Port

Port Name

Port Exit Command

Port DPA SSH Port

Port DPA Telnet Port
Port Keyword

Power Sequence Delay
Power Cycle Delay
Power Strip Name
Power Strip Description
Power Association Group Name
Power Association Group Description
PortLog Prefix

PortLog Timestamp

Character Length
255

255

64

64

255

128

128

128

128

128
1-65535
0-65535
255

64
1-64510
1-64510
1-64510
1-64510
64

100
1024-64510
1024-64510
40

2-60
5-60

64

255

255

255

64
0-99999

==
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Field Type
PortLog NFS Update

PortLog In/Out Directory
SMTP Username

SMTP Password

SMTP Source address
Event Destination

NFS Directory

SNMP Community

SNMP Dest Port

Login Inactive Expiration
Login Retries

Login Lockout Period

Strong Password Min Length
Strong Password Max Length

Idle Timeout Period

Appendix B: System Defaults

Character Length
0-99999

64

255

128

64

64

128

64
1-65535
0-65535
0-65535
0-65535
8-15
15-64
0-65535
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Default SX Certificate Authority Settings

The Server Certificate generated in the SX must be installed in the
browser in order for the browser to trust the Server Certificate.

Each time you access an SSL-enabled SX, you see a New Site
Certificate window. You can accept this on a per-session basis or you
can eliminate this window's appearance by accepting a session
certificate permanently. The following steps will show how to install the
SX's certificate into the browser's certificate store.

These steps must be performed for each SX to be accessed for each
client browser that accesses the SX.

Installing Dominion SX Server Certificate for Netscape Navigator

;
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By installing the SX Server certificate in Netscape®, you can prevent the
Security Alert pop-up from appearing whenever you access the SX. This
step will have to be performed for each SX you wish to access from each
client's browser.

Accept a Certificate (Session-Based)

Upon initial connection to a SX, a certificate warning pop-up appears. By
default, this certificate is signed by the local SX's CA as described above
and you will have to accept this certificate to continue. To eliminate the
appearance of the warning pop-up for this SX permanently, you must
install the server certificate in your browser. This procedure is described
in the section that follows.

Install the Dominion SX Server Certificate in Netscape Navigator

1. Launch Netscape Navigator® and connect to the IP address of the
SX. The “Web Site Certified by an Unknown Authority” page
appears.
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2. Select Accept this certificate permanently and click OK.
3. Select OK on the Security Warning window

4. The Raritan default certificate is now accepted on this computer.

Remove an Accepted Certificate

Removing a previously accepted certificate from a SX uses the same
process whether removing a Raritan default certificate or removing a
user-installed third-party certificate.

Note: The SX does not use encrypted private keys. When removing
encryption from the key, the SX uses a command such as openssl rsa -in
server.key -out server2.key or server2.key.

1. Choose Tools > Options.

2. Select Advanced panel and double-click the Certificates category.
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3. Inthe Manage Certificates section, click the Manage Certificates...
button to view the Certificate Manager.

Options - Advanced

<:] [[> Show Al

X

[ L [ M g [ || [ e L

=] Security
Use 5L 2.0
Use 55L 3.0
Use TLS 1.0

| Certificates

Client Certificate Selection

Decide how Metscape selects a security certificate ko present ko web sites that
require ane:

) Select Automatically ) Ask Every Time

Manage Certificakes

Ilse the Certificate Manager to manage wour personal certificates, as well as
thiose of other people and certificate authorities,

[ Manage Certificates, ., ]

Manage Security Devices

IJze this butkon ko manage your security devices, such as smark cards,

[ Manage Security Devices. .. ]

[

[ Ok ] [ Cancel

i
i
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4. Select the Web Sites tab, select the certificate name that is the

common name of the IP address of the SX, and click Delete.

@ Certificate Manager

Your Certificates " Other People's

Weh Sikes Authorities

8=

You have certificates on File that identify these web sites;

Certificate MName
=

©..192,168.50,132

Purposes

Sepver

Clienk

a

view | | Edt | [ Impot | | Delete |

[

Ik

J |

Help

5. Click OK on the Delete Web Site Certificates window to confirm the

deletion of the certificate.

6. On the left side of this page, locate Certificates, and click Web Sites.
7. Click OK on the Options Advanced Window.

Installing a Third-Party Root Certificate

i
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If you have installed a third-party certificate on the SX, you can get its

corresponding root certificate from the Certificate Authority that provided
you with a certificate. These instructions can be used for any of the CAs;

this example uses Thawte.

The CA that provided you with a certificate will have a root certificate

available for download. Root certificates are available on the CA web site;
click on the links to download. Some of the popular CAs and their sites:

Thawte Digital Certificate Services

http://www.thawte.com/ http://www.thawte.com/

VeriSign Incorporated

http://www.verisign.com/ http://www.verisign.com/
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Note: Some CAs will provide the root certificate code in text format rather
than providing a downloadable root certificate. If this occurs, select the
root certificate code, copy it, and follow the steps outlined in the section
Install the Raritan Root Certificate, then follow the steps outlined below.

Install a Third-Party Root Certificate to Internet Explorer

To install a third party certificate to Internet Explorer®, download the CA
certificate and install it following the steps above in Install the SX Server
Certificate In Internet Explorer.

Install a Third-Party Root Certificate to Netscape Navigator

1. Onthe CA Web site, click on the root certificate link and the New
Certificate Authority window appears. Click Next, and then click Next
again.

2. The Certificate Fingerprint will appear, providing information about
the CA and the root certificate you are downloading. It will look
similar to the following window. Record the Signed by information
and click Next.

3. Select the Accept this Certificate Authority for Certifying network
sites checkbox. The second and third boxes are optional.

4. Click Next, and then click Next again. When prompted to type a
name for the Certificate Authority, type the Signed by name that you
recorded in Step 6.

5. Click Finish. The root certificate for this Certificate Authority is now
installed for this computer.

6. |If the root certificate has already been installed, the following error
will appear and you must follow the steps below to remove the
currently installed certificate.

7. Click the Security button in Netscape® or click on the lock icon in the
lower left of the window to access the Security Information window.

8. Locate the Certificates section in the left panel and click Signers to
display a list of root certificates currently installed.

9. Find the name of the CA whose certificate you are installing. There
may be more than one listing for your CA. Select the listing with the
same name as the certificate you are trying to install.

10. Click Delete and then click OK.

11. Return to the CA's Web site and try to download the root certificate
again and follow steps 1 through 5 again.
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Generate a CSR for a Third Party CA to Sign

To have a third party CA certificate (for example, Verisign) installed on
the SX rather than the internal CA on the SX signing the certificate, a
Certificate Signing Request (CSR) must be generated by the SX to be
signed. The third party CA will take this CSR and generate a Certificate.
This certificate must be installed on the SX along with the CA's public
key in order for this certificate to be enabled. This Certificate and key
must then be installed onto the SX.

All GUI fields except the "Country" filed accept spaces in their names
without the need to put them in single quotes.

1. Choose Security > Certificate.

2. Click the Generate Certificate Signing Request radio button.

'@' Generate Certificate Signing Request
!?_-its:
| 1024 w

Hame:
I’n':.-'S}{_I:er‘tificate

Country:

pe

State:

|S|:|fia

Locality:

(Sofia |

Organization:
i'ElianI:ur Services' |

Unit:
[DS}: |

Email:
st@bianu:ur.u:u:um

3. Fill in parameters underneath the radio button (bits, name, and so
forth), and click OK. Note that the email address is mandatory.

Note: Spaces between words can be used in all fields without
needing to use single quotes except the Country field.

4. Click OK to generate a CSR.
Send the generated CSR to a third party CA to get it signed.
6. CAreturns a Signed Certificate built from the CSR.
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7.

8.

Install the certificate to SX.

&) Install User Certificate
IP Addre=s=:
hnuﬂjsg

Login:
|ani |

Password:

|tttttt |

Remote Path:
|m::mefaniJEerverCert |

Remote File:
|server pem |

Reboot the SX.

If the CSR is generated by an external source:

1.

o~ N

6.

Generate a CSR for the SX by an external computer.
Send this CSR to the third party CA to get it signed.
CA returns a Signed Certificate built from the CSR.
Install the certificate to the SX.

Upload the private key received for this CSR to the SX.

'@' Inztall User Key

IP Address:
|1 0.0.0.189

Login:
|ani |

Password:
EEETEE] |

Remote Path:
|J‘nn:nmefanifaerverl:er‘t |

Remote File:
|server ke |

Reboot the SX.
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Install Client Root Certificate

In order for Client Certificates to be recognized as valid by the SX, the
Root Certificate of the CA that signed the Client Certificates must be
installed on the SX with the following steps:

1. Retrieve the CA's Root certificate used to sign the client certificates
and place it on an accessible FTP server

Choose Security > SSL Client Certificates.

Select Install Certificate Authority.

Fill in the FTP parameters to retrieve the CA Root certificate.
Click OK.

Make sure the Enable SSL Client Certificate checkbox is selected.

S S T <

Restart the SX for the settings to take place.

Install Client Certificate into Internet Explorer

Installing client certificate into Internet Explorer® mostly follows the steps
described in the following link:

http://www.microsoft.com/technet/prodtechnol/ie/reskit/6/part2/cO6ie6rk.
mspx?mfr=true

Importing Certificates for LDAP

;
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The SX will properly add only binary encoded certificates to the local
certdb. In order to import LDAP certificates, the certificates should be
retrieved from the LDAP's server and placed on an FTP server from
which the SX can retrieve them.

Retrieve LDAP Certificate via Access from HTTP Interface

The following steps must be taken in order to insert the Retrieved Server
certificate to SX from the GUI. The LDAPS Server certificate should be
available on a valid FTP Server to which you know the authentication
information.

1. Log into the SX as admin.

Click the Set tab.

Click the Remote Authentication button.
Click the LDAPS Certificate Settings link.

Fill in IP, username, password, and path to the LDAPS Certificate.

o gk~ w N

If the certificate is ASCII encoded, select ASCII. If it is a binary
certificate file, select binary.
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7. Enter a unigue name for this certificate to be stored on the SX.

8. Click OK and the SX should retrieve the specified certificate file with
supplied credentials.

Import Certificates from Windows XP

Follow these steps to load the SX certdb with sufficient certificates to
allow for LDAP connectivity:

1. Launch Internet Explorer®.

2. Type https://<Idap server ip_addr>:636.

Click View Certificate in the name mismatch dialog box.
Click the Certification Path tab.

Select VeriSign/RSA Secure Server CA.

Click View Certificate in the name mismatch dialog box.
Click the Details tab.

Click Copy To File.

Click Next in the certificate import wizard box.

© ©® N o g s~

Select DER encoded Binary and click Next.
10. Complete the wizard to save ROOT_BIN.cer in the FTP root.

11. Close all windows.
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Import Certificates from Dominion SX via CLI

A user with Administrator privileges can do the following to import
certificates for LDAP.

Type the configuration command and issue the following commands:

Config > Authentication > LDAP > LDAPS >getservercert ip
<FTP Server ip addr> login <FTP username> password <FTP
password> path / file ROOT BIN.cer encode binary name
root bin

The command will then display the certificate retrieved, and prompt you
to insert the certificate if it can be retrieved as a valid certificate (as
shown below).

Certificate:

Data:

Version: 1 (0x0)

Serial Number:
02:ad:66:7e:4e:45:fe:5e:57:6f:3¢:98:19:5e:dd:cO
Signature Algorithm: PKCS #1 MD2 With RSA Encryption
Issuer: OU=Secure Server Certification Authority, O="RSA Data
Security, Inc.”, C=US

Validity:

Not Before: Wed Nov 09 00:00:00 1994

Not After: Thu Jan 07 23:59:59 2010

Subject: OU=Secure Server Certification Authority, O="RSA Data
Security, Inc.", C=US

Subject Public Key Info:

Public Key Algorithm: PKCS #1 RSA Encryption

RSA Public Key:

Modulus:
92:.ce:7a:cl:ae:83:3e:5a:aa:89:83:57:ac:25:01:76:
Oc:ad:ae:8e:2c:37:ce:eh:35:78:64:54:03:e5:84:40:
51:¢9:bf:8f:08:€2:8a:82:08:d2:16:86:37:55:€9:b1:
21:02:ad:76:68:81:9a:05:a2:4b:c9:4b:25:66:22:56:
6¢:88:07:8f:f7:81:59:6d:84:07:65:70:13:71:76:3€:
9b:77:4c:e3:50:89:56:98:48:b9:1d:a7:29:1a:13:2€:
4a:11:59:9c:1e:15:d5:49:54:2¢:73:3a:69:82:h1:97:
39:9¢:6d:70:67:48:e5:dd:2d:d6:c8:1e:7b

Exponent: 65537 (0x10001)

Fingerprint (MD5):
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D4:1D:8C:D9:8F:00:B2:04:E9:80:09:98:EC:F8:42:7E
Fingerprint (SHA1):
DA:39:A3:EE:5E:6B:4B:0D:32:55:BF:EF:95:60:18:90:AF:D8:07:09

Signature Algorithm: PKCS #1 MD2 With RSA Encryption
Signature:
65:dd:7e:el:b2:ec:b0:e2:3a:e0:ec:71:46:9a:19:11:
b8:d3:c7:a0:b4:03:40:26:02:3e:09:9¢c:e1:12:b3:d1:
5a:f6:37:a5:b7:61:03:b6:5b:16:69:3b:c6:44:08:0c:
88:53:0¢:6h:97:49:¢7:3e:35:dc:6¢:b9:bb:aa:df:5¢:
bb:3a:2f:93:60:b6:a9:4b:4d:f2:20:f7:cd:5f: 7f:64:
7h:8e:dc:00:5¢:d7:fa:77:ca:39:16:59:6f.0e:ea:d3:
b5:83:7f:4d:4d:42:56:76:b4:c9:5f:04:f8:38:f8:eb:
d2:5f:75:5f.cd:7b:fc:e5:8e:80:7c:fc:50

Certificate Trust Flags:

SSL Flags:

Valid CA

Trusted CA

Trusted Client CA

Email Flags:

Object Signing Flags:

Do you wish to add this certificate to the system database? (no/yes)
(default: no) yes
Adding certificate root_bin to database...
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Microsoft IAS RADIUS Server

;
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The Internet Authentication Service (IAS) is a Microsoft implementation
of the Remote Authentication Dial-In User Service (RADIUS) protocol.
The procedures in this section describe how to configure the SX to use
an IAS server.

Configure the SXto Use an IAS RADIUS Server
The tasks to set up the SX to use an IAS RADIUIS server are:

e Configure a Primary Radius Server (and optional secondary Radius
server).

e Configure a Radius port.

e Configure a secret (shared secret) that is matched in the IAS client
configuration within IAS.

The following example shows a simple setup based on a new IAS
installation.

Note: If the IAS setup already exists, these instructions may not apply
exactly as shown.

Enable IAS on the Server

1. Onthe IAS server, go to the Control Panel and launch Add or
Remove Programs.

2. Click Add/Remove Windows Components.
Highlight Networking Services then click the Detalils... button.

Select the Internet Authentication Service checkbox and then click
OK.

5. Click Next> and continue with the wizard steps.
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IAS Active Directory Access

If using a Domain Controller, set IAS to access the Active Directory®
using the following steps:

1. Launch IAS (choose Start > All Programs > Administrative Tools >
Internet Authentication Service).

2. Right-click on Internet Authentication Service (Local) and select
Register Server in Active Directory.

Note: See the following Microsoft URL for information about Active
Directory:
http://support.microsoft.com/default.aspx?scid=kb;en-us;321051

Add SX to the client list

1. From the Internet Authentication Service, right-click on RADIUS
Clients and select New RADIUS Client.

Type a friendly name and the IP address of the SX.

3. Select the RADIUS Standard in the Client-Vendor drop-down menu,
and type a Shared Secret that matches the SX configuration.

Create an IAS Policy

This section describes the steps to create a policy to allow Radius users
to access the SX. The example in this section requires two conditions:
the client source IP address of the SX and that the UserID is a member
of the SX User Group:

e NAS-IP-Address = Type the IP address of SX
e Windows-Group = SX User Group

Note: If you have multiple SX units or different models of Dominion
product family (DKX, DKSX or KX101), then using an appropriate
condition to match (NAS-IP-Address) rule will help apply the correct
policy for the appropriate Dominion unit.

1. From Internet Authentication Service, right-click on Remote Access
Policies and select New Remote Access Policy.

The New Remote Policy Wizard starts. Click Next>.

3. Select the Set up a custom policy radio button and type a Policy
name.

4. The Policy Conditions dialog appears. Click the Add... button.

Select the NAS-IP-Address name and click the Add... button. Type
the IP address of the SX.

6. Type a second condition using the name Windows-Group and the
value SX User Group. Click Next>.

==
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14.
15.

16.

17.
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Select the Grant remote access permission radio button.
Click Next>. The Profile dialog appears.
Click the Edit Profile... button.

Choose the Authentication tab. Deselect all other checkboxes select
the Unencrypted authentication (PAP, SPAP) checkbox.

Note: This version of SX does not support Challenge Authentication
Protocol (CHAP).

Click the Advanced tab. Remove Framed-Protocol.

Note: Each policy has conditions that must be met. If the conditions
are not met, then IAS goes to the next policy and examines the
conditions.

Click the Add... button. The RADIUS attributes list appears.

Select Filter-ld Name and click the Add button. Click Add in the
Attribute values section. Type the attribute value: Raritan:G{Admin}.

Click OK.

The value in G{} is the name of a group locally on the SX, in this
case the default Admin group.

= The value can be Raritan:G{Admin}:D{1234567890} if you are
using the dial back feature, where 1234567890 is the phone
number for dial back.

= The value Raritan:G{Admin} must match with the local group on
the SX.

= The SX comes from the factory with the default Admin group.

= Additional user groups can be created on the SX by using the
User Management>User Group option.

= Appropriate port access and user class (Operator or Observer)
can be defined. The group name should be specified in the
Filter-1d attribute value accordingly in order to authorize the
RADIUS user to access the SX.

Move the new policy so it appears as the first (top) policy in the
Policy List.

Note: If required, create a policy to allow dialup access to all users
that are members of a group (Windows® may already have a default
Policy in place to permit access by any user with Dial In enabled, so
this new policy would be optional. If you want to use a new Policy,
ensure that it appears above the default policy).

Ensure that the service is started.
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18. Ensure that the Active Directory®/Local account for the user has Dial
In access enabled in their user profile. If the Windows 2000® Domain
server is in Native Mode and IAS is registered with the Active
Directory, you can set the User Profile > Dial In setting to use
Remote Access Policies.

Cisco ACS RADIUS Server

The Cisco Access Control Server (ACS) is another authentication
solution supported by the SX. For the SX to support RADIUS, both the
SX and the user information must be added into the RADIUS
configuration.

Cisco ACS 5.x for RADIUS Authentication

If you are using a Cisco ACS 5.x server, after you have configured the
SX for RADIUS authentication, complete the following steps on the Cisco
ACS 5.x server.

Note: The following steps include the Cisco menus and menu items used
to access each page. Please refer to your Cisco documentation for the
most up to date information on each step and more details on performing
them.

e Add the SX as a AAA Client (Required) - Network Resources >
Network Device Group > Network Device and AAA Clients

o Add/edit users (Required) - Network Resources > Users and Identity
Stores > Internal Identity Stores > Users

e Configure Default Network access to enable CHAP Protocol
(Optional) - Policies > Access Services > Default Network Access

e Create authorization policy rules to control access (Required) -
Policy Elements > Authorization and Permissions > Network
Access > Authorization Profiles

= Dictionary Type: RADIUS-IETF
= RADIUS Attribute: Filter-ID
= Attribute Type: String

= Attribute Value: Raritan:G{Serial_Admin} (where Serial_Admin is
group name created locally on SX). Case sensitive.

e Configure Session Conditions (Date and Time) (Required) - Policy
Elements > Session Conditions > Date and Time

e Configure/create the Network Access Authorization Policy (Required)
- Access Policies > Access Services > Default Network
Access>Authorization
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TACACS+ Server Configuration

The SX has the capability to use Terminal Access Controller
Access-Control System Plus (TACACS+) for authentication services.

The SX requires a new service to be added and two argument-value
pairs to be returned by the server. The new service is called dominionsx.
The valid authorization parameter is user-group. If this user is to have a
modem dialback, the valid dialback parameter is user-dialback.

e user-group: Specifies the user group name that matches with local
group on SX. Group name specified for this attribute on TACACS+
Must exactly (case sensitive) match with group name on SX or else
authentication for TACACS+ user on SX will fail.

user-dialback: Specifies the user's modem dialback number. If the
SX has dialback enabled, this phone number will beis used to call
back the user.

CiscoSecure ACS

These instructions are written for CiscoSecure ACS version 3.2.

Note: See the following URL:
http://cisco.com/en/US/products/sw/secursw/ps2086/products_user_guid
e_chapter09186a008007cd49.html#12231

1. Add SX as a client on Cisco ACS TACACS+.

s Sunews  etwork Configuration

Edit
Uzer
TR Add AAA Client
% | Shared Profile
S ALA Clent Hostname |Dominionsx
] e on _ 152.165.56.20
AAA Clhent TP Address
% System
= Configuration
ot Key raritan
Canet':gz?’Ztion
. | Adrinistration Authenticate Tsing |TACACS+ (Cisco 105) V|

¥ | Control

= [ Single Connect TACACS+ A48 4 Clent (Record stop in accounting on failure).

- | External User
3@ | Databases . .
[ Log Update/Watchdog Packets from this A48 Clent
Reportsand
@ Gctivity [ Log BEADIUS Tunneling Packets from this A4 & Clent
‘ | Online

Dacurnentation

[ Submit ] ’ Submit + Restart ] ’ Cancel ]
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2. Select Interface Configuration.

wetine  Interface Configuration

| User

Setu

@ L E" szer Data Confisuration
B TACACST (Cisco IOS)

% |ghared Prﬁﬁle RAD—(]E—”US 1F
il T Advanced Options

MNetwork
Configuration

@ Back to Help
L)

i o System
Configuration

| ]

Interface
Configuration

| | Administration

Control

" | External User
Cratabases

e
G

Reportsand
Activity

ﬁ

‘ Online

= Crocurnentation

3. Select TACACS+ (Cisco 10S).
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4. Add dominionsx service under the heading New Services.

Cisco Srsrems IﬂtEﬂﬂcE [:[lllﬁ!]l]fﬂtio"

: Edit
‘
TACACS+ (Cisco)
Eroup
q | Setup
% | Shared Profile
Coneo TACACS+ Services hd
a Canthgarstion User  Group
% System D PPP IP
= Configuration D I:‘ PP IPX
Gontiauration o O FPP Multiind
e O O FPP Apple Talk
3l | Control D D PPP WDN
j_-l | External User O O PP LCE
E Lg Cratabases
O | ARAP
@ EZ?&T?J = O Shell (exec)
‘ g:c‘:i.lr::entation D I:‘ PD(: Sheu (pIXShE]D
O [ SLIP
New Services
Service Protocol
daminionsx

5.  When adding or editing a user or group, the dominionsx service will
appear under the heading TACACS+ Settings. The service can be
enabled per user or per group by selecting the dominionsx and
Custom Attributes checkboxes. Add the attributes (user-type) and
the appropriate values to the text box.
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Note: The value for the user-group attribute is case sensitive; ensure that
it matches exactly the same as the local group hame on the SX.

Cisco SysTEMs User SEII]I]

[ Failed attempts exceed:

5
Setup

=
w
o
]
b

Failed attempts since last successful login: 0

e [JFReset current failed attempts count on submit

el

% Shared Profile
Companents

Metwork
Configuration

At Sgstgm X

B Configuration TACACS+ Settnes ?
AlLaAalLsTe g #
Interface .

Configuration dominionsx

adrninistration Custom attributes

user—-group=Aadmin

d A, | External User
3@ | Databases

Sl |

Reportsand
Activity

2]

_‘ | ggcltiur;\:entation
IETF RADIUS Attributes hd

C1[011] Filter-Id
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Active Directory

;

Raritan.

Microsoft Active Directory® uses the LDAP protocol natively, and can
function as an LDAP server and authentication source for the SX. See
the following Microsoft URL for information about Active Directory:
http://support.microsoft.com/default.aspx?scid=kb;en-us;321051

If you choose LDAP authentication protocol, complete the LDAP fields as
follows:

Default Port/User Defined Port - By default, LDAP uses port 389. To
use a different port, click User defined ports, and then enter a
different port number in the Single port field.

Base DN, Base Search - This describes the name you want to bind
against the LDAP, and where in the database to begin searching for
the specified Base DN. An example Base DN value might be:
“cn=Administrator,cn=Users,dc=testradius,dc=com” and an example
Base Search value might be: “cn=Users,dc=raritan,dc=com”.
Consult your authentication server administrator for the appropriate
values to enter into these fields. In order to Authenticate to a remote
AD Server, the SX BaseDN must be set as follows:
"cn=Administrator,cn=Users,dc=raritan,dc=net".
Always use administrator or another role that has permissions to the
tree where the users are stored. Search fields must use, for example,
"cn=Users,dc=raritan,dc=net".

Certificate File - Consult your authentication server administrator for
the appropriate values to type into this field on LDAP configuration
menu/page, in order to process LDAP authentication queries from
SX.
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In This Chapter

Client Dial-Up Networking Configuration ............ccccoeevvvvvveeeeeiiiiiivinnennn. 294
Windows NT Dial-Up Networking Configuration............cccccccvvveeeviinnnnee, 294
Windows 2000 Dial-Up Networking Configuration ...........cccccceeeeviivnnen. 297
Windows Vista Dial-Up Networking Configuration ..............ccccceeviieeeee 301
Windows XP Dial-Up Networking Configuration.............ccccoovveeiiiineeens 302

Client Dial-Up Networking Configuration

Configuring Microsoft Windows® Dial-Up Networking for use with SX
allows configuration of a PC to reside on the same PPP network as the
SX. After the dial-up connection is established, connecting to a SX is
achieved by pointing the web browser to the PPP Server IP. Modem
installation guidelines are provided for the following client based
systems:

e Windows 7°
e Windows XP® operating system
e Windows Vista®

Windows NT Dial-Up Networking Configuration

;

Raritan.

1. Choose Start > Programs > Accessories > Dial-Up Networking.
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2. Click New in the Dial-Up Networking dialog. The New Phonebook
Entry dialog allows you to configure the details of this connection.

<% Dial-Up Networking

Phonebook entoy to dial:

uz Dialup

Phone number preview:;
|555-5555

Dialing from:
INm Location _ﬂ

Dial Close |

3. Click the Basic tab and complete the following fields:
= Entry name - Name of the SX connection

=  Phone number - Phone number of the line attached to the SX
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= Dial using - Modem being used to connect to SX; if there is no
entry here, there is no modem installed in your workstation

New Phonebook Entry

us Rorbroticsr SGk Sportster Modi ¥

4. Click the Security tab. The Security section allows you to specify the
level of security to use with the modem connection. When
connecting to the SX, security is provided by SSL/ with RC4
encryption, therefore no dial-up security is required.
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5. Click the "Accept any authentication including clear text" radio
button.

MNew Phonebook Entry

I Fes (i=elitzg 2 g

= Wsecumertusemame ernd [EESGT0

U FBavE DasSITD

6. Click OK to return to the main Dial page.

7. Click Dial. See the Windows NT® Users Guide if you receive any
error messages.

Windows 2000 Dial-Up Networking Configuration

1. Choose Start > Programs > Accessories > Communications >
Network and Dial-Up Connections.

=& Raritan. 297
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2. Double-click the Make New Connection icon when the Network and
Dial-Up Connections window appears.

1 Metwodk arad Dial-up Connectiong

Fﬁ-samrmrmmmh =
s A | = ' mom X |a-

| Has Semch Foldern Hitoy "'-\":'L Loy 1o Dskebe lJrhh
rhﬁwiﬂwmmnwcmmﬁ: =] 6o | NotonAniveus L] -

| L %
Hmﬂ: and Dial-up

Connections

Thie Bk contand restwork,
correchions fon B comguber, and &
wazind] b Fesle youi ErBibe & rsw
coredshon

To cieate & new connachon, chok
Make Wew Connection

T opean & connecion, ook, B icdn

T sccass sellingt b compeorsnts of
& correchon, nght-chck ks soon and
e ok g

T o identify pour compuber on the
Frbbyank,

Select &ry bivn o veiw RS destiplon

2 cbiects) o

3. Click Next and follow the steps in the Network Connection Wizard
dialog to create custom dial-up network profiles.
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4. Click the Dial-up to private network radio button and click Next.

—
| Hetwoirk Connection Wizard

Nelwork Conneclion Type
ou can choose the type of network connection you want to create, based on
wour network, configuralion and your netwolking needs.

5. Select the checkbox before the modem that you want to use to
connect to the SX and then click Next.

Select a Device
Thiz iz the device that wil be used to make the connection,

24 Modem - Lucent '\Win Modem [COM3)

6. Type the area code and phone number you wish to dial in the
appropriate fields.

=& Raritan. 299
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7. Click the Country/region code drop-down arrow and select the
country or region from the list.

| Helwork Conneclion Wizard

Phone Number to Dial
“fou must specify the phone number of the computer of rebwork. pou wanl to

| Urited States of Amedica (1] B
[V Use disfing nies

IV

8. Click Next. The Connection Availability dialog appears.

9. Click the Only for myself radio button in the Connection Availability
dialog.

*I woirk Connection Wizard

Connection Availability
“ou may make the new connection avalable to all uzers, or just vourself,
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10. Click Next. The Network Connection has been created.
11. Type the name of the Dial-up connection.
12. Click Finish.

13. Click Dial to connect to the remote machine when the Dial dialog
appears. A dialog indicating that a successful connection has been
established will appear.

Consult the Windows 2000° Dial-up Networking Help if you receive any
error messages.

Windows Vista Dial-Up Networking Configuration

1. Click Start and then click Network. The Network window opens.

2. Select Network and Sharing Center at the top of the window. The
Network and Sharing Center window opens.

Select “Set up a Connection or Network”.

4. Select “Set up a dial-up connection”. The "Set up a dial-up
connection” dialog appears.

Enter the dial-up number.

Enter your username and password.

Note: In order to access the SX, the username and password cannot
use a\ (backslash).

7. Click Connect.

@ @ Setuplbaia'l; ‘connection

Type the information from your Internet service provider (ISP)

Dial-up phone number: Dialing Rules

User name:

Password:

| Show characters
Rei

v

member this password

Connection name:

@ [ Allow other people to use this connection
This opticn allows anyone with access to this computer to use this connection.

1don't have an ISP

[ Connect ][ Cancel ]
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Windows XP Dial-Up Networking Configuration

1. Choose Start > Programs > Accessories > Communications > New
Connection Wizard.

2. Click Next and follow the steps in the New Connection Wizard to
create custom dial-up network profiles.

3. Click the Connect to the Internet radio button and click Next.

New Connection Wizard

Metwork Connection Type
w'hat do you want to do?

{*)iConnect to the Internet
Connect ta the Intermet zo vou can browse the Web and read email.

i) Connect to the network at my workplace

Connect to a business netwark [uzing dial-up or ¥PH] 20 yau can wark from haome,
a field office, or another location.

i) 5et up a home or zmall office network
Connect to an exizting home or small office netwark, or zet up a new one.

{1 5et up an advanced connection

Connect directly to anather computer using your zenal, parallel, or infrared port, or
zet up thiz computer zo that ather computers can connect to it

< Back ” Mest > l[ Cancel
502 =&=Raritan.



;

Raritan.

Appendix E: Modem Configuration

4. Click the "Set up my connection manually" radio button and click
Next.

HNew Connection Wizard

Getting Ready
The wizard iz preparing to set up wour Internet conneckion.

Howe do you want bo connect to the Intermet’?

() Choosze from a list of Internet service providers [I5Ps)

{(*)i5et up my connection manuallg

For a dial-up connection, you will need pour account name, paszword, and a
phone number for your ISP, For a broadband account, vou won't need a phone
number.

(i Use the CD | got from an ISP

< Back ” Mewt > l[ Cancel
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5. Click the "Connect using a dial-up modem" radio button and click

Next.
New Connection Wizard
Internet Connection
How do vou want to connect to the [nternet’?

{*)iConnect using a dial-up modem

Thiz type of connection uzes a modem and a reqular or IS0 phone line.

i) Connect uzing a broadband connection that requires a user name and
password

Thiz iz a high-speed connection using either a D5L or cable modem. our ISP may
refer ta thiz twpe of connection as PPPaE.

) Connect using a broadband connection that is always on

Thiz iz a high-zpeed connection wzing either a cable modem, DSL or LAM
connection. It iz always achive, and doesn't require you to zign in.

< Back ” Mest > l[ Cancel
50 =&=Raritan.
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6. Type a name to identify this particular connection in the ISP Name
field and click Next.

New Connection Wizard

Connection Name
What is the name of the service that provides your Internet connection?

Type the hame of your ISP in the following box.

ISP Name

' DominionKSX

The name you type here will be the name of the connection you are creating.

[ < Back ]L_ﬂexw ] [ Cancel ]
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7. Type the phone number for the connection in the Phone number field
and click Next.

New Connection Wizard
Phone Humber to Dial
w'hat iz your |SP's phone number?

Type the phone number below,

Phone number;
!aaaaaaaaaa

Yau might need ta include a "1 or the area cade, ar bath. If you are not sure
wou nieed the extra numberz, dial the phone number on your telephone. [F pou
hear a modemn sound, the number dialed iz comrect.

[ < Back ]uext> ][ Cancel

8. Type your ISP information. Type the user name and password in the
appropriate fields, and retype the password to confirm it.

306
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9. Select the checkbox before the appropriate option below the fields
and click Next.

HNew Connection Wizard

Internet Account Information
Y'ou will need an account name and pazsword to ziga in to your [ntermet account.

Tupe an ISP account name and pazsward, then write down this information and stare it in a
zafe place. [|If you have forgatten an exizting account name or pazeword, contact your 15P.]

g [ .
User name: | adrmir |
Pazzword: sessnee

Coanfirrn pazsward: i YT |

[ ]Use this account name and password when anyone connects to the Internet from
thiz computer

[ ] Make thiz the dafault Intemet connection

< Back ” Mewt > l[ Cancel

10. Click Finish.

11. Click Dial to connect to the remote machine when the Dial dialog
appears. A dialog indicating that you connected successfully appears.
If you get any errors, consult Windows XP® Dial-up Networking Help.

Note: The maximum modem speed connecting to the SX is 33,600 bps,
as it is a Linux® default limitation.
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Appendix F Accessing a PX2 from the SX

In This Chapter

OVEBIVIBW ...ttt ettt et e e e ettt e e e e st e e e e s e e e e nnees 308
Connecting the SX to the PX2 Serial POrt......ccccccoovecvivieiee e, 308
Connecting the SX to the PX2 FEATURE Port.......cccocccvvveeeviiciiiieennn, 309

Overview

The SX provides the following options when connecting a PX2 to a SX:

e Connecting the SX to the PX2 Serial port to connect to and access
the PX2.

In this configuration, access to the PX2 is done through the PX2 CLI.
e Connecting the SX to the Feature port on the PX2.

In this configuration, the PX2 is managed from the SX interface like
any other powerstrip. See Power Control (on page 237).

See the PX2 Help for information on using the PX2 device.

Connecting the SX to the PX2 Serial Port

i

Raritan.

In this configuration, after the PX2 is connected to the SX, access to the
PX2 is done through the PX2 CLI.

» To connect the SX to the PX2:

Connect the ASCSDB9F adapter to the PX2 DB9 console/modem
port.

2. Plug a Cat5 cable into the ASCSDB9F adapter and the other end
into an RJ45 Serial port on the SX.

308



Appendix F: Accessing a PX2 from the SX

3. Power on the PX2. The CLI interface appears.

Connecting the SX to the PX2 FEATURE Port

In this configuration, the PX2 is managed from the SX interface like any
other powerstrip. See Power Control (on page 237).

> To connect the SX to the Feature port on the PX2:

Connect the red end of the CSCSPCS crossover Cat5 cable into the
Feature port on the PX2.

2. Connect the yellow end of the CSCSPCS crossover Cat5 cable into
a port on the SX.

309
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3. Power on the PX2. You can now add the PX2 as a managed
powerstrip to the SX.

DAISY CHMAN TERMIMATION SEMBOR
Pr— s

CURRENT A,

VOLTAGR(V)

POWERW)

VO LOADON)

sENsOn

CUTLET I LINE /GO U
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In This Chapter
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Page Access

Problem Solution

Cannot login - what are
factory defaults? (only
for SX units running
firmware version 2.5 or
higher)

Cannot login - non
defaults.

Server Unreachable

DNS Error/Server
Unreachable

;

Raritan.

username: admin (all lower case)

password: raritan (all lower case)

Check multiple login per user status. If disabled and there
is already a session established opening anew one fails.

Check Local Authentication status. If it is not enabled only
remote users may login.

If a unit appears to be unreachable by a given browser,
run through the following troubleshooting list:

= Verify that the unit is powered on.

= Verify that the unit is properly connected to a network.

= Ping the unit from a computer on the same network to
ensure that network communication with the unit
occurs.

= Should the ping fail, contact your network
administrator. There may be a problem with your
network configuration that is preventing communication
with the unit.

= Should the ping succeed, consult the following topics.

When attempting to connect to the SX URL using
Microsoft IE, a web page may appear indicating a DNS
error and reading that the server is unreachable.

Remove any installed SX certificates and restart the
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Problem

Unsupported
Encryption

Number of Users
Exceeded

Solution
browser.

The unit supports only 128-hit SSL encryption.

In Internet Explorer®, view Help > About Internet Explorer
and determine the maximum SSL bit strength for the
browser. If it is not at the desired strength, it is
recommended that the browser be upgraded.

In Netscape®, view Communicator > Tools > Security
Info > SSL v3.0 Configuration and ensure that 128-bit SSL
is supported

The unit has a security measure that allows only a specific
number of login pages to be authenticated at any given
time. Should this number be reached when attempting to
login to the unit, a pop-up window displays indicating that
the maximum number of users is exceeded. This is normal
behavior for the unit.

Wait for a few minutes and attempt to login again. You
may need to refresh or <Shift+Refresh> your browser to
successfully log in.

Firewall

Problem

Solution

Unable to Access the Web  Firewalls must allow access on port 80 (for http) and 443 (for https)

Page

Login Failure

SSL Security Warnings

312

for the unit to operate through a firewall.

Contact your system administrator and request port 80 and 443, or
other custom configured ports for access.

Firewalls must be configured to allow connections using the SX
configurable port network parameter (Default 51000). If the firewall
does not allow these connections, the applet indicates that the login
has failed.

Contact your system administrator and request that connections be
allowed on the configurable port.

The unit embeds its Internet Address (IP) in its SSL certificate.
Should the firewall perform Network Address Translation (NAT), the
SSL certificate will not match the IP address recognized by the
browser generating a security warning.

This is normal behavior.

The warning message does not affect operation of the unit.

=&=Raritan.
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Login

Problem
Login Failure

RADIUS Users

Solution

To provide additional security, the unit login page expires after three
minutes. Therefore, all login attempts after this time period will fail.
Reload the browser to reset this timer.

Hold down the SHIFT key and click Reload in your browser. This will
refresh the login page from the unit itself (not from a local cache)
and allow login to the unit.

The unit can be configured to support RADIUS authentication. Any
user not defined as a local user is considered to be a RADIUS user
when RADIUS is enabled.

If the RADIUS server is not reachable for user authentication for any
reason, the unit will not allow the user to log in until the unit receives
the result of the authentication request from the RADIUS server.

Authentication may take up to 20 seconds. Be patient and wait until
either the user successfully logs in, or the Authentication Denied
message is displayed.

Port Access

Problem
Port Access Refresh

Solution

The unit does not automatically refresh the Port Access list. It is
refreshed only when the user clicks Port Access. Therefore, it is
possible that a user will have permissions revoked and these
changes will not be visible on the port access page until the Port
Access button is activated.

You must log out and log in again for the new restriction to be
applied. Then the restricted ports are invisible.

Whenever possible, it is recommended that Administrators not
change port access rights to a user who is already logged in to the
unit.

Upgrade

Problem
FTP - Server Unreachable

)
v

Raritan.

Solution

If FTP server specified in the upgrade panel is unreachable or
incorrect, the upgrade process halts until a response is received
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Problem

FTP - File Not Found

Insufficient Partition Size

Problem

Upgrade failed in dual-LAN
units

Solution
from the FTP server or until a timeout occurs.

Wait and allow the FTP Server Unreachable message to appear.

The unit requires a package of upgrade files to be in the directory
specified by the upgrade path. This package must have all included
files and an upgrade.cnf file. Should this file not exist, or if the
contents of the file are not in the indicated places, the File Not
Found message will appear.

Verify that the upgrade package is in the correct directory and
confirm the upgrade path and IP address of the FTP server.

If the upgrade still fails, reinstall the upgrade package and begin
again.

The latest 3.1.0.5.7 firmware is specifically applicable to SX models
- DSX16 and DSX32 only (purchased before August 2004). This
version also supports the use with CC-SG 3.1 (CommandCenter
SecureGateway) or higher.

Note that the attempt to upgrade firmware to the latest 3.1.0.5.7
version is aborted if the SX is detected with less than 32mb partition
size. Then the upgrade will not be performed, and the unit's
operation will not be impacted. The unit will auto restart after the
upgrade is attempted. Following screen shots exhibit a sample
upgrade attempted for such unit (IP Address for the unit is
10.0.13.182).

(See the figures shown below for details.)

Solution

While upgrading dual-LAN units from 2.5.x versions, an error
message appears stating "The upgrade has failed. Check your
upgrade directory and/or your connections, and try again.". (See the
figure below for details.) In order to properly complete the upgrade,
do not reboot the unit when the message appears, but re-apply the
upgrade pack again.

314

Modem

Problem Solution
Login Failure The unit supports Web-browser access through the modem

at connection speeds of 28.8K bps or greater. If the baud
rate is insufficient, the user may be unable to log in to the

==
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Problem Solution

unit via the modem.

28.8K bps minimum connection speed is recommended for
browser-based modem authentications (login). For
CLI-based access, using SSH or Telnet, speed as low as
9600bps is adequate.

SSH Connection

Problem

SSH Access to SX from a
client running the Windows
Vista® operating system
failed to connect.

Raritan.

;

Solution

There may be a problem experienced by some users of Vista's
Enterprise (and Business) edition with SX where the SSH window
starts and fails to open. This is independent of the SX firmware
version and does not require an upgrade of SX firmware to
resolve.

This problem seems to stem from the Vista's implementation of
TCP auto tuning.

Vista's Enterprise (and Business) editions utilize an aggressive
scaling factor, which causes issues in packet segmentation,
leading to SSH handshake messages being split apart and
connection to never complete. The problem with Vista, is what
Vista is doing when it sees that the SX cannot support the window
scaling size of 8. Microsoft has described this problem at
http://support.microsoft.com/kb/929868/
http://support.microsoft.com/kb/929868/. SX cannot support a
window scaling of 8 at all, because there is insufficient memory to
support this level of packet buffering. When this scaling factor is
shrunk or disabled entirely, the SSH handshaking completes
correctly and the connection can be established.

To perform this on vista, run a cmd.exe shell at an elevated admin
level and execute the following command:

netsh interface tcp set global
autotuninglevel=highlyrestricted

_or‘_

netsh interface tcp set global
autotuninglevel=disable
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iptables --list Hanging

If iptables --list hangs, it may be because the current rules are preventing
access to the DNS server from the SX. Execute iptables -n --list to
prevent DNS lookups from hanging this command.

Display Issue with Japanese Characters when Using Teraterm 3.1

When connecting to a SX serial port via Teraterm 3.1 and then setting
the terminal language to Japanese (ja_JP:UTF8), the characters are not
displayed correctly. To avoid this issue, use RSC or Putty.

Lines are Overwritten after Column 80 in Linux

The default Linux® terminal display is set up for 80 columns, while RSC
can be configured to have a different number of columns. If the RSC is
configured to a different column number than the terminal, the last line in
the columns may be overwritten when you perform a carriage return at
the end of the last line.

To avoid this, set the default display columns in RSC to the same value
as the terminal, or execute 'stty cols <numberofcols>' on the terminal.

AlX Terminal Settings Not Displaying Correctly

If you encounter a display issue where the AIX terminal settings do not
match up with the rows and columns in the RSC interface or the SSH
terminal, do the following:

1. From the terminal window when connected issue the following
command on the AIX shell: stty rows <X>

where <X> is the number of rows visible on the RSC or SSH
terminal.
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In This Chapter
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Chapter 15

FAQs

Questions

How do | enable Direct
Port Access with a

Dominion SX unit running

SX3.1+ firmware?

Why do | get a "This page

contains secure and
insecure items" prompt
when using IE6?

Why do | get an "Invalid

certificate message"
when using some
browsers?

What is the purpose of
the Disable Local
Authentication option?

When | Disable Local

Authentication, how come

| cannot log into the
Dominion SX unit?

Why do I lose
connectivity to the
Dominion SX unit after
resetting it to factory
default?

;
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Answers

Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Attached is a sample run for DPA configuration from CLI.

The following are main steps:

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

This message may or may not be displayed, depending on the settings of
IE6.

The Certificate Authority (CA) used by Raritan, Inc. may not be on the CA list
of the browser.

For security reasons, some users do not want to allow any locally
authenticated users to log into the Dominion SX unit. This option allows only
for remotely authenticated users to log into the Dominion SX unit. This option
should only be enabled AFTER remote authentication has been successfully
tested and configured.

This is because of a couple of reasons:
A valid remote authentication source has not been entered
e The remote authentication source is not reachable

e The Disable Local Authentication option should only be enabled AFTER
remote authentication has been successfully tested and configured

By default the unit in factory reset mode enables DHCP to get an IP address.
If there is no DHCP server, it will reset to the IP address 192.168.0.192 with
the username "admin" and password "raritan".
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Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

What settings will be lost
when restoring a unit to
factory default?

Why does the Device
disconnect indication not
work with all my devices
and servers?

Why does my device
show "Down" in the port
access menu on the GUI
and the CLI, but | can still
log into it?

How many lines can | cut
and paste with the
Dominion SX?

Where can | get a copy of
the MIB for Dominion
SX?

With Dominion SX
release 3.0 or higher, do |
still need to type
dominion before | get the
username and password
prompt using
SSH/Telnet?

;

Raritan.

Chapter 15: Frequently Asked Questions

Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

All user-entered settings: usernames, passwords, all networking parameters
—including IP address, security profiles, firewall rules, all services, TCP port
numbers for services, idle logout timer, strong password rules.

Device disconnect indication requires both hardware (RS232) control signal
support, and the right serial cabling to work. If either of these is missing,
device disconnect indication cannot correctly track the loss of connection to
a serial device. Most, but not all, servers and devices support these control
signals.

If a device is configured for device disconnect indication, but the device
cannot support the control signal or (RS232) serial cabling is not correctly
made, the device will indicate "Down" on the Port access screen (GUI) and
on the CLI, but it can may still be accessible when connected. Disable the
device disconnect indication option to show default indication that the device
is "Up".

With SX release 3.0, this user-configurable and can be set up to copy-paste
an industry-leading 9999 lines.

The SX MIB is available from the SX User Interface on the GUI SNMP
configuration page. Also from the Firmware, Software and Product
Documentation page for the SX: www.raritan.com/support/dominion-sx

No. Beginning with release 3.0, enter the username in the "Login as:" or
Username prompt.
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Chapter 15: Frequently Asked Questions

Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

When | SSH into
Dominion SX, | am
unable to log in, even
when | use a local
account that | know works
through the web/GUI
interface.

My Dominion SX has just
been configured with a
network address and |
can successfully ping the
SX IP, but when I try to
access it using a Web
browser, the message
reads "Page cannot be
found or server error,
please contact System
Administrator".

When | select the "Send
Break" option from the
Emulator menu in Raritan
Console (on my DSX), it
does not send a break to
my Sun server. What
could be wrong and how
can | address it?

Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

[Only applied to firmware releases 2.1 though 2.5] The initial login name for
Dominion SX over SSH interface is dominion (no password). Once this
account is accessed you will see the "Welcome to Raritan Dominion Server"
message and be prompted to enter a username. At this prompt, type the
account that exists locally on the SX or the remote account (this assumes
that the SX unit is configured with remote authentication information).

Check your Web browser settings and confirm that a proxy server is being
used. If so, click on the checkbox to '‘Bypass local addresses or configure
DSX IP in the exception list." Next, make sure the Web browser has 128-bit
cipher strength. From the Help menu, click on "About" to find this
information.

If the SUN machine does not respond to the break signal, verify that the line
'KEYBOARD_ABORT=disable' is commented out in the /etc/default/kbd file
(on the SUN machine). If this line is not commented out, it will disable a
keyboard abort sequence; comment out this line to enable the sequence.

i
i
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Questions
How do | enable Direct

Port

Dominion SX unit running

SX3

Is th

Access with a

1+ firmware?

ere any software

requirement for PCs
connected to Dominion

SX?

How can | consolidate the

sites where | have a
Dominion SX installed?

Is the Ethernet port on
the Dominion SX unit

10/1

00Mbps auto

sensing?

Can

the network port(s)

on the Dominion SX be
set to 100Mbps

Full-

Duplex?

Does Dominion SX
support RS422 and

RS4

Dol

85?

need to be a UNIX

expert to install
Dominion SX?

;

Raritan.

Chapter 15: Frequently Asked Questions

Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Depends. For access using a web-browser, the Dominion SX does not
require any software to be loaded on the client; the browser does have to be
Java-enabled. It is 100% operating system independent. When using an
SSH/Telnet client, the customer has to provide an SSH/Telnet client. In
some operating systems, like Linux®, an SSH client is included in the
distribution. Also, OpenSSH.org has an SSH client.

Raritan's CommandCenter® Secure Gateway is designed specifically to
provide centralized management. It is the ideal solution if you are looking to
consolidate management of devices such as Dominion SX and other Raritan
network-based products.

Yes.

Yes.

No. Currently Dominion SX supports only asynchronous RS232 (also
commonly called serial, even though serial is a broad term that covers more
than RS232). RS 422 and RS485 are used in industrial automation and other
markets. Dominion SX is currently designed for connection to serially
managed servers and other devices typically found in the data-center and
server rooms. This includes serially controlled power strips like Raritan's line
of remote power control units.

Dominion SX is the easiest to install of all the secure console servers on the
market. From power-up, typical time for installation is less than 3 minutes,
with no need to edit files and use the command-line. Dominion SX does not
require an external server to operate.
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Chapter 15: Frequently Asked Questions

Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

| have a server/serially
managed device that is
more than 300 feet from
the Dominion SX - how
do | connect?

Does Dominion SX
provide an integrated
interface that allows you
to view all the Serial
devices that are
connected?

Can | open multiple
windows and "tile" to
monitor multiple servers
and other IT equipment?

| manage many servers.
How do | select a server
to connect to?

As a user, do | see all
servers connected to a
Dominion SX?
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Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

You will need to purchase a 3rd party RS232 to RS422/485 converter for
each end (two units total)-one at the Dominion end and one connected to the
device.

Yes, Dominion SX provides a single, consolidated view of all serial devices
via one-sign-on. A single IP address gives access to all connected serial
devices while any Java-enabled Web browser provides terminal emulation.
Or, use an SSH/Telnet client.

Yes, you may monitor and "tile" as many windows as there are serial ports
on the Dominion SX. For example, up to 32 serial ports on a 32 port unit, 16
on a 16-port unit and 48 on a 48-port unit. This is assuming one (1) user
session per port; in some applications more than one user session per port
is possible.

From a browser, a simple menu provides the user-assigned name of each
server. Users simply click on a server to connect to its console port. When
using SSH/telnet, the user gets a list of ports they are authorized to connect
with when they log in.

No. Each user sees only a list of servers they are authorized to
manage/view. The administrator of the Dominion SX sets up the access
privileges to each server by user group, or under control of privileges from a
directory service like LDAP, Active Directory®, or authentication system -
TACACS+, RADIUS, or Kerberos.

i
i
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Questions

How do | enable Direct
Port Access with a

Dominion SX unit running

SX3.1+ firmware?

Does Dominion SX work

with

Raritan's

CommandCenter®
Secure Gateway?

Is the modem used only

for administering the
Dominion SX itself?

Is a modem standard on

any Dominion SX
models?

What level of control does
Dominion SX have over
attached target servers?

What is the MTBF for the

power supply in the
Dominion SX?

What is the ESD

(electro-static discharge)

protection on the
Dominion SX serial
ports?

Why do | need to use a

serial adapter to connect

to some servers?
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Answers

Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Attached is a sample run for DPA configuration from CLI.

The following are main steps:

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Yes, Dominion SX is deployable as part of an enterprise-wide management
solution with Raritan's CommandCenter Secure Gateway; hundreds of
Dominion SX units can be managed via CommandCenter Secure Gateway.

No. Unlike other products in its category, Dominion SX offers modem access
to administer the box and get to the target servers.

Many Dominion SX Models with 4- to 48-serial ports include a built-in 56K
modem. Competitors charge for an additional PCMCIA modem; other
models have a dedicated modem port via a DB9-Male connector.

The remote user has direct command line access and total control of target
devices for maintenance, administration, troubleshooting, and even
rebooting. User rights are only restricted by their log-on privileges on
Dominion SX and the server itself.

350,000 hours. But, keep in mind that the life of a power supply depends on
environmental factors like temperature, humidity, variation in power, and
other factors.

15KV (Kilo volts)

While EIA published a standard for RS232 on DB25 and DB9 connectors,
there is no standard for RS232 on RJ45 connectors. Also, some
manufacturers have chosen not to follow the pin out assignments of the EIA
on DB25 and DB9 connectors.
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Chapter 15: Frequently Asked Questions

Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

Is the Dominion SX unit
SUN® "break-safe"?

| have lost my Admin
password to the
Dominion SX. Is there a
back door or secret
password?

Does Dominion SX
include the 19" rack
mount Kit or is there an
extra charge for this
option?

What remote access
connection methods can
Dominion SX
accommodate?

Which ports need to be
open on the corporate
firewall for a secure
console session using
Dominion SX?

How do | get access to
the operating system of
the Dominion SX?
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Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

All Dominion SX units are SUN "break-safe" for use with SUN Solaris; and,
the units are Solaris Ready certified by SUN.

For security reasons, there is no back-door password. The only option is to
restore the unit to its factory default settings. A hardware reset function to
restore the unit to factory default settings is provided.

Dominion SX comes standard with a complete ready-to-install 19" rack
mount kit on the models with 16 or greater serial ports. One 8-port model
with dual-power also comes with a rack-mount kit. Some competitors charge
extra for a rack mount kit. On models with less than 16 ports, a rack mount
kit is available as an option.

Dominion SX provides multiple choices for remote access. These include:
HTTP/HTTPS, SSH/Telnet, or dial-up modem. That means servers can be
accessed both in and out of band so remote access to mission critical target
servers is always available-even if the network is down.

Port 443 (for https); optionally port 80 (http) for user sessions. For units
running software version 2.2 or higher, port 51000 (or other port between
1024-65536). On software releases PRIOR to firmware 2.2 (2.0Bx or 2.1.X)
either port 23 or a user-designated port between 2000 and 2400. When
using SSH, port 22 needs to be open. Starting with Dominion SX firmware
3.0, the TCP ports for HTTP, HTTPS, Telnet, SSH are all user configurable.
These user configured ports will need to be open for access. Also, TCP port
5000.

Dominion SX is a secure appliance. Therefore, NO access is possible to the
operating system.
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Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

| have a few serial
devices located a
distance away from my
server closet and the
Dominion SX. Can |
connect these devices to
my Raritan switch?

How do | upgrade the
software on my Dominion
SX?

Are updates to Dominion
SX software free?

Does Dominion SX
require any additional
client software?

What code-sets does the
terminal emulator in
Dominion SX support?

What is the name of the
terminal emulation
package included with
Dominion SX?

Raritan.
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Chapter 15: Frequently Asked Questions

Answers

Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Attached is a sample run for DPA configuration from CLI.

The following are main steps:

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Yes. EIA RS232 specifications defined in the 1970s recommend that the
maximum distance serial devices be 30 feet (10 meters). However, with
good cables, no patch panels, and lower baud rates, customers report
success up to 200 feet.

Use the Administrator option for Upgrade from a menu. The upgrade is done
over the Ethernet port of the Dominion SX. Access to an FTP server is
required.

Yes. Currently, all software upgrades are free.

No. Dominion SX is truly "Plug-and-Play" making installation quick and
set-up easy. It is not necessary to buy any additional client software or
hardware. In addition, no special networking equipment or design is
necessary.

Dominion SX release 3.0 or higher supports VT100/VT220/VT320 and ANSI
with the following code-sets:

US-ASCII (ISO 646)
e 1SO 8859- (Latin-1)

e 1SO-8859-15— (Latin -9)
e UTF8

Beginning with Release 3.0 it is called the Raritan Serial Console (RSC). For
firmware releases 2.00 through and including 2.5, it was called
RaritanConsole.
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Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

Can | use Dominion SX
over a VPN connection?

The Dominion SX uses
the Web browser to
access serial devices.
What are the advantages
of Java-enabled Web
browser access?

| need an IP-enabled
console switch. Now that
Dominion SX support
local (direct) Port access,
beginning with release
2.2, by using the AUATC,
can | connect a Dominion
SX to the Paragon
network, instead of using
an SCS232 Console
Switch (or equivalent)?

What Authentication
mechanisms does the
Dominion SX support?

What Authentication and
Authorization
mechanisms does the
Dominion SX support?
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Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Yes, Dominion SX fits into most any network configuration utilizing TCP/IP.
Set up the VPN (typically IPSec) connection then start the web-browser and
enter the URL for the Dominion unit. The session to the Dominion runs
transparently over the VPN tunnel.

For many Solaris™/Unix®/Linux system administrators, the de facto standard
for accessing serial hosts is SSH. However, the SSH clients available for
Unix/Linux do not support Apple Macintosh. Additionally, Java-enabled
browsers are available on many platforms, including PDAs and handheld
PCs. The easy "point-and-click" access offered by Dominion SX allows
administrators secure access from any Java-enabled Web browser.

Yes. Connect the AUATC to the Paragon switch, and connect the AUATC
(DB-25-Male connector) to the Dominion SX (DB9-Male connector) using a
DB25-female to DB9-female cable. Then Enable the local port access (LPA)
feature on the Dominion SX; ensuring that the communication parameters
(baud rate, parity, etc.) matches between the AUATC and the Dominion SX.

Local database, RADIUS, LDAP/S, TACACS+, Active Directory, and
Kerberos V5.

Local database, RADIUS, LDAP/S, TACACS+, Active Directory, Kerberos
V5. Optionally, local authentication can be Disabled.
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Chapter 15: Frequently Asked Questions

Questions Answers

How do | enable Direct Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Port Access with a

Dominion SX unit running
SX3.1+ firmware? The following are main steps:

Attached is a sample run for DPA configuration from CLI.

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Can the Dominion SX Yes. Dominion SX can support Authorization at a per port level — via Local
support Authorization at a database, RADIUS, LDAP/S, TACACS+, Active Directory, Kerberos V5.
per port level?

Does Dominion SX Yes. Dominion SX supports SNMP traps via the Raritan Enterprise MIB.
support SNMP? SNMPv2 and v3 are supported.
Does Dominion SX Yes. Dominion SX supports syslog — to primary and secondary servers.

support syslog

Can | log every keystroke Yes. Dominion SX supports logging over NFS. Beginning with Release 3.0,
of a session (input from the session can be optionally encrypted with a used-defined key.

user and response from a

server/device) with a

server?
Does Dominion SX Yes. Dominion SX supports enabling of the telnet daemon on the Dominion
support telnet? SX unit. Because telnet sends all information "in the clear”, enabling telnet is

at the customers own discretion, and telnet is disabled by default when the
unit ships from the factory. Raritan strongly suggests the use of SSH as a
safer alternative to telnet, since all data is encrypted, including the login
sequence.

Can | send an intentional  Yes.
"break" signal to the SUN
Solaris server when using
SSH?

Can | send an intentional  Yes.
"break" signal to the SUN
Solaris server when using

a Web browser?
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Questions Answers

How do | enable Direct Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Port Access with a

Dominion SX unit running
SX3.1+ firmware? The following are main steps:

Attached is a sample run for DPA configuration from CLI.

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Can | send an intentional  Yes.
"break" signal to the SUN
Solaris server when using
telnet?

Can | get the buffered Yes.
off-line data from a serial
port when using SSH?

Can | get the buffered Yes.
off-line data from a serial
port when using telnet?

Can | get the buffered Yes.
off-line data from a serial

port when using a
Java-enabled

web-browser?

Does Dominion SX Yes. Dominion SX supports local port access. Feature is disabled by default
support local (direct) port from the factory. Default parameters are 9600-N-8-1. The local port on the
access for "crash-cart” Dominion SX 4/8/16/32 is a DB9-Male.

ggﬁlgcritlons in a data 2. The local port on the Dominion SX 48 port models with a modem is RJ45

Female. For models with two local ports (models without a modem), the 2™
local port is DB9-Male.
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Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

What are the pin-outs of
the Dominion SX RJ45
serial ports?

How do | install Java?

Is the status of the unit
limited by the status of
the device or equipment
to which it is attached
(that is, Server, router,
firewall, load balancer, or
other network device)?

Can | reset the unit
without losing my
settings?
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Chapter 15: Frequently Asked Questions

Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Dominion SX Serial Pin-outs

The RJ45 connector on the rear of the unit has the following pinout:
RJ45 PIN [SIGNAL
RTS

DTR

TxD

GND
Signal GND
RxD

DSR

CTS

OlIN|oOOjOa| B[O IN]E

See the Standalone Raritan Serial Console section of Chapter 5: Port
Configuration and Port Access Application of the Dominion SX User Guide.

No, because the unit is a totally "out of band" solution that runs on its own
dedicated microprocessor.

Even if the target devices to which the Dominion SX is attached are turned
off, you will still be able to access the unit.

Click Maintenance > Reboot to reset the system.
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Questions Answers

How do | enable Direct Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Port Access with a

Dominion SX unit running
SX3.1+ firmware? The following are main steps:

Attached is a sample run for DPA configuration from CLI.

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

How do | reset the unit Performing a factory Reset returns the Dominion SX unit to its default factory

back to its factory-default ' settings. Be very careful when doing this, because it will erase all the data

settings? and settings on the Dominion SX unit and return it to the state in which it was
originally shipped.

To perform a factory reset, choose Maintenance > Factory Reset.

Does the unit need to be  No, setup can be performed via the SX's LPA port with a straight serial
on the same physical connection.

LAN as the client_host

during installation and

setup?

Once the physical Open a supported network-enabled web browser, type "192.168.0.192" in
installation is complete the address line, and press the <Enter> key.

and my ping query elicits
a response from the unit,
how do I initially access
the unit and begin to Once setup is complete, log off the console, and use the
customize the unit? IP address you assigned during set-up to re-access the unit.

The system displays the start-up screen for the unit, and prompts you
through the entire set-up process.

Once | have assigned the Open your supported Web browser,
unit a unique IP address,
how do | access the unit
in the future? Press the <Enter> key. The login/password screen for the unit will appear.

Type the IP address you have assigned to that unit into the Address field

Can | assign specific port ' Yes, but only if the user is NOT an Administrator. The Administrator will
access to a specific user? always have access to all the ports.
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Questions

How do | enable Direct
Port Access with a
Dominion SX unit running
SX3.1+ firmware?

| performed maintenance
on my NFS server, which
affected my Dominion SX
port logging. | had port
logging enabled , but |
could not access any port
on the DSX.

Sometimes when | try to
log on, | see a message
that states my "login is
incorrect" even though |
am sure | am entering the
correct User Name and
Password. Why is this?

What should | do if the
browser returns with the
message that the device
timed out?

How do | upgrade the
Dominion SX software?
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Answers
Enabling Direct Port Access (DPA) from the CLI in Dominion SX.

Attached is a sample run for DPA configuration from CLI.
The following are main steps:
1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

This is a designed feature. The idea of NFS port logging is to avoid missing
anything on the ports.

Disable port logging when performing maintenance on the NFS server.

This is a security feature.

There is a session-specific ID that is sent out each time you login to the unit.
This ID has a time-out feature. If you do not login to the unit before the
time-out occurs, then the session ID becomes invalid.

Performing a <Shift-Reload> refreshes the page from the unit, and not from
the now-expired cache. Similarly, you may close the current browser, open a
new browser, and login again. This provides an additional security feature so
that no one can recall information stored in the cache to access the unit.

Try reloading using <Shift-Reload>. If this does not work, check your
network connections and network status.

You may also want to ping the console or perform a route print (as described
in other FAQS) to ensure that proper network communication is occurring.

If a web page does not load to your browser, there are probably network
difficulties that are preventing the page from loading.

Click Maintenance > Firmware Upgrade and fill in the parameters.
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Questions Answers

How do | enable Direct Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Port Access with a

Dominion SX unit running
SX3.1+ firmware? The following are main steps:

Attached is a sample run for DPA configuration from CLI.

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

4. Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

What if | forget or lose my Any Administrator can assign any user (Administrator, Operator, or
password? Observer) a new password if it is forgotten or lost.

Important: If there is only one Administrator, and he/she forgets his/her
password, then the unit must be factory-reset and re-configured from
the initial set-up screen. All saved values will be lost.

Is there any way for me to To improve the performance of Microsoft Internet Explorer when accessing
optimize the performance the console:

of Microsoft Internet
Explorer if it is my
preferred Web browser? 2. Scroll through the list until you see the following items and disable them.

1. Select Tools®Internet Options®Advanced from the main menu.

3. JIT compiler for virtual machine enabled
4. Java logging enabled
5. Java console enabled

I am having trouble using It is likely that the browser you are using does not support 128-bit SSL
the 128-bit SSL on the encryption. Depending on the version of browser installed on your
unit. Do you know what  workstation, you may need to do one of the following:

i i is?
might be causing this? Install a 128-bit SSL compatible version of your browser.
e Upgrade your current browser to be 128-bhit SSL compatible.

See the browser manufacturer’s web site for instructions.
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Chapter 15: Frequently Asked Questions

Questions Answers

How do | enable Direct Enabling Direct Port Access (DPA) from the CLI in Dominion SX.
Port Access with a

Dominion SX unit running
SX3.1+ firmware? The following are main steps:

Attached is a sample run for DPA configuration from CLI.

1. Configure DPA mode from Configuration->Services.

2. Configure which port need DPA and type of DPA (Telnet-TCP,
SSH-TCP, IP ADDR) from Configuration->ports

Reboot SX

Reapply Configuration-Services settings, for SSH, Telnet to take effect
of DPA settings.

5. Reboot SX
DPA should be functional on 2™ reboot

Sometimes when | am In this case, "a few minutes" is the key:
trying to dial-in to the unit
or when | am connected

to the unit via the modem
and | lose my connection.

The modem has a pre-defined "clean up time" after every connection ends —
it does not matter whether the connection is dropped, severed, or
intentionally closed by the user.

The modem will take about one minute to re-cycle itself to be ready for the

If I immmediately try to next incoming call.

dial-in again, | can’t get
connected.

However, if | wait for a
few minutes, the dial-in is
successful. Why is this?

What's the MTBF for 131,566 Hours. Keep in mind that the life of a SX depends on the
Dominion SX? environment factors such as temperatures, humidity, variation in power and
other factors

How do | select the Open RSC - Emulator - Setting - Display - Language. SX 3.1 RSC can
language and how many  support four languages: English, Japanese, Korean and Chinese
languages that RSC can

support?

Does the SX support a Yes, SX supports the industry standard 2048 bit hash key length.
2048 bit hash key length?
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